Deag.Vdx

VDX Framework

Deag.Vdx Namespace

The extensive application development framework for the simple development of Microsoft Visual Studio.NET database applications.

Enumerations

Enumeration | Description
VdxAssembly | Defines all avaiable VDX assemblies.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


VdxAssembly Enumeration

Defines all avaiable VDX assemblies.

public enum VdxAssembly

Members

Member Name | Description
vdxCommon | Library of classes used in the client application and the middle tier.
vdxControls | Library of Classes to develop client applications.
vdxServer | Library of classes used in the database access layer and in the web services.

Requirements

Namespace: Deag.Vdx

Assembly: vdxCommon (in vdxCommon.dll)

See Also

Deag.Vdx Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Common

VDX Framework

Deag.Vdx.Common Namespace

Library of classes used in the client application and the middle tier. The most classes are used for the error handling purpose.

Classes

Class | Description
vdxDebug | Traces error messages if application is running in debug mode.
vdxExceptionHandler | Default ExceptionHandler.
vdxSearchParameter | Handles a single search parameter.
vdxSearchParameters | Collects different vdxSearchParameter objects in a Hashtable.
vdxStatics | Pool of static methods.
vdxTrace | Traces error messages with time stamp and trace level.
vdxUtility | Summary description for Utility.

Interfaces

Interface | Description
IvdxExceptionHandler | Provides functionality required by all exception handlers. vdxExceptionHandler is the default implementation of IvdxExceptionHandler and serves to handle Exceptions at Runtime.
IvdxExceptionHandlerForm | Provides functionality required by all exception handler forms.

Structures

Structure | Description
ExceptionTextCaption | Internal used Struct to hold the Severety, the Text and Caption for each Exception.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ExceptionTextCaption Structure

Internal used Struct to hold the Severety, the Text and Caption for each Exception.

For a list of all members of this type, see ExceptionTextCaption Members.

System.Object
ValueType
ExceptionTextCaption

public struct ExceptionTextCaption

Requirements

Namespace: Deag.Vdx.Common

Assembly: vdxCommon (in vdxCommon.dll)

See Also

ExceptionTextCaption Members | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ExceptionTextCaption Members

ExceptionTextCaption overview

Public Instance Fields

Caption | Holds the exception caption.
Severity | Holds the exception error severety.
Text | Holds the exception message.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExceptionTextCaption Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ExceptionTextCaption Fields

The fields of the ExceptionTextCaption structure are listed below. For a complete list of ExceptionTextCaption structure members, see the ExceptionTextCaption Members topic.

Public Instance Fields

Caption | Holds the exception caption.
Severity | Holds the exception error severety.
Text | Holds the exception message.

See Also

ExceptionTextCaption Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ExceptionTextCaption.Caption Field

Holds the exception caption.

public string Caption;

See Also

ExceptionTextCaption Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ExceptionTextCaption.Severity Field

Holds the exception error severety.

public int Severity;

See Also

ExceptionTextCaption Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ExceptionTextCaption.Text Field

Holds the exception message.

public string Text;

See Also

ExceptionTextCaption Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler Interface

Provides functionality required by all exception handlers. vdxExceptionHandler is the default implementation of IvdxExceptionHandler and serves to handle Exceptions at Runtime.

For a list of all members of this type, see IvdxExceptionHandler Members.

public interface IvdxExceptionHandler

Remarks

An exception handler must be configured in the app.config file or by setting each parameter. With the correct configuration it should deserialize the existent vdxException types of a XML-file into the vdxExceptionTexts DataSet. Afterwords the handler can handle the exception ID and return the corresponding text and caption.

Requirements

Namespace: Deag.Vdx.Common

Assembly: vdxCommon (in vdxCommon.dll)

See Also

IvdxExceptionHandler Members | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler Members

IvdxExceptionHandler overview

Public Instance Properties

ClientExceptionHandlerForm | Gets or sets the client exception handler form.
ClientExceptionHandlerFormUnhandled | Gets or sets the client unhandled exception handler form.
MailExceptionsTo | This is the Mail-Address where unhandled exceptions have to be mailed to.
VdxDefaultLanguage | Gets or sets the currently selected DefaultLanguage of exception messages.
VdxUserLanguage | Gets or sets the currently selected UserLanguage of exception messages. This language will override the DefaultLanguage.

Public Instance Methods

Application_ThreadException | Attach a handler to this method if the Framework should handle unhandled exceptions
ConvertSeverity | Helper function to convert the Severity from int to vdxErrorSeverity
GetLocalizedDialogText | Helper-Function to set the culture-dependent button-texts
GetLocalizedForeignKeyException | Returns a vdxForeignKeyException from a ConstraintName
GetLocalizedNullException | Returns a vdxNullException from a ConstraintName
GetLocalizedNumericOverflowException | Returns a vdxNumericOverflowException from a ConstraintName
GetLocalizedPrimaryKeyException | Returns a vdxPrimaryKeyException from a ConstraintName
GetLocalizedTextes | Gets the Texts in the UserCulture
GetLocalizedTruncationException | Returns a vdxTruncationException from a ConstraintName
GetLocalizedUniqueException | Returns a vdxUniqueException from a ConstraintName
InitSettings | Sets the default values.
InitSettingsFromConfig | Sets the default settings found in your app.config.
LoadCustomMessages | Use this function if you already have an instance of the application's ExceptionTexts-DataSet
LoadVdxMessages | This will Load the Messages based on the settings in the app.config or upon the values you set
VdxHandleException | Overloaded. Handles the Unhandled Exceptions

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler Properties

The properties of the IvdxExceptionHandler interface are listed below. For a complete list of IvdxExceptionHandler interface members, see the IvdxExceptionHandler Members topic.

Public Instance Properties

ClientExceptionHandlerForm | Gets or sets the client exception handler form.
ClientExceptionHandlerFormUnhandled | Gets or sets the client unhandled exception handler form.
MailExceptionsTo | This is the Mail-Address where unhandled exceptions have to be mailed to.
VdxDefaultLanguage | Gets or sets the currently selected DefaultLanguage of exception messages.
VdxUserLanguage | Gets or sets the currently selected UserLanguage of exception messages. This language will override the DefaultLanguage.

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.ClientExceptionHandlerForm Property

Gets or sets the client exception handler form.

IvdxExceptionHandlerForm ClientExceptionHandlerForm {get; set;}

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.ClientExceptionHandlerFormUnhandled Property

Gets or sets the client unhandled exception handler form.

IvdxExceptionHandlerForm ClientExceptionHandlerFormUnhandled {get; set;}

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.MailExceptionsTo Property

This is the Mail-Address where unhandled exceptions have to be mailed to.

string MailExceptionsTo {get; set;}

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.VdxDefaultLanguage Property

Gets or sets the currently selected DefaultLanguage of exception messages.

System.Globalization.CultureInfo VdxDefaultLanguage {get; set;}

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.VdxUserLanguage Property

Gets or sets the currently selected UserLanguage of exception messages. This language will override the DefaultLanguage.

System.Globalization.CultureInfo VdxUserLanguage {get; set;}

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler Methods

The methods of the IvdxExceptionHandler interface are listed below. For a complete list of IvdxExceptionHandler interface members, see the IvdxExceptionHandler Members topic.

Public Instance Methods

Application_ThreadException | Attach a handler to this method if the Framework should handle unhandled exceptions
ConvertSeverity | Helper function to convert the Severity from int to vdxErrorSeverity
GetLocalizedDialogText | Helper-Function to set the culture-dependent button-texts
GetLocalizedForeignKeyException | Returns a vdxForeignKeyException from a ConstraintName
GetLocalizedNullException | Returns a vdxNullException from a ConstraintName
GetLocalizedNumericOverflowException | Returns a vdxNumericOverflowException from a ConstraintName
GetLocalizedPrimaryKeyException | Returns a vdxPrimaryKeyException from a ConstraintName
GetLocalizedTextes | Gets the Texts in the UserCulture
GetLocalizedTruncationException | Returns a vdxTruncationException from a ConstraintName
GetLocalizedUniqueException | Returns a vdxUniqueException from a ConstraintName
InitSettings | Sets the default values.
InitSettingsFromConfig | Sets the default settings found in your app.config.
LoadCustomMessages | Use this function if you already have an instance of the application's ExceptionTexts-DataSet
LoadVdxMessages | This will Load the Messages based on the settings in the app.config or upon the values you set
VdxHandleException | Overloaded. Handles the Unhandled Exceptions

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.Application_ThreadException Method

Attach a handler to this method if the Framework should handle unhandled exceptions

void Application_ThreadException(
object sender,
ThreadExceptionEventArgs e
);

Parameters

sender
Sender
e
ThreadExceptionEventArgs

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.ConvertSeverity Method

Helper function to convert the Severity from int to vdxErrorSeverity

vdxErrorSeverity ConvertSeverity(
int severity
);

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.GetLocalizedDialogText Method

Helper-Function to set the culture-dependent button-texts

string GetLocalizedDialogText(
string contextKey
);

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.GetLocalizedForeignKeyException Method

Returns a vdxForeignKeyException from a ConstraintName

vdxForeignKeyException GetLocalizedForeignKeyException(
string constraintName
);

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.GetLocalizedNullException Method

Returns a vdxNullException from a ConstraintName

vdxNullException GetLocalizedNullException(
string constraintName
);

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.GetLocalizedNumericOverflowException Method

Returns a vdxNumericOverflowException from a ConstraintName

vdxNumericOverflowException GetLocalizedNumericOverflowException(
string constraintName
);

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.GetLocalizedPrimaryKeyException Method

Returns a vdxPrimaryKeyException from a ConstraintName

vdxPrimaryKeyException GetLocalizedPrimaryKeyException(
string constraintName
);

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.GetLocalizedTextes Method

Gets the Texts in the UserCulture

ExceptionTextCaption GetLocalizedTextes(
int exceptionId
);

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.GetLocalizedTruncationException Method

Returns a vdxTruncationException from a ConstraintName

vdxTruncationException GetLocalizedTruncationException(
string constraintName
);

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.GetLocalizedUniqueException Method

Returns a vdxUniqueException from a ConstraintName

vdxUniqueException GetLocalizedUniqueException(
string constraintName
);

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.InitSettings Method

Sets the default values.

void InitSettings(
string exceptionDefaultLanguage,
string exceptionUserLanguage,
string vdxExceptionXmlRessource,
string applicationExceptionsAssemblyName,
string applicationExceptionsXmlRessource,
string exceptionMailTo
);

Parameters

exceptionDefaultLanguage
Default language to load VDX-Exceptions textes if configured in the specified language. If the value is null or empty the default language is set to "en-US".
exceptionUserLanguage
User language to load VDX-Exceptions textes. If configured in the specified language, the default language text will be overridden. If the value is null or empty the user language is set to "en-US".
vdxExceptionXmlRessource
The full name of the vdxExceptionTexts-XML-File. If the value is null or empty the ressource name is set to "Deag.Vdx.Common.ErrorTextes.vdxExceptionTexts.xml".
applicationExceptionsAssemblyName
The name of the application specific Common-DLL that contains the applicationExceptionsXmlRessource. Example: "MyApplicationShared"
applicationExceptionsXmlRessource
The full name of the application error text XML-File. Example: "MyApplicationShared.ApplicationTexts.xml"
exceptionMailTo
The e-mail address to send exception occured in the application. Example: "support@myCompany.com"

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.InitSettingsFromConfig Method

Sets the default settings found in your app.config.

void InitSettingsFromConfig();

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.LoadCustomMessages Method

Use this function if you already have an instance of the application's ExceptionTexts-DataSet

void LoadCustomMessages(
vdxExceptionTexts ds
);

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.LoadVdxMessages Method

This will Load the Messages based on the settings in the app.config or upon the values you set

void LoadVdxMessages();

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


VdxHandleException Method

VDX Framework

IvdxExceptionHandler.VdxHandleException Method

Handles the Exception

Overload List

Handles the Exception

void VdxHandleException(Exception);

Handles the Unhandled Exceptions

void VdxHandleException(Exception,string);

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.VdxHandleException Method (Exception)

Handles the Exception

void VdxHandleException(
Exception ex
);

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace | IvdxExceptionHandler.VdxHandleException Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.VdxHandleException Method (Exception, String)

Handles the Unhandled Exceptions

void VdxHandleException(
Exception ex,
string context
);

See Also

IvdxExceptionHandler Interface | Deag.Vdx.Common Namespace | IvdxExceptionHandler.VdxHandleException Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandlerForm Interface

Provides functionality required by all exception handler forms.

For a list of all members of this type, see IvdxExceptionHandlerForm Members.

public interface IvdxExceptionHandlerForm

Remarks

The dialog must be configured with a specified language, severity, e-mail address, message and if the exit is disabled. With ShowDialog the form will be displayed.

Requirements

Namespace: Deag.Vdx.Common

Assembly: vdxCommon (in vdxCommon.dll)

See Also

IvdxExceptionHandlerForm Members | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandlerForm Members

IvdxExceptionHandlerForm overview

Public Instance Properties

EmailTo Gets or sets the mail address to send error message.

Public Instance Methods

DeactivateExitButton | Disables the exit button.
SetLanguage | Sets the language on the dialog for the child controls.
SetMessage | Sets the message with the given title and message.
SetSeverity | Sets the vdxErrorSeverity of the dialog.
ShowDialog | Shows the exception dialog.

See Also

IvdxExceptionHandlerForm Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandlerForm Properties

The properties of the IvdxExceptionHandlerForm interface are listed below. For a complete list of IvdxExceptionHandlerForm interface members, see the IvdxExceptionHandlerForm Members topic.

Public Instance Properties

EmailTo Gets or sets the mail address to send error message.

See Also

IvdxExceptionHandlerForm Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandlerForm.EmailTo Property

Gets or sets the mail address to send error message.

string EmailTo {get; set;}

See Also

IvdxExceptionHandlerForm Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandlerForm Methods

The methods of the IvdxExceptionHandlerForm interface are listed below. For a complete list of IvdxExceptionHandlerForm interface members, see the IvdxExceptionHandlerForm Members topic.

Public Instance Methods

DeactivateExitButton | Disables the exit button.
SetLanguage | Sets the language on the dialog for the child controls.
SetMessage | Sets the message with the given title and message.
SetSeverity | Sets the vdxErrorSeverity of the dialog.
ShowDialog | Shows the exception dialog.

See Also

IvdxExceptionHandlerForm Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandlerForm.DeactivateExitButton Method

Disables the exit button.

void DeactivateExitButton();

See Also

IvdxExceptionHandlerForm Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandlerForm.SetLanguage Method

Sets the language on the dialog for the child controls.

void SetLanguage(
CultureInfo cultureInfo
);

Parameters

cultureInfo

See Also

IvdxExceptionHandlerForm Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandlerForm.SetMessage Method

Sets the message with the given title and message.

void SetMessage(
string caption,
string message
);

Parameters

caption
The title of the dialog.
message
The message displayed on the dialog.

See Also

IvdxExceptionHandlerForm Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandlerForm.SetSeverity Method

Sets the vdxErrorSeverity of the dialog.

void SetSeverity(
vdxErrorSeverity severity
);

Parameters

severity
The severity for the dialog.

Remarks

Depending on the severity the controls will be displayed or hidden.

See Also

IvdxExceptionHandlerForm Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandlerForm.ShowDialog Method

Shows the exception dialog.

void ShowDialog();

See Also

IvdxExceptionHandlerForm Interface | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDebug Class

Traces error messages if application is running in debug mode.

For a list of all members of this type, see vdxDebug Members.

System.Object
vdxDebug

public class vdxDebug

Requirements

Namespace: Deag.Vdx.Common

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxDebug Members | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDebug Members

vdxDebug overview

Public Static Methods

WriteLine Overloaded. Writes a message with Error and actual time into Debug.

Public Instance Constructors

vdxDebug Constructor Initializes a new instance of the vdxDebug class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxDebug Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDebug Constructor

Initializes a new instance of the vdxDebug class.

public vdxDebug();

See Also

vdxDebug Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDebug Methods

The methods of the vdxDebug class are listed below. For a complete list of vdxDebug class members, see the vdxDebug Members topic.

Public Static Methods

WriteLine Overloaded. Writes a message with Error and actual time into Debug.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxDebug Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WriteLine Method

VDX Framework

vdxDebug.WriteLine Method

Writes a message with trace level and actual time into Debug.

Overload List

Writes a message with trace level and actual time into Debug.

public static void WriteLine(vdxTraceSwitch,string);

Writes a message with Error and actual time into Debug.

public static void WriteLine(string);

See Also

vdxDebug Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDebug.WriteLine Method (vdxTraceSwitch, String)

Writes a message with trace level and actual time into Debug.

public static void WriteLine(
vdxTraceSwitch ts,
string message
);

Parameters

ts
message

See Also

vdxDebug Class | Deag.Vdx.Common Namespace | vdxDebug.WriteLine Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDebug.WriteLine Method (String)

Writes a message with Error and actual time into Debug.

public static void WriteLine(
string message
);

Parameters

message

See Also

vdxDebug Class | Deag.Vdx.Common Namespace | vdxDebug.WriteLine Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler Class

Default ExceptionHandler.

For a list of all members of this type, see vdxExceptionHandler Members.

System.Object
vdxExceptionHandler

public class vdxExceptionHandler : IvdxExceptionHandler

Requirements

Namespace: Deag.Vdx.Common

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionHandler Members | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler Members

vdxExceptionHandler overview

Public Instance Constructors

vdxExceptionHandler Constructor Initializes a new instance of the vdxExceptionHandler class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

strApplicationAssemblyName | String representation of the Assembly which holds the Xml-ExceptionFile' used during app.config - read
strApplicationRessource | String representation of the Xml-ExceptionFile's RessourceName used during app.config - read
strDefaultLanguage | String representation of the DefaultLanguage used during app.config - read
strUserLanguage | String representation of the UserLanguage used during app.config - read
strVdxRessource | String representation of the Xml-ExceptionFile's RessourceName used during app.config - read

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Private Instance Properties

Deag.Vdx.Common.IvdxExceptionHandler.ClientExceptionHandlerForm
Deag.Vdx.Common.IvdxExceptionHandler.ClientExceptionHandlerFormUnhandled
Deag.Vdx.Common.IvdxExceptionHandler.MailExceptionsTo
Deag.Vdx.Common.IvdxExceptionHandler.VdxDefaultLanguage
Deag.Vdx.Common.IvdxExceptionHandler.VdxUserLanguage

Explicit Interface Implementations

IvdxExceptionHandler.Application_ThreadException | Attach a handler to this method if the Framework should handle unhandled exceptions
IvdxExceptionHandler.ConvertSeverity | Helper function to convert the Severity from int to vdxErrorSeverity
IvdxExceptionHandler.GetLocalizedDialogText | Gets the text used for the buttons on the UnhandledExceptionForm
IvdxExceptionHandler.GetLocalizedForeignKeyException | Returns a vdxForeignKeyException from a ConstraintName
IvdxExceptionHandler.GetLocalizedNullException | Returns a vdxNullException from a ConstraintName
IvdxExceptionHandler.GetLocalizedNumericOverflowException | Returns a vdxNumericOverflowException from a ConstraintName
IvdxExceptionHandler.GetLocalizedPrimaryKeyException | Returns a vdxPrimaryKeyException from a ConstraintName
IvdxExceptionHandler.GetLocalizedTextes | Returns the Texts for the exception in the userLanguage
IvdxExceptionHandler.GetLocalizedTruncationException | Returns a vdxTruncationException from a ConstraintName
IvdxExceptionHandler.GetLocalizedUniqueException | Returns a vdxUniqueException from a ConstraintName
IvdxExceptionHandler.InitSettings | Sets the default values.
IvdxExceptionHandler.InitSettingsFromConfig | Sets the default settings found in your app.config
IvdxExceptionHandler.LoadCustomMessages | This loads your Custom Messages from a DataSet
IvdxExceptionHandler.LoadVdxMessages | Call this Method whenever you need to Load the Messages - after setting the VdxDefaultLanguage and VdxUserLanguage - after re-setting the VdxDefaultLanguage or VdxUserLanguage This Method will clear all the Exceptions in the Memory and - Load the Exceptions for the VdxDefaultLanguage and then - Overload the VdxDefaultLanguage-Messages with the existing VdxUserLanguage-Messages After this call you need to Reload your CustomMessages by callin LoadCustomMessages
IvdxExceptionHandler.VdxHandleException | Overloaded. Handles the Unhandled Exceptions

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler Constructor

Initializes a new instance of the vdxExceptionHandler class.

public vdxExceptionHandler();

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler Fields

The fields of the vdxExceptionHandler class are listed below. For a complete list of vdxExceptionHandler class members, see the vdxExceptionHandler Members topic.

Protected Instance Fields

strApplicationAssemblyName | String representation of the Assembly which holds the Xml-ExceptionFile' used during app.config - read
strApplicationRessource | String representation of the Xml-ExceptionFile's RessourceName used during app.config - read
strDefaultLanguage | String representation of the DefaultLanguage used during app.config - read
strUserLanguage | String representation of the UserLanguage used during app.config - read
strVdxRessource | String representation of the Xml-ExceptionFile's RessourceName used during app.config - read

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.strApplicationAssemblyName Field

String representation of the Assembly which holds the Xml-ExceptionFile' used during app.config - read

protected string strApplicationAssemblyName;

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.strApplicationRessource Field

String representation of the Xml-ExceptionFile's RessourceName used during app.config - read

protected string strApplicationRessource;

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.strDefaultLanguage Field

String representation of the DefaultLanguage used during app.config - read

protected string strDefaultLanguage;

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.strUserLanguage Field

String representation of the UserLanguage used during app.config - read

protected string strUserLanguage;

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.strVdxRessource Field

String representation of the Xml-ExceptionFile's RessourceName used during app.config - read

protected string strVdxRessource;

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler Properties

The properties of the vdxExceptionHandler class are listed below. For a complete list of vdxExceptionHandler class members, see the vdxExceptionHandler Members topic.

Private Instance Properties

Deag.Vdx.Common.IvdxExceptionHandler.ClientExceptionHandlerForm
Deag.Vdx.Common.IvdxExceptionHandler.ClientExceptionHandlerFormUnhandled
Deag.Vdx.Common.IvdxExceptionHandler.MailExceptionsTo
Deag.Vdx.Common.IvdxExceptionHandler.VdxDefaultLanguage
Deag.Vdx.Common.IvdxExceptionHandler.VdxUserLanguage

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.Deag.Vdx.Common.IvdxExceptionHandler.ClientExceptionHandlerForm Property

private IvdxExceptionHandlerForm Deag.Vdx.Common.IvdxExceptionHandler.ClientExceptionHandlerForm {get; set;}

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.Deag.Vdx.Common.IvdxExceptionHandler.ClientExceptionHandlerFormUnhandled Property

private IvdxExceptionHandlerForm Deag.Vdx.Common.IvdxExceptionHandler.ClientExceptionHandlerFormUnhandled {get; set;}

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.Deag.Vdx.Common.IvdxExceptionHandler.MailExceptionsTo Property

private string Deag.Vdx.Common.IvdxExceptionHandler.MailExceptionsTo {get; set;}

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.Deag.Vdx.Common.IvdxExceptionHandler.VdxDefaultLanguage Property

private System.Globalization.CultureInfo Deag.Vdx.Common.IvdxExceptionHandler.VdxDefaultLanguage {get; set;}

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.Deag.Vdx.Common.IvdxExceptionHandler.VdxUserLanguage Property

private System.Globalization.CultureInfo Deag.Vdx.Common.IvdxExceptionHandler.VdxUserLanguage {get; set;}

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler Methods

The methods of the vdxExceptionHandler class are listed below. For a complete list of vdxExceptionHandler class members, see the vdxExceptionHandler Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

IvdxExceptionHandler.Application_ThreadException | Attach a handler to this method if the Framework should handle unhandled exceptions
IvdxExceptionHandler.ConvertSeverity | Helper function to convert the Severity from int to vdxErrorSeverity
IvdxExceptionHandler.GetLocalizedDialogText | Gets the text used for the buttons on the UnhandledExceptionForm
IvdxExceptionHandler.GetLocalizedForeignKeyException | Returns a vdxForeignKeyException from a ConstraintName
IvdxExceptionHandler.GetLocalizedNullException | Returns a vdxNullException from a ConstraintName
IvdxExceptionHandler.GetLocalizedNumericOverflowException | Returns a vdxNumericOverflowException from a ConstraintName
IvdxExceptionHandler.GetLocalizedPrimaryKeyException | Returns a vdxPrimaryKeyException from a ConstraintName
IvdxExceptionHandler.GetLocalizedTextes | Returns the Texts for the exception in the userLanguage
IvdxExceptionHandler.GetLocalizedTruncationException | Returns a vdxTruncationException from a ConstraintName
IvdxExceptionHandler.GetLocalizedUniqueException | Returns a vdxUniqueException from a ConstraintName
IvdxExceptionHandler.InitSettings | Sets the default values.
IvdxExceptionHandler.InitSettingsFromConfig | Sets the default settings found in your app.config
IvdxExceptionHandler.LoadCustomMessages | This loads your Custom Messages from a DataSet
IvdxExceptionHandler.LoadVdxMessages | Call this Method whenever you need to Load the Messages - after setting the VdxDefaultLanguage and VdxUserLanguage - after re-setting the VdxDefaultLanguage or VdxUserLanguage This Method will clear all the Exceptions in the Memory and - Load the Exceptions for the VdxDefaultLanguage and then - Overload the VdxDefaultLanguage-Messages with the existing VdxUserLanguage-Messages After this call you need to Reload your CustomMessages by callin LoadCustomMessages
IvdxExceptionHandler.VdxHandleException | Overloaded. Handles the Unhandled Exceptions

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.IvdxExceptionHandler.Application_ThreadException Method

Attach a handler to this method if the Framework should handle unhandled exceptions

void IvdxExceptionHandler.Application_ThreadException(
object sender,
ThreadExceptionEventArgs e
);

Parameters

sender
Sender
e
ThreadExceptionEventArgs

Implements

IvdxExceptionHandler.Application_ThreadException

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.IvdxExceptionHandler.ConvertSeverity Method

Helper function to convert the Severity from int to vdxErrorSeverity

vdxErrorSeverity IvdxExceptionHandler.ConvertSeverity(
int severity
);

Implements

IvdxExceptionHandler.ConvertSeverity

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.IvdxExceptionHandler.GetLocalizedDialogText Method

Gets the text used for the buttons on the UnhandledExceptionForm

string IvdxExceptionHandler.GetLocalizedDialogText(
string contextKey
);

Parameters

contextKey
Key in the collection

Return Value

the Text

Implements

IvdxExceptionHandler.GetLocalizedDialogText

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.IvdxExceptionHandler.GetLocalizedForeignKeyException Method

Returns a vdxForeignKeyException from a ConstraintName

vdxForeignKeyException IvdxExceptionHandler.GetLocalizedForeignKeyException(
string constraintName
);

Parameters

constraintName
ConstraintName which has to be defined in your Application's vdxExceptions.XML

Return Value

The Exception

Implements

IvdxExceptionHandler.GetLocalizedForeignKeyException

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.IvdxExceptionHandler.GetLocalizedNullException Method

Returns a vdxNullException from a ConstraintName

vdxNullException IvdxExceptionHandler.GetLocalizedNullException(
string constraintName
);

Parameters

constraintName
ConstraintName which has to be defined in your Application's vdxExceptions.XML

Return Value

The Exception

Implements

IvdxExceptionHandler.GetLocalizedNullException

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.IvdxExceptionHandler.GetLocalizedNumericOverflowException Method

Returns a vdxNumericOverflowException from a ConstraintName

vdxNumericOverflowException IvdxExceptionHandler.GetLocalizedNumericOverflowException(
string constraintName
);

Parameters

constraintName
ConstraintName which has to be defined in your Application's vdxExceptions.XML

Return Value

The Exception

Implements

IvdxExceptionHandler.GetLocalizedNumericOverflowException

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.IvdxExceptionHandler.GetLocalizedPrimaryKeyException Method

Returns a vdxPrimaryKeyException from a ConstraintName

vdxPrimaryKeyException IvdxExceptionHandler.GetLocalizedPrimaryKeyException(
string constraintName
);

Parameters

constraintName
ConstraintName which has to be defined in your Application's vdxExceptions.XML

Return Value

The Exception

Implements

IvdxExceptionHandler.GetLocalizedPrimaryKeyException

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.IvdxExceptionHandler.GetLocalizedTextes Method

Returns the Texts for the exception in the userLanguage

ExceptionTextCaption IvdxExceptionHandler.GetLocalizedTextes(
int exceptionId
);

Parameters

exceptionId
ExceptionID

Return Value

A Structure containing the Text / Caption / Severity for this Exception

Implements

IvdxExceptionHandler.GetLocalizedTextes

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.IvdxExceptionHandler.GetLocalizedTruncationException Method

Returns a vdxTruncationException from a ConstraintName

vdxTruncationException IvdxExceptionHandler.GetLocalizedTruncationException(
string constraintName
);

Parameters

constraintName
ConstraintName which has to be defined in your Application's vdxExceptions.XML

Return Value

The Exception

Implements

IvdxExceptionHandler.GetLocalizedTruncationException

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.IvdxExceptionHandler.GetLocalizedUniqueException Method

Returns a vdxUniqueException from a ConstraintName

vdxUniqueException IvdxExceptionHandler.GetLocalizedUniqueException(
string constraintName
);

Parameters

constraintName
ConstraintName which has to be defined in your Application's vdxExceptions.XML

Return Value

The Exception

Implements

IvdxExceptionHandler.GetLocalizedUniqueException

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.IvdxExceptionHandler.InitSettings Method

Sets the default values.

void IvdxExceptionHandler.InitSettings(
string exceptionDefaultLanguage,
string exceptionUserLanguage,
string vdxExceptionXmlRessource,
string applicationExceptionsAssemblyName,
string applicationExceptionsXmlRessource,
string exceptionMailTo
);

Parameters

exceptionDefaultLanguage
Default language to load VDX-Exceptions textes if configured in the specified language. If the value is null or empty the default language is set to "en-US".
exceptionUserLanguage
User language to load VDX-Exceptions textes. If configured in the specified language, the default language text will be overridden. If the value is null or empty the user language is set to "en-US".
vdxExceptionXmlRessource
The full name of the vdxExceptionTexts-XML-File. If the value is null or empty the ressource name is set to "Deag.Vdx.Common.ErrorTextes.vdxExceptionTexts.xml".
applicationExceptionsAssemblyName
The name of the application specific Common-DLL that contains the applicationExceptionsXmlRessource. Example: "MyApplicationShared"
applicationExceptionsXmlRessource
The full name of the application error text XML-File. Example: "MyApplicationShared.ApplicationTexts.xml"
exceptionMailTo
The e-mail address to send exception occured in the application. Example: "support@myCompany.com"

Implements

IvdxExceptionHandler.InitSettings

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.IvdxExceptionHandler.InitSettingsFromConfig Method

Sets the default settings found in your app.config

void IvdxExceptionHandler.InitSettingsFromConfig();

Implements

IvdxExceptionHandler.InitSettingsFromConfig

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.IvdxExceptionHandler.LoadCustomMessages Method

This loads your Custom Messages from a DataSet

void IvdxExceptionHandler.LoadCustomMessages(
vdxExceptionTexts ds
);

Parameters

ds

Implements

IvdxExceptionHandler.LoadCustomMessages

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.IvdxExceptionHandler.LoadVdxMessages Method

Call this Method whenever you need to Load the Messages - after setting the VdxDefaultLanguage and VdxUserLanguage - after re-setting the VdxDefaultLanguage or VdxUserLanguage This Method will clear all the Exceptions in the Memory and - Load the Exceptions for the VdxDefaultLanguage and then - Overload the VdxDefaultLanguage-Messages with the existing VdxUserLanguage-Messages After this call you need to Reload your CustomMessages by callin LoadCustomMessages

void IvdxExceptionHandler.LoadVdxMessages();

Implements

IvdxExceptionHandler.LoadVdxMessages

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxExceptionHandler.VdxHandleException Method

VDX Framework

vdxExceptionHandler.IvdxExceptionHandler.VdxHandleException Method

Handles the Exception

Overload List

Handles the Exception

private void IvdxExceptionHandler.VdxHandleException(Exception);

Handles the Unhandled Exceptions

private void IvdxExceptionHandler.VdxHandleException(Exception,string);

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.IvdxExceptionHandler.VdxHandleException Method (Exception)

Handles the Exception

void IvdxExceptionHandler.VdxHandleException(
Exception ex
);

Implements

IvdxExceptionHandler.VdxHandleException

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace | vdxExceptionHandler.IvdxExceptionHandler.VdxHandleException Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionHandler.IvdxExceptionHandler.VdxHandleException Method (Exception, String)

Handles the Unhandled Exceptions

void IvdxExceptionHandler.VdxHandleException(
Exception ex,
string context
);

Implements

IvdxExceptionHandler.VdxHandleException

See Also

vdxExceptionHandler Class | Deag.Vdx.Common Namespace | vdxExceptionHandler.IvdxExceptionHandler.VdxHandleException Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameter Class

Handles a single search parameter.

For a list of all members of this type, see vdxSearchParameter Members.

System.Object
vdxSearchParameter

public class vdxSearchParameter

Remarks

The search parameter class is used to store a single search name/value/type pair. Usually it gets used within the vdxSearchParameters class, where several search parameters get stored and passed from the client to the server.

Requirements

Namespace: Deag.Vdx.Common

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxSearchParameter Members | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameter Members

vdxSearchParameter overview

Public Instance Constructors

vdxSearchParameter Overloaded. Initializes a new instance of the vdxSearchParameter class.

Public Instance Properties

ParameterName | Gets or sets the name of the vdxSearchParameter object.
SearchType | Gets or sets the parametertype of the vdxSearchParameter object.
Value | Gets or sets the value of the vdxSearchParameter object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxSearchParameter Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameter Constructor

Initializes a new instance of the vdxSearchParameter class with the specified parameter name and value.

Overload List

Initializes a new instance of the vdxSearchParameter class with the specified parameter name and value.

public vdxSearchParameter(string,object);

Initializes a new instance of the vdxSearchParameter class with the specified parameter name, value and searchType.

public vdxSearchParameter(string,object,vdxSearchType);

See Also

vdxSearchParameter Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameter Constructor (String, Object)

Initializes a new instance of the vdxSearchParameter class with the specified parameter name and value.

public vdxSearchParameter(
string parameterName,
object value
);

Parameters

parameterName
The name of the parameter.
value
The value of the parameter.

Remarks

Be sure to pass the right type as value. If you want to pass a numeric string value, convert it to the right type.

Example

            int i = 21;
            string s = "34"
            // Search parameter must be string.
            vdxSearchParameter("myParam", i.ToString());
            // Search parameter must be int.
            vdxSearchParameter("myParam", int.Parse(s));

See Also

vdxSearchParameter Class | Deag.Vdx.Common Namespace | vdxSearchParameter Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameter Constructor (String, Object, vdxSearchType)

Initializes a new instance of the vdxSearchParameter class with the specified parameter name, value and searchType.

public vdxSearchParameter(
string parameterName,
object value,
vdxSearchType searchType
);

Parameters

parameterName
The name of the parameter.
value
The value of the parameter.
searchType
The specified type within the vdxSearchParamter object.

Remarks

Be sure to pass the right type as value. If you want to pass a numeric string value, convert it to the right type.

Example

            int i = 21;
            string s = "34"
            // Search parameter must be string.
            vdxSearchParameter("myParam", i.ToString());
            // Search parameter must be int.
            vdxSearchParameter("myParam", int.Parse(s));

See Also

vdxSearchParameter Class | Deag.Vdx.Common Namespace | vdxSearchParameter Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameter Properties

The properties of the vdxSearchParameter class are listed below. For a complete list of vdxSearchParameter class members, see the vdxSearchParameter Members topic.

Public Instance Properties

ParameterName | Gets or sets the name of the vdxSearchParameter object.
SearchType | Gets or sets the parametertype of the vdxSearchParameter object.
Value | Gets or sets the value of the vdxSearchParameter object.

See Also

vdxSearchParameter Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameter.ParameterName Property

Gets or sets the name of the vdxSearchParameter object.

public string ParameterName {get; set;}

Remarks

The name is used to identify the parameter.

See Also

vdxSearchParameter Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameter.SearchType Property

Gets or sets the parametertype of the vdxSearchParameter object.

public Enums.vdxSearchType SearchType {get; set;}

Remarks

The parametertypes are defined in the vdxSearchType enumeration.

See Also

vdxSearchParameter Class | Deag.Vdx.Common Namespace | vdxSearchType

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameter.Value Property

Gets or sets the value of the vdxSearchParameter object.

public object Value {get; set;}

See Also

vdxSearchParameter Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters Class

Collects different vdxSearchParameter objects in a Hashtable.

For a list of all members of this type, see vdxSearchParameters Members.

System.Object
Hashtable
vdxSearchParameters

public class vdxSearchParameters : Hashtable

Remarks

This class is used whenever you need to store or to serialize a combination of different vdxSearchParameter objects.

Example

The following code demonstrates the creation of a vdxSearchParameters object which stores three different vdxSearchParameter objects.

            vdxSearchParameters sp = new vdxSearchParameters("MySelectionScenario");
            sp.Add(new vdxSearchParameter("Company", this.txtCompany.Text, vdxSearchType.Equal));
            sp.Add(new vdxSearchParameter("ZipFrom", this.txtZipFrom.Text, vdxSearchType.LargerAs));
            sp.Add(new vdxSearchParameter("ZipTo", this.txtZipTo.Text, vdxSearchType.SmallerAs));
To serialize the search data, simply call the method GetParameters like this and directly pass it to your Webservice call:
            wsAddress = (wsAddressSoap)WebServiceProvider.GetWebService(typeof(wsAddressSoap());
            ds = wsAddress.GetDataSetAddressList(vdxSearchParameters.GetParameters());
On the the business layer, you receive the serialized object array and you can easily create the vdxSearchParameters object by passing this object array to the constructor like this and use the search data:
            public dsAddressList GetDataSetAddressList(object[] parameters)
            {
            ...
            // vdxSearchParameters deserialization
            vdxSearchParameters sp = new vdxSearchParameters(parameters);
            switch(sp.VdxSearchName)
            {
            case "MySelectionScenario":
                company = sp["Company"].Value.ToString();
                zipFrom = sp["ZipFrom"].Value.ToString();
                zipTo = sp["ZipTo"].Value.ToString();
                ...
                dal.Fillxy(ref dsRet, company, zipFrom, zipTo);
                ...
                break;
            ...
            }

Requirements

Namespace: Deag.Vdx.Common

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxSearchParameters Members | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters Members

vdxSearchParameters overview

Public Instance Constructors

vdxSearchParameters Overloaded. Initializes a new instance of the vdxSearchParameters class.

Public Instance Properties

Count (inherited from Hashtable) | Gets the number of key-and-value pairs contained in the Hashtable.
IsFixedSize (inherited from Hashtable) | Gets a value indicating whether the Hashtable has a fixed size.
IsReadOnly (inherited from Hashtable) | Gets a value indicating whether the Hashtable is read-only.
IsSynchronized (inherited from Hashtable) | Gets a value indicating whether access to the Hashtable is synchronized (thread-safe).
Item | Overloaded. Returns a vdxSearchParameter object by specifing the name.
Keys (inherited from Hashtable) | Gets an ICollection containing the keys in the Hashtable.
ParamString | Gets a parameter string representing the search data for each vdxSearchParameter as a single string.
SyncRoot (inherited from Hashtable) | Gets an object that can be used to synchronize access to the Hashtable.
Values (inherited from Hashtable) | Gets an ICollection containing the values in the Hashtable.
VdxSearchName | Gets or sets the search name of a vdxSearchParameters object.
VdxTag | Gets or sets the tag property.
VdxUsevdxLateBinding | Gets or sets whether to use vdxLateBinding or not.

Public Instance Methods

Add | Overloaded. Adds a vdxSearchParameter object to the Hashtable.
Clear (inherited from Hashtable) | Removes all elements from the Hashtable.
Clone (inherited from Hashtable) | Creates a shallow copy of the Hashtable.
Contains (inherited from Hashtable) | Determines whether the Hashtable contains a specific key.
ContainsKey (inherited from Hashtable) | Determines whether the Hashtable contains a specific key.
ContainsValue (inherited from Hashtable) | Determines whether the Hashtable contains a specific value.
CopyTo (inherited from Hashtable) | Copies the Hashtable elements to a one-dimensional Array instance at the specified index.
Equals | Overrides Equals.
GetEnumerator (inherited from Hashtable) | Returns an IDictionaryEnumerator that can iterate through the Hashtable.
GetHashCode | Overrides GetHashCode.
GetObjectData (inherited from Hashtable) | Implements the ISerializable interface and returns the data needed to serialize the Hashtable.
GetParameters | Overloaded. Returns all vdxSearchParameter in an object array.
GetType (inherited from Object) | Gets the Type of the current instance.
OnDeserialization (inherited from Hashtable) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from Hashtable) | Removes the element with the specified key from the Hashtable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

comparer (inherited from Hashtable) | Gets or sets the comparer to use for the Hashtable.
hcp (inherited from Hashtable) | Gets or sets the object that can dispense hash codes.

Protected Instance Methods

Add | Overloaded. Made HashTable.Add(object key, object value) protected. Use public Add-methods.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetHash (inherited from Hashtable) | Returns the hash code for the specified key.
KeyEquals (inherited from Hashtable) | Compares a specific Object with a specific key in the Hashtable.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

IEnumerable.GetEnumerator (inherited from Hashtable)

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters Constructor

Initializes a new instance of the vdxSearchParameters class.

Overload List

Initializes a new instance of the vdxSearchParameters class.

public vdxSearchParameters();

Initializes a new instance of the vdxSearchParameters class with the specified vdxSearchParameter objects.

public vdxSearchParameters(object[]);

Initializes a new instance of the vdxSearchParameters class with the specified search name.

public vdxSearchParameters(string);

Initializes a new instance of the vdxSearchParameters class with the specified search name.

public vdxSearchParameters(string,string);

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters Constructor ()

Initializes a new instance of the vdxSearchParameters class.

public vdxSearchParameters();

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace | vdxSearchParameters Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters Constructor (Object[])

Initializes a new instance of the vdxSearchParameters class with the specified vdxSearchParameter objects.

public vdxSearchParameters(
object[] parameters
);

Parameters

parameters
An array with vdxSearchParameter objects.

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace | vdxSearchParameters Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters Constructor (String)

Initializes a new instance of the vdxSearchParameters class with the specified search name.

public vdxSearchParameters(
string searchName
);

Parameters

searchName
The search name of the vdxSearchParameters object.

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace | vdxSearchParameters Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters Constructor (String, String)

Initializes a new instance of the vdxSearchParameters class with the specified search name.

public vdxSearchParameters(
string searchName,
string paramString
);

Parameters

searchName
The search name of the vdxSearchParameters object.
paramString
The vdxSearchParameters as string

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace | vdxSearchParameters Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters Properties

The properties of the vdxSearchParameters class are listed below. For a complete list of vdxSearchParameters class members, see the vdxSearchParameters Members topic.

Public Instance Properties

Count (inherited from Hashtable) | Gets the number of key-and-value pairs contained in the Hashtable.
IsFixedSize (inherited from Hashtable) | Gets a value indicating whether the Hashtable has a fixed size.
IsReadOnly (inherited from Hashtable) | Gets a value indicating whether the Hashtable is read-only.
IsSynchronized (inherited from Hashtable) | Gets a value indicating whether access to the Hashtable is synchronized (thread-safe).
Item | Overloaded. Returns a vdxSearchParameter object by specifing the name.
Keys (inherited from Hashtable) | Gets an ICollection containing the keys in the Hashtable.
ParamString | Gets a parameter string representing the search data for each vdxSearchParameter as a single string.
SyncRoot (inherited from Hashtable) | Gets an object that can be used to synchronize access to the Hashtable.
Values (inherited from Hashtable) | Gets an ICollection containing the values in the Hashtable.
VdxSearchName | Gets or sets the search name of a vdxSearchParameters object.
VdxTag | Gets or sets the tag property.
VdxUsevdxLateBinding | Gets or sets whether to use vdxLateBinding or not.

Protected Instance Properties

comparer (inherited from Hashtable) | Gets or sets the comparer to use for the Hashtable.
hcp (inherited from Hashtable) | Gets or sets the object that can dispense hash codes.

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters.Item Property

Returns a vdxSearchParameter object by specifing the name.

public vdxSearchParameter this[
string parameterName
] {get;}

Remarks

In C#, this property is the indexer for the vdxSearchParameters class

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters.ParamString Property

Gets a parameter string representing the search data for each vdxSearchParameter as a single string.

public string ParamString {get;}

Remarks

You can use this string if you need to store a complete vdxSearchParameters object. The string contains all information needed to recreate a new vdxSearchParameters object passing this string to the constructor.

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters.VdxSearchName Property

Gets or sets the search name of a vdxSearchParameters object.

public string VdxSearchName {get; set;}

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters.VdxTag Property

Gets or sets the tag property.

public string VdxTag {get; set;}

Remarks

Can be used for individual storage of any string information.

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters.VdxUsevdxLateBinding Property

Gets or sets whether to use vdxLateBinding or not.

public bool VdxUsevdxLateBinding {get; set;}

Remarks

If vdxUsevdxLateBinding ist set to true, a vdxSearchParameter object will be encapsulated in an object array when used with a GetParameters method. Leave this property false if you don't use vdxLateBinding explicitely.

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters Methods

The methods of the vdxSearchParameters class are listed below. For a complete list of vdxSearchParameters class members, see the vdxSearchParameters Members topic.

Public Instance Methods

Add | Overloaded. Adds a vdxSearchParameter object to the Hashtable.
Clear (inherited from Hashtable) | Removes all elements from the Hashtable.
Clone (inherited from Hashtable) | Creates a shallow copy of the Hashtable.
Contains (inherited from Hashtable) | Determines whether the Hashtable contains a specific key.
ContainsKey (inherited from Hashtable) | Determines whether the Hashtable contains a specific key.
ContainsValue (inherited from Hashtable) | Determines whether the Hashtable contains a specific value.
CopyTo (inherited from Hashtable) | Copies the Hashtable elements to a one-dimensional Array instance at the specified index.
Equals | Overrides Equals.
GetEnumerator (inherited from Hashtable) | Returns an IDictionaryEnumerator that can iterate through the Hashtable.
GetHashCode | Overrides GetHashCode.
GetObjectData (inherited from Hashtable) | Implements the ISerializable interface and returns the data needed to serialize the Hashtable.
GetParameters | Overloaded. Returns all vdxSearchParameter in an object array.
GetType (inherited from Object) | Gets the Type of the current instance.
OnDeserialization (inherited from Hashtable) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from Hashtable) | Removes the element with the specified key from the Hashtable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Add | Overloaded. Made HashTable.Add(object key, object value) protected. Use public Add-methods.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetHash (inherited from Hashtable) | Returns the hash code for the specified key.
KeyEquals (inherited from Hashtable) | Compares a specific Object with a specific key in the Hashtable.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

IEnumerable.GetEnumerator (inherited from Hashtable)

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Add Method

VDX Framework

vdxSearchParameters.Add Method

Adds a vdxSearchParameter object to the Hashtable.

Overload List

Adds a vdxSearchParameter object to the Hashtable.

public void Add(vdxSearchParameter);

Made HashTable.Add(object key, object value) protected. Use public Add-methods.

new protected void Add(object,object);

Adds a vdxSearchParameter object to the Hashtable for the given parameters.

public void Add(string,object);

Adds a vdxSearchParameter object to the Hashtable for the given parameters.

public void Add(string,object,vdxSearchType);

Adds a vdxSearchParameter object to the Hashtable for the given parameters if the test arguments does not math the value.

public void Add(string,object,vdxSearchType,params object[]);

Adds a vdxSearchParameter object to the Hashtable for the given parameters if the test arguments does not math the value.

public void Add(string,object,params object[]);

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters.Add Method (vdxSearchParameter)

Adds a vdxSearchParameter object to the Hashtable.

public void Add(
vdxSearchParameter sp
);

Parameters

sp
The vdxSearchParameter object.

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace | vdxSearchParameters.Add Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters.Add Method (Object, Object)

Made HashTable.Add(object key, object value) protected. Use public Add-methods.

new protected void Add(
object key,
object value
);

Parameters

key
value

Implements

IDictionary.Add

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace | vdxSearchParameters.Add Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters.Add Method (String, Object)

Adds a vdxSearchParameter object to the Hashtable for the given parameters.

public void Add(
string parameterName,
object value
);

Parameters

parameterName
The search parameter name.
value
The value to search for.

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace | vdxSearchParameters.Add Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters.Add Method (String, Object, vdxSearchType)

Adds a vdxSearchParameter object to the Hashtable for the given parameters.

public void Add(
string parameterName,
object value,
vdxSearchType searchType
);

Parameters

parameterName
The search parameter name.
value
The value to search for.
searchType
The search type for the search expression.

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace | vdxSearchParameters.Add Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters.Add Method (String, Object, vdxSearchType, Object[])

Adds a vdxSearchParameter object to the Hashtable for the given parameters if the test arguments does not math the value.

public void Add(
string parameterName,
object value,
vdxSearchType searchType,
params object[] testArguments
);

Parameters

parameterName
The search parameter name.
value
The value to search for.
searchType
The search type for the search expression.
testArguments
Test arguments to create an vdxSearchParameter object.

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace | vdxSearchParameters.Add Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters.Add Method (String, Object, Object[])

Adds a vdxSearchParameter object to the Hashtable for the given parameters if the test arguments does not math the value.

public void Add(
string parameterName,
object value,
params object[] testArguments
);

Parameters

parameterName
The search parameter name.
value
The value to search for.
testArguments
Test arguments to create an vdxSearchParameter object.

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace | vdxSearchParameters.Add Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters.Equals Method

Overrides Equals.

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters.GetHashCode Method

Overrides GetHashCode.

public override int GetHashCode();

Return Value

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


GetParameters Method

VDX Framework

vdxSearchParameters.GetParameters Method

Returns all vdxSearchParameter in an object array.

Overload List

Returns all vdxSearchParameter in an object array.

public object[] GetParameters();

Returns the vdxSearchParameters as an object[].

public object[] GetParameters(string);

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters.GetParameters Method ()

Returns all vdxSearchParameter in an object array.

public object[] GetParameters();

Return Value

An object array containing a vdxSearchParameter object as element.

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace | vdxSearchParameters.GetParameters Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParameters.GetParameters Method (String)

Returns the vdxSearchParameters as an object[].

public object[] GetParameters(
string searchName
);

Parameters

searchName
The name of the vdxSearchParameter object which will be serialized. The original SearchName will NOT change. This allows you to send the search data with another name to the server, if needed.

Return Value

An object array containing a vdxSearchParameter object as element.

See Also

vdxSearchParameters Class | Deag.Vdx.Common Namespace | vdxSearchParameters.GetParameters Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxStatics Class

Pool of static methods.

For a list of all members of this type, see vdxStatics Members.

System.Object
vdxStatics

public class vdxStatics

Requirements

Namespace: Deag.Vdx.Common

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxStatics Members | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxStatics Members

vdxStatics overview

Public Static Properties

VdxExceptionHandler Gets or sets the exception handler.

Public Instance Constructors

vdxStatics Constructor Initializes a new instance of the vdxStatics class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxStatics Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxStatics Constructor

Initializes a new instance of the vdxStatics class.

public vdxStatics();

See Also

vdxStatics Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxStatics Properties

The properties of the vdxStatics class are listed below. For a complete list of vdxStatics class members, see the vdxStatics Members topic.

Public Static Properties

VdxExceptionHandler Gets or sets the exception handler.

See Also

vdxStatics Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxStatics.VdxExceptionHandler Property

Gets or sets the exception handler.

public static IvdxExceptionHandler VdxExceptionHandler {get; set;}

See Also

vdxStatics Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTrace Class

Traces error messages with time stamp and trace level.

For a list of all members of this type, see vdxTrace Members.

System.Object
vdxTrace

public class vdxTrace

Requirements

Namespace: Deag.Vdx.Common

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxTrace Members | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTrace Members

vdxTrace overview

Public Static Methods

WriteLine Overloaded. Writes a message with Error and actual time into Trace.

Public Instance Constructors

vdxTrace Constructor Initializes a new instance of the vdxTrace class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxTrace Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTrace Constructor

Initializes a new instance of the vdxTrace class.

public vdxTrace();

See Also

vdxTrace Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTrace Methods

The methods of the vdxTrace class are listed below. For a complete list of vdxTrace class members, see the vdxTrace Members topic.

Public Static Methods

WriteLine Overloaded. Writes a message with Error and actual time into Trace.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxTrace Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WriteLine Method

VDX Framework

vdxTrace.WriteLine Method

Writes a message with trace level and actual time into Trace.

Overload List

Writes a message with trace level and actual time into Trace.

public static void WriteLine(vdxTraceSwitch,string);

Writes a message with trace level and actual time into Trace.

public static void WriteLine(vdxTraceSwitch,string,Exception);

Writes a message with Error and actual time into Trace.

public static void WriteLine(string);

Writes a message with trace level and actual time into Trace.

public static void WriteLine(string,Exception);

See Also

vdxTrace Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTrace.WriteLine Method (vdxTraceSwitch, String)

Writes a message with trace level and actual time into Trace.

public static void WriteLine(
vdxTraceSwitch ts,
string message
);

Parameters

ts
message

See Also

vdxTrace Class | Deag.Vdx.Common Namespace | vdxTrace.WriteLine Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTrace.WriteLine Method (vdxTraceSwitch, String, Exception)

Writes a message with trace level and actual time into Trace.

public static void WriteLine(
vdxTraceSwitch ts,
string message,
Exception e
);

Parameters

ts
message
e

See Also

vdxTrace Class | Deag.Vdx.Common Namespace | vdxTrace.WriteLine Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTrace.WriteLine Method (String)

Writes a message with Error and actual time into Trace.

public static void WriteLine(
string message
);

Parameters

message

See Also

vdxTrace Class | Deag.Vdx.Common Namespace | vdxTrace.WriteLine Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTrace.WriteLine Method (String, Exception)

Writes a message with trace level and actual time into Trace.

public static void WriteLine(
string message,
Exception e
);

See Also

vdxTrace Class | Deag.Vdx.Common Namespace | vdxTrace.WriteLine Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility Class

Summary description for Utility.

For a list of all members of this type, see vdxUtility Members.

System.Object
vdxUtility

public class vdxUtility

Requirements

Namespace: Deag.Vdx.Common

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxUtility Members | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility Members

vdxUtility overview

Public Static Methods

AddSeperator | Adds the seperator to the specified string and returnes the result. If the specified string is empty or null then it is returned (no spererator added)
AddString | Fügt einem String weitere Zeichen an.
BuildString | Builds a string out of a pool of sub strings and evaluating the maximal allowed length.
CompareTypedValues | Compare two objects by converting the "smaller" type to the "bigger" and comparing the typed values afterwards.
DataSetToFile | Serializes the given DataSet into the specified file.
DataSetToString | Serializes the specified table for the given DataSet string.
ExploreDataSetErrors | Gibt alle Fehler im DataSet als string zurück.
FindRowWithSameKey | Find in the destination table the DataRow with the primary keys of the source row.
GetTypedValues | Converts the values into the "bigger" type of v1 and v2
Merge | Overloaded. Merged das Dataset srcDs ins DataSet dstDs.
MergeDataRow | Merges the data of the sourceRow into the corresponding DataTable in the TargetDataSet. If the RowState of the sourceRow was DataRowState.Deleted, the corresponding target row would be deleted. In all other cases, the data of the target DataRow (if there is any) is updated or a new target row is added. The DataTable of the SourceRow and of the Target Row must have the same primarykey definitions. The constraints of the target DataSet are disabled during data copy. The readonly flag of a target column is ignored duriong data copy.
NvlBool | Converts the column value into a Boolean.
NvlDateTime | Converts the column value into a DateTime.
NvlInt | Converts the column value into a Int32.
NvlString | Overloaded. Converts the column value into a string.

Public Instance Constructors

vdxUtility Constructor Initializes a new instance of the vdxUtility class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxUtility Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility Constructor

Initializes a new instance of the vdxUtility class.

public vdxUtility();

See Also

vdxUtility Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility Methods

The methods of the vdxUtility class are listed below. For a complete list of vdxUtility class members, see the vdxUtility Members topic.

Public Static Methods

AddSeperator | Adds the seperator to the specified string and returnes the result. If the specified string is empty or null then it is returned (no spererator added)
AddString | Fügt einem String weitere Zeichen an.
BuildString | Builds a string out of a pool of sub strings and evaluating the maximal allowed length.
CompareTypedValues | Compare two objects by converting the "smaller" type to the "bigger" and comparing the typed values afterwards.
DataSetToFile | Serializes the given DataSet into the specified file.
DataSetToString | Serializes the specified table for the given DataSet string.
ExploreDataSetErrors | Gibt alle Fehler im DataSet als string zurück.
FindRowWithSameKey | Find in the destination table the DataRow with the primary keys of the source row.
GetTypedValues | Converts the values into the "bigger" type of v1 and v2
Merge | Overloaded. Merged das Dataset srcDs ins DataSet dstDs.
MergeDataRow | Merges the data of the sourceRow into the corresponding DataTable in the TargetDataSet. If the RowState of the sourceRow was DataRowState.Deleted, the corresponding target row would be deleted. In all other cases, the data of the target DataRow (if there is any) is updated or a new target row is added. The DataTable of the SourceRow and of the Target Row must have the same primarykey definitions. The constraints of the target DataSet are disabled during data copy. The readonly flag of a target column is ignored duriong data copy.
NvlBool | Converts the column value into a Boolean.
NvlDateTime | Converts the column value into a DateTime.
NvlInt | Converts the column value into a Int32.
NvlString | Overloaded. Converts the column value into a string.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxUtility Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.AddSeperator Method

Adds the seperator to the specified string and returnes the result. If the specified string is empty or null then it is returned (no spererator added)

public static string AddSeperator(
string str,
string seperator
);

Parameters

str
seperator

Return Value

See Also

vdxUtility Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.AddString Method

Fügt einem String weitere Zeichen an.

public static string AddString(
string old,
string toAdd,
string placeholder,
bool trim,
int substring,
int total
);

Parameters

old
alter Wert
toAdd
Wert der angefügt werden soll
placeholder
Wert der zwischen den alten und neuen Wert eingefügt werden soll
trim
Definiert, ob der anzufügende Wert getrimmt werden soll
substring
Definiert, wie viele Zeichen vom anzufügenden Wert angefügt werden sollen
total
Definiert, wie lang der zurückgebende Wert total sein darf

Return Value

kompletter String

See Also

vdxUtility Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.BuildString Method

Builds a string out of a pool of sub strings and evaluating the maximal allowed length.

public static string BuildString(
int maxLength,
params string[] values
);

Parameters

maxLength
values

Return Value

See Also

vdxUtility Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.CompareTypedValues Method

Compare two objects by converting the "smaller" type to the "bigger" and comparing the typed values afterwards.

public static bool CompareTypedValues(
object v1,
object v2
);

Parameters

v1
first value to convert
v2
second value to convert

Return Value

true if the values are equal

See Also

vdxUtility Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.DataSetToFile Method

Serializes the given DataSet into the specified file.

public static string DataSetToFile(
DataSet ds,
string fileName
);

Parameters

ds
fileName

Return Value

See Also

vdxUtility Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.DataSetToString Method

Serializes the specified table for the given DataSet string.

public static string DataSetToString(
DataSet ds,
string tableName
);

Parameters

ds
tableName

Return Value

See Also

vdxUtility Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.ExploreDataSetErrors Method

Gibt alle Fehler im DataSet als string zurück.

public static string ExploreDataSetErrors(
DataSet ds
);

Parameters

ds
DataSet mit Fehlern

Return Value

String Repräsentation der Fehler im DataSet

See Also

vdxUtility Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.FindRowWithSameKey Method

Find in the destination table the DataRow with the primary keys of the source row.

public static DataRow FindRowWithSameKey(
DataTable dstTable,
DataRow srcRow
);

Parameters

dstTable
srcRow

Return Value

See Also

vdxUtility Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.GetTypedValues Method

Converts the values into the "bigger" type of v1 and v2

public static void GetTypedValues(
object v1,
object v2,
out object tv1,
out object tv2
);

Parameters

v1
first value
v2
second value
tv1
converted v1
tv2
converted v2

Remarks

The types ar ordered by the following list:
enString  = 1000  (if one value is of type string, the other will be converted int string too)
Decimal = 100	  (if one value is a decima, the other value is converted into decimal too)
Double  = 99	  (ect)
Single  = 98
Date    = 97
TimeSpan= 96
UInt64  = 80
Int64   = 79
UInt32  = 78
Int32   = 77
UInt16  = 76
Int16   = 75
Byte    = 74
SByte   = 73
Char    = 72
Boole   = 71
Unknown = 0		  (if botrh types are unknowen, they are converted int string)

See Also

vdxUtility Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Merge Method

VDX Framework

vdxUtility.Merge Method

Merged das Dataset srcDs ins DataSet dstDs.

Overload List

Merged das Dataset srcDs ins DataSet dstDs.

public static void Merge(DataSet,DataSet,bool,bool,MissingSchemaAction);

Merged das Dataset srcDs ins DataSet dstDs.

public static void Merge(DataSet,DataSet,bool,bool,MissingSchemaAction,bool);

Merge eine einzelne DataRow in eine bestimmte Tabelle eines DataSets. Die Ziel Tabelle kann zuerst geleert werde (clearDstTable == true) --> Nach dem Merge sind in der dstTabelle nur die Daten der srcRow vorhanden, keine alten Werte.

public static void Merge(DataSet,string,DataRow,bool,bool,MissingSchemaAction);

Merge eine einzelne DataRow in eine bestimmte Tabelle eines DataSets. Die Ziel Tabelle kann zuerst geleert werde (clearDstTable == true) --> Nach dem Merge sind in der dstTabelle nur die Daten der srcRow vorhanden, keine alten Werte.

public static void Merge(DataSet,string,DataRow,bool,bool,MissingSchemaAction,bool);

Merged die Tabelle srcTable ins DataSet dstDs in die Tablle mit Namen dstTableName. Die Ziel Tabelle kann zuerst geleert werde (clearDstTable == true) --> Nach dem Merge sind in der dstTabelle nur die Daten der srcTabelle vorhanden, keine alten Werte.

public static void Merge(DataSet,string,DataTable,bool,bool,MissingSchemaAction);

Merged die Tabelle srcTable ins DataSet dstDs in die Tablle mit Namen dstTableName. Die Ziel Tabelle kann zuerst geleert werde (clearDstTable == true) --> Nach dem Merge sind in der dstTabelle nur die Daten der srcTabelle vorhanden, keine alten Werte.

public static void Merge(DataSet,string,DataTable,bool,bool,MissingSchemaAction,bool);

See Also

vdxUtility Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.Merge Method (DataSet, DataSet, Boolean, Boolean, MissingSchemaAction)

Merged das Dataset srcDs ins DataSet dstDs.

public static void Merge(
DataSet dstDs,
DataSet srcDs,
bool clearDstDs,
bool preserveChanges,
MissingSchemaAction missingSchemaAction
);

Parameters

dstDs
Ziel DS
srcDs
Source DS
clearDstDs
Ob Ziel DS vor dem Merge geleert werden soll
preserveChanges
wie im normalen Merge
missingSchemaAction
wie im normalen Merge

See Also

vdxUtility Class | Deag.Vdx.Common Namespace | vdxUtility.Merge Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.Merge Method (DataSet, DataSet, Boolean, Boolean, MissingSchemaAction, Boolean)

Merged das Dataset srcDs ins DataSet dstDs.

public static void Merge(
DataSet dstDs,
DataSet srcDs,
bool clearDstDs,
bool preserveChanges,
MissingSchemaAction missingSchemaAction,
bool throwError
);

Parameters

dstDs
Ziel DS
srcDs
Source DS
clearDstDs
Ob Ziel DS vor dem Merge geleert werden soll
preserveChanges
wie im normalen Merge
missingSchemaAction
wie im normalen Merge
throwError
Throws exception if error occurs

See Also

vdxUtility Class | Deag.Vdx.Common Namespace | vdxUtility.Merge Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.Merge Method (DataSet, String, DataRow, Boolean, Boolean, MissingSchemaAction)

Merge eine einzelne DataRow in eine bestimmte Tabelle eines DataSets. Die Ziel Tabelle kann zuerst geleert werde (clearDstTable == true) --> Nach dem Merge sind in der dstTabelle nur die Daten der srcRow vorhanden, keine alten Werte.

public static void Merge(
DataSet dstDs,
string dstTableName,
DataRow srcRow,
bool clearDstTable,
bool preserveChanges,
MissingSchemaAction missingSchemaAction
);

Parameters

dstDs
Ziel DataSet
dstTableName
Name der Tabelle in welche die Row gemerged werden soll
srcRow
Die zu mergende Row
clearDstTable
Ob die Ziel Tabelle zuerst geleert werden soll
preserveChanges
wie im normalen Merge
missingSchemaAction
wie im normalen Merge

See Also

vdxUtility Class | Deag.Vdx.Common Namespace | vdxUtility.Merge Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.Merge Method (DataSet, String, DataRow, Boolean, Boolean, MissingSchemaAction, Boolean)

Merge eine einzelne DataRow in eine bestimmte Tabelle eines DataSets. Die Ziel Tabelle kann zuerst geleert werde (clearDstTable == true) --> Nach dem Merge sind in der dstTabelle nur die Daten der srcRow vorhanden, keine alten Werte.

public static void Merge(
DataSet dstDs,
string dstTableName,
DataRow srcRow,
bool clearDstTable,
bool preserveChanges,
MissingSchemaAction missingSchemaAction,
bool throwError
);

Parameters

dstDs
Ziel DataSet
dstTableName
Name der Tabelle in welche die Row gemerged werden soll
srcRow
Die zu mergende Row
clearDstTable
Ob die Ziel Tabelle zuerst geleert werden soll
preserveChanges
wie im normalen Merge
missingSchemaAction
wie im normalen Merge
throwError
Throws error if one occurs

See Also

vdxUtility Class | Deag.Vdx.Common Namespace | vdxUtility.Merge Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.Merge Method (DataSet, String, DataTable, Boolean, Boolean, MissingSchemaAction)

Merged die Tabelle srcTable ins DataSet dstDs in die Tablle mit Namen dstTableName. Die Ziel Tabelle kann zuerst geleert werde (clearDstTable == true) --> Nach dem Merge sind in der dstTabelle nur die Daten der srcTabelle vorhanden, keine alten Werte.

public static void Merge(
DataSet dstDs,
string dstTableName,
DataTable srcTable,
bool clearDstTable,
bool preserveChanges,
MissingSchemaAction missingSchemaAction
);

Parameters

dstDs
Ziel DataSet in das gemerged wird
dstTableName
Name der Tabelle in welche gemerged wird
srcTable
Diese Tabelle wird ins DataSet gemerged
clearDstTable
Ob vor dem Merge die Zieltabelle geleert werden soll
preserveChanges
wie im normalen Merge
missingSchemaAction
wie im normalen Merge

See Also

vdxUtility Class | Deag.Vdx.Common Namespace | vdxUtility.Merge Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.Merge Method (DataSet, String, DataTable, Boolean, Boolean, MissingSchemaAction, Boolean)

Merged die Tabelle srcTable ins DataSet dstDs in die Tablle mit Namen dstTableName. Die Ziel Tabelle kann zuerst geleert werde (clearDstTable == true) --> Nach dem Merge sind in der dstTabelle nur die Daten der srcTabelle vorhanden, keine alten Werte.

public static void Merge(
DataSet dstDs,
string dstTableName,
DataTable srcTable,
bool clearDstTable,
bool preserveChanges,
MissingSchemaAction missingSchemaAction,
bool throwError
);

Parameters

dstDs
Ziel DataSet in das gemerged wird
dstTableName
Name der Tabelle in welche gemerged wird
srcTable
Diese Tabelle wird ins DataSet gemerged
clearDstTable
Ob vor dem Merge die Zieltabelle geleert werden soll
preserveChanges
wie im normalen Merge
missingSchemaAction
wie im normalen Merge
throwError
Throws exception if error occurs

See Also

vdxUtility Class | Deag.Vdx.Common Namespace | vdxUtility.Merge Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.MergeDataRow Method

Merges the data of the sourceRow into the corresponding DataTable in the TargetDataSet. If the RowState of the sourceRow was DataRowState.Deleted, the corresponding target row would be deleted. In all other cases, the data of the target DataRow (if there is any) is updated or a new target row is added. The DataTable of the SourceRow and of the Target Row must have the same primarykey definitions. The constraints of the target DataSet are disabled during data copy. The readonly flag of a target column is ignored duriong data copy.

public static DataRow MergeDataRow(
DataRow sourceRow,
DataSet TargetDataSet
);

Parameters

sourceRow
The source of the data to be merged
TargetDataSet
The DataSet with the target table

Return Value

The DataRow which have been merged or null

See Also

vdxUtility Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.NvlBool Method

Converts the column value into a Boolean.

public static bool NvlBool(
DataRow rw,
string col
);

Parameters

rw
The row which contains the column value.
col
The column name.

Return Value

The converted column value.

Remarks

Its returns false, if column value is DBNull.

See Also

vdxUtility Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.NvlDateTime Method

Converts the column value into a DateTime.

public static DateTime NvlDateTime(
DataRow rw,
string col
);

Parameters

rw
The row which contains the column value.
col
The column name.

Return Value

The converted column value.

Remarks

Its returns null, if column value is DBNull.

See Also

vdxUtility Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.NvlInt Method

Converts the column value into a Int32.

public static int NvlInt(
DataRow rw,
string col
);

Parameters

rw
The row which contains the column value.
col
The column name.

Return Value

The converted column value.

Remarks

Its returns 0, if column value is DBNull.

See Also

vdxUtility Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


NvlString Method

VDX Framework

vdxUtility.NvlString Method

Converts the column value into a string.

Overload List

Converts the column value into a string.

public static string NvlString(DataRow,string);

Converts the null value into an empty String.

public static string NvlString(string);

See Also

vdxUtility Class | Deag.Vdx.Common Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.NvlString Method (DataRow, String)

Converts the column value into a string.

public static string NvlString(
DataRow rw,
string col
);

Parameters

rw
The row which contains the column value.
col
The column name.

Return Value

The converted column value as string.

Remarks

Its returns an empty string, if column value is DBNull.

See Also

vdxUtility Class | Deag.Vdx.Common Namespace | vdxUtility.NvlString Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUtility.NvlString Method (String)

Converts the null value into an empty String.

public static string NvlString(
string obj
);

Parameters

obj

Return Value

The none null value.

See Also

vdxUtility Class | Deag.Vdx.Common Namespace | vdxUtility.NvlString Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Common.Enums

VDX Framework

Deag.Vdx.Common.Enums Namespace

Enumerations

Enumeration | Description
vdxDataLoadContext | Specifies the vdxDataLoadContext.
vdxDataStatus | Specifies the state of a vdxDataStatusManager.
vdxDataStatusManagerAction | Specifies the action of a vdxDataStatusManager.
vdxDataTreeNodeState | Specifies the state of the vdxTreeNode.
vdxDateFormat | Specifies the format of the date in a vdxDatePickField control.
vdxErrorSeverity | Specifies the error severity level.
vdxExplorerMode | Specifies the vdxExplorerMode.
vdxQuestion | Specifies the question type of the MessageBox.
vdxSearchType | Specifies the vdxSearchType.
vdxTraceSwitch | Specifies the trace switches.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataLoadContext Enumeration

Specifies the vdxDataLoadContext.

public enum vdxDataLoadContext

Members

Member Name | Description
Selection | Selection. Default case after search dialog has been used.
Detail | Detail. Detail data has to be fetched.
SubSelection | SubSelection. Subselection in tree (child nodes) has to be fetched.

Requirements

Namespace: Deag.Vdx.Common.Enums

Assembly: vdxCommon (in vdxCommon.dll)

See Also

Deag.Vdx.Common.Enums Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatus Enumeration

Specifies the state of a vdxDataStatusManager.

public enum vdxDataStatus

Members

Member Name | Description
Uninitialized | Data status uninizialized.
Unchanged | Data status Read. No pending changes.
New | Data status New. New record in the main table has been added.
Edit | Data status Edit. Either main table or child table have been modified.
NoData | Data status NoData. When no records are available in the main table.
Filling | Data is about to be filled into the data status manager.
Filled | Data is filled into the data status manager.

Requirements

Namespace: Deag.Vdx.Common.Enums

Assembly: vdxCommon (in vdxCommon.dll)

See Also

Deag.Vdx.Common.Enums Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManagerAction Enumeration

Specifies the action of a vdxDataStatusManager.

public enum vdxDataStatusManagerAction

Members

Member Name | Description
Add | The data status action is Add.
Copy | The data status action is Copy.
Delete | The data status action is Delete.
Edit | The data status action is Edit.
Save | The data status action is Save.
Undo | The data status action is Undo.
ShowDebug | The data status action is ShowDebug.
Find | The data status action is Find.
Print | The data status action is Print.
Preview | The data status action is Preview.

Requirements

Namespace: Deag.Vdx.Common.Enums

Assembly: vdxCommon (in vdxCommon.dll)

See Also

Deag.Vdx.Common.Enums Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataTreeNodeState Enumeration

Specifies the state of the vdxTreeNode.

public enum vdxDataTreeNodeState

Members

Member Name | Description
NodeNormal | Normal state.
NodeNew | The node is new.
NodeDeleted | The node is deleted.
NodeCopied | The node is copied.
NodeLinked | The node is linked.

Requirements

Namespace: Deag.Vdx.Common.Enums

Assembly: vdxCommon (in vdxCommon.dll)

See Also

Deag.Vdx.Common.Enums Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDateFormat Enumeration

Specifies the format of the date in a vdxDatePickField control.

public enum vdxDateFormat

Members

Member Name | Description
ShortDate | Short Date Format
LongDate | Date Time Format.

Requirements

Namespace: Deag.Vdx.Common.Enums

Assembly: vdxCommon (in vdxCommon.dll)

See Also

Deag.Vdx.Common.Enums Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxErrorSeverity Enumeration

Specifies the error severity level.

public enum vdxErrorSeverity

Members

Member Name | Description
Default | Take the Default as Defined in the XML-File.
Standard | Standard Error.
Low | Error with low severity.
High | Error with high severity.
Catastrophic | Error with catastrophic severity. Includes the stack dump.

Requirements

Namespace: Deag.Vdx.Common.Enums

Assembly: vdxCommon (in vdxCommon.dll)

See Also

Deag.Vdx.Common.Enums Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerMode Enumeration

Specifies the vdxExplorerMode.

public enum vdxExplorerMode

Members

Member Name | Description
Selection | Selection Mode.
Explore | Exlorer Mode.

Requirements

Namespace: Deag.Vdx.Common.Enums

Assembly: vdxCommon (in vdxCommon.dll)

See Also

Deag.Vdx.Common.Enums Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxQuestion Enumeration

Specifies the question type of the MessageBox.

public enum vdxQuestion

Members

Member Name | Description
SaveChanges | Asks for saving changed data.
SaveNew | Asks for saving newly entered data.
Delete | Asks for deleting data.

Requirements

Namespace: Deag.Vdx.Common.Enums

Assembly: vdxCommon (in vdxCommon.dll)

See Also

Deag.Vdx.Common.Enums Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchType Enumeration

Specifies the vdxSearchType.

public enum vdxSearchType

Remarks

Enumeration which collects the types of search options used on a 'vdxSearchParameter' object. It's possible to use a combination of search options.

Example

enSmallerAs | enEqual

Members

Member Name | Description
Equal | Use this option if you want to search with a '=' operator (field = value).
StartWith | Use this option if you want to search with a '%' operator at the end (field like value%).
Contains | Use this option if you want to search with a '%' operator at the beginning and the end (field like %value%).
BetweenStart | Use this option if you want to search with a 'between' operator (field between VALUE and value).
BetweenEnd | Use this option if you want to search with a 'between' operator (field between value and VALUE).
SmallerAs | Use this option if you want to search with a 'smaller' operator.
LargerAs | Use this option if you want to search with a 'larger' operator.
Other | Use this option if you want to put any additional information (such as order by info).
SmallerEqualAs | Use this option if you want to search with a 'smaller' and an 'equal' operator.
LargerEqualAs | Use this option if you want to search with a 'larger' and an 'equal' operator.

Requirements

Namespace: Deag.Vdx.Common.Enums

Assembly: vdxCommon (in vdxCommon.dll)

See Also

Deag.Vdx.Common.Enums Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTraceSwitch Enumeration

Specifies the trace switches.

public enum vdxTraceSwitch

Members

Member Name | Description
Error | Error.
Warning | Warning.
Info | Info.
Verbose | Verbose.

Requirements

Namespace: Deag.Vdx.Common.Enums

Assembly: vdxCommon (in vdxCommon.dll)

See Also

Deag.Vdx.Common.Enums Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Common.ErrorTextes

VDX Framework

Deag.Vdx.Common.ErrorTextes Namespace

Contains the DataSet vdxExceptionTexts that defines the structure of the VDX exception types.

Classes

Class | Description
vdxExceptionTexts |
vdxExceptionTexts.ExceptionInfoDataTable |
vdxExceptionTexts.ExceptionInfoRow |
vdxExceptionTexts.ExceptionInfoRowChangeEvent |
vdxExceptionTexts.ExceptionTextDataTable |
vdxExceptionTexts.ExceptionTextRow |
vdxExceptionTexts.ExceptionTextRowChangeEvent |
vdxExceptionTexts.ExceptionTypeDataTable |
vdxExceptionTexts.ExceptionTypeRow |
vdxExceptionTexts.ExceptionTypeRowChangeEvent |
vdxExceptionTexts.LanguageDataTable |
vdxExceptionTexts.LanguageRow |
vdxExceptionTexts.LanguageRowChangeEvent |
vdxExceptionTexts.SeverityDataTable |
vdxExceptionTexts.SeverityRow |
vdxExceptionTexts.SeverityRowChangeEvent |
vdxExceptionTexts.vdxExceptionDialogDataTable |
vdxExceptionTexts.vdxExceptionDialogRow |
vdxExceptionTexts.vdxExceptionDialogRowChangeEvent |

Delegates

Delegate | Description
vdxExceptionTexts.ExceptionInfoRowChangeEventHandler |
vdxExceptionTexts.ExceptionTextRowChangeEventHandler |
vdxExceptionTexts.ExceptionTypeRowChangeEventHandler |
vdxExceptionTexts.LanguageRowChangeEventHandler |
vdxExceptionTexts.SeverityRowChangeEventHandler |
vdxExceptionTexts.vdxExceptionDialogRowChangeEventHandler |

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts Class

For a list of all members of this type, see vdxExceptionTexts Members.

System.Object
MarshalByValueComponent
DataSet
vdxExceptionTexts

public class vdxExceptionTexts : DataSet

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionTexts Members | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts Members

vdxExceptionTexts overview

Public Instance Constructors

vdxExceptionTexts Overloaded. Initializes a new instance of the vdxExceptionTexts class.

Public Instance Properties

CaseSensitive (inherited from DataSet) | Gets or sets a value indicating whether string comparisons within DataTable objects are case-sensitive.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
DataSetName (inherited from DataSet) | Gets or sets the name of the current DataSet .
DefaultViewManager (inherited from DataSet) | Gets a custom view of the data contained in the DataSet to allow filtering, searching, and navigating using a custom DataViewManager .
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
EnforceConstraints (inherited from DataSet) | Gets or sets a value indicating whether constraint rules are followed when attempting any update operation.
ExceptionInfo |
ExceptionText |
ExceptionType |
ExtendedProperties (inherited from DataSet) | Gets the collection of customized user information associated with the DataSet .
HasErrors (inherited from DataSet) | Gets a value indicating whether there are errors in any of the DataTable objects within this DataSet .
Language |
Locale (inherited from DataSet) | Gets or sets the locale information used to compare strings within the table.
Namespace (inherited from DataSet) | Gets or sets the namespace of the DataSet.
Prefix (inherited from DataSet) | Gets or sets an XML prefix that aliases the namespace of the DataSet.
Relations (inherited from DataSet) | Get the collection of relations that link tables and allow navigation from parent tables to child tables.
Severity |
Site (inherited from DataSet) | Gets or sets an ISite for the DataSet .
Tables (inherited from DataSet) | Gets the collection of tables contained in the DataSet.
vdxExceptionDialog |

Public Instance Methods

AcceptChanges (inherited from DataSet) | Commits all the changes made to this DataSet since it was loaded or since the last time AcceptChanges was called.
BeginInit (inherited from DataSet) |
Clear (inherited from DataSet) | Clears the DataSet of any data by removing all rows in all tables.
Clone |
Copy (inherited from DataSet) | Copies both the structure and data for this DataSet.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent .
EndInit (inherited from DataSet) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChanges (inherited from DataSet) | Overloaded. Gets a copy of the DataSet that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
GetXml (inherited from DataSet) | Returns the XML representation of the data stored in the DataSet.
GetXmlSchema (inherited from DataSet) | Returns the XSD schema for the XML representation of the data stored in the DataSet.
HasChanges (inherited from DataSet) | Overloaded. Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.
InferXmlSchema (inherited from DataSet) | Overloaded. Applies the XML schema from the specified XmlReader to the DataSet
Merge (inherited from DataSet) | Overloaded. Merges a specified DataSet and its schema into the current DataSet.
ReadXml (inherited from DataSet) | Overloaded. Reads XML schema and data into the DataSet using the specified XmlReader.
ReadXmlSchema (inherited from DataSet) | Overloaded. Reads the XML schema from the specified XmlReader into the DataSet .
RejectChanges (inherited from DataSet) | Rolls back all the changes made to the DataSet since it was created, or since the last time AcceptChanges was called.
Reset (inherited from DataSet) | Resets the DataSet to its original state. Subclasses should override Resetto restore a DataSet to its original state.
ToString (inherited from MarshalByValueComponent) |
WriteXml (inherited from DataSet) | Overloaded. Writes the current data for the DataSet using the specified Stream .
WriteXmlSchema (inherited from DataSet) | Overloaded. Writes the DataSet structure as an XML schema to using the specified Stream object.

Public Instance Events

Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
MergeFailed (inherited from DataSet) | Occurs when a target and source DataRow have the same primary key value, and EnforceConstraints is set to true.

Protected Instance Constructors

vdxExceptionTexts Overloaded. Initializes a new instance of the vdxExceptionTexts class.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

Protected Instance Methods

Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) |
GetSchemaSerializable |
GetSerializationData (inherited from DataSet) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRemoveRelation (inherited from DataSet) | Occurs when a DataRelation object is removed from a DataTable.
OnRemoveTable (inherited from DataSet) | Occurs when a DataTable is removed from a DataSet.
ReadXmlSerializable |
ShouldSerializeRelations |
ShouldSerializeTables |

Protected Internal Instance Methods

OnPropertyChanging (inherited from DataSet) | Raises the OnPropertyChanging event.
RaisePropertyChanging (inherited from DataSet) | Sends notification that the specified DataSet property is about to change.

Explicit Interface Implementations

IListSource.GetList (inherited from DataSet)
ISerializable.GetObjectData (inherited from DataSet)
IXmlSerializable.GetSchema (inherited from DataSet)
IXmlSerializable.ReadXml (inherited from DataSet)
IXmlSerializable.WriteXml (inherited from DataSet)

See Also

vdxExceptionTexts Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts Constructor

Initializes a new instance of the vdxExceptionTexts class.

Overload List

Initializes a new instance of the vdxExceptionTexts class.

public vdxExceptionTexts();

protected vdxExceptionTexts(SerializationInfo,StreamingContext);

See Also

vdxExceptionTexts Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts Constructor ()

Initializes a new instance of the vdxExceptionTexts class.

public vdxExceptionTexts();

See Also

vdxExceptionTexts Class | Deag.Vdx.Common.ErrorTextes Namespace | vdxExceptionTexts Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts Constructor (SerializationInfo, StreamingContext)

protected vdxExceptionTexts(
SerializationInfo info,
StreamingContext context
);

See Also

vdxExceptionTexts Class | Deag.Vdx.Common.ErrorTextes Namespace | vdxExceptionTexts Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts Properties

The properties of the vdxExceptionTexts class are listed below. For a complete list of vdxExceptionTexts class members, see the vdxExceptionTexts Members topic.

Public Instance Properties

CaseSensitive (inherited from DataSet) | Gets or sets a value indicating whether string comparisons within DataTable objects are case-sensitive.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
DataSetName (inherited from DataSet) | Gets or sets the name of the current DataSet .
DefaultViewManager (inherited from DataSet) | Gets a custom view of the data contained in the DataSet to allow filtering, searching, and navigating using a custom DataViewManager .
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
EnforceConstraints (inherited from DataSet) | Gets or sets a value indicating whether constraint rules are followed when attempting any update operation.
ExceptionInfo |
ExceptionText |
ExceptionType |
ExtendedProperties (inherited from DataSet) | Gets the collection of customized user information associated with the DataSet .
HasErrors (inherited from DataSet) | Gets a value indicating whether there are errors in any of the DataTable objects within this DataSet .
Language |
Locale (inherited from DataSet) | Gets or sets the locale information used to compare strings within the table.
Namespace (inherited from DataSet) | Gets or sets the namespace of the DataSet.
Prefix (inherited from DataSet) | Gets or sets an XML prefix that aliases the namespace of the DataSet.
Relations (inherited from DataSet) | Get the collection of relations that link tables and allow navigation from parent tables to child tables.
Severity |
Site (inherited from DataSet) | Gets or sets an ISite for the DataSet .
Tables (inherited from DataSet) | Gets the collection of tables contained in the DataSet.
vdxExceptionDialog |

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

See Also

vdxExceptionTexts Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfo Property

public vdxExceptionTexts.ExceptionInfoDataTable ExceptionInfo {get;}

See Also

vdxExceptionTexts Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionText Property

public vdxExceptionTexts.ExceptionTextDataTable ExceptionText {get;}

See Also

vdxExceptionTexts Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionType Property

public vdxExceptionTexts.ExceptionTypeDataTable ExceptionType {get;}

See Also

vdxExceptionTexts Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.Language Property

public vdxExceptionTexts.LanguageDataTable Language {get;}

See Also

vdxExceptionTexts Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.Severity Property

public vdxExceptionTexts.SeverityDataTable Severity {get;}

See Also

vdxExceptionTexts Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialog Property

public vdxExceptionTexts.vdxExceptionDialogDataTable vdxExceptionDialog {get;}

See Also

vdxExceptionTexts Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts Methods

The methods of the vdxExceptionTexts class are listed below. For a complete list of vdxExceptionTexts class members, see the vdxExceptionTexts Members topic.

Public Instance Methods

AcceptChanges (inherited from DataSet) | Commits all the changes made to this DataSet since it was loaded or since the last time AcceptChanges was called.
BeginInit (inherited from DataSet) |
Clear (inherited from DataSet) | Clears the DataSet of any data by removing all rows in all tables.
Clone |
Copy (inherited from DataSet) | Copies both the structure and data for this DataSet.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent .
EndInit (inherited from DataSet) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChanges (inherited from DataSet) | Overloaded. Gets a copy of the DataSet that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
GetXml (inherited from DataSet) | Returns the XML representation of the data stored in the DataSet.
GetXmlSchema (inherited from DataSet) | Returns the XSD schema for the XML representation of the data stored in the DataSet.
HasChanges (inherited from DataSet) | Overloaded. Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.
InferXmlSchema (inherited from DataSet) | Overloaded. Applies the XML schema from the specified XmlReader to the DataSet
Merge (inherited from DataSet) | Overloaded. Merges a specified DataSet and its schema into the current DataSet.
ReadXml (inherited from DataSet) | Overloaded. Reads XML schema and data into the DataSet using the specified XmlReader.
ReadXmlSchema (inherited from DataSet) | Overloaded. Reads the XML schema from the specified XmlReader into the DataSet .
RejectChanges (inherited from DataSet) | Rolls back all the changes made to the DataSet since it was created, or since the last time AcceptChanges was called.
Reset (inherited from DataSet) | Resets the DataSet to its original state. Subclasses should override Resetto restore a DataSet to its original state.
ToString (inherited from MarshalByValueComponent) |
WriteXml (inherited from DataSet) | Overloaded. Writes the current data for the DataSet using the specified Stream .
WriteXmlSchema (inherited from DataSet) | Overloaded. Writes the DataSet structure as an XML schema to using the specified Stream object.

Protected Instance Methods

Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) |
GetSchemaSerializable |
GetSerializationData (inherited from DataSet) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRemoveRelation (inherited from DataSet) | Occurs when a DataRelation object is removed from a DataTable.
OnRemoveTable (inherited from DataSet) | Occurs when a DataTable is removed from a DataSet.
ReadXmlSerializable |
ShouldSerializeRelations |
ShouldSerializeTables |

Protected Internal Instance Methods

OnPropertyChanging (inherited from DataSet) | Raises the OnPropertyChanging event.
RaisePropertyChanging (inherited from DataSet) | Sends notification that the specified DataSet property is about to change.

Explicit Interface Implementations

IListSource.GetList (inherited from DataSet)
ISerializable.GetObjectData (inherited from DataSet)
IXmlSerializable.GetSchema (inherited from DataSet)
IXmlSerializable.ReadXml (inherited from DataSet)
IXmlSerializable.WriteXml (inherited from DataSet)

See Also

vdxExceptionTexts Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.Clone Method

public override DataSet Clone();

See Also

vdxExceptionTexts Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.GetSchemaSerializable Method

protected override XmlSchema GetSchemaSerializable();

See Also

vdxExceptionTexts Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ReadXmlSerializable Method

protected override void ReadXmlSerializable(
XmlReader reader
);

See Also

vdxExceptionTexts Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ShouldSerializeRelations Method

protected override bool ShouldSerializeRelations();

See Also

vdxExceptionTexts Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ShouldSerializeTables Method

protected override bool ShouldSerializeTables();

See Also

vdxExceptionTexts Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable Class

For a list of all members of this type, see vdxExceptionTexts.ExceptionInfoDataTable Members.

System.Object
MarshalByValueComponent
DataTable
vdxExceptionTexts.ExceptionInfoDataTable

public class vdxExceptionTexts.ExceptionInfoDataTable : DataTable, IEnumerable

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionTexts.ExceptionInfoDataTable Members | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable Members

vdxExceptionTexts.ExceptionInfoDataTable overview

Public Instance Properties

CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
DataSet (inherited from DataTable) | Gets the DataSet that this table belongs to.
DefaultView (inherited from DataTable) | Gets a customized view of the table which may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that will return a value used to represent this table in the user interface.
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable .
TableName (inherited from DataTable) | Gets or sets the name of the DataTable .

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddExceptionInfoRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent .
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByExceptionID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
LoadDataRow (inherited from DataTable) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
NewExceptionInfoRow |
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemoveExceptionInfoRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow .
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow .
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
ExceptionInfoRowChanged |
ExceptionInfoRowChanging |
ExceptionInfoRowDeleted |
ExceptionInfoRowDeleting |
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) |
GetRowType |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |

Protected Internal Instance Fields

fInitInProgress (inherited from DataTable) [To be supplied.]

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnPropertyChanging (inherited from DataTable) |
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.

Explicit Interface Implementations

IListSource.GetList (inherited from DataTable)
ISerializable.GetObjectData (inherited from DataTable)

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable Properties

The properties of the vdxExceptionTexts.ExceptionInfoDataTable class are listed below. For a complete list of vdxExceptionTexts.ExceptionInfoDataTable class members, see the vdxExceptionTexts.ExceptionInfoDataTable Members topic.

Public Instance Properties

CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
DataSet (inherited from DataTable) | Gets the DataSet that this table belongs to.
DefaultView (inherited from DataTable) | Gets a customized view of the table which may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that will return a value used to represent this table in the user interface.
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable .
TableName (inherited from DataTable) | Gets or sets the name of the DataTable .

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.Count Property

public int Count {get;}

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.Item Property

public vdxExceptionTexts.ExceptionInfoRow this[
int index
] {get;}

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable Methods

The methods of the vdxExceptionTexts.ExceptionInfoDataTable class are listed below. For a complete list of vdxExceptionTexts.ExceptionInfoDataTable class members, see the vdxExceptionTexts.ExceptionInfoDataTable Members topic.

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddExceptionInfoRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent .
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByExceptionID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
LoadDataRow (inherited from DataTable) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
NewExceptionInfoRow |
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemoveExceptionInfoRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) |
GetRowType |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnPropertyChanging (inherited from DataTable) |
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.

Explicit Interface Implementations

IListSource.GetList (inherited from DataTable)
ISerializable.GetObjectData (inherited from DataTable)

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AddExceptionInfoRow Method

VDX Framework

vdxExceptionTexts.ExceptionInfoDataTable.AddExceptionInfoRow Method

Overload List

public void AddExceptionInfoRow(ExceptionInfoRow);

public ExceptionInfoRow AddExceptionInfoRow(int,ExceptionTypeRow,SeverityRow,string);

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.AddExceptionInfoRow Method (ExceptionInfoRow)

public void AddExceptionInfoRow(
ExceptionInfoRow row
);

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace | vdxExceptionTexts.ExceptionInfoDataTable.AddExceptionInfoRow Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.AddExceptionInfoRow Method (Int32, ExceptionTypeRow, SeverityRow, String)

public ExceptionInfoRow AddExceptionInfoRow(
int ExceptionID,
ExceptionTypeRow parentExceptionTypeRowByExceptionTypeExceptionInfo,
SeverityRow parentSeverityRowBySeverityExceptionInfo,
string ConstraintName
);

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace | vdxExceptionTexts.ExceptionInfoDataTable.AddExceptionInfoRow Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.Clone Method

public override DataTable Clone();

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.CreateInstance Method

protected override DataTable CreateInstance();

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.FindByExceptionID Method

public ExceptionInfoRow FindByExceptionID(
int ExceptionID
);

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.GetRowType Method

protected override Type GetRowType();

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.NewExceptionInfoRow Method

public ExceptionInfoRow NewExceptionInfoRow();

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.NewRowFromBuilder Method

protected override DataRow NewRowFromBuilder(
DataRowBuilder builder
);

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.OnRowChanged Method

protected override void OnRowChanged(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.OnRowChanging Method

protected override void OnRowChanging(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.OnRowDeleted Method

protected override void OnRowDeleted(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.OnRowDeleting Method

protected override void OnRowDeleting(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.RemoveExceptionInfoRow Method

public void RemoveExceptionInfoRow(
ExceptionInfoRow row
);

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable Events

The events of the vdxExceptionTexts.ExceptionInfoDataTable class are listed below. For a complete list of vdxExceptionTexts.ExceptionInfoDataTable class members, see the vdxExceptionTexts.ExceptionInfoDataTable Members topic.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow .
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow .
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
ExceptionInfoRowChanged |
ExceptionInfoRowChanging |
ExceptionInfoRowDeleted |
ExceptionInfoRowDeleting |
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.ExceptionInfoRowChanged Event

public event ExceptionInfoRowChangeEventHandler ExceptionInfoRowChanged;

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.ExceptionInfoRowChanging Event

public event ExceptionInfoRowChangeEventHandler ExceptionInfoRowChanging;

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.ExceptionInfoRowDeleted Event

public event ExceptionInfoRowChangeEventHandler ExceptionInfoRowDeleted;

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoDataTable.ExceptionInfoRowDeleting Event

public event ExceptionInfoRowChangeEventHandler ExceptionInfoRowDeleting;

See Also

vdxExceptionTexts.ExceptionInfoDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRow Class

For a list of all members of this type, see vdxExceptionTexts.ExceptionInfoRow Members.

System.Object
DataRow
vdxExceptionTexts.ExceptionInfoRow

public class vdxExceptionTexts.ExceptionInfoRow : DataRow

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionTexts.ExceptionInfoRow Members | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRow Members

vdxExceptionTexts.ExceptionInfoRow overview

Public Instance Properties

ConstraintName |
ExceptionID |
ExceptionTypeID |
ExceptionTypeRow |
HasErrors (inherited from DataRow) | Gets a value indicating whether there are errors in a row.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all of the values for this row through an array.
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row in regard to its relationship to the DataRowCollection .
SeverityID |
SeverityRow |
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Begins an edit operation on a DataRowobject.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row, including the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow .
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetExceptionTextRows |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value indicating whether a specified version exists.
IsConstraintNameNull |
IsExceptionTypeIDNull |
IsNull (inherited from DataRow) | Overloaded. Gets a value indicating whether the column at the specified index contains a null value.
IsSeverityIDNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetConstraintNameNull |
SetExceptionTypeIDNull |
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow .
SetSeverityIDNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the the value of the specified DataColumn to a null value.

See Also

vdxExceptionTexts.ExceptionInfoRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRow Properties

The properties of the vdxExceptionTexts.ExceptionInfoRow class are listed below. For a complete list of vdxExceptionTexts.ExceptionInfoRow class members, see the vdxExceptionTexts.ExceptionInfoRow Members topic.

Public Instance Properties

ConstraintName |
ExceptionID |
ExceptionTypeID |
ExceptionTypeRow |
HasErrors (inherited from DataRow) | Gets a value indicating whether there are errors in a row.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all of the values for this row through an array.
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row in regard to its relationship to the DataRowCollection .
SeverityID |
SeverityRow |
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.

See Also

vdxExceptionTexts.ExceptionInfoRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRow.ConstraintName Property

public string ConstraintName {get; set;}

See Also

vdxExceptionTexts.ExceptionInfoRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRow.ExceptionID Property

public int ExceptionID {get; set;}

See Also

vdxExceptionTexts.ExceptionInfoRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRow.ExceptionTypeID Property

public string ExceptionTypeID {get; set;}

See Also

vdxExceptionTexts.ExceptionInfoRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRow.ExceptionTypeRow Property

public vdxExceptionTexts.ExceptionTypeRow ExceptionTypeRow {get; set;}

See Also

vdxExceptionTexts.ExceptionInfoRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRow.SeverityID Property

public int SeverityID {get; set;}

See Also

vdxExceptionTexts.ExceptionInfoRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRow.SeverityRow Property

public vdxExceptionTexts.SeverityRow SeverityRow {get; set;}

See Also

vdxExceptionTexts.ExceptionInfoRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRow Methods

The methods of the vdxExceptionTexts.ExceptionInfoRow class are listed below. For a complete list of vdxExceptionTexts.ExceptionInfoRow class members, see the vdxExceptionTexts.ExceptionInfoRow Members topic.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Begins an edit operation on a DataRowobject.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row, including the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow .
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetExceptionTextRows |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value indicating whether a specified version exists.
IsConstraintNameNull |
IsExceptionTypeIDNull |
IsNull (inherited from DataRow) | Overloaded. Gets a value indicating whether the column at the specified index contains a null value.
IsSeverityIDNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetConstraintNameNull |
SetExceptionTypeIDNull |
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow .
SetSeverityIDNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the the value of the specified DataColumn to a null value.

See Also

vdxExceptionTexts.ExceptionInfoRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRow.GetExceptionTextRows Method

public ExceptionTextRow[] GetExceptionTextRows();

See Also

vdxExceptionTexts.ExceptionInfoRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRow.IsConstraintNameNull Method

public bool IsConstraintNameNull();

See Also

vdxExceptionTexts.ExceptionInfoRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRow.IsExceptionTypeIDNull Method

public bool IsExceptionTypeIDNull();

See Also

vdxExceptionTexts.ExceptionInfoRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRow.IsSeverityIDNull Method

public bool IsSeverityIDNull();

See Also

vdxExceptionTexts.ExceptionInfoRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRow.SetConstraintNameNull Method

public void SetConstraintNameNull();

See Also

vdxExceptionTexts.ExceptionInfoRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRow.SetExceptionTypeIDNull Method

public void SetExceptionTypeIDNull();

See Also

vdxExceptionTexts.ExceptionInfoRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRow.SetSeverityIDNull Method

public void SetSeverityIDNull();

See Also

vdxExceptionTexts.ExceptionInfoRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRowChangeEvent Class

For a list of all members of this type, see vdxExceptionTexts.ExceptionInfoRowChangeEvent Members.

System.Object
EventArgs
vdxExceptionTexts.ExceptionInfoRowChangeEvent

public class vdxExceptionTexts.ExceptionInfoRowChangeEvent : EventArgs

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionTexts.ExceptionInfoRowChangeEvent Members | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRowChangeEvent Members

vdxExceptionTexts.ExceptionInfoRowChangeEvent overview

Public Instance Constructors

vdxExceptionTexts.ExceptionInfoRowChangeEvent Constructor

Public Instance Properties

Action
Row

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxExceptionTexts.ExceptionInfoRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRowChangeEvent Constructor

public vdxExceptionTexts.ExceptionInfoRowChangeEvent(
ExceptionInfoRow row,
DataRowAction action
);

See Also

vdxExceptionTexts.ExceptionInfoRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRowChangeEvent Properties

The properties of the vdxExceptionTexts.ExceptionInfoRowChangeEvent class are listed below. For a complete list of vdxExceptionTexts.ExceptionInfoRowChangeEvent class members, see the vdxExceptionTexts.ExceptionInfoRowChangeEvent Members topic.

Public Instance Properties

Action
Row

See Also

vdxExceptionTexts.ExceptionInfoRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRowChangeEvent.Action Property

public System.Data.DataRowAction Action {get;}

See Also

vdxExceptionTexts.ExceptionInfoRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRowChangeEvent.Row Property

public vdxExceptionTexts.ExceptionInfoRow Row {get;}

See Also

vdxExceptionTexts.ExceptionInfoRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionInfoRowChangeEventHandler Delegate

public delegate void vdxExceptionTexts.ExceptionInfoRowChangeEventHandler(
object sender,
ExceptionInfoRowChangeEvent e
);

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable Class

For a list of all members of this type, see vdxExceptionTexts.ExceptionTextDataTable Members.

System.Object
MarshalByValueComponent
DataTable
vdxExceptionTexts.ExceptionTextDataTable

public class vdxExceptionTexts.ExceptionTextDataTable : DataTable, IEnumerable

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionTexts.ExceptionTextDataTable Members | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable Members

vdxExceptionTexts.ExceptionTextDataTable overview

Public Instance Properties

CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
DataSet (inherited from DataTable) | Gets the DataSet that this table belongs to.
DefaultView (inherited from DataTable) | Gets a customized view of the table which may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that will return a value used to represent this table in the user interface.
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable .
TableName (inherited from DataTable) | Gets or sets the name of the DataTable .

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddExceptionTextRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent .
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByLanguageIDExceptionID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
LoadDataRow (inherited from DataTable) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
NewExceptionTextRow |
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemoveExceptionTextRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow .
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow .
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
ExceptionTextRowChanged |
ExceptionTextRowChanging |
ExceptionTextRowDeleted |
ExceptionTextRowDeleting |
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) |
GetRowType |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |

Protected Internal Instance Fields

fInitInProgress (inherited from DataTable) [To be supplied.]

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnPropertyChanging (inherited from DataTable) |
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.

Explicit Interface Implementations

IListSource.GetList (inherited from DataTable)
ISerializable.GetObjectData (inherited from DataTable)

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable Properties

The properties of the vdxExceptionTexts.ExceptionTextDataTable class are listed below. For a complete list of vdxExceptionTexts.ExceptionTextDataTable class members, see the vdxExceptionTexts.ExceptionTextDataTable Members topic.

Public Instance Properties

CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
DataSet (inherited from DataTable) | Gets the DataSet that this table belongs to.
DefaultView (inherited from DataTable) | Gets a customized view of the table which may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that will return a value used to represent this table in the user interface.
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable .
TableName (inherited from DataTable) | Gets or sets the name of the DataTable .

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.Count Property

public int Count {get;}

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.Item Property

public vdxExceptionTexts.ExceptionTextRow this[
int index
] {get;}

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable Methods

The methods of the vdxExceptionTexts.ExceptionTextDataTable class are listed below. For a complete list of vdxExceptionTexts.ExceptionTextDataTable class members, see the vdxExceptionTexts.ExceptionTextDataTable Members topic.

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddExceptionTextRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent .
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByLanguageIDExceptionID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
LoadDataRow (inherited from DataTable) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
NewExceptionTextRow |
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemoveExceptionTextRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) |
GetRowType |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnPropertyChanging (inherited from DataTable) |
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.

Explicit Interface Implementations

IListSource.GetList (inherited from DataTable)
ISerializable.GetObjectData (inherited from DataTable)

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AddExceptionTextRow Method

VDX Framework

vdxExceptionTexts.ExceptionTextDataTable.AddExceptionTextRow Method

Overload List

public void AddExceptionTextRow(ExceptionTextRow);

public ExceptionTextRow AddExceptionTextRow(LanguageRow,ExceptionInfoRow,string,string);

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.AddExceptionTextRow Method (ExceptionTextRow)

public void AddExceptionTextRow(
ExceptionTextRow row
);

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace | vdxExceptionTexts.ExceptionTextDataTable.AddExceptionTextRow Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.AddExceptionTextRow Method (LanguageRow, ExceptionInfoRow, String, String)

public ExceptionTextRow AddExceptionTextRow(
LanguageRow parentLanguageRowByLocaleExceptionText,
ExceptionInfoRow parentExceptionInfoRowByExceptionInfoExceptionText,
string Text,
string Caption
);

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace | vdxExceptionTexts.ExceptionTextDataTable.AddExceptionTextRow Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.Clone Method

public override DataTable Clone();

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.CreateInstance Method

protected override DataTable CreateInstance();

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.FindByLanguageIDExceptionID Method

public ExceptionTextRow FindByLanguageIDExceptionID(
string LanguageID,
int ExceptionID
);

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.GetRowType Method

protected override Type GetRowType();

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.NewExceptionTextRow Method

public ExceptionTextRow NewExceptionTextRow();

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.NewRowFromBuilder Method

protected override DataRow NewRowFromBuilder(
DataRowBuilder builder
);

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.OnRowChanged Method

protected override void OnRowChanged(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.OnRowChanging Method

protected override void OnRowChanging(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.OnRowDeleted Method

protected override void OnRowDeleted(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.OnRowDeleting Method

protected override void OnRowDeleting(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.RemoveExceptionTextRow Method

public void RemoveExceptionTextRow(
ExceptionTextRow row
);

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable Events

The events of the vdxExceptionTexts.ExceptionTextDataTable class are listed below. For a complete list of vdxExceptionTexts.ExceptionTextDataTable class members, see the vdxExceptionTexts.ExceptionTextDataTable Members topic.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow .
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow .
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
ExceptionTextRowChanged |
ExceptionTextRowChanging |
ExceptionTextRowDeleted |
ExceptionTextRowDeleting |
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.ExceptionTextRowChanged Event

public event ExceptionTextRowChangeEventHandler ExceptionTextRowChanged;

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.ExceptionTextRowChanging Event

public event ExceptionTextRowChangeEventHandler ExceptionTextRowChanging;

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.ExceptionTextRowDeleted Event

public event ExceptionTextRowChangeEventHandler ExceptionTextRowDeleted;

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextDataTable.ExceptionTextRowDeleting Event

public event ExceptionTextRowChangeEventHandler ExceptionTextRowDeleting;

See Also

vdxExceptionTexts.ExceptionTextDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRow Class

For a list of all members of this type, see vdxExceptionTexts.ExceptionTextRow Members.

System.Object
DataRow
vdxExceptionTexts.ExceptionTextRow

public class vdxExceptionTexts.ExceptionTextRow : DataRow

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionTexts.ExceptionTextRow Members | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRow Members

vdxExceptionTexts.ExceptionTextRow overview

Public Instance Properties

Caption |
ExceptionID |
ExceptionInfoRow |
HasErrors (inherited from DataRow) | Gets a value indicating whether there are errors in a row.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all of the values for this row through an array.
LanguageID |
LanguageRow |
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row in regard to its relationship to the DataRowCollection .
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.
Text |

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Begins an edit operation on a DataRowobject.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row, including the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow .
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value indicating whether a specified version exists.
IsCaptionNull |
IsNull (inherited from DataRow) | Overloaded. Gets a value indicating whether the column at the specified index contains a null value.
IsTextNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetCaptionNull |
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow .
SetTextNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the the value of the specified DataColumn to a null value.

See Also

vdxExceptionTexts.ExceptionTextRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRow Properties

The properties of the vdxExceptionTexts.ExceptionTextRow class are listed below. For a complete list of vdxExceptionTexts.ExceptionTextRow class members, see the vdxExceptionTexts.ExceptionTextRow Members topic.

Public Instance Properties

Caption |
ExceptionID |
ExceptionInfoRow |
HasErrors (inherited from DataRow) | Gets a value indicating whether there are errors in a row.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all of the values for this row through an array.
LanguageID |
LanguageRow |
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row in regard to its relationship to the DataRowCollection .
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.
Text |

See Also

vdxExceptionTexts.ExceptionTextRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRow.Caption Property

public string Caption {get; set;}

See Also

vdxExceptionTexts.ExceptionTextRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRow.ExceptionID Property

public int ExceptionID {get; set;}

See Also

vdxExceptionTexts.ExceptionTextRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRow.ExceptionInfoRow Property

public vdxExceptionTexts.ExceptionInfoRow ExceptionInfoRow {get; set;}

See Also

vdxExceptionTexts.ExceptionTextRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRow.LanguageID Property

public string LanguageID {get; set;}

See Also

vdxExceptionTexts.ExceptionTextRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRow.LanguageRow Property

public vdxExceptionTexts.LanguageRow LanguageRow {get; set;}

See Also

vdxExceptionTexts.ExceptionTextRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRow.Text Property

public string Text {get; set;}

See Also

vdxExceptionTexts.ExceptionTextRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRow Methods

The methods of the vdxExceptionTexts.ExceptionTextRow class are listed below. For a complete list of vdxExceptionTexts.ExceptionTextRow class members, see the vdxExceptionTexts.ExceptionTextRow Members topic.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Begins an edit operation on a DataRowobject.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row, including the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow .
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value indicating whether a specified version exists.
IsCaptionNull |
IsNull (inherited from DataRow) | Overloaded. Gets a value indicating whether the column at the specified index contains a null value.
IsTextNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetCaptionNull |
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow .
SetTextNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the the value of the specified DataColumn to a null value.

See Also

vdxExceptionTexts.ExceptionTextRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRow.IsCaptionNull Method

public bool IsCaptionNull();

See Also

vdxExceptionTexts.ExceptionTextRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRow.IsTextNull Method

public bool IsTextNull();

See Also

vdxExceptionTexts.ExceptionTextRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRow.SetCaptionNull Method

public void SetCaptionNull();

See Also

vdxExceptionTexts.ExceptionTextRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRow.SetTextNull Method

public void SetTextNull();

See Also

vdxExceptionTexts.ExceptionTextRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRowChangeEvent Class

For a list of all members of this type, see vdxExceptionTexts.ExceptionTextRowChangeEvent Members.

System.Object
EventArgs
vdxExceptionTexts.ExceptionTextRowChangeEvent

public class vdxExceptionTexts.ExceptionTextRowChangeEvent : EventArgs

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionTexts.ExceptionTextRowChangeEvent Members | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRowChangeEvent Members

vdxExceptionTexts.ExceptionTextRowChangeEvent overview

Public Instance Constructors

vdxExceptionTexts.ExceptionTextRowChangeEvent Constructor

Public Instance Properties

Action
Row

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxExceptionTexts.ExceptionTextRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRowChangeEvent Constructor

public vdxExceptionTexts.ExceptionTextRowChangeEvent(
ExceptionTextRow row,
DataRowAction action
);

See Also

vdxExceptionTexts.ExceptionTextRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRowChangeEvent Properties

The properties of the vdxExceptionTexts.ExceptionTextRowChangeEvent class are listed below. For a complete list of vdxExceptionTexts.ExceptionTextRowChangeEvent class members, see the vdxExceptionTexts.ExceptionTextRowChangeEvent Members topic.

Public Instance Properties

Action
Row

See Also

vdxExceptionTexts.ExceptionTextRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRowChangeEvent.Action Property

public System.Data.DataRowAction Action {get;}

See Also

vdxExceptionTexts.ExceptionTextRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRowChangeEvent.Row Property

public vdxExceptionTexts.ExceptionTextRow Row {get;}

See Also

vdxExceptionTexts.ExceptionTextRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTextRowChangeEventHandler Delegate

public delegate void vdxExceptionTexts.ExceptionTextRowChangeEventHandler(
object sender,
ExceptionTextRowChangeEvent e
);

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable Class

For a list of all members of this type, see vdxExceptionTexts.ExceptionTypeDataTable Members.

System.Object
MarshalByValueComponent
DataTable
vdxExceptionTexts.ExceptionTypeDataTable

public class vdxExceptionTexts.ExceptionTypeDataTable : DataTable, IEnumerable

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionTexts.ExceptionTypeDataTable Members | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable Members

vdxExceptionTexts.ExceptionTypeDataTable overview

Public Instance Properties

CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
DataSet (inherited from DataTable) | Gets the DataSet that this table belongs to.
DefaultView (inherited from DataTable) | Gets a customized view of the table which may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that will return a value used to represent this table in the user interface.
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable .
TableName (inherited from DataTable) | Gets or sets the name of the DataTable .

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddExceptionTypeRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent .
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByExceptionTypeID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
LoadDataRow (inherited from DataTable) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
NewExceptionTypeRow |
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemoveExceptionTypeRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow .
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow .
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
ExceptionTypeRowChanged |
ExceptionTypeRowChanging |
ExceptionTypeRowDeleted |
ExceptionTypeRowDeleting |
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) |
GetRowType |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |

Protected Internal Instance Fields

fInitInProgress (inherited from DataTable) [To be supplied.]

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnPropertyChanging (inherited from DataTable) |
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.

Explicit Interface Implementations

IListSource.GetList (inherited from DataTable)
ISerializable.GetObjectData (inherited from DataTable)

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable Properties

The properties of the vdxExceptionTexts.ExceptionTypeDataTable class are listed below. For a complete list of vdxExceptionTexts.ExceptionTypeDataTable class members, see the vdxExceptionTexts.ExceptionTypeDataTable Members topic.

Public Instance Properties

CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
DataSet (inherited from DataTable) | Gets the DataSet that this table belongs to.
DefaultView (inherited from DataTable) | Gets a customized view of the table which may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that will return a value used to represent this table in the user interface.
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable .
TableName (inherited from DataTable) | Gets or sets the name of the DataTable .

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.Count Property

public int Count {get;}

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.Item Property

public vdxExceptionTexts.ExceptionTypeRow this[
int index
] {get;}

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable Methods

The methods of the vdxExceptionTexts.ExceptionTypeDataTable class are listed below. For a complete list of vdxExceptionTexts.ExceptionTypeDataTable class members, see the vdxExceptionTexts.ExceptionTypeDataTable Members topic.

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddExceptionTypeRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent .
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByExceptionTypeID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
LoadDataRow (inherited from DataTable) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
NewExceptionTypeRow |
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemoveExceptionTypeRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) |
GetRowType |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnPropertyChanging (inherited from DataTable) |
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.

Explicit Interface Implementations

IListSource.GetList (inherited from DataTable)
ISerializable.GetObjectData (inherited from DataTable)

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AddExceptionTypeRow Method

VDX Framework

vdxExceptionTexts.ExceptionTypeDataTable.AddExceptionTypeRow Method

Overload List

public void AddExceptionTypeRow(ExceptionTypeRow);

public ExceptionTypeRow AddExceptionTypeRow(string);

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.AddExceptionTypeRow Method (ExceptionTypeRow)

public void AddExceptionTypeRow(
ExceptionTypeRow row
);

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace | vdxExceptionTexts.ExceptionTypeDataTable.AddExceptionTypeRow Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.AddExceptionTypeRow Method (String)

public ExceptionTypeRow AddExceptionTypeRow(
string ExceptionTypeID
);

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace | vdxExceptionTexts.ExceptionTypeDataTable.AddExceptionTypeRow Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.Clone Method

public override DataTable Clone();

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.CreateInstance Method

protected override DataTable CreateInstance();

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.FindByExceptionTypeID Method

public ExceptionTypeRow FindByExceptionTypeID(
string ExceptionTypeID
);

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.GetRowType Method

protected override Type GetRowType();

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.NewExceptionTypeRow Method

public ExceptionTypeRow NewExceptionTypeRow();

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.NewRowFromBuilder Method

protected override DataRow NewRowFromBuilder(
DataRowBuilder builder
);

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.OnRowChanged Method

protected override void OnRowChanged(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.OnRowChanging Method

protected override void OnRowChanging(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.OnRowDeleted Method

protected override void OnRowDeleted(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.OnRowDeleting Method

protected override void OnRowDeleting(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.RemoveExceptionTypeRow Method

public void RemoveExceptionTypeRow(
ExceptionTypeRow row
);

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable Events

The events of the vdxExceptionTexts.ExceptionTypeDataTable class are listed below. For a complete list of vdxExceptionTexts.ExceptionTypeDataTable class members, see the vdxExceptionTexts.ExceptionTypeDataTable Members topic.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow .
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow .
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
ExceptionTypeRowChanged |
ExceptionTypeRowChanging |
ExceptionTypeRowDeleted |
ExceptionTypeRowDeleting |
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.ExceptionTypeRowChanged Event

public event ExceptionTypeRowChangeEventHandler ExceptionTypeRowChanged;

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.ExceptionTypeRowChanging Event

public event ExceptionTypeRowChangeEventHandler ExceptionTypeRowChanging;

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.ExceptionTypeRowDeleted Event

public event ExceptionTypeRowChangeEventHandler ExceptionTypeRowDeleted;

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeDataTable.ExceptionTypeRowDeleting Event

public event ExceptionTypeRowChangeEventHandler ExceptionTypeRowDeleting;

See Also

vdxExceptionTexts.ExceptionTypeDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeRow Class

For a list of all members of this type, see vdxExceptionTexts.ExceptionTypeRow Members.

System.Object
DataRow
vdxExceptionTexts.ExceptionTypeRow

public class vdxExceptionTexts.ExceptionTypeRow : DataRow

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionTexts.ExceptionTypeRow Members | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeRow Members

vdxExceptionTexts.ExceptionTypeRow overview

Public Instance Properties

ExceptionTypeID |
HasErrors (inherited from DataRow) | Gets a value indicating whether there are errors in a row.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all of the values for this row through an array.
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row in regard to its relationship to the DataRowCollection .
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Begins an edit operation on a DataRowobject.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row, including the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow .
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetExceptionInfoRows |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value indicating whether a specified version exists.
IsNull (inherited from DataRow) | Overloaded. Gets a value indicating whether the column at the specified index contains a null value.
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow .
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the the value of the specified DataColumn to a null value.

See Also

vdxExceptionTexts.ExceptionTypeRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeRow Properties

The properties of the vdxExceptionTexts.ExceptionTypeRow class are listed below. For a complete list of vdxExceptionTexts.ExceptionTypeRow class members, see the vdxExceptionTexts.ExceptionTypeRow Members topic.

Public Instance Properties

ExceptionTypeID |
HasErrors (inherited from DataRow) | Gets a value indicating whether there are errors in a row.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all of the values for this row through an array.
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row in regard to its relationship to the DataRowCollection .
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.

See Also

vdxExceptionTexts.ExceptionTypeRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeRow.ExceptionTypeID Property

public string ExceptionTypeID {get; set;}

See Also

vdxExceptionTexts.ExceptionTypeRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeRow Methods

The methods of the vdxExceptionTexts.ExceptionTypeRow class are listed below. For a complete list of vdxExceptionTexts.ExceptionTypeRow class members, see the vdxExceptionTexts.ExceptionTypeRow Members topic.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Begins an edit operation on a DataRowobject.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row, including the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow .
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetExceptionInfoRows |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value indicating whether a specified version exists.
IsNull (inherited from DataRow) | Overloaded. Gets a value indicating whether the column at the specified index contains a null value.
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow .
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the the value of the specified DataColumn to a null value.

See Also

vdxExceptionTexts.ExceptionTypeRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeRow.GetExceptionInfoRows Method

public ExceptionInfoRow[] GetExceptionInfoRows();

See Also

vdxExceptionTexts.ExceptionTypeRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeRowChangeEvent Class

For a list of all members of this type, see vdxExceptionTexts.ExceptionTypeRowChangeEvent Members.

System.Object
EventArgs
vdxExceptionTexts.ExceptionTypeRowChangeEvent

public class vdxExceptionTexts.ExceptionTypeRowChangeEvent : EventArgs

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionTexts.ExceptionTypeRowChangeEvent Members | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeRowChangeEvent Members

vdxExceptionTexts.ExceptionTypeRowChangeEvent overview

Public Instance Constructors

vdxExceptionTexts.ExceptionTypeRowChangeEvent Constructor

Public Instance Properties

Action
Row

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxExceptionTexts.ExceptionTypeRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeRowChangeEvent Constructor

public vdxExceptionTexts.ExceptionTypeRowChangeEvent(
ExceptionTypeRow row,
DataRowAction action
);

See Also

vdxExceptionTexts.ExceptionTypeRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeRowChangeEvent Properties

The properties of the vdxExceptionTexts.ExceptionTypeRowChangeEvent class are listed below. For a complete list of vdxExceptionTexts.ExceptionTypeRowChangeEvent class members, see the vdxExceptionTexts.ExceptionTypeRowChangeEvent Members topic.

Public Instance Properties

Action
Row

See Also

vdxExceptionTexts.ExceptionTypeRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeRowChangeEvent.Action Property

public System.Data.DataRowAction Action {get;}

See Also

vdxExceptionTexts.ExceptionTypeRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeRowChangeEvent.Row Property

public vdxExceptionTexts.ExceptionTypeRow Row {get;}

See Also

vdxExceptionTexts.ExceptionTypeRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.ExceptionTypeRowChangeEventHandler Delegate

public delegate void vdxExceptionTexts.ExceptionTypeRowChangeEventHandler(
object sender,
ExceptionTypeRowChangeEvent e
);

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable Class

For a list of all members of this type, see vdxExceptionTexts.LanguageDataTable Members.

System.Object
MarshalByValueComponent
DataTable
vdxExceptionTexts.LanguageDataTable

public class vdxExceptionTexts.LanguageDataTable : DataTable, IEnumerable

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionTexts.LanguageDataTable Members | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable Members

vdxExceptionTexts.LanguageDataTable overview

Public Instance Properties

CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
DataSet (inherited from DataTable) | Gets the DataSet that this table belongs to.
DefaultView (inherited from DataTable) | Gets a customized view of the table which may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that will return a value used to represent this table in the user interface.
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable .
TableName (inherited from DataTable) | Gets or sets the name of the DataTable .

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddLanguageRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent .
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByLanguageID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
LoadDataRow (inherited from DataTable) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
NewLanguageRow |
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemoveLanguageRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow .
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow .
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
LanguageRowChanged |
LanguageRowChanging |
LanguageRowDeleted |
LanguageRowDeleting |
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) |
GetRowType |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |

Protected Internal Instance Fields

fInitInProgress (inherited from DataTable) [To be supplied.]

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnPropertyChanging (inherited from DataTable) |
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.

Explicit Interface Implementations

IListSource.GetList (inherited from DataTable)
ISerializable.GetObjectData (inherited from DataTable)

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable Properties

The properties of the vdxExceptionTexts.LanguageDataTable class are listed below. For a complete list of vdxExceptionTexts.LanguageDataTable class members, see the vdxExceptionTexts.LanguageDataTable Members topic.

Public Instance Properties

CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
DataSet (inherited from DataTable) | Gets the DataSet that this table belongs to.
DefaultView (inherited from DataTable) | Gets a customized view of the table which may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that will return a value used to represent this table in the user interface.
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable .
TableName (inherited from DataTable) | Gets or sets the name of the DataTable .

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.Count Property

public int Count {get;}

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.Item Property

public vdxExceptionTexts.LanguageRow this[
int index
] {get;}

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable Methods

The methods of the vdxExceptionTexts.LanguageDataTable class are listed below. For a complete list of vdxExceptionTexts.LanguageDataTable class members, see the vdxExceptionTexts.LanguageDataTable Members topic.

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddLanguageRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent .
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByLanguageID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
LoadDataRow (inherited from DataTable) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
NewLanguageRow |
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemoveLanguageRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) |
GetRowType |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnPropertyChanging (inherited from DataTable) |
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.

Explicit Interface Implementations

IListSource.GetList (inherited from DataTable)
ISerializable.GetObjectData (inherited from DataTable)

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AddLanguageRow Method

VDX Framework

vdxExceptionTexts.LanguageDataTable.AddLanguageRow Method

Overload List

public void AddLanguageRow(LanguageRow);

public LanguageRow AddLanguageRow(string);

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.AddLanguageRow Method (LanguageRow)

public void AddLanguageRow(
LanguageRow row
);

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace | vdxExceptionTexts.LanguageDataTable.AddLanguageRow Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.AddLanguageRow Method (String)

public LanguageRow AddLanguageRow(
string LanguageID
);

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace | vdxExceptionTexts.LanguageDataTable.AddLanguageRow Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.Clone Method

public override DataTable Clone();

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.CreateInstance Method

protected override DataTable CreateInstance();

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.FindByLanguageID Method

public LanguageRow FindByLanguageID(
string LanguageID
);

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.GetRowType Method

protected override Type GetRowType();

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.NewLanguageRow Method

public LanguageRow NewLanguageRow();

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.NewRowFromBuilder Method

protected override DataRow NewRowFromBuilder(
DataRowBuilder builder
);

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.OnRowChanged Method

protected override void OnRowChanged(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.OnRowChanging Method

protected override void OnRowChanging(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.OnRowDeleted Method

protected override void OnRowDeleted(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.OnRowDeleting Method

protected override void OnRowDeleting(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.RemoveLanguageRow Method

public void RemoveLanguageRow(
LanguageRow row
);

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable Events

The events of the vdxExceptionTexts.LanguageDataTable class are listed below. For a complete list of vdxExceptionTexts.LanguageDataTable class members, see the vdxExceptionTexts.LanguageDataTable Members topic.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow .
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow .
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
LanguageRowChanged |
LanguageRowChanging |
LanguageRowDeleted |
LanguageRowDeleting |
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.LanguageRowChanged Event

public event LanguageRowChangeEventHandler LanguageRowChanged;

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.LanguageRowChanging Event

public event LanguageRowChangeEventHandler LanguageRowChanging;

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.LanguageRowDeleted Event

public event LanguageRowChangeEventHandler LanguageRowDeleted;

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageDataTable.LanguageRowDeleting Event

public event LanguageRowChangeEventHandler LanguageRowDeleting;

See Also

vdxExceptionTexts.LanguageDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageRow Class

For a list of all members of this type, see vdxExceptionTexts.LanguageRow Members.

System.Object
DataRow
vdxExceptionTexts.LanguageRow

public class vdxExceptionTexts.LanguageRow : DataRow

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionTexts.LanguageRow Members | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageRow Members

vdxExceptionTexts.LanguageRow overview

Public Instance Properties

HasErrors (inherited from DataRow) | Gets a value indicating whether there are errors in a row.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all of the values for this row through an array.
LanguageID |
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row in regard to its relationship to the DataRowCollection .
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Begins an edit operation on a DataRowobject.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row, including the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow .
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetExceptionTextRows |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
GetvdxExceptionDialogRows |
HasVersion (inherited from DataRow) | Gets a value indicating whether a specified version exists.
IsNull (inherited from DataRow) | Overloaded. Gets a value indicating whether the column at the specified index contains a null value.
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow .
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the the value of the specified DataColumn to a null value.

See Also

vdxExceptionTexts.LanguageRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageRow Properties

The properties of the vdxExceptionTexts.LanguageRow class are listed below. For a complete list of vdxExceptionTexts.LanguageRow class members, see the vdxExceptionTexts.LanguageRow Members topic.

Public Instance Properties

HasErrors (inherited from DataRow) | Gets a value indicating whether there are errors in a row.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all of the values for this row through an array.
LanguageID |
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row in regard to its relationship to the DataRowCollection .
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.

See Also

vdxExceptionTexts.LanguageRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageRow.LanguageID Property

public string LanguageID {get; set;}

See Also

vdxExceptionTexts.LanguageRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageRow Methods

The methods of the vdxExceptionTexts.LanguageRow class are listed below. For a complete list of vdxExceptionTexts.LanguageRow class members, see the vdxExceptionTexts.LanguageRow Members topic.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Begins an edit operation on a DataRowobject.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row, including the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow .
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetExceptionTextRows |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
GetvdxExceptionDialogRows |
HasVersion (inherited from DataRow) | Gets a value indicating whether a specified version exists.
IsNull (inherited from DataRow) | Overloaded. Gets a value indicating whether the column at the specified index contains a null value.
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow .
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the the value of the specified DataColumn to a null value.

See Also

vdxExceptionTexts.LanguageRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageRow.GetExceptionTextRows Method

public ExceptionTextRow[] GetExceptionTextRows();

See Also

vdxExceptionTexts.LanguageRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageRow.GetvdxExceptionDialogRows Method

public vdxExceptionDialogRow[] GetvdxExceptionDialogRows();

See Also

vdxExceptionTexts.LanguageRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageRowChangeEvent Class

For a list of all members of this type, see vdxExceptionTexts.LanguageRowChangeEvent Members.

System.Object
EventArgs
vdxExceptionTexts.LanguageRowChangeEvent

public class vdxExceptionTexts.LanguageRowChangeEvent : EventArgs

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionTexts.LanguageRowChangeEvent Members | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageRowChangeEvent Members

vdxExceptionTexts.LanguageRowChangeEvent overview

Public Instance Constructors

vdxExceptionTexts.LanguageRowChangeEvent Constructor

Public Instance Properties

Action
Row

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxExceptionTexts.LanguageRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageRowChangeEvent Constructor

public vdxExceptionTexts.LanguageRowChangeEvent(
LanguageRow row,
DataRowAction action
);

See Also

vdxExceptionTexts.LanguageRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageRowChangeEvent Properties

The properties of the vdxExceptionTexts.LanguageRowChangeEvent class are listed below. For a complete list of vdxExceptionTexts.LanguageRowChangeEvent class members, see the vdxExceptionTexts.LanguageRowChangeEvent Members topic.

Public Instance Properties

Action
Row

See Also

vdxExceptionTexts.LanguageRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageRowChangeEvent.Action Property

public System.Data.DataRowAction Action {get;}

See Also

vdxExceptionTexts.LanguageRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageRowChangeEvent.Row Property

public vdxExceptionTexts.LanguageRow Row {get;}

See Also

vdxExceptionTexts.LanguageRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.LanguageRowChangeEventHandler Delegate

public delegate void vdxExceptionTexts.LanguageRowChangeEventHandler(
object sender,
LanguageRowChangeEvent e
);

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable Class

For a list of all members of this type, see vdxExceptionTexts.SeverityDataTable Members.

System.Object
MarshalByValueComponent
DataTable
vdxExceptionTexts.SeverityDataTable

public class vdxExceptionTexts.SeverityDataTable : DataTable, IEnumerable

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionTexts.SeverityDataTable Members | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable Members

vdxExceptionTexts.SeverityDataTable overview

Public Instance Properties

CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
DataSet (inherited from DataTable) | Gets the DataSet that this table belongs to.
DefaultView (inherited from DataTable) | Gets a customized view of the table which may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that will return a value used to represent this table in the user interface.
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable .
TableName (inherited from DataTable) | Gets or sets the name of the DataTable .

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddSeverityRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent .
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindBySeverityID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
LoadDataRow (inherited from DataTable) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
NewSeverityRow |
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemoveSeverityRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow .
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow .
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.
SeverityRowChanged |
SeverityRowChanging |
SeverityRowDeleted |
SeverityRowDeleting |

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) |
GetRowType |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |

Protected Internal Instance Fields

fInitInProgress (inherited from DataTable) [To be supplied.]

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnPropertyChanging (inherited from DataTable) |
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.

Explicit Interface Implementations

IListSource.GetList (inherited from DataTable)
ISerializable.GetObjectData (inherited from DataTable)

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable Properties

The properties of the vdxExceptionTexts.SeverityDataTable class are listed below. For a complete list of vdxExceptionTexts.SeverityDataTable class members, see the vdxExceptionTexts.SeverityDataTable Members topic.

Public Instance Properties

CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
DataSet (inherited from DataTable) | Gets the DataSet that this table belongs to.
DefaultView (inherited from DataTable) | Gets a customized view of the table which may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that will return a value used to represent this table in the user interface.
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable .
TableName (inherited from DataTable) | Gets or sets the name of the DataTable .

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.Count Property

public int Count {get;}

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.Item Property

public vdxExceptionTexts.SeverityRow this[
int index
] {get;}

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable Methods

The methods of the vdxExceptionTexts.SeverityDataTable class are listed below. For a complete list of vdxExceptionTexts.SeverityDataTable class members, see the vdxExceptionTexts.SeverityDataTable Members topic.

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddSeverityRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent .
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindBySeverityID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
LoadDataRow (inherited from DataTable) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
NewSeverityRow |
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemoveSeverityRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) |
GetRowType |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnPropertyChanging (inherited from DataTable) |
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.

Explicit Interface Implementations

IListSource.GetList (inherited from DataTable)
ISerializable.GetObjectData (inherited from DataTable)

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AddSeverityRow Method

VDX Framework

vdxExceptionTexts.SeverityDataTable.AddSeverityRow Method

Overload List

public void AddSeverityRow(SeverityRow);

public SeverityRow AddSeverityRow(int,string);

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.AddSeverityRow Method (SeverityRow)

public void AddSeverityRow(
SeverityRow row
);

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace | vdxExceptionTexts.SeverityDataTable.AddSeverityRow Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.AddSeverityRow Method (Int32, String)

public SeverityRow AddSeverityRow(
int SeverityID,
string SeverityText
);

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace | vdxExceptionTexts.SeverityDataTable.AddSeverityRow Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.Clone Method

public override DataTable Clone();

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.CreateInstance Method

protected override DataTable CreateInstance();

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.FindBySeverityID Method

public SeverityRow FindBySeverityID(
int SeverityID
);

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.GetRowType Method

protected override Type GetRowType();

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.NewRowFromBuilder Method

protected override DataRow NewRowFromBuilder(
DataRowBuilder builder
);

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.NewSeverityRow Method

public SeverityRow NewSeverityRow();

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.OnRowChanged Method

protected override void OnRowChanged(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.OnRowChanging Method

protected override void OnRowChanging(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.OnRowDeleted Method

protected override void OnRowDeleted(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.OnRowDeleting Method

protected override void OnRowDeleting(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.RemoveSeverityRow Method

public void RemoveSeverityRow(
SeverityRow row
);

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable Events

The events of the vdxExceptionTexts.SeverityDataTable class are listed below. For a complete list of vdxExceptionTexts.SeverityDataTable class members, see the vdxExceptionTexts.SeverityDataTable Members topic.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow .
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow .
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.
SeverityRowChanged |
SeverityRowChanging |
SeverityRowDeleted |
SeverityRowDeleting |

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.SeverityRowChanged Event

public event SeverityRowChangeEventHandler SeverityRowChanged;

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.SeverityRowChanging Event

public event SeverityRowChangeEventHandler SeverityRowChanging;

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.SeverityRowDeleted Event

public event SeverityRowChangeEventHandler SeverityRowDeleted;

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityDataTable.SeverityRowDeleting Event

public event SeverityRowChangeEventHandler SeverityRowDeleting;

See Also

vdxExceptionTexts.SeverityDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityRow Class

For a list of all members of this type, see vdxExceptionTexts.SeverityRow Members.

System.Object
DataRow
vdxExceptionTexts.SeverityRow

public class vdxExceptionTexts.SeverityRow : DataRow

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionTexts.SeverityRow Members | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityRow Members

vdxExceptionTexts.SeverityRow overview

Public Instance Properties

HasErrors (inherited from DataRow) | Gets a value indicating whether there are errors in a row.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all of the values for this row through an array.
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row in regard to its relationship to the DataRowCollection .
SeverityID |
SeverityText |
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Begins an edit operation on a DataRowobject.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row, including the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow .
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetExceptionInfoRows |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value indicating whether a specified version exists.
IsNull (inherited from DataRow) | Overloaded. Gets a value indicating whether the column at the specified index contains a null value.
IsSeverityTextNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow .
SetSeverityTextNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the the value of the specified DataColumn to a null value.

See Also

vdxExceptionTexts.SeverityRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityRow Properties

The properties of the vdxExceptionTexts.SeverityRow class are listed below. For a complete list of vdxExceptionTexts.SeverityRow class members, see the vdxExceptionTexts.SeverityRow Members topic.

Public Instance Properties

HasErrors (inherited from DataRow) | Gets a value indicating whether there are errors in a row.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all of the values for this row through an array.
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row in regard to its relationship to the DataRowCollection .
SeverityID |
SeverityText |
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.

See Also

vdxExceptionTexts.SeverityRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityRow.SeverityID Property

public int SeverityID {get; set;}

See Also

vdxExceptionTexts.SeverityRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityRow.SeverityText Property

public string SeverityText {get; set;}

See Also

vdxExceptionTexts.SeverityRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityRow Methods

The methods of the vdxExceptionTexts.SeverityRow class are listed below. For a complete list of vdxExceptionTexts.SeverityRow class members, see the vdxExceptionTexts.SeverityRow Members topic.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Begins an edit operation on a DataRowobject.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row, including the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow .
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetExceptionInfoRows |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value indicating whether a specified version exists.
IsNull (inherited from DataRow) | Overloaded. Gets a value indicating whether the column at the specified index contains a null value.
IsSeverityTextNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow .
SetSeverityTextNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the the value of the specified DataColumn to a null value.

See Also

vdxExceptionTexts.SeverityRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityRow.GetExceptionInfoRows Method

public ExceptionInfoRow[] GetExceptionInfoRows();

See Also

vdxExceptionTexts.SeverityRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityRow.IsSeverityTextNull Method

public bool IsSeverityTextNull();

See Also

vdxExceptionTexts.SeverityRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityRow.SetSeverityTextNull Method

public void SetSeverityTextNull();

See Also

vdxExceptionTexts.SeverityRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityRowChangeEvent Class

For a list of all members of this type, see vdxExceptionTexts.SeverityRowChangeEvent Members.

System.Object
EventArgs
vdxExceptionTexts.SeverityRowChangeEvent

public class vdxExceptionTexts.SeverityRowChangeEvent : EventArgs

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionTexts.SeverityRowChangeEvent Members | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityRowChangeEvent Members

vdxExceptionTexts.SeverityRowChangeEvent overview

Public Instance Constructors

vdxExceptionTexts.SeverityRowChangeEvent Constructor

Public Instance Properties

Action
Row

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxExceptionTexts.SeverityRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityRowChangeEvent Constructor

public vdxExceptionTexts.SeverityRowChangeEvent(
SeverityRow row,
DataRowAction action
);

See Also

vdxExceptionTexts.SeverityRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityRowChangeEvent Properties

The properties of the vdxExceptionTexts.SeverityRowChangeEvent class are listed below. For a complete list of vdxExceptionTexts.SeverityRowChangeEvent class members, see the vdxExceptionTexts.SeverityRowChangeEvent Members topic.

Public Instance Properties

Action
Row

See Also

vdxExceptionTexts.SeverityRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityRowChangeEvent.Action Property

public System.Data.DataRowAction Action {get;}

See Also

vdxExceptionTexts.SeverityRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityRowChangeEvent.Row Property

public vdxExceptionTexts.SeverityRow Row {get;}

See Also

vdxExceptionTexts.SeverityRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.SeverityRowChangeEventHandler Delegate

public delegate void vdxExceptionTexts.SeverityRowChangeEventHandler(
object sender,
SeverityRowChangeEvent e
);

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable Class

For a list of all members of this type, see vdxExceptionTexts.vdxExceptionDialogDataTable Members.

System.Object
MarshalByValueComponent
DataTable
vdxExceptionTexts.vdxExceptionDialogDataTable

public class vdxExceptionTexts.vdxExceptionDialogDataTable : DataTable, IEnumerable

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Members | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable Members

vdxExceptionTexts.vdxExceptionDialogDataTable overview

Public Instance Properties

CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
DataSet (inherited from DataTable) | Gets the DataSet that this table belongs to.
DefaultView (inherited from DataTable) | Gets a customized view of the table which may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that will return a value used to represent this table in the user interface.
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable .
TableName (inherited from DataTable) | Gets or sets the name of the DataTable .

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddvdxExceptionDialogRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent .
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByContextKeyLanguageID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
LoadDataRow (inherited from DataTable) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
NewvdxExceptionDialogRow |
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemovevdxExceptionDialogRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow .
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow .
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.
vdxExceptionDialogRowChanged |
vdxExceptionDialogRowChanging |
vdxExceptionDialogRowDeleted |
vdxExceptionDialogRowDeleting |

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) |
GetRowType |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |

Protected Internal Instance Fields

fInitInProgress (inherited from DataTable) [To be supplied.]

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnPropertyChanging (inherited from DataTable) |
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.

Explicit Interface Implementations

IListSource.GetList (inherited from DataTable)
ISerializable.GetObjectData (inherited from DataTable)

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable Properties

The properties of the vdxExceptionTexts.vdxExceptionDialogDataTable class are listed below. For a complete list of vdxExceptionTexts.vdxExceptionDialogDataTable class members, see the vdxExceptionTexts.vdxExceptionDialogDataTable Members topic.

Public Instance Properties

CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
DataSet (inherited from DataTable) | Gets the DataSet that this table belongs to.
DefaultView (inherited from DataTable) | Gets a customized view of the table which may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that will return a value used to represent this table in the user interface.
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML represenation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable .
TableName (inherited from DataTable) | Gets or sets the name of the DataTable .

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.Count Property

public int Count {get;}

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.Item Property

public vdxExceptionTexts.vdxExceptionDialogRow this[
int index
] {get;}

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable Methods

The methods of the vdxExceptionTexts.vdxExceptionDialogDataTable class are listed below. For a complete list of vdxExceptionTexts.vdxExceptionDialogDataTable class members, see the vdxExceptionTexts.vdxExceptionDialogDataTable Members topic.

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddvdxExceptionDialogRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent .
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByContextKeyLanguageID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
LoadDataRow (inherited from DataTable) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
NewvdxExceptionDialogRow |
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemovevdxExceptionDialogRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) |
GetRowType |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnPropertyChanging (inherited from DataTable) |
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.

Explicit Interface Implementations

IListSource.GetList (inherited from DataTable)
ISerializable.GetObjectData (inherited from DataTable)

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AddvdxExceptionDialogRow Method

VDX Framework

vdxExceptionTexts.vdxExceptionDialogDataTable.AddvdxExceptionDialogRow Method

Overload List

public void AddvdxExceptionDialogRow(vdxExceptionDialogRow);

public vdxExceptionDialogRow AddvdxExceptionDialogRow(string,LanguageRow,string);

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.AddvdxExceptionDialogRow Method (vdxExceptionDialogRow)

public void AddvdxExceptionDialogRow(
vdxExceptionDialogRow row
);

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace | vdxExceptionTexts.vdxExceptionDialogDataTable.AddvdxExceptionDialogRow Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.AddvdxExceptionDialogRow Method (String, LanguageRow, String)

public vdxExceptionDialogRow AddvdxExceptionDialogRow(
string ContextKey,
LanguageRow parentLanguageRowByLanguagevdxExceptionDialog,
string Text
);

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace | vdxExceptionTexts.vdxExceptionDialogDataTable.AddvdxExceptionDialogRow Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.Clone Method

public override DataTable Clone();

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.CreateInstance Method

protected override DataTable CreateInstance();

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.FindByContextKeyLanguageID Method

public vdxExceptionDialogRow FindByContextKeyLanguageID(
string ContextKey,
string LanguageID
);

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.GetRowType Method

protected override Type GetRowType();

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.NewRowFromBuilder Method

protected override DataRow NewRowFromBuilder(
DataRowBuilder builder
);

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.NewvdxExceptionDialogRow Method

public vdxExceptionDialogRow NewvdxExceptionDialogRow();

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.OnRowChanged Method

protected override void OnRowChanged(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.OnRowChanging Method

protected override void OnRowChanging(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.OnRowDeleted Method

protected override void OnRowDeleted(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.OnRowDeleting Method

protected override void OnRowDeleting(
DataRowChangeEventArgs e
);

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.RemovevdxExceptionDialogRow Method

public void RemovevdxExceptionDialogRow(
vdxExceptionDialogRow row
);

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable Events

The events of the vdxExceptionTexts.vdxExceptionDialogDataTable class are listed below. For a complete list of vdxExceptionTexts.vdxExceptionDialogDataTable class members, see the vdxExceptionTexts.vdxExceptionDialogDataTable Members topic.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow .
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow .
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.
vdxExceptionDialogRowChanged |
vdxExceptionDialogRowChanging |
vdxExceptionDialogRowDeleted |
vdxExceptionDialogRowDeleting |

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.vdxExceptionDialogRowChanged Event

public event vdxExceptionDialogRowChangeEventHandler vdxExceptionDialogRowChanged;

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.vdxExceptionDialogRowChanging Event

public event vdxExceptionDialogRowChangeEventHandler vdxExceptionDialogRowChanging;

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.vdxExceptionDialogRowDeleted Event

public event vdxExceptionDialogRowChangeEventHandler vdxExceptionDialogRowDeleted;

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogDataTable.vdxExceptionDialogRowDeleting Event

public event vdxExceptionDialogRowChangeEventHandler vdxExceptionDialogRowDeleting;

See Also

vdxExceptionTexts.vdxExceptionDialogDataTable Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogRow Class

For a list of all members of this type, see vdxExceptionTexts.vdxExceptionDialogRow Members.

System.Object
DataRow
vdxExceptionTexts.vdxExceptionDialogRow

public class vdxExceptionTexts.vdxExceptionDialogRow : DataRow

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionTexts.vdxExceptionDialogRow Members | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogRow Members

vdxExceptionTexts.vdxExceptionDialogRow overview

Public Instance Properties

ContextKey |
HasErrors (inherited from DataRow) | Gets a value indicating whether there are errors in a row.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all of the values for this row through an array.
LanguageID |
LanguageRow |
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row in regard to its relationship to the DataRowCollection .
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.
Text |

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Begins an edit operation on a DataRowobject.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row, including the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow .
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value indicating whether a specified version exists.
IsNull (inherited from DataRow) | Overloaded. Gets a value indicating whether the column at the specified index contains a null value.
IsTextNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow .
SetTextNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the the value of the specified DataColumn to a null value.

See Also

vdxExceptionTexts.vdxExceptionDialogRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogRow Properties

The properties of the vdxExceptionTexts.vdxExceptionDialogRow class are listed below. For a complete list of vdxExceptionTexts.vdxExceptionDialogRow class members, see the vdxExceptionTexts.vdxExceptionDialogRow Members topic.

Public Instance Properties

ContextKey |
HasErrors (inherited from DataRow) | Gets a value indicating whether there are errors in a row.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all of the values for this row through an array.
LanguageID |
LanguageRow |
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row in regard to its relationship to the DataRowCollection .
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.
Text |

See Also

vdxExceptionTexts.vdxExceptionDialogRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogRow.ContextKey Property

public string ContextKey {get; set;}

See Also

vdxExceptionTexts.vdxExceptionDialogRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogRow.LanguageID Property

public string LanguageID {get; set;}

See Also

vdxExceptionTexts.vdxExceptionDialogRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogRow.LanguageRow Property

public vdxExceptionTexts.LanguageRow LanguageRow {get; set;}

See Also

vdxExceptionTexts.vdxExceptionDialogRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogRow.Text Property

public string Text {get; set;}

See Also

vdxExceptionTexts.vdxExceptionDialogRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogRow Methods

The methods of the vdxExceptionTexts.vdxExceptionDialogRow class are listed below. For a complete list of vdxExceptionTexts.vdxExceptionDialogRow class members, see the vdxExceptionTexts.vdxExceptionDialogRow Members topic.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Begins an edit operation on a DataRowobject.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row, including the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow .
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value indicating whether a specified version exists.
IsNull (inherited from DataRow) | Overloaded. Gets a value indicating whether the column at the specified index contains a null value.
IsTextNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow .
SetTextNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the the value of the specified DataColumn to a null value.

See Also

vdxExceptionTexts.vdxExceptionDialogRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogRow.IsTextNull Method

public bool IsTextNull();

See Also

vdxExceptionTexts.vdxExceptionDialogRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogRow.SetTextNull Method

public void SetTextNull();

See Also

vdxExceptionTexts.vdxExceptionDialogRow Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogRowChangeEvent Class

For a list of all members of this type, see vdxExceptionTexts.vdxExceptionDialogRowChangeEvent Members.

System.Object
EventArgs
vdxExceptionTexts.vdxExceptionDialogRowChangeEvent

public class vdxExceptionTexts.vdxExceptionDialogRowChangeEvent : EventArgs

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxExceptionTexts.vdxExceptionDialogRowChangeEvent Members | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogRowChangeEvent Members

vdxExceptionTexts.vdxExceptionDialogRowChangeEvent overview

Public Instance Constructors

vdxExceptionTexts.vdxExceptionDialogRowChangeEvent Constructor

Public Instance Properties

Action
Row

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxExceptionTexts.vdxExceptionDialogRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogRowChangeEvent Constructor

public vdxExceptionTexts.vdxExceptionDialogRowChangeEvent(
vdxExceptionDialogRow row,
DataRowAction action
);

See Also

vdxExceptionTexts.vdxExceptionDialogRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogRowChangeEvent Properties

The properties of the vdxExceptionTexts.vdxExceptionDialogRowChangeEvent class are listed below. For a complete list of vdxExceptionTexts.vdxExceptionDialogRowChangeEvent class members, see the vdxExceptionTexts.vdxExceptionDialogRowChangeEvent Members topic.

Public Instance Properties

Action
Row

See Also

vdxExceptionTexts.vdxExceptionDialogRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogRowChangeEvent.Action Property

public System.Data.DataRowAction Action {get;}

See Also

vdxExceptionTexts.vdxExceptionDialogRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogRowChangeEvent.Row Property

public vdxExceptionTexts.vdxExceptionDialogRow Row {get;}

See Also

vdxExceptionTexts.vdxExceptionDialogRowChangeEvent Class | Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionTexts.vdxExceptionDialogRowChangeEventHandler Delegate

public delegate void vdxExceptionTexts.vdxExceptionDialogRowChangeEventHandler(
object sender,
vdxExceptionDialogRowChangeEvent e
);

Requirements

Namespace: Deag.Vdx.Common.ErrorTextes

Assembly: vdxCommon (in vdxCommon.dll)

See Also

Deag.Vdx.Common.ErrorTextes Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Common.Exceptions

VDX Framework

Deag.Vdx.Common.Exceptions Namespace

Library of all vdxException and their derivates.

Classes

Class | Description
vdxException | Implements the base functionality required by vdxExeption.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException Class

Implements the base functionality required by vdxExeption.

For a list of all members of this type, see vdxException Members.

System.Object
Exception
ApplicationException
vdxException

public class vdxException : ApplicationException

Requirements

Namespace: Deag.Vdx.Common.Exceptions

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxException Members | Deag.Vdx.Common.Exceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException Members

vdxException overview

Public Instance Constructors

vdxException Overloaded. Initializes a new instance of the vdxException class.

Public Instance Properties

Arguments | Gets/sets the collection of arguments passed to the error message.
Caption | Gets the error message text.
CustomMessage | Gets the error message text.
ErrorTime | Gets the time of the error.
ExceptionId | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName | Gets the name of the machine where the error occured.
Message | Gets the localized message.
Severity | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Encapsulate | Encapsulates the vdxException object into a SoapException.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMessage | Sets the message.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.
Trace | Traces the error text to the attached TraceListeners.

Protected Instance Constructors

vdxException Overloaded. Initializes a new instance of the vdxException class.

Protected Instance Fields

arguments Holds the argument for the vdxException.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException Constructor

Initializes a new instance of the vdxException class.

Overload List

Initializes a new instance of the vdxException class.

protected vdxException();

Initializes a new instance of the vdxException class using the exception ID.

public vdxException(int);

Initializes a new instance of the vdxException class.

public vdxException(int,vdxErrorSeverity);

Initializes a new instance of the vdxException class.

public vdxException(int,vdxErrorSeverity,Exception);

Initializes a new instance of the vdxException class.

public vdxException(int,vdxErrorSeverity,Exception,string);

Initializes a new instance of the vdxException class.

public vdxException(int,vdxErrorSeverity,Exception,string[]);

Initializes a new instance of the vdxException class with the specified message.

public vdxException(string);

Initializes a new instance of the vdxException class with the specified message.

public vdxException(string,Exception);

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException Constructor ()

Initializes a new instance of the vdxException class.

protected vdxException();

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace | vdxException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException Constructor (String)

Initializes a new instance of the vdxException class with the specified message.

public vdxException(
string message
);

Parameters

message
The message of the exception.

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace | vdxException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException Constructor (String, Exception)

Initializes a new instance of the vdxException class with the specified message.

public vdxException(
string message,
Exception innerException
);

Parameters

message
The message of the exception.
innerException
The exception causing this exception.

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace | vdxException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException Constructor (Int32)

Initializes a new instance of the vdxException class using the exception ID.

public vdxException(
int exceptionId
);

Parameters

exceptionId
The exception ID.

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace | vdxException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException Constructor (Int32, vdxErrorSeverity)

Initializes a new instance of the vdxException class.

public vdxException(
int exceptionId,
vdxErrorSeverity severity
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace | vdxException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException Constructor (Int32, vdxErrorSeverity, Exception)

Initializes a new instance of the vdxException class.

public vdxException(
int exceptionId,
vdxErrorSeverity severity,
Exception inner
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.
inner
The inner exception.

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace | vdxException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException Constructor (Int32, vdxErrorSeverity, Exception, String[])

Initializes a new instance of the vdxException class.

public vdxException(
int exceptionId,
vdxErrorSeverity severity,
Exception inner,
string[] arguments
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.
inner
The inner exception.
arguments
The arguments.

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace | vdxException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException Constructor (Int32, vdxErrorSeverity, Exception, String)

Initializes a new instance of the vdxException class.

public vdxException(
int exceptionId,
vdxErrorSeverity severity,
Exception inner,
string argument
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.
inner
The inner exception.
argument
The argument.

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace | vdxException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException Fields

The fields of the vdxException class are listed below. For a complete list of vdxException class members, see the vdxException Members topic.

Protected Instance Fields

arguments Holds the argument for the vdxException.

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException.Arguments Property

Gets/sets the collection of arguments passed to the error message.

public string[] Arguments {get; set;}

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException Properties

The properties of the vdxException class are listed below. For a complete list of vdxException class members, see the vdxException Members topic.

Public Instance Properties

Arguments | Gets/sets the collection of arguments passed to the error message.
Caption | Gets the error message text.
CustomMessage | Gets the error message text.
ErrorTime | Gets the time of the error.
ExceptionId | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName | Gets the name of the machine where the error occured.
Message | Gets the localized message.
Severity | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException.Caption Property

Gets the error message text.

public string Caption {get; set;}

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException.CustomMessage Property

Gets the error message text.

public string CustomMessage {get;}

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException.ErrorTime Property

Gets the time of the error.

public System.DateTime ErrorTime {get;}

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException.ExceptionId Property

Gets the exception ID.

public int ExceptionId {get;}

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException.MachineName Property

Gets the name of the machine where the error occured.

public string MachineName {get;}

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException.Message Property

Gets the localized message.

public override string Message {get;}

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException.Severity Property

Gets or sets the severity level of the error.

public Deag.Vdx.Common.Enums.vdxErrorSeverity Severity {get; set;}

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException Methods

The methods of the vdxException class are listed below. For a complete list of vdxException class members, see the vdxException Members topic.

Public Instance Methods

Encapsulate | Encapsulates the vdxException object into a SoapException.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMessage | Sets the message.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.
Trace | Traces the error text to the attached TraceListeners.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException.Encapsulate Method

Encapsulates the vdxException object into a SoapException.

public SoapException Encapsulate();

Return Value

A SoapException object.

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException.SetMessage Method

Sets the message.

public void SetMessage(
string text
);

Parameters

text
Text to set as message

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxException.Trace Method

Traces the error text to the attached TraceListeners.

public void Trace();

See Also

vdxException Class | Deag.Vdx.Common.Exceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Common.Exceptions.ConnectionExceptions

VDX Framework

Deag.Vdx.Common.Exceptions.ConnectionExceptions Namespace

Classes

Class | Description
vdxConnectionException | The exception that is thrown when a connection can not be established.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxConnectionException Class

The exception that is thrown when a connection can not be established.

For a list of all members of this type, see vdxConnectionException Members.

System.Object
Exception
ApplicationException
vdxException
vdxConnectionException

public class vdxConnectionException : vdxException

Requirements

Namespace: Deag.Vdx.Common.Exceptions.ConnectionExceptions

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxConnectionException Members | Deag.Vdx.Common.Exceptions.ConnectionExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxConnectionException Members

vdxConnectionException overview

Public Instance Constructors

vdxConnectionException Constructor Initializes a new instance of the vdxConnectionException class.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
CustomMessage (inherited from vdxException) | Gets the error message text.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Encapsulate (inherited from vdxException) | Encapsulates the vdxException object into a SoapException.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMessage (inherited from vdxException) | Sets the message.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.
Trace (inherited from vdxException) | Traces the error text to the attached TraceListeners.

Protected Instance Fields

arguments (inherited from vdxException) Holds the argument for the vdxException.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxConnectionException Class | Deag.Vdx.Common.Exceptions.ConnectionExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxConnectionException Constructor

Initializes a new instance of the vdxConnectionException class.

public vdxConnectionException(
Exception innerException
);

Parameters

innerException
The exception which throwed the exception.

See Also

vdxConnectionException Class | Deag.Vdx.Common.Exceptions.ConnectionExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Common.Exceptions.DatabaseExceptions

VDX Framework

Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Classes

Class | Description
vdxDatabaseException | The exception that is thrown when a database error occurs.
vdxForeignKeyException | The exception that is thrown when a foreign key violation was detected.
vdxNullException | The exception that is thrown when a column does not allow null values.
vdxNumericOverflowException | The exception that is thrown when a numeric value is greater than its type allows.
vdxPrimaryKeyException | The exception that is thrown when a primary key violation was detected.
vdxTruncationException | The exception that is thrown when a truncation violation was detected.
vdxUniqueException | The exception that is thrown when a record is not more unique in one table.

Enumerations

Enumeration | Description
vdxForeignKeyException.Directions | Enumeration to differ entry incoming and outgoing relation chip.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatabaseException Class

The exception that is thrown when a database error occurs.

For a list of all members of this type, see vdxDatabaseException Members.

System.Object
Exception
ApplicationException
vdxException
vdxDatabaseException

public class vdxDatabaseException : vdxException

Requirements

Namespace: Deag.Vdx.Common.Exceptions.DatabaseExceptions

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxDatabaseException Members | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatabaseException Members

vdxDatabaseException overview

Public Instance Constructors

vdxDatabaseException Overloaded. Initializes a new instance of the vdxDatabaseException class.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
CustomMessage (inherited from vdxException) | Gets the error message text.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Encapsulate (inherited from vdxException) | Encapsulates the vdxException object into a SoapException.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMessage (inherited from vdxException) | Sets the message.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.
Trace (inherited from vdxException) | Traces the error text to the attached TraceListeners.

Protected Instance Constructors

vdxDatabaseException Overloaded. Initializes a new instance of the vdxDatabaseException class.

Protected Instance Fields

arguments (inherited from vdxException) Holds the argument for the vdxException.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxDatabaseException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatabaseException Constructor

Initializes a new instance of the vdxDatabaseException class.

Overload List

Initializes a new instance of the vdxDatabaseException class.

protected vdxDatabaseException();

Initializes a new instance of the vdxDatabaseException class.

public vdxDatabaseException(int);

Initializes a new instance of the vdxDatabaseException class.

public vdxDatabaseException(int,vdxErrorSeverity);

Initializes a new instance of the vdxDatabaseException class.

public vdxDatabaseException(int,vdxErrorSeverity,Exception);

Initializes a new instance of the vdxDatabaseException class.

public vdxDatabaseException(int,vdxErrorSeverity,string);

Initializes a new instance of the vdxDatabaseException class.

public vdxDatabaseException(int,vdxErrorSeverity,params string[]);

See Also

vdxDatabaseException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatabaseException Constructor ()

Initializes a new instance of the vdxDatabaseException class.

protected vdxDatabaseException();

See Also

vdxDatabaseException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxDatabaseException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatabaseException Constructor (Int32)

Initializes a new instance of the vdxDatabaseException class.

public vdxDatabaseException(
int exceptionId
);

Parameters

exceptionId
The exception ID.

See Also

vdxDatabaseException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxDatabaseException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatabaseException Constructor (Int32, vdxErrorSeverity)

Initializes a new instance of the vdxDatabaseException class.

public vdxDatabaseException(
int exceptionId,
vdxErrorSeverity severity
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.

See Also

vdxDatabaseException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxDatabaseException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatabaseException Constructor (Int32, vdxErrorSeverity, String[])

Initializes a new instance of the vdxDatabaseException class.

public vdxDatabaseException(
int exceptionId,
vdxErrorSeverity severity,
params string[] arguments
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.
arguments
The arguments the message is formatted with.

See Also

vdxDatabaseException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxDatabaseException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatabaseException Constructor (Int32, vdxErrorSeverity, String)

Initializes a new instance of the vdxDatabaseException class.

public vdxDatabaseException(
int exceptionId,
vdxErrorSeverity severity,
string argument
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.
argument
The argument the message is formatted with.

See Also

vdxDatabaseException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxDatabaseException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatabaseException Constructor (Int32, vdxErrorSeverity, Exception)

Initializes a new instance of the vdxDatabaseException class.

public vdxDatabaseException(
int exceptionId,
vdxErrorSeverity severity,
Exception inner
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.
inner
The inner exception.

See Also

vdxDatabaseException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxDatabaseException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxForeignKeyException Class

The exception that is thrown when a foreign key violation was detected.

For a list of all members of this type, see vdxForeignKeyException Members.

System.Object
Exception
ApplicationException
vdxException
vdxDatabaseException
vdxForeignKeyException

public class vdxForeignKeyException : vdxDatabaseException

Requirements

Namespace: Deag.Vdx.Common.Exceptions.DatabaseExceptions

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxForeignKeyException Members | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxForeignKeyException Members

vdxForeignKeyException overview

Public Instance Constructors

vdxForeignKeyException Constructor Initializes a new instance of the vdxForeignKeyException class.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
ColumnName | Gets or sets the column which is invalid.
Constraint | Gets or sets the constraint which is incorrect.
CustomMessage (inherited from vdxException) | Gets the error message text.
DataBase | Gets or sets the database where violation occurs.
Direction | Gets or sets the direction of the relation of the foreign key.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TableName | Gets or sets the table where violation occurs.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Encapsulate (inherited from vdxException) | Encapsulates the vdxException object into a SoapException.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMessage (inherited from vdxException) | Sets the message.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.
Trace (inherited from vdxException) | Traces the error text to the attached TraceListeners.

Protected Instance Fields

arguments (inherited from vdxException) Holds the argument for the vdxException.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxForeignKeyException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxForeignKeyException Constructor

Initializes a new instance of the vdxForeignKeyException class.

public vdxForeignKeyException();

See Also

vdxForeignKeyException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxForeignKeyException Properties

The properties of the vdxForeignKeyException class are listed below. For a complete list of vdxForeignKeyException class members, see the vdxForeignKeyException Members topic.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
ColumnName | Gets or sets the column which is invalid.
Constraint | Gets or sets the constraint which is incorrect.
CustomMessage (inherited from vdxException) | Gets the error message text.
DataBase | Gets or sets the database where violation occurs.
Direction | Gets or sets the direction of the relation of the foreign key.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TableName | Gets or sets the table where violation occurs.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

vdxForeignKeyException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxForeignKeyException.ColumnName Property

Gets or sets the column which is invalid.

public string ColumnName {get; set;}

See Also

vdxForeignKeyException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxForeignKeyException.Constraint Property

Gets or sets the constraint which is incorrect.

public string Constraint {get; set;}

See Also

vdxForeignKeyException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxForeignKeyException.DataBase Property

Gets or sets the database where violation occurs.

public string DataBase {get; set;}

See Also

vdxForeignKeyException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxForeignKeyException.Direction Property

Gets or sets the direction of the relation of the foreign key.

public vdxForeignKeyException.Directions Direction {get; set;}

See Also

vdxForeignKeyException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxForeignKeyException.TableName Property

Gets or sets the table where violation occurs.

public string TableName {get; set;}

See Also

vdxForeignKeyException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxForeignKeyException.Directions Enumeration

Enumeration to differ entry incoming and outgoing relation chip.

public enum vdxForeignKeyException.Directions

Members

Member Name | Description
Incoming | Foreign key violation on incoming relation.
Outgoing | Foreign key violation on outgoing relation.

Requirements

Namespace: Deag.Vdx.Common.Exceptions.DatabaseExceptions

Assembly: vdxCommon (in vdxCommon.dll)

See Also

Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNullException Class

The exception that is thrown when a column does not allow null values.

For a list of all members of this type, see vdxNullException Members.

System.Object
Exception
ApplicationException
vdxException
vdxDatabaseException
vdxNullException

public class vdxNullException : vdxDatabaseException

Requirements

Namespace: Deag.Vdx.Common.Exceptions.DatabaseExceptions

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxNullException Members | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNullException Members

vdxNullException overview

Public Instance Constructors

vdxNullException Overloaded. Initializes a new instance of the vdxNullException class.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
ColumnName | Gets or sets the column that is null but does not allow null values.
CustomMessage (inherited from vdxException) | Gets the error message text.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TableName | Gets or sets the table which contains the invalid column.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Encapsulate (inherited from vdxException) | Encapsulates the vdxException object into a SoapException.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMessage (inherited from vdxException) | Sets the message.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.
Trace (inherited from vdxException) | Traces the error text to the attached TraceListeners.

Protected Instance Fields

arguments (inherited from vdxException) Holds the argument for the vdxException.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxNullException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNullException Constructor

Initializes a new instance of the vdxDatabaseException class.

Overload List

Initializes a new instance of the vdxDatabaseException class.

public vdxNullException(int);

Initializes a new instance of the vdxDatabaseException class.

public vdxNullException(int,vdxErrorSeverity);

Initializes a new instance of the vdxDatabaseException class.

public vdxNullException(int,vdxErrorSeverity,Exception);

Initializes a new instance of the vdxDatabaseException class.

public vdxNullException(int,vdxErrorSeverity,params string[]);

See Also

vdxNullException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNullException Constructor (Int32)

Initializes a new instance of the vdxDatabaseException class.

public vdxNullException(
int exceptionId
);

Parameters

exceptionId
The exception ID.

See Also

vdxNullException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxNullException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNullException Constructor (Int32, vdxErrorSeverity)

Initializes a new instance of the vdxDatabaseException class.

public vdxNullException(
int exceptionId,
vdxErrorSeverity severity
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.

See Also

vdxNullException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxNullException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNullException Constructor (Int32, vdxErrorSeverity, String[])

Initializes a new instance of the vdxDatabaseException class.

public vdxNullException(
int exceptionId,
vdxErrorSeverity severity,
params string[] arguments
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.
arguments
The arguments the message is formatted with.

See Also

vdxNullException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxNullException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNullException Constructor (Int32, vdxErrorSeverity, Exception)

Initializes a new instance of the vdxDatabaseException class.

public vdxNullException(
int exceptionId,
vdxErrorSeverity severity,
Exception inner
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.
inner
The inner exception.

See Also

vdxNullException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxNullException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNullException Properties

The properties of the vdxNullException class are listed below. For a complete list of vdxNullException class members, see the vdxNullException Members topic.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
ColumnName | Gets or sets the column that is null but does not allow null values.
CustomMessage (inherited from vdxException) | Gets the error message text.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TableName | Gets or sets the table which contains the invalid column.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

vdxNullException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNullException.ColumnName Property

Gets or sets the column that is null but does not allow null values.

public string ColumnName {get; set;}

See Also

vdxNullException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNullException.TableName Property

Gets or sets the table which contains the invalid column.

public string TableName {get; set;}

See Also

vdxNullException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNumericOverflowException Class

The exception that is thrown when a numeric value is greater than its type allows.

For a list of all members of this type, see vdxNumericOverflowException Members.

System.Object
Exception
ApplicationException
vdxException
vdxDatabaseException
vdxNumericOverflowException

public class vdxNumericOverflowException : vdxDatabaseException

Requirements

Namespace: Deag.Vdx.Common.Exceptions.DatabaseExceptions

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxNumericOverflowException Members | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNumericOverflowException Members

vdxNumericOverflowException overview

Public Instance Constructors

vdxNumericOverflowException Overloaded. Initializes a new instance of the vdxNumericOverflowException class.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
CustomMessage (inherited from vdxException) | Gets the error message text.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Encapsulate (inherited from vdxException) | Encapsulates the vdxException object into a SoapException.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMessage (inherited from vdxException) | Sets the message.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.
Trace (inherited from vdxException) | Traces the error text to the attached TraceListeners.

Protected Instance Fields

arguments (inherited from vdxException) Holds the argument for the vdxException.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxNumericOverflowException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNumericOverflowException Constructor

Initializes a new instance of the vdxNumericOverflowException class.

Overload List

Initializes a new instance of the vdxNumericOverflowException class.

public vdxNumericOverflowException(int);

Initializes a new instance of the vdxNumericOverflowException class.

public vdxNumericOverflowException(int,vdxErrorSeverity);

Initializes a new instance of the vdxNumericOverflowException class.

public vdxNumericOverflowException(int,vdxErrorSeverity,Exception);

Initializes a new instance of the vdxNumericOverflowException class.

public vdxNumericOverflowException(int,vdxErrorSeverity,params string[]);

See Also

vdxNumericOverflowException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNumericOverflowException Constructor (Int32)

Initializes a new instance of the vdxNumericOverflowException class.

public vdxNumericOverflowException(
int exceptionId
);

Parameters

exceptionId
The exception ID.

See Also

vdxNumericOverflowException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxNumericOverflowException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNumericOverflowException Constructor (Int32, vdxErrorSeverity)

Initializes a new instance of the vdxNumericOverflowException class.

public vdxNumericOverflowException(
int exceptionId,
vdxErrorSeverity severity
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.

See Also

vdxNumericOverflowException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxNumericOverflowException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNumericOverflowException Constructor (Int32, vdxErrorSeverity, String[])

Initializes a new instance of the vdxNumericOverflowException class.

public vdxNumericOverflowException(
int exceptionId,
vdxErrorSeverity severity,
params string[] arguments
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.
arguments
The arguments the message is formatted with.

See Also

vdxNumericOverflowException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxNumericOverflowException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNumericOverflowException Constructor (Int32, vdxErrorSeverity, Exception)

Initializes a new instance of the vdxNumericOverflowException class.

public vdxNumericOverflowException(
int exceptionId,
vdxErrorSeverity severity,
Exception inner
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.
inner
The inner exception.

See Also

vdxNumericOverflowException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxNumericOverflowException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPrimaryKeyException Class

The exception that is thrown when a primary key violation was detected.

For a list of all members of this type, see vdxPrimaryKeyException Members.

System.Object
Exception
ApplicationException
vdxException
vdxDatabaseException
vdxPrimaryKeyException

public class vdxPrimaryKeyException : vdxDatabaseException

Requirements

Namespace: Deag.Vdx.Common.Exceptions.DatabaseExceptions

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxPrimaryKeyException Members | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPrimaryKeyException Members

vdxPrimaryKeyException overview

Public Instance Constructors

vdxPrimaryKeyException Overloaded. Initializes a new instance of the vdxPrimaryKeyException class.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
Constraint | Gets or sets the constraint which is incorrect.
CustomMessage (inherited from vdxException) | Gets the error message text.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TableName | Gets or sets the table where violation occurs.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Encapsulate (inherited from vdxException) | Encapsulates the vdxException object into a SoapException.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMessage (inherited from vdxException) | Sets the message.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.
Trace (inherited from vdxException) | Traces the error text to the attached TraceListeners.

Protected Instance Constructors

vdxPrimaryKeyException Overloaded. Initializes a new instance of the vdxPrimaryKeyException class.

Protected Instance Fields

arguments (inherited from vdxException) Holds the argument for the vdxException.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxPrimaryKeyException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPrimaryKeyException Constructor

Initializes a new instance of the vdxPrimaryKeyException class.

Overload List

Initializes a new instance of the vdxPrimaryKeyException class.

protected vdxPrimaryKeyException();

Initializes a new instance of the vdxDatabaseException class.

public vdxPrimaryKeyException(int);

Initializes a new instance of the vdxDatabaseException class.

public vdxPrimaryKeyException(int,vdxErrorSeverity);

Initializes a new instance of the vdxDatabaseException class.

public vdxPrimaryKeyException(int,vdxErrorSeverity,Exception);

Initializes a new instance of the vdxDatabaseException class.

public vdxPrimaryKeyException(int,vdxErrorSeverity,params string[]);

See Also

vdxPrimaryKeyException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPrimaryKeyException Constructor ()

Initializes a new instance of the vdxPrimaryKeyException class.

protected vdxPrimaryKeyException();

See Also

vdxPrimaryKeyException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxPrimaryKeyException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPrimaryKeyException Constructor (Int32)

Initializes a new instance of the vdxDatabaseException class.

public vdxPrimaryKeyException(
int exceptionId
);

Parameters

exceptionId
The exception ID.

See Also

vdxPrimaryKeyException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxPrimaryKeyException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPrimaryKeyException Constructor (Int32, vdxErrorSeverity)

Initializes a new instance of the vdxDatabaseException class.

public vdxPrimaryKeyException(
int exceptionId,
vdxErrorSeverity severity
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.

See Also

vdxPrimaryKeyException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxPrimaryKeyException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPrimaryKeyException Constructor (Int32, vdxErrorSeverity, String[])

Initializes a new instance of the vdxDatabaseException class.

public vdxPrimaryKeyException(
int exceptionId,
vdxErrorSeverity severity,
params string[] arguments
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.
arguments
The arguments the message is formatted with.

See Also

vdxPrimaryKeyException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxPrimaryKeyException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPrimaryKeyException Constructor (Int32, vdxErrorSeverity, Exception)

Initializes a new instance of the vdxDatabaseException class.

public vdxPrimaryKeyException(
int exceptionId,
vdxErrorSeverity severity,
Exception inner
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.
inner
The inner exception.

See Also

vdxPrimaryKeyException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxPrimaryKeyException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPrimaryKeyException Properties

The properties of the vdxPrimaryKeyException class are listed below. For a complete list of vdxPrimaryKeyException class members, see the vdxPrimaryKeyException Members topic.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
Constraint | Gets or sets the constraint which is incorrect.
CustomMessage (inherited from vdxException) | Gets the error message text.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TableName | Gets or sets the table where violation occurs.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

vdxPrimaryKeyException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPrimaryKeyException.Constraint Property

Gets or sets the constraint which is incorrect.

public string Constraint {get; set;}

See Also

vdxPrimaryKeyException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPrimaryKeyException.TableName Property

Gets or sets the table where violation occurs.

public string TableName {get; set;}

See Also

vdxPrimaryKeyException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTruncationException Class

The exception that is thrown when a truncation violation was detected.

For a list of all members of this type, see vdxTruncationException Members.

System.Object
Exception
ApplicationException
vdxException
vdxDatabaseException
vdxTruncationException

public class vdxTruncationException : vdxDatabaseException

Requirements

Namespace: Deag.Vdx.Common.Exceptions.DatabaseExceptions

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxTruncationException Members | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTruncationException Members

vdxTruncationException overview

Public Instance Constructors

vdxTruncationException Overloaded. Initializes a new instance of the vdxTruncationException class.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
CustomMessage (inherited from vdxException) | Gets the error message text.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Encapsulate (inherited from vdxException) | Encapsulates the vdxException object into a SoapException.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMessage (inherited from vdxException) | Sets the message.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.
Trace (inherited from vdxException) | Traces the error text to the attached TraceListeners.

Protected Instance Fields

arguments (inherited from vdxException) Holds the argument for the vdxException.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxTruncationException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTruncationException Constructor

Initializes a new instance of the vdxTruncationException class.

Overload List

Initializes a new instance of the vdxTruncationException class.

public vdxTruncationException(int);

Initializes a new instance of the vdxTruncationException class.

public vdxTruncationException(int,vdxErrorSeverity);

Initializes a new instance of the vdxTruncationException class.

public vdxTruncationException(int,vdxErrorSeverity,Exception);

Initializes a new instance of the vdxTruncationException class.

public vdxTruncationException(int,vdxErrorSeverity,params string[]);

See Also

vdxTruncationException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTruncationException Constructor (Int32)

Initializes a new instance of the vdxTruncationException class.

public vdxTruncationException(
int exceptionId
);

Parameters

exceptionId
The exception ID.

See Also

vdxTruncationException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxTruncationException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTruncationException Constructor (Int32, vdxErrorSeverity)

Initializes a new instance of the vdxTruncationException class.

public vdxTruncationException(
int exceptionId,
vdxErrorSeverity severity
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.

See Also

vdxTruncationException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxTruncationException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTruncationException Constructor (Int32, vdxErrorSeverity, String[])

Initializes a new instance of the vdxTruncationException class.

public vdxTruncationException(
int exceptionId,
vdxErrorSeverity severity,
params string[] arguments
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.
arguments
The arguments the message is formatted with.

See Also

vdxTruncationException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxTruncationException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTruncationException Constructor (Int32, vdxErrorSeverity, Exception)

Initializes a new instance of the vdxTruncationException class.

public vdxTruncationException(
int exceptionId,
vdxErrorSeverity severity,
Exception inner
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.
inner
The inner exception.

See Also

vdxTruncationException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxTruncationException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUniqueException Class

The exception that is thrown when a record is not more unique in one table.

For a list of all members of this type, see vdxUniqueException Members.

System.Object
Exception
ApplicationException
vdxException
vdxDatabaseException
vdxUniqueException

public class vdxUniqueException : vdxDatabaseException

Requirements

Namespace: Deag.Vdx.Common.Exceptions.DatabaseExceptions

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxUniqueException Members | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUniqueException Members

vdxUniqueException overview

Public Instance Constructors

vdxUniqueException Overloaded. Initializes a new instance of the vdxUniqueException class.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
Constraint | Gets or sets the constraint which is incorrect.
CustomMessage (inherited from vdxException) | Gets the error message text.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TableName | Gets or sets the table where violation occurs.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Encapsulate (inherited from vdxException) | Encapsulates the vdxException object into a SoapException.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMessage (inherited from vdxException) | Sets the message.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.
Trace (inherited from vdxException) | Traces the error text to the attached TraceListeners.

Protected Instance Fields

arguments (inherited from vdxException) Holds the argument for the vdxException.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxUniqueException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUniqueException Constructor

Initializes a new instance of the vdxDatabaseException class.

Overload List

Initializes a new instance of the vdxDatabaseException class.

public vdxUniqueException(int);

Initializes a new instance of the vdxDatabaseException class.

public vdxUniqueException(int,vdxErrorSeverity);

Initializes a new instance of the vdxDatabaseException class.

public vdxUniqueException(int,vdxErrorSeverity,Exception);

Initializes a new instance of the vdxDatabaseException class.

public vdxUniqueException(int,vdxErrorSeverity,params string[]);

See Also

vdxUniqueException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUniqueException Constructor (Int32)

Initializes a new instance of the vdxDatabaseException class.

public vdxUniqueException(
int exceptionId
);

Parameters

exceptionId
The exception ID.

See Also

vdxUniqueException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxUniqueException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUniqueException Constructor (Int32, vdxErrorSeverity)

Initializes a new instance of the vdxDatabaseException class.

public vdxUniqueException(
int exceptionId,
vdxErrorSeverity severity
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.

See Also

vdxUniqueException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxUniqueException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUniqueException Constructor (Int32, vdxErrorSeverity, String[])

Initializes a new instance of the vdxDatabaseException class.

public vdxUniqueException(
int exceptionId,
vdxErrorSeverity severity,
params string[] arguments
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.
arguments
The arguments the message is formatted with.

See Also

vdxUniqueException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxUniqueException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUniqueException Constructor (Int32, vdxErrorSeverity, Exception)

Initializes a new instance of the vdxDatabaseException class.

public vdxUniqueException(
int exceptionId,
vdxErrorSeverity severity,
Exception inner
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.
inner
The inner exception.

See Also

vdxUniqueException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace | vdxUniqueException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUniqueException Properties

The properties of the vdxUniqueException class are listed below. For a complete list of vdxUniqueException class members, see the vdxUniqueException Members topic.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
Constraint | Gets or sets the constraint which is incorrect.
CustomMessage (inherited from vdxException) | Gets the error message text.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TableName | Gets or sets the table where violation occurs.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

vdxUniqueException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUniqueException.Constraint Property

Gets or sets the constraint which is incorrect.

public string Constraint {get; set;}

See Also

vdxUniqueException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUniqueException.TableName Property

Gets or sets the table where violation occurs.

public string TableName {get; set;}

See Also

vdxUniqueException Class | Deag.Vdx.Common.Exceptions.DatabaseExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Common.Exceptions.LocalExceptions

VDX Framework

Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Classes

Class | Description
vdxArgumentException | The exception that is thrown when one of the arguments provided to a method is not valid.
vdxDelegateException | The exception that is thrown when a delegate is not initialized.
vdxEntityException | The exception that is thrown when an error concerning entities occurs.
vdxNotSupportedException | The exception that is thrown when a not supported member is called.
vdxObjectNotSetException | The exception that is thrown when an object is not set.
vdxOperationNotAllowedException | The exception that is thrown when an operation is not allowed.
vdxRecordNotFoundException | The exception that is thrown when a record is not found.
vdxValidateException | The exception that is thrown when a validation error occurs.
vdxWhereClauseException | The exception that is thrown when a where clause validation error occurs.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxArgumentException Class

The exception that is thrown when one of the arguments provided to a method is not valid.

For a list of all members of this type, see vdxArgumentException Members.

System.Object
Exception
ApplicationException
vdxException
vdxArgumentException

public class vdxArgumentException : vdxException

Requirements

Namespace: Deag.Vdx.Common.Exceptions.LocalExceptions

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxArgumentException Members | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxArgumentException Members

vdxArgumentException overview

Public Instance Constructors

vdxArgumentException Constructor Initializes a new instance of the vdxArgumentException class.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
CustomMessage (inherited from vdxException) | Gets the error message text.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Encapsulate (inherited from vdxException) | Encapsulates the vdxException object into a SoapException.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMessage (inherited from vdxException) | Sets the message.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.
Trace (inherited from vdxException) | Traces the error text to the attached TraceListeners.

Protected Instance Fields

arguments (inherited from vdxException) Holds the argument for the vdxException.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxArgumentException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxArgumentException Constructor

Initializes a new instance of the vdxArgumentException class.

public vdxArgumentException(
int exceptionId,
vdxErrorSeverity severity,
string argument
);

Parameters

exceptionId
severity
argument

See Also

vdxArgumentException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDelegateException Class

The exception that is thrown when a delegate is not initialized.

For a list of all members of this type, see vdxDelegateException Members.

System.Object
Exception
ApplicationException
vdxException
vdxDelegateException

public class vdxDelegateException : vdxException

Requirements

Namespace: Deag.Vdx.Common.Exceptions.LocalExceptions

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxDelegateException Members | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDelegateException Members

vdxDelegateException overview

Public Instance Constructors

vdxDelegateException Constructor Initializes a new instance of the vdxDelegateException class.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
CustomMessage (inherited from vdxException) | Gets the error message text.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Encapsulate (inherited from vdxException) | Encapsulates the vdxException object into a SoapException.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMessage (inherited from vdxException) | Sets the message.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.
Trace (inherited from vdxException) | Traces the error text to the attached TraceListeners.

Protected Instance Fields

arguments (inherited from vdxException) Holds the argument for the vdxException.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxDelegateException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDelegateException Constructor

Initializes a new instance of the vdxDelegateException class.

public vdxDelegateException(
string delegateName
);

Parameters

delegateName

See Also

vdxDelegateException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxEntityException Class

The exception that is thrown when an error concerning entities occurs.

For a list of all members of this type, see vdxEntityException Members.

System.Object
Exception
ApplicationException
vdxException
vdxEntityException

public class vdxEntityException : vdxException

Requirements

Namespace: Deag.Vdx.Common.Exceptions.LocalExceptions

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxEntityException Members | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxEntityException Members

vdxEntityException overview

Public Instance Constructors

vdxEntityException Overloaded. Initializes a new instance of the vdxEntityException class.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
CustomMessage (inherited from vdxException) | Gets the error message text.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Encapsulate (inherited from vdxException) | Encapsulates the vdxException object into a SoapException.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMessage (inherited from vdxException) | Sets the message.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.
Trace (inherited from vdxException) | Traces the error text to the attached TraceListeners.

Protected Instance Fields

arguments (inherited from vdxException) Holds the argument for the vdxException.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxEntityException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxEntityException Constructor

Initializes a new instance of the vdxEntityException class.

Overload List

Initializes a new instance of the vdxEntityException class.

public vdxEntityException(int,Exception,params string[]);

Initializes a new instance of the vdxEntityException class.

public vdxEntityException(int,params string[]);

See Also

vdxEntityException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxEntityException Constructor (Int32, String[])

Initializes a new instance of the vdxEntityException class.

public vdxEntityException(
int exceptionId,
params string[] arguments
);

Parameters

exceptionId
arguments

See Also

vdxEntityException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace | vdxEntityException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxEntityException Constructor (Int32, Exception, String[])

Initializes a new instance of the vdxEntityException class.

public vdxEntityException(
int exceptionId,
Exception inner,
params string[] arguments
);

Parameters

exceptionId
inner
arguments

See Also

vdxEntityException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace | vdxEntityException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNotSupportedException Class

The exception that is thrown when a not supported member is called.

For a list of all members of this type, see vdxNotSupportedException Members.

System.Object
Exception
ApplicationException
vdxException
vdxNotSupportedException

public class vdxNotSupportedException : vdxException

Requirements

Namespace: Deag.Vdx.Common.Exceptions.LocalExceptions

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxNotSupportedException Members | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNotSupportedException Members

vdxNotSupportedException overview

Public Instance Constructors

vdxNotSupportedException Constructor Initializes a new instance of the vdxNotSupportedException class.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
CustomMessage (inherited from vdxException) | Gets the error message text.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Encapsulate (inherited from vdxException) | Encapsulates the vdxException object into a SoapException.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMessage (inherited from vdxException) | Sets the message.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.
Trace (inherited from vdxException) | Traces the error text to the attached TraceListeners.

Protected Instance Fields

arguments (inherited from vdxException) Holds the argument for the vdxException.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxNotSupportedException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNotSupportedException Constructor

Initializes a new instance of the vdxNotSupportedException class.

public vdxNotSupportedException(
int exceptionId,
vdxErrorSeverity severity,
params string[] arguments
);

Parameters

exceptionId
severity
arguments

See Also

vdxNotSupportedException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxObjectNotSetException Class

The exception that is thrown when an object is not set.

For a list of all members of this type, see vdxObjectNotSetException Members.

System.Object
Exception
ApplicationException
vdxException
vdxObjectNotSetException

public class vdxObjectNotSetException : vdxException

Requirements

Namespace: Deag.Vdx.Common.Exceptions.LocalExceptions

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxObjectNotSetException Members | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxObjectNotSetException Members

vdxObjectNotSetException overview

Public Instance Constructors

vdxObjectNotSetException Constructor Initializes a new instance of the vdxObjectNotSetException class.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
CustomMessage (inherited from vdxException) | Gets the error message text.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Encapsulate (inherited from vdxException) | Encapsulates the vdxException object into a SoapException.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMessage (inherited from vdxException) | Sets the message.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.
Trace (inherited from vdxException) | Traces the error text to the attached TraceListeners.

Protected Instance Fields

arguments (inherited from vdxException) Holds the argument for the vdxException.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxObjectNotSetException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxObjectNotSetException Constructor

Initializes a new instance of the vdxObjectNotSetException class.

public vdxObjectNotSetException(
string objectName
);

Parameters

objectName
The name of the object which caused the error.

See Also

vdxObjectNotSetException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOperationNotAllowedException Class

The exception that is thrown when an operation is not allowed.

For a list of all members of this type, see vdxOperationNotAllowedException Members.

System.Object
Exception
ApplicationException
vdxException
vdxOperationNotAllowedException

public class vdxOperationNotAllowedException : vdxException

Requirements

Namespace: Deag.Vdx.Common.Exceptions.LocalExceptions

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxOperationNotAllowedException Members | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOperationNotAllowedException Members

vdxOperationNotAllowedException overview

Public Instance Constructors

vdxOperationNotAllowedException Constructor Initializes a new instance of the vdxOperationNotAllowedException class.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
CustomMessage (inherited from vdxException) | Gets the error message text.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Encapsulate (inherited from vdxException) | Encapsulates the vdxException object into a SoapException.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMessage (inherited from vdxException) | Sets the message.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.
Trace (inherited from vdxException) | Traces the error text to the attached TraceListeners.

Protected Instance Fields

arguments (inherited from vdxException) Holds the argument for the vdxException.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxOperationNotAllowedException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOperationNotAllowedException Constructor

Initializes a new instance of the vdxOperationNotAllowedException class.

public vdxOperationNotAllowedException(
Exception innerException,
string vdxAllowedPropertyName
);

Parameters

innerException
The exception which throwed the exception.
vdxAllowedPropertyName
The name of the property that throwed the error.

See Also

vdxOperationNotAllowedException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRecordNotFoundException Class

The exception that is thrown when a record is not found.

For a list of all members of this type, see vdxRecordNotFoundException Members.

System.Object
Exception
ApplicationException
vdxException
vdxRecordNotFoundException

public class vdxRecordNotFoundException : vdxException

Requirements

Namespace: Deag.Vdx.Common.Exceptions.LocalExceptions

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxRecordNotFoundException Members | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRecordNotFoundException Members

vdxRecordNotFoundException overview

Public Instance Constructors

vdxRecordNotFoundException Overloaded. Initializes a new instance of the vdxRecordNotFoundException class.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
CustomMessage (inherited from vdxException) | Gets the error message text.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Encapsulate (inherited from vdxException) | Encapsulates the vdxException object into a SoapException.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMessage (inherited from vdxException) | Sets the message.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.
Trace (inherited from vdxException) | Traces the error text to the attached TraceListeners.

Protected Instance Fields

arguments (inherited from vdxException) Holds the argument for the vdxException.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxRecordNotFoundException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRecordNotFoundException Constructor

Initializes a new instance of the vdxRecordNotFoundException class.

Overload List

Initializes a new instance of the vdxRecordNotFoundException class.

public vdxRecordNotFoundException(int);

Initializes a new instance of the vdxRecordNotFoundException class.

public vdxRecordNotFoundException(int,vdxErrorSeverity);

Initializes a new instance of the vdxRecordNotFoundException class.

public vdxRecordNotFoundException(int,vdxErrorSeverity,Exception);

Initializes a new instance of the vdxRecordNotFoundException class.

public vdxRecordNotFoundException(string);

See Also

vdxRecordNotFoundException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRecordNotFoundException Constructor (Int32)

Initializes a new instance of the vdxRecordNotFoundException class.

public vdxRecordNotFoundException(
int exceptionId
);

Parameters

exceptionId
The exception ID.

See Also

vdxRecordNotFoundException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace | vdxRecordNotFoundException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRecordNotFoundException Constructor (Int32, vdxErrorSeverity)

Initializes a new instance of the vdxRecordNotFoundException class.

public vdxRecordNotFoundException(
int exceptionId,
vdxErrorSeverity severity
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.

See Also

vdxRecordNotFoundException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace | vdxRecordNotFoundException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRecordNotFoundException Constructor (Int32, vdxErrorSeverity, Exception)

Initializes a new instance of the vdxRecordNotFoundException class.

public vdxRecordNotFoundException(
int exceptionId,
vdxErrorSeverity severity,
Exception inner
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.
inner
The inner exception.

See Also

vdxRecordNotFoundException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace | vdxRecordNotFoundException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRecordNotFoundException Constructor (String)

Initializes a new instance of the vdxRecordNotFoundException class.

public vdxRecordNotFoundException(
string message
);

Parameters

message
The error message text.

See Also

vdxRecordNotFoundException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace | vdxRecordNotFoundException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxValidateException Class

The exception that is thrown when a validation error occurs.

For a list of all members of this type, see vdxValidateException Members.

System.Object
Exception
ApplicationException
vdxException
vdxValidateException

public class vdxValidateException : vdxException

Requirements

Namespace: Deag.Vdx.Common.Exceptions.LocalExceptions

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxValidateException Members | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxValidateException Members

vdxValidateException overview

Public Instance Constructors

vdxValidateException Overloaded. Initializes a new instance of the vdxValidateException class.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
CustomMessage (inherited from vdxException) | Gets the error message text.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Encapsulate (inherited from vdxException) | Encapsulates the vdxException object into a SoapException.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMessage (inherited from vdxException) | Sets the message.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.
Trace (inherited from vdxException) | Traces the error text to the attached TraceListeners.

Protected Instance Fields

arguments (inherited from vdxException) Holds the argument for the vdxException.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxValidateException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxValidateException Constructor

Initializes a new instance of the vdxValidateException class.

Overload List

Initializes a new instance of the vdxValidateException class.

public vdxValidateException(int);

Initializes a new instance of the vdxValidateException class.

public vdxValidateException(int,vdxErrorSeverity,Exception);

Initializes a new instance of the vdxValidateException class.

public vdxValidateException(int,vdxErrorSeverity,params string[]);

See Also

vdxValidateException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxValidateException Constructor (Int32)

Initializes a new instance of the vdxValidateException class.

public vdxValidateException(
int exceptionId
);

Parameters

exceptionId
The exception ID.

See Also

vdxValidateException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace | vdxValidateException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxValidateException Constructor (Int32, vdxErrorSeverity, String[])

Initializes a new instance of the vdxValidateException class.

public vdxValidateException(
int exceptionId,
vdxErrorSeverity severity,
params string[] arguments
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.
arguments
Arguments to format the error message.

See Also

vdxValidateException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace | vdxValidateException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxValidateException Constructor (Int32, vdxErrorSeverity, Exception)

Initializes a new instance of the vdxValidateException class.

public vdxValidateException(
int exceptionId,
vdxErrorSeverity severity,
Exception inner
);

Parameters

exceptionId
The exception ID.
severity
The severity level of the error.
inner
The inner exception.

See Also

vdxValidateException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace | vdxValidateException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxWhereClauseException Class

The exception that is thrown when a where clause validation error occurs.

For a list of all members of this type, see vdxWhereClauseException Members.

System.Object
Exception
ApplicationException
vdxException
vdxWhereClauseException

public class vdxWhereClauseException : vdxException

Requirements

Namespace: Deag.Vdx.Common.Exceptions.LocalExceptions

Assembly: vdxCommon (in vdxCommon.dll)

See Also

vdxWhereClauseException Members | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxWhereClauseException Members

vdxWhereClauseException overview

Public Instance Constructors

vdxWhereClauseException Overloaded. Initializes a new instance of the vdxWhereClauseException class.

Public Instance Properties

Arguments (inherited from vdxException) | Gets/sets the collection of arguments passed to the error message.
Caption (inherited from vdxException) | Gets the error message text.
CustomMessage (inherited from vdxException) | Gets the error message text.
ErrorTime (inherited from vdxException) | Gets the time of the error.
ExceptionId (inherited from vdxException) | Gets the exception ID.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from vdxException) | Gets the name of the machine where the error occured.
Message (inherited from vdxException) | Gets the localized message.
Severity (inherited from vdxException) | Gets or sets the severity level of the error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Encapsulate (inherited from vdxException) | Encapsulates the vdxException object into a SoapException.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
SetMessage (inherited from vdxException) | Sets the message.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.
Trace (inherited from vdxException) | Traces the error text to the attached TraceListeners.

Protected Instance Fields

arguments (inherited from vdxException) Holds the argument for the vdxException.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxWhereClauseException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxWhereClauseException Constructor

Initializes a new instance of the vdxWhereClauseException class.

Overload List

Initializes a new instance of the vdxWhereClauseException class.

public vdxWhereClauseException(int);

Initializes a new instance of the vdxWhereClauseException class.

public vdxWhereClauseException(int,string);

See Also

vdxWhereClauseException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxWhereClauseException Constructor (Int32)

Initializes a new instance of the vdxWhereClauseException class.

public vdxWhereClauseException(
int exceptionId
);

Parameters

exceptionId

See Also

vdxWhereClauseException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace | vdxWhereClauseException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxWhereClauseException Constructor (Int32, String)

Initializes a new instance of the vdxWhereClauseException class.

public vdxWhereClauseException(
int exceptionId,
string whereClauses
);

Parameters

exceptionId
whereClauses

See Also

vdxWhereClauseException Class | Deag.Vdx.Common.Exceptions.LocalExceptions Namespace | vdxWhereClauseException Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Controls

VDX Framework

Deag.Vdx.Controls Namespace

Classes

Class | Description
vdxApplication | This is the application class of the VDX framework. It's purpose is to wrap all the vdx functionality and to provide application tasks. A custom application class must derive from this class in order to fit with the framework.
vdxDebugData | This Class is used for Debugging and has a few Methods to Debug your Data.
vdxExceptionForm | Default implementation of an IvdxExceptionHandlerForm.
vdxLateBinding | Late binding helper class.
vdxPrintScreen | Provides methods to print the current screen.
vdxReflection | Reflection helper class.
vdxUnhandledExceptionForm | Specialized vdxExceptionForm for unhandled exceptions.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxApplication Class

This is the application class of the VDX framework. It's purpose is to wrap all the vdx functionality and to provide application tasks. A custom application class must derive from this class in order to fit with the framework.

For a list of all members of this type, see vdxApplication Members.

System.Object
ApplicationContext
vdxApplication

public class vdxApplication : ApplicationContext

Requirements

Namespace: Deag.Vdx.Controls

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxApplication Members | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxApplication Members

vdxApplication overview

Public Static Properties

IsInDesignMode | Gets if we are the Design Mode
VdxDebugFeatures | Gets or sets if you need the DebugFeatures
VdxExceptionHandler | Gets or sets the ExceptionHandler
VdxLateBinding | Gets or sets the vdxLateBinding object.
VdxReflection | Gets or sets the vdxReflection object.

Public Static Methods

IsComponentInDesignMode Gets if the component is in the Design Mode.

Protected Static Fields

exceptionHandler | Holds a reference to the appropriate IvdxExceptionHandler object.
logon | Holds a reference to the appropriate logon object.
splash | An instance to the IvdxSpash if a Splash is needed
vdxDebugFeatures | Set this to true to activate Debugging-Features.

Public Instance Properties

MainForm (inherited from ApplicationContext) Gets or sets the Form to use as context.

Public Instance Methods

Dispose (inherited from ApplicationContext) | Overloaded. Releases all resources used by the ApplicationContext .
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExitThread (inherited from ApplicationContext) | Terminates the message loop of the thread.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ThreadExit (inherited from ApplicationContext) Occurs when the message loop of the thread should be terminated, by calling ExitThread .

Protected Instance Constructors

vdxApplication Constructor Default constructor.

Protected Instance Methods

Dispose (inherited from ApplicationContext) | Overloaded. Releases the unmanaged resources used by the ApplicationContext and optionally releases the managed resources.
ExitThreadCore (inherited from ApplicationContext) | Terminates the message loop of the thread.
Finalize (inherited from ApplicationContext) | Attempts to free resources and perform other cleanup operations before the application context is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnMainFormClosed (inherited from ApplicationContext) | Calls ExitThreadCore, which raises the ThreadExit event.

See Also

vdxApplication Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxApplication Constructor

Default constructor.

protected vdxApplication();

See Also

vdxApplication Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxApplication Fields

The fields of the vdxApplication class are listed below. For a complete list of vdxApplication class members, see the vdxApplication Members topic.

Protected Static Fields

exceptionHandler | Holds a reference to the appropriate IvdxExceptionHandler object.
logon | Holds a reference to the appropriate logon object.
splash | An instance to the IvdxSpash if a Splash is needed
vdxDebugFeatures | Set this to true to activate Debugging-Features.

See Also

vdxApplication Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxApplication.exceptionHandler Field

Holds a reference to the appropriate IvdxExceptionHandler object.

protected static IvdxExceptionHandler exceptionHandler;

See Also

vdxApplication Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxApplication.logon Field

Holds a reference to the appropriate logon object.

protected static IvdxLogon logon;

See Also

vdxApplication Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxApplication.splash Field

An instance to the IvdxSpash if a Splash is needed

protected static IvdxSplashScreen splash;

See Also

vdxApplication Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxApplication.VdxDebugFeatures Property

Gets or sets if you need the DebugFeatures

public static bool VdxDebugFeatures {get; set;}

See Also

vdxApplication Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxApplication Properties

The properties of the vdxApplication class are listed below. For a complete list of vdxApplication class members, see the vdxApplication Members topic.

Public Static Properties

IsInDesignMode | Gets if we are the Design Mode
VdxDebugFeatures | Gets or sets if you need the DebugFeatures
VdxExceptionHandler | Gets or sets the ExceptionHandler
VdxLateBinding | Gets or sets the vdxLateBinding object.
VdxReflection | Gets or sets the vdxReflection object.

Public Instance Properties

MainForm (inherited from ApplicationContext) Gets or sets the Form to use as context.

See Also

vdxApplication Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxApplication.IsInDesignMode Property

Gets if we are the Design Mode

public static bool IsInDesignMode {get;}

See Also

vdxApplication Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxApplication.VdxExceptionHandler Property

Gets or sets the ExceptionHandler

public static Deag.Vdx.Common.IvdxExceptionHandler VdxExceptionHandler {get; set;}

See Also

vdxApplication Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxApplication.VdxLateBinding Property

Gets or sets the vdxLateBinding object.

public static vdxLateBinding VdxLateBinding {get; set;}

See Also

vdxApplication Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxApplication.VdxReflection Property

Gets or sets the vdxReflection object.

public static vdxReflection VdxReflection {get; set;}

See Also

vdxApplication Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxApplication Methods

The methods of the vdxApplication class are listed below. For a complete list of vdxApplication class members, see the vdxApplication Members topic.

Public Static Methods

IsComponentInDesignMode Gets if the component is in the Design Mode.

Public Instance Methods

Dispose (inherited from ApplicationContext) | Overloaded. Releases all resources used by the ApplicationContext .
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExitThread (inherited from ApplicationContext) | Terminates the message loop of the thread.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose (inherited from ApplicationContext) | Overloaded. Releases the unmanaged resources used by the ApplicationContext and optionally releases the managed resources.
ExitThreadCore (inherited from ApplicationContext) | Terminates the message loop of the thread.
Finalize (inherited from ApplicationContext) | Attempts to free resources and perform other cleanup operations before the application context is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnMainFormClosed (inherited from ApplicationContext) | Calls ExitThreadCore, which raises the ThreadExit event.

See Also

vdxApplication Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxApplication.IsComponentInDesignMode Method

Gets if the component is in the Design Mode.

public static bool IsComponentInDesignMode(
IComponent component
);

See Also

vdxApplication Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDebugData Class

This Class is used for Debugging and has a few Methods to Debug your Data.

For a list of all members of this type, see vdxDebugData Members.

System.Object
vdxDebugData

public class vdxDebugData

Requirements

Namespace: Deag.Vdx.Controls

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDebugData Members | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDebugData Members

vdxDebugData overview

Public Static Methods

Show | Shows a form with a DataGrid displaying your Data
ShowDebug | Overloaded. Shows a form with a DataGrid displaying your Data

Public Instance Constructors

vdxDebugData Constructor Initializes a new instance of the vdxDebugData class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxDebugData Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDebugData Constructor

Initializes a new instance of the vdxDebugData class.

public vdxDebugData();

See Also

vdxDebugData Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDebugData Methods

The methods of the vdxDebugData class are listed below. For a complete list of vdxDebugData class members, see the vdxDebugData Members topic.

Public Static Methods

Show | Shows a form with a DataGrid displaying your Data
ShowDebug | Overloaded. Shows a form with a DataGrid displaying your Data

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxDebugData Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDebugData.Show Method

Shows a form with a DataGrid displaying your Data

public static void Show(
ref DataView dv
);

Parameters

dv
the DataView containing the Data to debug

See Also

vdxDebugData Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ShowDebug Method

VDX Framework

vdxDebugData.ShowDebug Method

Shows a form with a DataGrid displaying your Data

Overload List

Shows a form with a DataGrid displaying your Data

public static void ShowDebug(ref DataRow[]);

Shows a form with a DataGrid displaying your Data

public static void ShowDebug(ref DataSet);

Shows a form with a DataGrid displaying your Data

public static void ShowDebug(ref DataSet,bool);

Shows a form with a DataGrid displaying your Data

public static void ShowDebug(ref DataSet,string);

Shows a form with a DataGrid displaying your Data

public static void ShowDebug(ref DataSet,string,bool);

Shows a form with a DataGrid displaying your Data

public static void ShowDebug(ref DataTable);

Shows a form with a DataGrid displaying your Data

public static void ShowDebug(ref DataTable,bool);

See Also

vdxDebugData Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDebugData.ShowDebug Method (DataRow[])

Shows a form with a DataGrid displaying your Data

public static void ShowDebug(
ref DataRow[] rows
);

Parameters

rows
the DataRows containing the Data to debug

See Also

vdxDebugData Class | Deag.Vdx.Controls Namespace | vdxDebugData.ShowDebug Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDebugData.ShowDebug Method (DataSet)

Shows a form with a DataGrid displaying your Data

public static void ShowDebug(
ref DataSet ds
);

Parameters

ds
DataSet containing the Data to debug

See Also

vdxDebugData Class | Deag.Vdx.Controls Namespace | vdxDebugData.ShowDebug Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDebugData.ShowDebug Method (DataSet, Boolean)

Shows a form with a DataGrid displaying your Data

public static void ShowDebug(
ref DataSet ds,
bool changesOnly
);

Parameters

ds
DataSet containing the Data to debug
changesOnly
Show only changes

See Also

vdxDebugData Class | Deag.Vdx.Controls Namespace | vdxDebugData.ShowDebug Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDebugData.ShowDebug Method (DataSet, String)

Shows a form with a DataGrid displaying your Data

public static void ShowDebug(
ref DataSet ds,
string tableName
);

Parameters

ds
DataSet containing the Data to debug
tableName
the TableName inside the DataSet

See Also

vdxDebugData Class | Deag.Vdx.Controls Namespace | vdxDebugData.ShowDebug Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDebugData.ShowDebug Method (DataSet, String, Boolean)

Shows a form with a DataGrid displaying your Data

public static void ShowDebug(
ref DataSet ds,
string tableName,
bool changesOnly
);

Parameters

ds
DataSet containing the Data to debug
tableName
the TableName inside the DataSet
changesOnly
Show only changes

See Also

vdxDebugData Class | Deag.Vdx.Controls Namespace | vdxDebugData.ShowDebug Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDebugData.ShowDebug Method (DataTable)

Shows a form with a DataGrid displaying your Data

public static void ShowDebug(
ref DataTable dt
);

Parameters

dt
the DataTable containing the Data to debug

See Also

vdxDebugData Class | Deag.Vdx.Controls Namespace | vdxDebugData.ShowDebug Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDebugData.ShowDebug Method (DataTable, Boolean)

Shows a form with a DataGrid displaying your Data

public static void ShowDebug(
ref DataTable dt,
bool changesOnly
);

Parameters

dt
the DataTable containing the Data to debug
changesOnly
Show only changes

See Also

vdxDebugData Class | Deag.Vdx.Controls Namespace | vdxDebugData.ShowDebug Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionForm Class

Default implementation of an IvdxExceptionHandlerForm.

For a list of all members of this type, see vdxExceptionForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
vdxExceptionForm

public class vdxExceptionForm : Form, IvdxExceptionHandlerForm

Requirements

Namespace: Deag.Vdx.Controls

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxExceptionForm Members | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionForm Members

vdxExceptionForm overview

Public Instance Constructors

vdxExceptionForm Constructor Default constructor.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
EmailTo | Gets or sets the mail address to send error message.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
ActivateCloseButton | Enables the close button.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeactivateExitButton | Disables the exit button.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
SetLanguage | Sets the language on the dialog for the child controls.
SetMessage | Sets the message with the given title and message.
SetSeverity | Sets the vdxErrorSeverity of the dialog.
Show (inherited from Control) | Displays the control to the user.
ShowDialog | Overloaded. Shows the dialog.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

btnClose | Button to close dialog.
btnExit | Button to exit application.
emailTo | Mail address to send error message.
txtMessage | Text box that holds the message.

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

vdxExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionForm Constructor

Default constructor.

public vdxExceptionForm();

See Also

vdxExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionForm Fields

The fields of the vdxExceptionForm class are listed below. For a complete list of vdxExceptionForm class members, see the vdxExceptionForm Members topic.

Protected Instance Fields

btnClose | Button to close dialog.
btnExit | Button to exit application.
emailTo | Mail address to send error message.
txtMessage | Text box that holds the message.

See Also

vdxExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionForm.btnClose Field

Button to close dialog.

protected Button btnClose;

See Also

vdxExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionForm.btnExit Field

Button to exit application.

protected Button btnExit;

See Also

vdxExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionForm.EmailTo Property

Gets or sets the mail address to send error message.

public string EmailTo {get; set;}

Implements

IvdxExceptionHandlerForm.EmailTo

See Also

vdxExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionForm.txtMessage Field

Text box that holds the message.

protected RichTextBox txtMessage;

See Also

vdxExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionForm Properties

The properties of the vdxExceptionForm class are listed below. For a complete list of vdxExceptionForm class members, see the vdxExceptionForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
EmailTo | Gets or sets the mail address to send error message.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

vdxExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionForm Methods

The methods of the vdxExceptionForm class are listed below. For a complete list of vdxExceptionForm class members, see the vdxExceptionForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
ActivateCloseButton | Enables the close button.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeactivateExitButton | Disables the exit button.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
SetLanguage | Sets the language on the dialog for the child controls.
SetMessage | Sets the message with the given title and message.
SetSeverity | Sets the vdxErrorSeverity of the dialog.
Show (inherited from Control) | Displays the control to the user.
ShowDialog | Overloaded. Shows the dialog.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

vdxExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionForm.ActivateCloseButton Method

Enables the close button.

public void ActivateCloseButton();

See Also

vdxExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionForm.DeactivateExitButton Method

Disables the exit button.

public void DeactivateExitButton();

Implements

IvdxExceptionHandlerForm.DeactivateExitButton

See Also

vdxExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Dispose Method

VDX Framework

vdxExceptionForm.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

vdxExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionForm.Dispose Method (Boolean)

Clean up any resources being used.

protected override void Dispose(
bool disposing
);

See Also

vdxExceptionForm Class | Deag.Vdx.Controls Namespace | vdxExceptionForm.Dispose Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionForm.SetLanguage Method

Sets the language on the dialog for the child controls.

public void SetLanguage(
CultureInfo cultureInfo
);

Parameters

cultureInfo

Implements

IvdxExceptionHandlerForm.SetLanguage

See Also

vdxExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionForm.SetMessage Method

Sets the message with the given title and message.

public void SetMessage(
string caption,
string message
);

Parameters

caption
The title of the dialog.
message
The message displayed on the dialog.

Implements

IvdxExceptionHandlerForm.SetMessage

See Also

vdxExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionForm.SetSeverity Method

Sets the vdxErrorSeverity of the dialog.

public void SetSeverity(
vdxErrorSeverity severity
);

Parameters

severity
The severity for the dialog.

Implements

IvdxExceptionHandlerForm.SetSeverity

Remarks

Depending on the severity the controls will be displayed or hided.

See Also

vdxExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ShowDialog Method

VDX Framework

vdxExceptionForm.ShowDialog Method

Shows the dialog.

Overload List

Shows the dialog.

new public void ShowDialog();

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

vdxExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExceptionForm.ShowDialog Method ()

Shows the dialog.

new public void ShowDialog();

Implements

IvdxExceptionHandlerForm.ShowDialog

See Also

vdxExceptionForm Class | Deag.Vdx.Controls Namespace | vdxExceptionForm.ShowDialog Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLateBinding Class

Late binding helper class.

For a list of all members of this type, see vdxLateBinding Members.

System.Object
vdxLateBinding

public class vdxLateBinding

Requirements

Namespace: Deag.Vdx.Controls

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxLateBinding Members | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLateBinding Members

vdxLateBinding overview

Public Instance Constructors

vdxLateBinding Constructor Initializes a new instance of the vdxLateBinding class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxCreateInstance | Overloaded. Create an instance of a class.
VdxGetFieldValue | Gets all values of a indexed field (array, collection...).
VdxGetIndexedFieldValue | Gets a value of a indexed field (array, collection...).
VdxGetIndexedPropertyValue | Gets a value of a indexed property.
VdxGetPropertyValue | Gets a value of a property.
VdxGetType | Gets the type of a fullqualified string which represents that class.
VdxInvokeDefaultMethod | Invokes the default method.
VdxInvokeMethod | Invokes a specific method.
VdxInvokeMethodNamedParameters | Invokes a specific method.
VdxInvokeStaticMethod | Invokes the default method.
VdxSetFieldValue | Sets a value of a field (array, collection...).
VdxSetIndexedFieldValue | Sets a value of a indexed field (array, collection...).
VdxSetIndexedPropertyValue | Sets a value of a indexed property.
VdxSetPropertyValue | Sets a value of a property.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxLateBinding Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLateBinding Constructor

Initializes a new instance of the vdxLateBinding class.

public vdxLateBinding();

See Also

vdxLateBinding Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLateBinding Methods

The methods of the vdxLateBinding class are listed below. For a complete list of vdxLateBinding class members, see the vdxLateBinding Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxCreateInstance | Overloaded. Create an instance of a class.
VdxGetFieldValue | Gets all values of a indexed field (array, collection...).
VdxGetIndexedFieldValue | Gets a value of a indexed field (array, collection...).
VdxGetIndexedPropertyValue | Gets a value of a indexed property.
VdxGetPropertyValue | Gets a value of a property.
VdxGetType | Gets the type of a fullqualified string which represents that class.
VdxInvokeDefaultMethod | Invokes the default method.
VdxInvokeMethod | Invokes a specific method.
VdxInvokeMethodNamedParameters | Invokes a specific method.
VdxInvokeStaticMethod | Invokes the default method.
VdxSetFieldValue | Sets a value of a field (array, collection...).
VdxSetIndexedFieldValue | Sets a value of a indexed field (array, collection...).
VdxSetIndexedPropertyValue | Sets a value of a indexed property.
VdxSetPropertyValue | Sets a value of a property.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxLateBinding Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


VdxCreateInstance Method

VDX Framework

vdxLateBinding.VdxCreateInstance Method

Create an instance of a class.

Overload List

Create an instance of a class.

public virtual object VdxCreateInstance(string);

Create an instance of a class.

public virtual object VdxCreateInstance(Type);

See Also

vdxLateBinding Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLateBinding.VdxCreateInstance Method (String)

Create an instance of a class.

public virtual object VdxCreateInstance(
string className
);

Parameters

className
Fullqualified string which represents a class.

Return Value

An object of the desired type.

See Also

vdxLateBinding Class | Deag.Vdx.Controls Namespace | vdxLateBinding.VdxCreateInstance Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLateBinding.VdxCreateInstance Method (Type)

Create an instance of a class.

public virtual object VdxCreateInstance(
Type typeToCreate
);

Parameters

typeToCreate
The Type of the class to create.

Return Value

An object of the desired type.

See Also

vdxLateBinding Class | Deag.Vdx.Controls Namespace | vdxLateBinding.VdxCreateInstance Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLateBinding.VdxGetFieldValue Method

Gets all values of a indexed field (array, collection...).

public object VdxGetFieldValue(
object obj,
string field
);

Parameters

obj
Instance of the class which contains the field.
field
Name of the field.

Return Value

All values of the field.

See Also

vdxLateBinding Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLateBinding.VdxGetIndexedFieldValue Method

Gets a value of a indexed field (array, collection...).

public object VdxGetIndexedFieldValue(
object obj,
string field,
int index
);

Parameters

obj
Instance of the class which contains the field.
field
Name of the field.
index
The index of the desired item.

Return Value

The return value of desired item.

See Also

vdxLateBinding Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLateBinding.VdxGetIndexedPropertyValue Method

Gets a value of a indexed property.

public object VdxGetIndexedPropertyValue(
object obj,
string property,
int index
);

Parameters

obj
Instance of the class which contains the property.
property
The name of the property.
index
The index of the desired item.

Return Value

The value of the desired item.

See Also

vdxLateBinding Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLateBinding.VdxGetPropertyValue Method

Gets a value of a property.

public object VdxGetPropertyValue(
object obj,
string property
);

Parameters

obj
Instance of the class which contains the property.
property
The name of the property.

Return Value

The value of the property.

See Also

vdxLateBinding Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLateBinding.VdxGetType Method

Gets the type of a fullqualified string which represents that class.

public virtual Type VdxGetType(
string className
);

Parameters

className
Fullqualified string which represents a class.

Return Value

The type of the class.

See Also

vdxLateBinding Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLateBinding.VdxInvokeDefaultMethod Method

Invokes the default method.

public object VdxInvokeDefaultMethod(
object obj,
object[] parameters
);

Parameters

obj
Instance of the class which contains the method to invoke.
parameters
The parameters of the method. Each element in this array represents a single parameter. If you use vdxSearchParameters.GetParameters(), set the vdxSearchParameters.VdxUsevdxLateBinding property to true. This will encapsulate the vdxSearchParameters in a object array.

Return Value

The return value of the invoked method.

See Also

vdxLateBinding Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLateBinding.VdxInvokeMethod Method

Invokes a specific method.

public object VdxInvokeMethod(
object obj,
string method,
object[] parameters
);

Parameters

obj
Instance of the class which contains the method to invoke.
method
The method to invoke.
parameters
The parameters of the method. Each element in this array represents a single parameter. If you use vdxSearchParameters.GetParameters(), set the vdxSearchParameters.VdxUsevdxLateBinding property to true. This will encapsulate the vdxSearchParameters in a object array.

Return Value

The return value of the invoked method.

See Also

vdxLateBinding Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLateBinding.VdxInvokeMethodNamedParameters Method

Invokes a specific method.

public object VdxInvokeMethodNamedParameters(
object obj,
string method,
object[] parameters,
string[] parameterNames
);

Parameters

obj
Instance of the class which contains the method to invoke.
method
The method to invoke.
parameters
The parameters of the method. Each element in this array represents a single parameter. If you use vdxSearchParameters.GetParameters(), set the vdxSearchParameters.VdxUsevdxLateBinding property to true. This will encapsulate the vdxSearchParameters in a object array.
parameterNames
Array of named parameters.

Return Value

The return value of the invoked method.

See Also

vdxLateBinding Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLateBinding.VdxInvokeStaticMethod Method

Invokes the default method.

public object VdxInvokeStaticMethod(
Type type,
string method,
object[] parameters
);

Parameters

type
The Type of the object.
method
The method to invoke.
parameters
The parameters of the method. Each element in this array represents a single parameter. If you use vdxSearchParameters.GetParameters(), set the vdxSearchParameters.VdxUsevdxLateBinding property to true. This will encapsulate the vdxSearchParameters in a object array.

Return Value

The return value of the invoked method.

See Also

vdxLateBinding Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLateBinding.VdxSetFieldValue Method

Sets a value of a field (array, collection...).

public void VdxSetFieldValue(
object obj,
string field,
object val
);

Parameters

obj
Instance of the class which contains the field.
field
The name of the field
val
The value to set.

See Also

vdxLateBinding Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLateBinding.VdxSetIndexedFieldValue Method

Sets a value of a indexed field (array, collection...).

public void VdxSetIndexedFieldValue(
object obj,
string field,
int index,
object val
);

Parameters

obj
Instance of the class which contains the field.
field
The name of the field.
index
The index of the desired item.
val
The value to set.

See Also

vdxLateBinding Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLateBinding.VdxSetIndexedPropertyValue Method

Sets a value of a indexed property.

public void VdxSetIndexedPropertyValue(
object obj,
string property,
int index,
object val
);

Parameters

obj
Instance of the class which contains the property.
property
Name of property
index
The index of the desired item
val
The value to set.

See Also

vdxLateBinding Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLateBinding.VdxSetPropertyValue Method

Sets a value of a property.

public void VdxSetPropertyValue(
object obj,
string property,
object val
);

Parameters

obj
Instance of the class which contains the property.
property
Name of property
val
The value to set.

See Also

vdxLateBinding Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPrintScreen Class

Provides methods to print the current screen.

For a list of all members of this type, see vdxPrintScreen Members.

System.Object
vdxPrintScreen

public sealed class vdxPrintScreen

Requirements

Namespace: Deag.Vdx.Controls

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxPrintScreen Members | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPrintScreen Members

vdxPrintScreen overview

Public Static Methods

GetInstance | Returns a Pointer to this Singleton-Class
PrintScreen | Shows you a PrinterDialog to print a PrintScreen

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxPrintScreen Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPrintScreen Methods

The methods of the vdxPrintScreen class are listed below. For a complete list of vdxPrintScreen class members, see the vdxPrintScreen Members topic.

Public Static Methods

GetInstance | Returns a Pointer to this Singleton-Class
PrintScreen | Shows you a PrinterDialog to print a PrintScreen

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxPrintScreen Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPrintScreen.GetInstance Method

Returns a Pointer to this Singleton-Class

public static vdxPrintScreen GetInstance();

Return Value

See Also

vdxPrintScreen Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPrintScreen.PrintScreen Method

Shows you a PrinterDialog to print a PrintScreen

public static void PrintScreen();

See Also

vdxPrintScreen Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection Class

Reflection helper class.

For a list of all members of this type, see vdxReflection Members.

System.Object
vdxReflection

public class vdxReflection

Requirements

Namespace: Deag.Vdx.Controls

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxReflection Members | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection Members

vdxReflection overview

Public Instance Constructors

vdxReflection Constructor Initializes a new instance of the vdxReflection class.

Public Instance Properties

VdxBusinessObjectBaseType Gets or sets the business object base type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxGetEvents | Gets all the public events of the specified type.
VdxGetEventsStringArray | Gets all the public events of the specified type.
VdxGetFields | Gets all the public fields of the specified type.
VdxGetFieldsStringArray | Gets all the public fields of the specified type.
VdxGetInterfaces | Gets all the interfaces of the specified type.
VdxGetInterfacesStringArray | Gets all the interfaces of the specified type.
VdxGetMethods | Gets all the public Methods of the specified type.
VdxGetMethodsStringArray | Gets all the public Methods as string representations of the specified type.
VdxGetParameters | Gets all the parameters of the specified method.
VdxGetParametersStringArray | Gets all the parameters of the specified method.
VdxGetProperties | Gets all the properties of the specified type.
VdxGetPropertiesStringArray | Gets all the properties of the specified type.
VdxGetType | Gets the type defined in the specified assembly with the specified class name.
VdxGetTypes | Overloaded. Gets all the types defined in the GetEntryAssembly.
VdxGetTypesStringArray | Overloaded. Gets all the types defined in the GetEntryAssembly which base upon the specified base type.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection Constructor

Initializes a new instance of the vdxReflection class.

public vdxReflection();

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection Properties

The properties of the vdxReflection class are listed below. For a complete list of vdxReflection class members, see the vdxReflection Members topic.

Public Instance Properties

VdxBusinessObjectBaseType Gets or sets the business object base type.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxBusinessObjectBaseType Property

Gets or sets the business object base type.

public System.Type VdxBusinessObjectBaseType {get; set;}

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection Methods

The methods of the vdxReflection class are listed below. For a complete list of vdxReflection class members, see the vdxReflection Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxGetEvents | Gets all the public events of the specified type.
VdxGetEventsStringArray | Gets all the public events of the specified type.
VdxGetFields | Gets all the public fields of the specified type.
VdxGetFieldsStringArray | Gets all the public fields of the specified type.
VdxGetInterfaces | Gets all the interfaces of the specified type.
VdxGetInterfacesStringArray | Gets all the interfaces of the specified type.
VdxGetMethods | Gets all the public Methods of the specified type.
VdxGetMethodsStringArray | Gets all the public Methods as string representations of the specified type.
VdxGetParameters | Gets all the parameters of the specified method.
VdxGetParametersStringArray | Gets all the parameters of the specified method.
VdxGetProperties | Gets all the properties of the specified type.
VdxGetPropertiesStringArray | Gets all the properties of the specified type.
VdxGetType | Gets the type defined in the specified assembly with the specified class name.
VdxGetTypes | Overloaded. Gets all the types defined in the GetEntryAssembly.
VdxGetTypesStringArray | Overloaded. Gets all the types defined in the GetEntryAssembly which base upon the specified base type.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxGetEvents Method

Gets all the public events of the specified type.

public EventInfo[] VdxGetEvents(
Type type
);

Parameters

type
The type to search on.

Return Value

The events of the specified type.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxGetEventsStringArray Method

Gets all the public events of the specified type.

public string[] VdxGetEventsStringArray(
Type type
);

Parameters

type
The type to search on.

Return Value

The string representations of the events found on the specified type.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxGetFields Method

Gets all the public fields of the specified type.

public FieldInfo[] VdxGetFields(
Type type
);

Parameters

type
The type to search on.

Return Value

The fields of the specified type.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxGetFieldsStringArray Method

Gets all the public fields of the specified type.

public string[] VdxGetFieldsStringArray(
Type type
);

Parameters

type
The type to search on.

Return Value

The string representations of the fields on the specified type.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxGetInterfaces Method

Gets all the interfaces of the specified type.

public Type[] VdxGetInterfaces(
Type type
);

Parameters

type
The type to search on.

Return Value

The interface types of the specified type.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxGetInterfacesStringArray Method

Gets all the interfaces of the specified type.

public string[] VdxGetInterfacesStringArray(
Type type
);

Parameters

type
The type to search on.

Return Value

The string representations of the interfaces found on the specified type.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxGetMethods Method

Gets all the public Methods of the specified type.

public MethodInfo[] VdxGetMethods(
Type type
);

Parameters

type
The type to search on.

Return Value

The Methods of the specified type.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxGetMethodsStringArray Method

Gets all the public Methods as string representations of the specified type.

public string[] VdxGetMethodsStringArray(
Type type
);

Parameters

type
The type to search on.

Return Value

The string representations of the Methods found on the specified type.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxGetParameters Method

Gets all the parameters of the specified method.

public ParameterInfo[] VdxGetParameters(
MethodInfo methodInfo
);

Parameters

methodInfo
The method to search on.

Return Value

The parameters as ParameterInfo.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxGetParametersStringArray Method

Gets all the parameters of the specified method.

public string[] VdxGetParametersStringArray(
MethodInfo methodInfo
);

Parameters

methodInfo
The method to search on.

Return Value

The parameters as a string representation.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxGetProperties Method

Gets all the properties of the specified type.

public PropertyInfo[] VdxGetProperties(
Type type
);

Parameters

type
The type to search on.

Return Value

The properties of the specified type.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxGetPropertiesStringArray Method

Gets all the properties of the specified type.

public string[] VdxGetPropertiesStringArray(
Type type
);

Parameters

type
The type to search on.

Return Value

The string representations of the properties found on the specified type.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxGetType Method

Gets the type defined in the specified assembly with the specified class name.

public Type VdxGetType(
Assembly assembly,
string className
);

Parameters

assembly
The assembly containing the type.
className
The class name.

Return Value

The type found in the assembly.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


VdxGetTypes Method

VDX Framework

vdxReflection.VdxGetTypes Method

Gets all the types defined in the GetEntryAssembly.

Overload List

Gets all the types defined in the GetEntryAssembly.

public Type[] VdxGetTypes();

Gets all the tpyes defined in the specified assembly.

public Type[] VdxGetTypes(Assembly);

Gets all the types defined in the assembly which base upon the specified base type.

public Type[] VdxGetTypes(Assembly,Type);

Gets all the types defined in the GetEntryAssembly which base upon the specified base type.

public Type[] VdxGetTypes(Type);

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxGetTypes Method ()

Gets all the types defined in the GetEntryAssembly.

public Type[] VdxGetTypes();

Return Value

The types found in the GetEntryAssembly.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace | vdxReflection.VdxGetTypes Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxGetTypes Method (Assembly)

Gets all the tpyes defined in the specified assembly.

public Type[] VdxGetTypes(
Assembly assembly
);

Parameters

assembly
Assembly containing the types.

Return Value

The types found in the assembly.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace | vdxReflection.VdxGetTypes Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxGetTypes Method (Assembly, Type)

Gets all the types defined in the assembly which base upon the specified base type.

public Type[] VdxGetTypes(
Assembly assembly,
Type baseType
);

Parameters

assembly
The assembly containing the types.
baseType
The base type of the types searching for.

Return Value

The types found in the assembly.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace | vdxReflection.VdxGetTypes Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxGetTypes Method (Type)

Gets all the types defined in the GetEntryAssembly which base upon the specified base type.

public Type[] VdxGetTypes(
Type baseType
);

Parameters

baseType
The base type of the types searching for.

Return Value

The types found in the GetEntryAssembly.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace | vdxReflection.VdxGetTypes Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


VdxGetTypesStringArray Method

VDX Framework

vdxReflection.VdxGetTypesStringArray Method

Gets all the types defined in the specified assembly which base upon the specified base type.

Overload List

Gets all the types defined in the specified assembly which base upon the specified base type.

public string[] VdxGetTypesStringArray(Assembly,Type);

Gets all the types defined in the GetEntryAssembly which base upon the specified base type.

public string[] VdxGetTypesStringArray(Type);

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxGetTypesStringArray Method (Assembly, Type)

Gets all the types defined in the specified assembly which base upon the specified base type.

public string[] VdxGetTypesStringArray(
Assembly entryAssembly,
Type baseType
);

Parameters

entryAssembly
The assembly containing the types.
baseType
The base type of the types searching for.

Return Value

The string representations of the types found in the assembly.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace | vdxReflection.VdxGetTypesStringArray Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxReflection.VdxGetTypesStringArray Method (Type)

Gets all the types defined in the GetEntryAssembly which base upon the specified base type.

public string[] VdxGetTypesStringArray(
Type baseType
);

Parameters

baseType
The base type of the types searching for.

Return Value

The string representations of the types found in the GetEntryAssembly.

See Also

vdxReflection Class | Deag.Vdx.Controls Namespace | vdxReflection.VdxGetTypesStringArray Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUnhandledExceptionForm Class

Specialized vdxExceptionForm for unhandled exceptions.

For a list of all members of this type, see vdxUnhandledExceptionForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
vdxExceptionForm
vdxUnhandledExceptionForm

public class vdxUnhandledExceptionForm : vdxExceptionForm

Requirements

Namespace: Deag.Vdx.Controls

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxUnhandledExceptionForm Members | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUnhandledExceptionForm Members

vdxUnhandledExceptionForm overview

Public Instance Constructors

vdxUnhandledExceptionForm Constructor Default Constructor

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
EmailTo (inherited from vdxExceptionForm) | Gets or sets the mail address to send error message.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
Subject | Gets or sets the subject for the outgoing mail.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
ActivateCloseButton (inherited from vdxExceptionForm) | Enables the close button.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeactivateExitButton (inherited from vdxExceptionForm) | Disables the exit button.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
SetLanguage (inherited from vdxExceptionForm) | Sets the language on the dialog for the child controls.
SetMessage (inherited from vdxExceptionForm) | Sets the message with the given title and message.
SetSeverity (inherited from vdxExceptionForm) | Sets the vdxErrorSeverity of the dialog.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from vdxExceptionForm) | Overloaded. Shows the dialog.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

btnClose (inherited from vdxExceptionForm) | Button to close dialog.
btnExit (inherited from vdxExceptionForm) | Button to exit application.
emailTo (inherited from vdxExceptionForm) | Mail address to send error message.
txtMessage (inherited from vdxExceptionForm) | Text box that holds the message.

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

vdxUnhandledExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUnhandledExceptionForm Constructor

Default Constructor

public vdxUnhandledExceptionForm();

See Also

vdxUnhandledExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUnhandledExceptionForm Properties

The properties of the vdxUnhandledExceptionForm class are listed below. For a complete list of vdxUnhandledExceptionForm class members, see the vdxUnhandledExceptionForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
EmailTo (inherited from vdxExceptionForm) | Gets or sets the mail address to send error message.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
Subject | Gets or sets the subject for the outgoing mail.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

vdxUnhandledExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUnhandledExceptionForm.Subject Property

Gets or sets the subject for the outgoing mail.

public string Subject {get; set;}

See Also

vdxUnhandledExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUnhandledExceptionForm Methods

The methods of the vdxUnhandledExceptionForm class are listed below. For a complete list of vdxUnhandledExceptionForm class members, see the vdxUnhandledExceptionForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
ActivateCloseButton (inherited from vdxExceptionForm) | Enables the close button.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeactivateExitButton (inherited from vdxExceptionForm) | Disables the exit button.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
SetLanguage (inherited from vdxExceptionForm) | Sets the language on the dialog for the child controls.
SetMessage (inherited from vdxExceptionForm) | Sets the message with the given title and message.
SetSeverity (inherited from vdxExceptionForm) | Sets the vdxErrorSeverity of the dialog.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from vdxExceptionForm) | Overloaded. Shows the dialog.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

vdxUnhandledExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Dispose Method

VDX Framework

vdxUnhandledExceptionForm.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

vdxUnhandledExceptionForm Class | Deag.Vdx.Controls Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxUnhandledExceptionForm.Dispose Method (Boolean)

Clean up any resources being used.

protected override void Dispose(
bool disposing
);

See Also

vdxUnhandledExceptionForm Class | Deag.Vdx.Controls Namespace | vdxUnhandledExceptionForm.Dispose Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Controls.Base

VDX Framework

Deag.Vdx.Controls.Base Namespace

Classes

Class | Description
vdxButton | Specialized .Net Button that implements the IvdxBindable to bind the bindable properties.
vdxCheckBox | Specialized .Net CheckBox that implements the IvdxBindable to bind the bindable properties. It also implements IvdxInputControl to provide input functionality.
vdxCheckedListBox | Specialized .Net CheckedListBox that implements the IvdxBindable to bind the bindable properties.
vdxComboBox | Specialized .Net ComboBox that implements the IvdxBindable to bind the bindable properties. It also implements IvdxInputControl to provide input functionality.
vdxComboBoxEdit | Editable ComboBox combined with a TextBox that implements the IvdxBindable to bind the bindable properties. It also implements IvdxInputControl to provide input functionality.
vdxControl | Specialized .Net Control that implements the IvdxBindable to bind the bindable properties.
vdxDataGrid | Specialized .Net DataGrid that implements the IvdxBindable to bind the bindable properties.
vdxDataGridManipulator | Displays data in a scrollable grid and offer editing features.
vdxDataGridNavigator | Displays data in a scrollable grid and interact with vdxExplorer.
vdxDataView | VDX specific DataView. Allow to use vdxDataStatusManager and vdxDataSetReference.
vdxDesignerItem | Class to inherit from to hide default properties.
vdxGroupBox | Specialized .Net GroupBox that implements the IvdxBindable to bind the bindable properties.
vdxLabel | Specialized .Net Label that implements the IvdxBindable to bind the bindable properties.
vdxLinkLabel | Specialized .Net LinkLabel that implements the IvdxBindable to bind the bindable properties.
vdxListBox | Specialized .Net ListBox that implements the IvdxBindable to bind the bindable properties.
vdxNumericUpDown | Specialized .Net NumericUpDown that implements the IvdxBindable to bind the bindable properties.
vdxPanel | Specialized .Net Panel that implements the IvdxBindable to bind the bindable properties.
vdxRadioButton | Specialized .Net RadioButton that implements the IvdxBindable to bind the bindable properties.
vdxRichTextBox | Specialized .Net RichTextBox that implements the IvdxBindable to bind the bindable properties.
vdxTabControl | Specialized .Net TabControl that implements the IvdxBindable to bind the bindable properties.
vdxTextBox | Specialized .Net TextBox that implements the IvdxBindable to bind the bindable properties.
vdxTextBoxChangeValidate | Specialized vdxTextBox that implements the IvdxBindable to bind the bindable properties.
vdxTextBoxDecimal | Specialisation of vdxTextBoxNumeric to simplify the input of numeric values of the type decimal. In addition to vdxTextBoxNumeric, the decimal value can be accessed directly by the NumericValue property. The NullValue Property is used to define a decimal value used to represent null. (No data present).
vdxTextBoxDouble | Specialisation of vdxTextBoxNumeric to simplify the input of numeric values of the type double. In addition to vdxTextBoxNumeric, the double value can be accessed directly by the NumericValue property. The NullValue Property is used to define a double value used to represent null. (No data present).
vdxTextBoxLong | Specialisation of vdxTextBoxNumeric to simplify the input of numeric values of the type long. In addition to vdxTextBoxNumeric, the long value can be accessed directly by the NumericValue property. The NullValue Property is used to define a long value used to represent null. (No data present).
vdxTextBoxNumeric | Represents TextBox control that accepts only numeric values. The type of the number may be specified by the property 'NumericType'. According to this type, only input of the appropriate type will be accepted. Additionally a Format string may be specified and used for formatting the textual representation ofthe number. The TextBox is able to convert numbers of the following types: Undefined = 0: No typ set (default of the NumericType property) Byte = 1: signed byte (8 bit) Short = 2: signed short (16 bit) Int = 3: signed int (32 bit) Long = 4: signed long (64 bit) Float = 5: float (4 byte) Double = 6: double (8 byte) Decimal = 7: decimal (128 bit, high percision floation point) UByte = 8: unsigned byte (8 bit) UShort = 9: unsigned short (16 bit) UInt = 10: unsigned int (32 bit) ULong = 11: unsigned long (64 bit) user = 100: User defined type. Use this type to indicate, that you are inheritting the control to manage a new type Note for inheritors: If you intend to process types not defined in the enNumericTypes enumeration, set the controls type to 'user' by overriding the NumericType property. Then you have to override the methods GetFormattedValue, GetTypeInfo and TryToConvert. For more details see the the summary of those methods.
vdxTreeNode | Represents a node in a vdxTreeView object.
vdxTreeView | Displays a hierarchical collection of labeled items, each represented by a vdxTreeNode or a .Net TreeNode.

Enumerations

Enumeration | Description
enNumericTypes | Enumerates the numeric types supported by the vdxTextBoxNumeric control.
RefreshAlgorithmType | The algorithm type for refresh action.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


enNumericTypes Enumeration

Enumerates the numeric types supported by the vdxTextBoxNumeric control.

public enum enNumericTypes

Members

Member Name | Description
Undefined | Undefined type
Byte | signed byte (8 bit)
Short | signed short (16 bit)
Int | signed int (32 but)
Long | signed long (64 bit)
Float | float (4 byte)
Double | double (8 byte)
Decimal | decimal (128 bit, high precision floation point)
UByte | unsigned byte (8 bit)
UShort | unsigned short (16 bit)
UInt | unsigned int (32 bit)
ULong | unsigned long (64 bit)
userdefined | user defined type

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


RefreshAlgorithmType Enumeration

The algorithm type for refresh action.

public enum RefreshAlgorithmType

Members

Member Name | Description
RefreshNone | Expands no node after refresh.
RefreshSelected | Expands only selected node after refresh.
RefreshAllExpanded | Expands all nodes after refresh.

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxButton Class

Specialized .Net Button that implements the IvdxBindable to bind the bindable properties.

For a list of all members of this type, see vdxButton Members.

System.Object
MarshalByRefObject
Component
Control
ButtonBase
Button
vdxButton

public class vdxButton : Button, IvdxBindable

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxButton Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxButton Members

vdxButton overview

Public Instance Constructors

vdxButton Constructor Initializes a new instance of the vdxButton class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DialogResult (inherited from Button) | Gets or sets a value that is returned to the parent form when the button is clicked.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from ButtonBase) | Gets or sets the alignment of the text on the button control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyDefault (inherited from Button) | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly.
PerformClick (inherited from Button) | Generates a Click event for a button.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Button) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Button) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from ButtonBase) |
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Button) |
DefaultImeMode (inherited from ButtonBase) | Gets the default Input Method Editor (IME) mode supported by this control.
DefaultSize (inherited from ButtonBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
IsDefault (inherited from ButtonBase) | Gets or sets a value indicating whether the button control is the default button.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from ButtonBase) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ButtonBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Button) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from ButtonBase) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from ButtonBase) |
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from ButtonBase) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from ButtonBase) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from ButtonBase) |
OnMouseDown (inherited from ButtonBase) |
OnMouseEnter (inherited from ButtonBase) |
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from ButtonBase) |
OnMouseMove (inherited from ButtonBase) |
OnMouseUp (inherited from Button) |
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from ButtonBase) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ButtonBase) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from ButtonBase) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ButtonBase) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Button) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetFlagsandPaint (inherited from ButtonBase) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Button) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxButton Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxButton Constructor

Initializes a new instance of the vdxButton class.

public vdxButton();

See Also

vdxButton Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxButton Properties

The properties of the vdxButton class are listed below. For a complete list of vdxButton class members, see the vdxButton Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DialogResult (inherited from Button) | Gets or sets a value that is returned to the parent form when the button is clicked.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from ButtonBase) | Gets or sets the alignment of the text on the button control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Button) |
DefaultImeMode (inherited from ButtonBase) | Gets the default Input Method Editor (IME) mode supported by this control.
DefaultSize (inherited from ButtonBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
IsDefault (inherited from ButtonBase) | Gets or sets a value indicating whether the button control is the default button.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxButton Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxButton.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxButton Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxButton.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxButton Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxButton Methods

The methods of the vdxButton class are listed below. For a complete list of vdxButton class members, see the vdxButton Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyDefault (inherited from Button) | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly.
PerformClick (inherited from Button) | Generates a Click event for a button.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Button) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from ButtonBase) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ButtonBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Button) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from ButtonBase) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from ButtonBase) |
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from ButtonBase) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from ButtonBase) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from ButtonBase) |
OnMouseDown (inherited from ButtonBase) |
OnMouseEnter (inherited from ButtonBase) |
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from ButtonBase) |
OnMouseMove (inherited from ButtonBase) |
OnMouseUp (inherited from Button) |
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from ButtonBase) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ButtonBase) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from ButtonBase) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ButtonBase) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Button) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetFlagsandPaint (inherited from ButtonBase) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Button) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxButton Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxButton.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxButton Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxButton.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxButton Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckBox Class

Specialized .Net CheckBox that implements the IvdxBindable to bind the bindable properties. It also implements IvdxInputControl to provide input functionality.

For a list of all members of this type, see vdxCheckBox Members.

System.Object
MarshalByRefObject
Component
Control
ButtonBase
CheckBox
vdxCheckBox

public class vdxCheckBox : CheckBox, IvdxInputControl, IvdxDsmHost, IvdxResettable, IvdxBindingManagable, IvdxBindable

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxCheckBox Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckBox Members

vdxCheckBox overview

Public Instance Constructors

vdxCheckBox Constructor Initializes a new instance of the vdxCheckBox class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
Appearance (inherited from CheckBox) | Gets or sets the value that determines the appearance of a check box control.
AutoCheck (inherited from CheckBox) | Gets or set a value indicating whether the Checked or CheckState values and the check box's appearance are automatically changed when the check box is clicked.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindEmptyValuesAsNull | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CheckAlign (inherited from CheckBox) | Gets or sets the horizontal and vertical alignment of a check box on a check box control.
Checked (inherited from CheckBox) | Gets or set a value indicating whether the check box is in the checked state.
CheckState (inherited from CheckBox) | Gets or sets the state of the check box.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control.
InteractWithDSM | Gets/sets a value indicating whether the CheckBox interacts with the DSM. If set to true then the CheckBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from CheckBox) |
ThreeState (inherited from CheckBox) | Gets or sets a value indicating whether the check box will allow three check states rather than two.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from CheckBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AppearanceChanged (inherited from CheckBox) | Occurs when the value of the Appearance property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
CheckedChanged (inherited from CheckBox) | Occurs when the value of the Checked property changes.
CheckStateChanged (inherited from CheckBox) | Occurs when the value of the CheckState property changes.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from CheckBox) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from ButtonBase) |
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from CheckBox) |
DefaultImeMode (inherited from ButtonBase) | Gets the default Input Method Editor (IME) mode supported by this control.
DefaultSize (inherited from CheckBox) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
IsDefault (inherited from ButtonBase) | Gets or sets a value indicating whether the button control is the default button.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from CheckBox) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ButtonBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAppearanceChanged (inherited from CheckBox) | Raises the AppearanceChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnCheckedChanged (inherited from CheckBox) | Raises the CheckedChanged event.
OnCheckStateChanged (inherited from CheckBox) | Raises the CheckStateChanged event.
OnClick | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from ButtonBase) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from ButtonBase) |
OnHandleCreated (inherited from CheckBox) |
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from ButtonBase) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from ButtonBase) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from ButtonBase) |
OnMouseDown (inherited from ButtonBase) |
OnMouseEnter (inherited from ButtonBase) |
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from ButtonBase) |
OnMouseMove (inherited from ButtonBase) |
OnMouseUp (inherited from CheckBox) |
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from ButtonBase) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ButtonBase) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from ButtonBase) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ButtonBase) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from CheckBox) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetFlagsandPaint (inherited from ButtonBase) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from ButtonBase) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager

Explicit Interface Implementations

IvdxInputControl.InitializeBinding | Do any initializing work like converting format.
IvdxResettable.Reset |

See Also

vdxCheckBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckBox Constructor

Initializes a new instance of the vdxCheckBox class.

public vdxCheckBox();

See Also

vdxCheckBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckBox Properties

The properties of the vdxCheckBox class are listed below. For a complete list of vdxCheckBox class members, see the vdxCheckBox Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
Appearance (inherited from CheckBox) | Gets or sets the value that determines the appearance of a check box control.
AutoCheck (inherited from CheckBox) | Gets or set a value indicating whether the Checked or CheckState values and the check box's appearance are automatically changed when the check box is clicked.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindEmptyValuesAsNull | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CheckAlign (inherited from CheckBox) | Gets or sets the horizontal and vertical alignment of a check box on a check box control.
Checked (inherited from CheckBox) | Gets or set a value indicating whether the check box is in the checked state.
CheckState (inherited from CheckBox) | Gets or sets the state of the check box.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control.
InteractWithDSM | Gets/sets a value indicating whether the CheckBox interacts with the DSM. If set to true then the CheckBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from CheckBox) |
ThreeState (inherited from CheckBox) | Gets or sets a value indicating whether the check box will allow three check states rather than two.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from CheckBox) |
DefaultImeMode (inherited from ButtonBase) | Gets the default Input Method Editor (IME) mode supported by this control.
DefaultSize (inherited from CheckBox) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
IsDefault (inherited from ButtonBase) | Gets or sets a value indicating whether the button control is the default button.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager

See Also

vdxCheckBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckBox.BindEmptyValuesAsNull Property

Gets or sets whether the empty values must be binded as null.

public bool BindEmptyValuesAsNull {get; set;}

Implements

IvdxInputControl.BindEmptyValuesAsNull

See Also

vdxCheckBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckBox.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxCheckBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckBox.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxCheckBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckBox.Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager Property

private Deag.Vdx.Controls.Core.vdxDataStatusManager Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager {get; set;}

See Also

vdxCheckBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckBox.InteractWithDSM Property

Gets/sets a value indicating whether the CheckBox interacts with the DSM. If set to true then the CheckBox will not force an AutoEdit on the DSM. Default value = true;

public bool InteractWithDSM {get; set;}

Implements

IvdxInputControl.InteractWithDSM

See Also

vdxCheckBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckBox Methods

The methods of the vdxCheckBox class are listed below. For a complete list of vdxCheckBox class members, see the vdxCheckBox Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from CheckBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from CheckBox) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ButtonBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAppearanceChanged (inherited from CheckBox) | Raises the AppearanceChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnCheckedChanged (inherited from CheckBox) | Raises the CheckedChanged event.
OnCheckStateChanged (inherited from CheckBox) | Raises the CheckStateChanged event.
OnClick | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from ButtonBase) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from ButtonBase) |
OnHandleCreated (inherited from CheckBox) |
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from ButtonBase) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from ButtonBase) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from ButtonBase) |
OnMouseDown (inherited from ButtonBase) |
OnMouseEnter (inherited from ButtonBase) |
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from ButtonBase) |
OnMouseMove (inherited from ButtonBase) |
OnMouseUp (inherited from CheckBox) |
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from ButtonBase) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ButtonBase) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from ButtonBase) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ButtonBase) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from CheckBox) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetFlagsandPaint (inherited from ButtonBase) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from ButtonBase) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IvdxInputControl.InitializeBinding | Do any initializing work like converting format.
IvdxResettable.Reset |

See Also

vdxCheckBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckBox.IvdxInputControl.InitializeBinding Method

Do any initializing work like converting format.

void IvdxInputControl.InitializeBinding(
Binding binding
);

Implements

IvdxInputControl.InitializeBinding

See Also

vdxCheckBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckBox.IvdxResettable.Reset Method

void IvdxResettable.Reset();

Implements

IvdxResettable.Reset

See Also

vdxCheckBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckBox.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxCheckBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckBox.OnClick Method

Raises the Click event.

protected override void OnClick(
EventArgs e
);

Parameters

e
Event parameters.

See Also

vdxCheckBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckBox.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxCheckBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckedListBox Class

Specialized .Net CheckedListBox that implements the IvdxBindable to bind the bindable properties.

For a list of all members of this type, see vdxCheckedListBox Members.

System.Object
MarshalByRefObject
Component
Control
ListControl
ListBox
CheckedListBox
vdxCheckedListBox

public class vdxCheckedListBox : CheckedListBox, IvdxBindable

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxCheckedListBox Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckedListBox Members

vdxCheckedListBox overview

Public Instance Constructors

vdxCheckedListBox Constructor Initializes a new instance of the vdxCheckedListBox class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from ListBox) |
BackgroundImage (inherited from ListBox) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from ListBox) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CheckedIndices (inherited from CheckedListBox) | Collection of checked indexes in this CheckedListBox .
CheckedItems (inherited from CheckedListBox) | Collection of checked items in this CheckedListBox .
CheckOnClick (inherited from CheckedListBox) | Gets or sets a value indicating whether the check box should be toggled when an item is selected.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColumnWidth (inherited from ListBox) | Gets or sets the width of columns in a multicolumn ListBox.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataSource (inherited from CheckedListBox) |
DisplayMember (inherited from CheckedListBox) |
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DrawMode (inherited from CheckedListBox) |
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from ListBox) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalExtent (inherited from ListBox) | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll.
HorizontalScrollbar (inherited from ListBox) | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
IntegralHeight (inherited from ListBox) | Gets or sets a value indicating whether the control should resize to avoid showing partial items.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from CheckedListBox) |
Items (inherited from CheckedListBox) | Gets the collection of items in this CheckedListBox.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MultiColumn (inherited from ListBox) | Gets or sets a value indicating whether the ListBox supports multiple columns.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from ListBox) | Gets the combined height of all items in the ListBox .
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from ListBox) | Gets or sets a value indicating whether text displayed by the control is displayed from right to left.
ScrollAlwaysVisible (inherited from ListBox) | Gets or sets a value indicating whether the vertical scroll bar is shown at all times.
SelectedIndex (inherited from ListBox) | Gets or sets the zero-based index of the currently selected item in a ListBox.
SelectedIndices (inherited from ListBox) | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox.
SelectedItem (inherited from ListBox) | Gets or sets the currently selected item in the ListBox .
SelectedItems (inherited from ListBox) | Gets a collection containing the currently selected items in the ListBox .
SelectedValue (inherited from ListControl) | Gets or sets the value of the member property specified by the ValueMember property.
SelectionMode (inherited from CheckedListBox) | Gets or sets a value specifying the selection mode.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from ListBox) | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from ListBox) | Gets or searches for the text of the currently selected item in the ListBox .
ThreeDCheckBoxes (inherited from CheckedListBox) | Gets or sets a value indicating whether the check boxes display as Flat or Normal in appearance.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopIndex (inherited from ListBox) | Gets or sets the index of the first visible item in the ListBox .
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseTabStops (inherited from ListBox) | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings.
ValueMember (inherited from CheckedListBox) |
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from ListBox) | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearSelected (inherited from ListBox) | Unselects all items in the ListBox .
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from ListBox) | Resumes painting the ListBox control after painting is suspended by the BeginUpdatemethod.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindString (inherited from ListBox) | Overloaded. Finds the first item in the ListBox that starts with the specified string.
FindStringExact (inherited from ListBox) | Overloaded. Finds the first item in the ListBox that exactly matches the specified string.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetItemChecked (inherited from CheckedListBox) | Returns a value indicating whether the specified item is checked.
GetItemCheckState (inherited from CheckedListBox) | Returns a value indicating the check state of the current item.
GetItemHeight (inherited from ListBox) | Returns the height of an item in the ListBox .
GetItemRectangle (inherited from ListBox) | Returns the bounding rectangle for an item in the ListBox .
GetItemText (inherited from ListControl) | Returns the text representation of the specified item.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetSelected (inherited from ListBox) | Returns a value indicating whether the specified item is selected.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
IndexFromPoint (inherited from ListBox) | Overloaded. Returns the zero-based index of the item at the specified coordinates.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from ListBox) |
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetItemChecked (inherited from CheckedListBox) | Sets the item at the specified index to Checked .
SetItemCheckState (inherited from CheckedListBox) | Sets the check state of the item at the specified index.
SetSelected (inherited from ListBox) | Selects or clears the selection for the specified item in a ListBox .
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from ListBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from ListBox) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from CheckedListBox) |
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
DataSourceChanged (inherited from CheckedListBox) |
DisplayMemberChanged (inherited from CheckedListBox) |
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DrawItem (inherited from CheckedListBox) |
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
ItemCheck (inherited from CheckedListBox) | Occurs when the checked state of an item changes.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MeasureItem (inherited from CheckedListBox) |
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from ListBox) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectedIndexChanged (inherited from ListBox) | Occurs when the SelectedIndex property has changed.
SelectedValueChanged (inherited from ListControl) | Occurs when the SelectedValue property changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from ListBox) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueMemberChanged (inherited from CheckedListBox) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from CheckedListBox) |
DataManager (inherited from ListControl) | Gets the CurrencyManager associated with this control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from ListBox) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AddItemsCore (inherited from ListBox) |
CreateAccessibilityInstance (inherited from CheckedListBox) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateItemCollection (inherited from CheckedListBox) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
FilterItemOnProperty (inherited from ListControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from ListControl) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from CheckedListBox) |
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from ListControl) |
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from ListBox) |
OnClick (inherited from CheckedListBox) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from ListBox) |
OnDisplayMemberChanged (inherited from ListBox) |
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnDrawItem (inherited from CheckedListBox) |
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from CheckedListBox) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from CheckedListBox) |
OnHandleDestroyed (inherited from ListBox) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnItemCheck (inherited from CheckedListBox) |
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from CheckedListBox) |
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMeasureItem (inherited from CheckedListBox) |
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ListBox) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from ListBox) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSelectedIndexChanged (inherited from CheckedListBox) | Raises the SelectedIndexChanged event.
OnSelectedValueChanged (inherited from ListBox) |
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueMemberChanged (inherited from ListControl) | Raises the ValueMemberChanged event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshItem (inherited from ListBox) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from ListBox) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetItemCore (inherited from ListBox) |
SetItemsCore (inherited from ListBox) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
Sort (inherited from ListBox) | Sorts the items in the ListBox alphabetically.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WmReflectCommand (inherited from CheckedListBox) |
WndProc (inherited from CheckedListBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxCheckedListBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckedListBox Constructor

Initializes a new instance of the vdxCheckedListBox class.

public vdxCheckedListBox();

See Also

vdxCheckedListBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckedListBox Properties

The properties of the vdxCheckedListBox class are listed below. For a complete list of vdxCheckedListBox class members, see the vdxCheckedListBox Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from ListBox) |
BackgroundImage (inherited from ListBox) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from ListBox) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CheckedIndices (inherited from CheckedListBox) | Collection of checked indexes in this CheckedListBox .
CheckedItems (inherited from CheckedListBox) | Collection of checked items in this CheckedListBox .
CheckOnClick (inherited from CheckedListBox) | Gets or sets a value indicating whether the check box should be toggled when an item is selected.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColumnWidth (inherited from ListBox) | Gets or sets the width of columns in a multicolumn ListBox.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataSource (inherited from CheckedListBox) |
DisplayMember (inherited from CheckedListBox) |
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DrawMode (inherited from CheckedListBox) |
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from ListBox) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalExtent (inherited from ListBox) | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll.
HorizontalScrollbar (inherited from ListBox) | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
IntegralHeight (inherited from ListBox) | Gets or sets a value indicating whether the control should resize to avoid showing partial items.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from CheckedListBox) |
Items (inherited from CheckedListBox) | Gets the collection of items in this CheckedListBox.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MultiColumn (inherited from ListBox) | Gets or sets a value indicating whether the ListBox supports multiple columns.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from ListBox) | Gets the combined height of all items in the ListBox .
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from ListBox) | Gets or sets a value indicating whether text displayed by the control is displayed from right to left.
ScrollAlwaysVisible (inherited from ListBox) | Gets or sets a value indicating whether the vertical scroll bar is shown at all times.
SelectedIndex (inherited from ListBox) | Gets or sets the zero-based index of the currently selected item in a ListBox.
SelectedIndices (inherited from ListBox) | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox.
SelectedItem (inherited from ListBox) | Gets or sets the currently selected item in the ListBox .
SelectedItems (inherited from ListBox) | Gets a collection containing the currently selected items in the ListBox .
SelectedValue (inherited from ListControl) | Gets or sets the value of the member property specified by the ValueMember property.
SelectionMode (inherited from CheckedListBox) | Gets or sets a value specifying the selection mode.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from ListBox) | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from ListBox) | Gets or searches for the text of the currently selected item in the ListBox .
ThreeDCheckBoxes (inherited from CheckedListBox) | Gets or sets a value indicating whether the check boxes display as Flat or Normal in appearance.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopIndex (inherited from ListBox) | Gets or sets the index of the first visible item in the ListBox .
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseTabStops (inherited from ListBox) | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings.
ValueMember (inherited from CheckedListBox) |
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from CheckedListBox) |
DataManager (inherited from ListControl) | Gets the CurrencyManager associated with this control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from ListBox) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxCheckedListBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckedListBox.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxCheckedListBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckedListBox.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxCheckedListBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckedListBox Methods

The methods of the vdxCheckedListBox class are listed below. For a complete list of vdxCheckedListBox class members, see the vdxCheckedListBox Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from ListBox) | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearSelected (inherited from ListBox) | Unselects all items in the ListBox .
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from ListBox) | Resumes painting the ListBox control after painting is suspended by the BeginUpdatemethod.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindString (inherited from ListBox) | Overloaded. Finds the first item in the ListBox that starts with the specified string.
FindStringExact (inherited from ListBox) | Overloaded. Finds the first item in the ListBox that exactly matches the specified string.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetItemChecked (inherited from CheckedListBox) | Returns a value indicating whether the specified item is checked.
GetItemCheckState (inherited from CheckedListBox) | Returns a value indicating the check state of the current item.
GetItemHeight (inherited from ListBox) | Returns the height of an item in the ListBox .
GetItemRectangle (inherited from ListBox) | Returns the bounding rectangle for an item in the ListBox .
GetItemText (inherited from ListControl) | Returns the text representation of the specified item.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetSelected (inherited from ListBox) | Returns a value indicating whether the specified item is selected.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
IndexFromPoint (inherited from ListBox) | Overloaded. Returns the zero-based index of the item at the specified coordinates.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from ListBox) |
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetItemChecked (inherited from CheckedListBox) | Sets the item at the specified index to Checked .
SetItemCheckState (inherited from CheckedListBox) | Sets the check state of the item at the specified index.
SetSelected (inherited from ListBox) | Selects or clears the selection for the specified item in a ListBox .
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from ListBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AddItemsCore (inherited from ListBox) |
CreateAccessibilityInstance (inherited from CheckedListBox) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateItemCollection (inherited from CheckedListBox) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
FilterItemOnProperty (inherited from ListControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from ListControl) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from CheckedListBox) |
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from ListControl) |
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from ListBox) |
OnClick (inherited from CheckedListBox) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from ListBox) |
OnDisplayMemberChanged (inherited from ListBox) |
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnDrawItem (inherited from CheckedListBox) |
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from CheckedListBox) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from CheckedListBox) |
OnHandleDestroyed (inherited from ListBox) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnItemCheck (inherited from CheckedListBox) |
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from CheckedListBox) |
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMeasureItem (inherited from CheckedListBox) |
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ListBox) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from ListBox) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSelectedIndexChanged (inherited from CheckedListBox) | Raises the SelectedIndexChanged event.
OnSelectedValueChanged (inherited from ListBox) |
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueMemberChanged (inherited from ListControl) | Raises the ValueMemberChanged event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshItem (inherited from ListBox) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from ListBox) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetItemCore (inherited from ListBox) |
SetItemsCore (inherited from ListBox) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
Sort (inherited from ListBox) | Sorts the items in the ListBox alphabetically.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WmReflectCommand (inherited from CheckedListBox) |
WndProc (inherited from CheckedListBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxCheckedListBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckedListBox.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxCheckedListBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckedListBox.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxCheckedListBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox Class

Specialized .Net ComboBox that implements the IvdxBindable to bind the bindable properties. It also implements IvdxInputControl to provide input functionality.

For a list of all members of this type, see vdxComboBox Members.

System.Object
MarshalByRefObject
Component
Control
ListControl
ComboBox
vdxComboBox

public class vdxComboBox : ComboBox, IvdxInputControl, IvdxDsmHost, IvdxResettable, IvdxBindingManagable, IvdxBindable

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxComboBox Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox Members

vdxComboBox overview

Public Instance Constructors

vdxComboBox Overloaded. Initializes a new instance of the vdxComboBox class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from ComboBox) |
BackgroundImage (inherited from ComboBox) |
BindEmptyValuesAsNull | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataSource | Gets or sets the data source for this ComboBox.
DisplayMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source whose contents you want to display.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DrawMode (inherited from ComboBox) | Gets or sets a value indicating whether your code or the operating system will handle drawing of elements in the list.
DropDownStyle (inherited from ComboBox) | Gets or sets a value specifying the style of the combo box.
DropDownWidth (inherited from ComboBox) | Gets or sets the width of the of the drop-down portion of a combo box.
DroppedDown (inherited from ComboBox) | Gets or sets a value indicating whether the combo box is displaying its drop-down portion.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from ComboBox) |
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from ComboBox) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
IntegralHeight (inherited from ComboBox) | Gets or sets a value indicating whether the control should resize to avoid showing partial items.
InteractWithDSM | Gets/sets a value indicating whether the ComboBox interacts with the DSM. If set to true then the ComboBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from ComboBox) | Gets or sets the height of an item in the combo box.
Items (inherited from ComboBox) | Gets an object representing the collection of the items contained in this ComboBox .
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxDropDownItems (inherited from ComboBox) | Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox .
MaxLength (inherited from ComboBox) | Gets or sets the maximum number of characters allowed in the editable portion of a combo box.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from ComboBox) | Gets the preferred height of the ComboBox.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedIndex | Gets or sets the index of the currently selected item.
SelectedItem (inherited from ComboBox) | Gets or sets currently selected item in the ComboBox .
SelectedText (inherited from ComboBox) | Gets or sets the text that is selected in the editable portion of a ComboBox .
SelectedValue (inherited from ListControl) | Gets or sets the value of the member property specified by the ValueMember property.
SelectionLength (inherited from ComboBox) | Gets or sets the number of characters selected in the editable portion of the combo box.
SelectionStart (inherited from ComboBox) | Gets or sets the starting index of text selected in the combo box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from ComboBox) | Gets or sets a value indicating whether the items in the combo box are sorted.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from ComboBox) | Gets or sets the text associated with this control.
TextIsNull | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
ValueMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source from which to draw the value.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from ComboBox) | Maintains performance when items are added to the ComboBox one at a time.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from ComboBox) | Resumes painting the ComboBox control after painting is suspended by the BeginUpdate method.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindString (inherited from ComboBox) | Overloaded. Finds the first item in the combo box that starts with the specified string.
FindStringExact (inherited from ComboBox) | Overloaded. Finds the first item in the combo box that matches the specified string.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetItemHeight (inherited from ComboBox) | Returns the height of an item in the ComboBox.
GetItemText (inherited from ListControl) | Returns the text representation of the specified item.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from ComboBox) | Overloaded. Selects a range of text in the editable portion of the ComboBox.
Select (inherited from Control) | Overloaded. Activates the control.
SelectAll (inherited from ComboBox) | Selects all the text in the editable portion of the ComboBox .
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetSelectedDisplayValue | Sets the selected displayed value for the given display member.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from ComboBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from ComboBox) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
DataSourceChanged (inherited from ListControl) | Occurs when the DataSource changes.
DisplayMemberChanged (inherited from ListControl) | Occurs when the DisplayMember property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DrawItem (inherited from ComboBox) | Occurs when a visual aspect of an owner-drawn ComboBox changes.
DropDown (inherited from ComboBox) | Occurs when the drop-down portion of a ComboBox is shown.
DropDownStyleChanged (inherited from ComboBox) | Occurs when the DropDownStyle property has changed.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InteractiveChanged | Occurs when the user selects an item in the dropdown menu.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MeasureItem (inherited from ComboBox) | Occurs each time an owner-drawn ComboBox item needs to be drawn and when the sizes of the list items are determined.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from ComboBox) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectedIndexChanged (inherited from ComboBox) | Occurs when the SelectedIndex property has changed.
SelectedValueChanged (inherited from ListControl) | Occurs when the SelectedValue property changes.
SelectionChangeCommitted (inherited from ComboBox) | Occurs when the selected item has changed and that change is committed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueMemberChanged (inherited from ListControl) | Occurs when the ValueMember property changes.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from ComboBox) |
DataManager (inherited from ListControl) | Gets the CurrencyManager associated with this control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from ComboBox) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AddItemsCore (inherited from ComboBox) | Adds the specified items to the combo box.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ComboBox) | Overloaded.
FilterItemOnProperty (inherited from ListControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from ComboBox) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from ComboBox) |
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from ListControl) |
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from ComboBox) |
OnDisplayMemberChanged (inherited from ComboBox) |
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnDrawItem (inherited from ComboBox) | Raises the DrawItem event.
OnDropDown | Gets invoked eachtime a user opens the combo box.
OnDropDownStyleChanged (inherited from ComboBox) | Raises the DropDownStyleChanged event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ComboBox) |
OnForeColorChanged (inherited from ComboBox) |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from ComboBox) |
OnHandleDestroyed (inherited from ComboBox) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInteractiveChanged | Invokes the vdxInteractiveChanged Event
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown | Raises the OnKeyDown event.
OnKeyPress | Raises the OnKeyPress event.
OnKeyUp | Raises the OnKeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMeasureItem (inherited from ComboBox) | Raises the MeasureItem event.
OnMouseDown | Raises the OnMouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp | Raises the OnMouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from ComboBox) |
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from ComboBox) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSelectedIndexChanged | This member overrides OnSelectedIndexChanged.
OnSelectedItemChanged (inherited from ComboBox) |
OnSelectedValueChanged (inherited from ComboBox) |
OnSelectionChangeCommitted | Gets invoked each time a selection changes.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating | Overrides OnValidating to interact with vdxDataStatusManager.
OnValueMemberChanged (inherited from ListControl) | Raises the ValueMemberChanged event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshItem (inherited from ComboBox) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from ComboBox) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetItemCore (inherited from ComboBox) |
SetItemsCore (inherited from ComboBox) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from ComboBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager

Explicit Interface Implementations

IvdxInputControl.InitializeBinding | Do any initializing work like converting format.
IvdxResettable.Reset | Resets the value of the text box

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox Constructor

Initializes a new instance of the vdxComboBox class.

Overload List

Initializes a new instance of the vdxComboBox class.

public vdxComboBox();

Initializes a new instance of the vdxComboBox class.

public vdxComboBox(IContainer);

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox Constructor ()

Initializes a new instance of the vdxComboBox class.

public vdxComboBox();

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace | vdxComboBox Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox Constructor (IContainer)

Initializes a new instance of the vdxComboBox class.

public vdxComboBox(
IContainer container
);

Parameters

container
The container that holds this vdxComboBox instance.

Remarks

This contructor is usually used by the designer.

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace | vdxComboBox Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox Properties

The properties of the vdxComboBox class are listed below. For a complete list of vdxComboBox class members, see the vdxComboBox Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from ComboBox) |
BackgroundImage (inherited from ComboBox) |
BindEmptyValuesAsNull | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataSource | Gets or sets the data source for this ComboBox.
DisplayMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source whose contents you want to display.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DrawMode (inherited from ComboBox) | Gets or sets a value indicating whether your code or the operating system will handle drawing of elements in the list.
DropDownStyle (inherited from ComboBox) | Gets or sets a value specifying the style of the combo box.
DropDownWidth (inherited from ComboBox) | Gets or sets the width of the of the drop-down portion of a combo box.
DroppedDown (inherited from ComboBox) | Gets or sets a value indicating whether the combo box is displaying its drop-down portion.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from ComboBox) |
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from ComboBox) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
IntegralHeight (inherited from ComboBox) | Gets or sets a value indicating whether the control should resize to avoid showing partial items.
InteractWithDSM | Gets/sets a value indicating whether the ComboBox interacts with the DSM. If set to true then the ComboBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from ComboBox) | Gets or sets the height of an item in the combo box.
Items (inherited from ComboBox) | Gets an object representing the collection of the items contained in this ComboBox .
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxDropDownItems (inherited from ComboBox) | Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox .
MaxLength (inherited from ComboBox) | Gets or sets the maximum number of characters allowed in the editable portion of a combo box.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from ComboBox) | Gets the preferred height of the ComboBox.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedIndex | Gets or sets the index of the currently selected item.
SelectedItem (inherited from ComboBox) | Gets or sets currently selected item in the ComboBox .
SelectedText (inherited from ComboBox) | Gets or sets the text that is selected in the editable portion of a ComboBox .
SelectedValue (inherited from ListControl) | Gets or sets the value of the member property specified by the ValueMember property.
SelectionLength (inherited from ComboBox) | Gets or sets the number of characters selected in the editable portion of the combo box.
SelectionStart (inherited from ComboBox) | Gets or sets the starting index of text selected in the combo box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from ComboBox) | Gets or sets a value indicating whether the items in the combo box are sorted.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from ComboBox) | Gets or sets the text associated with this control.
TextIsNull | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
ValueMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source from which to draw the value.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ComboBox) |
DataManager (inherited from ListControl) | Gets the CurrencyManager associated with this control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from ComboBox) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.BindEmptyValuesAsNull Property

Gets or sets whether the empty values must be binded as null.

public bool BindEmptyValuesAsNull {get; set;}

Implements

IvdxInputControl.BindEmptyValuesAsNull

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.DataSource Property

Gets or sets the data source for this ComboBox.

new public object DataSource {get; set;}

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager Property

private Deag.Vdx.Controls.Core.vdxDataStatusManager Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager {get; set;}

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.InteractWithDSM Property

Gets/sets a value indicating whether the ComboBox interacts with the DSM. If set to true then the ComboBox will not force an AutoEdit on the DSM. Default value = true;

public bool InteractWithDSM {get; set;}

Implements

IvdxInputControl.InteractWithDSM

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.SelectedIndex Property

Gets or sets the index of the currently selected item.

public override int SelectedIndex {get; set;}

Remarks

System.Windows.Forms.ComboBox selects the first item, when SelectedIndex is set to -1 and the current index is greater than 0. SelectedIndex has to be set to -1 twice to avoid a value being selected. This override corrects that problem.

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.TextIsNull Property

This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.

public virtual bool TextIsNull {get; set;}

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox Methods

The methods of the vdxComboBox class are listed below. For a complete list of vdxComboBox class members, see the vdxComboBox Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from ComboBox) | Maintains performance when items are added to the ComboBox one at a time.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from ComboBox) | Resumes painting the ComboBox control after painting is suspended by the BeginUpdate method.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindString (inherited from ComboBox) | Overloaded. Finds the first item in the combo box that starts with the specified string.
FindStringExact (inherited from ComboBox) | Overloaded. Finds the first item in the combo box that matches the specified string.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetItemHeight (inherited from ComboBox) | Returns the height of an item in the ComboBox.
GetItemText (inherited from ListControl) | Returns the text representation of the specified item.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from ComboBox) | Overloaded. Selects a range of text in the editable portion of the ComboBox.
Select (inherited from Control) | Overloaded. Activates the control.
SelectAll (inherited from ComboBox) | Selects all the text in the editable portion of the ComboBox .
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetSelectedDisplayValue | Sets the selected displayed value for the given display member.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from ComboBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AddItemsCore (inherited from ComboBox) | Adds the specified items to the combo box.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ComboBox) | Overloaded.
FilterItemOnProperty (inherited from ListControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from ComboBox) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from ComboBox) |
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from ListControl) |
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from ComboBox) |
OnDisplayMemberChanged (inherited from ComboBox) |
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnDrawItem (inherited from ComboBox) | Raises the DrawItem event.
OnDropDown | Gets invoked eachtime a user opens the combo box.
OnDropDownStyleChanged (inherited from ComboBox) | Raises the DropDownStyleChanged event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ComboBox) |
OnForeColorChanged (inherited from ComboBox) |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from ComboBox) |
OnHandleDestroyed (inherited from ComboBox) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInteractiveChanged | Invokes the vdxInteractiveChanged Event
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown | Raises the OnKeyDown event.
OnKeyPress | Raises the OnKeyPress event.
OnKeyUp | Raises the OnKeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMeasureItem (inherited from ComboBox) | Raises the MeasureItem event.
OnMouseDown | Raises the OnMouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp | Raises the OnMouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from ComboBox) |
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from ComboBox) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSelectedIndexChanged | This member overrides OnSelectedIndexChanged.
OnSelectedItemChanged (inherited from ComboBox) |
OnSelectedValueChanged (inherited from ComboBox) |
OnSelectionChangeCommitted | Gets invoked each time a selection changes.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating | Overrides OnValidating to interact with vdxDataStatusManager.
OnValueMemberChanged (inherited from ListControl) | Raises the ValueMemberChanged event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshItem (inherited from ComboBox) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from ComboBox) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetItemCore (inherited from ComboBox) |
SetItemsCore (inherited from ComboBox) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from ComboBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IvdxInputControl.InitializeBinding | Do any initializing work like converting format.
IvdxResettable.Reset | Resets the value of the text box

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.IvdxInputControl.InitializeBinding Method

Do any initializing work like converting format.

void IvdxInputControl.InitializeBinding(
Binding binding
);

Implements

IvdxInputControl.InitializeBinding

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.IvdxResettable.Reset Method

Resets the value of the text box

void IvdxResettable.Reset();

Implements

IvdxResettable.Reset

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.OnDropDown Method

Gets invoked eachtime a user opens the combo box.

protected override void OnDropDown(
EventArgs e
);

Parameters

e
The EventArgs object.

Remarks

Checks if the selected row is in edit mode.

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.OnInteractiveChanged Method

Invokes the vdxInteractiveChanged Event

protected void OnInteractiveChanged();

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.OnKeyDown Method

Raises the OnKeyDown event.

protected override void OnKeyDown(
KeyEventArgs e
);

Parameters

e
An KeyEventArgs that contains the event data.

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.OnKeyPress Method

Raises the OnKeyPress event.

protected override void OnKeyPress(
KeyPressEventArgs e
);

Parameters

e
An KeyPressEventArgs that contains the event data.

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.OnKeyUp Method

Raises the OnKeyUp event.

protected override void OnKeyUp(
KeyEventArgs e
);

Parameters

e
An KeyEventArgs that contains the event data.

Remarks

In case of KeyUp event is invoked, its possible to paste text in the 'vdxTextBox', but the attached 'vdxDataStatusManager' may not allow this action.

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.OnMouseDown Method

Raises the OnMouseDown event.

protected override void OnMouseDown(
MouseEventArgs e
);

Parameters

e
An MouseEventArgs that contains the event data.

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.OnMouseUp Method

Raises the OnMouseUp event.

protected override void OnMouseUp(
MouseEventArgs e
);

Parameters

e
An MouseEventArgs that contains the event data.

Remarks

In case of MouseUp event is invoked by the right mouse button, the framework displays the default context menu. The context menu allows to copy/cut/etc. text in the 'vdxTextBox', but the attached 'vdxDataStatusManager' may not allow this action.

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.OnSelectedIndexChanged Method

This member overrides OnSelectedIndexChanged.

protected override void OnSelectedIndexChanged(
EventArgs e
);

Parameters

e
The EventArgs object.

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.OnSelectionChangeCommitted Method

Gets invoked each time a selection changes.

protected override void OnSelectionChangeCommitted(
EventArgs e
);

Parameters

e
The EventArgs object.

Remarks

If vdxDataStatus is not Edit or New (clean status), check if the selected row is in edit mode; if not, cancel the current edit.

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.OnValidating Method

Overrides OnValidating to interact with vdxDataStatusManager.

protected override void OnValidating(
CancelEventArgs e
);

Parameters

e
A CancelEventArgs that contains the event data.

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.SetSelectedDisplayValue Method

Sets the selected displayed value for the given display member.

public void SetSelectedDisplayValue(
string displayMember
);

Parameters

displayMember
The display member to select.

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox Events

The events of the vdxComboBox class are listed below. For a complete list of vdxComboBox class members, see the vdxComboBox Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from ComboBox) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
DataSourceChanged (inherited from ListControl) | Occurs when the DataSource changes.
DisplayMemberChanged (inherited from ListControl) | Occurs when the DisplayMember property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DrawItem (inherited from ComboBox) | Occurs when a visual aspect of an owner-drawn ComboBox changes.
DropDown (inherited from ComboBox) | Occurs when the drop-down portion of a ComboBox is shown.
DropDownStyleChanged (inherited from ComboBox) | Occurs when the DropDownStyle property has changed.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InteractiveChanged | Occurs when the user selects an item in the dropdown menu.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MeasureItem (inherited from ComboBox) | Occurs each time an owner-drawn ComboBox item needs to be drawn and when the sizes of the list items are determined.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from ComboBox) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectedIndexChanged (inherited from ComboBox) | Occurs when the SelectedIndex property has changed.
SelectedValueChanged (inherited from ListControl) | Occurs when the SelectedValue property changes.
SelectionChangeCommitted (inherited from ComboBox) | Occurs when the selected item has changed and that change is committed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueMemberChanged (inherited from ListControl) | Occurs when the ValueMember property changes.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBox.InteractiveChanged Event

Occurs when the user selects an item in the dropdown menu.

public event vdxInteractiveChangedEventHandler InteractiveChanged;

Event Data

The event handler receives an argument of type vdxInteractiveChangedEventArgs containing data related to this event. The following vdxInteractiveChangedEventArgs properties provide information specific to this event.

Property | Description
NewIndex | Gets the New Index.
NewItem | Gets the New Item.
NewValue | Gets the New Value.

See Also

vdxComboBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit Class

Editable ComboBox combined with a TextBox that implements the IvdxBindable to bind the bindable properties. It also implements IvdxInputControl to provide input functionality.

For a list of all members of this type, see vdxComboBoxEdit Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxComboBoxEdit

public class vdxComboBoxEdit : UserControl, IvdxInputControl, IvdxDsmHost, IvdxResettable, IvdxBindingManagable, IvdxBindable

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxComboBoxEdit Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit Members

vdxComboBoxEdit overview

Public Instance Constructors

vdxComboBoxEdit Constructor Default constructor

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindEmptyValuesAsNull | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from ContainerControl) |
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataSource | Gets and sets data source on dummy comboBox.
DisplayMember | Gets and sets display member on dummy comboBox.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM | Gets/sets a value indicating whether the ComboBox interacts with the DSM. If set to true then the ComboBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Gets or sets text on dummy textBox.
TextIsNull | Indicates whether text is null.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

txtDummy TextBox to provide special edit mode.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl) |
IvdxInputControl.InitializeBinding | Do any initializing work like converting format.
IvdxResettable.Reset |

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit Constructor

Default constructor

public vdxComboBoxEdit();

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit Fields

The fields of the vdxComboBoxEdit class are listed below. For a complete list of vdxComboBoxEdit class members, see the vdxComboBoxEdit Members topic.

Protected Instance Fields

txtDummy TextBox to provide special edit mode.

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit.txtDummy Field

TextBox to provide special edit mode.

protected vdxTextBox txtDummy;

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit Properties

The properties of the vdxComboBoxEdit class are listed below. For a complete list of vdxComboBoxEdit class members, see the vdxComboBoxEdit Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindEmptyValuesAsNull | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from ContainerControl) |
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataSource | Gets and sets data source on dummy comboBox.
DisplayMember | Gets and sets display member on dummy comboBox.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM | Gets/sets a value indicating whether the ComboBox interacts with the DSM. If set to true then the ComboBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Gets or sets text on dummy textBox.
TextIsNull | Indicates whether text is null.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit.BindEmptyValuesAsNull Property

Gets or sets whether the empty values must be binded as null.

public bool BindEmptyValuesAsNull {get; set;}

Implements

IvdxInputControl.BindEmptyValuesAsNull

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit.DataSource Property

Gets and sets data source on dummy comboBox.

public object DataSource {get; set;}

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit.Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager Property

private Deag.Vdx.Controls.Core.vdxDataStatusManager Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager {get; set;}

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit.DisplayMember Property

Gets and sets display member on dummy comboBox.

public string DisplayMember {get; set;}

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit.InteractWithDSM Property

Gets/sets a value indicating whether the ComboBox interacts with the DSM. If set to true then the ComboBox will not force an AutoEdit on the DSM. Default value = true;

public bool InteractWithDSM {get; set;}

Implements

IvdxInputControl.InteractWithDSM

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit.Text Property

Gets or sets text on dummy textBox.

public override string Text {get; set;}

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit.TextIsNull Property

Indicates whether text is null.

public bool TextIsNull {get; set;}

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit Methods

The methods of the vdxComboBoxEdit class are listed below. For a complete list of vdxComboBoxEdit class members, see the vdxComboBoxEdit Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl) |
IvdxInputControl.InitializeBinding | Do any initializing work like converting format.
IvdxResettable.Reset |

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit.IvdxInputControl.InitializeBinding Method

Do any initializing work like converting format.

void IvdxInputControl.InitializeBinding(
Binding binding
);

Implements

IvdxInputControl.InitializeBinding

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit.IvdxResettable.Reset Method

void IvdxResettable.Reset();

Implements

IvdxResettable.Reset

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Dispose Method

VDX Framework

vdxComboBoxEdit.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit.Dispose Method (Boolean)

Clean up any resources being used.

protected override void Dispose(
bool disposing
);

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace | vdxComboBoxEdit.Dispose Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxComboBoxEdit.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxComboBoxEdit Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxControl Class

Specialized .Net Control that implements the IvdxBindable to bind the bindable properties.

For a list of all members of this type, see vdxControl Members.

System.Object
MarshalByRefObject
Component
Control
vdxControl

public class vdxControl : Control, IvdxBindable

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxControl Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxControl Members

vdxControl overview

Public Instance Constructors

vdxControl Overloaded. Initializes a new instance of the vdxControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Control) | Gets the default size of the control.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxControl Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxControl Constructor

Initializes a new instance of the vdxControl class.

Overload List

Initializes a new instance of the vdxControl class.

public vdxControl();

Initializes a new instance of the vdxControl class with the specified container.

public vdxControl(IContainer);

See Also

vdxControl Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxControl Constructor ()

Initializes a new instance of the vdxControl class.

public vdxControl();

See Also

vdxControl Class | Deag.Vdx.Controls.Base Namespace | vdxControl Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxControl Constructor (IContainer)

Initializes a new instance of the vdxControl class with the specified container.

public vdxControl(
IContainer container
);

Parameters

container
The container of the Visual Studio Designer to add this panel.

Remarks

See Also

vdxControl Class | Deag.Vdx.Controls.Base Namespace | vdxControl Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxControl Properties

The properties of the vdxControl class are listed below. For a complete list of vdxControl class members, see the vdxControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Control) | Gets the default size of the control.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxControl Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxControl.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxControl Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxControl.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxControl Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxControl Methods

The methods of the vdxControl class are listed below. For a complete list of vdxControl class members, see the vdxControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxControl Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxControl.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxControl Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxControl.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxControl Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid Class

Specialized .Net DataGrid that implements the IvdxBindable to bind the bindable properties.

For a list of all members of this type, see vdxDataGrid Members.

System.Object
MarshalByRefObject
Component
Control
DataGrid
vdxDataGrid

public class vdxDataGrid : DataGrid, IvdxBindable

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataGrid Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid Members

vdxDataGrid overview

Public Instance Constructors

vdxDataGrid Constructor Initializes a new instance of the vdxDataGrid class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowNavigation (inherited from DataGrid) | Gets or sets a value indicating whether navigation is allowed.
AllowSorting (inherited from DataGrid) | Gets or sets a value indicating whether the grid can be resorted by clicking on a column header.
AlternatingBackColor (inherited from DataGrid) | Gets or sets the background color of odd-numbered rows of the grid.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from DataGrid) | Gets or sets the background color of even-numbered rows of the grid.
BackgroundColor (inherited from DataGrid) | Gets or sets the color of the non-row area of the grid.
BackgroundImage (inherited from DataGrid) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from DataGrid) | Gets or sets the grid's border style.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CaptionBackColor (inherited from DataGrid) | Gets or sets the background color of the caption area.
CaptionFont (inherited from DataGrid) | Gets or sets the font of the grid's caption.
CaptionForeColor (inherited from DataGrid) | Gets or sets the foreground color of the caption area.
CaptionText (inherited from DataGrid) | Gets or sets the text of the grid's window caption.
CaptionVisible (inherited from DataGrid) | Gets or sets a value that indicates whether the grid's caption is visible.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColumnHeadersVisible (inherited from DataGrid) | Gets or sets a value indicating whether the column headers a table are visible.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrencyManager | Gets the managed CurrencyManager of this data grid.
CurrentCell (inherited from DataGrid) | Gets or sets which cell has the focus. Not available at design time.
CurrentDataRow | Gets or sets the dataRows which are selected.
CurrentRowIndex (inherited from DataGrid) | Gets or sets index of the selected row.
Cursor (inherited from DataGrid) |
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataMember |
DataSource | Gets or sets the data source that this grid is displaying data for.
DataView | Gets the managed DataView of this data grid.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FirstVisibleColumn (inherited from DataGrid) | Gets the index of the first visible column in a grid.
FlatMode (inherited from DataGrid) | Gets or sets a value indicating whether the grid displays in flat mode.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from DataGrid) | Gets or sets the foreground color (typically the color of the text) property of the DataGrid control.
GridLineColor (inherited from DataGrid) | Gets or sets the color of the grid lines.
GridLineStyle (inherited from DataGrid) | Gets or sets the line style of the grid.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HeaderBackColor (inherited from DataGrid) | Gets or sets the background color of all row and column headers.
HeaderFont (inherited from DataGrid) | Gets or sets the font used for column headers.
HeaderForeColor (inherited from DataGrid) | Gets or sets the foreground color of headers.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Item (inherited from DataGrid) | Gets or sets the value of the cell at the specified the row and column.
Item (inherited from DataGrid) | Gets or sets the value of a specified DataGridCell .
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LinkColor (inherited from DataGrid) | Gets or sets the color of the text that you can click to navigate to a child table.
LinkHoverColor (inherited from DataGrid) | Gets or sets the color a link changes to when the mouse pointer moves over it.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentRowsBackColor (inherited from DataGrid) | Gets or sets the background color of parent rows.
ParentRowsForeColor (inherited from DataGrid) | Gets or sets the foreground color of parent rows.
ParentRowsLabelStyle (inherited from DataGrid) | Gets or sets the way parent row labels are displayed.
ParentRowsVisible (inherited from DataGrid) | Gets or sets a value indicating whether the parent rows of a table are visible.
PreferredColumnWidth (inherited from DataGrid) | Gets or sets the default width of the grid columns in pixels.
PreferredRowHeight (inherited from DataGrid) | Gets or sets the preferred row height for the DataGrid control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from DataGrid) | Gets or sets a value indicating whether the grid is in read-only mode.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RowHeadersVisible (inherited from DataGrid) | Gets or sets a value that specifies whether row headers are visible.
RowHeaderWidth (inherited from DataGrid) | Gets or sets the width of row headers.
SelectedDataRows | Gets or sets the dataRows which are selected.
SelectionBackColor (inherited from DataGrid) | Gets or sets the background color of selected rows.
SelectionForeColor (inherited from DataGrid) | Gets or set the foreground color of selected rows.
Site (inherited from DataGrid) |
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TableStyles (inherited from DataGrid) | Gets the collection of DataGridTableStyle objects for the grid.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from DataGrid) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisibleColumnCount (inherited from DataGrid) | Gets the number of visible columns.
VisibleRowCount (inherited from DataGrid) | Gets the number of rows visible.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginEdit (inherited from DataGrid) | Attempts to put the grid into a state where editing is allowed.
BeginInit (inherited from DataGrid) | Begins the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Collapse (inherited from DataGrid) | Collapses child relations, if any exist for all rows, or for a specified row.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndEdit (inherited from DataGrid) | Requests an end to an edit operation taking place on the DataGrid control.
EndInit (inherited from DataGrid) | Ends the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from DataGrid) | Displays child relations, if any exist, for all rows or a specific row.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindRows | Find rows by a SQL where clause.
FindText | Full text search for the passed Text. Every row is scanned for the Text. If the row contains the text, it is added to the resultion row collection.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetCellBounds (inherited from DataGrid) | Overloaded. Gets the Rectangle of the cell specified by row and column number.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetCurrentCellBounds (inherited from DataGrid) | Gets a Rectangle that specifies the four corners of the selected cell.
GetDataRowAT | Gets the Datarow with the specified index
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetRowIndex | Returns the (momentary) index of a row in the grid. The returned index depends on the momentary sort order.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HitTest (inherited from DataGrid) | Overloaded. Gets information, such as row and column number of a clicked point on the grid, using the x and y coordinate passed to the method.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
IsExpanded (inherited from DataGrid) | Gets a value that indicates whether a specified row's node is expanded or collapsed.
IsSelected (inherited from DataGrid) | Gets a value indicating whether a specified row is selected.
MoveFirst | Moves to the first record in the grid
MoveLast | Move to the last record of the grid if possible
MoveNext | Moves to the next record in the grid. If we are already on the last record, moves to the first record.
MovePrevious | Moves to the previous record in the grid. If we are already on the first recorde, moves to the last record
NavigateBack (inherited from DataGrid) | Navigates back to the table previously displayed in the grid.
NavigateTo (inherited from DataGrid) | Navigates to the table specified by row and relation name.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetAlternatingBackColor (inherited from DataGrid) | Resets the AlternatingBackColor property to its default color.
ResetBackColor (inherited from DataGrid) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from DataGrid) | Resets the ForeColor property to its default value.
ResetGridLineColor (inherited from DataGrid) | Resets the GridLineColor property to its default value.
ResetHeaderBackColor (inherited from DataGrid) | Resets the HeaderBackColor property to its default value.
ResetHeaderFont (inherited from DataGrid) | Resets the HeaderFont property to its default value.
ResetHeaderForeColor (inherited from DataGrid) | Resets the HeaderForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetLinkColor (inherited from DataGrid) | Resets the LinkColor property to its default value.
ResetLinkHoverColor (inherited from DataGrid) |
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetSelectionBackColor (inherited from DataGrid) | Resets the SelectionBackColor property to its default value.
ResetSelectionForeColor (inherited from DataGrid) | Resets the SelectionForeColor property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from DataGrid) | Overloaded. Selects a specified row.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDataBinding (inherited from DataGrid) | Sets the DataSource and DataMember properties at run time.
Show (inherited from Control) | Displays the control to the user.
SubObjectsSiteChange (inherited from DataGrid) |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
UnSelect (inherited from DataGrid) | Unselects a specified row.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AllowNavigationChanged (inherited from DataGrid) | Occurs when the AllowNavigation property has changed.
BackButtonClick (inherited from DataGrid) | Occurs when the Back button on a child table is clicked.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundColorChanged (inherited from DataGrid) | Occurs when the BackgroundColor has changed.
BackgroundImageChanged (inherited from DataGrid) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
BorderStyleChanged (inherited from DataGrid) | Occurs when the BorderStyle has changed.
CaptionVisibleChanged (inherited from DataGrid) | Occurs when the CaptionVisible property has changed.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CurrentCellChanged (inherited from DataGrid) | Occurs when the CurrentCell property has changed.
CursorChanged (inherited from DataGrid) |
DataSourceChanged (inherited from DataGrid) | Occurs when the DataSource property value has changed.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FlatModeChanged (inherited from DataGrid) | Occurs when the FlatMode has changed.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Navigate (inherited from DataGrid) | Occurs when the user navigates to a new table.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
ParentRowsLabelStyleChanged (inherited from DataGrid) | Occurs when the label style of the parent row is changed.
ParentRowsVisibleChanged (inherited from DataGrid) | Occurs when the ParentRowsVisible property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
ReadOnlyChanged (inherited from DataGrid) | Occurs when the ReadOnly property value changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from DataGrid) | Occurs when the user scrolls the DataGrid control.
ShowParentDetailsButtonClick (inherited from DataGrid) | Occurs when the ShowParentDetails button is clicked.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from DataGrid) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DataSet | Gets or sets DataSet on DataSource.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from DataGrid) | Gets the default size of the control.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HorizScrollBar (inherited from DataGrid) | Gets the horizontal scrollbar for the grid.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
SelectedDataRow | Gets the corresponding selected data row.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VertScrollBar (inherited from DataGrid) | Gets the vertical scroll bar of the control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CancelEditing (inherited from DataGrid) | Cancels the current edit operation and rolls back all changes.
CreateAccessibilityInstance (inherited from DataGrid) | Constructs a new instance of the accessibility object for this control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateGridColumn (inherited from DataGrid) | Overloaded. Creates a new DataGridColumnStyle with the specified PropertyDescriptor.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from DataGrid) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetOutputTextDelimiter (inherited from DataGrid) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GridHScrolled (inherited from DataGrid) | Listens for the horizontal scrollbar's scroll event.
GridVScrolled (inherited from DataGrid) | Listens for the vertical scrollbar's scroll event.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAllowNavigationChanged (inherited from DataGrid) | Raises the AllowNavigationChanged event.
OnBackButtonClicked (inherited from DataGrid) | Listens for the caption's back button clicked event.
OnBackColorChanged (inherited from DataGrid) | Raises the BackColorChanged event.
OnBackgroundColorChanged (inherited from DataGrid) | Raises the BackgroundColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from DataGrid) | Raises the BindingContextChanged event.
OnBorderStyleChanged (inherited from DataGrid) | Raises the BorderStyleChanged event.
OnCaptionVisibleChanged (inherited from DataGrid) | Raises the CaptionVisibleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCurrentCellChanged (inherited from DataGrid) | Raises the CurrentCellChanged event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from DataGrid) | Raises the DataSourceChanged event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from DataGrid) | Raises the Enter event.
OnFlatModeChanged (inherited from DataGrid) | Raises the FlatModeChanged event.
OnFontChanged (inherited from DataGrid) | Raises the FontChanged event.
OnForeColorChanged (inherited from DataGrid) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from DataGrid) | Raises the CreateHandle event.
OnHandleDestroyed (inherited from DataGrid) | Raises the DestroyHandle event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from DataGrid) | Raises the KeyDown event.
OnKeyPress (inherited from DataGrid) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from DataGrid) | Raises the Layout event that repositions controls and updates scroll bars.
OnLeave (inherited from DataGrid) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from DataGrid) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from DataGrid) | Creates the MouseLeave event.
OnMouseMove (inherited from DataGrid) | Raises the MouseMove event.
OnMouseUp (inherited from DataGrid) | Raises the MouseUp event.
OnMouseWheel (inherited from DataGrid) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNavigate (inherited from DataGrid) | Raises the Navigate event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from DataGrid) | Raises the Paint event.
OnPaintBackground (inherited from DataGrid) | Overrides OnPaintBackground to prevent painting the background of the DataGrid control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentRowsLabelStyleChanged (inherited from DataGrid) | Raises the ParentRowsLabelStyleChanged event.
OnParentRowsVisibleChanged (inherited from DataGrid) | Raises the ParentRowsVisibleChanged event.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from DataGrid) | Raises the ReadOnlyChanged event
OnResize (inherited from DataGrid) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnRowHeaderClick (inherited from DataGrid) | Raises the RowHeaderClick event.
OnScroll (inherited from DataGrid) | Raises the Scroll event.
OnShowParentDetailsButtonClicked (inherited from DataGrid) | Raises the ShowParentDetailsButtonClick event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from DataGrid) | Gets or sets a value that indicates whether a key should be processed further.
ProcessGridKey (inherited from DataGrid) | Processes keys for grid navigation.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from DataGrid) | Previews a keyboard message and returns a value indicating if the key was consumed.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
ProcessTabKey (inherited from DataGrid) | Gets a value indicating whether the Tab key should be processed.
ProviderToSet_OnDataTypeSet | Listens to the Event OnDataTypeSet that was set on DataSource and set the DataSource with the sender.
ProviderToSet_OnDataTypeSetDM |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
ResetSelection (inherited from DataGrid) | Turns off selection for all rows that are selected.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShouldSerializeAlternatingBackColor (inherited from DataGrid) | Indicates whether the AlternatingBackColor property should be persisted.
ShouldSerializeBackgroundColor (inherited from DataGrid) | Indicates whether the BackgroundColor property should be persisted.
ShouldSerializeCaptionBackColor (inherited from DataGrid) | Gets a value indicating whether the CaptionBackColor property should be persisted.
ShouldSerializeCaptionForeColor (inherited from DataGrid) | Gets a value indicating whether the CaptionForeColor property should be persisted.
ShouldSerializeGridLineColor (inherited from DataGrid) | Indicates whether the GridLineColor property should be persisted.
ShouldSerializeHeaderBackColor (inherited from DataGrid) | Indicates whether the HeaderBackColor property should be persisted.
ShouldSerializeHeaderFont (inherited from DataGrid) | Indicates whether the HeaderFont property should be persisted.
ShouldSerializeHeaderForeColor (inherited from DataGrid) | Indicates whether the HeaderForeColor property should be persisted.
ShouldSerializeLinkHoverColor (inherited from DataGrid) | Indicates whether the LinkHoverColor property should be persisted.
ShouldSerializeParentRowsBackColor (inherited from DataGrid) | Indicates whether the ParentRowsBackColor property should be persisted.
ShouldSerializeParentRowsForeColor (inherited from DataGrid) | Indicates whether the ParentRowsForeColor property should be persisted.
ShouldSerializePreferredRowHeight (inherited from DataGrid) | Indicates whether the PreferredRowHeight property should be persisted.
ShouldSerializeSelectionBackColor (inherited from DataGrid) | Indicates whether the SelectionBackColor property should be persisted.
ShouldSerializeSelectionForeColor (inherited from DataGrid) | Indicates whether the SelectionForeColor property should be persisted.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Instance Events

RowHeaderClick (inherited from DataGrid) Occurs when a row header is clicked.

Protected Internal Instance Properties

ListManager (inherited from DataGrid) Gets the CurrencyManager for this DataGrid control.

Protected Internal Instance Methods

ColumnStartedEditing (inherited from DataGrid) | Overloaded. Informs the DataGrid control when the user begins to edit a column using the specified control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid Constructor

Initializes a new instance of the vdxDataGrid class.

public vdxDataGrid();

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid Properties

The properties of the vdxDataGrid class are listed below. For a complete list of vdxDataGrid class members, see the vdxDataGrid Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowNavigation (inherited from DataGrid) | Gets or sets a value indicating whether navigation is allowed.
AllowSorting (inherited from DataGrid) | Gets or sets a value indicating whether the grid can be resorted by clicking on a column header.
AlternatingBackColor (inherited from DataGrid) | Gets or sets the background color of odd-numbered rows of the grid.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from DataGrid) | Gets or sets the background color of even-numbered rows of the grid.
BackgroundColor (inherited from DataGrid) | Gets or sets the color of the non-row area of the grid.
BackgroundImage (inherited from DataGrid) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from DataGrid) | Gets or sets the grid's border style.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CaptionBackColor (inherited from DataGrid) | Gets or sets the background color of the caption area.
CaptionFont (inherited from DataGrid) | Gets or sets the font of the grid's caption.
CaptionForeColor (inherited from DataGrid) | Gets or sets the foreground color of the caption area.
CaptionText (inherited from DataGrid) | Gets or sets the text of the grid's window caption.
CaptionVisible (inherited from DataGrid) | Gets or sets a value that indicates whether the grid's caption is visible.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColumnHeadersVisible (inherited from DataGrid) | Gets or sets a value indicating whether the column headers a table are visible.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrencyManager | Gets the managed CurrencyManager of this data grid.
CurrentCell (inherited from DataGrid) | Gets or sets which cell has the focus. Not available at design time.
CurrentDataRow | Gets or sets the dataRows which are selected.
CurrentRowIndex (inherited from DataGrid) | Gets or sets index of the selected row.
Cursor (inherited from DataGrid) |
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataMember |
DataSource | Gets or sets the data source that this grid is displaying data for.
DataView | Gets the managed DataView of this data grid.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FirstVisibleColumn (inherited from DataGrid) | Gets the index of the first visible column in a grid.
FlatMode (inherited from DataGrid) | Gets or sets a value indicating whether the grid displays in flat mode.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from DataGrid) | Gets or sets the foreground color (typically the color of the text) property of the DataGrid control.
GridLineColor (inherited from DataGrid) | Gets or sets the color of the grid lines.
GridLineStyle (inherited from DataGrid) | Gets or sets the line style of the grid.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HeaderBackColor (inherited from DataGrid) | Gets or sets the background color of all row and column headers.
HeaderFont (inherited from DataGrid) | Gets or sets the font used for column headers.
HeaderForeColor (inherited from DataGrid) | Gets or sets the foreground color of headers.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Item (inherited from DataGrid) | Gets or sets the value of the cell at the specified the row and column.
Item (inherited from DataGrid) | Gets or sets the value of a specified DataGridCell .
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LinkColor (inherited from DataGrid) | Gets or sets the color of the text that you can click to navigate to a child table.
LinkHoverColor (inherited from DataGrid) | Gets or sets the color a link changes to when the mouse pointer moves over it.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentRowsBackColor (inherited from DataGrid) | Gets or sets the background color of parent rows.
ParentRowsForeColor (inherited from DataGrid) | Gets or sets the foreground color of parent rows.
ParentRowsLabelStyle (inherited from DataGrid) | Gets or sets the way parent row labels are displayed.
ParentRowsVisible (inherited from DataGrid) | Gets or sets a value indicating whether the parent rows of a table are visible.
PreferredColumnWidth (inherited from DataGrid) | Gets or sets the default width of the grid columns in pixels.
PreferredRowHeight (inherited from DataGrid) | Gets or sets the preferred row height for the DataGrid control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from DataGrid) | Gets or sets a value indicating whether the grid is in read-only mode.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RowHeadersVisible (inherited from DataGrid) | Gets or sets a value that specifies whether row headers are visible.
RowHeaderWidth (inherited from DataGrid) | Gets or sets the width of row headers.
SelectedDataRows | Gets or sets the dataRows which are selected.
SelectionBackColor (inherited from DataGrid) | Gets or sets the background color of selected rows.
SelectionForeColor (inherited from DataGrid) | Gets or set the foreground color of selected rows.
Site (inherited from DataGrid) |
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TableStyles (inherited from DataGrid) | Gets the collection of DataGridTableStyle objects for the grid.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from DataGrid) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisibleColumnCount (inherited from DataGrid) | Gets the number of visible columns.
VisibleRowCount (inherited from DataGrid) | Gets the number of rows visible.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DataSet | Gets or sets DataSet on DataSource.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from DataGrid) | Gets the default size of the control.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HorizScrollBar (inherited from DataGrid) | Gets the horizontal scrollbar for the grid.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
SelectedDataRow | Gets the corresponding selected data row.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VertScrollBar (inherited from DataGrid) | Gets the vertical scroll bar of the control.

Protected Internal Instance Properties

ListManager (inherited from DataGrid) Gets the CurrencyManager for this DataGrid control.

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.CurrencyManager Property

Gets the managed CurrencyManager of this data grid.

public System.Windows.Forms.CurrencyManager CurrencyManager {get;}

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.CurrentDataRow Property

Gets or sets the dataRows which are selected.

public System.Data.DataRow CurrentDataRow {get; set;}

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.DataMember Property

new public string DataMember {get; set;}

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.DataSet Property

Gets or sets DataSet on DataSource.

protected System.Data.DataSet DataSet {get; set;}

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.DataSource Property

Gets or sets the data source that this grid is displaying data for.

new public object DataSource {get; set;}

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.DataView Property

Gets the managed DataView of this data grid.

public System.Data.DataView DataView {get;}

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.SelectedDataRow Property

Gets the corresponding selected data row.

protected System.Data.DataRow SelectedDataRow {get;}

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.SelectedDataRows Property

Gets or sets the dataRows which are selected.

public System.Data.DataRow[] SelectedDataRows {get; set;}

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid Methods

The methods of the vdxDataGrid class are listed below. For a complete list of vdxDataGrid class members, see the vdxDataGrid Members topic.

Public Instance Methods

BeginEdit (inherited from DataGrid) | Attempts to put the grid into a state where editing is allowed.
BeginInit (inherited from DataGrid) | Begins the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Collapse (inherited from DataGrid) | Collapses child relations, if any exist for all rows, or for a specified row.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndEdit (inherited from DataGrid) | Requests an end to an edit operation taking place on the DataGrid control.
EndInit (inherited from DataGrid) | Ends the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from DataGrid) | Displays child relations, if any exist, for all rows or a specific row.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindRows | Find rows by a SQL where clause.
FindText | Full text search for the passed Text. Every row is scanned for the Text. If the row contains the text, it is added to the resultion row collection.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetCellBounds (inherited from DataGrid) | Overloaded. Gets the Rectangle of the cell specified by row and column number.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetCurrentCellBounds (inherited from DataGrid) | Gets a Rectangle that specifies the four corners of the selected cell.
GetDataRowAT | Gets the Datarow with the specified index
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetRowIndex | Returns the (momentary) index of a row in the grid. The returned index depends on the momentary sort order.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HitTest (inherited from DataGrid) | Overloaded. Gets information, such as row and column number of a clicked point on the grid, using the x and y coordinate passed to the method.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
IsExpanded (inherited from DataGrid) | Gets a value that indicates whether a specified row's node is expanded or collapsed.
IsSelected (inherited from DataGrid) | Gets a value indicating whether a specified row is selected.
MoveFirst | Moves to the first record in the grid
MoveLast | Move to the last record of the grid if possible
MoveNext | Moves to the next record in the grid. If we are already on the last record, moves to the first record.
MovePrevious | Moves to the previous record in the grid. If we are already on the first recorde, moves to the last record
NavigateBack (inherited from DataGrid) | Navigates back to the table previously displayed in the grid.
NavigateTo (inherited from DataGrid) | Navigates to the table specified by row and relation name.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetAlternatingBackColor (inherited from DataGrid) | Resets the AlternatingBackColor property to its default color.
ResetBackColor (inherited from DataGrid) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from DataGrid) | Resets the ForeColor property to its default value.
ResetGridLineColor (inherited from DataGrid) | Resets the GridLineColor property to its default value.
ResetHeaderBackColor (inherited from DataGrid) | Resets the HeaderBackColor property to its default value.
ResetHeaderFont (inherited from DataGrid) | Resets the HeaderFont property to its default value.
ResetHeaderForeColor (inherited from DataGrid) | Resets the HeaderForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetLinkColor (inherited from DataGrid) | Resets the LinkColor property to its default value.
ResetLinkHoverColor (inherited from DataGrid) |
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetSelectionBackColor (inherited from DataGrid) | Resets the SelectionBackColor property to its default value.
ResetSelectionForeColor (inherited from DataGrid) | Resets the SelectionForeColor property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from DataGrid) | Overloaded. Selects a specified row.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDataBinding (inherited from DataGrid) | Sets the DataSource and DataMember properties at run time.
Show (inherited from Control) | Displays the control to the user.
SubObjectsSiteChange (inherited from DataGrid) |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
UnSelect (inherited from DataGrid) | Unselects a specified row.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CancelEditing (inherited from DataGrid) | Cancels the current edit operation and rolls back all changes.
CreateAccessibilityInstance (inherited from DataGrid) | Constructs a new instance of the accessibility object for this control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateGridColumn (inherited from DataGrid) | Overloaded. Creates a new DataGridColumnStyle with the specified PropertyDescriptor.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from DataGrid) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetOutputTextDelimiter (inherited from DataGrid) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GridHScrolled (inherited from DataGrid) | Listens for the horizontal scrollbar's scroll event.
GridVScrolled (inherited from DataGrid) | Listens for the vertical scrollbar's scroll event.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAllowNavigationChanged (inherited from DataGrid) | Raises the AllowNavigationChanged event.
OnBackButtonClicked (inherited from DataGrid) | Listens for the caption's back button clicked event.
OnBackColorChanged (inherited from DataGrid) | Raises the BackColorChanged event.
OnBackgroundColorChanged (inherited from DataGrid) | Raises the BackgroundColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from DataGrid) | Raises the BindingContextChanged event.
OnBorderStyleChanged (inherited from DataGrid) | Raises the BorderStyleChanged event.
OnCaptionVisibleChanged (inherited from DataGrid) | Raises the CaptionVisibleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCurrentCellChanged (inherited from DataGrid) | Raises the CurrentCellChanged event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from DataGrid) | Raises the DataSourceChanged event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from DataGrid) | Raises the Enter event.
OnFlatModeChanged (inherited from DataGrid) | Raises the FlatModeChanged event.
OnFontChanged (inherited from DataGrid) | Raises the FontChanged event.
OnForeColorChanged (inherited from DataGrid) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from DataGrid) | Raises the CreateHandle event.
OnHandleDestroyed (inherited from DataGrid) | Raises the DestroyHandle event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from DataGrid) | Raises the KeyDown event.
OnKeyPress (inherited from DataGrid) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from DataGrid) | Raises the Layout event that repositions controls and updates scroll bars.
OnLeave (inherited from DataGrid) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from DataGrid) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from DataGrid) | Creates the MouseLeave event.
OnMouseMove (inherited from DataGrid) | Raises the MouseMove event.
OnMouseUp (inherited from DataGrid) | Raises the MouseUp event.
OnMouseWheel (inherited from DataGrid) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNavigate (inherited from DataGrid) | Raises the Navigate event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from DataGrid) | Raises the Paint event.
OnPaintBackground (inherited from DataGrid) | Overrides OnPaintBackground to prevent painting the background of the DataGrid control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentRowsLabelStyleChanged (inherited from DataGrid) | Raises the ParentRowsLabelStyleChanged event.
OnParentRowsVisibleChanged (inherited from DataGrid) | Raises the ParentRowsVisibleChanged event.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from DataGrid) | Raises the ReadOnlyChanged event
OnResize (inherited from DataGrid) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnRowHeaderClick (inherited from DataGrid) | Raises the RowHeaderClick event.
OnScroll (inherited from DataGrid) | Raises the Scroll event.
OnShowParentDetailsButtonClicked (inherited from DataGrid) | Raises the ShowParentDetailsButtonClick event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from DataGrid) | Gets or sets a value that indicates whether a key should be processed further.
ProcessGridKey (inherited from DataGrid) | Processes keys for grid navigation.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from DataGrid) | Previews a keyboard message and returns a value indicating if the key was consumed.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
ProcessTabKey (inherited from DataGrid) | Gets a value indicating whether the Tab key should be processed.
ProviderToSet_OnDataTypeSet | Listens to the Event OnDataTypeSet that was set on DataSource and set the DataSource with the sender.
ProviderToSet_OnDataTypeSetDM |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
ResetSelection (inherited from DataGrid) | Turns off selection for all rows that are selected.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShouldSerializeAlternatingBackColor (inherited from DataGrid) | Indicates whether the AlternatingBackColor property should be persisted.
ShouldSerializeBackgroundColor (inherited from DataGrid) | Indicates whether the BackgroundColor property should be persisted.
ShouldSerializeCaptionBackColor (inherited from DataGrid) | Gets a value indicating whether the CaptionBackColor property should be persisted.
ShouldSerializeCaptionForeColor (inherited from DataGrid) | Gets a value indicating whether the CaptionForeColor property should be persisted.
ShouldSerializeGridLineColor (inherited from DataGrid) | Indicates whether the GridLineColor property should be persisted.
ShouldSerializeHeaderBackColor (inherited from DataGrid) | Indicates whether the HeaderBackColor property should be persisted.
ShouldSerializeHeaderFont (inherited from DataGrid) | Indicates whether the HeaderFont property should be persisted.
ShouldSerializeHeaderForeColor (inherited from DataGrid) | Indicates whether the HeaderForeColor property should be persisted.
ShouldSerializeLinkHoverColor (inherited from DataGrid) | Indicates whether the LinkHoverColor property should be persisted.
ShouldSerializeParentRowsBackColor (inherited from DataGrid) | Indicates whether the ParentRowsBackColor property should be persisted.
ShouldSerializeParentRowsForeColor (inherited from DataGrid) | Indicates whether the ParentRowsForeColor property should be persisted.
ShouldSerializePreferredRowHeight (inherited from DataGrid) | Indicates whether the PreferredRowHeight property should be persisted.
ShouldSerializeSelectionBackColor (inherited from DataGrid) | Indicates whether the SelectionBackColor property should be persisted.
ShouldSerializeSelectionForeColor (inherited from DataGrid) | Indicates whether the SelectionForeColor property should be persisted.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ColumnStartedEditing (inherited from DataGrid) | Overloaded. Informs the DataGrid control when the user begins to edit a column using the specified control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.FindRows Method

Find rows by a SQL where clause.

public DataRow[] FindRows(
string sWhere
);

Parameters

sWhere
The where statement

Return Value

Array with the results

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.FindText Method

Full text search for the passed Text. Every row is scanned for the Text. If the row contains the text, it is added to the resultion row collection.

public DataRow[] FindText(
string Text
);

Parameters

Text
Text to scan for

Return Value

Array of found rows or empty array if no rows have been found

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.GetDataRowAT Method

Gets the Datarow with the specified index

public DataRow GetDataRowAT(
int RowNum
);

Parameters

RowNum
Index of the DataRow

Return Value

The DataRow or null if no row found

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.GetRowIndex Method

Returns the (momentary) index of a row in the grid. The returned index depends on the momentary sort order.

public int GetRowIndex(
DataRow row
);

Parameters

row
The row to look for

Return Value

The index of the row or -1 if the row was not found

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.MoveFirst Method

Moves to the first record in the grid

public void MoveFirst();

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.MoveLast Method

Move to the last record of the grid if possible

public void MoveLast();

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.MoveNext Method

Moves to the next record in the grid. If we are already on the last record, moves to the first record.

public void MoveNext();

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.MovePrevious Method

Moves to the previous record in the grid. If we are already on the first recorde, moves to the last record

public void MovePrevious();

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.ProviderToSet_OnDataTypeSet Method

Listens to the Event OnDataTypeSet that was set on DataSource and set the DataSource with the sender.

protected virtual void ProviderToSet_OnDataTypeSet(
object sender,
EventArgs e
);

Parameters

sender
The new DataSource to set.
e
not used

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.ProviderToSet_OnDataTypeSetDM Method

protected virtual void ProviderToSet_OnDataTypeSetDM(
object sender,
EventArgs e
);

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGrid.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxDataGrid Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridManipulator Class

Displays data in a scrollable grid and offer editing features.

For a list of all members of this type, see vdxDataGridManipulator Members.

System.Object
MarshalByRefObject
Component
Control
DataGrid
vdxDataGrid
vdxDataGridManipulator

public class vdxDataGridManipulator : vdxDataGrid

Remarks

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataGridManipulator Members | Deag.Vdx.Controls.Base Namespace | vdxDataGrid

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridManipulator Members

vdxDataGridManipulator overview

Public Instance Constructors

vdxDataGridManipulator Constructor Initializes a new instance of the vdxDataGridManipulator class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowAdd | Gets or sets whether the user is allowed to add new records. If AllowAdd is set to true, AllowEdit is also set to true.
AllowDelete | Gets or sets whether the user is allowed to delete records
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowEdit | Gets or sets whether the user is allowed to edit records
AllowNavigation (inherited from DataGrid) | Gets or sets a value indicating whether navigation is allowed.
AllowSorting (inherited from DataGrid) | Gets or sets a value indicating whether the grid can be resorted by clicking on a column header.
AlternatingBackColor (inherited from DataGrid) | Gets or sets the background color of odd-numbered rows of the grid.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from DataGrid) | Gets or sets the background color of even-numbered rows of the grid.
BackgroundColor (inherited from DataGrid) | Gets or sets the color of the non-row area of the grid.
BackgroundImage (inherited from DataGrid) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxDataGrid) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from DataGrid) | Gets or sets the grid's border style.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CaptionBackColor (inherited from DataGrid) | Gets or sets the background color of the caption area.
CaptionFont (inherited from DataGrid) | Gets or sets the font of the grid's caption.
CaptionForeColor (inherited from DataGrid) | Gets or sets the foreground color of the caption area.
CaptionText (inherited from DataGrid) | Gets or sets the text of the grid's window caption.
CaptionVisible (inherited from DataGrid) | Gets or sets a value that indicates whether the grid's caption is visible.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColumnHeadersVisible (inherited from DataGrid) | Gets or sets a value indicating whether the column headers a table are visible.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrencyManager (inherited from vdxDataGrid) | Gets the managed CurrencyManager of this data grid.
CurrentCell (inherited from DataGrid) | Gets or sets which cell has the focus. Not available at design time.
CurrentDataRow (inherited from vdxDataGrid) | Gets or sets the dataRows which are selected.
CurrentRowIndex (inherited from DataGrid) | Gets or sets index of the selected row.
Cursor (inherited from DataGrid) |
DataBindingInfos (inherited from vdxDataGrid) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataMember (inherited from vdxDataGrid) |
DataSource (inherited from vdxDataGrid) | Gets or sets the data source that this grid is displaying data for.
DataView (inherited from vdxDataGrid) | Gets the managed DataView of this data grid.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FirstVisibleColumn (inherited from DataGrid) | Gets the index of the first visible column in a grid.
FlatMode (inherited from DataGrid) | Gets or sets a value indicating whether the grid displays in flat mode.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from DataGrid) | Gets or sets the foreground color (typically the color of the text) property of the DataGrid control.
GridLineColor (inherited from DataGrid) | Gets or sets the color of the grid lines.
GridLineStyle (inherited from DataGrid) | Gets or sets the line style of the grid.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HeaderBackColor (inherited from DataGrid) | Gets or sets the background color of all row and column headers.
HeaderFont (inherited from DataGrid) | Gets or sets the font used for column headers.
HeaderForeColor (inherited from DataGrid) | Gets or sets the foreground color of headers.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Item (inherited from DataGrid) | Gets or sets the value of the cell at the specified the row and column.
Item (inherited from DataGrid) | Gets or sets the value of a specified DataGridCell .
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LinkColor (inherited from DataGrid) | Gets or sets the color of the text that you can click to navigate to a child table.
LinkHoverColor (inherited from DataGrid) | Gets or sets the color a link changes to when the mouse pointer moves over it.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentRowsBackColor (inherited from DataGrid) | Gets or sets the background color of parent rows.
ParentRowsForeColor (inherited from DataGrid) | Gets or sets the foreground color of parent rows.
ParentRowsLabelStyle (inherited from DataGrid) | Gets or sets the way parent row labels are displayed.
ParentRowsVisible (inherited from DataGrid) | Gets or sets a value indicating whether the parent rows of a table are visible.
PreferredColumnWidth (inherited from DataGrid) | Gets or sets the default width of the grid columns in pixels.
PreferredRowHeight (inherited from DataGrid) | Gets or sets the preferred row height for the DataGrid control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from DataGrid) | Gets or sets a value indicating whether the grid is in read-only mode.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RowHeadersVisible (inherited from DataGrid) | Gets or sets a value that specifies whether row headers are visible.
RowHeaderWidth (inherited from DataGrid) | Gets or sets the width of row headers.
SelectedDataRows (inherited from vdxDataGrid) | Gets or sets the dataRows which are selected.
SelectionBackColor (inherited from DataGrid) | Gets or sets the background color of selected rows.
SelectionForeColor (inherited from DataGrid) | Gets or set the foreground color of selected rows.
Site (inherited from DataGrid) |
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TableStyles (inherited from DataGrid) | Gets the collection of DataGridTableStyle objects for the grid.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from DataGrid) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisibleColumnCount (inherited from DataGrid) | Gets the number of visible columns.
VisibleRowCount (inherited from DataGrid) | Gets the number of rows visible.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

AddRow | Add a new DataRow to the grid's DataSource.
BeginEdit (inherited from DataGrid) | Attempts to put the grid into a state where editing is allowed.
BeginInit (inherited from DataGrid) | Begins the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Collapse (inherited from DataGrid) | Collapses child relations, if any exist for all rows, or for a specified row.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteRow | Overloaded. Deletes the current row
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndEdit (inherited from DataGrid) | Requests an end to an edit operation taking place on the DataGrid control.
EndInit (inherited from DataGrid) | Ends the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from DataGrid) | Displays child relations, if any exist, for all rows or a specific row.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindRows (inherited from vdxDataGrid) | Find rows by a SQL where clause.
FindText (inherited from vdxDataGrid) | Full text search for the passed Text. Every row is scanned for the Text. If the row contains the text, it is added to the resultion row collection.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxDataGrid) | Get the binding info for the Property specified.
GetCellBounds (inherited from DataGrid) | Overloaded. Gets the Rectangle of the cell specified by row and column number.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetCurrentCellBounds (inherited from DataGrid) | Gets a Rectangle that specifies the four corners of the selected cell.
GetDataRowAT (inherited from vdxDataGrid) | Gets the Datarow with the specified index
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetRowIndex (inherited from vdxDataGrid) | Returns the (momentary) index of a row in the grid. The returned index depends on the momentary sort order.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HitTest (inherited from DataGrid) | Overloaded. Gets information, such as row and column number of a clicked point on the grid, using the x and y coordinate passed to the method.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
IsExpanded (inherited from DataGrid) | Gets a value that indicates whether a specified row's node is expanded or collapsed.
IsSelected (inherited from DataGrid) | Gets a value indicating whether a specified row is selected.
MoveFirst (inherited from vdxDataGrid) | Moves to the first record in the grid
MoveLast (inherited from vdxDataGrid) | Move to the last record of the grid if possible
MoveNext (inherited from vdxDataGrid) | Moves to the next record in the grid. If we are already on the last record, moves to the first record.
MovePrevious (inherited from vdxDataGrid) | Moves to the previous record in the grid. If we are already on the first recorde, moves to the last record
NavigateBack (inherited from DataGrid) | Navigates back to the table previously displayed in the grid.
NavigateTo (inherited from DataGrid) | Navigates to the table specified by row and relation name.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetAlternatingBackColor (inherited from DataGrid) | Resets the AlternatingBackColor property to its default color.
ResetBackColor (inherited from DataGrid) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from DataGrid) | Resets the ForeColor property to its default value.
ResetGridLineColor (inherited from DataGrid) | Resets the GridLineColor property to its default value.
ResetHeaderBackColor (inherited from DataGrid) | Resets the HeaderBackColor property to its default value.
ResetHeaderFont (inherited from DataGrid) | Resets the HeaderFont property to its default value.
ResetHeaderForeColor (inherited from DataGrid) | Resets the HeaderForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetLinkColor (inherited from DataGrid) | Resets the LinkColor property to its default value.
ResetLinkHoverColor (inherited from DataGrid) |
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetSelectionBackColor (inherited from DataGrid) | Resets the SelectionBackColor property to its default value.
ResetSelectionForeColor (inherited from DataGrid) | Resets the SelectionForeColor property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from DataGrid) | Overloaded. Selects a specified row.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo (inherited from vdxDataGrid) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDataBinding (inherited from DataGrid) | Sets the DataSource and DataMember properties at run time.
Show (inherited from Control) | Displays the control to the user.
SubObjectsSiteChange (inherited from DataGrid) |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
UnSelect (inherited from DataGrid) | Unselects a specified row.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AllowNavigationChanged (inherited from DataGrid) | Occurs when the AllowNavigation property has changed.
BackButtonClick (inherited from DataGrid) | Occurs when the Back button on a child table is clicked.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundColorChanged (inherited from DataGrid) | Occurs when the BackgroundColor has changed.
BackgroundImageChanged (inherited from DataGrid) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
BorderStyleChanged (inherited from DataGrid) | Occurs when the BorderStyle has changed.
CaptionVisibleChanged (inherited from DataGrid) | Occurs when the CaptionVisible property has changed.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CurrentCellChanged (inherited from DataGrid) | Occurs when the CurrentCell property has changed.
CursorChanged (inherited from DataGrid) |
DataSourceChanged (inherited from DataGrid) | Occurs when the DataSource property value has changed.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FlatModeChanged (inherited from DataGrid) | Occurs when the FlatMode has changed.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Navigate (inherited from DataGrid) | Occurs when the user navigates to a new table.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
ParentRowsLabelStyleChanged (inherited from DataGrid) | Occurs when the label style of the parent row is changed.
ParentRowsVisibleChanged (inherited from DataGrid) | Occurs when the ParentRowsVisible property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
ReadOnlyChanged (inherited from DataGrid) | Occurs when the ReadOnly property value changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from DataGrid) | Occurs when the user scrolls the DataGrid control.
ShowParentDetailsButtonClick (inherited from DataGrid) | Occurs when the ShowParentDetails button is clicked.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from DataGrid) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DataSet (inherited from vdxDataGrid) | Gets or sets DataSet on DataSource.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from DataGrid) | Gets the default size of the control.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HorizScrollBar (inherited from DataGrid) | Gets the horizontal scrollbar for the grid.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
SelectedDataRow (inherited from vdxDataGrid) | Gets the corresponding selected data row.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VertScrollBar (inherited from DataGrid) | Gets the vertical scroll bar of the control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CancelEditing (inherited from DataGrid) | Cancels the current edit operation and rolls back all changes.
CreateAccessibilityInstance (inherited from DataGrid) | Constructs a new instance of the accessibility object for this control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateGridColumn (inherited from DataGrid) | Overloaded. Creates a new DataGridColumnStyle with the specified PropertyDescriptor.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from DataGrid) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetOutputTextDelimiter (inherited from DataGrid) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GridHScrolled (inherited from DataGrid) | Listens for the horizontal scrollbar's scroll event.
GridVScrolled (inherited from DataGrid) | Listens for the vertical scrollbar's scroll event.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAllowNavigationChanged (inherited from DataGrid) | Raises the AllowNavigationChanged event.
OnBackButtonClicked (inherited from DataGrid) | Listens for the caption's back button clicked event.
OnBackColorChanged (inherited from DataGrid) | Raises the BackColorChanged event.
OnBackgroundColorChanged (inherited from DataGrid) | Raises the BackgroundColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from DataGrid) | Raises the BindingContextChanged event.
OnBorderStyleChanged (inherited from DataGrid) | Raises the BorderStyleChanged event.
OnCaptionVisibleChanged (inherited from DataGrid) | Raises the CaptionVisibleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCurrentCellChanged (inherited from DataGrid) | Raises the CurrentCellChanged event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from DataGrid) | Raises the DataSourceChanged event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from DataGrid) | Raises the Enter event.
OnFlatModeChanged (inherited from DataGrid) | Raises the FlatModeChanged event.
OnFontChanged (inherited from DataGrid) | Raises the FontChanged event.
OnForeColorChanged (inherited from DataGrid) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from DataGrid) | Raises the CreateHandle event.
OnHandleDestroyed (inherited from DataGrid) | Raises the DestroyHandle event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from DataGrid) | Raises the KeyDown event.
OnKeyPress (inherited from DataGrid) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from DataGrid) | Raises the Layout event that repositions controls and updates scroll bars.
OnLeave (inherited from DataGrid) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from DataGrid) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from DataGrid) | Creates the MouseLeave event.
OnMouseMove (inherited from DataGrid) | Raises the MouseMove event.
OnMouseUp (inherited from DataGrid) | Raises the MouseUp event.
OnMouseWheel (inherited from DataGrid) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNavigate (inherited from DataGrid) | Raises the Navigate event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from DataGrid) | Raises the Paint event.
OnPaintBackground (inherited from DataGrid) | Overrides OnPaintBackground to prevent painting the background of the DataGrid control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentRowsLabelStyleChanged (inherited from DataGrid) | Raises the ParentRowsLabelStyleChanged event.
OnParentRowsVisibleChanged (inherited from DataGrid) | Raises the ParentRowsVisibleChanged event.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from DataGrid) | Raises the ReadOnlyChanged event
OnResize (inherited from DataGrid) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnRowHeaderClick (inherited from DataGrid) | Raises the RowHeaderClick event.
OnScroll (inherited from DataGrid) | Raises the Scroll event.
OnShowParentDetailsButtonClicked (inherited from DataGrid) | Raises the ShowParentDetailsButtonClick event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from DataGrid) | Gets or sets a value that indicates whether a key should be processed further.
ProcessGridKey (inherited from DataGrid) | Processes keys for grid navigation.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from DataGrid) | Previews a keyboard message and returns a value indicating if the key was consumed.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
ProcessTabKey (inherited from DataGrid) | Gets a value indicating whether the Tab key should be processed.
ProviderToSet_OnDataTypeSet (inherited from vdxDataGrid) | Listens to the Event OnDataTypeSet that was set on DataSource and set the DataSource with the sender.
ProviderToSet_OnDataTypeSetDM (inherited from vdxDataGrid) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
ResetSelection (inherited from DataGrid) | Turns off selection for all rows that are selected.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShouldSerializeAlternatingBackColor (inherited from DataGrid) | Indicates whether the AlternatingBackColor property should be persisted.
ShouldSerializeBackgroundColor (inherited from DataGrid) | Indicates whether the BackgroundColor property should be persisted.
ShouldSerializeCaptionBackColor (inherited from DataGrid) | Gets a value indicating whether the CaptionBackColor property should be persisted.
ShouldSerializeCaptionForeColor (inherited from DataGrid) | Gets a value indicating whether the CaptionForeColor property should be persisted.
ShouldSerializeGridLineColor (inherited from DataGrid) | Indicates whether the GridLineColor property should be persisted.
ShouldSerializeHeaderBackColor (inherited from DataGrid) | Indicates whether the HeaderBackColor property should be persisted.
ShouldSerializeHeaderFont (inherited from DataGrid) | Indicates whether the HeaderFont property should be persisted.
ShouldSerializeHeaderForeColor (inherited from DataGrid) | Indicates whether the HeaderForeColor property should be persisted.
ShouldSerializeLinkHoverColor (inherited from DataGrid) | Indicates whether the LinkHoverColor property should be persisted.
ShouldSerializeParentRowsBackColor (inherited from DataGrid) | Indicates whether the ParentRowsBackColor property should be persisted.
ShouldSerializeParentRowsForeColor (inherited from DataGrid) | Indicates whether the ParentRowsForeColor property should be persisted.
ShouldSerializePreferredRowHeight (inherited from DataGrid) | Indicates whether the PreferredRowHeight property should be persisted.
ShouldSerializeSelectionBackColor (inherited from DataGrid) | Indicates whether the SelectionBackColor property should be persisted.
ShouldSerializeSelectionForeColor (inherited from DataGrid) | Indicates whether the SelectionForeColor property should be persisted.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Instance Events

RowHeaderClick (inherited from DataGrid) Occurs when a row header is clicked.

Protected Internal Instance Properties

ListManager (inherited from DataGrid) Gets the CurrencyManager for this DataGrid control.

Protected Internal Instance Methods

ColumnStartedEditing (inherited from DataGrid) | Overloaded. Informs the DataGrid control when the user begins to edit a column using the specified control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.

See Also

vdxDataGridManipulator Class | Deag.Vdx.Controls.Base Namespace | vdxDataGrid

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridManipulator Constructor

Initializes a new instance of the vdxDataGridManipulator class.

public vdxDataGridManipulator();

See Also

vdxDataGridManipulator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridManipulator Properties

The properties of the vdxDataGridManipulator class are listed below. For a complete list of vdxDataGridManipulator class members, see the vdxDataGridManipulator Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowAdd | Gets or sets whether the user is allowed to add new records. If AllowAdd is set to true, AllowEdit is also set to true.
AllowDelete | Gets or sets whether the user is allowed to delete records
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowEdit | Gets or sets whether the user is allowed to edit records
AllowNavigation (inherited from DataGrid) | Gets or sets a value indicating whether navigation is allowed.
AllowSorting (inherited from DataGrid) | Gets or sets a value indicating whether the grid can be resorted by clicking on a column header.
AlternatingBackColor (inherited from DataGrid) | Gets or sets the background color of odd-numbered rows of the grid.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from DataGrid) | Gets or sets the background color of even-numbered rows of the grid.
BackgroundColor (inherited from DataGrid) | Gets or sets the color of the non-row area of the grid.
BackgroundImage (inherited from DataGrid) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxDataGrid) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from DataGrid) | Gets or sets the grid's border style.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CaptionBackColor (inherited from DataGrid) | Gets or sets the background color of the caption area.
CaptionFont (inherited from DataGrid) | Gets or sets the font of the grid's caption.
CaptionForeColor (inherited from DataGrid) | Gets or sets the foreground color of the caption area.
CaptionText (inherited from DataGrid) | Gets or sets the text of the grid's window caption.
CaptionVisible (inherited from DataGrid) | Gets or sets a value that indicates whether the grid's caption is visible.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColumnHeadersVisible (inherited from DataGrid) | Gets or sets a value indicating whether the column headers a table are visible.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrencyManager (inherited from vdxDataGrid) | Gets the managed CurrencyManager of this data grid.
CurrentCell (inherited from DataGrid) | Gets or sets which cell has the focus. Not available at design time.
CurrentDataRow (inherited from vdxDataGrid) | Gets or sets the dataRows which are selected.
CurrentRowIndex (inherited from DataGrid) | Gets or sets index of the selected row.
Cursor (inherited from DataGrid) |
DataBindingInfos (inherited from vdxDataGrid) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataMember (inherited from vdxDataGrid) |
DataSource (inherited from vdxDataGrid) | Gets or sets the data source that this grid is displaying data for.
DataView (inherited from vdxDataGrid) | Gets the managed DataView of this data grid.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FirstVisibleColumn (inherited from DataGrid) | Gets the index of the first visible column in a grid.
FlatMode (inherited from DataGrid) | Gets or sets a value indicating whether the grid displays in flat mode.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from DataGrid) | Gets or sets the foreground color (typically the color of the text) property of the DataGrid control.
GridLineColor (inherited from DataGrid) | Gets or sets the color of the grid lines.
GridLineStyle (inherited from DataGrid) | Gets or sets the line style of the grid.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HeaderBackColor (inherited from DataGrid) | Gets or sets the background color of all row and column headers.
HeaderFont (inherited from DataGrid) | Gets or sets the font used for column headers.
HeaderForeColor (inherited from DataGrid) | Gets or sets the foreground color of headers.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Item (inherited from DataGrid) | Gets or sets the value of the cell at the specified the row and column.
Item (inherited from DataGrid) | Gets or sets the value of a specified DataGridCell .
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LinkColor (inherited from DataGrid) | Gets or sets the color of the text that you can click to navigate to a child table.
LinkHoverColor (inherited from DataGrid) | Gets or sets the color a link changes to when the mouse pointer moves over it.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentRowsBackColor (inherited from DataGrid) | Gets or sets the background color of parent rows.
ParentRowsForeColor (inherited from DataGrid) | Gets or sets the foreground color of parent rows.
ParentRowsLabelStyle (inherited from DataGrid) | Gets or sets the way parent row labels are displayed.
ParentRowsVisible (inherited from DataGrid) | Gets or sets a value indicating whether the parent rows of a table are visible.
PreferredColumnWidth (inherited from DataGrid) | Gets or sets the default width of the grid columns in pixels.
PreferredRowHeight (inherited from DataGrid) | Gets or sets the preferred row height for the DataGrid control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from DataGrid) | Gets or sets a value indicating whether the grid is in read-only mode.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RowHeadersVisible (inherited from DataGrid) | Gets or sets a value that specifies whether row headers are visible.
RowHeaderWidth (inherited from DataGrid) | Gets or sets the width of row headers.
SelectedDataRows (inherited from vdxDataGrid) | Gets or sets the dataRows which are selected.
SelectionBackColor (inherited from DataGrid) | Gets or sets the background color of selected rows.
SelectionForeColor (inherited from DataGrid) | Gets or set the foreground color of selected rows.
Site (inherited from DataGrid) |
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TableStyles (inherited from DataGrid) | Gets the collection of DataGridTableStyle objects for the grid.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from DataGrid) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisibleColumnCount (inherited from DataGrid) | Gets the number of visible columns.
VisibleRowCount (inherited from DataGrid) | Gets the number of rows visible.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DataSet (inherited from vdxDataGrid) | Gets or sets DataSet on DataSource.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from DataGrid) | Gets the default size of the control.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HorizScrollBar (inherited from DataGrid) | Gets the horizontal scrollbar for the grid.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
SelectedDataRow (inherited from vdxDataGrid) | Gets the corresponding selected data row.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VertScrollBar (inherited from DataGrid) | Gets the vertical scroll bar of the control.

Protected Internal Instance Properties

ListManager (inherited from DataGrid) Gets the CurrencyManager for this DataGrid control.

See Also

vdxDataGridManipulator Class | Deag.Vdx.Controls.Base Namespace | vdxDataGrid

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridManipulator.AllowAdd Property

Gets or sets whether the user is allowed to add new records. If AllowAdd is set to true, AllowEdit is also set to true.

public bool AllowAdd {get; set;}

See Also

vdxDataGridManipulator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridManipulator.AllowDelete Property

Gets or sets whether the user is allowed to delete records

public bool AllowDelete {get; set;}

See Also

vdxDataGridManipulator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridManipulator.AllowEdit Property

Gets or sets whether the user is allowed to edit records

public bool AllowEdit {get; set;}

See Also

vdxDataGridManipulator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridManipulator Methods

The methods of the vdxDataGridManipulator class are listed below. For a complete list of vdxDataGridManipulator class members, see the vdxDataGridManipulator Members topic.

Public Instance Methods

AddRow | Add a new DataRow to the grid's DataSource.
BeginEdit (inherited from DataGrid) | Attempts to put the grid into a state where editing is allowed.
BeginInit (inherited from DataGrid) | Begins the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Collapse (inherited from DataGrid) | Collapses child relations, if any exist for all rows, or for a specified row.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteRow | Overloaded. Deletes the current row
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndEdit (inherited from DataGrid) | Requests an end to an edit operation taking place on the DataGrid control.
EndInit (inherited from DataGrid) | Ends the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from DataGrid) | Displays child relations, if any exist, for all rows or a specific row.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindRows (inherited from vdxDataGrid) | Find rows by a SQL where clause.
FindText (inherited from vdxDataGrid) | Full text search for the passed Text. Every row is scanned for the Text. If the row contains the text, it is added to the resultion row collection.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxDataGrid) | Get the binding info for the Property specified.
GetCellBounds (inherited from DataGrid) | Overloaded. Gets the Rectangle of the cell specified by row and column number.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetCurrentCellBounds (inherited from DataGrid) | Gets a Rectangle that specifies the four corners of the selected cell.
GetDataRowAT (inherited from vdxDataGrid) | Gets the Datarow with the specified index
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetRowIndex (inherited from vdxDataGrid) | Returns the (momentary) index of a row in the grid. The returned index depends on the momentary sort order.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HitTest (inherited from DataGrid) | Overloaded. Gets information, such as row and column number of a clicked point on the grid, using the x and y coordinate passed to the method.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
IsExpanded (inherited from DataGrid) | Gets a value that indicates whether a specified row's node is expanded or collapsed.
IsSelected (inherited from DataGrid) | Gets a value indicating whether a specified row is selected.
MoveFirst (inherited from vdxDataGrid) | Moves to the first record in the grid
MoveLast (inherited from vdxDataGrid) | Move to the last record of the grid if possible
MoveNext (inherited from vdxDataGrid) | Moves to the next record in the grid. If we are already on the last record, moves to the first record.
MovePrevious (inherited from vdxDataGrid) | Moves to the previous record in the grid. If we are already on the first recorde, moves to the last record
NavigateBack (inherited from DataGrid) | Navigates back to the table previously displayed in the grid.
NavigateTo (inherited from DataGrid) | Navigates to the table specified by row and relation name.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetAlternatingBackColor (inherited from DataGrid) | Resets the AlternatingBackColor property to its default color.
ResetBackColor (inherited from DataGrid) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from DataGrid) | Resets the ForeColor property to its default value.
ResetGridLineColor (inherited from DataGrid) | Resets the GridLineColor property to its default value.
ResetHeaderBackColor (inherited from DataGrid) | Resets the HeaderBackColor property to its default value.
ResetHeaderFont (inherited from DataGrid) | Resets the HeaderFont property to its default value.
ResetHeaderForeColor (inherited from DataGrid) | Resets the HeaderForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetLinkColor (inherited from DataGrid) | Resets the LinkColor property to its default value.
ResetLinkHoverColor (inherited from DataGrid) |
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetSelectionBackColor (inherited from DataGrid) | Resets the SelectionBackColor property to its default value.
ResetSelectionForeColor (inherited from DataGrid) | Resets the SelectionForeColor property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from DataGrid) | Overloaded. Selects a specified row.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo (inherited from vdxDataGrid) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDataBinding (inherited from DataGrid) | Sets the DataSource and DataMember properties at run time.
Show (inherited from Control) | Displays the control to the user.
SubObjectsSiteChange (inherited from DataGrid) |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
UnSelect (inherited from DataGrid) | Unselects a specified row.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CancelEditing (inherited from DataGrid) | Cancels the current edit operation and rolls back all changes.
CreateAccessibilityInstance (inherited from DataGrid) | Constructs a new instance of the accessibility object for this control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateGridColumn (inherited from DataGrid) | Overloaded. Creates a new DataGridColumnStyle with the specified PropertyDescriptor.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from DataGrid) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetOutputTextDelimiter (inherited from DataGrid) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GridHScrolled (inherited from DataGrid) | Listens for the horizontal scrollbar's scroll event.
GridVScrolled (inherited from DataGrid) | Listens for the vertical scrollbar's scroll event.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAllowNavigationChanged (inherited from DataGrid) | Raises the AllowNavigationChanged event.
OnBackButtonClicked (inherited from DataGrid) | Listens for the caption's back button clicked event.
OnBackColorChanged (inherited from DataGrid) | Raises the BackColorChanged event.
OnBackgroundColorChanged (inherited from DataGrid) | Raises the BackgroundColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from DataGrid) | Raises the BindingContextChanged event.
OnBorderStyleChanged (inherited from DataGrid) | Raises the BorderStyleChanged event.
OnCaptionVisibleChanged (inherited from DataGrid) | Raises the CaptionVisibleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCurrentCellChanged (inherited from DataGrid) | Raises the CurrentCellChanged event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from DataGrid) | Raises the DataSourceChanged event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from DataGrid) | Raises the Enter event.
OnFlatModeChanged (inherited from DataGrid) | Raises the FlatModeChanged event.
OnFontChanged (inherited from DataGrid) | Raises the FontChanged event.
OnForeColorChanged (inherited from DataGrid) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from DataGrid) | Raises the CreateHandle event.
OnHandleDestroyed (inherited from DataGrid) | Raises the DestroyHandle event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from DataGrid) | Raises the KeyDown event.
OnKeyPress (inherited from DataGrid) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from DataGrid) | Raises the Layout event that repositions controls and updates scroll bars.
OnLeave (inherited from DataGrid) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from DataGrid) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from DataGrid) | Creates the MouseLeave event.
OnMouseMove (inherited from DataGrid) | Raises the MouseMove event.
OnMouseUp (inherited from DataGrid) | Raises the MouseUp event.
OnMouseWheel (inherited from DataGrid) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNavigate (inherited from DataGrid) | Raises the Navigate event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from DataGrid) | Raises the Paint event.
OnPaintBackground (inherited from DataGrid) | Overrides OnPaintBackground to prevent painting the background of the DataGrid control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentRowsLabelStyleChanged (inherited from DataGrid) | Raises the ParentRowsLabelStyleChanged event.
OnParentRowsVisibleChanged (inherited from DataGrid) | Raises the ParentRowsVisibleChanged event.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from DataGrid) | Raises the ReadOnlyChanged event
OnResize (inherited from DataGrid) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnRowHeaderClick (inherited from DataGrid) | Raises the RowHeaderClick event.
OnScroll (inherited from DataGrid) | Raises the Scroll event.
OnShowParentDetailsButtonClicked (inherited from DataGrid) | Raises the ShowParentDetailsButtonClick event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from DataGrid) | Gets or sets a value that indicates whether a key should be processed further.
ProcessGridKey (inherited from DataGrid) | Processes keys for grid navigation.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from DataGrid) | Previews a keyboard message and returns a value indicating if the key was consumed.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
ProcessTabKey (inherited from DataGrid) | Gets a value indicating whether the Tab key should be processed.
ProviderToSet_OnDataTypeSet (inherited from vdxDataGrid) | Listens to the Event OnDataTypeSet that was set on DataSource and set the DataSource with the sender.
ProviderToSet_OnDataTypeSetDM (inherited from vdxDataGrid) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
ResetSelection (inherited from DataGrid) | Turns off selection for all rows that are selected.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShouldSerializeAlternatingBackColor (inherited from DataGrid) | Indicates whether the AlternatingBackColor property should be persisted.
ShouldSerializeBackgroundColor (inherited from DataGrid) | Indicates whether the BackgroundColor property should be persisted.
ShouldSerializeCaptionBackColor (inherited from DataGrid) | Gets a value indicating whether the CaptionBackColor property should be persisted.
ShouldSerializeCaptionForeColor (inherited from DataGrid) | Gets a value indicating whether the CaptionForeColor property should be persisted.
ShouldSerializeGridLineColor (inherited from DataGrid) | Indicates whether the GridLineColor property should be persisted.
ShouldSerializeHeaderBackColor (inherited from DataGrid) | Indicates whether the HeaderBackColor property should be persisted.
ShouldSerializeHeaderFont (inherited from DataGrid) | Indicates whether the HeaderFont property should be persisted.
ShouldSerializeHeaderForeColor (inherited from DataGrid) | Indicates whether the HeaderForeColor property should be persisted.
ShouldSerializeLinkHoverColor (inherited from DataGrid) | Indicates whether the LinkHoverColor property should be persisted.
ShouldSerializeParentRowsBackColor (inherited from DataGrid) | Indicates whether the ParentRowsBackColor property should be persisted.
ShouldSerializeParentRowsForeColor (inherited from DataGrid) | Indicates whether the ParentRowsForeColor property should be persisted.
ShouldSerializePreferredRowHeight (inherited from DataGrid) | Indicates whether the PreferredRowHeight property should be persisted.
ShouldSerializeSelectionBackColor (inherited from DataGrid) | Indicates whether the SelectionBackColor property should be persisted.
ShouldSerializeSelectionForeColor (inherited from DataGrid) | Indicates whether the SelectionForeColor property should be persisted.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ColumnStartedEditing (inherited from DataGrid) | Overloaded. Informs the DataGrid control when the user begins to edit a column using the specified control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.

See Also

vdxDataGridManipulator Class | Deag.Vdx.Controls.Base Namespace | vdxDataGrid

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridManipulator.AddRow Method

Add a new DataRow to the grid's DataSource.

public DataRow AddRow();

Return Value

The new row

See Also

vdxDataGridManipulator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DeleteRow Method

VDX Framework

vdxDataGridManipulator.DeleteRow Method

Deletes the current row

Overload List

Deletes the current row

public void DeleteRow();

Deletes the specified row

public void DeleteRow(DataRow);

Delete the row with the specified index

public void DeleteRow(int);

See Also

vdxDataGridManipulator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridManipulator.DeleteRow Method ()

Deletes the current row

public void DeleteRow();

See Also

vdxDataGridManipulator Class | Deag.Vdx.Controls.Base Namespace | vdxDataGridManipulator.DeleteRow Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridManipulator.DeleteRow Method (DataRow)

Deletes the specified row

public void DeleteRow(
DataRow row
);

Parameters

row
Row to delete

See Also

vdxDataGridManipulator Class | Deag.Vdx.Controls.Base Namespace | vdxDataGridManipulator.DeleteRow Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridManipulator.DeleteRow Method (Int32)

Delete the row with the specified index

public void DeleteRow(
int idx
);

Parameters

idx
Index of the row to delete

See Also

vdxDataGridManipulator Class | Deag.Vdx.Controls.Base Namespace | vdxDataGridManipulator.DeleteRow Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator Class

Displays data in a scrollable grid and interact with vdxExplorer.

For a list of all members of this type, see vdxDataGridNavigator Members.

System.Object
MarshalByRefObject
Component
Control
DataGrid
vdxDataGrid
vdxDataGridNavigator

public class vdxDataGridNavigator : vdxDataGrid, IvdxNavigator

Remarks

This dataGrid implements the interface IvdxNavigator to be used in vdxExplorer context. The communication is bi-directional, the explorer commands the dataGrid to build himself with the given DataSet. In the other hand the explorer is informed about selection changes of the navigators he contains.

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataGridNavigator Members | Deag.Vdx.Controls.Base Namespace | vdxDataGrid | IvdxNavigator

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator Members

vdxDataGridNavigator overview

Public Instance Constructors

vdxDataGridNavigator Constructor Initializes a new instance of vdxDataGridNavigator class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowNavigation | Gets or sets a value indicating whether navigation is allowed.
AllowSorting (inherited from DataGrid) | Gets or sets a value indicating whether the grid can be resorted by clicking on a column header.
AlternatingBackColor (inherited from DataGrid) | Gets or sets the background color of odd-numbered rows of the grid.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from DataGrid) | Gets or sets the background color of even-numbered rows of the grid.
BackgroundColor (inherited from DataGrid) | Gets or sets the color of the non-row area of the grid.
BackgroundImage (inherited from DataGrid) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxDataGrid) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from DataGrid) | Gets or sets the grid's border style.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CaptionBackColor (inherited from DataGrid) | Gets or sets the background color of the caption area.
CaptionFont (inherited from DataGrid) | Gets or sets the font of the grid's caption.
CaptionForeColor (inherited from DataGrid) | Gets or sets the foreground color of the caption area.
CaptionText (inherited from DataGrid) | Gets or sets the text of the grid's window caption.
CaptionVisible (inherited from DataGrid) | Gets or sets a value that indicates whether the grid's caption is visible.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColumnHeadersVisible (inherited from DataGrid) | Gets or sets a value indicating whether the column headers a table are visible.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrencyManager (inherited from vdxDataGrid) | Gets the managed CurrencyManager of this data grid.
CurrentCell (inherited from DataGrid) | Gets or sets which cell has the focus. Not available at design time.
CurrentDataRow (inherited from vdxDataGrid) | Gets or sets the dataRows which are selected.
CurrentRowIndex (inherited from DataGrid) | Gets or sets index of the selected row.
Cursor (inherited from DataGrid) |
DataBindingInfos (inherited from vdxDataGrid) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataMember (inherited from vdxDataGrid) |
DataSource (inherited from vdxDataGrid) | Gets or sets the data source that this grid is displaying data for.
DataView (inherited from vdxDataGrid) | Gets the managed DataView of this data grid.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FirstVisibleColumn (inherited from DataGrid) | Gets the index of the first visible column in a grid.
FlatMode (inherited from DataGrid) | Gets or sets a value indicating whether the grid displays in flat mode.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from DataGrid) | Gets or sets the foreground color (typically the color of the text) property of the DataGrid control.
GridLineColor (inherited from DataGrid) | Gets or sets the color of the grid lines.
GridLineStyle (inherited from DataGrid) | Gets or sets the line style of the grid.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HeaderBackColor (inherited from DataGrid) | Gets or sets the background color of all row and column headers.
HeaderFont (inherited from DataGrid) | Gets or sets the font used for column headers.
HeaderForeColor (inherited from DataGrid) | Gets or sets the foreground color of headers.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Item (inherited from DataGrid) | Gets or sets the value of the cell at the specified the row and column.
Item (inherited from DataGrid) | Gets or sets the value of a specified DataGridCell .
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LinkColor (inherited from DataGrid) | Gets or sets the color of the text that you can click to navigate to a child table.
LinkHoverColor (inherited from DataGrid) | Gets or sets the color a link changes to when the mouse pointer moves over it.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentRowsBackColor (inherited from DataGrid) | Gets or sets the background color of parent rows.
ParentRowsForeColor (inherited from DataGrid) | Gets or sets the foreground color of parent rows.
ParentRowsLabelStyle (inherited from DataGrid) | Gets or sets the way parent row labels are displayed.
ParentRowsVisible (inherited from DataGrid) | Gets or sets a value indicating whether the parent rows of a table are visible.
PreferredColumnWidth (inherited from DataGrid) | Gets or sets the default width of the grid columns in pixels.
PreferredRowHeight (inherited from DataGrid) | Gets or sets the preferred row height for the DataGrid control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from DataGrid) | Gets or sets a value indicating whether the grid is in read-only mode.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RowHeadersVisible (inherited from DataGrid) | Gets or sets a value that specifies whether row headers are visible.
RowHeaderWidth (inherited from DataGrid) | Gets or sets the width of row headers.
SelectedDataRows (inherited from vdxDataGrid) | Gets or sets the dataRows which are selected.
SelectionBackColor (inherited from DataGrid) | Gets or sets the background color of selected rows.
SelectionForeColor (inherited from DataGrid) | Gets or set the foreground color of selected rows.
Site (inherited from DataGrid) |
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TableStyles (inherited from DataGrid) | Gets the collection of DataGridTableStyle objects for the grid.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from DataGrid) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisibleColumnCount (inherited from DataGrid) | Gets the number of visible columns.
VisibleRowCount (inherited from DataGrid) | Gets the number of rows visible.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginEdit (inherited from DataGrid) | Attempts to put the grid into a state where editing is allowed.
BeginInit (inherited from DataGrid) | Begins the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Collapse (inherited from DataGrid) | Collapses child relations, if any exist for all rows, or for a specified row.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndEdit (inherited from DataGrid) | Requests an end to an edit operation taking place on the DataGrid control.
EndInit (inherited from DataGrid) | Ends the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from DataGrid) | Displays child relations, if any exist, for all rows or a specific row.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindRows (inherited from vdxDataGrid) | Find rows by a SQL where clause.
FindText (inherited from vdxDataGrid) | Full text search for the passed Text. Every row is scanned for the Text. If the row contains the text, it is added to the resultion row collection.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxDataGrid) | Get the binding info for the Property specified.
GetCellBounds (inherited from DataGrid) | Overloaded. Gets the Rectangle of the cell specified by row and column number.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetCurrentCellBounds (inherited from DataGrid) | Gets a Rectangle that specifies the four corners of the selected cell.
GetDataRowAT (inherited from vdxDataGrid) | Gets the Datarow with the specified index
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetRowIndex (inherited from vdxDataGrid) | Returns the (momentary) index of a row in the grid. The returned index depends on the momentary sort order.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HitTest (inherited from DataGrid) | Overloaded. Gets information, such as row and column number of a clicked point on the grid, using the x and y coordinate passed to the method.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
IsExpanded (inherited from DataGrid) | Gets a value that indicates whether a specified row's node is expanded or collapsed.
IsSelected (inherited from DataGrid) | Gets a value indicating whether a specified row is selected.
MoveFirst (inherited from vdxDataGrid) | Moves to the first record in the grid
MoveLast (inherited from vdxDataGrid) | Move to the last record of the grid if possible
MoveNext (inherited from vdxDataGrid) | Moves to the next record in the grid. If we are already on the last record, moves to the first record.
MovePrevious (inherited from vdxDataGrid) | Moves to the previous record in the grid. If we are already on the first recorde, moves to the last record
NavigateBack (inherited from DataGrid) | Navigates back to the table previously displayed in the grid.
NavigateTo (inherited from DataGrid) | Navigates to the table specified by row and relation name.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetAlternatingBackColor (inherited from DataGrid) | Resets the AlternatingBackColor property to its default color.
ResetBackColor (inherited from DataGrid) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from DataGrid) | Resets the ForeColor property to its default value.
ResetGridLineColor (inherited from DataGrid) | Resets the GridLineColor property to its default value.
ResetHeaderBackColor (inherited from DataGrid) | Resets the HeaderBackColor property to its default value.
ResetHeaderFont (inherited from DataGrid) | Resets the HeaderFont property to its default value.
ResetHeaderForeColor (inherited from DataGrid) | Resets the HeaderForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetLinkColor (inherited from DataGrid) | Resets the LinkColor property to its default value.
ResetLinkHoverColor (inherited from DataGrid) |
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetSelectionBackColor (inherited from DataGrid) | Resets the SelectionBackColor property to its default value.
ResetSelectionForeColor (inherited from DataGrid) | Resets the SelectionForeColor property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from DataGrid) | Overloaded. Selects a specified row.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo (inherited from vdxDataGrid) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDataBinding (inherited from DataGrid) | Sets the DataSource and DataMember properties at run time.
Show (inherited from Control) | Displays the control to the user.
SubObjectsSiteChange (inherited from DataGrid) |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
UnSelect (inherited from DataGrid) | Unselects a specified row.
Update (inherited from Control) | Overloaded. Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AllowNavigationChanged (inherited from DataGrid) | Occurs when the AllowNavigation property has changed.
BackButtonClick (inherited from DataGrid) | Occurs when the Back button on a child table is clicked.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundColorChanged (inherited from DataGrid) | Occurs when the BackgroundColor has changed.
BackgroundImageChanged (inherited from DataGrid) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
BorderStyleChanged (inherited from DataGrid) | Occurs when the BorderStyle has changed.
CaptionVisibleChanged (inherited from DataGrid) | Occurs when the CaptionVisible property has changed.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlChanged | Occurs when an other cacheable control had to be shown.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CurrentCellChanged (inherited from DataGrid) | Occurs when the CurrentCell property has changed.
CursorChanged (inherited from DataGrid) |
DataSourceChanged (inherited from DataGrid) | Occurs when the DataSource property value has changed.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
Filled | Occurs after Fill was called.
FlatModeChanged (inherited from DataGrid) | Occurs when the FlatMode has changed.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Navigate (inherited from DataGrid) | Occurs when the user navigates to a new table.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
ParentRowsLabelStyleChanged (inherited from DataGrid) | Occurs when the label style of the parent row is changed.
ParentRowsVisibleChanged (inherited from DataGrid) | Occurs when the ParentRowsVisible property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
ReadOnlyChanged (inherited from DataGrid) | Occurs when the ReadOnly property value changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from DataGrid) | Occurs when the user scrolls the DataGrid control.
SelectionChanged | Occurs when an other DataRow was selected.
ShowParentDetailsButtonClick (inherited from DataGrid) | Occurs when the ShowParentDetails button is clicked.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from DataGrid) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

fireEvent | Activate/Deactivate event firing for OnSelectionChanged and OnControlChanged.
mousePosition | Mouse position after mouse click event.

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DataSet (inherited from vdxDataGrid) | Gets or sets DataSet on DataSource.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from DataGrid) | Gets the default size of the control.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HorizScrollBar (inherited from DataGrid) | Gets the horizontal scrollbar for the grid.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
SelectedDataRow (inherited from vdxDataGrid) | Gets the corresponding selected data row.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VertScrollBar (inherited from DataGrid) | Gets the vertical scroll bar of the control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AddRow | Adds gridDataRow to data source table.
AttatchCurrencyManagerEventHandlers | Register CurrencyManager listeners.
CancelEditing (inherited from DataGrid) | Cancels the current edit operation and rolls back all changes.
ChangeSelection | Changes current selection to the given row.
Clear | Remove all rows from the grid.
CreateAccessibilityInstance (inherited from DataGrid) | Constructs a new instance of the accessibility object for this control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateGridColumn (inherited from DataGrid) | Overloaded. Creates a new DataGridColumnStyle with the specified PropertyDescriptor.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateNavigatorInfoItem | Creates a vdxNavigatorInfoItem for the given dataRow.
CurrencyManager_PositionChanged | Event listener on CurrencyManager to detect position changes.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
Delete | Deletes the selected row.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from DataGrid) | Overloaded.
Fill | Builds a dataGrid for the given DataSet;
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetDataRowKey | Gets an unique key to differ TreeNodes on the same hierarchy level.
GetGridDataRow | Gets the corresponding grid DataRow for the given navigator DataRow.
GetLoaderInfo | Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.
GetNavigatorInfo | Gets the corresponding navigation info for the given item.
GetNavigatorInfoItemForGridRow | Gets the corresponding navigator DataRow for the given grid DataRow.
GetOutputTextDelimiter (inherited from DataGrid) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GridHScrolled (inherited from DataGrid) | Listens for the horizontal scrollbar's scroll event.
GridVScrolled (inherited from DataGrid) | Listens for the vertical scrollbar's scroll event.
InitLayout (inherited from Control) | Called after the control has been added to another container.
Insert | Inserts a new navigator row for the corresponding navigator row.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsRefreshable | Checks if the component supports refresh.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAllowNavigationChanged (inherited from DataGrid) | Raises the AllowNavigationChanged event.
OnBackButtonClicked (inherited from DataGrid) | Listens for the caption's back button clicked event.
OnBackColorChanged (inherited from DataGrid) | Raises the BackColorChanged event.
OnBackgroundColorChanged (inherited from DataGrid) | Raises the BackgroundColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from DataGrid) | Raises the BindingContextChanged event.
OnBorderStyleChanged (inherited from DataGrid) | Raises the BorderStyleChanged event.
OnCaptionVisibleChanged (inherited from DataGrid) | Raises the CaptionVisibleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlChanged | Inform all registered components on ControlChanged about a control change.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCurrentCellChanged (inherited from DataGrid) | Raises the CurrentCellChanged event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from DataGrid) | Raises the DataSourceChanged event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from DataGrid) | Raises the Enter event.
OnFilled | Raises the Filled event.
OnFlatModeChanged (inherited from DataGrid) | Raises the FlatModeChanged event.
OnFontChanged (inherited from DataGrid) | Raises the FontChanged event.
OnForeColorChanged (inherited from DataGrid) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from DataGrid) | Raises the CreateHandle event.
OnHandleDestroyed (inherited from DataGrid) | Raises the DestroyHandle event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from DataGrid) | Raises the KeyDown event.
OnKeyPress (inherited from DataGrid) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from DataGrid) | Raises the Layout event that repositions controls and updates scroll bars.
OnLeave (inherited from DataGrid) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from DataGrid) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from DataGrid) | Creates the MouseLeave event.
OnMouseMove (inherited from DataGrid) | Raises the MouseMove event.
OnMouseUp (inherited from DataGrid) | Raises the MouseUp event.
OnMouseWheel (inherited from DataGrid) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNavigate (inherited from DataGrid) | Raises the Navigate event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from DataGrid) | Raises the Paint event.
OnPaintBackground (inherited from DataGrid) | Overrides OnPaintBackground to prevent painting the background of the DataGrid control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentRowsLabelStyleChanged (inherited from DataGrid) | Raises the ParentRowsLabelStyleChanged event.
OnParentRowsVisibleChanged (inherited from DataGrid) | Raises the ParentRowsVisibleChanged event.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from DataGrid) | Raises the ReadOnlyChanged event
OnResize (inherited from DataGrid) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnRowHeaderClick (inherited from DataGrid) | Raises the RowHeaderClick event.
OnScroll (inherited from DataGrid) | Raises the Scroll event.
OnSelectionChanged | Inform all registered components on SelectionChanged about a selection change.
OnShowParentDetailsButtonClicked (inherited from DataGrid) | Raises the ShowParentDetailsButtonClick event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from DataGrid) | Gets or sets a value that indicates whether a key should be processed further.
ProcessGridKey (inherited from DataGrid) | Processes keys for grid navigation.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from DataGrid) | Previews a keyboard message and returns a value indicating if the key was consumed.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
ProcessTabKey (inherited from DataGrid) | Gets a value indicating whether the Tab key should be processed.
ProviderToSet_OnDataTypeSet (inherited from vdxDataGrid) | Listens to the Event OnDataTypeSet that was set on DataSource and set the DataSource with the sender.
ProviderToSet_OnDataTypeSetDM (inherited from vdxDataGrid) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshData | Remove all elements from the navigator and fill up the given dataSet.
RemoveRow | Adds gridDataRow to data source table.
RemoveSelectedRow | Removes current selected gridDataRow from data source table.
ResetMouseEventArgs (inherited from Control) |
ResetSelection (inherited from DataGrid) | Turns off selection for all rows that are selected.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SelectDefault | Selects the default element.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShouldSerializeAlternatingBackColor (inherited from DataGrid) | Indicates whether the AlternatingBackColor property should be persisted.
ShouldSerializeBackgroundColor (inherited from DataGrid) | Indicates whether the BackgroundColor property should be persisted.
ShouldSerializeCaptionBackColor (inherited from DataGrid) | Gets a value indicating whether the CaptionBackColor property should be persisted.
ShouldSerializeCaptionForeColor (inherited from DataGrid) | Gets a value indicating whether the CaptionForeColor property should be persisted.
ShouldSerializeGridLineColor (inherited from DataGrid) | Indicates whether the GridLineColor property should be persisted.
ShouldSerializeHeaderBackColor (inherited from DataGrid) | Indicates whether the HeaderBackColor property should be persisted.
ShouldSerializeHeaderFont (inherited from DataGrid) | Indicates whether the HeaderFont property should be persisted.
ShouldSerializeHeaderForeColor (inherited from DataGrid) | Indicates whether the HeaderForeColor property should be persisted.
ShouldSerializeLinkHoverColor (inherited from DataGrid) | Indicates whether the LinkHoverColor property should be persisted.
ShouldSerializeParentRowsBackColor (inherited from DataGrid) | Indicates whether the ParentRowsBackColor property should be persisted.
ShouldSerializeParentRowsForeColor (inherited from DataGrid) | Indicates whether the ParentRowsForeColor property should be persisted.
ShouldSerializePreferredRowHeight (inherited from DataGrid) | Indicates whether the PreferredRowHeight property should be persisted.
ShouldSerializeSelectionBackColor (inherited from DataGrid) | Indicates whether the SelectionBackColor property should be persisted.
ShouldSerializeSelectionForeColor (inherited from DataGrid) | Indicates whether the SelectionForeColor property should be persisted.
Undo | Undo changes for the corresponding navigatorDataRow.
Update | Overloaded. Updates the corresponding navigator row with the given manipulator row.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Instance Events

RowHeaderClick (inherited from DataGrid) Occurs when a row header is clicked.

Protected Internal Instance Properties

ListManager (inherited from DataGrid) Gets the CurrencyManager for this DataGrid control.

Protected Internal Instance Methods

ColumnStartedEditing (inherited from DataGrid) | Overloaded. Informs the DataGrid control when the user begins to edit a column using the specified control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.

Explicit Interface Implementations

IvdxNavigator.ChangeSelection
IvdxNavigator.Clear
IvdxNavigator.Copy
IvdxNavigator.Delete
IvdxNavigator.Fill
IvdxNavigator.GetLoaderInfo
IvdxNavigator.Insert
IvdxNavigator.IsRefreshable
IvdxNavigator.RefreshData
IvdxNavigator.SelectDefault
IvdxNavigator.Undo
IvdxNavigator.Update

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace | vdxDataGrid | IvdxNavigator

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator Constructor

Initializes a new instance of vdxDataGridNavigator class.

public vdxDataGridNavigator();

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator Fields

The fields of the vdxDataGridNavigator class are listed below. For a complete list of vdxDataGridNavigator class members, see the vdxDataGridNavigator Members topic.

Protected Instance Fields

fireEvent | Activate/Deactivate event firing for OnSelectionChanged and OnControlChanged.
mousePosition | Mouse position after mouse click event.

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace | vdxDataGrid | IvdxNavigator

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.fireEvent Field

Activate/Deactivate event firing for OnSelectionChanged and OnControlChanged.

protected bool fireEvent;

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.mousePosition Field

Mouse position after mouse click event.

protected Point mousePosition;

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator Properties

The properties of the vdxDataGridNavigator class are listed below. For a complete list of vdxDataGridNavigator class members, see the vdxDataGridNavigator Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowNavigation | Gets or sets a value indicating whether navigation is allowed.
AllowSorting (inherited from DataGrid) | Gets or sets a value indicating whether the grid can be resorted by clicking on a column header.
AlternatingBackColor (inherited from DataGrid) | Gets or sets the background color of odd-numbered rows of the grid.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from DataGrid) | Gets or sets the background color of even-numbered rows of the grid.
BackgroundColor (inherited from DataGrid) | Gets or sets the color of the non-row area of the grid.
BackgroundImage (inherited from DataGrid) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxDataGrid) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from DataGrid) | Gets or sets the grid's border style.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CaptionBackColor (inherited from DataGrid) | Gets or sets the background color of the caption area.
CaptionFont (inherited from DataGrid) | Gets or sets the font of the grid's caption.
CaptionForeColor (inherited from DataGrid) | Gets or sets the foreground color of the caption area.
CaptionText (inherited from DataGrid) | Gets or sets the text of the grid's window caption.
CaptionVisible (inherited from DataGrid) | Gets or sets a value that indicates whether the grid's caption is visible.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColumnHeadersVisible (inherited from DataGrid) | Gets or sets a value indicating whether the column headers a table are visible.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrencyManager (inherited from vdxDataGrid) | Gets the managed CurrencyManager of this data grid.
CurrentCell (inherited from DataGrid) | Gets or sets which cell has the focus. Not available at design time.
CurrentDataRow (inherited from vdxDataGrid) | Gets or sets the dataRows which are selected.
CurrentRowIndex (inherited from DataGrid) | Gets or sets index of the selected row.
Cursor (inherited from DataGrid) |
DataBindingInfos (inherited from vdxDataGrid) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataMember (inherited from vdxDataGrid) |
DataSource (inherited from vdxDataGrid) | Gets or sets the data source that this grid is displaying data for.
DataView (inherited from vdxDataGrid) | Gets the managed DataView of this data grid.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FirstVisibleColumn (inherited from DataGrid) | Gets the index of the first visible column in a grid.
FlatMode (inherited from DataGrid) | Gets or sets a value indicating whether the grid displays in flat mode.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from DataGrid) | Gets or sets the foreground color (typically the color of the text) property of the DataGrid control.
GridLineColor (inherited from DataGrid) | Gets or sets the color of the grid lines.
GridLineStyle (inherited from DataGrid) | Gets or sets the line style of the grid.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HeaderBackColor (inherited from DataGrid) | Gets or sets the background color of all row and column headers.
HeaderFont (inherited from DataGrid) | Gets or sets the font used for column headers.
HeaderForeColor (inherited from DataGrid) | Gets or sets the foreground color of headers.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Item (inherited from DataGrid) | Gets or sets the value of the cell at the specified the row and column.
Item (inherited from DataGrid) | Gets or sets the value of a specified DataGridCell .
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LinkColor (inherited from DataGrid) | Gets or sets the color of the text that you can click to navigate to a child table.
LinkHoverColor (inherited from DataGrid) | Gets or sets the color a link changes to when the mouse pointer moves over it.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentRowsBackColor (inherited from DataGrid) | Gets or sets the background color of parent rows.
ParentRowsForeColor (inherited from DataGrid) | Gets or sets the foreground color of parent rows.
ParentRowsLabelStyle (inherited from DataGrid) | Gets or sets the way parent row labels are displayed.
ParentRowsVisible (inherited from DataGrid) | Gets or sets a value indicating whether the parent rows of a table are visible.
PreferredColumnWidth (inherited from DataGrid) | Gets or sets the default width of the grid columns in pixels.
PreferredRowHeight (inherited from DataGrid) | Gets or sets the preferred row height for the DataGrid control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from DataGrid) | Gets or sets a value indicating whether the grid is in read-only mode.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RowHeadersVisible (inherited from DataGrid) | Gets or sets a value that specifies whether row headers are visible.
RowHeaderWidth (inherited from DataGrid) | Gets or sets the width of row headers.
SelectedDataRows (inherited from vdxDataGrid) | Gets or sets the dataRows which are selected.
SelectionBackColor (inherited from DataGrid) | Gets or sets the background color of selected rows.
SelectionForeColor (inherited from DataGrid) | Gets or set the foreground color of selected rows.
Site (inherited from DataGrid) |
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TableStyles (inherited from DataGrid) | Gets the collection of DataGridTableStyle objects for the grid.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from DataGrid) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisibleColumnCount (inherited from DataGrid) | Gets the number of visible columns.
VisibleRowCount (inherited from DataGrid) | Gets the number of rows visible.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DataSet (inherited from vdxDataGrid) | Gets or sets DataSet on DataSource.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from DataGrid) | Gets the default size of the control.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HorizScrollBar (inherited from DataGrid) | Gets the horizontal scrollbar for the grid.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
SelectedDataRow (inherited from vdxDataGrid) | Gets the corresponding selected data row.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VertScrollBar (inherited from DataGrid) | Gets the vertical scroll bar of the control.

Protected Internal Instance Properties

ListManager (inherited from DataGrid) Gets the CurrencyManager for this DataGrid control.

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace | vdxDataGrid | IvdxNavigator

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.AllowNavigation Property

Gets or sets a value indicating whether navigation is allowed.

new public bool AllowNavigation {get; set;}

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator Methods

The methods of the vdxDataGridNavigator class are listed below. For a complete list of vdxDataGridNavigator class members, see the vdxDataGridNavigator Members topic.

Public Instance Methods

BeginEdit (inherited from DataGrid) | Attempts to put the grid into a state where editing is allowed.
BeginInit (inherited from DataGrid) | Begins the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Collapse (inherited from DataGrid) | Collapses child relations, if any exist for all rows, or for a specified row.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndEdit (inherited from DataGrid) | Requests an end to an edit operation taking place on the DataGrid control.
EndInit (inherited from DataGrid) | Ends the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from DataGrid) | Displays child relations, if any exist, for all rows or a specific row.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindRows (inherited from vdxDataGrid) | Find rows by a SQL where clause.
FindText (inherited from vdxDataGrid) | Full text search for the passed Text. Every row is scanned for the Text. If the row contains the text, it is added to the resultion row collection.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxDataGrid) | Get the binding info for the Property specified.
GetCellBounds (inherited from DataGrid) | Overloaded. Gets the Rectangle of the cell specified by row and column number.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetCurrentCellBounds (inherited from DataGrid) | Gets a Rectangle that specifies the four corners of the selected cell.
GetDataRowAT (inherited from vdxDataGrid) | Gets the Datarow with the specified index
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetRowIndex (inherited from vdxDataGrid) | Returns the (momentary) index of a row in the grid. The returned index depends on the momentary sort order.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HitTest (inherited from DataGrid) | Overloaded. Gets information, such as row and column number of a clicked point on the grid, using the x and y coordinate passed to the method.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
IsExpanded (inherited from DataGrid) | Gets a value that indicates whether a specified row's node is expanded or collapsed.
IsSelected (inherited from DataGrid) | Gets a value indicating whether a specified row is selected.
MoveFirst (inherited from vdxDataGrid) | Moves to the first record in the grid
MoveLast (inherited from vdxDataGrid) | Move to the last record of the grid if possible
MoveNext (inherited from vdxDataGrid) | Moves to the next record in the grid. If we are already on the last record, moves to the first record.
MovePrevious (inherited from vdxDataGrid) | Moves to the previous record in the grid. If we are already on the first recorde, moves to the last record
NavigateBack (inherited from DataGrid) | Navigates back to the table previously displayed in the grid.
NavigateTo (inherited from DataGrid) | Navigates to the table specified by row and relation name.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetAlternatingBackColor (inherited from DataGrid) | Resets the AlternatingBackColor property to its default color.
ResetBackColor (inherited from DataGrid) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from DataGrid) | Resets the ForeColor property to its default value.
ResetGridLineColor (inherited from DataGrid) | Resets the GridLineColor property to its default value.
ResetHeaderBackColor (inherited from DataGrid) | Resets the HeaderBackColor property to its default value.
ResetHeaderFont (inherited from DataGrid) | Resets the HeaderFont property to its default value.
ResetHeaderForeColor (inherited from DataGrid) | Resets the HeaderForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetLinkColor (inherited from DataGrid) | Resets the LinkColor property to its default value.
ResetLinkHoverColor (inherited from DataGrid) |
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetSelectionBackColor (inherited from DataGrid) | Resets the SelectionBackColor property to its default value.
ResetSelectionForeColor (inherited from DataGrid) | Resets the SelectionForeColor property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from DataGrid) | Overloaded. Selects a specified row.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo (inherited from vdxDataGrid) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDataBinding (inherited from DataGrid) | Sets the DataSource and DataMember properties at run time.
Show (inherited from Control) | Displays the control to the user.
SubObjectsSiteChange (inherited from DataGrid) |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
UnSelect (inherited from DataGrid) | Unselects a specified row.
Update (inherited from Control) | Overloaded. Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AddRow | Adds gridDataRow to data source table.
AttatchCurrencyManagerEventHandlers | Register CurrencyManager listeners.
CancelEditing (inherited from DataGrid) | Cancels the current edit operation and rolls back all changes.
ChangeSelection | Changes current selection to the given row.
Clear | Remove all rows from the grid.
CreateAccessibilityInstance (inherited from DataGrid) | Constructs a new instance of the accessibility object for this control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateGridColumn (inherited from DataGrid) | Overloaded. Creates a new DataGridColumnStyle with the specified PropertyDescriptor.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateNavigatorInfoItem | Creates a vdxNavigatorInfoItem for the given dataRow.
CurrencyManager_PositionChanged | Event listener on CurrencyManager to detect position changes.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
Delete | Deletes the selected row.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from DataGrid) | Overloaded.
Fill | Builds a dataGrid for the given DataSet;
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetDataRowKey | Gets an unique key to differ TreeNodes on the same hierarchy level.
GetGridDataRow | Gets the corresponding grid DataRow for the given navigator DataRow.
GetLoaderInfo | Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.
GetNavigatorInfo | Gets the corresponding navigation info for the given item.
GetNavigatorInfoItemForGridRow | Gets the corresponding navigator DataRow for the given grid DataRow.
GetOutputTextDelimiter (inherited from DataGrid) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GridHScrolled (inherited from DataGrid) | Listens for the horizontal scrollbar's scroll event.
GridVScrolled (inherited from DataGrid) | Listens for the vertical scrollbar's scroll event.
InitLayout (inherited from Control) | Called after the control has been added to another container.
Insert | Inserts a new navigator row for the corresponding navigator row.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsRefreshable | Checks if the component supports refresh.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAllowNavigationChanged (inherited from DataGrid) | Raises the AllowNavigationChanged event.
OnBackButtonClicked (inherited from DataGrid) | Listens for the caption's back button clicked event.
OnBackColorChanged (inherited from DataGrid) | Raises the BackColorChanged event.
OnBackgroundColorChanged (inherited from DataGrid) | Raises the BackgroundColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from DataGrid) | Raises the BindingContextChanged event.
OnBorderStyleChanged (inherited from DataGrid) | Raises the BorderStyleChanged event.
OnCaptionVisibleChanged (inherited from DataGrid) | Raises the CaptionVisibleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlChanged | Inform all registered components on ControlChanged about a control change.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCurrentCellChanged (inherited from DataGrid) | Raises the CurrentCellChanged event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from DataGrid) | Raises the DataSourceChanged event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from DataGrid) | Raises the Enter event.
OnFilled | Raises the Filled event.
OnFlatModeChanged (inherited from DataGrid) | Raises the FlatModeChanged event.
OnFontChanged (inherited from DataGrid) | Raises the FontChanged event.
OnForeColorChanged (inherited from DataGrid) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from DataGrid) | Raises the CreateHandle event.
OnHandleDestroyed (inherited from DataGrid) | Raises the DestroyHandle event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from DataGrid) | Raises the KeyDown event.
OnKeyPress (inherited from DataGrid) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from DataGrid) | Raises the Layout event that repositions controls and updates scroll bars.
OnLeave (inherited from DataGrid) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from DataGrid) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from DataGrid) | Creates the MouseLeave event.
OnMouseMove (inherited from DataGrid) | Raises the MouseMove event.
OnMouseUp (inherited from DataGrid) | Raises the MouseUp event.
OnMouseWheel (inherited from DataGrid) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNavigate (inherited from DataGrid) | Raises the Navigate event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from DataGrid) | Raises the Paint event.
OnPaintBackground (inherited from DataGrid) | Overrides OnPaintBackground to prevent painting the background of the DataGrid control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentRowsLabelStyleChanged (inherited from DataGrid) | Raises the ParentRowsLabelStyleChanged event.
OnParentRowsVisibleChanged (inherited from DataGrid) | Raises the ParentRowsVisibleChanged event.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from DataGrid) | Raises the ReadOnlyChanged event
OnResize (inherited from DataGrid) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnRowHeaderClick (inherited from DataGrid) | Raises the RowHeaderClick event.
OnScroll (inherited from DataGrid) | Raises the Scroll event.
OnSelectionChanged | Inform all registered components on SelectionChanged about a selection change.
OnShowParentDetailsButtonClicked (inherited from DataGrid) | Raises the ShowParentDetailsButtonClick event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from DataGrid) | Gets or sets a value that indicates whether a key should be processed further.
ProcessGridKey (inherited from DataGrid) | Processes keys for grid navigation.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from DataGrid) | Previews a keyboard message and returns a value indicating if the key was consumed.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
ProcessTabKey (inherited from DataGrid) | Gets a value indicating whether the Tab key should be processed.
ProviderToSet_OnDataTypeSet (inherited from vdxDataGrid) | Listens to the Event OnDataTypeSet that was set on DataSource and set the DataSource with the sender.
ProviderToSet_OnDataTypeSetDM (inherited from vdxDataGrid) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshData | Remove all elements from the navigator and fill up the given dataSet.
RemoveRow | Adds gridDataRow to data source table.
RemoveSelectedRow | Removes current selected gridDataRow from data source table.
ResetMouseEventArgs (inherited from Control) |
ResetSelection (inherited from DataGrid) | Turns off selection for all rows that are selected.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SelectDefault | Selects the default element.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShouldSerializeAlternatingBackColor (inherited from DataGrid) | Indicates whether the AlternatingBackColor property should be persisted.
ShouldSerializeBackgroundColor (inherited from DataGrid) | Indicates whether the BackgroundColor property should be persisted.
ShouldSerializeCaptionBackColor (inherited from DataGrid) | Gets a value indicating whether the CaptionBackColor property should be persisted.
ShouldSerializeCaptionForeColor (inherited from DataGrid) | Gets a value indicating whether the CaptionForeColor property should be persisted.
ShouldSerializeGridLineColor (inherited from DataGrid) | Indicates whether the GridLineColor property should be persisted.
ShouldSerializeHeaderBackColor (inherited from DataGrid) | Indicates whether the HeaderBackColor property should be persisted.
ShouldSerializeHeaderFont (inherited from DataGrid) | Indicates whether the HeaderFont property should be persisted.
ShouldSerializeHeaderForeColor (inherited from DataGrid) | Indicates whether the HeaderForeColor property should be persisted.
ShouldSerializeLinkHoverColor (inherited from DataGrid) | Indicates whether the LinkHoverColor property should be persisted.
ShouldSerializeParentRowsBackColor (inherited from DataGrid) | Indicates whether the ParentRowsBackColor property should be persisted.
ShouldSerializeParentRowsForeColor (inherited from DataGrid) | Indicates whether the ParentRowsForeColor property should be persisted.
ShouldSerializePreferredRowHeight (inherited from DataGrid) | Indicates whether the PreferredRowHeight property should be persisted.
ShouldSerializeSelectionBackColor (inherited from DataGrid) | Indicates whether the SelectionBackColor property should be persisted.
ShouldSerializeSelectionForeColor (inherited from DataGrid) | Indicates whether the SelectionForeColor property should be persisted.
Undo | Undo changes for the corresponding navigatorDataRow.
Update | Overloaded. Updates the corresponding navigator row with the given manipulator row.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ColumnStartedEditing (inherited from DataGrid) | Overloaded. Informs the DataGrid control when the user begins to edit a column using the specified control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.

Explicit Interface Implementations

IvdxNavigator.ChangeSelection
IvdxNavigator.Clear
IvdxNavigator.Copy
IvdxNavigator.Delete
IvdxNavigator.Fill
IvdxNavigator.GetLoaderInfo
IvdxNavigator.Insert
IvdxNavigator.IsRefreshable
IvdxNavigator.RefreshData
IvdxNavigator.SelectDefault
IvdxNavigator.Undo
IvdxNavigator.Update

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace | vdxDataGrid | IvdxNavigator

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.AddRow Method

Adds gridDataRow to data source table.

protected void AddRow(
DataRow gridDataRow,
vdxNavigatorInfoItem navInfoItem
);

Parameters

gridDataRow
navInfoItem

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.AttatchCurrencyManagerEventHandlers Method

Register CurrencyManager listeners.

protected void AttatchCurrencyManagerEventHandlers();

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.ChangeSelection Method

Changes current selection to the given row.

protected virtual void ChangeSelection(
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorInfo
The corresponding vdxNavigatorInfo to select.

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.Clear Method

Remove all rows from the grid.

protected virtual void Clear();

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.CreateNavigatorInfoItem Method

Creates a vdxNavigatorInfoItem for the given dataRow.

protected virtual vdxNavigatorInfoItem CreateNavigatorInfoItem(
DataRow dataRow
);

Parameters

dataRow
The row which will be encapsulated in the vdxNavigatorInfoItem.

Return Value

The created vdxNavigatorInfoItem.

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.CurrencyManager_PositionChanged Method

Event listener on CurrencyManager to detect position changes.

protected virtual void CurrencyManager_PositionChanged(
object sender,
EventArgs e
);

Parameters

sender
e

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.IvdxNavigator.ChangeSelection Method

void IvdxNavigator.ChangeSelection(
vdxNavigatorInfo navigatorInfo
);

Implements

IvdxNavigator.ChangeSelection

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.IvdxNavigator.Clear Method

void IvdxNavigator.Clear();

Implements

IvdxNavigator.Clear

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.IvdxNavigator.Copy Method

void IvdxNavigator.Copy(
DataRow navigatorDataRow,
vdxNavigatorInfo navigatorInfo
);

Implements

IvdxNavigator.Copy

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.IvdxNavigator.Delete Method

void IvdxNavigator.Delete(
vdxNavigatorInfo navigatorInfo
);

Implements

IvdxNavigator.Delete

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.IvdxNavigator.Fill Method

void IvdxNavigator.Fill(
DataSet dataSet
);

Implements

IvdxNavigator.Fill

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.IvdxNavigator.GetLoaderInfo Method

vdxLoaderInfo IvdxNavigator.GetLoaderInfo(
vdxNavigatorInfo navigatorInfo
);

Implements

IvdxNavigator.GetLoaderInfo

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.IvdxNavigator.Insert Method

void IvdxNavigator.Insert(
DataRow navigatorDataRow,
vdxNavigatorInfo navigatorInfo
);

Implements

IvdxNavigator.Insert

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.IvdxNavigator.IsRefreshable Method

bool IvdxNavigator.IsRefreshable();

Implements

IvdxNavigator.IsRefreshable

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.IvdxNavigator.RefreshData Method

vdxNavigatorInfo IvdxNavigator.RefreshData(
DataSet dataSet
);

Implements

IvdxNavigator.RefreshData

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.IvdxNavigator.SelectDefault Method

void IvdxNavigator.SelectDefault();

Implements

IvdxNavigator.SelectDefault

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.IvdxNavigator.Undo Method

void IvdxNavigator.Undo(
vdxNavigatorInfo navigatorInfo
);

Implements

IvdxNavigator.Undo

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.IvdxNavigator.Update Method

void IvdxNavigator.Update(
DataRow navigatorDataRow,
vdxNavigatorInfo navigatorInfo
);

Implements

IvdxNavigator.Update

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.Delete Method

Deletes the selected row.

protected virtual void Delete(
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorInfo
The last selected navigator info.

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.Fill Method

Builds a dataGrid for the given DataSet;

protected virtual void Fill(
DataSet dataSet
);

Parameters

dataSet
The dataSet, which the navigator extract all rows out of.

Remarks

On default the first table in the dataSet is shown.

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.GetDataRowKey Method

Gets an unique key to differ TreeNodes on the same hierarchy level.

protected virtual object GetDataRowKey(
DataRow gridRow
);

Parameters

gridRow
The row to extract key out of.

Return Value

The unique key of the treeNode.

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.GetGridDataRow Method

Gets the corresponding grid DataRow for the given navigator DataRow.

protected DataRow GetGridDataRow(
vdxNavigatorInfoItem navInfoItem
);

Parameters

navInfoItem

Return Value

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.GetLoaderInfo Method

Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.

protected virtual vdxLoaderInfo GetLoaderInfo(
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorInfo
Contains the DataRow to define the vdxLoaderInfo.

Return Value

The vdxLoaderInfo for the given navigatorInfo.

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.GetNavigatorInfo Method

Gets the corresponding navigation info for the given item.

protected virtual vdxNavigatorInfo GetNavigatorInfo(
DataRow gridRow
);

Parameters

gridRow
The specialized element of this navigator.

Return Value

The general communication object between the navigators.

Remarks

Used as eventArgs for vdxNavigatorSelectionEventHandler.

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.GetNavigatorInfoItemForGridRow Method

Gets the corresponding navigator DataRow for the given grid DataRow.

protected vdxNavigatorInfoItem GetNavigatorInfoItemForGridRow(
DataRow gridDataRow
);

Parameters

gridDataRow

Return Value

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.Insert Method

Inserts a new navigator row for the corresponding navigator row.

protected virtual void Insert(
DataRow navigatorDataRow,
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorDataRow
The row to be inserted.
navigatorInfo
The last selected navigator info.

Remarks

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.IsRefreshable Method

Checks if the component supports refresh.

protected virtual bool IsRefreshable();

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.OnControlChanged Method

Inform all registered components on ControlChanged about a control change.

protected virtual void OnControlChanged(
vdxNavigatorControlEventArgs eventArgs
);

Parameters

eventArgs
Contains the involved searchParameters and dataDetailType.

Remarks

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace | vdxNavigatorControlEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.OnFilled Method

Raises the Filled event.

protected virtual void OnFilled(
EventArgs e
);

Parameters

e
System.EventArgs that contains the event data.

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.OnSelectionChanged Method

Inform all registered components on SelectionChanged about a selection change.

protected virtual void OnSelectionChanged(
vdxNavigatorSelectionEventArgs eventArgs
);

Parameters

eventArgs
The invoker of the selection changed event.

Remarks

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace | vdxNavigatorSelectionEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.RefreshData Method

Remove all elements from the navigator and fill up the given dataSet.

protected virtual void RefreshData(
DataSet dataSet
);

Parameters

dataSet
The dataSet, which the navigator extract all rows out of.

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.RemoveRow Method

Adds gridDataRow to data source table.

protected void RemoveRow(
DataRow gridDataRow,
vdxNavigatorInfoItem navInfoItem
);

Parameters

gridDataRow
navInfoItem

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.RemoveSelectedRow Method

Removes current selected gridDataRow from data source table.

protected void RemoveSelectedRow();

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.SelectDefault Method

Selects the default element.

protected virtual void SelectDefault();

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.Undo Method

Undo changes for the corresponding navigatorDataRow.

protected virtual void Undo(
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorInfo
The last selected navigator info.

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Update Method

VDX Framework

vdxDataGridNavigator.Update Method

Updates the corresponding navigator row with the given manipulator row.

Overload List

Inherited from Control.

public void Update();

Updates the corresponding navigator row with the given manipulator row.

protected virtual void Update(DataRow,vdxNavigatorInfo);

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.Update Method (DataRow, vdxNavigatorInfo)

Updates the corresponding navigator row with the given manipulator row.

protected virtual void Update(
DataRow navigatorDataRow,
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorDataRow
The updated row.
navigatorInfo
The last selected navigator info.

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace | vdxDataGridNavigator.Update Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator Events

The events of the vdxDataGridNavigator class are listed below. For a complete list of vdxDataGridNavigator class members, see the vdxDataGridNavigator Members topic.

Public Instance Events

AllowNavigationChanged (inherited from DataGrid) | Occurs when the AllowNavigation property has changed.
BackButtonClick (inherited from DataGrid) | Occurs when the Back button on a child table is clicked.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundColorChanged (inherited from DataGrid) | Occurs when the BackgroundColor has changed.
BackgroundImageChanged (inherited from DataGrid) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
BorderStyleChanged (inherited from DataGrid) | Occurs when the BorderStyle has changed.
CaptionVisibleChanged (inherited from DataGrid) | Occurs when the CaptionVisible property has changed.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlChanged | Occurs when an other cacheable control had to be shown.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CurrentCellChanged (inherited from DataGrid) | Occurs when the CurrentCell property has changed.
CursorChanged (inherited from DataGrid) |
DataSourceChanged (inherited from DataGrid) | Occurs when the DataSource property value has changed.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
Filled | Occurs after Fill was called.
FlatModeChanged (inherited from DataGrid) | Occurs when the FlatMode has changed.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Navigate (inherited from DataGrid) | Occurs when the user navigates to a new table.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
ParentRowsLabelStyleChanged (inherited from DataGrid) | Occurs when the label style of the parent row is changed.
ParentRowsVisibleChanged (inherited from DataGrid) | Occurs when the ParentRowsVisible property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
ReadOnlyChanged (inherited from DataGrid) | Occurs when the ReadOnly property value changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from DataGrid) | Occurs when the user scrolls the DataGrid control.
SelectionChanged | Occurs when an other DataRow was selected.
ShowParentDetailsButtonClick (inherited from DataGrid) | Occurs when the ShowParentDetails button is clicked.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from DataGrid) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Events

RowHeaderClick (inherited from DataGrid) Occurs when a row header is clicked.

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace | vdxDataGrid | IvdxNavigator

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.ControlChanged Event

Occurs when an other cacheable control had to be shown.

public event vdxNavigatorControlEventHandler ControlChanged;

Event Data

The event handler receives an argument of type vdxNavigatorControlEventArgs containing data related to this event. The following vdxNavigatorControlEventArgs property provides information specific to this event.

Property | Description
LoaderInfo | Gets the involved .

Implements

IvdxNavigator.ControlChanged

Remarks

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace | vdxExplorer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.Filled Event

Occurs after Fill was called.

public event EventHandler Filled;

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataGridNavigator.SelectionChanged Event

Occurs when an other DataRow was selected.

public event vdxNavigatorSelectionEventHandler SelectionChanged;

Event Data

The event handler receives an argument of type vdxNavigatorSelectionEventArgs containing data related to this event. The following vdxNavigatorSelectionEventArgs property provides information specific to this event.

Property | Description
NavigatorInfo | Gets the involved .

Implements

IvdxNavigator.SelectionChanged

See Also

vdxDataGridNavigator Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView Class

VDX specific DataView. Allow to use vdxDataStatusManager and vdxDataSetReference.

For a list of all members of this type, see vdxDataView Members.

System.Object
MarshalByValueComponent
DataView
vdxDataView

public class vdxDataView : DataView, IvdxDataSetProvider, IListSource

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataView Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView Members

vdxDataView overview

Public Instance Constructors

vdxDataView Overloaded. Initializes a new instance of the vdxDataView class.

Public Instance Properties

AllowDelete (inherited from DataView) | Sets or gets a value indicating whether deletes are allowed.
AllowEdit (inherited from DataView) | Gets or sets a value indicating whether edits are allowed.
AllowNew (inherited from DataView) | Gets or sets a value indicating whether the new rows can be added using the AddNew method.
ApplyDefaultSort (inherited from DataView) | Gets or sets a value indicating whether to use the default sort.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count (inherited from DataView) | Gets the number of records in the DataView after RowFilter and RowStateFilter have been applied.
DataMember | DataMember is the name of the table in the Datasource used as aource for the DataView.
DataSource | Gets or sets the data source that this grid is displaying data for.
DataViewManager (inherited from DataView) | Gets the DataViewManager associated with this view.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
Item (inherited from DataView) | Gets a row of data from a specified table.
Name | Gets or sets designer component name. Corresponds to the Property (Name).
RowFilter (inherited from DataView) | Gets or sets the expression used to filter which rows are viewed in the DataView.
RowStateFilter (inherited from DataView) | Gets or sets the row state filter used in the DataView.
Site (inherited from MarshalByValueComponent) | Gets or sets the site of the component.
Sort (inherited from DataView) | Gets or sets the sort column or columns, and sort order for the DataView.
Table | Hidden designer property Table.

Public Instance Methods

AddNew (inherited from DataView) | Adds a new row to the DataView .
BeginInit (inherited from DataView) | Begins the initialization of a DataView that is used on a form or used by another component. The initialization occurs at runtime.
CopyTo (inherited from DataView) | Copies items into an array. Only for Web Forms Interfaces.
Delete (inherited from DataView) | Deletes a row at the specified index.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent .
EndInit (inherited from DataView) | Ends the initialization of a DataView that is used on a form or used by another component. The initialization occurs at runtime.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Find (inherited from DataView) | Overloaded. Finds a row in the DataView by the specified sort key value.
FindRows (inherited from DataView) | Overloaded. Returns an array of DataRowView objects whose columns match the specified sort key value.
GetEnumerator (inherited from DataView) | Gets an enumerator for this DataView.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from MarshalByValueComponent) |

Public Instance Events

Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
ListChanged (inherited from DataView) | Occurs when the list managed by the DataView changes.
OnDataTypeSet | Occurs after the DataSet type was set.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) | Gets the list of event handlers that are attached to this component.
IsOpen (inherited from DataView) | Gets a value indicating whether the data source is currently open and projecting views of data on the DataTable.

Protected Instance Methods

Close (inherited from DataView) | Closes the DataView .
ColumnCollectionChanged (inherited from DataView) | Occurs after a DataColumnCollection has been changed successfully.
Dispose (inherited from DataView) | Overloaded. Disposes of the resources (other than memory) used by the DataView object.
Finalize (inherited from MarshalByValueComponent) |
IndexListChanged (inherited from DataView) | Occurs after a DataView has been changed successfully.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnListChanged (inherited from DataView) | Raises the ListChanged event.
Open (inherited from DataView) | Opens a DataView.
ProviderToSet_OnDataTypeSetDM | Listens to the Event OnDataTypeSet that was set on DataSource and set the DataSource with the sender.
ProviderToSet_OnDataTypeSetDS | Listens to the Event OnDataTypeSet that was set on DataSource and set the DataSource with the sender.
Reset (inherited from DataView) | Reserved for internal use only.
UpdateIndex (inherited from DataView) | Overloaded. Reserved for internal use only.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDataSetProvider.DataSet
Deag.Vdx.Controls.Core.IvdxDataSetProvider.DataSetType
System.ComponentModel.IListSource.ContainsListCollection

Explicit Interface Implementations

IBindingList.AddIndex (inherited from DataView) |
IBindingList.AddNew (inherited from DataView) |
IBindingList.ApplySort (inherited from DataView) |
IBindingList.Find (inherited from DataView) |
IBindingList.RemoveIndex (inherited from DataView) |
IBindingList.RemoveSort (inherited from DataView) |
IList.Add (inherited from DataView) |
IList.Clear (inherited from DataView) |
IList.Contains (inherited from DataView) |
IList.IndexOf (inherited from DataView) |
IList.Insert (inherited from DataView) |
IList.Remove (inherited from DataView) |
IList.RemoveAt (inherited from DataView) |
IListSource.GetList |
ISupportInitialize.BeginInit |
ISupportInitialize.EndInit | if we have a valid datatable attatched, we throw the OnDataTypeSet event
ITypedList.GetItemProperties (inherited from DataView) |
ITypedList.GetListName (inherited from DataView) |
IvdxDataSetProvider.Contains |

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView Constructor

Initializes a new instance of the vdxDataStatusManager class.

Overload List

Initializes a new instance of the vdxDataStatusManager class.

public vdxDataView();

Initializes a new instance of the vdxDataStatusManager class.

public vdxDataView(IContainer);

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView Constructor ()

Initializes a new instance of the vdxDataStatusManager class.

public vdxDataView();

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace | vdxDataView Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView Constructor (IContainer)

Initializes a new instance of the vdxDataStatusManager class.

public vdxDataView(
IContainer container
);

Parameters

container
The container that holds this vdxDataView instance.

Remarks

This contructor is usually used by the designer.

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace | vdxDataView Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView Properties

The properties of the vdxDataView class are listed below. For a complete list of vdxDataView class members, see the vdxDataView Members topic.

Public Instance Properties

AllowDelete (inherited from DataView) | Sets or gets a value indicating whether deletes are allowed.
AllowEdit (inherited from DataView) | Gets or sets a value indicating whether edits are allowed.
AllowNew (inherited from DataView) | Gets or sets a value indicating whether the new rows can be added using the AddNew method.
ApplyDefaultSort (inherited from DataView) | Gets or sets a value indicating whether to use the default sort.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count (inherited from DataView) | Gets the number of records in the DataView after RowFilter and RowStateFilter have been applied.
DataMember | DataMember is the name of the table in the Datasource used as aource for the DataView.
DataSource | Gets or sets the data source that this grid is displaying data for.
DataViewManager (inherited from DataView) | Gets the DataViewManager associated with this view.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
Item (inherited from DataView) | Gets a row of data from a specified table.
Name | Gets or sets designer component name. Corresponds to the Property (Name).
RowFilter (inherited from DataView) | Gets or sets the expression used to filter which rows are viewed in the DataView.
RowStateFilter (inherited from DataView) | Gets or sets the row state filter used in the DataView.
Site (inherited from MarshalByValueComponent) | Gets or sets the site of the component.
Sort (inherited from DataView) | Gets or sets the sort column or columns, and sort order for the DataView.
Table | Hidden designer property Table.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) | Gets the list of event handlers that are attached to this component.
IsOpen (inherited from DataView) | Gets a value indicating whether the data source is currently open and projecting views of data on the DataTable.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDataSetProvider.DataSet
Deag.Vdx.Controls.Core.IvdxDataSetProvider.DataSetType
System.ComponentModel.IListSource.ContainsListCollection

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView.DataMember Property

DataMember is the name of the table in the Datasource used as aource for the DataView.

public string DataMember {get; set;}

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView.DataSource Property

Gets or sets the data source that this grid is displaying data for.

public object DataSource {get; set;}

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView.Deag.Vdx.Controls.Core.IvdxDataSetProvider.DataSet Property

private System.Data.DataSet Deag.Vdx.Controls.Core.IvdxDataSetProvider.DataSet {get; set;}

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView.Deag.Vdx.Controls.Core.IvdxDataSetProvider.DataSetType Property

private System.Type Deag.Vdx.Controls.Core.IvdxDataSetProvider.DataSetType {get; set;}

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView.Name Property

Gets or sets designer component name. Corresponds to the Property (Name).

public string Name {get; set;}

Implements

IvdxDataSetProvider.Name

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView.System.ComponentModel.IListSource.ContainsListCollection Property

private bool System.ComponentModel.IListSource.ContainsListCollection {get;}

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView.Table Property

Hidden designer property Table.

new public System.Data.DataTable Table {get; set;}

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView Methods

The methods of the vdxDataView class are listed below. For a complete list of vdxDataView class members, see the vdxDataView Members topic.

Public Instance Methods

AddNew (inherited from DataView) | Adds a new row to the DataView .
BeginInit (inherited from DataView) | Begins the initialization of a DataView that is used on a form or used by another component. The initialization occurs at runtime.
CopyTo (inherited from DataView) | Copies items into an array. Only for Web Forms Interfaces.
Delete (inherited from DataView) | Deletes a row at the specified index.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent .
EndInit (inherited from DataView) | Ends the initialization of a DataView that is used on a form or used by another component. The initialization occurs at runtime.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Find (inherited from DataView) | Overloaded. Finds a row in the DataView by the specified sort key value.
FindRows (inherited from DataView) | Overloaded. Returns an array of DataRowView objects whose columns match the specified sort key value.
GetEnumerator (inherited from DataView) | Gets an enumerator for this DataView.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from MarshalByValueComponent) |

Protected Instance Methods

Close (inherited from DataView) | Closes the DataView .
ColumnCollectionChanged (inherited from DataView) | Occurs after a DataColumnCollection has been changed successfully.
Dispose (inherited from DataView) | Overloaded. Disposes of the resources (other than memory) used by the DataView object.
Finalize (inherited from MarshalByValueComponent) |
IndexListChanged (inherited from DataView) | Occurs after a DataView has been changed successfully.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnListChanged (inherited from DataView) | Raises the ListChanged event.
Open (inherited from DataView) | Opens a DataView.
ProviderToSet_OnDataTypeSetDM | Listens to the Event OnDataTypeSet that was set on DataSource and set the DataSource with the sender.
ProviderToSet_OnDataTypeSetDS | Listens to the Event OnDataTypeSet that was set on DataSource and set the DataSource with the sender.
Reset (inherited from DataView) | Reserved for internal use only.
UpdateIndex (inherited from DataView) | Overloaded. Reserved for internal use only.

Explicit Interface Implementations

IBindingList.AddIndex (inherited from DataView) |
IBindingList.AddNew (inherited from DataView) |
IBindingList.ApplySort (inherited from DataView) |
IBindingList.Find (inherited from DataView) |
IBindingList.RemoveIndex (inherited from DataView) |
IBindingList.RemoveSort (inherited from DataView) |
IList.Add (inherited from DataView) |
IList.Clear (inherited from DataView) |
IList.Contains (inherited from DataView) |
IList.IndexOf (inherited from DataView) |
IList.Insert (inherited from DataView) |
IList.Remove (inherited from DataView) |
IList.RemoveAt (inherited from DataView) |
IListSource.GetList |
ISupportInitialize.BeginInit |
ISupportInitialize.EndInit | if we have a valid datatable attatched, we throw the OnDataTypeSet event
ITypedList.GetItemProperties (inherited from DataView) |
ITypedList.GetListName (inherited from DataView) |
IvdxDataSetProvider.Contains |

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView.IvdxDataSetProvider.Contains Method

bool IvdxDataSetProvider.Contains(
DataTable table
);

Implements

IvdxDataSetProvider.Contains

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView.ProviderToSet_OnDataTypeSetDM Method

Listens to the Event OnDataTypeSet that was set on DataSource and set the DataSource with the sender.

protected virtual void ProviderToSet_OnDataTypeSetDM(
object sender,
EventArgs e
);

Parameters

sender
The new DataSource to set.
e
not used

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView.ProviderToSet_OnDataTypeSetDS Method

Listens to the Event OnDataTypeSet that was set on DataSource and set the DataSource with the sender.

protected virtual void ProviderToSet_OnDataTypeSetDS(
object sender,
EventArgs e
);

Parameters

sender
The new DataSource to set.
e
not used

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView.IListSource.GetList Method

IList IListSource.GetList();

Implements

IListSource.GetList

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView.ISupportInitialize.BeginInit Method

void ISupportInitialize.BeginInit();

Implements

ISupportInitialize.BeginInit

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView.ISupportInitialize.EndInit Method

if we have a valid datatable attatched, we throw the OnDataTypeSet event

void ISupportInitialize.EndInit();

Implements

ISupportInitialize.EndInit

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView Events

The events of the vdxDataView class are listed below. For a complete list of vdxDataView class members, see the vdxDataView Members topic.

Public Instance Events

Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
ListChanged (inherited from DataView) | Occurs when the list managed by the DataView changes.
OnDataTypeSet | Occurs after the DataSet type was set.

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataView.OnDataTypeSet Event

Occurs after the DataSet type was set.

public event EventHandler OnDataTypeSet;

Implements

IvdxDataSetProvider.OnDataTypeSet

See Also

vdxDataView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem Class

Class to inherit from to hide default properties.

For a list of all members of this type, see vdxDesignerItem Members.

System.Object
MarshalByRefObject
Component
Control
vdxDesignerItem

public class vdxDesignerItem : Control

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDesignerItem Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem Members

vdxDesignerItem overview

Public Instance Constructors

vdxDesignerItem Constructor Initializes a new instance of the vdxDesignerItem class.

Public Instance Properties

AccessibilityObject | Overloaded. Hides the corresponding property for easier use within property sheet.
AccessibleDefaultActionDescription | Hides the corresponding property for easier use within property sheet.
AccessibleDescription | Hides the corresponding property for easier use within property sheet.
AccessibleName | Hides the corresponding property for easier use within property sheet.
AccessibleRole | Hides the corresponding property for easier use within property sheet.
AllowDrop | Hides the corresponding property for easier use within property sheet.
Anchor | Hides the corresponding property for easier use within property sheet.
BackColor | Hides the corresponding property for easier use within property sheet.
BackgroundImage | Hides the corresponding property for easier use within property sheet.
BindingContext | Hides the corresponding property for easier use within property sheet.
Bottom | Hides the corresponding property for easier use within property sheet.
Bounds | Hides the corresponding property for easier use within property sheet.
CanFocus | Hides the corresponding property for easier use within property sheet.
CanSelect | Hides the corresponding property for easier use within property sheet.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation | Hides the corresponding property for easier use within property sheet.
ClientRectangle | Hides the corresponding property for easier use within property sheet.
ClientSize | Hides the corresponding property for easier use within property sheet.
CompanyName | Hides the corresponding property for easier use within property sheet.
Container | Hides the corresponding property for easier use within property sheet.
ContainsFocus | Hides the corresponding property for easier use within property sheet.
ContextMenu | Hides the corresponding property for easier use within property sheet.
Controls | Hides the corresponding property for easier use within property sheet.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor | Hides the corresponding property for easier use within property sheet.
DataBindings | Hides the corresponding property for easier use within property sheet.
DesignMode | Hides the corresponding property for easier use within property sheet.
DisplayRectangle | Hides the corresponding property for easier use within property sheet.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock | Hides the corresponding property for easier use within property sheet.
Enabled | Hides the corresponding property for easier use within property sheet.
Focused | Hides the corresponding property for easier use within property sheet.
Font | Hides the corresponding property for easier use within property sheet.
ForeColor | Hides the corresponding property for easier use within property sheet.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height | Hides the corresponding property for easier use within property sheet.
ImeMode | Hides the corresponding property for easier use within property sheet.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left | Hides the corresponding property for easier use within property sheet.
Location | Hides the corresponding property for easier use within property sheet.
Name (inherited from Control) | Gets or sets the name of the control.
Parent | Hides the corresponding property for easier use within property sheet.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion | Hides the corresponding property for easier use within property sheet.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right | Hides the corresponding property for easier use within property sheet.
RightToLeft | Overloaded. Hides the corresponding property for easier use within property sheet.
Site (inherited from Control) | Gets or sets the site of the control.
Size | Hides the corresponding property for easier use within property sheet.
TabIndex | Hides the corresponding property for easier use within property sheet.
TabStop | Hides the corresponding property for easier use within property sheet.
Tag | Hides the corresponding property for easier use within property sheet.
Text | Hides the corresponding property for easier use within property sheet.
Top | Hides the corresponding property for easier use within property sheet.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible | Hides the corresponding property for easier use within property sheet.
Width | Hides the corresponding property for easier use within property sheet.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Control) | Gets the default size of the control.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem Constructor

Initializes a new instance of the vdxDesignerItem class.

public vdxDesignerItem();

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem Properties

The properties of the vdxDesignerItem class are listed below. For a complete list of vdxDesignerItem class members, see the vdxDesignerItem Members topic.

Public Instance Properties

AccessibilityObject | Overloaded. Hides the corresponding property for easier use within property sheet.
AccessibleDefaultActionDescription | Hides the corresponding property for easier use within property sheet.
AccessibleDescription | Hides the corresponding property for easier use within property sheet.
AccessibleName | Hides the corresponding property for easier use within property sheet.
AccessibleRole | Hides the corresponding property for easier use within property sheet.
AllowDrop | Hides the corresponding property for easier use within property sheet.
Anchor | Hides the corresponding property for easier use within property sheet.
BackColor | Hides the corresponding property for easier use within property sheet.
BackgroundImage | Hides the corresponding property for easier use within property sheet.
BindingContext | Hides the corresponding property for easier use within property sheet.
Bottom | Hides the corresponding property for easier use within property sheet.
Bounds | Hides the corresponding property for easier use within property sheet.
CanFocus | Hides the corresponding property for easier use within property sheet.
CanSelect | Hides the corresponding property for easier use within property sheet.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation | Hides the corresponding property for easier use within property sheet.
ClientRectangle | Hides the corresponding property for easier use within property sheet.
ClientSize | Hides the corresponding property for easier use within property sheet.
CompanyName | Hides the corresponding property for easier use within property sheet.
Container | Hides the corresponding property for easier use within property sheet.
ContainsFocus | Hides the corresponding property for easier use within property sheet.
ContextMenu | Hides the corresponding property for easier use within property sheet.
Controls | Hides the corresponding property for easier use within property sheet.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor | Hides the corresponding property for easier use within property sheet.
DataBindings | Hides the corresponding property for easier use within property sheet.
DesignMode | Hides the corresponding property for easier use within property sheet.
DisplayRectangle | Hides the corresponding property for easier use within property sheet.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock | Hides the corresponding property for easier use within property sheet.
Enabled | Hides the corresponding property for easier use within property sheet.
Focused | Hides the corresponding property for easier use within property sheet.
Font | Hides the corresponding property for easier use within property sheet.
ForeColor | Hides the corresponding property for easier use within property sheet.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height | Hides the corresponding property for easier use within property sheet.
ImeMode | Hides the corresponding property for easier use within property sheet.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left | Hides the corresponding property for easier use within property sheet.
Location | Hides the corresponding property for easier use within property sheet.
Name (inherited from Control) | Gets or sets the name of the control.
Parent | Hides the corresponding property for easier use within property sheet.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion | Hides the corresponding property for easier use within property sheet.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right | Hides the corresponding property for easier use within property sheet.
RightToLeft | Overloaded. Hides the corresponding property for easier use within property sheet.
Site (inherited from Control) | Gets or sets the site of the control.
Size | Hides the corresponding property for easier use within property sheet.
TabIndex | Hides the corresponding property for easier use within property sheet.
TabStop | Hides the corresponding property for easier use within property sheet.
Tag | Hides the corresponding property for easier use within property sheet.
Text | Hides the corresponding property for easier use within property sheet.
Top | Hides the corresponding property for easier use within property sheet.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible | Hides the corresponding property for easier use within property sheet.
Width | Hides the corresponding property for easier use within property sheet.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Control) | Gets the default size of the control.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.AccessibilityObject Property

Hides the corresponding property for easier use within property sheet.

new public System.Windows.Forms.Control.ControlAccessibleObject AccessibilityObject {get;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.AccessibleDefaultActionDescription Property

Hides the corresponding property for easier use within property sheet.

new public string AccessibleDefaultActionDescription {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.AccessibleDescription Property

Hides the corresponding property for easier use within property sheet.

new public string AccessibleDescription {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.AccessibleName Property

Hides the corresponding property for easier use within property sheet.

new public string AccessibleName {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.AccessibleRole Property

Hides the corresponding property for easier use within property sheet.

new public System.Windows.Forms.AccessibleRole AccessibleRole {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.AllowDrop Property

Hides the corresponding property for easier use within property sheet.

new public bool AllowDrop {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Anchor Property

Hides the corresponding property for easier use within property sheet.

new public System.Windows.Forms.AnchorStyles Anchor {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.BackColor Property

Hides the corresponding property for easier use within property sheet.

new public System.Drawing.Color BackColor {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.BackgroundImage Property

Hides the corresponding property for easier use within property sheet.

new public System.Drawing.Image BackgroundImage {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.BindingContext Property

Hides the corresponding property for easier use within property sheet.

new public System.Windows.Forms.BindingContext BindingContext {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Bottom Property

Hides the corresponding property for easier use within property sheet.

new public int Bottom {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Bounds Property

Hides the corresponding property for easier use within property sheet.

new public System.Drawing.Rectangle Bounds {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.CanFocus Property

Hides the corresponding property for easier use within property sheet.

new public bool CanFocus {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.CanSelect Property

Hides the corresponding property for easier use within property sheet.

new public bool CanSelect {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.CausesValidation Property

Hides the corresponding property for easier use within property sheet.

new public bool CausesValidation {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.ClientRectangle Property

Hides the corresponding property for easier use within property sheet.

new public System.Drawing.Rectangle ClientRectangle {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.ClientSize Property

Hides the corresponding property for easier use within property sheet.

new public System.Drawing.Size ClientSize {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.CompanyName Property

Hides the corresponding property for easier use within property sheet.

new public string CompanyName {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Container Property

Hides the corresponding property for easier use within property sheet.

new public System.ComponentModel.IContainer Container {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.ContainsFocus Property

Hides the corresponding property for easier use within property sheet.

new public bool ContainsFocus {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.ContextMenu Property

Hides the corresponding property for easier use within property sheet.

new public System.Windows.Forms.ContextMenu ContextMenu {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Controls Property

Hides the corresponding property for easier use within property sheet.

new public System.Windows.Forms.Control.ControlCollection Controls {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Cursor Property

Hides the corresponding property for easier use within property sheet.

new public System.Windows.Forms.Cursor Cursor {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.DataBindings Property

Hides the corresponding property for easier use within property sheet.

new public System.Windows.Forms.ControlBindingsCollection DataBindings {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.DesignMode Property

Hides the corresponding property for easier use within property sheet.

new public bool DesignMode {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.DisplayRectangle Property

Hides the corresponding property for easier use within property sheet.

new public System.Drawing.Rectangle DisplayRectangle {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Dock Property

Hides the corresponding property for easier use within property sheet.

new public System.Windows.Forms.DockStyle Dock {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Enabled Property

Hides the corresponding property for easier use within property sheet.

new public bool Enabled {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Focused Property

Hides the corresponding property for easier use within property sheet.

new public bool Focused {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Font Property

Hides the corresponding property for easier use within property sheet.

new public System.Drawing.Font Font {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.ForeColor Property

Hides the corresponding property for easier use within property sheet.

new public System.Drawing.Color ForeColor {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Height Property

Hides the corresponding property for easier use within property sheet.

new public int Height {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.ImeMode Property

Hides the corresponding property for easier use within property sheet.

new public System.Windows.Forms.ImeMode ImeMode {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Left Property

Hides the corresponding property for easier use within property sheet.

new public int Left {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Location Property

Hides the corresponding property for easier use within property sheet.

new public System.Drawing.Point Location {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Parent Property

Hides the corresponding property for easier use within property sheet.

new public System.Windows.Forms.Control Parent {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.ProductVersion Property

Hides the corresponding property for easier use within property sheet.

new public string ProductVersion {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Right Property

Hides the corresponding property for easier use within property sheet.

new public int Right {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.RightToLeft Property

Hides the corresponding property for easier use within property sheet.

new public int RightToLeft {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Size Property

Hides the corresponding property for easier use within property sheet.

new public System.Drawing.Size Size {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.TabIndex Property

Hides the corresponding property for easier use within property sheet.

new public int TabIndex {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.TabStop Property

Hides the corresponding property for easier use within property sheet.

new public bool TabStop {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Tag Property

Hides the corresponding property for easier use within property sheet.

new public object Tag {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Text Property

Hides the corresponding property for easier use within property sheet.

new public string Text {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Top Property

Hides the corresponding property for easier use within property sheet.

new public int Top {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Visible Property

Hides the corresponding property for easier use within property sheet.

new public bool Visible {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDesignerItem.Width Property

Hides the corresponding property for easier use within property sheet.

new public int Width {get; set;}

See Also

vdxDesignerItem Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxGroupBox Class

Specialized .Net GroupBox that implements the IvdxBindable to bind the bindable properties.

For a list of all members of this type, see vdxGroupBox Members.

System.Object
MarshalByRefObject
Component
Control
GroupBox
vdxGroupBox

public class vdxGroupBox : GroupBox, IvdxBindable

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxGroupBox Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxGroupBox Members

vdxGroupBox overview

Public Instance Constructors

vdxGroupBox Overloaded. Initializes a new instance of the vdxGroupBox class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from GroupBox) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from GroupBox) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from GroupBox) | Gets or sets the flat style appearance of the group box control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from GroupBox) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from GroupBox) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from GroupBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from GroupBox) |
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from GroupBox) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from GroupBox) |
KeyPress (inherited from GroupBox) |
KeyUp (inherited from GroupBox) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from GroupBox) |
MouseEnter (inherited from GroupBox) |
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from GroupBox) |
MouseMove (inherited from GroupBox) |
MouseUp (inherited from GroupBox) |
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from GroupBox) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from GroupBox) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from GroupBox) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from GroupBox) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from GroupBox) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from GroupBox) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from GroupBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxGroupBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxGroupBox Constructor

Initializes a new instance of the vdxGroupBox class.

Overload List

Initializes a new instance of the vdxGroupBox class.

public vdxGroupBox();

Initializes a new instance of the vdxGroupBox class with the specified container.

public vdxGroupBox(IContainer);

See Also

vdxGroupBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxGroupBox Constructor ()

Initializes a new instance of the vdxGroupBox class.

public vdxGroupBox();

See Also

vdxGroupBox Class | Deag.Vdx.Controls.Base Namespace | vdxGroupBox Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxGroupBox Constructor (IContainer)

Initializes a new instance of the vdxGroupBox class with the specified container.

public vdxGroupBox(
IContainer container
);

Parameters

container
The container of the Visual Studio Designer to add this group box.

Remarks

See Also

vdxGroupBox Class | Deag.Vdx.Controls.Base Namespace | vdxGroupBox Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxGroupBox Properties

The properties of the vdxGroupBox class are listed below. For a complete list of vdxGroupBox class members, see the vdxGroupBox Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from GroupBox) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from GroupBox) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from GroupBox) | Gets or sets the flat style appearance of the group box control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from GroupBox) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from GroupBox) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from GroupBox) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from GroupBox) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxGroupBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxGroupBox.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxGroupBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxGroupBox.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxGroupBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxGroupBox Methods

The methods of the vdxGroupBox class are listed below. For a complete list of vdxGroupBox class members, see the vdxGroupBox Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from GroupBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from GroupBox) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from GroupBox) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from GroupBox) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from GroupBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxGroupBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxGroupBox.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxGroupBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxGroupBox.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxGroupBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLabel Class

Specialized .Net Label that implements the IvdxBindable to bind the bindable properties.

For a list of all members of this type, see vdxLabel Members.

System.Object
MarshalByRefObject
Component
Control
Label
vdxLabel

public class vdxLabel : Label, IvdxBindable

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxLabel Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLabel Members

vdxLabel overview

Public Instance Constructors

vdxLabel Constructor Initializes a new instance of the vdxLabel class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from Label) | Gets or sets a value indicating whether the control is automatically resized to display its entire contents.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Label) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from Label) | Gets or sets the border style for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from Label) | Gets or sets the flat style appearance of the label control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from Label) | Gets or sets the image that is displayed on a Label.
ImageAlign (inherited from Label) | Gets or sets the alignment of an image that is displayed in the control.
ImageIndex (inherited from Label) | Gets or sets the index value of the image displayed on the Label.
ImageList (inherited from Label) | Gets or sets the ImageList that contains the images to display in the Label control.
ImeMode (inherited from Label) |
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from Label) | Gets the preferred height of the control.
PreferredWidth (inherited from Label) | Gets the preferred width of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Label) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from Label) | Gets or sets the alignment of text in the label.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseMnemonic (inherited from Label) | Gets or sets a value indicating whether the control interprets an ampersand character (&) in the control's Text property to be an access key prefix character.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Label) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AutoSizeChanged (inherited from Label) | Occurs when the value of the AutoSize property has changed.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Label) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Label) |
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Label) |
KeyPress (inherited from Label) |
KeyUp (inherited from Label) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Label) |
TextAlignChanged (inherited from Label) | Occurs when the value of the TextAlign property has changed.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Label) |
DefaultImeMode (inherited from Label) | Gets the default Input Method Editor(IME) mode supported by this control.
DefaultSize (inherited from Label) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
RenderTransparent (inherited from Label) | Indicates whether the container control background is rendered on the Label.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CalcImageRenderBounds (inherited from Label) | Determines the size and location of an image drawn within the Label control based on the alignment of the control.
CreateAccessibilityInstance (inherited from Label) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Label) | Overloaded.
DrawImage (inherited from Label) | Draws an Image within the specified bounds.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAutoSizeChanged (inherited from Label) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Label) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Label) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Label) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Label) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextAlignChanged (inherited from Label) | Raises the TextAlignChanged event.
OnTextChanged (inherited from Label) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Label) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Label) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Label) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Label) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxLabel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLabel Constructor

Initializes a new instance of the vdxLabel class.

public vdxLabel();

See Also

vdxLabel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLabel Properties

The properties of the vdxLabel class are listed below. For a complete list of vdxLabel class members, see the vdxLabel Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from Label) | Gets or sets a value indicating whether the control is automatically resized to display its entire contents.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Label) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from Label) | Gets or sets the border style for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from Label) | Gets or sets the flat style appearance of the label control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from Label) | Gets or sets the image that is displayed on a Label.
ImageAlign (inherited from Label) | Gets or sets the alignment of an image that is displayed in the control.
ImageIndex (inherited from Label) | Gets or sets the index value of the image displayed on the Label.
ImageList (inherited from Label) | Gets or sets the ImageList that contains the images to display in the Label control.
ImeMode (inherited from Label) |
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from Label) | Gets the preferred height of the control.
PreferredWidth (inherited from Label) | Gets the preferred width of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Label) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from Label) | Gets or sets the alignment of text in the label.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseMnemonic (inherited from Label) | Gets or sets a value indicating whether the control interprets an ampersand character (&) in the control's Text property to be an access key prefix character.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Label) |
DefaultImeMode (inherited from Label) | Gets the default Input Method Editor(IME) mode supported by this control.
DefaultSize (inherited from Label) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
RenderTransparent (inherited from Label) | Indicates whether the container control background is rendered on the Label.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxLabel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLabel.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxLabel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLabel.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxLabel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLabel Methods

The methods of the vdxLabel class are listed below. For a complete list of vdxLabel class members, see the vdxLabel Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Label) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CalcImageRenderBounds (inherited from Label) | Determines the size and location of an image drawn within the Label control based on the alignment of the control.
CreateAccessibilityInstance (inherited from Label) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Label) | Overloaded.
DrawImage (inherited from Label) | Draws an Image within the specified bounds.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAutoSizeChanged (inherited from Label) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Label) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Label) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Label) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Label) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextAlignChanged (inherited from Label) | Raises the TextAlignChanged event.
OnTextChanged (inherited from Label) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Label) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Label) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Label) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Label) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxLabel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLabel.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxLabel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLabel.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxLabel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLinkLabel Class

Specialized .Net LinkLabel that implements the IvdxBindable to bind the bindable properties.

For a list of all members of this type, see vdxLinkLabel Members.

System.Object
MarshalByRefObject
Component
Control
Label
LinkLabel
vdxLinkLabel

public class vdxLinkLabel : LinkLabel, IvdxBindable

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxLinkLabel Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLinkLabel Members

vdxLinkLabel overview

Public Instance Constructors

vdxLinkLabel Constructor Initializes a new instance of the vdxLinkLabel class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveLinkColor (inherited from LinkLabel) | Gets or sets the color used to display an active link.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from Label) | Gets or sets a value indicating whether the control is automatically resized to display its entire contents.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Label) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from Label) | Gets or sets the border style for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisabledLinkColor (inherited from LinkLabel) | Gets or sets the color used when displaying a disabled link.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from Label) | Gets or sets the flat style appearance of the label control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from Label) | Gets or sets the image that is displayed on a Label.
ImageAlign (inherited from Label) | Gets or sets the alignment of an image that is displayed in the control.
ImageIndex (inherited from Label) | Gets or sets the index value of the image displayed on the Label.
ImageList (inherited from Label) | Gets or sets the ImageList that contains the images to display in the Label control.
ImeMode (inherited from Label) |
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LinkArea (inherited from LinkLabel) | Gets or sets the range in the text to treat as a link.
LinkBehavior (inherited from LinkLabel) | Gets or sets a value that represents the behavior of a link.
LinkColor (inherited from LinkLabel) | Gets or sets the color used when displaying a normal link.
Links (inherited from LinkLabel) | Gets the collection of links contained within the LinkLabel.
LinkVisited (inherited from LinkLabel) | Gets or sets a value indicating whether a link should be displayed as though it were visited.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from Label) | Gets the preferred height of the control.
PreferredWidth (inherited from Label) | Gets the preferred width of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Label) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from LinkLabel) |
TextAlign (inherited from Label) | Gets or sets the alignment of text in the label.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseMnemonic (inherited from Label) | Gets or sets a value indicating whether the control interprets an ampersand character (&) in the control's Text property to be an access key prefix character.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisitedLinkColor (inherited from LinkLabel) | Gets or sets the color used when displaying a link that that has been previously visited.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Label) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AutoSizeChanged (inherited from Label) | Occurs when the value of the AutoSize property has changed.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Label) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Label) |
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Label) |
KeyPress (inherited from Label) |
KeyUp (inherited from Label) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LinkClicked (inherited from LinkLabel) | Occurs when a link is clicked within the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Label) |
TextAlignChanged (inherited from Label) | Occurs when the value of the TextAlign property has changed.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Label) |
DefaultImeMode (inherited from Label) | Gets the default Input Method Editor(IME) mode supported by this control.
DefaultSize (inherited from Label) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
OverrideCursor (inherited from LinkLabel) |
RenderRightToLeft (inherited from Control) |
RenderTransparent (inherited from Label) | Indicates whether the container control background is rendered on the Label.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CalcImageRenderBounds (inherited from Label) | Determines the size and location of an image drawn within the Label control based on the alignment of the control.
CreateAccessibilityInstance (inherited from LinkLabel) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from LinkLabel) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Label) | Overloaded.
DrawImage (inherited from Label) | Draws an Image within the specified bounds.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAutoSizeChanged (inherited from Label) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from LinkLabel) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from LinkLabel) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from LinkLabel) |
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from LinkLabel) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLinkClicked (inherited from LinkLabel) | Raises the LinkClicked event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from LinkLabel) |
OnMouseDown (inherited from LinkLabel) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from LinkLabel) |
OnMouseMove (inherited from LinkLabel) |
OnMouseUp (inherited from LinkLabel) |
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from LinkLabel) |
OnPaintBackground (inherited from LinkLabel) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Label) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextAlignChanged (inherited from LinkLabel) |
OnTextChanged (inherited from LinkLabel) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Label) |
PointInLink (inherited from LinkLabel) | Gets the link located at the specified client coordinates.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from LinkLabel) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Label) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from LinkLabel) | Overloaded.
SetBoundsCore (inherited from LinkLabel) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from LinkLabel) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IButtonControl.NotifyDefault (inherited from LinkLabel)
IButtonControl.PerformClick (inherited from LinkLabel)

See Also

vdxLinkLabel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLinkLabel Constructor

Initializes a new instance of the vdxLinkLabel class.

public vdxLinkLabel();

See Also

vdxLinkLabel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLinkLabel Properties

The properties of the vdxLinkLabel class are listed below. For a complete list of vdxLinkLabel class members, see the vdxLinkLabel Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveLinkColor (inherited from LinkLabel) | Gets or sets the color used to display an active link.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from Label) | Gets or sets a value indicating whether the control is automatically resized to display its entire contents.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Label) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from Label) | Gets or sets the border style for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisabledLinkColor (inherited from LinkLabel) | Gets or sets the color used when displaying a disabled link.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from Label) | Gets or sets the flat style appearance of the label control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from Label) | Gets or sets the image that is displayed on a Label.
ImageAlign (inherited from Label) | Gets or sets the alignment of an image that is displayed in the control.
ImageIndex (inherited from Label) | Gets or sets the index value of the image displayed on the Label.
ImageList (inherited from Label) | Gets or sets the ImageList that contains the images to display in the Label control.
ImeMode (inherited from Label) |
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LinkArea (inherited from LinkLabel) | Gets or sets the range in the text to treat as a link.
LinkBehavior (inherited from LinkLabel) | Gets or sets a value that represents the behavior of a link.
LinkColor (inherited from LinkLabel) | Gets or sets the color used when displaying a normal link.
Links (inherited from LinkLabel) | Gets the collection of links contained within the LinkLabel.
LinkVisited (inherited from LinkLabel) | Gets or sets a value indicating whether a link should be displayed as though it were visited.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from Label) | Gets the preferred height of the control.
PreferredWidth (inherited from Label) | Gets the preferred width of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Label) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from LinkLabel) |
TextAlign (inherited from Label) | Gets or sets the alignment of text in the label.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseMnemonic (inherited from Label) | Gets or sets a value indicating whether the control interprets an ampersand character (&) in the control's Text property to be an access key prefix character.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisitedLinkColor (inherited from LinkLabel) | Gets or sets the color used when displaying a link that that has been previously visited.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Label) |
DefaultImeMode (inherited from Label) | Gets the default Input Method Editor(IME) mode supported by this control.
DefaultSize (inherited from Label) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
OverrideCursor (inherited from LinkLabel) |
RenderRightToLeft (inherited from Control) |
RenderTransparent (inherited from Label) | Indicates whether the container control background is rendered on the Label.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxLinkLabel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLinkLabel.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxLinkLabel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLinkLabel.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxLinkLabel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLinkLabel Methods

The methods of the vdxLinkLabel class are listed below. For a complete list of vdxLinkLabel class members, see the vdxLinkLabel Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Label) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CalcImageRenderBounds (inherited from Label) | Determines the size and location of an image drawn within the Label control based on the alignment of the control.
CreateAccessibilityInstance (inherited from LinkLabel) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from LinkLabel) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Label) | Overloaded.
DrawImage (inherited from Label) | Draws an Image within the specified bounds.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAutoSizeChanged (inherited from Label) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from LinkLabel) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from LinkLabel) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from LinkLabel) |
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from LinkLabel) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLinkClicked (inherited from LinkLabel) | Raises the LinkClicked event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from LinkLabel) |
OnMouseDown (inherited from LinkLabel) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from LinkLabel) |
OnMouseMove (inherited from LinkLabel) |
OnMouseUp (inherited from LinkLabel) |
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from LinkLabel) |
OnPaintBackground (inherited from LinkLabel) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Label) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextAlignChanged (inherited from LinkLabel) |
OnTextChanged (inherited from LinkLabel) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Label) |
PointInLink (inherited from LinkLabel) | Gets the link located at the specified client coordinates.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from LinkLabel) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Label) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from LinkLabel) | Overloaded.
SetBoundsCore (inherited from LinkLabel) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from LinkLabel) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IButtonControl.NotifyDefault (inherited from LinkLabel)
IButtonControl.PerformClick (inherited from LinkLabel)

See Also

vdxLinkLabel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLinkLabel.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxLinkLabel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLinkLabel.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxLinkLabel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListBox Class

Specialized .Net ListBox that implements the IvdxBindable to bind the bindable properties.

For a list of all members of this type, see vdxListBox Members.

System.Object
MarshalByRefObject
Component
Control
ListControl
ListBox
vdxListBox

public class vdxListBox : ListBox, IvdxDsmHost, IvdxBindable

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxListBox Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListBox Members

vdxListBox overview

Public Instance Constructors

vdxListBox Constructor Initializes a new instance of the vdxListBox class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from ListBox) |
BackgroundImage (inherited from ListBox) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from ListBox) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColumnWidth (inherited from ListBox) | Gets or sets the width of columns in a multicolumn ListBox.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataSource (inherited from ListControl) | Gets or sets the data source for this ListControl .
DisplayMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source whose contents you want to display.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DrawMode (inherited from ListBox) | Gets or sets the drawing mode for the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from ListBox) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalExtent (inherited from ListBox) | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll.
HorizontalScrollbar (inherited from ListBox) | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
IntegralHeight (inherited from ListBox) | Gets or sets a value indicating whether the control should resize to avoid showing partial items.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from ListBox) | Gets or sets the height of an item in the ListBox .
Items (inherited from ListBox) | Gets the items of the ListBox .
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MultiColumn (inherited from ListBox) | Gets or sets a value indicating whether the ListBox supports multiple columns.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from ListBox) | Gets the combined height of all items in the ListBox .
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from ListBox) | Gets or sets a value indicating whether text displayed by the control is displayed from right to left.
ScrollAlwaysVisible (inherited from ListBox) | Gets or sets a value indicating whether the vertical scroll bar is shown at all times.
SelectedIndex (inherited from ListBox) | Gets or sets the zero-based index of the currently selected item in a ListBox.
SelectedIndices (inherited from ListBox) | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox.
SelectedItem (inherited from ListBox) | Gets or sets the currently selected item in the ListBox .
SelectedItems (inherited from ListBox) | Gets a collection containing the currently selected items in the ListBox .
SelectedValue (inherited from ListControl) | Gets or sets the value of the member property specified by the ValueMember property.
SelectionMode (inherited from ListBox) | Gets or sets the method in which items are selected in the ListBox .
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from ListBox) | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from ListBox) | Gets or searches for the text of the currently selected item in the ListBox .
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopIndex (inherited from ListBox) | Gets or sets the index of the first visible item in the ListBox .
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseTabStops (inherited from ListBox) | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings.
ValueMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source from which to draw the value.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from ListBox) | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearSelected (inherited from ListBox) | Unselects all items in the ListBox .
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from ListBox) | Resumes painting the ListBox control after painting is suspended by the BeginUpdatemethod.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindString (inherited from ListBox) | Overloaded. Finds the first item in the ListBox that starts with the specified string.
FindStringExact (inherited from ListBox) | Overloaded. Finds the first item in the ListBox that exactly matches the specified string.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetItemHeight (inherited from ListBox) | Returns the height of an item in the ListBox .
GetItemRectangle (inherited from ListBox) | Returns the bounding rectangle for an item in the ListBox .
GetItemText (inherited from ListControl) | Returns the text representation of the specified item.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetSelected (inherited from ListBox) | Returns a value indicating whether the specified item is selected.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
IndexFromPoint (inherited from ListBox) | Overloaded. Returns the zero-based index of the item at the specified coordinates.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from ListBox) |
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetSelected (inherited from ListBox) | Selects or clears the selection for the specified item in a ListBox .
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from ListBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from ListBox) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from ListBox) |
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
DataSourceChanged (inherited from ListControl) | Occurs when the DataSource changes.
DisplayMemberChanged (inherited from ListControl) | Occurs when the DisplayMember property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DrawItem (inherited from ListBox) | Occurs when a visual aspect of an owner-drawn ListBox changes.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MeasureItem (inherited from ListBox) | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from ListBox) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectedIndexChanged (inherited from ListBox) | Occurs when the SelectedIndex property has changed.
SelectedValueChanged (inherited from ListControl) | Occurs when the SelectedValue property changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from ListBox) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueMemberChanged (inherited from ListControl) | Occurs when the ValueMember property changes.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from ListBox) |
DataManager (inherited from ListControl) | Gets the CurrencyManager associated with this control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from ListBox) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AddItemsCore (inherited from ListBox) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateItemCollection (inherited from ListBox) | Creates a new instance of the item collection.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
FilterItemOnProperty (inherited from ListControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from ListControl) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from ListControl) |
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from ListBox) |
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from ListBox) |
OnDisplayMemberChanged (inherited from ListBox) |
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnDrawItem (inherited from ListBox) | Raises the DrawItem event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ListBox) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from ListBox) |
OnHandleDestroyed (inherited from ListBox) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMeasureItem (inherited from ListBox) | Raises the MeasureItem event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ListBox) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from ListBox) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSelectedIndexChanged (inherited from ListBox) |
OnSelectedValueChanged (inherited from ListBox) |
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueMemberChanged (inherited from ListControl) | Raises the ValueMemberChanged event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshItem (inherited from ListBox) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from ListBox) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetItemCore (inherited from ListBox) |
SetItemsCore (inherited from ListBox) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
Sort (inherited from ListBox) | Sorts the items in the ListBox alphabetically.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WmReflectCommand (inherited from ListBox) |
WndProc (inherited from ListBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager

See Also

vdxListBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListBox Constructor

Initializes a new instance of the vdxListBox class.

public vdxListBox();

See Also

vdxListBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListBox Properties

The properties of the vdxListBox class are listed below. For a complete list of vdxListBox class members, see the vdxListBox Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from ListBox) |
BackgroundImage (inherited from ListBox) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from ListBox) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColumnWidth (inherited from ListBox) | Gets or sets the width of columns in a multicolumn ListBox.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataSource (inherited from ListControl) | Gets or sets the data source for this ListControl .
DisplayMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source whose contents you want to display.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DrawMode (inherited from ListBox) | Gets or sets the drawing mode for the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from ListBox) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalExtent (inherited from ListBox) | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll.
HorizontalScrollbar (inherited from ListBox) | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
IntegralHeight (inherited from ListBox) | Gets or sets a value indicating whether the control should resize to avoid showing partial items.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from ListBox) | Gets or sets the height of an item in the ListBox .
Items (inherited from ListBox) | Gets the items of the ListBox .
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MultiColumn (inherited from ListBox) | Gets or sets a value indicating whether the ListBox supports multiple columns.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from ListBox) | Gets the combined height of all items in the ListBox .
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from ListBox) | Gets or sets a value indicating whether text displayed by the control is displayed from right to left.
ScrollAlwaysVisible (inherited from ListBox) | Gets or sets a value indicating whether the vertical scroll bar is shown at all times.
SelectedIndex (inherited from ListBox) | Gets or sets the zero-based index of the currently selected item in a ListBox.
SelectedIndices (inherited from ListBox) | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox.
SelectedItem (inherited from ListBox) | Gets or sets the currently selected item in the ListBox .
SelectedItems (inherited from ListBox) | Gets a collection containing the currently selected items in the ListBox .
SelectedValue (inherited from ListControl) | Gets or sets the value of the member property specified by the ValueMember property.
SelectionMode (inherited from ListBox) | Gets or sets the method in which items are selected in the ListBox .
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from ListBox) | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from ListBox) | Gets or searches for the text of the currently selected item in the ListBox .
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopIndex (inherited from ListBox) | Gets or sets the index of the first visible item in the ListBox .
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseTabStops (inherited from ListBox) | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings.
ValueMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source from which to draw the value.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ListBox) |
DataManager (inherited from ListControl) | Gets the CurrencyManager associated with this control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from ListBox) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager

See Also

vdxListBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListBox.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxListBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListBox.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxListBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListBox.Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager Property

private Deag.Vdx.Controls.Core.vdxDataStatusManager Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager {get; set;}

See Also

vdxListBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListBox Methods

The methods of the vdxListBox class are listed below. For a complete list of vdxListBox class members, see the vdxListBox Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from ListBox) | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearSelected (inherited from ListBox) | Unselects all items in the ListBox .
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from ListBox) | Resumes painting the ListBox control after painting is suspended by the BeginUpdatemethod.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindString (inherited from ListBox) | Overloaded. Finds the first item in the ListBox that starts with the specified string.
FindStringExact (inherited from ListBox) | Overloaded. Finds the first item in the ListBox that exactly matches the specified string.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetItemHeight (inherited from ListBox) | Returns the height of an item in the ListBox .
GetItemRectangle (inherited from ListBox) | Returns the bounding rectangle for an item in the ListBox .
GetItemText (inherited from ListControl) | Returns the text representation of the specified item.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetSelected (inherited from ListBox) | Returns a value indicating whether the specified item is selected.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
IndexFromPoint (inherited from ListBox) | Overloaded. Returns the zero-based index of the item at the specified coordinates.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from ListBox) |
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetSelected (inherited from ListBox) | Selects or clears the selection for the specified item in a ListBox .
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from ListBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AddItemsCore (inherited from ListBox) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateItemCollection (inherited from ListBox) | Creates a new instance of the item collection.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
FilterItemOnProperty (inherited from ListControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from ListControl) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from ListControl) |
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from ListBox) |
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from ListBox) |
OnDisplayMemberChanged (inherited from ListBox) |
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnDrawItem (inherited from ListBox) | Raises the DrawItem event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ListBox) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from ListBox) |
OnHandleDestroyed (inherited from ListBox) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMeasureItem (inherited from ListBox) | Raises the MeasureItem event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ListBox) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from ListBox) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSelectedIndexChanged (inherited from ListBox) |
OnSelectedValueChanged (inherited from ListBox) |
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueMemberChanged (inherited from ListControl) | Raises the ValueMemberChanged event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshItem (inherited from ListBox) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from ListBox) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetItemCore (inherited from ListBox) |
SetItemsCore (inherited from ListBox) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
Sort (inherited from ListBox) | Sorts the items in the ListBox alphabetically.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WmReflectCommand (inherited from ListBox) |
WndProc (inherited from ListBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxListBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListBox.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxListBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListBox.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxListBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNumericUpDown Class

Specialized .Net NumericUpDown that implements the IvdxBindable to bind the bindable properties.

For a list of all members of this type, see vdxNumericUpDown Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UpDownBase
NumericUpDown
vdxNumericUpDown

public class vdxNumericUpDown : NumericUpDown, IvdxBindable

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxNumericUpDown Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNumericUpDown Members

vdxNumericUpDown overview

Public Instance Constructors

vdxNumericUpDown Constructor Initializes a new instance of the vdxNumericUpDown class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from UpDownBase) |
AutoScrollMargin (inherited from UpDownBase) |
AutoScrollMinSize (inherited from UpDownBase) |
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from UpDownBase) |
BackgroundImage (inherited from UpDownBase) |
BindingContext (inherited from ContainerControl) |
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from UpDownBase) | Gets or sets the border style for the up-down control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from UpDownBase) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DecimalPlaces (inherited from NumericUpDown) | Gets or sets the number of decimal places to display in the up-down control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from UpDownBase) |
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from UpDownBase) |
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from UpDownBase) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Hexadecimal (inherited from NumericUpDown) | Gets or sets a value indicating whether the up-down control should display the value it contains in hexadecimal format.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
Increment (inherited from NumericUpDown) | Gets or sets the value to increment or decrement the up-down control when the up or down buttons are clicked.
InterceptArrowKeys (inherited from UpDownBase) | Gets or sets a value indicating whether the user can use the UP ARROW and DOWN ARROW keys to select values.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum (inherited from NumericUpDown) | Gets or sets the maximum value for the up-down control.
Minimum (inherited from NumericUpDown) | Gets or sets the minimum allowed value for the up-down control.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredHeight (inherited from UpDownBase) | Gets the height of the up-down control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from UpDownBase) | Gets or sets a value indicating whether the text can be changed by the use of the up or down buttons only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from NumericUpDown) |
TextAlign (inherited from UpDownBase) | Gets or sets the alignment of the text in the up-down control.
ThousandsSeparator (inherited from NumericUpDown) | Gets or sets a value indicating whether a thousands separator is displayed in the up-down control when appropriate.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UpDownAlign (inherited from UpDownBase) | Gets or sets the alignment of the up and down buttons on the up-down control.
Value (inherited from NumericUpDown) | Gets or sets the value assigned to the up-down control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInit (inherited from NumericUpDown) |
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DownButton (inherited from NumericUpDown) | Decrements the value of the up-down control.
EndInit (inherited from NumericUpDown) |
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from UpDownBase) | Overloaded. Selects a range of text in the up-down control specifying the starting position and number of characters to select.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from NumericUpDown) |
UpButton (inherited from NumericUpDown) | Increments the value of the up-down control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from UpDownBase) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from UpDownBase) |
MouseHover (inherited from UpDownBase) |
MouseLeave (inherited from UpDownBase) |
MouseMove (inherited from UpDownBase) |
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from NumericUpDown) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from NumericUpDown) | Occurs when the Value property has been changed in some way.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

ChangingText (inherited from UpDownBase) | Gets or sets a value indicating whether the text property is being changed internally by its parent class.
CreateParams (inherited from UpDownBase) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UpDownBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
UserEdit (inherited from UpDownBase) | Gets or sets a value indicating whether a value has been entered by the user.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from NumericUpDown) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from UpDownBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChanged (inherited from UpDownBase) |
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from ContainerControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from UpDownBase) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from UpDownBase) |
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from UpDownBase) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from UpDownBase) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextBoxKeyDown (inherited from UpDownBase) | Raises the KeyDown event.
OnTextBoxKeyPress (inherited from NumericUpDown) |
OnTextBoxLostFocus (inherited from UpDownBase) | Raises the LostFocus event.
OnTextBoxResize (inherited from UpDownBase) | Raises the Resize event.
OnTextBoxTextChanged (inherited from UpDownBase) | Raises the TextChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from NumericUpDown) | Raises the ValueChanged event.
OnVisibleChanged (inherited from ScrollableControl) |
ParseEditText (inherited from NumericUpDown) | Converts the text displayed in the up-down control to a numeric value and evaluates it.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from UpDownBase) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateEditText (inherited from NumericUpDown) | Displays the current value of the up-down control in the appropriate format.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValidateEditText (inherited from NumericUpDown) | Validates and updates the text displayed in the up-down control.
WndProc (inherited from UpDownBase) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

vdxNumericUpDown Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNumericUpDown Constructor

Initializes a new instance of the vdxNumericUpDown class.

public vdxNumericUpDown();

See Also

vdxNumericUpDown Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNumericUpDown Properties

The properties of the vdxNumericUpDown class are listed below. For a complete list of vdxNumericUpDown class members, see the vdxNumericUpDown Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from UpDownBase) |
AutoScrollMargin (inherited from UpDownBase) |
AutoScrollMinSize (inherited from UpDownBase) |
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from UpDownBase) |
BackgroundImage (inherited from UpDownBase) |
BindingContext (inherited from ContainerControl) |
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from UpDownBase) | Gets or sets the border style for the up-down control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from UpDownBase) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DecimalPlaces (inherited from NumericUpDown) | Gets or sets the number of decimal places to display in the up-down control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from UpDownBase) |
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from UpDownBase) |
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from UpDownBase) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Hexadecimal (inherited from NumericUpDown) | Gets or sets a value indicating whether the up-down control should display the value it contains in hexadecimal format.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
Increment (inherited from NumericUpDown) | Gets or sets the value to increment or decrement the up-down control when the up or down buttons are clicked.
InterceptArrowKeys (inherited from UpDownBase) | Gets or sets a value indicating whether the user can use the UP ARROW and DOWN ARROW keys to select values.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum (inherited from NumericUpDown) | Gets or sets the maximum value for the up-down control.
Minimum (inherited from NumericUpDown) | Gets or sets the minimum allowed value for the up-down control.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredHeight (inherited from UpDownBase) | Gets the height of the up-down control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from UpDownBase) | Gets or sets a value indicating whether the text can be changed by the use of the up or down buttons only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from NumericUpDown) |
TextAlign (inherited from UpDownBase) | Gets or sets the alignment of the text in the up-down control.
ThousandsSeparator (inherited from NumericUpDown) | Gets or sets a value indicating whether a thousands separator is displayed in the up-down control when appropriate.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UpDownAlign (inherited from UpDownBase) | Gets or sets the alignment of the up and down buttons on the up-down control.
Value (inherited from NumericUpDown) | Gets or sets the value assigned to the up-down control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

ChangingText (inherited from UpDownBase) | Gets or sets a value indicating whether the text property is being changed internally by its parent class.
CreateParams (inherited from UpDownBase) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UpDownBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
UserEdit (inherited from UpDownBase) | Gets or sets a value indicating whether a value has been entered by the user.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

vdxNumericUpDown Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNumericUpDown.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxNumericUpDown Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNumericUpDown.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxNumericUpDown Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNumericUpDown Methods

The methods of the vdxNumericUpDown class are listed below. For a complete list of vdxNumericUpDown class members, see the vdxNumericUpDown Members topic.

Public Instance Methods

BeginInit (inherited from NumericUpDown) |
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DownButton (inherited from NumericUpDown) | Decrements the value of the up-down control.
EndInit (inherited from NumericUpDown) |
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from UpDownBase) | Overloaded. Selects a range of text in the up-down control specifying the starting position and number of characters to select.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from NumericUpDown) |
UpButton (inherited from NumericUpDown) | Increments the value of the up-down control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from NumericUpDown) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from UpDownBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChanged (inherited from UpDownBase) |
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from ContainerControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from UpDownBase) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from UpDownBase) |
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from UpDownBase) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from UpDownBase) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextBoxKeyDown (inherited from UpDownBase) | Raises the KeyDown event.
OnTextBoxKeyPress (inherited from NumericUpDown) |
OnTextBoxLostFocus (inherited from UpDownBase) | Raises the LostFocus event.
OnTextBoxResize (inherited from UpDownBase) | Raises the Resize event.
OnTextBoxTextChanged (inherited from UpDownBase) | Raises the TextChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from NumericUpDown) | Raises the ValueChanged event.
OnVisibleChanged (inherited from ScrollableControl) |
ParseEditText (inherited from NumericUpDown) | Converts the text displayed in the up-down control to a numeric value and evaluates it.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from UpDownBase) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateEditText (inherited from NumericUpDown) | Displays the current value of the up-down control in the appropriate format.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValidateEditText (inherited from NumericUpDown) | Validates and updates the text displayed in the up-down control.
WndProc (inherited from UpDownBase) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

vdxNumericUpDown Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNumericUpDown.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxNumericUpDown Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNumericUpDown.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxNumericUpDown Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPanel Class

Specialized .Net Panel that implements the IvdxBindable to bind the bindable properties.

For a list of all members of this type, see vdxPanel Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
Panel
vdxPanel

public class vdxPanel : Panel, IvdxBindable

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxPanel Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPanel Members

vdxPanel overview

Public Instance Constructors

vdxPanel Overloaded. Initializes a new instance of the vdxPanel class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from Panel) | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Panel) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Panel) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Panel) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Panel) |
KeyPress (inherited from Panel) |
KeyUp (inherited from Panel) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Panel) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Panel) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Panel) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ScrollableControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Panel) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from ScrollableControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxPanel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPanel Constructor

Initializes a new instance of the vdxPanel class.

Overload List

Initializes a new instance of the vdxPanel class.

public vdxPanel();

Initializes a new instance of the vdxPanel class with the specified container.

public vdxPanel(IContainer);

See Also

vdxPanel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPanel Constructor ()

Initializes a new instance of the vdxPanel class.

public vdxPanel();

See Also

vdxPanel Class | Deag.Vdx.Controls.Base Namespace | vdxPanel Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPanel Constructor (IContainer)

Initializes a new instance of the vdxPanel class with the specified container.

public vdxPanel(
IContainer container
);

Parameters

container
The container of the Visual Studio Designer to add this panel.

Remarks

See Also

vdxPanel Class | Deag.Vdx.Controls.Base Namespace | vdxPanel Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPanel Properties

The properties of the vdxPanel class are listed below. For a complete list of vdxPanel class members, see the vdxPanel Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from Panel) | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Panel) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Panel) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Panel) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Panel) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

vdxPanel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPanel.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxPanel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPanel.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxPanel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPanel Methods

The methods of the vdxPanel class are listed below. For a complete list of vdxPanel class members, see the vdxPanel Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Panel) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ScrollableControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Panel) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from ScrollableControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxPanel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPanel.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxPanel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPanel.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxPanel Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRadioButton Class

Specialized .Net RadioButton that implements the IvdxBindable to bind the bindable properties.

For a list of all members of this type, see vdxRadioButton Members.

System.Object
MarshalByRefObject
Component
Control
ButtonBase
RadioButton
vdxRadioButton

public class vdxRadioButton : RadioButton, IvdxBindable

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxRadioButton Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRadioButton Members

vdxRadioButton overview

Public Instance Constructors

vdxRadioButton Constructor Initializes a new instance of the vdxRadioButton class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
Appearance (inherited from RadioButton) | Gets or set the value that determines the appearance of the radio button control.
AutoCheck (inherited from RadioButton) | Gets or sets a value indicating whether the Checked value and the appearance of the control automatically change when the control is clicked.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CheckAlign (inherited from RadioButton) | Gets or sets the location of the check box portion of the radio button control.
Checked (inherited from RadioButton) | Gets or sets a value indicating whether the control is checked.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from RadioButton) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from RadioButton) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformClick (inherited from RadioButton) | Generates a Click event for the button, simulating a click by a user.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from RadioButton) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AppearanceChanged (inherited from RadioButton) | Occurs when the Appearance property value changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
CheckedChanged (inherited from RadioButton) | Occurs when the value of the Checked property changes.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from RadioButton) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from ButtonBase) |
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from RadioButton) |
DefaultImeMode (inherited from ButtonBase) | Gets the default Input Method Editor (IME) mode supported by this control.
DefaultSize (inherited from RadioButton) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
IsDefault (inherited from ButtonBase) | Gets or sets a value indicating whether the button control is the default button.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from RadioButton) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ButtonBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnCheckedChanged (inherited from RadioButton) | Raises the CheckedChanged event.
OnClick (inherited from RadioButton) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from ButtonBase) |
OnEnter (inherited from RadioButton) |
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from ButtonBase) |
OnHandleCreated (inherited from RadioButton) |
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from ButtonBase) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from ButtonBase) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from ButtonBase) |
OnMouseDown (inherited from ButtonBase) |
OnMouseEnter (inherited from ButtonBase) |
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from ButtonBase) |
OnMouseMove (inherited from ButtonBase) |
OnMouseUp (inherited from RadioButton) |
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from ButtonBase) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ButtonBase) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from ButtonBase) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ButtonBase) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from RadioButton) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetFlagsandPaint (inherited from ButtonBase) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from ButtonBase) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxRadioButton Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRadioButton Constructor

Initializes a new instance of the vdxRadioButton class.

public vdxRadioButton();

See Also

vdxRadioButton Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRadioButton Properties

The properties of the vdxRadioButton class are listed below. For a complete list of vdxRadioButton class members, see the vdxRadioButton Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
Appearance (inherited from RadioButton) | Gets or set the value that determines the appearance of the radio button control.
AutoCheck (inherited from RadioButton) | Gets or sets a value indicating whether the Checked value and the appearance of the control automatically change when the control is clicked.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CheckAlign (inherited from RadioButton) | Gets or sets the location of the check box portion of the radio button control.
Checked (inherited from RadioButton) | Gets or sets a value indicating whether the control is checked.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from RadioButton) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from RadioButton) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from RadioButton) |
DefaultImeMode (inherited from ButtonBase) | Gets the default Input Method Editor (IME) mode supported by this control.
DefaultSize (inherited from RadioButton) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
IsDefault (inherited from ButtonBase) | Gets or sets a value indicating whether the button control is the default button.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxRadioButton Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRadioButton.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxRadioButton Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRadioButton.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxRadioButton Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRadioButton Methods

The methods of the vdxRadioButton class are listed below. For a complete list of vdxRadioButton class members, see the vdxRadioButton Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformClick (inherited from RadioButton) | Generates a Click event for the button, simulating a click by a user.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from RadioButton) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from RadioButton) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ButtonBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnCheckedChanged (inherited from RadioButton) | Raises the CheckedChanged event.
OnClick (inherited from RadioButton) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from ButtonBase) |
OnEnter (inherited from RadioButton) |
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from ButtonBase) |
OnHandleCreated (inherited from RadioButton) |
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from ButtonBase) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from ButtonBase) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from ButtonBase) |
OnMouseDown (inherited from ButtonBase) |
OnMouseEnter (inherited from ButtonBase) |
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from ButtonBase) |
OnMouseMove (inherited from ButtonBase) |
OnMouseUp (inherited from RadioButton) |
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from ButtonBase) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ButtonBase) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from ButtonBase) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ButtonBase) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from RadioButton) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetFlagsandPaint (inherited from ButtonBase) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from ButtonBase) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxRadioButton Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRadioButton.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxRadioButton Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRadioButton.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxRadioButton Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRichTextBox Class

Specialized .Net RichTextBox that implements the IvdxBindable to bind the bindable properties.

For a list of all members of this type, see vdxRichTextBox Members.

System.Object
MarshalByRefObject
Component
Control
TextBoxBase
RichTextBox
vdxRichTextBox

public class vdxRichTextBox : RichTextBox, IvdxInputControl, IvdxDsmHost, IvdxResettable, IvdxBindingManagable, IvdxBindable

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxRichTextBox Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRichTextBox Members

vdxRichTextBox overview

Public Instance Constructors

vdxRichTextBox Constructor Initializes a new instance of the vdxRichTextBox class.

Public Instance Properties

AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from RichTextBox) | Gets or sets a value indicating whether the control will allow drag-and-drop operations.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from RichTextBox) | Gets or sets a value indicating whether the size of the RichTextBox automatically adjusts when the font assigned to the control is changed.
AutoWordSelection (inherited from RichTextBox) | Gets or sets a value indicating whether automatic word selection is enabled.
BackColor (inherited from TextBoxBase) | Gets or sets the background color of the control.
BackgroundImage (inherited from RichTextBox) |
BindEmptyValuesAsNull | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
BulletIndent (inherited from RichTextBox) | Gets or sets the indentation used in the RichTextBox control when the bullet style is applied to the text.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanRedo (inherited from RichTextBox) | Gets a value indicating whether there are actions that have occurred within the RichTextBox that can be reapplied.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DetectUrls (inherited from RichTextBox) | Gets or sets a value indicating whether or not the RichTextBox will automatically format a Uniform Resource Locator (URL) when it is typed into the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from RichTextBox) |
ForeColor (inherited from RichTextBox) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM | Gets/sets a value indicating whether the TextBox interacts with the DSM. If set to true then the TextBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Lines (inherited from TextBoxBase) | Gets or sets the lines of text in a text box control.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxLength (inherited from RichTextBox) | Gets or sets the maximum number of characters the user can type or paste into the rich text box control.
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
Multiline (inherited from RichTextBox) |
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
RedoActionName (inherited from RichTextBox) | Gets the name of the action that can be reapplied to the control when the Redo method is called.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightMargin (inherited from RichTextBox) | Gets or sets the size of a single line of text within the RichTextBox control.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Rtf (inherited from RichTextBox) | Gets or sets the text of the RichTextBox control, including all Rich Text Format (RTF) codes.
ScrollBars (inherited from RichTextBox) | Gets or sets the type of scroll bars to display in the RichTextBox control.
SelectedRtf (inherited from RichTextBox) | Gets or sets the currently selected Rich Text Format (RTF) formatted text in the control.
SelectedText (inherited from RichTextBox) | Gets or sets the selected text within the RichTextBox .
SelectionAlignment (inherited from RichTextBox) | Gets or sets the alignment to apply to the current selection or insertion point.
SelectionBullet (inherited from RichTextBox) | Gets or sets a value indicating whether the bullet style is applied to the current selection or insertion point.
SelectionCharOffset (inherited from RichTextBox) | Gets or sets whether text in the control appears on the baseline, as a superscript, or as a subscript below the baseline.
SelectionColor (inherited from RichTextBox) | Gets or sets the text color of the current text selection or insertion point.
SelectionFont (inherited from RichTextBox) | Gets or sets the font of the current text selection or insertion point.
SelectionHangingIndent (inherited from RichTextBox) | Gets or sets the distance between the left edge of the first line of text in the selected paragraph and the left edge of subsequent lines in the same paragraph.
SelectionIndent (inherited from RichTextBox) | Gets or sets the distance in pixels between the left edge of the RichTextBox and the left edge of the current text selection or text added after the insertion point.
SelectionLength (inherited from RichTextBox) | Gets or sets the number of characters selected in control.
SelectionProtected (inherited from RichTextBox) | Gets or sets a value indicating whether the current text selection is protected.
SelectionRightIndent (inherited from RichTextBox) | The distance (in pixels) between the right edge of the RichTextBox control and the right edge of the text that is selected or added at the current insertion point.
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
SelectionTabs (inherited from RichTextBox) | Gets or sets the absolute tab stop positions in a RichTextBox control.
SelectionType (inherited from RichTextBox) | Gets the selection type within the control.
ShowSelectionMargin (inherited from RichTextBox) | Gets or sets a value indicating whether a selection margin is displayed in the RichTextBox .
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from RichTextBox) | Gets or sets the current text in the rich text box.
TextLength (inherited from RichTextBox) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UndoActionName (inherited from RichTextBox) | Gets the name of the action that can be undone in the control when the Undo method is called.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
WordWrap (inherited from TextBoxBase) | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.
ZoomFactor (inherited from RichTextBox) | Gets or sets the current zoom level of the RichTextBox .

Public Instance Methods

AppendText (inherited from TextBoxBase) | Appends text to the current text of text box.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
CanPaste (inherited from RichTextBox) | Determines whether you can paste information from the Clipboard in the specified data format.
Clear (inherited from TextBoxBase) | Clears all text from the text box control.
ClearUndo (inherited from TextBoxBase) | Clears information about the most recent operation from the undo buffer of the text box.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
Copy (inherited from TextBoxBase) | Copies the current selection in the text box to the Clipboard.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Cut (inherited from TextBoxBase) | Moves the current selection in the text box to the Clipboard.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Find (inherited from RichTextBox) | Overloaded. Searches the text in a RichTextBox control for a string.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetCharFromPosition (inherited from RichTextBox) | Gets the character that is closest to the specified location within the control.
GetCharIndexFromPosition (inherited from RichTextBox) | Gets the index of the character nearest to the specified location.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetLineFromCharIndex (inherited from RichTextBox) | Gets the line number from the specified character position within the text of the RichTextBox control.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPositionFromCharIndex (inherited from RichTextBox) | Gets the location within the control at the specified character index.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LoadFile (inherited from RichTextBox) | Overloaded. Loads a Rich Text Format (RTF) or standard ASCII text file into the RichTextBox control.
Paste (inherited from RichTextBox) | Overloaded. Pastes the contents of the Clipboard in the specified Clipboard format.
Paste (inherited from TextBoxBase) | Overloaded. Replaces the current selection in the text box with the contents of the Clipboard.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Redo (inherited from RichTextBox) | Reapplies the last operation that was undone in the control.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
SaveFile (inherited from RichTextBox) | Overloaded. Saves the contents of the RichTextBox to a Rich Text Format (RTF) file.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollToCaret (inherited from TextBoxBase) | Scrolls the contents of the control to the current caret position.
Select (inherited from TextBoxBase) | Overloaded. Selects a range of text in the text box.
Select (inherited from Control) | Overloaded. Activates the control.
SelectAll (inherited from TextBoxBase) | Selects all text in the text box.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TextBoxBase) |
Undo (inherited from TextBoxBase) | Undoes the last edit operation in the text box.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AcceptsTabChanged (inherited from TextBoxBase) | Occurs when the value of the AcceptsTab property has changed.
AutoSizeChanged (inherited from TextBoxBase) | Occurs when the value of the AutoSize property has changed.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from RichTextBox) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
BorderStyleChanged (inherited from TextBoxBase) | Occurs when the value of the BorderStyle property has changed.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from TextBoxBase) | Occurs when the text box is clicked.
ContentsResized (inherited from RichTextBox) | Occurs when contents within the control are resized.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from RichTextBox) |
DragDrop (inherited from RichTextBox) |
DragEnter (inherited from RichTextBox) |
DragLeave (inherited from RichTextBox) |
DragOver (inherited from RichTextBox) |
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from RichTextBox) |
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
HideSelectionChanged (inherited from TextBoxBase) | Occurs when the value of the HideSelection property has changed.
HScroll (inherited from RichTextBox) | Occurs when the user clicks the horizontal scroll bar of the control.
ImeChange (inherited from RichTextBox) | Occurs when the user switches input methods on an Asian version of the Windows operating system.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LinkClicked (inherited from RichTextBox) | Occurs when the user clicks on a link within the text of the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
ModifiedChanged (inherited from TextBoxBase) | Occurs when the value of the Modified property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
MultilineChanged (inherited from TextBoxBase) | Occurs when the value of the Multiline property has changed.
Paint (inherited from TextBoxBase) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
Protected (inherited from RichTextBox) | Occurs when the user attempts to modify protected text in the control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from RichTextBox) |
ReadOnlyChanged (inherited from TextBoxBase) | Occurs when the value of the ReadOnly property has changed.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectionChanged (inherited from RichTextBox) | Occurs when the selection of text within the control has changed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.
VScroll (inherited from RichTextBox) | Occurs when the user clicks the vertical scroll bars of the control.

Protected Instance Properties

CreateParams (inherited from RichTextBox) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from RichTextBox) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from TextBoxBase) |
CreateRichEditOleCallback (inherited from RichTextBox) | Creates an IRichEditOleCallback compatible object for handling RichEdit callback operations.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from TextBoxBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAcceptsTabChanged (inherited from TextBoxBase) | Raises the AcceptsTabChanged event.
OnAutoSizeChanged (inherited from TextBoxBase) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from RichTextBox) |
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnBorderStyleChanged (inherited from TextBoxBase) | Raises the BorderStyleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContentsResized (inherited from RichTextBox) | Raises the ContentsResized event.
OnContextMenuChanged (inherited from RichTextBox) |
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from TextBoxBase) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from RichTextBox) |
OnHandleDestroyed (inherited from RichTextBox) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHideSelectionChanged (inherited from TextBoxBase) | Raise the HideSelectionChanged event.
OnHScroll (inherited from RichTextBox) | Raises the HScroll event.
OnImeChange (inherited from RichTextBox) | Raises the ImeChange event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown |
OnKeyPress | Raises the KeyPress event
OnKeyUp |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLinkClicked (inherited from RichTextBox) | Raises the LinkClicked event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnModifiedChanged (inherited from TextBoxBase) | Raises the ModifiedChanged event.
OnMouseDown |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp |
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnMultilineChanged (inherited from TextBoxBase) | Raises the MultilineChanged event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnProtected (inherited from RichTextBox) | Raises the Protected event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from TextBoxBase) | Raises the ReadOnlyChanged event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from RichTextBox) |
OnSelectionChanged (inherited from RichTextBox) | Raises the SelectionChanged event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from RichTextBox) |
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from RichTextBox) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
OnVScroll (inherited from RichTextBox) | Raises the VScroll event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from TextBoxBase) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from TextBoxBase) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from RichTextBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager

Explicit Interface Implementations

IvdxInputControl.InitializeBinding | Do any initializing work like converting format.
IvdxResettable.Reset | Resets the value of the text box

See Also

vdxRichTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRichTextBox Constructor

Initializes a new instance of the vdxRichTextBox class.

public vdxRichTextBox();

See Also

vdxRichTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRichTextBox Properties

The properties of the vdxRichTextBox class are listed below. For a complete list of vdxRichTextBox class members, see the vdxRichTextBox Members topic.

Public Instance Properties

AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from RichTextBox) | Gets or sets a value indicating whether the control will allow drag-and-drop operations.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from RichTextBox) | Gets or sets a value indicating whether the size of the RichTextBox automatically adjusts when the font assigned to the control is changed.
AutoWordSelection (inherited from RichTextBox) | Gets or sets a value indicating whether automatic word selection is enabled.
BackColor (inherited from TextBoxBase) | Gets or sets the background color of the control.
BackgroundImage (inherited from RichTextBox) |
BindEmptyValuesAsNull | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
BulletIndent (inherited from RichTextBox) | Gets or sets the indentation used in the RichTextBox control when the bullet style is applied to the text.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanRedo (inherited from RichTextBox) | Gets a value indicating whether there are actions that have occurred within the RichTextBox that can be reapplied.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DetectUrls (inherited from RichTextBox) | Gets or sets a value indicating whether or not the RichTextBox will automatically format a Uniform Resource Locator (URL) when it is typed into the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from RichTextBox) |
ForeColor (inherited from RichTextBox) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM | Gets/sets a value indicating whether the TextBox interacts with the DSM. If set to true then the TextBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Lines (inherited from TextBoxBase) | Gets or sets the lines of text in a text box control.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxLength (inherited from RichTextBox) | Gets or sets the maximum number of characters the user can type or paste into the rich text box control.
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
Multiline (inherited from RichTextBox) |
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
RedoActionName (inherited from RichTextBox) | Gets the name of the action that can be reapplied to the control when the Redo method is called.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightMargin (inherited from RichTextBox) | Gets or sets the size of a single line of text within the RichTextBox control.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Rtf (inherited from RichTextBox) | Gets or sets the text of the RichTextBox control, including all Rich Text Format (RTF) codes.
ScrollBars (inherited from RichTextBox) | Gets or sets the type of scroll bars to display in the RichTextBox control.
SelectedRtf (inherited from RichTextBox) | Gets or sets the currently selected Rich Text Format (RTF) formatted text in the control.
SelectedText (inherited from RichTextBox) | Gets or sets the selected text within the RichTextBox .
SelectionAlignment (inherited from RichTextBox) | Gets or sets the alignment to apply to the current selection or insertion point.
SelectionBullet (inherited from RichTextBox) | Gets or sets a value indicating whether the bullet style is applied to the current selection or insertion point.
SelectionCharOffset (inherited from RichTextBox) | Gets or sets whether text in the control appears on the baseline, as a superscript, or as a subscript below the baseline.
SelectionColor (inherited from RichTextBox) | Gets or sets the text color of the current text selection or insertion point.
SelectionFont (inherited from RichTextBox) | Gets or sets the font of the current text selection or insertion point.
SelectionHangingIndent (inherited from RichTextBox) | Gets or sets the distance between the left edge of the first line of text in the selected paragraph and the left edge of subsequent lines in the same paragraph.
SelectionIndent (inherited from RichTextBox) | Gets or sets the distance in pixels between the left edge of the RichTextBox and the left edge of the current text selection or text added after the insertion point.
SelectionLength (inherited from RichTextBox) | Gets or sets the number of characters selected in control.
SelectionProtected (inherited from RichTextBox) | Gets or sets a value indicating whether the current text selection is protected.
SelectionRightIndent (inherited from RichTextBox) | The distance (in pixels) between the right edge of the RichTextBox control and the right edge of the text that is selected or added at the current insertion point.
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
SelectionTabs (inherited from RichTextBox) | Gets or sets the absolute tab stop positions in a RichTextBox control.
SelectionType (inherited from RichTextBox) | Gets the selection type within the control.
ShowSelectionMargin (inherited from RichTextBox) | Gets or sets a value indicating whether a selection margin is displayed in the RichTextBox .
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from RichTextBox) | Gets or sets the current text in the rich text box.
TextLength (inherited from RichTextBox) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UndoActionName (inherited from RichTextBox) | Gets the name of the action that can be undone in the control when the Undo method is called.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
WordWrap (inherited from TextBoxBase) | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.
ZoomFactor (inherited from RichTextBox) | Gets or sets the current zoom level of the RichTextBox .

Protected Instance Properties

CreateParams (inherited from RichTextBox) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from RichTextBox) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager

See Also

vdxRichTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRichTextBox.BindEmptyValuesAsNull Property

Gets or sets whether the empty values must be binded as null.

public bool BindEmptyValuesAsNull {get; set;}

Implements

IvdxInputControl.BindEmptyValuesAsNull

See Also

vdxRichTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRichTextBox.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxRichTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRichTextBox.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxRichTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRichTextBox.Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager Property

private Deag.Vdx.Controls.Core.vdxDataStatusManager Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager {get; set;}

See Also

vdxRichTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRichTextBox.InteractWithDSM Property

Gets/sets a value indicating whether the TextBox interacts with the DSM. If set to true then the TextBox will not force an AutoEdit on the DSM. Default value = true;

public bool InteractWithDSM {get; set;}

Implements

IvdxInputControl.InteractWithDSM

See Also

vdxRichTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRichTextBox Methods

The methods of the vdxRichTextBox class are listed below. For a complete list of vdxRichTextBox class members, see the vdxRichTextBox Members topic.

Public Instance Methods

AppendText (inherited from TextBoxBase) | Appends text to the current text of text box.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
CanPaste (inherited from RichTextBox) | Determines whether you can paste information from the Clipboard in the specified data format.
Clear (inherited from TextBoxBase) | Clears all text from the text box control.
ClearUndo (inherited from TextBoxBase) | Clears information about the most recent operation from the undo buffer of the text box.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
Copy (inherited from TextBoxBase) | Copies the current selection in the text box to the Clipboard.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Cut (inherited from TextBoxBase) | Moves the current selection in the text box to the Clipboard.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Find (inherited from RichTextBox) | Overloaded. Searches the text in a RichTextBox control for a string.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetCharFromPosition (inherited from RichTextBox) | Gets the character that is closest to the specified location within the control.
GetCharIndexFromPosition (inherited from RichTextBox) | Gets the index of the character nearest to the specified location.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetLineFromCharIndex (inherited from RichTextBox) | Gets the line number from the specified character position within the text of the RichTextBox control.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPositionFromCharIndex (inherited from RichTextBox) | Gets the location within the control at the specified character index.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LoadFile (inherited from RichTextBox) | Overloaded. Loads a Rich Text Format (RTF) or standard ASCII text file into the RichTextBox control.
Paste (inherited from RichTextBox) | Overloaded. Pastes the contents of the Clipboard in the specified Clipboard format.
Paste (inherited from TextBoxBase) | Overloaded. Replaces the current selection in the text box with the contents of the Clipboard.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Redo (inherited from RichTextBox) | Reapplies the last operation that was undone in the control.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
SaveFile (inherited from RichTextBox) | Overloaded. Saves the contents of the RichTextBox to a Rich Text Format (RTF) file.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollToCaret (inherited from TextBoxBase) | Scrolls the contents of the control to the current caret position.
Select (inherited from TextBoxBase) | Overloaded. Selects a range of text in the text box.
Select (inherited from Control) | Overloaded. Activates the control.
SelectAll (inherited from TextBoxBase) | Selects all text in the text box.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TextBoxBase) |
Undo (inherited from TextBoxBase) | Undoes the last edit operation in the text box.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from TextBoxBase) |
CreateRichEditOleCallback (inherited from RichTextBox) | Creates an IRichEditOleCallback compatible object for handling RichEdit callback operations.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from TextBoxBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAcceptsTabChanged (inherited from TextBoxBase) | Raises the AcceptsTabChanged event.
OnAutoSizeChanged (inherited from TextBoxBase) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from RichTextBox) |
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnBorderStyleChanged (inherited from TextBoxBase) | Raises the BorderStyleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContentsResized (inherited from RichTextBox) | Raises the ContentsResized event.
OnContextMenuChanged (inherited from RichTextBox) |
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from TextBoxBase) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from RichTextBox) |
OnHandleDestroyed (inherited from RichTextBox) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHideSelectionChanged (inherited from TextBoxBase) | Raise the HideSelectionChanged event.
OnHScroll (inherited from RichTextBox) | Raises the HScroll event.
OnImeChange (inherited from RichTextBox) | Raises the ImeChange event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown |
OnKeyPress | Raises the KeyPress event
OnKeyUp |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLinkClicked (inherited from RichTextBox) | Raises the LinkClicked event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnModifiedChanged (inherited from TextBoxBase) | Raises the ModifiedChanged event.
OnMouseDown |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp |
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnMultilineChanged (inherited from TextBoxBase) | Raises the MultilineChanged event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnProtected (inherited from RichTextBox) | Raises the Protected event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from TextBoxBase) | Raises the ReadOnlyChanged event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from RichTextBox) |
OnSelectionChanged (inherited from RichTextBox) | Raises the SelectionChanged event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from RichTextBox) |
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from RichTextBox) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
OnVScroll (inherited from RichTextBox) | Raises the VScroll event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from TextBoxBase) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from TextBoxBase) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from RichTextBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IvdxInputControl.InitializeBinding | Do any initializing work like converting format.
IvdxResettable.Reset | Resets the value of the text box

See Also

vdxRichTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRichTextBox.IvdxInputControl.InitializeBinding Method

Do any initializing work like converting format.

void IvdxInputControl.InitializeBinding(
Binding binding
);

Implements

IvdxInputControl.InitializeBinding

See Also

vdxRichTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRichTextBox.IvdxResettable.Reset Method

Resets the value of the text box

void IvdxResettable.Reset();

Implements

IvdxResettable.Reset

See Also

vdxRichTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRichTextBox.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxRichTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRichTextBox.OnKeyDown Method

protected override void OnKeyDown(
KeyEventArgs e
);

Parameters

e

See Also

vdxRichTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRichTextBox.OnKeyPress Method

Raises the KeyPress event

protected override void OnKeyPress(
KeyPressEventArgs e
);

Parameters

e
A KeyPressEventArgs that contains the event data

See Also

vdxRichTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRichTextBox.OnKeyUp Method

protected override void OnKeyUp(
KeyEventArgs e
);

Parameters

e

See Also

vdxRichTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRichTextBox.OnMouseDown Method

protected override void OnMouseDown(
MouseEventArgs e
);

Parameters

e

See Also

vdxRichTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRichTextBox.OnMouseUp Method

protected override void OnMouseUp(
MouseEventArgs e
);

Parameters

e

See Also

vdxRichTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxRichTextBox.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxRichTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTabControl Class

Specialized .Net TabControl that implements the IvdxBindable to bind the bindable properties.

For a list of all members of this type, see vdxTabControl Members.

System.Object
MarshalByRefObject
Component
Control
TabControl
vdxTabControl

public class vdxTabControl : TabControl, IvdxBindable

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxTabControl Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTabControl Members

vdxTabControl overview

Public Instance Constructors

vdxTabControl Overloaded. Initializes a new instance of the vdxTabControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
Alignment (inherited from TabControl) | Gets or sets the area of the control (for example, along the top) where the tabs are aligned.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
Appearance (inherited from TabControl) | Gets or sets the visual appearance of the control's tabs.
BackColor (inherited from TabControl) |
BackgroundImage (inherited from TabControl) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from TabControl) | Gets the display area of the control's tab pages.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DrawMode (inherited from TabControl) | Gets or sets the way that the control's tab pages are drawn.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TabControl) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HotTrack (inherited from TabControl) | Gets or sets a value indicating whether the control's tabs change in appearance when the mouse passes over them.
ImageList (inherited from TabControl) | Gets or sets the images to display on the control's tabs.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemSize (inherited from TabControl) | Gets or sets the size of the control's tabs.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Multiline (inherited from TabControl) | Gets or sets a value indicating whether more than one row of tabs can be displayed.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from TabControl) | Gets or sets the amount of space around each item on the control's tab pages.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RowCount (inherited from TabControl) | Gets the number of rows that are currently being displayed in the control's tab strip.
SelectedIndex (inherited from TabControl) | Gets or sets the index of the currently-selected tab page.
SelectedTab (inherited from TabControl) | Gets or sets the currently-selected tab page.
ShowToolTips (inherited from TabControl) | Gets or sets a value indicating whether a tab's ToolTip is shown when the mouse passes over the tab.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeMode (inherited from TabControl) | Gets or sets the way that the control's tabs are sized.
TabCount (inherited from TabControl) | Gets the number of tabs in the tab strip.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabPages (inherited from TabControl) | Gets the collection of tab pages in this tab control.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from TabControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetControl (inherited from TabControl) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetTabRect (inherited from TabControl) | Returns the bounding rectangle for a specified tab in this tab control.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TabControl) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from TabControl) |
BackgroundImageChanged (inherited from TabControl) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DrawItem (inherited from TabControl) | Occurs when the tabs are drawn, if the DrawMode property is set to OwnerDrawFixed.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from TabControl) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from TabControl) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectedIndexChanged (inherited from TabControl) | Occurs when the SelectedIndex property is changed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from TabControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from TabControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from TabControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from TabControl) |
CreateHandle (inherited from TabControl) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from TabControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetItems (inherited from TabControl) | Overloaded.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetToolTipText (inherited from TabControl) |
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from TabControl) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnDrawItem (inherited from TabControl) | Raises the DrawItem event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from TabControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from TabControl) |
OnHandleDestroyed (inherited from TabControl) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from TabControl) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from TabControl) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSelectedIndexChanged (inherited from TabControl) | Raises the SelectedIndexChanged event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from TabControl) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from TabControl) |
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RemoveAll (inherited from TabControl) | Removes all the tab pages and additional controls from this tab control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateTabSelection (inherited from TabControl) |
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from TabControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxTabControl Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTabControl Constructor

Initializes a new instance of the vdxTabControl class.

Overload List

Initializes a new instance of the vdxTabControl class.

public vdxTabControl();

Initializes a new instance of the vdxTabControl class with the specified container.

public vdxTabControl(IContainer);

See Also

vdxTabControl Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTabControl Constructor ()

Initializes a new instance of the vdxTabControl class.

public vdxTabControl();

See Also

vdxTabControl Class | Deag.Vdx.Controls.Base Namespace | vdxTabControl Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTabControl Constructor (IContainer)

Initializes a new instance of the vdxTabControl class with the specified container.

public vdxTabControl(
IContainer container
);

Parameters

container
The container of the Visual Studio Designer to add this panel.

Remarks

See Also

vdxTabControl Class | Deag.Vdx.Controls.Base Namespace | vdxTabControl Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTabControl Properties

The properties of the vdxTabControl class are listed below. For a complete list of vdxTabControl class members, see the vdxTabControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
Alignment (inherited from TabControl) | Gets or sets the area of the control (for example, along the top) where the tabs are aligned.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
Appearance (inherited from TabControl) | Gets or sets the visual appearance of the control's tabs.
BackColor (inherited from TabControl) |
BackgroundImage (inherited from TabControl) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from TabControl) | Gets the display area of the control's tab pages.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DrawMode (inherited from TabControl) | Gets or sets the way that the control's tab pages are drawn.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TabControl) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HotTrack (inherited from TabControl) | Gets or sets a value indicating whether the control's tabs change in appearance when the mouse passes over them.
ImageList (inherited from TabControl) | Gets or sets the images to display on the control's tabs.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemSize (inherited from TabControl) | Gets or sets the size of the control's tabs.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Multiline (inherited from TabControl) | Gets or sets a value indicating whether more than one row of tabs can be displayed.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from TabControl) | Gets or sets the amount of space around each item on the control's tab pages.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RowCount (inherited from TabControl) | Gets the number of rows that are currently being displayed in the control's tab strip.
SelectedIndex (inherited from TabControl) | Gets or sets the index of the currently-selected tab page.
SelectedTab (inherited from TabControl) | Gets or sets the currently-selected tab page.
ShowToolTips (inherited from TabControl) | Gets or sets a value indicating whether a tab's ToolTip is shown when the mouse passes over the tab.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeMode (inherited from TabControl) | Gets or sets the way that the control's tabs are sized.
TabCount (inherited from TabControl) | Gets the number of tabs in the tab strip.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabPages (inherited from TabControl) | Gets the collection of tab pages in this tab control.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from TabControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from TabControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from TabControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxTabControl Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTabControl.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxTabControl Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTabControl.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxTabControl Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTabControl Methods

The methods of the vdxTabControl class are listed below. For a complete list of vdxTabControl class members, see the vdxTabControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetControl (inherited from TabControl) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetTabRect (inherited from TabControl) | Returns the bounding rectangle for a specified tab in this tab control.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TabControl) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from TabControl) |
CreateHandle (inherited from TabControl) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from TabControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetItems (inherited from TabControl) | Overloaded.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetToolTipText (inherited from TabControl) |
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from TabControl) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnDrawItem (inherited from TabControl) | Raises the DrawItem event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from TabControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from TabControl) |
OnHandleDestroyed (inherited from TabControl) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from TabControl) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from TabControl) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSelectedIndexChanged (inherited from TabControl) | Raises the SelectedIndexChanged event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from TabControl) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from TabControl) |
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RemoveAll (inherited from TabControl) | Removes all the tab pages and additional controls from this tab control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateTabSelection (inherited from TabControl) |
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from TabControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxTabControl Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTabControl.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxTabControl Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTabControl.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxTabControl Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox Class

Specialized .Net TextBox that implements the IvdxBindable to bind the bindable properties.

For a list of all members of this type, see vdxTextBox Members.

System.Object
MarshalByRefObject
Component
Control
TextBoxBase
TextBox
vdxTextBox

public class vdxTextBox : TextBox, IvdxInputControl, IvdxDsmHost, IvdxResettable, IvdxBindingManagable, IvdxBindable

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxTextBox Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox Members

vdxTextBox overview

Public Instance Constructors

vdxTextBox Constructor Initializes a new instance of the vdxTextBox class.

Public Instance Properties

AcceptsReturn (inherited from TextBox) | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.
AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from TextBoxBase) | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
BackColor (inherited from TextBoxBase) | Gets or sets the background color of the control.
BackgroundImage (inherited from TextBoxBase) |
BindEmptyValuesAsNull | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CharacterCasing (inherited from TextBox) | Gets or sets whether the TextBox control modifies the case of characters as they are typed.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TextBoxBase) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM | Gets/sets a value indicating whether the TextBox interacts with the DSM. If set to true then the TextBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Lines (inherited from TextBoxBase) | Gets or sets the lines of text in a text box control.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxLength (inherited from TextBoxBase) | Gets or sets the maximum number of characters the user can type or paste into the text box control.
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
Multiline (inherited from TextBoxBase) | Gets or sets a value indicating whether this is a multiline text box control.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PasswordChar (inherited from TextBox) | Gets or sets the character used to mask characters of a password in a single-line TextBox control.
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScrollBars (inherited from TextBox) | Gets or sets which scroll bars should appear in a multiline TextBox control.
SelectedText (inherited from TextBoxBase) | Gets or sets a value indicating the currently selected text in the control.
SelectionLength (inherited from TextBox) |
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from TextBox) |
TextAlign (inherited from TextBox) | Gets or sets how text is aligned in a TextBox control.
TextIsNull | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
TextLength (inherited from TextBoxBase) | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
WordWrap (inherited from TextBoxBase) | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.

Public Instance Methods

AppendText (inherited from TextBoxBase) | Appends text to the current text of text box.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear (inherited from TextBoxBase) | Clears all text from the text box control.
ClearUndo (inherited from TextBoxBase) | Clears information about the most recent operation from the undo buffer of the text box.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
Copy (inherited from TextBoxBase) | Copies the current selection in the text box to the Clipboard.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Cut (inherited from TextBoxBase) | Moves the current selection in the text box to the Clipboard.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
Paste (inherited from TextBoxBase) | Replaces the current selection in the text box with the contents of the Clipboard.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollToCaret (inherited from TextBoxBase) | Scrolls the contents of the control to the current caret position.
Select (inherited from TextBoxBase) | Overloaded. Selects a range of text in the text box.
Select (inherited from Control) | Overloaded. Activates the control.
SelectAll (inherited from TextBoxBase) | Selects all text in the text box.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TextBoxBase) |
Undo (inherited from TextBoxBase) | Undoes the last edit operation in the text box.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AcceptsTabChanged (inherited from TextBoxBase) | Occurs when the value of the AcceptsTab property has changed.
AutoSizeChanged (inherited from TextBoxBase) | Occurs when the value of the AutoSize property has changed.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from TextBoxBase) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
BorderStyleChanged (inherited from TextBoxBase) | Occurs when the value of the BorderStyle property has changed.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from TextBoxBase) | Occurs when the text box is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
HideSelectionChanged (inherited from TextBoxBase) | Occurs when the value of the HideSelection property has changed.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
ModifiedChanged (inherited from TextBoxBase) | Occurs when the value of the Modified property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
MultilineChanged (inherited from TextBoxBase) | Occurs when the value of the Multiline property has changed.
Paint (inherited from TextBoxBase) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
ReadOnlyChanged (inherited from TextBoxBase) | Occurs when the value of the ReadOnly property has changed.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextAlignChanged (inherited from TextBox) | Occurs when the value of the TextAlign property has changed.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from TextBox) |
DefaultImeMode (inherited from TextBox) |
DefaultSize (inherited from TextBoxBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from TextBoxBase) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from TextBox) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAcceptsTabChanged (inherited from TextBoxBase) | Raises the AcceptsTabChanged event.
OnAutoSizeChanged (inherited from TextBoxBase) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnBorderStyleChanged (inherited from TextBoxBase) | Raises the BorderStyleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from TextBoxBase) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from TextBox) |
OnHandleCreated (inherited from TextBox) |
OnHandleDestroyed (inherited from TextBoxBase) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHideSelectionChanged (inherited from TextBoxBase) | Raise the HideSelectionChanged event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown | Raises the OnKeyDown event.
OnKeyPress | Raises the OnKeyPress event.
OnKeyUp | Raises the OnKeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnModifiedChanged (inherited from TextBoxBase) | Raises the ModifiedChanged event.
OnMouseDown | Raises the OnMouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp | Raises the OnMouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnMultilineChanged (inherited from TextBoxBase) | Raises the MultilineChanged event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from TextBoxBase) | Raises the ReadOnlyChanged event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextAlignChanged (inherited from TextBox) | Raises the TextAlignChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from TextBoxBase) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from TextBoxBase) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from TextBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager

Explicit Interface Implementations

IvdxInputControl.InitializeBinding | Do any initializing work like converting format.
IvdxResettable.Reset | Resets the value of the text box

See Also

vdxTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox Constructor

Initializes a new instance of the vdxTextBox class.

public vdxTextBox();

See Also

vdxTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox Properties

The properties of the vdxTextBox class are listed below. For a complete list of vdxTextBox class members, see the vdxTextBox Members topic.

Public Instance Properties

AcceptsReturn (inherited from TextBox) | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.
AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from TextBoxBase) | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
BackColor (inherited from TextBoxBase) | Gets or sets the background color of the control.
BackgroundImage (inherited from TextBoxBase) |
BindEmptyValuesAsNull | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CharacterCasing (inherited from TextBox) | Gets or sets whether the TextBox control modifies the case of characters as they are typed.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TextBoxBase) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM | Gets/sets a value indicating whether the TextBox interacts with the DSM. If set to true then the TextBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Lines (inherited from TextBoxBase) | Gets or sets the lines of text in a text box control.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxLength (inherited from TextBoxBase) | Gets or sets the maximum number of characters the user can type or paste into the text box control.
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
Multiline (inherited from TextBoxBase) | Gets or sets a value indicating whether this is a multiline text box control.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PasswordChar (inherited from TextBox) | Gets or sets the character used to mask characters of a password in a single-line TextBox control.
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScrollBars (inherited from TextBox) | Gets or sets which scroll bars should appear in a multiline TextBox control.
SelectedText (inherited from TextBoxBase) | Gets or sets a value indicating the currently selected text in the control.
SelectionLength (inherited from TextBox) |
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from TextBox) |
TextAlign (inherited from TextBox) | Gets or sets how text is aligned in a TextBox control.
TextIsNull | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
TextLength (inherited from TextBoxBase) | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
WordWrap (inherited from TextBoxBase) | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.

Protected Instance Properties

CreateParams (inherited from TextBox) |
DefaultImeMode (inherited from TextBox) |
DefaultSize (inherited from TextBoxBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager

See Also

vdxTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox.BindEmptyValuesAsNull Property

Gets or sets whether the empty values must be binded as null.

public bool BindEmptyValuesAsNull {get; set;}

Implements

IvdxInputControl.BindEmptyValuesAsNull

See Also

vdxTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox.Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager Property

private Deag.Vdx.Controls.Core.vdxDataStatusManager Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager {get; set;}

See Also

vdxTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox.InteractWithDSM Property

Gets/sets a value indicating whether the TextBox interacts with the DSM. If set to true then the TextBox will not force an AutoEdit on the DSM. Default value = true;

public bool InteractWithDSM {get; set;}

Implements

IvdxInputControl.InteractWithDSM

See Also

vdxTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox.TextIsNull Property

This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.

public virtual bool TextIsNull {get; set;}

See Also

vdxTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox Methods

The methods of the vdxTextBox class are listed below. For a complete list of vdxTextBox class members, see the vdxTextBox Members topic.

Public Instance Methods

AppendText (inherited from TextBoxBase) | Appends text to the current text of text box.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear (inherited from TextBoxBase) | Clears all text from the text box control.
ClearUndo (inherited from TextBoxBase) | Clears information about the most recent operation from the undo buffer of the text box.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
Copy (inherited from TextBoxBase) | Copies the current selection in the text box to the Clipboard.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Cut (inherited from TextBoxBase) | Moves the current selection in the text box to the Clipboard.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
Paste (inherited from TextBoxBase) | Replaces the current selection in the text box with the contents of the Clipboard.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollToCaret (inherited from TextBoxBase) | Scrolls the contents of the control to the current caret position.
Select (inherited from TextBoxBase) | Overloaded. Selects a range of text in the text box.
Select (inherited from Control) | Overloaded. Activates the control.
SelectAll (inherited from TextBoxBase) | Selects all text in the text box.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TextBoxBase) |
Undo (inherited from TextBoxBase) | Undoes the last edit operation in the text box.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from TextBoxBase) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from TextBox) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAcceptsTabChanged (inherited from TextBoxBase) | Raises the AcceptsTabChanged event.
OnAutoSizeChanged (inherited from TextBoxBase) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnBorderStyleChanged (inherited from TextBoxBase) | Raises the BorderStyleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from TextBoxBase) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from TextBox) |
OnHandleCreated (inherited from TextBox) |
OnHandleDestroyed (inherited from TextBoxBase) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHideSelectionChanged (inherited from TextBoxBase) | Raise the HideSelectionChanged event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown | Raises the OnKeyDown event.
OnKeyPress | Raises the OnKeyPress event.
OnKeyUp | Raises the OnKeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnModifiedChanged (inherited from TextBoxBase) | Raises the ModifiedChanged event.
OnMouseDown | Raises the OnMouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp | Raises the OnMouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnMultilineChanged (inherited from TextBoxBase) | Raises the MultilineChanged event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from TextBoxBase) | Raises the ReadOnlyChanged event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextAlignChanged (inherited from TextBox) | Raises the TextAlignChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from TextBoxBase) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from TextBoxBase) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from TextBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IvdxInputControl.InitializeBinding | Do any initializing work like converting format.
IvdxResettable.Reset | Resets the value of the text box

See Also

vdxTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox.IvdxInputControl.InitializeBinding Method

Do any initializing work like converting format.

void IvdxInputControl.InitializeBinding(
Binding binding
);

Implements

IvdxInputControl.InitializeBinding

See Also

vdxTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox.IvdxResettable.Reset Method

Resets the value of the text box

void IvdxResettable.Reset();

Implements

IvdxResettable.Reset

See Also

vdxTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox.OnKeyDown Method

Raises the OnKeyDown event.

protected override void OnKeyDown(
KeyEventArgs e
);

Parameters

e
An KeyEventArgs that contains the event data.

See Also

vdxTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox.OnKeyPress Method

Raises the OnKeyPress event.

protected override void OnKeyPress(
KeyPressEventArgs e
);

Parameters

e
An KeyPressEventArgs that contains the event data.

See Also

vdxTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox.OnKeyUp Method

Raises the OnKeyUp event.

protected override void OnKeyUp(
KeyEventArgs e
);

Parameters

e
An KeyEventArgs that contains the event data.

Remarks

In case of KeyUp event is invoked, its possible to paste text in the 'vdxTextBox', but the attached 'vdxDataStatusManager' may not allow this action.

See Also

vdxTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox.OnMouseDown Method

Raises the OnMouseDown event.

protected override void OnMouseDown(
MouseEventArgs e
);

Parameters

e
An MouseEventArgs that contains the event data.

See Also

vdxTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox.OnMouseUp Method

Raises the OnMouseUp event.

protected override void OnMouseUp(
MouseEventArgs e
);

Parameters

e
An MouseEventArgs that contains the event data.

Remarks

In case of MouseUp event is invoked by the right mouse button, the framework displays the default context menu. The context menu allows to copy/cut/etc. text in the 'vdxTextBox', but the attached 'vdxDataStatusManager' may not allow this action.

See Also

vdxTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBox.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxTextBox Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxChangeValidate Class

Specialized vdxTextBox that implements the IvdxBindable to bind the bindable properties.

For a list of all members of this type, see vdxTextBoxChangeValidate Members.

System.Object
MarshalByRefObject
Component
Control
TextBoxBase
TextBox
vdxTextBox
vdxTextBoxChangeValidate

public class vdxTextBoxChangeValidate : vdxTextBox

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxTextBoxChangeValidate Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxChangeValidate Members

vdxTextBoxChangeValidate overview

Public Instance Constructors

vdxTextBoxChangeValidate Constructor Initializes a new instance of the vdxTextBoxChangeValidate class.

Public Instance Properties

AcceptsReturn (inherited from TextBox) | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.
AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from TextBoxBase) | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
BackColor (inherited from TextBoxBase) | Gets or sets the background color of the control.
BackgroundImage (inherited from TextBoxBase) |
BindEmptyValuesAsNull (inherited from vdxTextBox) | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Changed | Indicates whether textBox must be go in changed state.
CharacterCasing (inherited from TextBox) | Gets or sets whether the TextBox control modifies the case of characters as they are typed.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TextBoxBase) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM (inherited from vdxTextBox) | Gets/sets a value indicating whether the TextBox interacts with the DSM. If set to true then the TextBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Lines (inherited from TextBoxBase) | Gets or sets the lines of text in a text box control.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxLength (inherited from TextBoxBase) | Gets or sets the maximum number of characters the user can type or paste into the text box control.
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
Multiline (inherited from TextBoxBase) | Gets or sets a value indicating whether this is a multiline text box control.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PasswordChar (inherited from TextBox) | Gets or sets the character used to mask characters of a password in a single-line TextBox control.
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ResetChangeOnEnter | Indicates whether changes must be resetted on pressed enter.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScrollBars (inherited from TextBox) | Gets or sets which scroll bars should appear in a multiline TextBox control.
SelectedText (inherited from TextBoxBase) | Gets or sets a value indicating the currently selected text in the control.
SelectionLength (inherited from TextBox) |
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from TextBox) |
TextAlign (inherited from TextBox) | Gets or sets how text is aligned in a TextBox control.
TextIsNull (inherited from vdxTextBox) | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
TextLength (inherited from TextBoxBase) | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
ValidateEmptyText | Indicates whether empty text must be validated.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
WordWrap (inherited from TextBoxBase) | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.

Public Instance Methods

AppendText (inherited from TextBoxBase) | Appends text to the current text of text box.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear (inherited from TextBoxBase) | Clears all text from the text box control.
ClearUndo (inherited from TextBoxBase) | Clears information about the most recent operation from the undo buffer of the text box.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
Copy (inherited from TextBoxBase) | Copies the current selection in the text box to the Clipboard.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Cut (inherited from TextBoxBase) | Moves the current selection in the text box to the Clipboard.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
ForceChanged | Forces textBox to changed status.
GetBindingInfo (inherited from vdxTextBox) | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
Paste (inherited from TextBoxBase) | Replaces the current selection in the text box with the contents of the Clipboard.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollToCaret (inherited from TextBoxBase) | Scrolls the contents of the control to the current caret position.
Select (inherited from TextBoxBase) | Overloaded. Selects a range of text in the text box.
Select (inherited from Control) | Overloaded. Activates the control.
SelectAll (inherited from TextBoxBase) | Selects all text in the text box.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo (inherited from vdxTextBox) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TextBoxBase) |
Undo (inherited from TextBoxBase) | Undoes the last edit operation in the text box.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AcceptsTabChanged (inherited from TextBoxBase) | Occurs when the value of the AcceptsTab property has changed.
AutoSizeChanged (inherited from TextBoxBase) | Occurs when the value of the AutoSize property has changed.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from TextBoxBase) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
BorderStyleChanged (inherited from TextBoxBase) | Occurs when the value of the BorderStyle property has changed.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from TextBoxBase) | Occurs when the text box is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
HideSelectionChanged (inherited from TextBoxBase) | Occurs when the value of the HideSelection property has changed.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
ModifiedChanged (inherited from TextBoxBase) | Occurs when the value of the Modified property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
MultilineChanged (inherited from TextBoxBase) | Occurs when the value of the Multiline property has changed.
Paint (inherited from TextBoxBase) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
ReadOnlyChanged (inherited from TextBoxBase) | Occurs when the value of the ReadOnly property has changed.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextAlignChanged (inherited from TextBox) | Occurs when the value of the TextAlign property has changed.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from TextBox) |
DefaultImeMode (inherited from TextBox) |
DefaultSize (inherited from TextBoxBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from TextBoxBase) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from TextBox) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAcceptsTabChanged (inherited from TextBoxBase) | Raises the AcceptsTabChanged event.
OnAutoSizeChanged (inherited from TextBoxBase) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnBorderStyleChanged (inherited from TextBoxBase) | Raises the BorderStyleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter | Overrides OnEnter event invoker of TextBox to set changed status if ResetChangeOnEnter is true.
OnFontChanged (inherited from TextBoxBase) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from TextBox) |
OnHandleCreated (inherited from TextBox) |
OnHandleDestroyed (inherited from TextBoxBase) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHideSelectionChanged (inherited from TextBoxBase) | Raise the HideSelectionChanged event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from vdxTextBox) | Raises the OnKeyDown event.
OnKeyPress (inherited from vdxTextBox) | Raises the OnKeyPress event.
OnKeyUp (inherited from vdxTextBox) | Raises the OnKeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnModifiedChanged (inherited from TextBoxBase) | Raises the ModifiedChanged event.
OnMouseDown (inherited from vdxTextBox) | Raises the OnMouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from vdxTextBox) | Raises the OnMouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnMultilineChanged (inherited from TextBoxBase) | Raises the MultilineChanged event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from TextBoxBase) | Raises the ReadOnlyChanged event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextAlignChanged (inherited from TextBox) | Raises the TextAlignChanged event.
OnTextChanged | Overrides OnTextChanged event invoker of TextBox to evaluate set the changed status.
OnValidated | Overrides OnValidated event invoker of TextBox to evaluate the changed status.
OnValidating | Overrides OnValidating event invoker of TextBox to evaluate the changed status.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from TextBoxBase) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from TextBoxBase) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from TextBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IvdxInputControl.InitializeBinding (inherited from vdxTextBox) | Do any initializing work like converting format.
IvdxResettable.Reset (inherited from vdxTextBox) | Resets the value of the text box

See Also

vdxTextBoxChangeValidate Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxChangeValidate Constructor

Initializes a new instance of the vdxTextBoxChangeValidate class.

public vdxTextBoxChangeValidate();

See Also

vdxTextBoxChangeValidate Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxChangeValidate Properties

The properties of the vdxTextBoxChangeValidate class are listed below. For a complete list of vdxTextBoxChangeValidate class members, see the vdxTextBoxChangeValidate Members topic.

Public Instance Properties

AcceptsReturn (inherited from TextBox) | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.
AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from TextBoxBase) | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
BackColor (inherited from TextBoxBase) | Gets or sets the background color of the control.
BackgroundImage (inherited from TextBoxBase) |
BindEmptyValuesAsNull (inherited from vdxTextBox) | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Changed | Indicates whether textBox must be go in changed state.
CharacterCasing (inherited from TextBox) | Gets or sets whether the TextBox control modifies the case of characters as they are typed.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TextBoxBase) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM (inherited from vdxTextBox) | Gets/sets a value indicating whether the TextBox interacts with the DSM. If set to true then the TextBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Lines (inherited from TextBoxBase) | Gets or sets the lines of text in a text box control.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxLength (inherited from TextBoxBase) | Gets or sets the maximum number of characters the user can type or paste into the text box control.
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
Multiline (inherited from TextBoxBase) | Gets or sets a value indicating whether this is a multiline text box control.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PasswordChar (inherited from TextBox) | Gets or sets the character used to mask characters of a password in a single-line TextBox control.
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ResetChangeOnEnter | Indicates whether changes must be resetted on pressed enter.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScrollBars (inherited from TextBox) | Gets or sets which scroll bars should appear in a multiline TextBox control.
SelectedText (inherited from TextBoxBase) | Gets or sets a value indicating the currently selected text in the control.
SelectionLength (inherited from TextBox) |
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from TextBox) |
TextAlign (inherited from TextBox) | Gets or sets how text is aligned in a TextBox control.
TextIsNull (inherited from vdxTextBox) | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
TextLength (inherited from TextBoxBase) | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
ValidateEmptyText | Indicates whether empty text must be validated.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
WordWrap (inherited from TextBoxBase) | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.

Protected Instance Properties

CreateParams (inherited from TextBox) |
DefaultImeMode (inherited from TextBox) |
DefaultSize (inherited from TextBoxBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxTextBoxChangeValidate Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxChangeValidate.Changed Property

Indicates whether textBox must be go in changed state.

public bool Changed {get; set;}

See Also

vdxTextBoxChangeValidate Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxChangeValidate.ResetChangeOnEnter Property

Indicates whether changes must be resetted on pressed enter.

public bool ResetChangeOnEnter {get; set;}

See Also

vdxTextBoxChangeValidate Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxChangeValidate.ValidateEmptyText Property

Indicates whether empty text must be validated.

public bool ValidateEmptyText {get; set;}

See Also

vdxTextBoxChangeValidate Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxChangeValidate Methods

The methods of the vdxTextBoxChangeValidate class are listed below. For a complete list of vdxTextBoxChangeValidate class members, see the vdxTextBoxChangeValidate Members topic.

Public Instance Methods

AppendText (inherited from TextBoxBase) | Appends text to the current text of text box.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear (inherited from TextBoxBase) | Clears all text from the text box control.
ClearUndo (inherited from TextBoxBase) | Clears information about the most recent operation from the undo buffer of the text box.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
Copy (inherited from TextBoxBase) | Copies the current selection in the text box to the Clipboard.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Cut (inherited from TextBoxBase) | Moves the current selection in the text box to the Clipboard.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
ForceChanged | Forces textBox to changed status.
GetBindingInfo (inherited from vdxTextBox) | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
Paste (inherited from TextBoxBase) | Replaces the current selection in the text box with the contents of the Clipboard.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollToCaret (inherited from TextBoxBase) | Scrolls the contents of the control to the current caret position.
Select (inherited from TextBoxBase) | Overloaded. Selects a range of text in the text box.
Select (inherited from Control) | Overloaded. Activates the control.
SelectAll (inherited from TextBoxBase) | Selects all text in the text box.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo (inherited from vdxTextBox) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TextBoxBase) |
Undo (inherited from TextBoxBase) | Undoes the last edit operation in the text box.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from TextBoxBase) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from TextBox) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAcceptsTabChanged (inherited from TextBoxBase) | Raises the AcceptsTabChanged event.
OnAutoSizeChanged (inherited from TextBoxBase) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnBorderStyleChanged (inherited from TextBoxBase) | Raises the BorderStyleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter | Overrides OnEnter event invoker of TextBox to set changed status if ResetChangeOnEnter is true.
OnFontChanged (inherited from TextBoxBase) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from TextBox) |
OnHandleCreated (inherited from TextBox) |
OnHandleDestroyed (inherited from TextBoxBase) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHideSelectionChanged (inherited from TextBoxBase) | Raise the HideSelectionChanged event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from vdxTextBox) | Raises the OnKeyDown event.
OnKeyPress (inherited from vdxTextBox) | Raises the OnKeyPress event.
OnKeyUp (inherited from vdxTextBox) | Raises the OnKeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnModifiedChanged (inherited from TextBoxBase) | Raises the ModifiedChanged event.
OnMouseDown (inherited from vdxTextBox) | Raises the OnMouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from vdxTextBox) | Raises the OnMouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnMultilineChanged (inherited from TextBoxBase) | Raises the MultilineChanged event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from TextBoxBase) | Raises the ReadOnlyChanged event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextAlignChanged (inherited from TextBox) | Raises the TextAlignChanged event.
OnTextChanged | Overrides OnTextChanged event invoker of TextBox to evaluate set the changed status.
OnValidated | Overrides OnValidated event invoker of TextBox to evaluate the changed status.
OnValidating | Overrides OnValidating event invoker of TextBox to evaluate the changed status.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from TextBoxBase) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from TextBoxBase) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from TextBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IvdxInputControl.InitializeBinding (inherited from vdxTextBox) | Do any initializing work like converting format.
IvdxResettable.Reset (inherited from vdxTextBox) | Resets the value of the text box

See Also

vdxTextBoxChangeValidate Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxChangeValidate.ForceChanged Method

Forces textBox to changed status.

public void ForceChanged();

See Also

vdxTextBoxChangeValidate Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxChangeValidate.OnEnter Method

Overrides OnEnter event invoker of TextBox to set changed status if ResetChangeOnEnter is true.

protected override void OnEnter(
EventArgs e
);

Parameters

e
A EventArgsthat contains the event data.

See Also

vdxTextBoxChangeValidate Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxChangeValidate.OnTextChanged Method

Overrides OnTextChanged event invoker of TextBox to evaluate set the changed status.

protected override void OnTextChanged(
EventArgs e
);

Parameters

e
A EventArgs that contains the event data.

See Also

vdxTextBoxChangeValidate Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxChangeValidate.OnValidated Method

Overrides OnValidated event invoker of TextBox to evaluate the changed status.

protected override void OnValidated(
EventArgs e
);

Parameters

e
A EventArgs that contains the event data.

See Also

vdxTextBoxChangeValidate Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxChangeValidate.OnValidating Method

Overrides OnValidating event invoker of TextBox to evaluate the changed status.

protected override void OnValidating(
CancelEventArgs e
);

Parameters

e
A CancelEventArgs that contains the event data.

See Also

vdxTextBoxChangeValidate Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxDecimal Class

Specialisation of vdxTextBoxNumeric to simplify the input of numeric values of the type decimal. In addition to vdxTextBoxNumeric, the decimal value can be accessed directly by the NumericValue property. The NullValue Property is used to define a decimal value used to represent null. (No data present).

For a list of all members of this type, see vdxTextBoxDecimal Members.

System.Object
MarshalByRefObject
Component
Control
TextBoxBase
TextBox
vdxTextBox
vdxTextBoxNumeric
vdxTextBoxDecimal

public class vdxTextBoxDecimal : vdxTextBoxNumeric

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxTextBoxDecimal Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxDecimal Members

vdxTextBoxDecimal overview

Public Instance Constructors

vdxTextBoxDecimal Constructor Default constructor of vdxTextBoxDecimal: The NumericType property is set to enNumericTypes.Decimal and CheckDataBeforeUpdate is set to false, because we assume that this control always is bound to a data column of type decimal.

Public Instance Properties

AcceptsReturn (inherited from TextBox) | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.
AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from TextBoxBase) | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
BackColor (inherited from TextBoxBase) | Gets or sets the background color of the control.
BackgroundImage (inherited from TextBoxBase) |
BindEmptyValuesAsNull (inherited from vdxTextBox) | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CharacterCasing (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
CheckDataBeforeUpdate | In this context always false and not browsable, because we assume that this control only will be bound to decimal typed data columns.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TextBoxBase) | Gets or sets the foreground color of the control.
Format (inherited from vdxTextBoxNumeric) | Gets or sets the format expression used to format the textual representation of the numeric value" If a number of the actually set type cannot be formatted by the desired format string, the user will be informed by a maessage box and the format will not be set.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM (inherited from vdxTextBox) | Gets/sets a value indicating whether the TextBox interacts with the DSM. If set to true then the TextBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Lines (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxLength (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
Multiline (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
Name (inherited from Control) | Gets or sets the name of the control.
NullValue | Gets or sets the value used as null value. Default is 0D.
NumericType | Gets the numeric type format identification used for range checking This property is overridden, because this control only supports decimal data type.
NumericValue | Returns the value of the textbox as decimal. If the value is null, the value of the NullValue property is returned
Parent (inherited from Control) | Gets or sets the parent container of the control.
PasswordChar (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScrollBars (inherited from TextBox) | Gets or sets which scroll bars should appear in a multiline TextBox control.
SelectedText (inherited from TextBoxBase) | Gets or sets a value indicating the currently selected text in the control.
SelectionLength (inherited from TextBox) |
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from vdxTextBoxNumeric) | Overload of the text property: We want to apply the format before setting the text of the control
TextAlign (inherited from vdxTextBoxNumeric) | Overrides TextAlign to make default value Right.
TextIsNull (inherited from vdxTextBox) | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
TextLength (inherited from TextBoxBase) | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
WordWrap (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here

Public Instance Methods

AppendText (inherited from TextBoxBase) | Appends text to the current text of text box.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear (inherited from TextBoxBase) | Clears all text from the text box control.
ClearUndo (inherited from TextBoxBase) | Clears information about the most recent operation from the undo buffer of the text box.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
Copy (inherited from TextBoxBase) | Copies the current selection in the text box to the Clipboard.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Cut (inherited from TextBoxBase) | Moves the current selection in the text box to the Clipboard.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxTextBox) | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
Paste (inherited from TextBoxBase) | Replaces the current selection in the text box with the contents of the Clipboard.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollToCaret (inherited from TextBoxBase) | Scrolls the contents of the control to the current caret position.
Select (inherited from TextBoxBase) | Overloaded. Selects a range of text in the text box.
Select (inherited from Control) | Overloaded. Activates the control.
SelectAll (inherited from TextBoxBase) | Selects all text in the text box.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo (inherited from vdxTextBox) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TextBoxBase) |
Undo (inherited from TextBoxBase) | Undoes the last edit operation in the text box.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AcceptsTabChanged (inherited from TextBoxBase) | Occurs when the value of the AcceptsTab property has changed.
AutoSizeChanged (inherited from TextBoxBase) | Occurs when the value of the AutoSize property has changed.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from TextBoxBase) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
BorderStyleChanged (inherited from TextBoxBase) | Occurs when the value of the BorderStyle property has changed.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from TextBoxBase) | Occurs when the text box is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
HideSelectionChanged (inherited from TextBoxBase) | Occurs when the value of the HideSelection property has changed.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
ModifiedChanged (inherited from TextBoxBase) | Occurs when the value of the Modified property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
MultilineChanged (inherited from TextBoxBase) | Occurs when the value of the Multiline property has changed.
Paint (inherited from TextBoxBase) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
ReadOnlyChanged (inherited from TextBoxBase) | Occurs when the value of the ReadOnly property has changed.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextAlignChanged (inherited from TextBox) | Occurs when the value of the TextAlign property has changed.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

format (inherited from vdxTextBoxNumeric) The Format string of used to format the decimal value

Protected Instance Properties

CreateParams (inherited from TextBox) |
DefaultImeMode (inherited from TextBox) |
DefaultSize (inherited from TextBoxBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from TextBoxBase) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
FilterKey (inherited from vdxTextBoxNumeric) | Validates a key stroke and sets the Handled falg of the KeyPressEventArgs to true, if the key was invalid Note for inheritors: You should override this metod to accept additional keys for input.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetFormattedValue (inherited from vdxTextBoxNumeric) | Formats the object value according to the actual format If the format cannot be evaluated the original value is returned. Thes method is called by the Text property to format the text bevore storion it in the base class and by the Format property to check the format string. Note for inheritors: To support your own types, set the NumericType property to 'user'. Overrite this metod and implement your own conversion by parsion the string Val to the desired type.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GetTypeInfo (inherited from vdxTextBoxNumeric) | Evaluates whether the decimal pont and/or the sign indicator are used in numbers of the actual type. Note for inheritors: To support your own types, set the NumericType property to 'user'. Overrite this metod to set the flags AllowDecimal and AllowSign according to your type
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from TextBox) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAcceptsTabChanged (inherited from TextBoxBase) | Raises the AcceptsTabChanged event.
OnAutoSizeChanged (inherited from TextBoxBase) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnBorderStyleChanged (inherited from TextBoxBase) | Raises the BorderStyleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from TextBoxBase) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from TextBox) |
OnHandleCreated (inherited from TextBox) |
OnHandleDestroyed (inherited from TextBoxBase) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHideSelectionChanged (inherited from TextBoxBase) | Raise the HideSelectionChanged event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from vdxTextBox) | Raises the OnKeyDown event.
OnKeyPress (inherited from vdxTextBoxNumeric) | Overrides the OnKeyPress event of this control. The keys are filtered according to the actual numeric data type
OnKeyUp (inherited from vdxTextBox) | Raises the OnKeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnModifiedChanged (inherited from TextBoxBase) | Raises the ModifiedChanged event.
OnMouseDown (inherited from vdxTextBox) | Raises the OnMouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from vdxTextBox) | Raises the OnMouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnMultilineChanged (inherited from TextBoxBase) | Raises the MultilineChanged event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from TextBoxBase) | Raises the ReadOnlyChanged event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextAlignChanged (inherited from TextBox) | Raises the TextAlignChanged event.
OnTextChanged (inherited from vdxTextBoxNumeric) | This Event Listener makes sure that only correct strings (e.g. strings that can be converted into the actual numeric type) can be assigned to the text box. This is only done during runtime. While designtime, the the format will not be applied when the text changes
OnValidated (inherited from vdxTextBoxNumeric) | Overrides OnValidated to reformat the text.
OnValidating (inherited from vdxTextBoxNumeric) | Overrides OnValidating to reformat the text and to call the ValidateBindings method if the checkDataBeforeUpdate property is set.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from TextBoxBase) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from TextBoxBase) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
TryToConvert (inherited from vdxTextBoxNumeric) | Tries to convert the text to the actual numeric type. In case of an exception null is returned otherwise the result of the conversion Note for inheritors: To support your own types, set the NumericType property to 'user'. Overrite this metod to convert the text to the according type
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValidateBindings (inherited from vdxTextBoxNumeric) | This Method is called by the framework before writing the value to the data source when the CheckDataBeforeUpdate property have been set to true. The metod evaluates the data taype of the column bound to the control (the control must be bound to a DataTable). The evaluated type must have a static Parse method with a single string parameter. This metod is called to try to convert the text of the control into the data type of the column. If the conversion fails, an exception is thorwn, indication the table and column name, the data to convert and the target type. Note for inheritors: If you intend to bind your control to columns of a data type not implementing the Parse method, you can preform your own checking before writion down the value to the data source.
WndProc (inherited from TextBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IvdxInputControl.InitializeBinding (inherited from vdxTextBox) | Do any initializing work like converting format.
IvdxResettable.Reset (inherited from vdxTextBox) | Resets the value of the text box

See Also

vdxTextBoxDecimal Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxDecimal Constructor

Default constructor of vdxTextBoxDecimal: The NumericType property is set to enNumericTypes.Decimal and CheckDataBeforeUpdate is set to false, because we assume that this control always is bound to a data column of type decimal.

public vdxTextBoxDecimal();

See Also

vdxTextBoxDecimal Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxDecimal Properties

The properties of the vdxTextBoxDecimal class are listed below. For a complete list of vdxTextBoxDecimal class members, see the vdxTextBoxDecimal Members topic.

Public Instance Properties

AcceptsReturn (inherited from TextBox) | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.
AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from TextBoxBase) | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
BackColor (inherited from TextBoxBase) | Gets or sets the background color of the control.
BackgroundImage (inherited from TextBoxBase) |
BindEmptyValuesAsNull (inherited from vdxTextBox) | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CharacterCasing (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
CheckDataBeforeUpdate | In this context always false and not browsable, because we assume that this control only will be bound to decimal typed data columns.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TextBoxBase) | Gets or sets the foreground color of the control.
Format (inherited from vdxTextBoxNumeric) | Gets or sets the format expression used to format the textual representation of the numeric value" If a number of the actually set type cannot be formatted by the desired format string, the user will be informed by a maessage box and the format will not be set.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM (inherited from vdxTextBox) | Gets/sets a value indicating whether the TextBox interacts with the DSM. If set to true then the TextBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Lines (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxLength (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
Multiline (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
Name (inherited from Control) | Gets or sets the name of the control.
NullValue | Gets or sets the value used as null value. Default is 0D.
NumericType | Gets the numeric type format identification used for range checking This property is overridden, because this control only supports decimal data type.
NumericValue | Returns the value of the textbox as decimal. If the value is null, the value of the NullValue property is returned
Parent (inherited from Control) | Gets or sets the parent container of the control.
PasswordChar (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScrollBars (inherited from TextBox) | Gets or sets which scroll bars should appear in a multiline TextBox control.
SelectedText (inherited from TextBoxBase) | Gets or sets a value indicating the currently selected text in the control.
SelectionLength (inherited from TextBox) |
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from vdxTextBoxNumeric) | Overload of the text property: We want to apply the format before setting the text of the control
TextAlign (inherited from vdxTextBoxNumeric) | Overrides TextAlign to make default value Right.
TextIsNull (inherited from vdxTextBox) | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
TextLength (inherited from TextBoxBase) | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
WordWrap (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here

Protected Instance Properties

CreateParams (inherited from TextBox) |
DefaultImeMode (inherited from TextBox) |
DefaultSize (inherited from TextBoxBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxTextBoxDecimal Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxDecimal.CheckDataBeforeUpdate Property

In this context always false and not browsable, because we assume that this control only will be bound to decimal typed data columns.

public override bool CheckDataBeforeUpdate {get; set;}

See Also

vdxTextBoxDecimal Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxDecimal.NullValue Property

Gets or sets the value used as null value. Default is 0D.

public decimal NullValue {get; set;}

See Also

vdxTextBoxDecimal Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxDecimal.NumericType Property

Gets the numeric type format identification used for range checking This property is overridden, because this control only supports decimal data type.

public override enNumericTypes NumericType {get;}

See Also

vdxTextBoxDecimal Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxDecimal.NumericValue Property

Returns the value of the textbox as decimal. If the value is null, the value of the NullValue property is returned

public decimal NumericValue {get; set;}

See Also

vdxTextBoxDecimal Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxDouble Class

Specialisation of vdxTextBoxNumeric to simplify the input of numeric values of the type double. In addition to vdxTextBoxNumeric, the double value can be accessed directly by the NumericValue property. The NullValue Property is used to define a double value used to represent null. (No data present).

For a list of all members of this type, see vdxTextBoxDouble Members.

System.Object
MarshalByRefObject
Component
Control
TextBoxBase
TextBox
vdxTextBox
vdxTextBoxNumeric
vdxTextBoxDouble

public class vdxTextBoxDouble : vdxTextBoxNumeric

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxTextBoxDouble Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxDouble Members

vdxTextBoxDouble overview

Public Instance Constructors

vdxTextBoxDouble Constructor Default constructor of vdxTextBoxDouble: The NumericType property is set to enNumericTypes.Double and CheckDataBeforeUpdate is set to false, because we assume that this control always is bound to a data column of type double.

Public Instance Properties

AcceptsReturn (inherited from TextBox) | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.
AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from TextBoxBase) | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
BackColor (inherited from TextBoxBase) | Gets or sets the background color of the control.
BackgroundImage (inherited from TextBoxBase) |
BindEmptyValuesAsNull (inherited from vdxTextBox) | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CharacterCasing (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
CheckDataBeforeUpdate | In this context always false and not browsable, because we assume that this control only will be bound to double typed data columns.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TextBoxBase) | Gets or sets the foreground color of the control.
Format (inherited from vdxTextBoxNumeric) | Gets or sets the format expression used to format the textual representation of the numeric value" If a number of the actually set type cannot be formatted by the desired format string, the user will be informed by a maessage box and the format will not be set.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM (inherited from vdxTextBox) | Gets/sets a value indicating whether the TextBox interacts with the DSM. If set to true then the TextBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Lines (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxLength (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
Multiline (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
Name (inherited from Control) | Gets or sets the name of the control.
NullValue | Gets or sets the value used as null value. Default is 0D.
NumericType | Gets the numeric type format identification used for range checking This property is overridden, because this control only supports double data type.
NumericValue | Returns the value of the textbox as double. If the value is null, the value of the NullValue property is returned
Parent (inherited from Control) | Gets or sets the parent container of the control.
PasswordChar (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScrollBars (inherited from TextBox) | Gets or sets which scroll bars should appear in a multiline TextBox control.
SelectedText (inherited from TextBoxBase) | Gets or sets a value indicating the currently selected text in the control.
SelectionLength (inherited from TextBox) |
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from vdxTextBoxNumeric) | Overload of the text property: We want to apply the format before setting the text of the control
TextAlign (inherited from vdxTextBoxNumeric) | Overrides TextAlign to make default value Right.
TextIsNull (inherited from vdxTextBox) | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
TextLength (inherited from TextBoxBase) | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
WordWrap (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here

Public Instance Methods

AppendText (inherited from TextBoxBase) | Appends text to the current text of text box.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear (inherited from TextBoxBase) | Clears all text from the text box control.
ClearUndo (inherited from TextBoxBase) | Clears information about the most recent operation from the undo buffer of the text box.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
Copy (inherited from TextBoxBase) | Copies the current selection in the text box to the Clipboard.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Cut (inherited from TextBoxBase) | Moves the current selection in the text box to the Clipboard.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxTextBox) | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
Paste (inherited from TextBoxBase) | Replaces the current selection in the text box with the contents of the Clipboard.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollToCaret (inherited from TextBoxBase) | Scrolls the contents of the control to the current caret position.
Select (inherited from TextBoxBase) | Overloaded. Selects a range of text in the text box.
Select (inherited from Control) | Overloaded. Activates the control.
SelectAll (inherited from TextBoxBase) | Selects all text in the text box.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo (inherited from vdxTextBox) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TextBoxBase) |
Undo (inherited from TextBoxBase) | Undoes the last edit operation in the text box.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AcceptsTabChanged (inherited from TextBoxBase) | Occurs when the value of the AcceptsTab property has changed.
AutoSizeChanged (inherited from TextBoxBase) | Occurs when the value of the AutoSize property has changed.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from TextBoxBase) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
BorderStyleChanged (inherited from TextBoxBase) | Occurs when the value of the BorderStyle property has changed.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from TextBoxBase) | Occurs when the text box is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
HideSelectionChanged (inherited from TextBoxBase) | Occurs when the value of the HideSelection property has changed.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
ModifiedChanged (inherited from TextBoxBase) | Occurs when the value of the Modified property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
MultilineChanged (inherited from TextBoxBase) | Occurs when the value of the Multiline property has changed.
Paint (inherited from TextBoxBase) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
ReadOnlyChanged (inherited from TextBoxBase) | Occurs when the value of the ReadOnly property has changed.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextAlignChanged (inherited from TextBox) | Occurs when the value of the TextAlign property has changed.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

format (inherited from vdxTextBoxNumeric) The Format string of used to format the decimal value

Protected Instance Properties

CreateParams (inherited from TextBox) |
DefaultImeMode (inherited from TextBox) |
DefaultSize (inherited from TextBoxBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from TextBoxBase) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
FilterKey (inherited from vdxTextBoxNumeric) | Validates a key stroke and sets the Handled falg of the KeyPressEventArgs to true, if the key was invalid Note for inheritors: You should override this metod to accept additional keys for input.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetFormattedValue (inherited from vdxTextBoxNumeric) | Formats the object value according to the actual format If the format cannot be evaluated the original value is returned. Thes method is called by the Text property to format the text bevore storion it in the base class and by the Format property to check the format string. Note for inheritors: To support your own types, set the NumericType property to 'user'. Overrite this metod and implement your own conversion by parsion the string Val to the desired type.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GetTypeInfo (inherited from vdxTextBoxNumeric) | Evaluates whether the decimal pont and/or the sign indicator are used in numbers of the actual type. Note for inheritors: To support your own types, set the NumericType property to 'user'. Overrite this metod to set the flags AllowDecimal and AllowSign according to your type
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from TextBox) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAcceptsTabChanged (inherited from TextBoxBase) | Raises the AcceptsTabChanged event.
OnAutoSizeChanged (inherited from TextBoxBase) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnBorderStyleChanged (inherited from TextBoxBase) | Raises the BorderStyleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from TextBoxBase) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from TextBox) |
OnHandleCreated (inherited from TextBox) |
OnHandleDestroyed (inherited from TextBoxBase) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHideSelectionChanged (inherited from TextBoxBase) | Raise the HideSelectionChanged event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from vdxTextBox) | Raises the OnKeyDown event.
OnKeyPress (inherited from vdxTextBoxNumeric) | Overrides the OnKeyPress event of this control. The keys are filtered according to the actual numeric data type
OnKeyUp (inherited from vdxTextBox) | Raises the OnKeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnModifiedChanged (inherited from TextBoxBase) | Raises the ModifiedChanged event.
OnMouseDown (inherited from vdxTextBox) | Raises the OnMouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from vdxTextBox) | Raises the OnMouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnMultilineChanged (inherited from TextBoxBase) | Raises the MultilineChanged event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from TextBoxBase) | Raises the ReadOnlyChanged event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextAlignChanged (inherited from TextBox) | Raises the TextAlignChanged event.
OnTextChanged (inherited from vdxTextBoxNumeric) | This Event Listener makes sure that only correct strings (e.g. strings that can be converted into the actual numeric type) can be assigned to the text box. This is only done during runtime. While designtime, the the format will not be applied when the text changes
OnValidated (inherited from vdxTextBoxNumeric) | Overrides OnValidated to reformat the text.
OnValidating (inherited from vdxTextBoxNumeric) | Overrides OnValidating to reformat the text and to call the ValidateBindings method if the checkDataBeforeUpdate property is set.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from TextBoxBase) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from TextBoxBase) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
TryToConvert (inherited from vdxTextBoxNumeric) | Tries to convert the text to the actual numeric type. In case of an exception null is returned otherwise the result of the conversion Note for inheritors: To support your own types, set the NumericType property to 'user'. Overrite this metod to convert the text to the according type
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValidateBindings (inherited from vdxTextBoxNumeric) | This Method is called by the framework before writing the value to the data source when the CheckDataBeforeUpdate property have been set to true. The metod evaluates the data taype of the column bound to the control (the control must be bound to a DataTable). The evaluated type must have a static Parse method with a single string parameter. This metod is called to try to convert the text of the control into the data type of the column. If the conversion fails, an exception is thorwn, indication the table and column name, the data to convert and the target type. Note for inheritors: If you intend to bind your control to columns of a data type not implementing the Parse method, you can preform your own checking before writion down the value to the data source.
WndProc (inherited from TextBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IvdxInputControl.InitializeBinding (inherited from vdxTextBox) | Do any initializing work like converting format.
IvdxResettable.Reset (inherited from vdxTextBox) | Resets the value of the text box

See Also

vdxTextBoxDouble Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxDouble Constructor

Default constructor of vdxTextBoxDouble: The NumericType property is set to enNumericTypes.Double and CheckDataBeforeUpdate is set to false, because we assume that this control always is bound to a data column of type double.

public vdxTextBoxDouble();

See Also

vdxTextBoxDouble Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxDouble Properties

The properties of the vdxTextBoxDouble class are listed below. For a complete list of vdxTextBoxDouble class members, see the vdxTextBoxDouble Members topic.

Public Instance Properties

AcceptsReturn (inherited from TextBox) | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.
AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from TextBoxBase) | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
BackColor (inherited from TextBoxBase) | Gets or sets the background color of the control.
BackgroundImage (inherited from TextBoxBase) |
BindEmptyValuesAsNull (inherited from vdxTextBox) | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CharacterCasing (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
CheckDataBeforeUpdate | In this context always false and not browsable, because we assume that this control only will be bound to double typed data columns.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TextBoxBase) | Gets or sets the foreground color of the control.
Format (inherited from vdxTextBoxNumeric) | Gets or sets the format expression used to format the textual representation of the numeric value" If a number of the actually set type cannot be formatted by the desired format string, the user will be informed by a maessage box and the format will not be set.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM (inherited from vdxTextBox) | Gets/sets a value indicating whether the TextBox interacts with the DSM. If set to true then the TextBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Lines (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxLength (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
Multiline (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
Name (inherited from Control) | Gets or sets the name of the control.
NullValue | Gets or sets the value used as null value. Default is 0D.
NumericType | Gets the numeric type format identification used for range checking This property is overridden, because this control only supports double data type.
NumericValue | Returns the value of the textbox as double. If the value is null, the value of the NullValue property is returned
Parent (inherited from Control) | Gets or sets the parent container of the control.
PasswordChar (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScrollBars (inherited from TextBox) | Gets or sets which scroll bars should appear in a multiline TextBox control.
SelectedText (inherited from TextBoxBase) | Gets or sets a value indicating the currently selected text in the control.
SelectionLength (inherited from TextBox) |
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from vdxTextBoxNumeric) | Overload of the text property: We want to apply the format before setting the text of the control
TextAlign (inherited from vdxTextBoxNumeric) | Overrides TextAlign to make default value Right.
TextIsNull (inherited from vdxTextBox) | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
TextLength (inherited from TextBoxBase) | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
WordWrap (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here

Protected Instance Properties

CreateParams (inherited from TextBox) |
DefaultImeMode (inherited from TextBox) |
DefaultSize (inherited from TextBoxBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxTextBoxDouble Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxDouble.CheckDataBeforeUpdate Property

In this context always false and not browsable, because we assume that this control only will be bound to double typed data columns.

public override bool CheckDataBeforeUpdate {get; set;}

See Also

vdxTextBoxDouble Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxDouble.NullValue Property

Gets or sets the value used as null value. Default is 0D.

public double NullValue {get; set;}

See Also

vdxTextBoxDouble Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxDouble.NumericType Property

Gets the numeric type format identification used for range checking This property is overridden, because this control only supports double data type.

public override enNumericTypes NumericType {get;}

See Also

vdxTextBoxDouble Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxDouble.NumericValue Property

Returns the value of the textbox as double. If the value is null, the value of the NullValue property is returned

public double NumericValue {get; set;}

See Also

vdxTextBoxDouble Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxLong Class

Specialisation of vdxTextBoxNumeric to simplify the input of numeric values of the type long. In addition to vdxTextBoxNumeric, the long value can be accessed directly by the NumericValue property. The NullValue Property is used to define a long value used to represent null. (No data present).

For a list of all members of this type, see vdxTextBoxLong Members.

System.Object
MarshalByRefObject
Component
Control
TextBoxBase
TextBox
vdxTextBox
vdxTextBoxNumeric
vdxTextBoxLong

public class vdxTextBoxLong : vdxTextBoxNumeric

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxTextBoxLong Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxLong Members

vdxTextBoxLong overview

Public Instance Constructors

vdxTextBoxLong Constructor Default constructor of vdxTextBoxDouble: The NumericType property is set to enNumericTypes.Long and CheckDataBeforeUpdate is set to false, because we assume that this control always is bound to a data column of type long.

Public Instance Properties

AcceptsReturn (inherited from TextBox) | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.
AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from TextBoxBase) | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
BackColor (inherited from TextBoxBase) | Gets or sets the background color of the control.
BackgroundImage (inherited from TextBoxBase) |
BindEmptyValuesAsNull (inherited from vdxTextBox) | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CharacterCasing (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
CheckDataBeforeUpdate | In this context always false and not browsable, because we assume that this control only will be bound to long typed data columns.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TextBoxBase) | Gets or sets the foreground color of the control.
Format (inherited from vdxTextBoxNumeric) | Gets or sets the format expression used to format the textual representation of the numeric value" If a number of the actually set type cannot be formatted by the desired format string, the user will be informed by a maessage box and the format will not be set.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM (inherited from vdxTextBox) | Gets/sets a value indicating whether the TextBox interacts with the DSM. If set to true then the TextBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Lines (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxLength (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
Multiline (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
Name (inherited from Control) | Gets or sets the name of the control.
NullValue | Gets or sets the value used as null value. Default is 0D.
NumericType | Gets the numeric type format identification used for range checking This property is overridden, because this control only supports long data type.
NumericValue | Returns the value of the textbox as decimal. If the value is null, the value of the NullValue property is returned
Parent (inherited from Control) | Gets or sets the parent container of the control.
PasswordChar (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScrollBars (inherited from TextBox) | Gets or sets which scroll bars should appear in a multiline TextBox control.
SelectedText (inherited from TextBoxBase) | Gets or sets a value indicating the currently selected text in the control.
SelectionLength (inherited from TextBox) |
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from vdxTextBoxNumeric) | Overload of the text property: We want to apply the format before setting the text of the control
TextAlign (inherited from vdxTextBoxNumeric) | Overrides TextAlign to make default value Right.
TextIsNull (inherited from vdxTextBox) | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
TextLength (inherited from TextBoxBase) | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
WordWrap (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here

Public Instance Methods

AppendText (inherited from TextBoxBase) | Appends text to the current text of text box.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear (inherited from TextBoxBase) | Clears all text from the text box control.
ClearUndo (inherited from TextBoxBase) | Clears information about the most recent operation from the undo buffer of the text box.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
Copy (inherited from TextBoxBase) | Copies the current selection in the text box to the Clipboard.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Cut (inherited from TextBoxBase) | Moves the current selection in the text box to the Clipboard.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxTextBox) | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
Paste (inherited from TextBoxBase) | Replaces the current selection in the text box with the contents of the Clipboard.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollToCaret (inherited from TextBoxBase) | Scrolls the contents of the control to the current caret position.
Select (inherited from TextBoxBase) | Overloaded. Selects a range of text in the text box.
Select (inherited from Control) | Overloaded. Activates the control.
SelectAll (inherited from TextBoxBase) | Selects all text in the text box.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo (inherited from vdxTextBox) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TextBoxBase) |
Undo (inherited from TextBoxBase) | Undoes the last edit operation in the text box.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AcceptsTabChanged (inherited from TextBoxBase) | Occurs when the value of the AcceptsTab property has changed.
AutoSizeChanged (inherited from TextBoxBase) | Occurs when the value of the AutoSize property has changed.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from TextBoxBase) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
BorderStyleChanged (inherited from TextBoxBase) | Occurs when the value of the BorderStyle property has changed.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from TextBoxBase) | Occurs when the text box is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
HideSelectionChanged (inherited from TextBoxBase) | Occurs when the value of the HideSelection property has changed.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
ModifiedChanged (inherited from TextBoxBase) | Occurs when the value of the Modified property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
MultilineChanged (inherited from TextBoxBase) | Occurs when the value of the Multiline property has changed.
Paint (inherited from TextBoxBase) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
ReadOnlyChanged (inherited from TextBoxBase) | Occurs when the value of the ReadOnly property has changed.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextAlignChanged (inherited from TextBox) | Occurs when the value of the TextAlign property has changed.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

format (inherited from vdxTextBoxNumeric) The Format string of used to format the decimal value

Protected Instance Properties

CreateParams (inherited from TextBox) |
DefaultImeMode (inherited from TextBox) |
DefaultSize (inherited from TextBoxBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from TextBoxBase) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
FilterKey (inherited from vdxTextBoxNumeric) | Validates a key stroke and sets the Handled falg of the KeyPressEventArgs to true, if the key was invalid Note for inheritors: You should override this metod to accept additional keys for input.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetFormattedValue (inherited from vdxTextBoxNumeric) | Formats the object value according to the actual format If the format cannot be evaluated the original value is returned. Thes method is called by the Text property to format the text bevore storion it in the base class and by the Format property to check the format string. Note for inheritors: To support your own types, set the NumericType property to 'user'. Overrite this metod and implement your own conversion by parsion the string Val to the desired type.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GetTypeInfo (inherited from vdxTextBoxNumeric) | Evaluates whether the decimal pont and/or the sign indicator are used in numbers of the actual type. Note for inheritors: To support your own types, set the NumericType property to 'user'. Overrite this metod to set the flags AllowDecimal and AllowSign according to your type
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from TextBox) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAcceptsTabChanged (inherited from TextBoxBase) | Raises the AcceptsTabChanged event.
OnAutoSizeChanged (inherited from TextBoxBase) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnBorderStyleChanged (inherited from TextBoxBase) | Raises the BorderStyleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from TextBoxBase) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from TextBox) |
OnHandleCreated (inherited from TextBox) |
OnHandleDestroyed (inherited from TextBoxBase) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHideSelectionChanged (inherited from TextBoxBase) | Raise the HideSelectionChanged event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from vdxTextBox) | Raises the OnKeyDown event.
OnKeyPress (inherited from vdxTextBoxNumeric) | Overrides the OnKeyPress event of this control. The keys are filtered according to the actual numeric data type
OnKeyUp (inherited from vdxTextBox) | Raises the OnKeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnModifiedChanged (inherited from TextBoxBase) | Raises the ModifiedChanged event.
OnMouseDown (inherited from vdxTextBox) | Raises the OnMouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from vdxTextBox) | Raises the OnMouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnMultilineChanged (inherited from TextBoxBase) | Raises the MultilineChanged event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from TextBoxBase) | Raises the ReadOnlyChanged event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextAlignChanged (inherited from TextBox) | Raises the TextAlignChanged event.
OnTextChanged (inherited from vdxTextBoxNumeric) | This Event Listener makes sure that only correct strings (e.g. strings that can be converted into the actual numeric type) can be assigned to the text box. This is only done during runtime. While designtime, the the format will not be applied when the text changes
OnValidated (inherited from vdxTextBoxNumeric) | Overrides OnValidated to reformat the text.
OnValidating (inherited from vdxTextBoxNumeric) | Overrides OnValidating to reformat the text and to call the ValidateBindings method if the checkDataBeforeUpdate property is set.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from TextBoxBase) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from TextBoxBase) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
TryToConvert (inherited from vdxTextBoxNumeric) | Tries to convert the text to the actual numeric type. In case of an exception null is returned otherwise the result of the conversion Note for inheritors: To support your own types, set the NumericType property to 'user'. Overrite this metod to convert the text to the according type
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValidateBindings (inherited from vdxTextBoxNumeric) | This Method is called by the framework before writing the value to the data source when the CheckDataBeforeUpdate property have been set to true. The metod evaluates the data taype of the column bound to the control (the control must be bound to a DataTable). The evaluated type must have a static Parse method with a single string parameter. This metod is called to try to convert the text of the control into the data type of the column. If the conversion fails, an exception is thorwn, indication the table and column name, the data to convert and the target type. Note for inheritors: If you intend to bind your control to columns of a data type not implementing the Parse method, you can preform your own checking before writion down the value to the data source.
WndProc (inherited from TextBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IvdxInputControl.InitializeBinding (inherited from vdxTextBox) | Do any initializing work like converting format.
IvdxResettable.Reset (inherited from vdxTextBox) | Resets the value of the text box

See Also

vdxTextBoxLong Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxLong Constructor

Default constructor of vdxTextBoxDouble: The NumericType property is set to enNumericTypes.Long and CheckDataBeforeUpdate is set to false, because we assume that this control always is bound to a data column of type long.

public vdxTextBoxLong();

See Also

vdxTextBoxLong Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxLong Properties

The properties of the vdxTextBoxLong class are listed below. For a complete list of vdxTextBoxLong class members, see the vdxTextBoxLong Members topic.

Public Instance Properties

AcceptsReturn (inherited from TextBox) | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.
AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from TextBoxBase) | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
BackColor (inherited from TextBoxBase) | Gets or sets the background color of the control.
BackgroundImage (inherited from TextBoxBase) |
BindEmptyValuesAsNull (inherited from vdxTextBox) | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CharacterCasing (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
CheckDataBeforeUpdate | In this context always false and not browsable, because we assume that this control only will be bound to long typed data columns.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TextBoxBase) | Gets or sets the foreground color of the control.
Format (inherited from vdxTextBoxNumeric) | Gets or sets the format expression used to format the textual representation of the numeric value" If a number of the actually set type cannot be formatted by the desired format string, the user will be informed by a maessage box and the format will not be set.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM (inherited from vdxTextBox) | Gets/sets a value indicating whether the TextBox interacts with the DSM. If set to true then the TextBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Lines (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxLength (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
Multiline (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
Name (inherited from Control) | Gets or sets the name of the control.
NullValue | Gets or sets the value used as null value. Default is 0D.
NumericType | Gets the numeric type format identification used for range checking This property is overridden, because this control only supports long data type.
NumericValue | Returns the value of the textbox as decimal. If the value is null, the value of the NullValue property is returned
Parent (inherited from Control) | Gets or sets the parent container of the control.
PasswordChar (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScrollBars (inherited from TextBox) | Gets or sets which scroll bars should appear in a multiline TextBox control.
SelectedText (inherited from TextBoxBase) | Gets or sets a value indicating the currently selected text in the control.
SelectionLength (inherited from TextBox) |
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from vdxTextBoxNumeric) | Overload of the text property: We want to apply the format before setting the text of the control
TextAlign (inherited from vdxTextBoxNumeric) | Overrides TextAlign to make default value Right.
TextIsNull (inherited from vdxTextBox) | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
TextLength (inherited from TextBoxBase) | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
WordWrap (inherited from vdxTextBoxNumeric) | This property is inherited and makes no sence here

Protected Instance Properties

CreateParams (inherited from TextBox) |
DefaultImeMode (inherited from TextBox) |
DefaultSize (inherited from TextBoxBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxTextBoxLong Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxLong.CheckDataBeforeUpdate Property

In this context always false and not browsable, because we assume that this control only will be bound to long typed data columns.

public override bool CheckDataBeforeUpdate {get; set;}

See Also

vdxTextBoxLong Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxLong.NullValue Property

Gets or sets the value used as null value. Default is 0D.

public long NullValue {get; set;}

See Also

vdxTextBoxLong Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxLong.NumericType Property

Gets the numeric type format identification used for range checking This property is overridden, because this control only supports long data type.

public override enNumericTypes NumericType {get;}

See Also

vdxTextBoxLong Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxLong.NumericValue Property

Returns the value of the textbox as decimal. If the value is null, the value of the NullValue property is returned

public long NumericValue {get; set;}

See Also

vdxTextBoxLong Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric Class

Represents TextBox control that accepts only numeric values. The type of the number may be specified by the property 'NumericType'. According to this type, only input of the appropriate type will be accepted. Additionally a Format string may be specified and used for formatting the textual representation ofthe number. The TextBox is able to convert numbers of the following types: Undefined = 0: No typ set (default of the NumericType property) Byte = 1: signed byte (8 bit) Short = 2: signed short (16 bit) Int = 3: signed int (32 bit) Long = 4: signed long (64 bit) Float = 5: float (4 byte) Double = 6: double (8 byte) Decimal = 7: decimal (128 bit, high percision floation point) UByte = 8: unsigned byte (8 bit) UShort = 9: unsigned short (16 bit) UInt = 10: unsigned int (32 bit) ULong = 11: unsigned long (64 bit) user = 100: User defined type. Use this type to indicate, that you are inheritting the control to manage a new type Note for inheritors: If you intend to process types not defined in the enNumericTypes enumeration, set the controls type to 'user' by overriding the NumericType property. Then you have to override the methods GetFormattedValue, GetTypeInfo and TryToConvert. For more details see the the summary of those methods.

For a list of all members of this type, see vdxTextBoxNumeric Members.

System.Object
MarshalByRefObject
Component
Control
TextBoxBase
TextBox
vdxTextBox
vdxTextBoxNumeric

public class vdxTextBoxNumeric : vdxTextBox

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxTextBoxNumeric Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric Members

vdxTextBoxNumeric overview

Public Instance Constructors

vdxTextBoxNumeric Constructor Initializes a new instance of the vdxTextBoxNumeric class. The TextChanged event is handled to check whether the text ican be converted into the actual type or not.

Public Instance Properties

AcceptsReturn (inherited from TextBox) | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.
AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from TextBoxBase) | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
BackColor (inherited from TextBoxBase) | Gets or sets the background color of the control.
BackgroundImage (inherited from TextBoxBase) |
BindEmptyValuesAsNull (inherited from vdxTextBox) | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CharacterCasing | This property is inherited and makes no sence here
CheckDataBeforeUpdate | Gets or sets whether the control to check if the data may be converted into the datacolumns type of the bound data tabel before storing the value in the data row. If the conversion fails, an exception is thrown.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TextBoxBase) | Gets or sets the foreground color of the control.
Format | Gets or sets the format expression used to format the textual representation of the numeric value" If a number of the actually set type cannot be formatted by the desired format string, the user will be informed by a maessage box and the format will not be set.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM (inherited from vdxTextBox) | Gets/sets a value indicating whether the TextBox interacts with the DSM. If set to true then the TextBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Lines | This property is inherited and makes no sence here
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxLength | This property is inherited and makes no sence here
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
Multiline | This property is inherited and makes no sence here
Name (inherited from Control) | Gets or sets the name of the control.
NumericType | Gets or sets the numeric type format identification used for range checking and formatting.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PasswordChar | This property is inherited and makes no sence here
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScrollBars (inherited from TextBox) | Gets or sets which scroll bars should appear in a multiline TextBox control.
SelectedText (inherited from TextBoxBase) | Gets or sets a value indicating the currently selected text in the control.
SelectionLength (inherited from TextBox) |
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Overload of the text property: We want to apply the format before setting the text of the control
TextAlign | Overrides TextAlign to make default value Right.
TextIsNull (inherited from vdxTextBox) | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
TextLength (inherited from TextBoxBase) | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
WordWrap | This property is inherited and makes no sence here

Public Instance Methods

AppendText (inherited from TextBoxBase) | Appends text to the current text of text box.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear (inherited from TextBoxBase) | Clears all text from the text box control.
ClearUndo (inherited from TextBoxBase) | Clears information about the most recent operation from the undo buffer of the text box.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
Copy (inherited from TextBoxBase) | Copies the current selection in the text box to the Clipboard.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Cut (inherited from TextBoxBase) | Moves the current selection in the text box to the Clipboard.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxTextBox) | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
Paste (inherited from TextBoxBase) | Replaces the current selection in the text box with the contents of the Clipboard.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollToCaret (inherited from TextBoxBase) | Scrolls the contents of the control to the current caret position.
Select (inherited from TextBoxBase) | Overloaded. Selects a range of text in the text box.
Select (inherited from Control) | Overloaded. Activates the control.
SelectAll (inherited from TextBoxBase) | Selects all text in the text box.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo (inherited from vdxTextBox) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TextBoxBase) |
Undo (inherited from TextBoxBase) | Undoes the last edit operation in the text box.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AcceptsTabChanged (inherited from TextBoxBase) | Occurs when the value of the AcceptsTab property has changed.
AutoSizeChanged (inherited from TextBoxBase) | Occurs when the value of the AutoSize property has changed.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from TextBoxBase) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
BorderStyleChanged (inherited from TextBoxBase) | Occurs when the value of the BorderStyle property has changed.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from TextBoxBase) | Occurs when the text box is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
HideSelectionChanged (inherited from TextBoxBase) | Occurs when the value of the HideSelection property has changed.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
ModifiedChanged (inherited from TextBoxBase) | Occurs when the value of the Modified property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
MultilineChanged (inherited from TextBoxBase) | Occurs when the value of the Multiline property has changed.
Paint (inherited from TextBoxBase) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
ReadOnlyChanged (inherited from TextBoxBase) | Occurs when the value of the ReadOnly property has changed.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextAlignChanged (inherited from TextBox) | Occurs when the value of the TextAlign property has changed.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

format The Format string of used to format the decimal value

Protected Instance Properties

CreateParams (inherited from TextBox) |
DefaultImeMode (inherited from TextBox) |
DefaultSize (inherited from TextBoxBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from TextBoxBase) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
FilterKey | Validates a key stroke and sets the Handled falg of the KeyPressEventArgs to true, if the key was invalid Note for inheritors: You should override this metod to accept additional keys for input.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetFormattedValue | Formats the object value according to the actual format If the format cannot be evaluated the original value is returned. Thes method is called by the Text property to format the text bevore storion it in the base class and by the Format property to check the format string. Note for inheritors: To support your own types, set the NumericType property to 'user'. Overrite this metod and implement your own conversion by parsion the string Val to the desired type.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GetTypeInfo | Evaluates whether the decimal pont and/or the sign indicator are used in numbers of the actual type. Note for inheritors: To support your own types, set the NumericType property to 'user'. Overrite this metod to set the flags AllowDecimal and AllowSign according to your type
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from TextBox) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAcceptsTabChanged (inherited from TextBoxBase) | Raises the AcceptsTabChanged event.
OnAutoSizeChanged (inherited from TextBoxBase) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnBorderStyleChanged (inherited from TextBoxBase) | Raises the BorderStyleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from TextBoxBase) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from TextBox) |
OnHandleCreated (inherited from TextBox) |
OnHandleDestroyed (inherited from TextBoxBase) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHideSelectionChanged (inherited from TextBoxBase) | Raise the HideSelectionChanged event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from vdxTextBox) | Raises the OnKeyDown event.
OnKeyPress | Overrides the OnKeyPress event of this control. The keys are filtered according to the actual numeric data type
OnKeyUp (inherited from vdxTextBox) | Raises the OnKeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnModifiedChanged (inherited from TextBoxBase) | Raises the ModifiedChanged event.
OnMouseDown (inherited from vdxTextBox) | Raises the OnMouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from vdxTextBox) | Raises the OnMouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnMultilineChanged (inherited from TextBoxBase) | Raises the MultilineChanged event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from TextBoxBase) | Raises the ReadOnlyChanged event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextAlignChanged (inherited from TextBox) | Raises the TextAlignChanged event.
OnTextChanged | This Event Listener makes sure that only correct strings (e.g. strings that can be converted into the actual numeric type) can be assigned to the text box. This is only done during runtime. While designtime, the the format will not be applied when the text changes
OnValidated | Overrides OnValidated to reformat the text.
OnValidating | Overrides OnValidating to reformat the text and to call the ValidateBindings method if the checkDataBeforeUpdate property is set.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from TextBoxBase) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from TextBoxBase) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
TryToConvert | Tries to convert the text to the actual numeric type. In case of an exception null is returned otherwise the result of the conversion Note for inheritors: To support your own types, set the NumericType property to 'user'. Overrite this metod to convert the text to the according type
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValidateBindings | This Method is called by the framework before writing the value to the data source when the CheckDataBeforeUpdate property have been set to true. The metod evaluates the data taype of the column bound to the control (the control must be bound to a DataTable). The evaluated type must have a static Parse method with a single string parameter. This metod is called to try to convert the text of the control into the data type of the column. If the conversion fails, an exception is thorwn, indication the table and column name, the data to convert and the target type. Note for inheritors: If you intend to bind your control to columns of a data type not implementing the Parse method, you can preform your own checking before writion down the value to the data source.
WndProc (inherited from TextBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IvdxInputControl.InitializeBinding (inherited from vdxTextBox) | Do any initializing work like converting format.
IvdxResettable.Reset (inherited from vdxTextBox) | Resets the value of the text box

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric Constructor

Initializes a new instance of the vdxTextBoxNumeric class. The TextChanged event is handled to check whether the text ican be converted into the actual type or not.

public vdxTextBoxNumeric();

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric Fields

The fields of the vdxTextBoxNumeric class are listed below. For a complete list of vdxTextBoxNumeric class members, see the vdxTextBoxNumeric Members topic.

Protected Instance Fields

format The Format string of used to format the decimal value

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.Format Property

Gets or sets the format expression used to format the textual representation of the numeric value" If a number of the actually set type cannot be formatted by the desired format string, the user will be informed by a maessage box and the format will not be set.

public virtual string Format {get; set;}

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric Properties

The properties of the vdxTextBoxNumeric class are listed below. For a complete list of vdxTextBoxNumeric class members, see the vdxTextBoxNumeric Members topic.

Public Instance Properties

AcceptsReturn (inherited from TextBox) | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.
AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from TextBoxBase) | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
BackColor (inherited from TextBoxBase) | Gets or sets the background color of the control.
BackgroundImage (inherited from TextBoxBase) |
BindEmptyValuesAsNull (inherited from vdxTextBox) | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CharacterCasing | This property is inherited and makes no sence here
CheckDataBeforeUpdate | Gets or sets whether the control to check if the data may be converted into the datacolumns type of the bound data tabel before storing the value in the data row. If the conversion fails, an exception is thrown.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos (inherited from vdxTextBox) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TextBoxBase) | Gets or sets the foreground color of the control.
Format | Gets or sets the format expression used to format the textual representation of the numeric value" If a number of the actually set type cannot be formatted by the desired format string, the user will be informed by a maessage box and the format will not be set.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM (inherited from vdxTextBox) | Gets/sets a value indicating whether the TextBox interacts with the DSM. If set to true then the TextBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Lines | This property is inherited and makes no sence here
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaxLength | This property is inherited and makes no sence here
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
Multiline | This property is inherited and makes no sence here
Name (inherited from Control) | Gets or sets the name of the control.
NumericType | Gets or sets the numeric type format identification used for range checking and formatting.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PasswordChar | This property is inherited and makes no sence here
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScrollBars (inherited from TextBox) | Gets or sets which scroll bars should appear in a multiline TextBox control.
SelectedText (inherited from TextBoxBase) | Gets or sets a value indicating the currently selected text in the control.
SelectionLength (inherited from TextBox) |
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Overload of the text property: We want to apply the format before setting the text of the control
TextAlign | Overrides TextAlign to make default value Right.
TextIsNull (inherited from vdxTextBox) | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
TextLength (inherited from TextBoxBase) | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
WordWrap | This property is inherited and makes no sence here

Protected Instance Properties

CreateParams (inherited from TextBox) |
DefaultImeMode (inherited from TextBox) |
DefaultSize (inherited from TextBoxBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.CharacterCasing Property

This property is inherited and makes no sence here

new public System.Windows.Forms.CharacterCasing CharacterCasing {get; set;}

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.CheckDataBeforeUpdate Property

Gets or sets whether the control to check if the data may be converted into the datacolumns type of the bound data tabel before storing the value in the data row. If the conversion fails, an exception is thrown.

public virtual bool CheckDataBeforeUpdate {get; set;}

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.Lines Property

This property is inherited and makes no sence here

new public string[] Lines {get; set;}

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.MaxLength Property

This property is inherited and makes no sence here

new public int MaxLength {get; set;}

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.Multiline Property

This property is inherited and makes no sence here

new public bool Multiline {get; set;}

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.NumericType Property

Gets or sets the numeric type format identification used for range checking and formatting.

public virtual enNumericTypes NumericType {get; set;}

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.PasswordChar Property

This property is inherited and makes no sence here

new public char PasswordChar {get; set;}

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.Text Property

Overload of the text property: We want to apply the format before setting the text of the control

new public string Text {get; set;}

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.TextAlign Property

Overrides TextAlign to make default value Right.

new public System.Windows.Forms.HorizontalAlignment TextAlign {get; set;}

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.WordWrap Property

This property is inherited and makes no sence here

new public bool WordWrap {get; set;}

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric Methods

The methods of the vdxTextBoxNumeric class are listed below. For a complete list of vdxTextBoxNumeric class members, see the vdxTextBoxNumeric Members topic.

Public Instance Methods

AppendText (inherited from TextBoxBase) | Appends text to the current text of text box.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear (inherited from TextBoxBase) | Clears all text from the text box control.
ClearUndo (inherited from TextBoxBase) | Clears information about the most recent operation from the undo buffer of the text box.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
Copy (inherited from TextBoxBase) | Copies the current selection in the text box to the Clipboard.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Cut (inherited from TextBoxBase) | Moves the current selection in the text box to the Clipboard.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxTextBox) | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
Paste (inherited from TextBoxBase) | Replaces the current selection in the text box with the contents of the Clipboard.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollToCaret (inherited from TextBoxBase) | Scrolls the contents of the control to the current caret position.
Select (inherited from TextBoxBase) | Overloaded. Selects a range of text in the text box.
Select (inherited from Control) | Overloaded. Activates the control.
SelectAll (inherited from TextBoxBase) | Selects all text in the text box.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo (inherited from vdxTextBox) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TextBoxBase) |
Undo (inherited from TextBoxBase) | Undoes the last edit operation in the text box.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from TextBoxBase) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
FilterKey | Validates a key stroke and sets the Handled falg of the KeyPressEventArgs to true, if the key was invalid Note for inheritors: You should override this metod to accept additional keys for input.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetFormattedValue | Formats the object value according to the actual format If the format cannot be evaluated the original value is returned. Thes method is called by the Text property to format the text bevore storion it in the base class and by the Format property to check the format string. Note for inheritors: To support your own types, set the NumericType property to 'user'. Overrite this metod and implement your own conversion by parsion the string Val to the desired type.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GetTypeInfo | Evaluates whether the decimal pont and/or the sign indicator are used in numbers of the actual type. Note for inheritors: To support your own types, set the NumericType property to 'user'. Overrite this metod to set the flags AllowDecimal and AllowSign according to your type
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from TextBox) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAcceptsTabChanged (inherited from TextBoxBase) | Raises the AcceptsTabChanged event.
OnAutoSizeChanged (inherited from TextBoxBase) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnBorderStyleChanged (inherited from TextBoxBase) | Raises the BorderStyleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from TextBoxBase) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from TextBox) |
OnHandleCreated (inherited from TextBox) |
OnHandleDestroyed (inherited from TextBoxBase) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHideSelectionChanged (inherited from TextBoxBase) | Raise the HideSelectionChanged event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from vdxTextBox) | Raises the OnKeyDown event.
OnKeyPress | Overrides the OnKeyPress event of this control. The keys are filtered according to the actual numeric data type
OnKeyUp (inherited from vdxTextBox) | Raises the OnKeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnModifiedChanged (inherited from TextBoxBase) | Raises the ModifiedChanged event.
OnMouseDown (inherited from vdxTextBox) | Raises the OnMouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from vdxTextBox) | Raises the OnMouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnMultilineChanged (inherited from TextBoxBase) | Raises the MultilineChanged event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from TextBoxBase) | Raises the ReadOnlyChanged event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextAlignChanged (inherited from TextBox) | Raises the TextAlignChanged event.
OnTextChanged | This Event Listener makes sure that only correct strings (e.g. strings that can be converted into the actual numeric type) can be assigned to the text box. This is only done during runtime. While designtime, the the format will not be applied when the text changes
OnValidated | Overrides OnValidated to reformat the text.
OnValidating | Overrides OnValidating to reformat the text and to call the ValidateBindings method if the checkDataBeforeUpdate property is set.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from TextBoxBase) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from TextBoxBase) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
TryToConvert | Tries to convert the text to the actual numeric type. In case of an exception null is returned otherwise the result of the conversion Note for inheritors: To support your own types, set the NumericType property to 'user'. Overrite this metod to convert the text to the according type
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValidateBindings | This Method is called by the framework before writing the value to the data source when the CheckDataBeforeUpdate property have been set to true. The metod evaluates the data taype of the column bound to the control (the control must be bound to a DataTable). The evaluated type must have a static Parse method with a single string parameter. This metod is called to try to convert the text of the control into the data type of the column. If the conversion fails, an exception is thorwn, indication the table and column name, the data to convert and the target type. Note for inheritors: If you intend to bind your control to columns of a data type not implementing the Parse method, you can preform your own checking before writion down the value to the data source.
WndProc (inherited from TextBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IvdxInputControl.InitializeBinding (inherited from vdxTextBox) | Do any initializing work like converting format.
IvdxResettable.Reset (inherited from vdxTextBox) | Resets the value of the text box

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.FilterKey Method

Validates a key stroke and sets the Handled falg of the KeyPressEventArgs to true, if the key was invalid Note for inheritors: You should override this metod to accept additional keys for input.

protected virtual void FilterKey(
KeyPressEventArgs e
);

Parameters

e

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.GetFormattedValue Method

Formats the object value according to the actual format If the format cannot be evaluated the original value is returned. Thes method is called by the Text property to format the text bevore storion it in the base class and by the Format property to check the format string. Note for inheritors: To support your own types, set the NumericType property to 'user'. Overrite this metod and implement your own conversion by parsion the string Val to the desired type.

protected virtual string GetFormattedValue(
string Val
);

Parameters

Val
Value to format

Return Value

formatted text

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.GetTypeInfo Method

Evaluates whether the decimal pont and/or the sign indicator are used in numbers of the actual type. Note for inheritors: To support your own types, set the NumericType property to 'user'. Overrite this metod to set the flags AllowDecimal and AllowSign according to your type

protected virtual void GetTypeInfo(
out bool AllowDecimal,
out bool AllowSign
);

Parameters

AllowDecimal
true when decimal point is accepted
AllowSign
true when sign character is accepted

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.OnKeyPress Method

Overrides the OnKeyPress event of this control. The keys are filtered according to the actual numeric data type

protected override void OnKeyPress(
KeyPressEventArgs e
);

Parameters

e
The event parameters.

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.OnTextChanged Method

This Event Listener makes sure that only correct strings (e.g. strings that can be converted into the actual numeric type) can be assigned to the text box. This is only done during runtime. While designtime, the the format will not be applied when the text changes

protected override void OnTextChanged(
EventArgs e
);

Parameters

e
The arguments of the event

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.OnValidated Method

Overrides OnValidated to reformat the text.

protected override void OnValidated(
EventArgs e
);

Parameters

e
A EventArgs that contains the event data.

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.OnValidating Method

Overrides OnValidating to reformat the text and to call the ValidateBindings method if the checkDataBeforeUpdate property is set.

protected override void OnValidating(
CancelEventArgs e
);

Parameters

e
A CancelEventArgs that contains the event data.

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.TryToConvert Method

Tries to convert the text to the actual numeric type. In case of an exception null is returned otherwise the result of the conversion Note for inheritors: To support your own types, set the NumericType property to 'user'. Overrite this metod to convert the text to the according type

protected virtual object TryToConvert(
string Text
);

Parameters

Text
the number as text

Return Value

null or teh converted value

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTextBoxNumeric.ValidateBindings Method

This Method is called by the framework before writing the value to the data source when the CheckDataBeforeUpdate property have been set to true. The metod evaluates the data taype of the column bound to the control (the control must be bound to a DataTable). The evaluated type must have a static Parse method with a single string parameter. This metod is called to try to convert the text of the control into the data type of the column. If the conversion fails, an exception is thorwn, indication the table and column name, the data to convert and the target type. Note for inheritors: If you intend to bind your control to columns of a data type not implementing the Parse method, you can preform your own checking before writion down the value to the data source.

protected virtual bool ValidateBindings();

Return Value

True if the value may be converted correctly

See Also

vdxTextBoxNumeric Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeNode Class

Represents a node in a vdxTreeView object.

For a list of all members of this type, see vdxTreeNode Members.

System.Object
MarshalByRefObject
TreeNode
vdxTreeNode

public class vdxTreeNode : TreeNode

Remarks

This is a spezialized .NET TreeNode to realize delayed data load. With the property HasChildren you can control the plus sign for a node. If HasChildren is set to true, the new node will also create a child node without data. Later, before the node will expand, the dummy child node will be removed.

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxTreeNode Members | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeNode Members

vdxTreeNode overview

Public Instance Constructors

vdxTreeNode Overloaded. Initializes a new instance of the vdxTreeNode class.

Public Instance Properties

BackColor (inherited from TreeNode) | Gets or sets the background color of the tree node.
Bounds (inherited from TreeNode) | Gets the bounds of the tree node.
Checked (inherited from TreeNode) | Gets or sets a value indicating whether the tree node is in a checked state.
FirstNode (inherited from TreeNode) | Gets the first child tree node in the tree node collection.
ForeColor (inherited from TreeNode) | Gets or sets the foreground color of the tree node.
FullPath (inherited from TreeNode) | Gets the path from the root tree node to the current tree node.
Handle (inherited from TreeNode) | Gets the handle of the tree node.
HasChildren | Gets or sets if the node has a dummy node or not.
ImageIndex (inherited from TreeNode) | Gets or sets the image list index value of the image displayed when the tree node is in the unselected state.
Index (inherited from TreeNode) | Gets the position of the tree node in the tree node collection.
IsEditing (inherited from TreeNode) | Gets a value indicating whether the tree node is in an editable state.
IsExpanded (inherited from TreeNode) | Gets a value indicating whether the tree node is in the expanded state.
IsSelected (inherited from TreeNode) | Gets a value indicating whether the tree node is in the selected state.
IsVisible (inherited from TreeNode) | Gets a value indicating whether the tree node is visible.
LastNode (inherited from TreeNode) | Gets the last child tree node.
NextNode (inherited from TreeNode) | Gets the next sibling tree node.
NextVisibleNode (inherited from TreeNode) | Gets the next visible tree node.
NodeFont (inherited from TreeNode) | Gets or sets the font used to display the text on the tree node's label.
Nodes (inherited from TreeNode) | Gets the collection of TreeNode objects assigned to the current tree node.
Parent (inherited from TreeNode) | Gets the parent tree node of the current tree node.
PrevNode (inherited from TreeNode) | Gets the previous sibling tree node.
PrevVisibleNode (inherited from TreeNode) | Gets the previous visible tree node.
RefreshKey | Gets the key to compare two vdxTreeNode during refresh.
SelectedImageIndex (inherited from TreeNode) | Gets or sets the image list index value of the image that is displayed when the tree node is in the selected state.
Tag (inherited from TreeNode) | Gets or sets the object that contains data about the tree node.
Text (inherited from TreeNode) | Gets or sets the text displayed in the label of the tree node.
TreeView (inherited from TreeNode) | Gets the parent tree view that the tree node is assigned to.

Public Instance Methods

BeginEdit (inherited from TreeNode) | Initiates the editing of the tree node label.
Clone (inherited from TreeNode) | Copies the tree node and the entire subtree rooted at this tree node.
Collapse (inherited from TreeNode) | Collapses the tree node.
CopyFrom | Copy the node text from the source node into this text property.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
EndEdit (inherited from TreeNode) | Ends the editing of the tree node label.
EnsureVisible (inherited from TreeNode) | Ensures that the tree node is visible, expanding tree nodes and scrolling the tree view control as necessary.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from TreeNode) | Expands the tree node.
ExpandAll (inherited from TreeNode) | Expands all the child tree nodes.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNodeCount (inherited from TreeNode) | Returns the number of child tree nodes.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Remove (inherited from TreeNode) | Removes the current tree node from the tree view control.
Toggle (inherited from TreeNode) | Toggles the tree node to either the expanded or collapsed state.
ToString (inherited from TreeNode) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

ISerializable.GetObjectData (inherited from TreeNode)

See Also

vdxTreeNode Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeNode Constructor

Initializes a new instance of the vdxTreeNode class.

Overload List

Initializes a new instance of the vdxTreeNode class.

public vdxTreeNode(string,int);

Initializes a new instance of the vdxTreeNode class.

public vdxTreeNode(string,int,bool);

Initializes a new instance of the vdxTreeNode class.

public vdxTreeNode(string,int,bool,object);

Initializes a new instance of the vdxTreeNode class.

public vdxTreeNode(string,int,int);

Initializes a new instance of the vdxTreeNode class.

public vdxTreeNode(string,int,int,bool);

Initializes a new instance of the vdxTreeNode class.

public vdxTreeNode(string,int,int,bool,object);

See Also

vdxTreeNode Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeNode Constructor (String, Int32, Int32, Boolean, Object)

Initializes a new instance of the vdxTreeNode class.

public vdxTreeNode(
string text,
int imageIndex,
int selectedImageIndex,
bool hasChildren,
object refreshKey
);

Parameters

text
The caption of the TreeNode.
imageIndex
The imageIndex of the unselected TreeNode.
selectedImageIndex
The imageIndex of the selected TreeNode.
hasChildren
True if it has a sub dummy node.
refreshKey
Key to compare two vdxTreeNodes during refresh.

See Also

vdxTreeNode Class | Deag.Vdx.Controls.Base Namespace | vdxTreeNode Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeNode Constructor (String, Int32, Int32, Boolean)

Initializes a new instance of the vdxTreeNode class.

public vdxTreeNode(
string text,
int imageIndex,
int selectedImageIndex,
bool hasChildren
);

Parameters

text
The caption of the TreeNode.
imageIndex
The imageIndex of the unselected TreeNode.
selectedImageIndex
The imageIndex of the selected TreeNode.
hasChildren
True if it has a sub dummy node.

See Also

vdxTreeNode Class | Deag.Vdx.Controls.Base Namespace | vdxTreeNode Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeNode Constructor (String, Int32, Boolean)

Initializes a new instance of the vdxTreeNode class.

public vdxTreeNode(
string text,
int imageIndex,
bool hasChildren
);

Parameters

text
The caption of the TreeNode.
imageIndex
The imageIndex of the unselected TreeNode.
hasChildren
True if it has a sub dummy node.

See Also

vdxTreeNode Class | Deag.Vdx.Controls.Base Namespace | vdxTreeNode Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeNode Constructor (String, Int32, Boolean, Object)

Initializes a new instance of the vdxTreeNode class.

public vdxTreeNode(
string text,
int imageIndex,
bool hasChildren,
object refreshKey
);

Parameters

text
The caption of the TreeNode.
imageIndex
The imageIndex of the unselected TreeNode.
hasChildren
True if it has a sub dummy node.
refreshKey
Key to compare two vdxTreeNodes during refresh.

See Also

vdxTreeNode Class | Deag.Vdx.Controls.Base Namespace | vdxTreeNode Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeNode Constructor (String, Int32, Int32)

Initializes a new instance of the vdxTreeNode class.

public vdxTreeNode(
string text,
int imageIndex,
int selectedImageIndex
);

Parameters

text
The caption of the TreeNode.
imageIndex
The imageIndex of the unselected TreeNode.
selectedImageIndex
The imageIndex of the selected TreeNode.

See Also

vdxTreeNode Class | Deag.Vdx.Controls.Base Namespace | vdxTreeNode Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeNode Constructor (String, Int32)

Initializes a new instance of the vdxTreeNode class.

public vdxTreeNode(
string text,
int imageIndex
);

Parameters

text
The caption of the TreeNode.
imageIndex
The imageIndex of the unselected TreeNode.

See Also

vdxTreeNode Class | Deag.Vdx.Controls.Base Namespace | vdxTreeNode Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeNode Properties

The properties of the vdxTreeNode class are listed below. For a complete list of vdxTreeNode class members, see the vdxTreeNode Members topic.

Public Instance Properties

BackColor (inherited from TreeNode) | Gets or sets the background color of the tree node.
Bounds (inherited from TreeNode) | Gets the bounds of the tree node.
Checked (inherited from TreeNode) | Gets or sets a value indicating whether the tree node is in a checked state.
FirstNode (inherited from TreeNode) | Gets the first child tree node in the tree node collection.
ForeColor (inherited from TreeNode) | Gets or sets the foreground color of the tree node.
FullPath (inherited from TreeNode) | Gets the path from the root tree node to the current tree node.
Handle (inherited from TreeNode) | Gets the handle of the tree node.
HasChildren | Gets or sets if the node has a dummy node or not.
ImageIndex (inherited from TreeNode) | Gets or sets the image list index value of the image displayed when the tree node is in the unselected state.
Index (inherited from TreeNode) | Gets the position of the tree node in the tree node collection.
IsEditing (inherited from TreeNode) | Gets a value indicating whether the tree node is in an editable state.
IsExpanded (inherited from TreeNode) | Gets a value indicating whether the tree node is in the expanded state.
IsSelected (inherited from TreeNode) | Gets a value indicating whether the tree node is in the selected state.
IsVisible (inherited from TreeNode) | Gets a value indicating whether the tree node is visible.
LastNode (inherited from TreeNode) | Gets the last child tree node.
NextNode (inherited from TreeNode) | Gets the next sibling tree node.
NextVisibleNode (inherited from TreeNode) | Gets the next visible tree node.
NodeFont (inherited from TreeNode) | Gets or sets the font used to display the text on the tree node's label.
Nodes (inherited from TreeNode) | Gets the collection of TreeNode objects assigned to the current tree node.
Parent (inherited from TreeNode) | Gets the parent tree node of the current tree node.
PrevNode (inherited from TreeNode) | Gets the previous sibling tree node.
PrevVisibleNode (inherited from TreeNode) | Gets the previous visible tree node.
RefreshKey | Gets the key to compare two vdxTreeNode during refresh.
SelectedImageIndex (inherited from TreeNode) | Gets or sets the image list index value of the image that is displayed when the tree node is in the selected state.
Tag (inherited from TreeNode) | Gets or sets the object that contains data about the tree node.
Text (inherited from TreeNode) | Gets or sets the text displayed in the label of the tree node.
TreeView (inherited from TreeNode) | Gets the parent tree view that the tree node is assigned to.

See Also

vdxTreeNode Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeNode.HasChildren Property

Gets or sets if the node has a dummy node or not.

public bool HasChildren {get; set;}

See Also

vdxTreeNode Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeNode.RefreshKey Property

Gets the key to compare two vdxTreeNode during refresh.

public object RefreshKey {get;}

See Also

vdxTreeNode Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeNode Methods

The methods of the vdxTreeNode class are listed below. For a complete list of vdxTreeNode class members, see the vdxTreeNode Members topic.

Public Instance Methods

BeginEdit (inherited from TreeNode) | Initiates the editing of the tree node label.
Clone (inherited from TreeNode) | Copies the tree node and the entire subtree rooted at this tree node.
Collapse (inherited from TreeNode) | Collapses the tree node.
CopyFrom | Copy the node text from the source node into this text property.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
EndEdit (inherited from TreeNode) | Ends the editing of the tree node label.
EnsureVisible (inherited from TreeNode) | Ensures that the tree node is visible, expanding tree nodes and scrolling the tree view control as necessary.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from TreeNode) | Expands the tree node.
ExpandAll (inherited from TreeNode) | Expands all the child tree nodes.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNodeCount (inherited from TreeNode) | Returns the number of child tree nodes.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Remove (inherited from TreeNode) | Removes the current tree node from the tree view control.
Toggle (inherited from TreeNode) | Toggles the tree node to either the expanded or collapsed state.
ToString (inherited from TreeNode) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

ISerializable.GetObjectData (inherited from TreeNode)

See Also

vdxTreeNode Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeNode.CopyFrom Method

Copy the node text from the source node into this text property.

public virtual void CopyFrom(
vdxTreeNode sourceNode
);

Parameters

sourceNode
Node that contains the data to copy.

Remarks

If you desired to copy more properties, override the method in your own vdxTreeNode class.

See Also

vdxTreeNode Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView Class

Displays a hierarchical collection of labeled items, each represented by a vdxTreeNode or a .Net TreeNode.

For a list of all members of this type, see vdxTreeView Members.

System.Object
MarshalByRefObject
Component
Control
TreeView
vdxTreeView

public class vdxTreeView : TreeView, IvdxNavigator, IvdxBindable

Remarks

This treeView implements the interface IvdxNavigator to be used in vdxExplorer context. The communication is bi-directional, the explorer command the treeView to build himself with the given DataSet. In the other hand the explorer is informed about selection changes of the navigators he contains.

Requirements

Namespace: Deag.Vdx.Controls.Base

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxTreeView Members | Deag.Vdx.Controls.Base Namespace | TreeView | IvdxNavigator

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView Members

vdxTreeView overview

Public Instance Constructors

vdxTreeView Constructor Initializes a new instance of the vdxTreeView class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from TreeView) |
BackgroundImage (inherited from TreeView) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from TreeView) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CheckBoxes (inherited from TreeView) | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TreeView) |
FullRowSelect (inherited from TreeView) | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TreeView) | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus.
HotTracking (inherited from TreeView) | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it.
ImageIndex (inherited from TreeView) | Gets or sets the image-list index value of the default image that is displayed by the tree nodes.
ImageList (inherited from TreeView) | Gets or sets the ImageList that contains the Image objects used by the tree nodes.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
Indent (inherited from TreeView) | Gets or sets the distance to indent each of the child tree node levels.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from TreeView) | Gets or sets the height of each tree node in the tree view control.
LabelEdit (inherited from TreeView) | Gets or sets a value indicating whether the label text of the tree nodes can be edited.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Nodes (inherited from TreeView) | Gets the collection of tree nodes that are assigned to the tree view control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PathSeparator (inherited from TreeView) | Gets or sets the delimiter string that the tree node path uses.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
RefreshAlgorithm | Gets or sets the algorithm to expand nodes after refresh.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Scrollable (inherited from TreeView) | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed.
SelectedImageIndex (inherited from TreeView) | Gets or sets the image list index value of the image that is displayed when a tree node is selected.
SelectedNode (inherited from TreeView) | Gets or sets the tree node that is currently selected in the tree view control.
ShowLines (inherited from TreeView) | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control.
ShowPlusMinus (inherited from TreeView) | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes.
ShowRootLines (inherited from TreeView) | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from TreeView) | Gets or sets a value indicating whether the tree nodes in the tree view are sorted.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from TreeView) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopNode (inherited from TreeView) | Gets the first fully-visible tree node in the tree view control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisibleCount (inherited from TreeView) | Gets the number of tree nodes that can be fully visible in the tree view control.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from TreeView) | Disables any redrawing of the tree view.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear | Remove all nodes from the tree.
CollapseAll (inherited from TreeView) | Collapses all the tree nodes.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from TreeView) | Enables the redrawing of the tree view.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandAll (inherited from TreeView) | Expands all the tree nodes.
Fill | Overloaded. Builds the first level of the tree.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetNodeAt (inherited from TreeView) | Overloaded. Retrieves the tree node that is at the specified point.
GetNodeCount (inherited from TreeView) | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control.
GetTreeNode | Overloaded. Gets the corresponding TreeNode for the given DataRow.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RefreshData | Remove all elements from the navigator and fill up the given dataSet.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectDefault | Selects the default element.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TreeView) |
Update (inherited from Control) | Overloaded. Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AfterCheck (inherited from TreeView) | Occurs after the tree node check box is checked.
AfterCollapse (inherited from TreeView) | Occurs after the tree node is collapsed.
AfterExpand (inherited from TreeView) | Occurs after the tree node is expanded.
AfterLabelEdit (inherited from TreeView) | Occurs after the tree node label text is edited.
AfterSelect (inherited from TreeView) | Occurs after the tree node is selected.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from TreeView) |
BeforeCheck (inherited from TreeView) | Occurs before the tree node check box is checked.
BeforeCollapse (inherited from TreeView) | Occurs before the tree node is collapsed.
BeforeExpand (inherited from TreeView) | Occurs before the tree node is expanded.
BeforeLabelEdit (inherited from TreeView) | Occurs before the tree node label text is edited.
BeforeSelect (inherited from TreeView) | Occurs before the tree node is selected.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlChanged | Occurs when an other cacheable control had to be shown.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
ItemDrag (inherited from TreeView) | Occurs when an item is dragged into the tree view control.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from TreeView) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectionChanged | Occurs when an other DataRow was selected.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from TreeView) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from TreeView) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from TreeView) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AddNode | Overloaded. Adds a node to the given parent node.
AddNodeToTree | Adds a node to the given parent node.
ChangeSelection | Changes current selection to the row corresponding treeNode.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from TreeView) |
CreateNavigatorInfoItem | Creates a vdxNavigatorInfoItem for the given dataRow.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
Delete | Overloaded. Deletes the given node.
DesiredTable | Gets the desired table in the dataSet for the corresponding searchParameters.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from TreeView) | Overloaded.
ExpandTreeNodesAfterRefresh | Expands recursively all corresponding TreeNodes.
Fill | Overloaded. Builds the sub nodes for the given treeNode.
FillSubTree | Builds child nodes for parent node.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GenerateSubNodeSearchParameters | Generates vdxSearchParameters to load subnodes.
GetAllTreeNodesToExpand | Gets all TreeNodes that are expanded.
GetItemRenderStyles (inherited from TreeView) |
GetLoaderInfo | Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.
GetNavigatorInfo | Gets the corresponding navigation info for the given item.
GetNavigatorInfoItem | Gets the corresponding DataRow for the given TreeNode.
GetNodeToSelectAfterDelete | Gets the node to select after deleting an node.
GetNoneTreeNodeToExpand | Gets an empty collection that expand no TreeNodes.
GetSelectedTreeNodeToExpand | Gets only the expanded TreeNode hierarchy of the selected node.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GetTopTreeNode | Gets the top level node for the given treeNode.
GetTreeNode | Overloaded. Creates a vdxTreeNode for the given DataRow.
GetTreeNodeInfo | Gets the text and image information to build a treeNode.
GetTreeNodeKey | Gets an unique key to differ TreeNodes on the same hierarchy level.
GetTreeNodesToExpandAfterRefresh | Gets all TreeNodes that are expanded depending on RefreshAlgorithmType.
InitLayout (inherited from Control) | Called after the control has been added to another container.
Insert | Inserts a new treeNode for the corresponding row.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from TreeView) |
IsRefreshable | Checks if the component supports refresh.
LoadData | Loads data for the given search parameters.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAfterCheck (inherited from TreeView) | Raises the AfterCheck event.
OnAfterCollapse (inherited from TreeView) | Raises the AfterCollapse event.
OnAfterExpand (inherited from TreeView) | Raises the AfterExpand event.
OnAfterLabelEdit (inherited from TreeView) | Raises the AfterLabelEdit event.
OnAfterSelect (inherited from TreeView) | Raises the AfterSelect event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBeforeCheck (inherited from TreeView) | Raises the BeforeCheck event.
OnBeforeCollapse (inherited from TreeView) | Raises the BeforeCollapse event.
OnBeforeExpand (inherited from TreeView) | Raises the BeforeExpand event.
OnBeforeLabelEdit (inherited from TreeView) | Raises the BeforeLabelEdit event.
OnBeforeSelect (inherited from TreeView) | Raises the BeforeSelect event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlChanged | Inform all registered components on ControlChanged about a control change.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from TreeView) |
OnHandleDestroyed (inherited from TreeView) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnItemDrag (inherited from TreeView) | Raises the ItemDrag event.
OnKeyDown (inherited from TreeView) |
OnKeyPress (inherited from TreeView) |
OnKeyUp (inherited from TreeView) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSelectionChanged | Inform all registered components on SelectionChanged about a selection change.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
Undo | Undo changes for the corresponding navigatorDataRow.
Update | Overloaded. Updates the node for given vdxNavigatorInfo.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from TreeView) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IvdxNavigator.ChangeSelection
IvdxNavigator.Clear
IvdxNavigator.Copy
IvdxNavigator.Delete
IvdxNavigator.Fill
IvdxNavigator.GetLoaderInfo
IvdxNavigator.Insert
IvdxNavigator.IsRefreshable
IvdxNavigator.RefreshData
IvdxNavigator.Undo
IvdxNavigator.Update

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace | TreeView | IvdxNavigator

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView Constructor

Initializes a new instance of the vdxTreeView class.

public vdxTreeView();

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView Properties

The properties of the vdxTreeView class are listed below. For a complete list of vdxTreeView class members, see the vdxTreeView Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from TreeView) |
BackgroundImage (inherited from TreeView) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from TreeView) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CheckBoxes (inherited from TreeView) | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TreeView) |
FullRowSelect (inherited from TreeView) | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TreeView) | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus.
HotTracking (inherited from TreeView) | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it.
ImageIndex (inherited from TreeView) | Gets or sets the image-list index value of the default image that is displayed by the tree nodes.
ImageList (inherited from TreeView) | Gets or sets the ImageList that contains the Image objects used by the tree nodes.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
Indent (inherited from TreeView) | Gets or sets the distance to indent each of the child tree node levels.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from TreeView) | Gets or sets the height of each tree node in the tree view control.
LabelEdit (inherited from TreeView) | Gets or sets a value indicating whether the label text of the tree nodes can be edited.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Nodes (inherited from TreeView) | Gets the collection of tree nodes that are assigned to the tree view control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PathSeparator (inherited from TreeView) | Gets or sets the delimiter string that the tree node path uses.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
RefreshAlgorithm | Gets or sets the algorithm to expand nodes after refresh.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Scrollable (inherited from TreeView) | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed.
SelectedImageIndex (inherited from TreeView) | Gets or sets the image list index value of the image that is displayed when a tree node is selected.
SelectedNode (inherited from TreeView) | Gets or sets the tree node that is currently selected in the tree view control.
ShowLines (inherited from TreeView) | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control.
ShowPlusMinus (inherited from TreeView) | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes.
ShowRootLines (inherited from TreeView) | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from TreeView) | Gets or sets a value indicating whether the tree nodes in the tree view are sorted.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from TreeView) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopNode (inherited from TreeView) | Gets the first fully-visible tree node in the tree view control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisibleCount (inherited from TreeView) | Gets the number of tree nodes that can be fully visible in the tree view control.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from TreeView) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from TreeView) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace | TreeView | IvdxNavigator

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.RefreshAlgorithm Property

Gets or sets the algorithm to expand nodes after refresh.

public RefreshAlgorithmType RefreshAlgorithm {get; set;}

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView Methods

The methods of the vdxTreeView class are listed below. For a complete list of vdxTreeView class members, see the vdxTreeView Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from TreeView) | Disables any redrawing of the tree view.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear | Remove all nodes from the tree.
CollapseAll (inherited from TreeView) | Collapses all the tree nodes.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from TreeView) | Enables the redrawing of the tree view.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandAll (inherited from TreeView) | Expands all the tree nodes.
Fill | Overloaded. Builds the first level of the tree.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetNodeAt (inherited from TreeView) | Overloaded. Retrieves the tree node that is at the specified point.
GetNodeCount (inherited from TreeView) | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control.
GetTreeNode | Overloaded. Gets the corresponding TreeNode for the given DataRow.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RefreshData | Remove all elements from the navigator and fill up the given dataSet.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectDefault | Selects the default element.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TreeView) |
Update (inherited from Control) | Overloaded. Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AddNode | Overloaded. Adds a node to the given parent node.
AddNodeToTree | Adds a node to the given parent node.
ChangeSelection | Changes current selection to the row corresponding treeNode.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from TreeView) |
CreateNavigatorInfoItem | Creates a vdxNavigatorInfoItem for the given dataRow.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
Delete | Overloaded. Deletes the given node.
DesiredTable | Gets the desired table in the dataSet for the corresponding searchParameters.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from TreeView) | Overloaded.
ExpandTreeNodesAfterRefresh | Expands recursively all corresponding TreeNodes.
Fill | Overloaded. Builds the sub nodes for the given treeNode.
FillSubTree | Builds child nodes for parent node.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GenerateSubNodeSearchParameters | Generates vdxSearchParameters to load subnodes.
GetAllTreeNodesToExpand | Gets all TreeNodes that are expanded.
GetItemRenderStyles (inherited from TreeView) |
GetLoaderInfo | Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.
GetNavigatorInfo | Gets the corresponding navigation info for the given item.
GetNavigatorInfoItem | Gets the corresponding DataRow for the given TreeNode.
GetNodeToSelectAfterDelete | Gets the node to select after deleting an node.
GetNoneTreeNodeToExpand | Gets an empty collection that expand no TreeNodes.
GetSelectedTreeNodeToExpand | Gets only the expanded TreeNode hierarchy of the selected node.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GetTopTreeNode | Gets the top level node for the given treeNode.
GetTreeNode | Overloaded. Creates a vdxTreeNode for the given DataRow.
GetTreeNodeInfo | Gets the text and image information to build a treeNode.
GetTreeNodeKey | Gets an unique key to differ TreeNodes on the same hierarchy level.
GetTreeNodesToExpandAfterRefresh | Gets all TreeNodes that are expanded depending on RefreshAlgorithmType.
InitLayout (inherited from Control) | Called after the control has been added to another container.
Insert | Inserts a new treeNode for the corresponding row.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from TreeView) |
IsRefreshable | Checks if the component supports refresh.
LoadData | Loads data for the given search parameters.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAfterCheck (inherited from TreeView) | Raises the AfterCheck event.
OnAfterCollapse (inherited from TreeView) | Raises the AfterCollapse event.
OnAfterExpand (inherited from TreeView) | Raises the AfterExpand event.
OnAfterLabelEdit (inherited from TreeView) | Raises the AfterLabelEdit event.
OnAfterSelect (inherited from TreeView) | Raises the AfterSelect event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBeforeCheck (inherited from TreeView) | Raises the BeforeCheck event.
OnBeforeCollapse (inherited from TreeView) | Raises the BeforeCollapse event.
OnBeforeExpand (inherited from TreeView) | Raises the BeforeExpand event.
OnBeforeLabelEdit (inherited from TreeView) | Raises the BeforeLabelEdit event.
OnBeforeSelect (inherited from TreeView) | Raises the BeforeSelect event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlChanged | Inform all registered components on ControlChanged about a control change.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from TreeView) |
OnHandleDestroyed (inherited from TreeView) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnItemDrag (inherited from TreeView) | Raises the ItemDrag event.
OnKeyDown (inherited from TreeView) |
OnKeyPress (inherited from TreeView) |
OnKeyUp (inherited from TreeView) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSelectionChanged | Inform all registered components on SelectionChanged about a selection change.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
Undo | Undo changes for the corresponding navigatorDataRow.
Update | Overloaded. Updates the node for given vdxNavigatorInfo.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from TreeView) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IvdxNavigator.ChangeSelection
IvdxNavigator.Clear
IvdxNavigator.Copy
IvdxNavigator.Delete
IvdxNavigator.Fill
IvdxNavigator.GetLoaderInfo
IvdxNavigator.Insert
IvdxNavigator.IsRefreshable
IvdxNavigator.RefreshData
IvdxNavigator.Undo
IvdxNavigator.Update

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace | TreeView | IvdxNavigator

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AddNode Method

VDX Framework

vdxTreeView.AddNode Method

Adds a node to the given parent node.

Overload List

Adds a node to the given parent node.

protected void AddNode(vdxNavigatorInfoItem,vdxTreeNode,vdxTreeNode);

Adds a node to the given parent node.

protected void AddNode(vdxNavigatorInfoItem,vdxTreeNode,vdxTreeNode,int);

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.AddNode Method (vdxNavigatorInfoItem, vdxTreeNode, vdxTreeNode)

Adds a node to the given parent node.

protected void AddNode(
vdxNavigatorInfoItem navInfoItem,
vdxTreeNode treeNode,
vdxTreeNode parentNode
);

Parameters

navInfoItem
Represents the node to be added.
treeNode
The node to be added.
parentNode
The parent node where the node will be added.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace | vdxTreeView.AddNode Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.AddNode Method (vdxNavigatorInfoItem, vdxTreeNode, vdxTreeNode, Int32)

Adds a node to the given parent node.

protected void AddNode(
vdxNavigatorInfoItem navInfoItem,
vdxTreeNode treeNode,
vdxTreeNode parentNode,
int index
);

Parameters

navInfoItem
Represents the node to be added.
treeNode
The node to be added.
parentNode
The parent node where the node will be added.
index
The position, where the treeNode will be inserted.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace | vdxTreeView.AddNode Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.AddNodeToTree Method

Adds a node to the given parent node.

protected virtual void AddNodeToTree(
vdxTreeNode treeNode,
vdxTreeNode parentNode,
int index
);

Parameters

treeNode
The node to be added.
parentNode
The parent node where the node will be added.
index
The position, where the treeNode will be inserted.

Remarks

Never call this method, call AddNode instead.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.ChangeSelection Method

Changes current selection to the row corresponding treeNode.

protected virtual void ChangeSelection(
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorInfo
Represents the node which will selected.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.Clear Method

Remove all nodes from the tree.

public virtual void Clear();

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.CreateNavigatorInfoItem Method

Creates a vdxNavigatorInfoItem for the given dataRow.

protected virtual vdxNavigatorInfoItem CreateNavigatorInfoItem(
DataRow dataRow
);

Parameters

dataRow
The row which will be encapsulated in the vdxNavigatorInfoItem.

Return Value

The created vdxNavigatorInfoItem.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.IvdxNavigator.ChangeSelection Method

void IvdxNavigator.ChangeSelection(
vdxNavigatorInfo navigatorInfo
);

Implements

IvdxNavigator.ChangeSelection

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.IvdxNavigator.Clear Method

void IvdxNavigator.Clear();

Implements

IvdxNavigator.Clear

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.IvdxNavigator.Copy Method

void IvdxNavigator.Copy(
DataRow navigatorDataRow,
vdxNavigatorInfo navigatorInfo
);

Implements

IvdxNavigator.Copy

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.IvdxNavigator.Delete Method

void IvdxNavigator.Delete(
vdxNavigatorInfo navigatorInfo
);

Implements

IvdxNavigator.Delete

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.IvdxNavigator.Fill Method

void IvdxNavigator.Fill(
DataSet dataSet
);

Implements

IvdxNavigator.Fill

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.IvdxNavigator.GetLoaderInfo Method

vdxLoaderInfo IvdxNavigator.GetLoaderInfo(
vdxNavigatorInfo navigatorInfo
);

Implements

IvdxNavigator.GetLoaderInfo

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.IvdxNavigator.Insert Method

void IvdxNavigator.Insert(
DataRow navigatorDataRow,
vdxNavigatorInfo navigatorInfo
);

Implements

IvdxNavigator.Insert

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.IvdxNavigator.IsRefreshable Method

bool IvdxNavigator.IsRefreshable();

Implements

IvdxNavigator.IsRefreshable

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.IvdxNavigator.RefreshData Method

vdxNavigatorInfo IvdxNavigator.RefreshData(
DataSet dataSet
);

Implements

IvdxNavigator.RefreshData

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.IvdxNavigator.Undo Method

void IvdxNavigator.Undo(
vdxNavigatorInfo navigatorInfo
);

Implements

IvdxNavigator.Undo

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.IvdxNavigator.Update Method

void IvdxNavigator.Update(
DataRow navigatorDataRow,
vdxNavigatorInfo navigatorInfo
);

Implements

IvdxNavigator.Update

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Delete Method

VDX Framework

vdxTreeView.Delete Method

Deletes the given node.

Overload List

Deletes the given node.

protected virtual void Delete(vdxNavigatorInfo);

Deletes the given node.

protected virtual void Delete(vdxNavigatorInfoItem);

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.Delete Method (vdxNavigatorInfo)

Deletes the given node.

protected virtual void Delete(
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorInfo
The last selected navigator info.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace | vdxTreeView.Delete Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.Delete Method (vdxNavigatorInfoItem)

Deletes the given node.

protected virtual void Delete(
vdxNavigatorInfoItem navigatorInfoItem
);

Parameters

navigatorInfoItem
The last selected navigator info item.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace | vdxTreeView.Delete Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.DesiredTable Method

Gets the desired table in the dataSet for the corresponding searchParameters.

protected virtual DataTable DesiredTable(
DataSet dataSet
);

Parameters

dataSet
The dataSet, which holds the table(s).

Return Value

The table corresponding to the searchParameter.

Remarks

Default table is the first one in the dataSet.

dataSet.Tables[0]
Is called in the Fill method to define from which table the rows had to be extracted.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.ExpandTreeNodesAfterRefresh Method

Expands recursively all corresponding TreeNodes.

protected virtual void ExpandTreeNodesAfterRefresh(
IList expandedNodes,
TreeNodeCollection treeNodeCollection
);

Parameters

expandedNodes
treeNodeCollection

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Fill Method

VDX Framework

vdxTreeView.Fill Method

Builds the sub nodes for the given treeNode.

Overload List

Builds the sub nodes for the given treeNode.

protected virtual void Fill(vdxTreeNode);

Builds the first level of the tree.

public virtual void Fill(DataSet);

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.Fill Method (vdxTreeNode)

Builds the sub nodes for the given treeNode.

protected virtual void Fill(
vdxTreeNode parentNode
);

Parameters

parentNode
The parent treeNode

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace | vdxTreeView.Fill Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.Fill Method (DataSet)

Builds the first level of the tree.

public virtual void Fill(
DataSet dataSet
);

Parameters

dataSet
The dataSet, which the navigator extract all rows out of.

Remarks

The other levels are build, after a treeNode is expanded.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace | vdxTreeView.Fill Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.FillSubTree Method

Builds child nodes for parent node.

protected virtual void FillSubTree(
DataSet dataSet,
vdxTreeNode parentNode,
vdxSearchParameters searchParameters
);

Parameters

dataSet
The dataSet, to extract the DataRow out of.
parentNode
The node, which the created child nodes will be added to.
searchParameters
The search parameters, to extract the desired table name.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.GenerateSubNodeSearchParameters Method

Generates vdxSearchParameters to load subnodes.

protected virtual vdxSearchParameters GenerateSubNodeSearchParameters(
vdxNavigatorInfoItem navInfoItem
);

Parameters

navInfoItem
The row, which contains information to build the searchParameters.

Return Value

The corresponding searchParameters for the given row.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.GetAllTreeNodesToExpand Method

Gets all TreeNodes that are expanded.

protected IList GetAllTreeNodesToExpand(
TreeNodeCollection treeNodeCollection
);

Return Value

A list with all TreeNode keys to expand.

Remarks

The hierarchy is completely affected. Possible collection can be. nodeKey1, nodeKey4, etc. nodeKey6, nodeKey9, etc.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.GetLoaderInfo Method

Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.

protected virtual vdxLoaderInfo GetLoaderInfo(
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorInfo
Contains the DataRow to define the vdxLoaderInfo.

Return Value

The vdxLoaderInfo for the given navigatorInfo.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.GetNavigatorInfo Method

Gets the corresponding navigation info for the given item.

protected virtual vdxNavigatorInfo GetNavigatorInfo(
vdxTreeNode treeNode
);

Parameters

treeNode
The specialized element of this navigator.

Return Value

The general communication object between the navigators.

Remarks

Used as eventArgs for vdxNavigatorSelectionEventHandler.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.GetNavigatorInfoItem Method

Gets the corresponding DataRow for the given TreeNode.

protected vdxNavigatorInfoItem GetNavigatorInfoItem(
TreeNode treeNode
);

Parameters

treeNode
The key to search the wanted dataRow.

Return Value

Corresponding dataRow for the given treeNode.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.GetNodeToSelectAfterDelete Method

Gets the node to select after deleting an node.

protected virtual TreeNode GetNodeToSelectAfterDelete();

Return Value

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.GetNoneTreeNodeToExpand Method

Gets an empty collection that expand no TreeNodes.

protected IList GetNoneTreeNodeToExpand();

Return Value

A empty list.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.GetSelectedTreeNodeToExpand Method

Gets only the expanded TreeNode hierarchy of the selected node.

protected IList GetSelectedTreeNodeToExpand();

Return Value

A list with all TreeNode keys to expand.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.GetTopTreeNode Method

Gets the top level node for the given treeNode.

protected virtual vdxTreeNode GetTopTreeNode(
vdxTreeNode treeNode
);

Parameters

treeNode
The treeNode, to get the corresponding top level treeNode

Return Value

The top level tree node.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


GetTreeNode Method

VDX Framework

vdxTreeView.GetTreeNode Method

Gets the corresponding TreeNode for the given DataRow.

Overload List

Gets the corresponding TreeNode for the given DataRow.

public vdxTreeNode GetTreeNode(vdxNavigatorInfoItem);

Creates a vdxTreeNode for the given DataRow.

protected virtual vdxTreeNode GetTreeNode(vdxNavigatorInfoItem,vdxTreeNode);

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.GetTreeNode Method (vdxNavigatorInfoItem)

Gets the corresponding TreeNode for the given DataRow.

public vdxTreeNode GetTreeNode(
vdxNavigatorInfoItem navInfoItem
);

Parameters

navInfoItem
The key to search the wanted treeNode.

Return Value

Corresponding treeNode for the given dataRow.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace | vdxTreeView.GetTreeNode Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.GetTreeNode Method (vdxNavigatorInfoItem, vdxTreeNode)

Creates a vdxTreeNode for the given DataRow.

protected virtual vdxTreeNode GetTreeNode(
vdxNavigatorInfoItem navInfoItem,
vdxTreeNode parentNode
);

Parameters

navInfoItem
The DataRow which contains the data to create the treeNode.
parentNode
The parent treeNode of the node to create.

Return Value

Corresponding treeNode for the given dataRow.

Remarks

Default the first string column is used for the text and if there is a imageList set, the first image of imageList is used.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace | vdxTreeView.GetTreeNode Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.GetTreeNodeInfo Method

Gets the text and image information to build a treeNode.

protected virtual void GetTreeNodeInfo(
vdxNavigatorInfoItem navInfoItem,
out string text,
out int imageIndex
);

Parameters

navInfoItem
The input parameter to evaluate the text, imageIndex and hasChilds.
text
The text shown on a treeNode.
imageIndex
The imageIndex, which must be contained in the treeView imageList.

Remarks

Must be implemented by the derived class.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.GetTreeNodeKey Method

Gets an unique key to differ TreeNodes on the same hierarchy level.

protected virtual object GetTreeNodeKey(
TreeNode treeNode
);

Parameters

treeNode
The node to extract key out of.

Return Value

The unique key of the treeNode.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.GetTreeNodesToExpandAfterRefresh Method

Gets all TreeNodes that are expanded depending on RefreshAlgorithmType.

protected virtual IList GetTreeNodesToExpandAfterRefresh();

Return Value

A list with all TreeNode keys to expand.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.Insert Method

Inserts a new treeNode for the corresponding row.

protected virtual void Insert(
DataRow navigatorDataRow,
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorDataRow
The row to be inserted.
navigatorInfo
The last selected navigator info.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.IsRefreshable Method

Checks if the component supports refresh.

protected virtual bool IsRefreshable();

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.LoadData Method

Loads data for the given search parameters.

protected virtual DataSet LoadData(
vdxSearchParameters searchParameters
);

Parameters

searchParameters
The specific search arguments.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.OnControlChanged Method

Inform all registered components on ControlChanged about a control change.

protected virtual void OnControlChanged(
vdxNavigatorControlEventArgs eventArgs
);

Parameters

eventArgs
Contains the involved searchParameters and dataDetailType.

Remarks

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace | vdxNavigatorControlEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.OnSelectionChanged Method

Inform all registered components on SelectionChanged about a selection change.

protected virtual void OnSelectionChanged(
vdxNavigatorSelectionEventArgs eventArgs
);

Parameters

eventArgs
Contains the involved dataRow.

Remarks

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace | vdxNavigatorSelectionEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.RefreshData Method

Remove all elements from the navigator and fill up the given dataSet.

public virtual void RefreshData(
DataSet dataSet
);

Parameters

dataSet
The dataSet, which the navigator extract all rows out of.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.SelectDefault Method

Selects the default element.

public virtual void SelectDefault();

Implements

IvdxNavigator.SelectDefault

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.Undo Method

Undo changes for the corresponding navigatorDataRow.

protected virtual void Undo(
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorInfo
The last selected navigator info.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Update Method

VDX Framework

vdxTreeView.Update Method

Updates the node for given vdxNavigatorInfo.

Overload List

Inherited from Control.

public void Update();

Updates the node for given vdxNavigatorInfo.

protected virtual void Update(DataRow,vdxNavigatorInfo);

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.Update Method (DataRow, vdxNavigatorInfo)

Updates the node for given vdxNavigatorInfo.

protected virtual void Update(
DataRow navigatorDataRow,
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorDataRow
The updated row.
navigatorInfo
The last selected navigator info.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace | vdxTreeView.Update Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView Events

The events of the vdxTreeView class are listed below. For a complete list of vdxTreeView class members, see the vdxTreeView Members topic.

Public Instance Events

AfterCheck (inherited from TreeView) | Occurs after the tree node check box is checked.
AfterCollapse (inherited from TreeView) | Occurs after the tree node is collapsed.
AfterExpand (inherited from TreeView) | Occurs after the tree node is expanded.
AfterLabelEdit (inherited from TreeView) | Occurs after the tree node label text is edited.
AfterSelect (inherited from TreeView) | Occurs after the tree node is selected.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from TreeView) |
BeforeCheck (inherited from TreeView) | Occurs before the tree node check box is checked.
BeforeCollapse (inherited from TreeView) | Occurs before the tree node is collapsed.
BeforeExpand (inherited from TreeView) | Occurs before the tree node is expanded.
BeforeLabelEdit (inherited from TreeView) | Occurs before the tree node label text is edited.
BeforeSelect (inherited from TreeView) | Occurs before the tree node is selected.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlChanged | Occurs when an other cacheable control had to be shown.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
ItemDrag (inherited from TreeView) | Occurs when an item is dragged into the tree view control.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from TreeView) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectionChanged | Occurs when an other DataRow was selected.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from TreeView) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace | TreeView | IvdxNavigator

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.ControlChanged Event

Occurs when an other cacheable control had to be shown.

public event vdxNavigatorControlEventHandler ControlChanged;

Event Data

The event handler receives an argument of type vdxNavigatorControlEventArgs containing data related to this event. The following vdxNavigatorControlEventArgs property provides information specific to this event.

Property | Description
LoaderInfo | Gets the involved .

Implements

IvdxNavigator.ControlChanged

Remarks

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace | vdxExplorer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTreeView.SelectionChanged Event

Occurs when an other DataRow was selected.

public event vdxNavigatorSelectionEventHandler SelectionChanged;

Event Data

The event handler receives an argument of type vdxNavigatorSelectionEventArgs containing data related to this event. The following vdxNavigatorSelectionEventArgs property provides information specific to this event.

Property | Description
NavigatorInfo | Gets the involved .

Implements

IvdxNavigator.SelectionChanged

See Also

vdxTreeView Class | Deag.Vdx.Controls.Base Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Controls.Converter

VDX Framework

Deag.Vdx.Controls.Converter Namespace

Classes

Class | Description
vdxDataDetailTypeConverter | Apply this class as a TypeConverterAttribute to list the available classes based upon your vdxDataDetail controls.
vdxDataTableProviderTypeConverter | Provides a list of DataTable names of all found components that implement IvdxDataSetProvider.
vdxIDataSetProviderTypeConverter | Provides a list of all available components that implement IvdxDataSetProvider.
vdxNavigatorTypeConverter | Apply this class as a TypeConverterAttribute to list the available classes based upon your IvdxNavigator controls.
vdxPickerTypeConverter | Apply this class as a TypeConverterAttribute to list the available classes based upon your IvdxPicker controls.
vdxSearchControlTypeConverter | Apply this class as a TypeConverterAttribute to list the available classes based upon your IvdxSearchControl controls.
vdxSelectionGridTypeConverter | Apply this class as a TypeConverterAttribute to list the available classes based upon your vdxSelection controls.
vdxTablePickerTypeConverter | Provides a list of DataTable of DataSet.
vdxTypeConverterBase | The base class for all vdxTypeConverters classes.
vdxTypedDSTypeConverter | Provides a list of typed DataSet.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetailTypeConverter Class

Apply this class as a TypeConverterAttribute to list the available classes based upon your vdxDataDetail controls.

For a list of all members of this type, see vdxDataDetailTypeConverter Members.

System.Object
TypeConverter
StringConverter
vdxTypeConverterBase
vdxDataDetailTypeConverter

public class vdxDataDetailTypeConverter : vdxTypeConverterBase

Requirements

Namespace: Deag.Vdx.Controls.Converter

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataDetailTypeConverter Members | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetailTypeConverter Members

vdxDataDetailTypeConverter overview

Public Instance Constructors

vdxDataDetailTypeConverter Constructor Initializes a new instance of the vdxDataDetailTypeConverter class.

Public Instance Methods

CanConvertFrom (inherited from StringConverter) | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from StringConverter) | Overloaded. Converts the specified value object to a String object.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from vdxTypeConverterBase) | Overloaded. Gets the collection of supported standard values.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from vdxTypeConverterBase) | Overloaded. Gets whether only standard values are supported or not.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from vdxTypeConverterBase) | Overloaded. Gets whether standard values are supported or not.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxGetAllKnownAssemblies (inherited from vdxTypeConverterBase) | Retrieves all referenced assemblies and the context assembly for the given context.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.
VdxGetContextAssembly (inherited from vdxTypeConverterBase) | Gets a reference to the client assembly. Used by the type converters in design mode.
VdxGetEffectiveType (inherited from vdxTypeConverterBase) | Gets the effective type.

See Also

vdxDataDetailTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetailTypeConverter Constructor

Initializes a new instance of the vdxDataDetailTypeConverter class.

public vdxDataDetailTypeConverter();

See Also

vdxDataDetailTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataTableProviderTypeConverter Class

Provides a list of DataTable names of all found components that implement IvdxDataSetProvider.

For a list of all members of this type, see vdxDataTableProviderTypeConverter Members.

System.Object
TypeConverter
StringConverter
vdxTypeConverterBase
vdxDataTableProviderTypeConverter

public class vdxDataTableProviderTypeConverter : vdxTypeConverterBase

Requirements

Namespace: Deag.Vdx.Controls.Converter

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataTableProviderTypeConverter Members | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataTableProviderTypeConverter Members

vdxDataTableProviderTypeConverter overview

Public Instance Constructors

vdxDataTableProviderTypeConverter Constructor Initializes a new instance of the vdxDataTableProviderTypeConverter class.

Public Instance Methods

CanConvertFrom (inherited from StringConverter) | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from StringConverter) | Overloaded. Converts the specified value object to a String object.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues | Overloaded. Returns the collection of supported standard values.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from vdxTypeConverterBase) | Overloaded. Gets whether only standard values are supported or not.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from vdxTypeConverterBase) | Overloaded. Gets whether standard values are supported or not.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxGetAllKnownAssemblies (inherited from vdxTypeConverterBase) | Retrieves all referenced assemblies and the context assembly for the given context.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.
VdxGetContextAssembly (inherited from vdxTypeConverterBase) | Gets a reference to the client assembly. Used by the type converters in design mode.
VdxGetEffectiveType (inherited from vdxTypeConverterBase) | Gets the effective type.

See Also

vdxDataTableProviderTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataTableProviderTypeConverter Constructor

Initializes a new instance of the vdxDataTableProviderTypeConverter class.

public vdxDataTableProviderTypeConverter();

See Also

vdxDataTableProviderTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataTableProviderTypeConverter Methods

The methods of the vdxDataTableProviderTypeConverter class are listed below. For a complete list of vdxDataTableProviderTypeConverter class members, see the vdxDataTableProviderTypeConverter Members topic.

Public Instance Methods

CanConvertFrom (inherited from StringConverter) | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from StringConverter) | Overloaded. Converts the specified value object to a String object.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues | Overloaded. Returns the collection of supported standard values.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from vdxTypeConverterBase) | Overloaded. Gets whether only standard values are supported or not.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from vdxTypeConverterBase) | Overloaded. Gets whether standard values are supported or not.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxGetAllKnownAssemblies (inherited from vdxTypeConverterBase) | Retrieves all referenced assemblies and the context assembly for the given context.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.
VdxGetContextAssembly (inherited from vdxTypeConverterBase) | Gets a reference to the client assembly. Used by the type converters in design mode.
VdxGetEffectiveType (inherited from vdxTypeConverterBase) | Gets the effective type.

See Also

vdxDataTableProviderTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


GetStandardValues Method

VDX Framework

vdxDataTableProviderTypeConverter.GetStandardValues Method

Returns the collection of supported standard values.

Overload List

Inherited from TypeConverter.

public ICollection GetStandardValues();

Returns the collection of supported standard values.

public override StandardValuesCollection GetStandardValues(ITypeDescriptorContext);

See Also

vdxDataTableProviderTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataTableProviderTypeConverter.GetStandardValues Method (ITypeDescriptorContext)

Returns the collection of supported standard values.

public override StandardValuesCollection GetStandardValues(
ITypeDescriptorContext context
);

Parameters

context
Context of the converter.

Return Value

Collection to show in a selection list.

See Also

vdxDataTableProviderTypeConverter Class | Deag.Vdx.Controls.Converter Namespace | vdxDataTableProviderTypeConverter.GetStandardValues Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxIDataSetProviderTypeConverter Class

Provides a list of all available components that implement IvdxDataSetProvider.

For a list of all members of this type, see vdxIDataSetProviderTypeConverter Members.

System.Object
TypeConverter
StringConverter
vdxTypeConverterBase
vdxIDataSetProviderTypeConverter

public class vdxIDataSetProviderTypeConverter : vdxTypeConverterBase

Requirements

Namespace: Deag.Vdx.Controls.Converter

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxIDataSetProviderTypeConverter Members | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxIDataSetProviderTypeConverter Members

vdxIDataSetProviderTypeConverter overview

Public Instance Constructors

vdxIDataSetProviderTypeConverter Constructor Initializes a new instance of the vdxIDataSetProviderTypeConverter class.

Public Instance Methods

CanConvertFrom (inherited from StringConverter) | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from StringConverter) | Overloaded. Converts the specified value object to a String object.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues | Overloaded. Returns the collection of supported standard values.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from vdxTypeConverterBase) | Overloaded. Gets whether only standard values are supported or not.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from vdxTypeConverterBase) | Overloaded. Gets whether standard values are supported or not.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxGetAllKnownAssemblies (inherited from vdxTypeConverterBase) | Retrieves all referenced assemblies and the context assembly for the given context.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.
VdxGetContextAssembly (inherited from vdxTypeConverterBase) | Gets a reference to the client assembly. Used by the type converters in design mode.
VdxGetEffectiveType (inherited from vdxTypeConverterBase) | Gets the effective type.

See Also

vdxIDataSetProviderTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxIDataSetProviderTypeConverter Constructor

Initializes a new instance of the vdxIDataSetProviderTypeConverter class.

public vdxIDataSetProviderTypeConverter();

See Also

vdxIDataSetProviderTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxIDataSetProviderTypeConverter Methods

The methods of the vdxIDataSetProviderTypeConverter class are listed below. For a complete list of vdxIDataSetProviderTypeConverter class members, see the vdxIDataSetProviderTypeConverter Members topic.

Public Instance Methods

CanConvertFrom (inherited from StringConverter) | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from StringConverter) | Overloaded. Converts the specified value object to a String object.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues | Overloaded. Returns the collection of supported standard values.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from vdxTypeConverterBase) | Overloaded. Gets whether only standard values are supported or not.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from vdxTypeConverterBase) | Overloaded. Gets whether standard values are supported or not.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxGetAllKnownAssemblies (inherited from vdxTypeConverterBase) | Retrieves all referenced assemblies and the context assembly for the given context.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.
VdxGetContextAssembly (inherited from vdxTypeConverterBase) | Gets a reference to the client assembly. Used by the type converters in design mode.
VdxGetEffectiveType (inherited from vdxTypeConverterBase) | Gets the effective type.

See Also

vdxIDataSetProviderTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


GetStandardValues Method

VDX Framework

vdxIDataSetProviderTypeConverter.GetStandardValues Method

Returns the collection of supported standard values.

Overload List

Inherited from TypeConverter.

public ICollection GetStandardValues();

Returns the collection of supported standard values.

public override StandardValuesCollection GetStandardValues(ITypeDescriptorContext);

See Also

vdxIDataSetProviderTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxIDataSetProviderTypeConverter.GetStandardValues Method (ITypeDescriptorContext)

Returns the collection of supported standard values.

public override StandardValuesCollection GetStandardValues(
ITypeDescriptorContext context
);

Parameters

context
Context of the converter.

Return Value

Collection to show in a selection list.

See Also

vdxIDataSetProviderTypeConverter Class | Deag.Vdx.Controls.Converter Namespace | vdxIDataSetProviderTypeConverter.GetStandardValues Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorTypeConverter Class

Apply this class as a TypeConverterAttribute to list the available classes based upon your IvdxNavigator controls.

For a list of all members of this type, see vdxNavigatorTypeConverter Members.

System.Object
TypeConverter
StringConverter
vdxTypeConverterBase
vdxNavigatorTypeConverter

public class vdxNavigatorTypeConverter : vdxTypeConverterBase

Requirements

Namespace: Deag.Vdx.Controls.Converter

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxNavigatorTypeConverter Members | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorTypeConverter Members

vdxNavigatorTypeConverter overview

Public Instance Constructors

vdxNavigatorTypeConverter Constructor Initializes a new instance of the vdxNavigatorTypeConverter class.

Public Instance Methods

CanConvertFrom (inherited from StringConverter) | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from StringConverter) | Overloaded. Converts the specified value object to a String object.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from vdxTypeConverterBase) | Overloaded. Gets the collection of supported standard values.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from vdxTypeConverterBase) | Overloaded. Gets whether only standard values are supported or not.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from vdxTypeConverterBase) | Overloaded. Gets whether standard values are supported or not.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxGetAllKnownAssemblies (inherited from vdxTypeConverterBase) | Retrieves all referenced assemblies and the context assembly for the given context.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.
VdxGetContextAssembly (inherited from vdxTypeConverterBase) | Gets a reference to the client assembly. Used by the type converters in design mode.
VdxGetEffectiveType (inherited from vdxTypeConverterBase) | Gets the effective type.

See Also

vdxNavigatorTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorTypeConverter Constructor

Initializes a new instance of the vdxNavigatorTypeConverter class.

public vdxNavigatorTypeConverter();

See Also

vdxNavigatorTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerTypeConverter Class

Apply this class as a TypeConverterAttribute to list the available classes based upon your IvdxPicker controls.

For a list of all members of this type, see vdxPickerTypeConverter Members.

System.Object
TypeConverter
StringConverter
vdxTypeConverterBase
vdxPickerTypeConverter

public class vdxPickerTypeConverter : vdxTypeConverterBase

Requirements

Namespace: Deag.Vdx.Controls.Converter

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxPickerTypeConverter Members | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerTypeConverter Members

vdxPickerTypeConverter overview

Public Instance Constructors

vdxPickerTypeConverter Constructor Initializes a new instance of the vdxPickerTypeConverter class.

Public Instance Methods

CanConvertFrom (inherited from StringConverter) | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from StringConverter) | Overloaded. Converts the specified value object to a String object.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from vdxTypeConverterBase) | Overloaded. Gets the collection of supported standard values.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from vdxTypeConverterBase) | Overloaded. Gets whether only standard values are supported or not.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from vdxTypeConverterBase) | Overloaded. Gets whether standard values are supported or not.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxGetAllKnownAssemblies (inherited from vdxTypeConverterBase) | Retrieves all referenced assemblies and the context assembly for the given context.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.
VdxGetContextAssembly (inherited from vdxTypeConverterBase) | Gets a reference to the client assembly. Used by the type converters in design mode.
VdxGetEffectiveType (inherited from vdxTypeConverterBase) | Gets the effective type.

See Also

vdxPickerTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerTypeConverter Constructor

Initializes a new instance of the vdxPickerTypeConverter class.

public vdxPickerTypeConverter();

See Also

vdxPickerTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchControlTypeConverter Class

Apply this class as a TypeConverterAttribute to list the available classes based upon your IvdxSearchControl controls.

For a list of all members of this type, see vdxSearchControlTypeConverter Members.

System.Object
TypeConverter
StringConverter
vdxTypeConverterBase
vdxSearchControlTypeConverter

public class vdxSearchControlTypeConverter : vdxTypeConverterBase

Requirements

Namespace: Deag.Vdx.Controls.Converter

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxSearchControlTypeConverter Members | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchControlTypeConverter Members

vdxSearchControlTypeConverter overview

Public Instance Constructors

vdxSearchControlTypeConverter Constructor Initializes a new instance of the vdxSearchControlTypeConverter class.

Public Instance Methods

CanConvertFrom (inherited from StringConverter) | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from StringConverter) | Overloaded. Converts the specified value object to a String object.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from vdxTypeConverterBase) | Overloaded. Gets the collection of supported standard values.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from vdxTypeConverterBase) | Overloaded. Gets whether only standard values are supported or not.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from vdxTypeConverterBase) | Overloaded. Gets whether standard values are supported or not.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxGetAllKnownAssemblies (inherited from vdxTypeConverterBase) | Retrieves all referenced assemblies and the context assembly for the given context.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.
VdxGetContextAssembly (inherited from vdxTypeConverterBase) | Gets a reference to the client assembly. Used by the type converters in design mode.
VdxGetEffectiveType (inherited from vdxTypeConverterBase) | Gets the effective type.

See Also

vdxSearchControlTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchControlTypeConverter Constructor

Initializes a new instance of the vdxSearchControlTypeConverter class.

public vdxSearchControlTypeConverter();

See Also

vdxSearchControlTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGridTypeConverter Class

Apply this class as a TypeConverterAttribute to list the available classes based upon your vdxSelection controls.

For a list of all members of this type, see vdxSelectionGridTypeConverter Members.

System.Object
TypeConverter
StringConverter
vdxTypeConverterBase
vdxSelectionGridTypeConverter

public class vdxSelectionGridTypeConverter : vdxTypeConverterBase

Requirements

Namespace: Deag.Vdx.Controls.Converter

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxSelectionGridTypeConverter Members | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGridTypeConverter Members

vdxSelectionGridTypeConverter overview

Public Instance Constructors

vdxSelectionGridTypeConverter Constructor Initializes a new instance of the vdxSelectionGridTypeConverter class.

Public Instance Methods

CanConvertFrom (inherited from StringConverter) | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from StringConverter) | Overloaded. Converts the specified value object to a String object.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from vdxTypeConverterBase) | Overloaded. Gets the collection of supported standard values.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from vdxTypeConverterBase) | Overloaded. Gets whether only standard values are supported or not.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from vdxTypeConverterBase) | Overloaded. Gets whether standard values are supported or not.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxGetAllKnownAssemblies (inherited from vdxTypeConverterBase) | Retrieves all referenced assemblies and the context assembly for the given context.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.
VdxGetContextAssembly (inherited from vdxTypeConverterBase) | Gets a reference to the client assembly. Used by the type converters in design mode.
VdxGetEffectiveType (inherited from vdxTypeConverterBase) | Gets the effective type.

See Also

vdxSelectionGridTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGridTypeConverter Constructor

Initializes a new instance of the vdxSelectionGridTypeConverter class.

public vdxSelectionGridTypeConverter();

See Also

vdxSelectionGridTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTablePickerTypeConverter Class

Provides a list of DataTable of DataSet.

For a list of all members of this type, see vdxTablePickerTypeConverter Members.

System.Object
TypeConverter
StringConverter
vdxTypeConverterBase
vdxTablePickerTypeConverter

public class vdxTablePickerTypeConverter : vdxTypeConverterBase

Requirements

Namespace: Deag.Vdx.Controls.Converter

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxTablePickerTypeConverter Members | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTablePickerTypeConverter Members

vdxTablePickerTypeConverter overview

Public Instance Constructors

vdxTablePickerTypeConverter Constructor Initializes a new instance of the vdxTablePickerTypeConverter class.

Public Instance Methods

CanConvertFrom (inherited from StringConverter) | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from StringConverter) | Overloaded. Converts the specified value object to a String object.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues | Overloaded. Returns the collection of supported standard values.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from vdxTypeConverterBase) | Overloaded. Gets whether only standard values are supported or not.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from vdxTypeConverterBase) | Overloaded. Gets whether standard values are supported or not.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxGetAllKnownAssemblies (inherited from vdxTypeConverterBase) | Retrieves all referenced assemblies and the context assembly for the given context.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.
VdxGetContextAssembly (inherited from vdxTypeConverterBase) | Gets a reference to the client assembly. Used by the type converters in design mode.
VdxGetEffectiveType (inherited from vdxTypeConverterBase) | Gets the effective type.

See Also

vdxTablePickerTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTablePickerTypeConverter Constructor

Initializes a new instance of the vdxTablePickerTypeConverter class.

public vdxTablePickerTypeConverter();

See Also

vdxTablePickerTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTablePickerTypeConverter Methods

The methods of the vdxTablePickerTypeConverter class are listed below. For a complete list of vdxTablePickerTypeConverter class members, see the vdxTablePickerTypeConverter Members topic.

Public Instance Methods

CanConvertFrom (inherited from StringConverter) | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from StringConverter) | Overloaded. Converts the specified value object to a String object.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues | Overloaded. Returns the collection of supported standard values.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from vdxTypeConverterBase) | Overloaded. Gets whether only standard values are supported or not.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from vdxTypeConverterBase) | Overloaded. Gets whether standard values are supported or not.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxGetAllKnownAssemblies (inherited from vdxTypeConverterBase) | Retrieves all referenced assemblies and the context assembly for the given context.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.
VdxGetContextAssembly (inherited from vdxTypeConverterBase) | Gets a reference to the client assembly. Used by the type converters in design mode.
VdxGetEffectiveType (inherited from vdxTypeConverterBase) | Gets the effective type.

See Also

vdxTablePickerTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


GetStandardValues Method

VDX Framework

vdxTablePickerTypeConverter.GetStandardValues Method

Returns the collection of supported standard values.

Overload List

Inherited from TypeConverter.

public ICollection GetStandardValues();

Returns the collection of supported standard values.

public override StandardValuesCollection GetStandardValues(ITypeDescriptorContext);

See Also

vdxTablePickerTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTablePickerTypeConverter.GetStandardValues Method (ITypeDescriptorContext)

Returns the collection of supported standard values.

public override StandardValuesCollection GetStandardValues(
ITypeDescriptorContext context
);

Parameters

context
Context of the converter.

Return Value

Collection to show in a selection list.

See Also

vdxTablePickerTypeConverter Class | Deag.Vdx.Controls.Converter Namespace | vdxTablePickerTypeConverter.GetStandardValues Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTypeConverterBase Class

The base class for all vdxTypeConverters classes.

For a list of all members of this type, see vdxTypeConverterBase Members.

System.Object
TypeConverter
StringConverter
vdxTypeConverterBase

public class vdxTypeConverterBase : StringConverter

Requirements

Namespace: Deag.Vdx.Controls.Converter

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxTypeConverterBase Members | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTypeConverterBase Members

vdxTypeConverterBase overview

Public Instance Constructors

vdxTypeConverterBase Overloaded. Initializes a new instance of the vdxTypeConverterBase class.

Public Instance Methods

CanConvertFrom (inherited from StringConverter) | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from StringConverter) | Overloaded. Converts the specified value object to a String object.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues | Overloaded. Gets the collection of supported standard values.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive | Overloaded. Gets whether only standard values are supported or not.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported | Overloaded. Gets whether standard values are supported or not.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxGetAllKnownAssemblies | Retrieves all referenced assemblies and the context assembly for the given context.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.
VdxGetContextAssembly | Gets a reference to the client assembly. Used by the type converters in design mode.
VdxGetEffectiveType | Gets the effective type.

See Also

vdxTypeConverterBase Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTypeConverterBase Constructor

Initializes a new instance of the vdxTypeConverterBase class.

Overload List

Initializes a new instance of the vdxTypeConverterBase class.

public vdxTypeConverterBase();

Initializes a new instance of the vdxTypeConverterBase class.

public vdxTypeConverterBase(Type);

See Also

vdxTypeConverterBase Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTypeConverterBase Constructor ()

Initializes a new instance of the vdxTypeConverterBase class.

public vdxTypeConverterBase();

See Also

vdxTypeConverterBase Class | Deag.Vdx.Controls.Converter Namespace | vdxTypeConverterBase Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTypeConverterBase Constructor (Type)

Initializes a new instance of the vdxTypeConverterBase class.

public vdxTypeConverterBase(
Type type
);

Parameters

type
The type of the class.

See Also

vdxTypeConverterBase Class | Deag.Vdx.Controls.Converter Namespace | vdxTypeConverterBase Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTypeConverterBase Methods

The methods of the vdxTypeConverterBase class are listed below. For a complete list of vdxTypeConverterBase class members, see the vdxTypeConverterBase Members topic.

Public Instance Methods

CanConvertFrom (inherited from StringConverter) | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from StringConverter) | Overloaded. Converts the specified value object to a String object.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues | Overloaded. Gets the collection of supported standard values.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive | Overloaded. Gets whether only standard values are supported or not.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported | Overloaded. Gets whether standard values are supported or not.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxGetAllKnownAssemblies | Retrieves all referenced assemblies and the context assembly for the given context.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.
VdxGetContextAssembly | Gets a reference to the client assembly. Used by the type converters in design mode.
VdxGetEffectiveType | Gets the effective type.

See Also

vdxTypeConverterBase Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


GetStandardValues Method

VDX Framework

vdxTypeConverterBase.GetStandardValues Method

Gets the collection of supported standard values.

Overload List

Inherited from TypeConverter.

public ICollection GetStandardValues();

Gets the collection of supported standard values.

public override StandardValuesCollection GetStandardValues(ITypeDescriptorContext);

See Also

vdxTypeConverterBase Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTypeConverterBase.GetStandardValues Method (ITypeDescriptorContext)

Gets the collection of supported standard values.

public override StandardValuesCollection GetStandardValues(
ITypeDescriptorContext context
);

Parameters

context
Context of the converter.

Return Value

The collection to show in a selection list.

See Also

vdxTypeConverterBase Class | Deag.Vdx.Controls.Converter Namespace | vdxTypeConverterBase.GetStandardValues Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


GetStandardValuesExclusive Method

VDX Framework

vdxTypeConverterBase.GetStandardValuesExclusive Method

Gets whether only standard values are supported or not.

Overload List

Inherited from TypeConverter.

public bool GetStandardValuesExclusive();

Gets whether only standard values are supported or not.

public override bool GetStandardValuesExclusive(ITypeDescriptorContext);

See Also

vdxTypeConverterBase Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTypeConverterBase.GetStandardValuesExclusive Method (ITypeDescriptorContext)

Gets whether only standard values are supported or not.

public override bool GetStandardValuesExclusive(
ITypeDescriptorContext context
);

Parameters

context
Context of the converter.

Return Value

True if only standard values are supported.

See Also

vdxTypeConverterBase Class | Deag.Vdx.Controls.Converter Namespace | vdxTypeConverterBase.GetStandardValuesExclusive Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


GetStandardValuesSupported Method

VDX Framework

vdxTypeConverterBase.GetStandardValuesSupported Method

Gets whether standard values are supported or not.

Overload List

Inherited from TypeConverter.

public bool GetStandardValuesSupported();

Gets whether standard values are supported or not.

public override bool GetStandardValuesSupported(ITypeDescriptorContext);

See Also

vdxTypeConverterBase Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTypeConverterBase.GetStandardValuesSupported Method (ITypeDescriptorContext)

Gets whether standard values are supported or not.

public override bool GetStandardValuesSupported(
ITypeDescriptorContext context
);

Parameters

context
Context of the converter.

Return Value

True if standard values are supported.

See Also

vdxTypeConverterBase Class | Deag.Vdx.Controls.Converter Namespace | vdxTypeConverterBase.GetStandardValuesSupported Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTypeConverterBase.VdxGetAllKnownAssemblies Method

Retrieves all referenced assemblies and the context assembly for the given context.

public Assembly[] VdxGetAllKnownAssemblies(
ITypeDescriptorContext context
);

Parameters

context
The context which assembly is retrieved.

Return Value

All referenced assemblies and the context assembly.

See Also

vdxTypeConverterBase Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTypeConverterBase.VdxGetContextAssembly Method

Gets a reference to the client assembly. Used by the type converters in design mode.

protected Assembly VdxGetContextAssembly(
ITypeDescriptorContext context
);

Parameters

context
An ITypeDescriptorContext object which is used by the type converter.

Return Value

The client assembly.

See Also

vdxTypeConverterBase Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTypeConverterBase.VdxGetEffectiveType Method

Gets the effective type.

protected Type VdxGetEffectiveType(
Assembly assembly,
Component currentComponent,
string propertyName
);

Parameters

assembly
The assembly.
currentComponent
The current component.
propertyName
The name of the property.

Return Value

The effective type.

See Also

vdxTypeConverterBase Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTypedDSTypeConverter Class

Provides a list of typed DataSet.

For a list of all members of this type, see vdxTypedDSTypeConverter Members.

System.Object
TypeConverter
StringConverter
vdxTypeConverterBase
vdxTypedDSTypeConverter

public class vdxTypedDSTypeConverter : vdxTypeConverterBase

Requirements

Namespace: Deag.Vdx.Controls.Converter

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxTypedDSTypeConverter Members | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTypedDSTypeConverter Members

vdxTypedDSTypeConverter overview

Public Instance Constructors

vdxTypedDSTypeConverter Constructor Initializes a new instance of the vdxTypedDSTypeConverter class.

Public Instance Methods

CanConvertFrom (inherited from StringConverter) | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom | Overloaded. Converts the specified value object to a typed DataSet from the context assembly.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo | Overloaded. Converts the given value object to the destination type, in this context a String.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the arguments.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues | Overloaded. Returns the collection of supported standard values.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from vdxTypeConverterBase) | Overloaded. Gets whether only standard values are supported or not.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from vdxTypeConverterBase) | Overloaded. Gets whether standard values are supported or not.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxGetAllKnownAssemblies (inherited from vdxTypeConverterBase) | Retrieves all referenced assemblies and the context assembly for the given context.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.
VdxGetContextAssembly (inherited from vdxTypeConverterBase) | Gets a reference to the client assembly. Used by the type converters in design mode.
VdxGetEffectiveType (inherited from vdxTypeConverterBase) | Gets the effective type.

See Also

vdxTypedDSTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTypedDSTypeConverter Constructor

Initializes a new instance of the vdxTypedDSTypeConverter class.

public vdxTypedDSTypeConverter();

See Also

vdxTypedDSTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTypedDSTypeConverter Methods

The methods of the vdxTypedDSTypeConverter class are listed below. For a complete list of vdxTypedDSTypeConverter class members, see the vdxTypedDSTypeConverter Members topic.

Public Instance Methods

CanConvertFrom (inherited from StringConverter) | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom | Overloaded. Converts the specified value object to a typed DataSet from the context assembly.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo | Overloaded. Converts the given value object to the destination type, in this context a String.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the arguments.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues | Overloaded. Returns the collection of supported standard values.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from vdxTypeConverterBase) | Overloaded. Gets whether only standard values are supported or not.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from vdxTypeConverterBase) | Overloaded. Gets whether standard values are supported or not.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxGetAllKnownAssemblies (inherited from vdxTypeConverterBase) | Retrieves all referenced assemblies and the context assembly for the given context.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.
VdxGetContextAssembly (inherited from vdxTypeConverterBase) | Gets a reference to the client assembly. Used by the type converters in design mode.
VdxGetEffectiveType (inherited from vdxTypeConverterBase) | Gets the effective type.

See Also

vdxTypedDSTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConvertFrom Method

VDX Framework

vdxTypedDSTypeConverter.ConvertFrom Method

Converts the specified value object to a typed DataSet from the context assembly.

Overload List

Converts the specified value object to a typed DataSet from the context assembly.

public override object ConvertFrom(ITypeDescriptorContext,CultureInfo,object);

Inherited from TypeConverter.

public object ConvertFrom(object);

See Also

vdxTypedDSTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTypedDSTypeConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts the specified value object to a typed DataSet from the context assembly.

public override object ConvertFrom(
ITypeDescriptorContext context,
CultureInfo culture,
object value
);

Parameters

context
The context which the typed DataSet is getting from.
culture
Not used
value
The System.Object to convert.

Return Value

The typed DataSet.

See Also

vdxTypedDSTypeConverter Class | Deag.Vdx.Controls.Converter Namespace | vdxTypedDSTypeConverter.ConvertFrom Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConvertTo Method

VDX Framework

vdxTypedDSTypeConverter.ConvertTo Method

Converts the given value object to the destination type, in this context a String.

Overload List

Converts the given value object to the destination type, in this context a String.

public override object ConvertTo(ITypeDescriptorContext,CultureInfo,object,Type);

Inherited from TypeConverter.

public object ConvertTo(object,Type);

See Also

vdxTypedDSTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTypedDSTypeConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Converts the given value object to the destination type, in this context a String.

public override object ConvertTo(
ITypeDescriptorContext context,
CultureInfo culture,
object value,
Type destinationType
);

Parameters

context
culture
value
destinationType

Return Value

See Also

vdxTypedDSTypeConverter Class | Deag.Vdx.Controls.Converter Namespace | vdxTypedDSTypeConverter.ConvertTo Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


GetStandardValues Method

VDX Framework

vdxTypedDSTypeConverter.GetStandardValues Method

Returns the collection of supported standard values.

Overload List

Inherited from TypeConverter.

public ICollection GetStandardValues();

Returns the collection of supported standard values.

public override StandardValuesCollection GetStandardValues(ITypeDescriptorContext);

See Also

vdxTypedDSTypeConverter Class | Deag.Vdx.Controls.Converter Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTypedDSTypeConverter.GetStandardValues Method (ITypeDescriptorContext)

Returns the collection of supported standard values.

public override StandardValuesCollection GetStandardValues(
ITypeDescriptorContext context
);

Parameters

context
Context of the converter.

Return Value

Collection to show in a selection list.

See Also

vdxTypedDSTypeConverter Class | Deag.Vdx.Controls.Converter Namespace | vdxTypedDSTypeConverter.GetStandardValues Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Controls.Core

VDX Framework

Deag.Vdx.Controls.Core Namespace

Classes

Class | Description
vdxActionInvokerCollection | The collection that holds all action invoker items.
vdxActionItem | A vdxActionItem provides an easy way to handle all the controls, menu items or toolbar buttons that trigger the same action.
vdxActionItemCollection | The collection that holds all action items.
vdxActionManager | A vdxActionManager handles a colletion of vdxActionItems.
vdxBindingManager | The default binding manager.
vdxCacheableControl | The default implementation for a cacheable component in the vdxMultiContainer.
vdxControlResetter | Provides the function to reset all child Controls in a container.
vdxDataActionManager | The vdxDataActionManager defines several actions that are associated with data handling.
vdxDataControl | Defines the needed interfaces for a data driven control like a vdxDataDetail or a vdxExplorer.
vdxDataDetail | Defines the base class for all data detail user controls that can handle data.
vdxDataDetailDelayed | Specialized vdxDataDetail control that load data delayed.
vdxDataDetailTab | Data detail class with a tab control, whose TabPage only load data when they were clicked.
vdxDataMultiContainer | Specialized vdxMultiContainer that also is a IvdxDataActionManagerConsumer.
vdxDataSetReference | The vdxDataSetReference component encapsulates a typed DataSet. The type of the DataSet is passed to the component. This causes the creation of a DataSet of the desired type. Afterwards every Control may be bound to the vdxDataSetReference component. If you have several (and big) typed DataSets in your project, the devenv's performance may decrease dramatically, as soon you have some instances of typed DataSets on a Form. To prevent this, you can encapsulate the DataSet by a vdxDataSetReference component. You will also be able to use the vdxControlDesigner of the component to create the bound controls easyly.
vdxDataStatusManager | VDX Data Status Management class.
vdxExplorer | Defines the base class for navigation typed panels.
vdxExplorer.vdxNavigatorCollection | Helper class for vdxExplorer to manage all navigators on it.
vdxFrameLine | A horizontal line with caption.
vdxLoaderInfo | Communication media between IvdxNavigator and vdxExplorer.
vdxMultiContainer | Manages one instance per IvdxMultiContainerCacheable element type.
vdxNavigatorInfo | Communication media between IvdxNavigator and vdxExplorer.
vdxNavigatorInfoItem | Specify the element which is encapsulated in a vdxNavigatorInfo.
vdxNavigatorInfoItemRow | Specify the DataRow which is encapsulated in a vdxNavigatorInfoItem.
vdxPossibleOperations | Represents an object with the currently possible data operations.
vdxSelection | Default implementation of IvdxSearchControl.
vdxSelectionName | This class represents a form where a custom selection which has been dragged and dropped on the outlook bar can be renamed.
vdxTableManager | Manages one DataTable within the vdxDataStatusManager.
vdxTableManagerCollection | A collection if vdxTableManagers.

Interfaces

Interface | Description
IvdxBindingManagable | Interface used for input controls to force binding update.
IvdxBindingManager | Interface used for managers that handles binding context.
IvdxChangeable | Defines the interface for all datamanipulation management controls (including the vdxDataStatusManager, vdxExplorerTree, vdxExplorerGrid, ...) which are involved in the VDX datamanipulation concept.
IvdxDataActionManagerConsumer | Provides a vdxDataActionManager property that can hold several ActionItems.
IvdxDataLoader | Defines the interface for components that can load and manipulate data.
IvdxDataManipulator | Defines the interface for components that data can be manipulated.
IvdxDataSetProvider | Defines the interface for components that are listed in the property TableName of the vdxDataView class.
IvdxDsmHost | Each control wich can be managed by the vdxDataStatusManager must implement this interface.
IvdxDsmProvider | Defines the interface for user controls that status changes are handled by a vdxDataStatusManager.
IvdxGetContextAssembly | This interface is used for all controls, where the Typeconverter cannot access the context assembly directly.
IvdxInputControl | Interface for controls that handle user inputs.
IvdxLogon | Interface for all VDX-compatible logon dialogs.
IvdxMultiContainerCacheable | Defines the interface for components, which can managed by a vdxMultiContainer.
IvdxNavigator | Defines the inferface for all components, which can navigate through a amount of data. The information what was selected, inserted, updated is transported over the vdxNavigatorInfo.
IvdxPicker | Defines the interface for components that supports pick field dialogs.
IvdxResettable | Defines the Interface for all controls that must provide the the capability to be reset to an originl value. This includes Text Boxes, Combo Boxes and so on. Within Vdx, these controls are reset when the clear button is pressed.
IvdxSearchControl | Defines the interface for components that manage a search parameters.
IvdxSplashScreen | Defines the interface for components, which can be set on vdxApplication.

Delegates

Delegate | Description
vdxDataStatusManager.MergeUpdateDelegate | Declare a delegate type for merge DataSet changes.

Enumerations

Enumeration | Description
vdxBindingManagerRefreshKind | Enumeration for the type of binding manager refresh.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxBindingManagable Interface

Interface used for input controls to force binding update.

public interface IvdxBindingManagable

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager | IvdxInputControl

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxBindingManager Interface

Interface used for managers that handles binding context.

For a list of all members of this type, see IvdxBindingManager Members.

public interface IvdxBindingManager

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

IvdxBindingManager Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxBindingManager Members

IvdxBindingManager overview

Public Instance Methods

Add | Adds a binding managable to the collection.
AddContainer | Adds the specified control and all its children to the collection of managed controls (only controls that implement IvdxBindingManagable).
Contains | Returns whether the collection contains the specified binding managable.
Refresh | Overloaded. Refreshs the specified binding managable.
Remove | Removes a binding managable from the collection.

See Also

IvdxBindingManager Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxBindingManager Methods

The methods of the IvdxBindingManager interface are listed below. For a complete list of IvdxBindingManager interface members, see the IvdxBindingManager Members topic.

Public Instance Methods

Add | Adds a binding managable to the collection.
AddContainer | Adds the specified control and all its children to the collection of managed controls (only controls that implement IvdxBindingManagable).
Contains | Returns whether the collection contains the specified binding managable.
Refresh | Overloaded. Refreshs the specified binding managable.
Remove | Removes a binding managable from the collection.

See Also

IvdxBindingManager Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxBindingManager.Add Method

Adds a binding managable to the collection.

void Add(
IvdxBindingManagable bm
);

Parameters

bm
The binding managable that will be added.

See Also

IvdxBindingManager Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxBindingManager.AddContainer Method

Adds the specified control and all its children to the collection of managed controls (only controls that implement IvdxBindingManagable).

void AddContainer(
Control container
);

Parameters

container
The control that will be added to the collection.

See Also

IvdxBindingManager Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxBindingManager.Contains Method

Returns whether the collection contains the specified binding managable.

bool Contains(
IvdxBindingManagable bm
);

Parameters

bm
The binding managable to search for.

Return Value

True if collection contains the binding managable.

See Also

IvdxBindingManager Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Refresh Method

VDX Framework

IvdxBindingManager.Refresh Method

Refreshs the specified binding managable.

Overload List

Refreshs the specified binding managable.

bool Refresh(IvdxBindingManagable);

Loops through all managed objects and calls their Refresh method.

bool Refresh(vdxBindingManagerRefreshKind);

Refreshs the specified list.

bool Refresh(vdxBindingManagerRefreshKind,params IvdxBindingManagable[]);

See Also

IvdxBindingManager Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxBindingManager.Refresh Method (IvdxBindingManagable)

Refreshs the specified binding managable.

bool Refresh(
IvdxBindingManagable bm
);

Parameters

bm
Which object that should be refreshed.

Return Value

Whether the given managed objects were refreshed (due to validation errors for example)

See Also

IvdxBindingManager Interface | Deag.Vdx.Controls.Core Namespace | IvdxBindingManager.Refresh Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxBindingManager.Refresh Method (vdxBindingManagerRefreshKind)

Loops through all managed objects and calls their Refresh method.

bool Refresh(
vdxBindingManagerRefreshKind kind
);

Parameters

kind
Which objects should be refreshed.

Return Value

Whether all managed objects were refreshed (due to validation errors for example)

See Also

IvdxBindingManager Interface | Deag.Vdx.Controls.Core Namespace | IvdxBindingManager.Refresh Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxBindingManager.Refresh Method (vdxBindingManagerRefreshKind, IvdxBindingManagable[])

Refreshs the specified list.

bool Refresh(
vdxBindingManagerRefreshKind kind,
params IvdxBindingManagable[] bms
);

Parameters

kind
Which objects are refreshed.
bms
List of objects to be refreshed.

Return Value

Whether the given managed objects were refreshed (due to validation errors for example)

See Also

IvdxBindingManager Interface | Deag.Vdx.Controls.Core Namespace | IvdxBindingManager.Refresh Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxBindingManager.Remove Method

Removes a binding managable from the collection.

void Remove(
IvdxBindingManagable bm
);

Parameters

bm
The binding managable that will be removed.

See Also

IvdxBindingManager Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxChangeable Interface

Defines the interface for all datamanipulation management controls (including the vdxDataStatusManager, vdxExplorerTree, vdxExplorerGrid, ...) which are involved in the VDX datamanipulation concept.

For a list of all members of this type, see IvdxChangeable Members.

public interface IvdxChangeable

Remarks

This interface is used when detection capabilities of changes are needed as well as activating pending changes must be implemented.

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

IvdxChangeable Members | Deag.Vdx.Controls.Core Namespace | vdxDataControl | vdxDataStatusManager | vdxMultiContainer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxChangeable Members

IvdxChangeable overview

Public Instance Methods

HandleChanges | Activates and displays the unsaved changes to the user which can decide if he wants to save the changes.
HasChanges | Indicates if a component or one of its subcomponents have pending changes.

See Also

IvdxChangeable Interface | Deag.Vdx.Controls.Core Namespace | vdxDataControl | vdxDataStatusManager | vdxMultiContainer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxChangeable Methods

The methods of the IvdxChangeable interface are listed below. For a complete list of IvdxChangeable interface members, see the IvdxChangeable Members topic.

Public Instance Methods

HandleChanges | Activates and displays the unsaved changes to the user which can decide if he wants to save the changes.
HasChanges | Indicates if a component or one of its subcomponents have pending changes.

See Also

IvdxChangeable Interface | Deag.Vdx.Controls.Core Namespace | vdxDataControl | vdxDataStatusManager | vdxMultiContainer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxChangeable.HandleChanges Method

Activates and displays the unsaved changes to the user which can decide if he wants to save the changes.

bool HandleChanges();

Return Value

True if there are changes.

Remarks

If there are no changes, nothing happens. Therefore, you can usually use directly this method.

See Also

IvdxChangeable Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxChangeable.HasChanges Method

Indicates if a component or one of its subcomponents have pending changes.

bool HasChanges();

Return Value

True if there are changes.

Remarks

You don't have to use this property if you want to activate pending changes. Since the HandleChanges method can be called safetely, also if there are no pendig changes.

See Also

IvdxChangeable Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataActionManagerConsumer Interface

Provides a vdxDataActionManager property that can hold several ActionItems.

For a list of all members of this type, see IvdxDataActionManagerConsumer Members.

public interface IvdxDataActionManagerConsumer

Remarks

Ensures the passing of the vdxDataActionManager from the MainForm through the hierarchy of all vdxDataMultiContainers and vdxExplorers. A vdxDataMultiContainer can hold an amount of vdxExplorers and the vdxDataMultiContainer of a vdxExplorer can hold again an amount of vdxExplorers. The innermost IvdxDataActionManagerConsumer will connect the passed vdxDataActionManager with the vdxDataStatusManager of the editable IvdxDataLoader component.

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

IvdxDataActionManagerConsumer Members | Deag.Vdx.Controls.Core Namespace | vdxExplorer | vdxDataMultiContainer | vdxDataStatusManager

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataActionManagerConsumer Members

IvdxDataActionManagerConsumer overview

Public Instance Properties

DataActionManager Gets or sets the corresponding vdxDataActionManager to enable/disable actions after a status changed.

See Also

IvdxDataActionManagerConsumer Interface | Deag.Vdx.Controls.Core Namespace | vdxExplorer | vdxDataMultiContainer | vdxDataStatusManager

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataActionManagerConsumer Properties

The properties of the IvdxDataActionManagerConsumer interface are listed below. For a complete list of IvdxDataActionManagerConsumer interface members, see the IvdxDataActionManagerConsumer Members topic.

Public Instance Properties

DataActionManager Gets or sets the corresponding vdxDataActionManager to enable/disable actions after a status changed.

See Also

IvdxDataActionManagerConsumer Interface | Deag.Vdx.Controls.Core Namespace | vdxExplorer | vdxDataMultiContainer | vdxDataStatusManager

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataActionManagerConsumer.DataActionManager Property

Gets or sets the corresponding vdxDataActionManager to enable/disable actions after a status changed.

vdxDataActionManager DataActionManager {get; set;}

See Also

IvdxDataActionManagerConsumer Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataLoader Interface

Defines the interface for components that can load and manipulate data.

For a list of all members of this type, see IvdxDataLoader Members.

public interface IvdxDataLoader

Remarks

Classes that implement IvdxDataLoader:

  • vdxDataDetail
  • vdxExplorer
The methods allow to load (PerformDataLoad) and reload (RefreshData) the data managed by the IvdxDataLoader.

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

IvdxDataLoader Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataLoader Members

IvdxDataLoader overview

Public Instance Properties

SearchParameters Gets the related search parameters of the component.

Public Instance Methods

ClearSearchParameters | Clear search parameters.
IsRefreshable | Checks if the component can be refreshed.
PerformDataLoad | Delegates the components to load the corresponding data with the given search parameters.
RefreshData | Loads again the data.

See Also

IvdxDataLoader Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataLoader Properties

The properties of the IvdxDataLoader interface are listed below. For a complete list of IvdxDataLoader interface members, see the IvdxDataLoader Members topic.

Public Instance Properties

SearchParameters Gets the related search parameters of the component.

See Also

IvdxDataLoader Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataLoader.SearchParameters Property

Gets the related search parameters of the component.

Deag.Vdx.Common.vdxSearchParameters SearchParameters {get;}

See Also

IvdxDataLoader Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataLoader Methods

The methods of the IvdxDataLoader interface are listed below. For a complete list of IvdxDataLoader interface members, see the IvdxDataLoader Members topic.

Public Instance Methods

ClearSearchParameters | Clear search parameters.
IsRefreshable | Checks if the component can be refreshed.
PerformDataLoad | Delegates the components to load the corresponding data with the given search parameters.
RefreshData | Loads again the data.

See Also

IvdxDataLoader Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataLoader.ClearSearchParameters Method

Clear search parameters.

void ClearSearchParameters();

See Also

IvdxDataLoader Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataLoader.IsRefreshable Method

Checks if the component can be refreshed.

bool IsRefreshable();

See Also

IvdxDataLoader Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataLoader.PerformDataLoad Method

Delegates the components to load the corresponding data with the given search parameters.

void PerformDataLoad(
vdxSearchParameters searchParameters
);

Parameters

searchParameters
The specific search arguments.

See Also

IvdxDataLoader Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataLoader.RefreshData Method

Loads again the data.

void RefreshData();

See Also

IvdxDataLoader Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataManipulator Interface

Defines the interface for components that data can be manipulated.

For a list of all members of this type, see IvdxDataManipulator Members.

public interface IvdxDataManipulator

Remarks

The main using is on user controls that holds a vdxDataStatusManager like the vdxDataDetail.

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

IvdxDataManipulator Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataManipulator Members

IvdxDataManipulator overview

Public Instance Methods

AcceptNewData Does this manipulator accept new data. Are there any changes?

Public Instance Events

Copied | Occurs after vdxDataStatusManager has copied data.
Deleted | Occurs after vdxDataStatusManager has deleted data.
Inserted | Occurs after vdxDataStatusManager has inserted new data.
Undone | Occurs after vdxDataStatusManager has undone data changes.
Updated | Occurs after vdxDataStatusManager has updated data.

See Also

IvdxDataManipulator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataManipulator Methods

The methods of the IvdxDataManipulator interface are listed below. For a complete list of IvdxDataManipulator interface members, see the IvdxDataManipulator Members topic.

Public Instance Methods

AcceptNewData Does this manipulator accept new data. Are there any changes?

See Also

IvdxDataManipulator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataManipulator.AcceptNewData Method

Does this manipulator accept new data. Are there any changes?

bool AcceptNewData();

Return Value

True if new data is allowed.

See Also

IvdxDataManipulator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataManipulator Events

The events of the IvdxDataManipulator interface are listed below. For a complete list of IvdxDataManipulator interface members, see the IvdxDataManipulator Members topic.

Public Instance Events

Copied | Occurs after vdxDataStatusManager has copied data.
Deleted | Occurs after vdxDataStatusManager has deleted data.
Inserted | Occurs after vdxDataStatusManager has inserted new data.
Undone | Occurs after vdxDataStatusManager has undone data changes.
Updated | Occurs after vdxDataStatusManager has updated data.

See Also

IvdxDataManipulator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataManipulator.Copied Event

Occurs after vdxDataStatusManager has copied data.

event vdxDataManipulatorEventHandler Copied;

Event Data

The event handler receives an argument of type vdxDataManipulatorEventArgs containing data related to this event. The following vdxDataManipulatorEventArgs property provides information specific to this event.

Property | Description
Data | Gets the involved .

See Also

IvdxDataManipulator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataManipulator.Deleted Event

Occurs after vdxDataStatusManager has deleted data.

event vdxDataManipulatorEventHandler Deleted;

Event Data

The event handler receives an argument of type vdxDataManipulatorEventArgs containing data related to this event. The following vdxDataManipulatorEventArgs property provides information specific to this event.

Property | Description
Data | Gets the involved .

See Also

IvdxDataManipulator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataManipulator.Inserted Event

Occurs after vdxDataStatusManager has inserted new data.

event vdxDataManipulatorEventHandler Inserted;

Event Data

The event handler receives an argument of type vdxDataManipulatorEventArgs containing data related to this event. The following vdxDataManipulatorEventArgs property provides information specific to this event.

Property | Description
Data | Gets the involved .

See Also

IvdxDataManipulator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataManipulator.Undone Event

Occurs after vdxDataStatusManager has undone data changes.

event vdxDataManipulatorEventHandler Undone;

Event Data

The event handler receives an argument of type vdxDataManipulatorEventArgs containing data related to this event. The following vdxDataManipulatorEventArgs property provides information specific to this event.

Property | Description
Data | Gets the involved .

See Also

IvdxDataManipulator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataManipulator.Updated Event

Occurs after vdxDataStatusManager has updated data.

event vdxDataManipulatorEventHandler Updated;

Event Data

The event handler receives an argument of type vdxDataManipulatorEventArgs containing data related to this event. The following vdxDataManipulatorEventArgs property provides information specific to this event.

Property | Description
Data | Gets the involved .

See Also

IvdxDataManipulator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataSetProvider Interface

Defines the interface for components that are listed in the property TableName of the vdxDataView class.

For a list of all members of this type, see IvdxDataSetProvider Members.

public interface IvdxDataSetProvider

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

IvdxDataSetProvider Members | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager | vdxDataSetReference | vdxDataView

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataSetProvider Members

IvdxDataSetProvider overview

Public Instance Properties

DataSet | Gets or sets the managed DataSet.
DataSetType | Gets or sets the managed DataSet type.
Name | Gets the designer component name. Corresponds to the Property (Name).

Public Instance Methods

Contains Check if table exists in the managed DataSet.

Public Instance Events

OnDataTypeSet Occurs after the DataSet type was set.

See Also

IvdxDataSetProvider Interface | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager | vdxDataSetReference | vdxDataView

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataSetProvider Properties

The properties of the IvdxDataSetProvider interface are listed below. For a complete list of IvdxDataSetProvider interface members, see the IvdxDataSetProvider Members topic.

Public Instance Properties

DataSet | Gets or sets the managed DataSet.
DataSetType | Gets or sets the managed DataSet type.
Name | Gets the designer component name. Corresponds to the Property (Name).

See Also

IvdxDataSetProvider Interface | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager | vdxDataSetReference | vdxDataView

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataSetProvider.DataSet Property

Gets or sets the managed DataSet.

System.Data.DataSet DataSet {get; set;}

See Also

IvdxDataSetProvider Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataSetProvider.DataSetType Property

Gets or sets the managed DataSet type.

System.Type DataSetType {get; set;}

See Also

IvdxDataSetProvider Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataSetProvider.Name Property

Gets the designer component name. Corresponds to the Property (Name).

string Name {get;}

See Also

IvdxDataSetProvider Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataSetProvider Methods

The methods of the IvdxDataSetProvider interface are listed below. For a complete list of IvdxDataSetProvider interface members, see the IvdxDataSetProvider Members topic.

Public Instance Methods

Contains Check if table exists in the managed DataSet.

See Also

IvdxDataSetProvider Interface | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager | vdxDataSetReference | vdxDataView

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataSetProvider.Contains Method

Check if table exists in the managed DataSet.

bool Contains(
DataTable table
);

Parameters

table
Table to search for.

Return Value

True, if table was found.

See Also

IvdxDataSetProvider Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataSetProvider Events

The events of the IvdxDataSetProvider interface are listed below. For a complete list of IvdxDataSetProvider interface members, see the IvdxDataSetProvider Members topic.

Public Instance Events

OnDataTypeSet Occurs after the DataSet type was set.

See Also

IvdxDataSetProvider Interface | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager | vdxDataSetReference | vdxDataView

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDataSetProvider.OnDataTypeSet Event

Occurs after the DataSet type was set.

event EventHandler OnDataTypeSet;

See Also

IvdxDataSetProvider Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDsmHost Interface

Each control wich can be managed by the vdxDataStatusManager must implement this interface.

For a list of all members of this type, see IvdxDsmHost Members.

public interface IvdxDsmHost

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

IvdxDsmHost Members | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager | Deag.Vdx.Controls.Base

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDsmHost Members

IvdxDsmHost overview

Public Instance Properties

DataStatusManager Gets or sets the vdxDataStatusManager which manage the data binding of the implementator.

See Also

IvdxDsmHost Interface | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager | Deag.Vdx.Controls.Base

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDsmHost Properties

The properties of the IvdxDsmHost interface are listed below. For a complete list of IvdxDsmHost interface members, see the IvdxDsmHost Members topic.

Public Instance Properties

DataStatusManager Gets or sets the vdxDataStatusManager which manage the data binding of the implementator.

See Also

IvdxDsmHost Interface | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager | Deag.Vdx.Controls.Base

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDsmHost.DataStatusManager Property

Gets or sets the vdxDataStatusManager which manage the data binding of the implementator.

vdxDataStatusManager DataStatusManager {get; set;}

See Also

IvdxDsmHost Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDsmProvider Interface

Defines the interface for user controls that status changes are handled by a vdxDataStatusManager.

For a list of all members of this type, see IvdxDsmProvider Members.

public interface IvdxDsmProvider

Remarks

Use this interface to establish the communication between your user control and the dataStatusManager.

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

IvdxDsmProvider Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDsmProvider Members

IvdxDsmProvider overview

Public Instance Properties

DataStatusManager Gets or sets the corresponding manager that controls the data status changes of this user control.

See Also

IvdxDsmProvider Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDsmProvider Properties

The properties of the IvdxDsmProvider interface are listed below. For a complete list of IvdxDsmProvider interface members, see the IvdxDsmProvider Members topic.

Public Instance Properties

DataStatusManager Gets or sets the corresponding manager that controls the data status changes of this user control.

See Also

IvdxDsmProvider Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxDsmProvider.DataStatusManager Property

Gets or sets the corresponding manager that controls the data status changes of this user control.

vdxDataStatusManager DataStatusManager {get;}

See Also

IvdxDsmProvider Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxGetContextAssembly Interface

This interface is used for all controls, where the Typeconverter cannot access the context assembly directly.

For a list of all members of this type, see IvdxGetContextAssembly Members.

public interface IvdxGetContextAssembly

Remarks

This interface is used in the vdxDataStatusManager class. Usually, you will not use this interface directly. This interface gets implemented to allow access to the context assembly if the implementing class has no default access to the context assembly because it's container does not implement the IDesignerHost interface.

Example

The class vdxDataDetail uses a vdxDataStatusManager which is defined in the base class and therefore has no direct access to the context assembly.

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

IvdxGetContextAssembly Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxGetContextAssembly Members

IvdxGetContextAssembly overview

Public Instance Methods

VdxGetContextAssembly Used to retrieve the IDesignerHost.

See Also

IvdxGetContextAssembly Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxGetContextAssembly Methods

The methods of the IvdxGetContextAssembly interface are listed below. For a complete list of IvdxGetContextAssembly interface members, see the IvdxGetContextAssembly Members topic.

Public Instance Methods

VdxGetContextAssembly Used to retrieve the IDesignerHost.

See Also

IvdxGetContextAssembly Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxGetContextAssembly.VdxGetContextAssembly Method

Used to retrieve the IDesignerHost.

Assembly VdxGetContextAssembly();

Return Value

Returns the context assembly of type System.Reflection.Assembly.

Remarks

Used internally by the reflection class through type converters to get a reference to the context assembly.

See Also

IvdxGetContextAssembly Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxInputControl Interface

Interface for controls that handle user inputs.

For a list of all members of this type, see IvdxInputControl Members.

public interface IvdxInputControl : IvdxDsmHost, IvdxResettable, IvdxBindingManagable

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

IvdxInputControl Members | Deag.Vdx.Controls.Core Namespace | vdxCheckBox | vdxCheckGroupBox | vdxComboBox | vdxComboBoxEdit | vdxPickField | vdxRichTextBox | vdxTextBox

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxInputControl Members

IvdxInputControl overview

Public Instance Properties

BindEmptyValuesAsNull | Gets or sets whether the empty values must be binded as null.
InteractWithDSM | Gets or sets a value indicating whether this control should interact with the DSM.

Public Instance Methods

InitializeBinding Do any initializing work like converting format.

See Also

IvdxInputControl Interface | Deag.Vdx.Controls.Core Namespace | vdxCheckBox | vdxCheckGroupBox | vdxComboBox | vdxComboBoxEdit | vdxPickField | vdxRichTextBox | vdxTextBox

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxInputControl Properties

The properties of the IvdxInputControl interface are listed below. For a complete list of IvdxInputControl interface members, see the IvdxInputControl Members topic.

Public Instance Properties

BindEmptyValuesAsNull | Gets or sets whether the empty values must be binded as null.
InteractWithDSM | Gets or sets a value indicating whether this control should interact with the DSM.

See Also

IvdxInputControl Interface | Deag.Vdx.Controls.Core Namespace | vdxCheckBox | vdxCheckGroupBox | vdxComboBox | vdxComboBoxEdit | vdxPickField | vdxRichTextBox | vdxTextBox

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxInputControl.BindEmptyValuesAsNull Property

Gets or sets whether the empty values must be binded as null.

bool BindEmptyValuesAsNull {get; set;}

See Also

IvdxInputControl Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxInputControl.InteractWithDSM Property

Gets or sets a value indicating whether this control should interact with the DSM.

bool InteractWithDSM {get; set;}

Remarks

If set to false than the control will not force an AutoEdit on the DSM.

See Also

IvdxInputControl Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxInputControl Methods

The methods of the IvdxInputControl interface are listed below. For a complete list of IvdxInputControl interface members, see the IvdxInputControl Members topic.

Public Instance Methods

InitializeBinding Do any initializing work like converting format.

See Also

IvdxInputControl Interface | Deag.Vdx.Controls.Core Namespace | vdxCheckBox | vdxCheckGroupBox | vdxComboBox | vdxComboBoxEdit | vdxPickField | vdxRichTextBox | vdxTextBox

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxInputControl.InitializeBinding Method

Do any initializing work like converting format.

void InitializeBinding(
Binding binding
);

Parameters

binding

Example

Example with vdxCheckBox:

            void IvdxInputControl.InitializeBinding(System.Windows.Forms.Binding binding)
            {
                binding.Format += new ConvertEventHandler(Binding_Format);
            }

            private void Binding_Format(object sender, ConvertEventArgs e)
            {
                if (e.Value == DBNull.Value)
                    e.Value = false;
            }

See Also

IvdxInputControl Interface | Deag.Vdx.Controls.Core Namespace | vdxCheckBox

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxLogon Interface

Interface for all VDX-compatible logon dialogs.

For a list of all members of this type, see IvdxLogon Members.

public interface IvdxLogon

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

IvdxLogon Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxLogon Members

IvdxLogon overview

Public Instance Properties

ApplicationUser | Gets or sets the application user.
DialogResult | Gets or sets the dialog result.

Public Instance Methods

Clear | Clears the input values.
Logon | Log on the application user.
ShowDialog | Overloaded. Shows this logon dialog with the given owner.

See Also

IvdxLogon Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxLogon Properties

The properties of the IvdxLogon interface are listed below. For a complete list of IvdxLogon interface members, see the IvdxLogon Members topic.

Public Instance Properties

ApplicationUser | Gets or sets the application user.
DialogResult | Gets or sets the dialog result.

See Also

IvdxLogon Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxLogon.ApplicationUser Property

Gets or sets the application user.

object ApplicationUser {get; set;}

See Also

IvdxLogon Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxLogon.DialogResult Property

Gets or sets the dialog result.

System.Windows.Forms.DialogResult DialogResult {get; set;}

See Also

IvdxLogon Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxLogon Methods

The methods of the IvdxLogon interface are listed below. For a complete list of IvdxLogon interface members, see the IvdxLogon Members topic.

Public Instance Methods

Clear | Clears the input values.
Logon | Log on the application user.
ShowDialog | Overloaded. Shows this logon dialog with the given owner.

See Also

IvdxLogon Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxLogon.Clear Method

Clears the input values.

void Clear();

See Also

IvdxLogon Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxLogon.Logon Method

Log on the application user.

void Logon();

See Also

IvdxLogon Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ShowDialog Method

VDX Framework

IvdxLogon.ShowDialog Method

Shows this logon dialog without owner.

Overload List

Shows this logon dialog without owner.

void ShowDialog();

Shows this logon dialog with the given owner.

void ShowDialog(IWin32Window);

See Also

IvdxLogon Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxLogon.ShowDialog Method ()

Shows this logon dialog without owner.

void ShowDialog();

See Also

IvdxLogon Interface | Deag.Vdx.Controls.Core Namespace | IvdxLogon.ShowDialog Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxLogon.ShowDialog Method (IWin32Window)

Shows this logon dialog with the given owner.

void ShowDialog(
IWin32Window owner
);

See Also

IvdxLogon Interface | Deag.Vdx.Controls.Core Namespace | IvdxLogon.ShowDialog Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxMultiContainerCacheable Interface

Defines the interface for components, which can managed by a vdxMultiContainer.

For a list of all members of this type, see IvdxMultiContainerCacheable Members.

public interface IvdxMultiContainerCacheable

Remarks

The user has the possibility to interact during the different status a cacheable component can has.

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

IvdxMultiContainerCacheable Members | Deag.Vdx.Controls.Core Namespace | vdxCacheableControl

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxMultiContainerCacheable Members

IvdxMultiContainerCacheable overview

Public Instance Methods

Activate | The method is called each time the instance of the compenent was re-shown.
Create | The method is called once in the lifetime of the cacheable component after this was instantiated.
Deactivate | The method is called each time the instance of the compenent was hidden.
DeactivateAllowed | Checks if the component can be deactivated.
Reactivate | The method is called each time the instance of the compenent was set as current control.

See Also

IvdxMultiContainerCacheable Interface | Deag.Vdx.Controls.Core Namespace | vdxCacheableControl

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxMultiContainerCacheable Methods

The methods of the IvdxMultiContainerCacheable interface are listed below. For a complete list of IvdxMultiContainerCacheable interface members, see the IvdxMultiContainerCacheable Members topic.

Public Instance Methods

Activate | The method is called each time the instance of the compenent was re-shown.
Create | The method is called once in the lifetime of the cacheable component after this was instantiated.
Deactivate | The method is called each time the instance of the compenent was hidden.
DeactivateAllowed | Checks if the component can be deactivated.
Reactivate | The method is called each time the instance of the compenent was set as current control.

See Also

IvdxMultiContainerCacheable Interface | Deag.Vdx.Controls.Core Namespace | vdxCacheableControl

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxMultiContainerCacheable.Activate Method

The method is called each time the instance of the compenent was re-shown.

void Activate();

See Also

IvdxMultiContainerCacheable Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxMultiContainerCacheable.Create Method

The method is called once in the lifetime of the cacheable component after this was instantiated.

void Create();

See Also

IvdxMultiContainerCacheable Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxMultiContainerCacheable.Deactivate Method

The method is called each time the instance of the compenent was hidden.

void Deactivate();

See Also

IvdxMultiContainerCacheable Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxMultiContainerCacheable.DeactivateAllowed Method

Checks if the component can be deactivated.

bool DeactivateAllowed();

Return Value

If true, the component allows the deactivate, otherwise it is blocked.

See Also

IvdxMultiContainerCacheable Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxMultiContainerCacheable.Reactivate Method

The method is called each time the instance of the compenent was set as current control.

void Reactivate();

See Also

IvdxMultiContainerCacheable Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxNavigator Interface

Defines the inferface for all components, which can navigate through a amount of data. The information what was selected, inserted, updated is transported over the vdxNavigatorInfo.

For a list of all members of this type, see IvdxNavigator Members.

public interface IvdxNavigator

Remarks

Normally the navigators are managed by a vdxExplorer that can holds more than one navigator. The navigators can communicate their selection changes over the SelectionChanged event. But receive also a ChangeSelection command. The ControlChanged event is used to inform the vdxExplorer about control changes to show the corresponding control in its vdxMultiContainer.

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

IvdxNavigator Members | Deag.Vdx.Controls.Core Namespace | vdxNavigatorInfo | vdxExplorer | vdxMultiContainer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxNavigator Members

IvdxNavigator overview

Public Instance Methods

ChangeSelection | Changes the selection to the corresponding vdxNavigatorInfo in the navigator.
Clear | Remove all elements from the navigator.
Copy | Copies the given navigator element.
Delete | Deletes the given navigator element.
Fill | Constructs the navigator with the given DataSet.
GetLoaderInfo | Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.
Insert | Inserts a new navigator element for the corresponding navigatorDataRow.
IsRefreshable | Checks if the component supports refresh.
RefreshData | Remove all elements from the navigator and fill up the given dataSet.
SelectDefault | Selects the default element.
Undo | Undo changes for the given navigator element.
Update | Updates the given navigator element.

Public Instance Events

ControlChanged | Occurs when an other cacheable control had to be shown.
SelectionChanged | Occurs when an other vdxNavigatorInfo was selected.

See Also

IvdxNavigator Interface | Deag.Vdx.Controls.Core Namespace | vdxNavigatorInfo | vdxExplorer | vdxMultiContainer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxNavigator Methods

The methods of the IvdxNavigator interface are listed below. For a complete list of IvdxNavigator interface members, see the IvdxNavigator Members topic.

Public Instance Methods

ChangeSelection | Changes the selection to the corresponding vdxNavigatorInfo in the navigator.
Clear | Remove all elements from the navigator.
Copy | Copies the given navigator element.
Delete | Deletes the given navigator element.
Fill | Constructs the navigator with the given DataSet.
GetLoaderInfo | Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.
Insert | Inserts a new navigator element for the corresponding navigatorDataRow.
IsRefreshable | Checks if the component supports refresh.
RefreshData | Remove all elements from the navigator and fill up the given dataSet.
SelectDefault | Selects the default element.
Undo | Undo changes for the given navigator element.
Update | Updates the given navigator element.

See Also

IvdxNavigator Interface | Deag.Vdx.Controls.Core Namespace | vdxNavigatorInfo | vdxExplorer | vdxMultiContainer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxNavigator.ChangeSelection Method

Changes the selection to the corresponding vdxNavigatorInfo in the navigator.

void ChangeSelection(
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorInfo
The navigator element to be selected.

See Also

IvdxNavigator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxNavigator.Clear Method

Remove all elements from the navigator.

void Clear();

See Also

IvdxNavigator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxNavigator.Copy Method

Copies the given navigator element.

void Copy(
DataRow navigatorDataRow,
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorDataRow
The copied row.
navigatorInfo
The last selected navigator element.

See Also

IvdxNavigator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxNavigator.Delete Method

Deletes the given navigator element.

void Delete(
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorInfo
The last selected navigator element.

See Also

IvdxNavigator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxNavigator.Fill Method

Constructs the navigator with the given DataSet.

void Fill(
DataSet dataSet
);

Parameters

dataSet
The dataSet, which the navigator extract all rows out of.

See Also

IvdxNavigator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxNavigator.GetLoaderInfo Method

Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.

vdxLoaderInfo GetLoaderInfo(
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorInfo
Contains the DataRow to define the vdxLoaderInfo.

Return Value

The vdxLoaderInfo for the given navigatorInfo.

See Also

IvdxNavigator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxNavigator.Insert Method

Inserts a new navigator element for the corresponding navigatorDataRow.

void Insert(
DataRow navigatorDataRow,
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorDataRow
The row to be inserted.
navigatorInfo
The last selected navigator element.

See Also

IvdxNavigator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxNavigator.IsRefreshable Method

Checks if the component supports refresh.

bool IsRefreshable();

See Also

IvdxNavigator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxNavigator.RefreshData Method

Remove all elements from the navigator and fill up the given dataSet.

vdxNavigatorInfo RefreshData(
DataSet dataSet
);

Parameters

dataSet
The dataSet, which the navigator extract all rows out of.

See Also

IvdxNavigator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxNavigator.SelectDefault Method

Selects the default element.

void SelectDefault();

See Also

IvdxNavigator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxNavigator.Undo Method

Undo changes for the given navigator element.

void Undo(
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorInfo
The last selected navigator element.

See Also

IvdxNavigator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxNavigator.Update Method

Updates the given navigator element.

void Update(
DataRow navigatorDataRow,
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorDataRow
The updated row.
navigatorInfo
The last selected navigator element.

See Also

IvdxNavigator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxNavigator Events

The events of the IvdxNavigator interface are listed below. For a complete list of IvdxNavigator interface members, see the IvdxNavigator Members topic.

Public Instance Events

ControlChanged | Occurs when an other cacheable control had to be shown.
SelectionChanged | Occurs when an other vdxNavigatorInfo was selected.

See Also

IvdxNavigator Interface | Deag.Vdx.Controls.Core Namespace | vdxNavigatorInfo | vdxExplorer | vdxMultiContainer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxNavigator.ControlChanged Event

Occurs when an other cacheable control had to be shown.

event vdxNavigatorControlEventHandler ControlChanged;

Event Data

The event handler receives an argument of type vdxNavigatorControlEventArgs containing data related to this event. The following vdxNavigatorControlEventArgs property provides information specific to this event.

Property | Description
LoaderInfo | Gets the involved .

Remarks

See Also

IvdxNavigator Interface | Deag.Vdx.Controls.Core Namespace | vdxExplorer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxNavigator.SelectionChanged Event

Occurs when an other vdxNavigatorInfo was selected.

event vdxNavigatorSelectionEventHandler SelectionChanged;

Event Data

The event handler receives an argument of type vdxNavigatorSelectionEventArgs containing data related to this event. The following vdxNavigatorSelectionEventArgs property provides information specific to this event.

Property | Description
NavigatorInfo | Gets the involved .

See Also

IvdxNavigator Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxPicker Interface

Defines the interface for components that supports pick field dialogs.

For a list of all members of this type, see IvdxPicker Members.

public interface IvdxPicker

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

IvdxPicker Members | Deag.Vdx.Controls.Core Namespace | vdxPickerDialog | vdxPickField

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxPicker Members

IvdxPicker overview

Public Instance Properties

PickField Gets or sets the caller pick field.

Public Instance Methods

Clear | Resets all fields on the picker.
Close | Closes the picker.
Show | Makes the picker visible.

Public Instance Events

PickerAccepted | Occurs when the value or values were accepted.
PickerCancelled | Occurs when the picker routine was canceled.

See Also

IvdxPicker Interface | Deag.Vdx.Controls.Core Namespace | vdxPickerDialog | vdxPickField

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxPicker Properties

The properties of the IvdxPicker interface are listed below. For a complete list of IvdxPicker interface members, see the IvdxPicker Members topic.

Public Instance Properties

PickField Gets or sets the caller pick field.

See Also

IvdxPicker Interface | Deag.Vdx.Controls.Core Namespace | vdxPickerDialog | vdxPickField

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxPicker.PickField Property

Gets or sets the caller pick field.

System.Windows.Forms.Control PickField {get; set;}

See Also

IvdxPicker Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxPicker Methods

The methods of the IvdxPicker interface are listed below. For a complete list of IvdxPicker interface members, see the IvdxPicker Members topic.

Public Instance Methods

Clear | Resets all fields on the picker.
Close | Closes the picker.
Show | Makes the picker visible.

See Also

IvdxPicker Interface | Deag.Vdx.Controls.Core Namespace | vdxPickerDialog | vdxPickField

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxPicker.Clear Method

Resets all fields on the picker.

void Clear();

See Also

IvdxPicker Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxPicker.Close Method

Closes the picker.

void Close();

See Also

IvdxPicker Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxPicker.Show Method

Makes the picker visible.

void Show();

See Also

IvdxPicker Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxPicker Events

The events of the IvdxPicker interface are listed below. For a complete list of IvdxPicker interface members, see the IvdxPicker Members topic.

Public Instance Events

PickerAccepted | Occurs when the value or values were accepted.
PickerCancelled | Occurs when the picker routine was canceled.

See Also

IvdxPicker Interface | Deag.Vdx.Controls.Core Namespace | vdxPickerDialog | vdxPickField

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxPicker.PickerAccepted Event

Occurs when the value or values were accepted.

event vdxPickerEventHandler PickerAccepted;

Event Data

The event handler receives an argument of type vdxPickerEventArgs containing data related to this event. The following vdxPickerEventArgs property provides information specific to this event.

Property | Description
PickerInfo | Gets the vdxPickerInfo object.

See Also

IvdxPicker Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxPicker.PickerCancelled Event

Occurs when the picker routine was canceled.

event vdxPickerEventHandler PickerCancelled;

Event Data

The event handler receives an argument of type vdxPickerEventArgs containing data related to this event. The following vdxPickerEventArgs property provides information specific to this event.

Property | Description
PickerInfo | Gets the vdxPickerInfo object.

See Also

IvdxPicker Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxResettable Interface

Defines the Interface for all controls that must provide the the capability to be reset to an originl value. This includes Text Boxes, Combo Boxes and so on. Within Vdx, these controls are reset when the clear button is pressed.

For a list of all members of this type, see IvdxResettable Members.

public interface IvdxResettable

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

IvdxResettable Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxResettable Members

IvdxResettable overview

Public Instance Methods

Reset Resets the value of the control.

See Also

IvdxResettable Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxResettable Methods

The methods of the IvdxResettable interface are listed below. For a complete list of IvdxResettable interface members, see the IvdxResettable Members topic.

Public Instance Methods

Reset Resets the value of the control.

See Also

IvdxResettable Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxResettable.Reset Method

Resets the value of the control.

void Reset();

See Also

IvdxResettable Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxSearchControl Interface

Defines the interface for components that manage a search parameters.

For a list of all members of this type, see IvdxSearchControl Members.

public interface IvdxSearchControl

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

IvdxSearchControl Members | Deag.Vdx.Controls.Core Namespace | vdxSelection

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxSearchControl Members

IvdxSearchControl overview

Public Instance Methods

Clear | Reset all Fields on search control.
FillSearchParameters | Read parameters from user control and fill them into vdxSearchParameters.

Public Instance Events

SearchParamsFilled Occurs when user the search parameters were filled.

See Also

IvdxSearchControl Interface | Deag.Vdx.Controls.Core Namespace | vdxSelection

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxSearchControl Methods

The methods of the IvdxSearchControl interface are listed below. For a complete list of IvdxSearchControl interface members, see the IvdxSearchControl Members topic.

Public Instance Methods

Clear | Reset all Fields on search control.
FillSearchParameters | Read parameters from user control and fill them into vdxSearchParameters.

See Also

IvdxSearchControl Interface | Deag.Vdx.Controls.Core Namespace | vdxSelection

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxSearchControl.Clear Method

Reset all Fields on search control.

void Clear();

See Also

IvdxSearchControl Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxSearchControl.FillSearchParameters Method

Read parameters from user control and fill them into vdxSearchParameters.

vdxSearchParameters FillSearchParameters();

Return Value

The builded vdxSearchParameters from the user control

See Also

IvdxSearchControl Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxSearchControl Events

The events of the IvdxSearchControl interface are listed below. For a complete list of IvdxSearchControl interface members, see the IvdxSearchControl Members topic.

Public Instance Events

SearchParamsFilled Occurs when user the search parameters were filled.

See Also

IvdxSearchControl Interface | Deag.Vdx.Controls.Core Namespace | vdxSelection

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxSearchControl.SearchParamsFilled Event

Occurs when user the search parameters were filled.

event vdxSearchParametersFilledEventHandler SearchParamsFilled;

Event Data

The event handler receives an argument of type vdxSearchParametersFilledEventArgs containing data related to this event. The following vdxSearchParametersFilledEventArgs property provides information specific to this event.

Property | Description
SearchParameters | Gets the vdxSearchParameters object.

See Also

IvdxSearchControl Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxSplashScreen Interface

Defines the interface for components, which can be set on vdxApplication.

For a list of all members of this type, see IvdxSplashScreen Members.

public interface IvdxSplashScreen

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

IvdxSplashScreen Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxSplashScreen Members

IvdxSplashScreen overview

Public Instance Methods

HideSplash | Hides splash.
SetActionText | Sets action text for current task.
ShowSplash | Overloaded. Show splash until time duration ends.
ShowSplashModal | Show modal splash until time duration ends.

See Also

IvdxSplashScreen Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxSplashScreen Methods

The methods of the IvdxSplashScreen interface are listed below. For a complete list of IvdxSplashScreen interface members, see the IvdxSplashScreen Members topic.

Public Instance Methods

HideSplash | Hides splash.
SetActionText | Sets action text for current task.
ShowSplash | Overloaded. Show splash until time duration ends.
ShowSplashModal | Show modal splash until time duration ends.

See Also

IvdxSplashScreen Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxSplashScreen.HideSplash Method

Hides splash.

void HideSplash();

See Also

IvdxSplashScreen Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxSplashScreen.SetActionText Method

Sets action text for current task.

void SetActionText(
string actionText
);

Parameters

actionText

See Also

IvdxSplashScreen Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ShowSplash Method

VDX Framework

IvdxSplashScreen.ShowSplash Method

Show splash without timer.

Overload List

Show splash without timer.

void ShowSplash();

Show splash until time duration ends.

void ShowSplash(int);

See Also

IvdxSplashScreen Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxSplashScreen.ShowSplash Method ()

Show splash without timer.

void ShowSplash();

See Also

IvdxSplashScreen Interface | Deag.Vdx.Controls.Core Namespace | IvdxSplashScreen.ShowSplash Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxSplashScreen.ShowSplash Method (Int32)

Show splash until time duration ends.

void ShowSplash(
int duration
);

Parameters

duration
Show time in milliseconds

See Also

IvdxSplashScreen Interface | Deag.Vdx.Controls.Core Namespace | IvdxSplashScreen.ShowSplash Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxSplashScreen.ShowSplashModal Method

Show modal splash until time duration ends.

void ShowSplashModal(
int duration
);

Parameters

duration
Show time in milliseconds

See Also

IvdxSplashScreen Interface | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionInvokerCollection Class

The collection that holds all action invoker items.

For a list of all members of this type, see vdxActionInvokerCollection Members.

System.Object
CollectionBase
vdxActionInvokerCollection

public class vdxActionInvokerCollection : CollectionBase

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxActionInvokerCollection Members | Deag.Vdx.Controls.Core Namespace | CollectionBase

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionInvokerCollection Members

vdxActionInvokerCollection overview

Public Instance Constructors

vdxActionInvokerCollection Constructor Initializes a new instance of the vdxActionInvokerCollection class.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Gets or sets the action invoker item at the specified index.

Public Instance Methods

Add | Overloaded. Adds the control to the collection.
AddRange | Overloaded. Adds a range of invoker controls to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Overloaded. Checks if the collection contains the given control.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Overloaded. Removes a control from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace | CollectionBase

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionInvokerCollection Constructor

Initializes a new instance of the vdxActionInvokerCollection class.

public vdxActionInvokerCollection();

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionInvokerCollection Properties

The properties of the vdxActionInvokerCollection class are listed below. For a complete list of vdxActionInvokerCollection class members, see the vdxActionInvokerCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Gets or sets the action invoker item at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace | CollectionBase

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionInvokerCollection.Item Property

Gets or sets the action invoker item at the specified index.

public object this[
int index
] {get; set;}

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionInvokerCollection Methods

The methods of the vdxActionInvokerCollection class are listed below. For a complete list of vdxActionInvokerCollection class members, see the vdxActionInvokerCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds the control to the collection.
AddRange | Overloaded. Adds a range of invoker controls to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Overloaded. Checks if the collection contains the given control.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Overloaded. Removes a control from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace | CollectionBase

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Add Method

VDX Framework

vdxActionInvokerCollection.Add Method

Adds the control to the collection.

Overload List

Adds the control to the collection.

public void Add(Control);

Adds the menu item to the collection.

public void Add(MenuItem);

Adds the toolBar button to the collection.

public void Add(ToolBarButton);

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionInvokerCollection.Add Method (Control)

Adds the control to the collection.

public void Add(
Control control
);

Parameters

control
The invoker control.

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace | vdxActionInvokerCollection.Add Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionInvokerCollection.Add Method (MenuItem)

Adds the menu item to the collection.

public void Add(
MenuItem menuitem
);

Parameters

menuitem
The invoker control.

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace | vdxActionInvokerCollection.Add Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionInvokerCollection.Add Method (ToolBarButton)

Adds the toolBar button to the collection.

public void Add(
ToolBarButton button
);

Parameters

button
The invoker control.

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace | vdxActionInvokerCollection.Add Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AddRange Method

VDX Framework

vdxActionInvokerCollection.AddRange Method

Adds a range of invoker controls to the collection.

Overload List

Adds a range of invoker controls to the collection.

public void AddRange(Control[]);

Adds a range of menu items to the collection.

public void AddRange(MenuItem[]);

Adds a range of toolBar buttons to the collection.

public void AddRange(ToolBarButton[]);

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionInvokerCollection.AddRange Method (Control[])

Adds a range of invoker controls to the collection.

public void AddRange(
Control[] controls
);

Parameters

controls
The invoker controls.

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace | vdxActionInvokerCollection.AddRange Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionInvokerCollection.AddRange Method (MenuItem[])

Adds a range of menu items to the collection.

public void AddRange(
MenuItem[] menuitems
);

Parameters

menuitems
The invoker controls.

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace | vdxActionInvokerCollection.AddRange Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionInvokerCollection.AddRange Method (ToolBarButton[])

Adds a range of toolBar buttons to the collection.

public void AddRange(
ToolBarButton[] buttons
);

Parameters

buttons
The invoker controls.

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace | vdxActionInvokerCollection.AddRange Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Contains Method

VDX Framework

vdxActionInvokerCollection.Contains Method

Checks if the collection contains the given control.

Overload List

Checks if the collection contains the given control.

public bool Contains(Control);

Checks if the collection contains the given menu item.

public bool Contains(MenuItem);

Checks if the collection contains the given toolBar button.

public bool Contains(ToolBarButton);

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionInvokerCollection.Contains Method (Control)

Checks if the collection contains the given control.

public bool Contains(
Control control
);

Parameters

control
The invoker control.

Return Value

Whether the collection contains the invoker control or not.

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace | vdxActionInvokerCollection.Contains Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionInvokerCollection.Contains Method (MenuItem)

Checks if the collection contains the given menu item.

public bool Contains(
MenuItem menuitem
);

Parameters

menuitem
The invoker control.

Return Value

Whether the collection contains the invoker control or not.

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace | vdxActionInvokerCollection.Contains Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionInvokerCollection.Contains Method (ToolBarButton)

Checks if the collection contains the given toolBar button.

public bool Contains(
ToolBarButton button
);

Parameters

button
The invoker control.

Return Value

Whether the collection contains the invoker control or not.

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace | vdxActionInvokerCollection.Contains Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Remove Method

VDX Framework

vdxActionInvokerCollection.Remove Method

Removes a control from the collection.

Overload List

Removes a control from the collection.

public void Remove(Control);

Removes a menu item from the collection.

public void Remove(MenuItem);

Removes a toolBar button from the collection.

public void Remove(ToolBarButton);

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionInvokerCollection.Remove Method (Control)

Removes a control from the collection.

public void Remove(
Control control
);

Parameters

control
The invoker control.

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace | vdxActionInvokerCollection.Remove Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionInvokerCollection.Remove Method (MenuItem)

Removes a menu item from the collection.

public void Remove(
MenuItem menuitem
);

Parameters

menuitem
The invoker control.

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace | vdxActionInvokerCollection.Remove Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionInvokerCollection.Remove Method (ToolBarButton)

Removes a toolBar button from the collection.

public void Remove(
ToolBarButton button
);

Parameters

button
The invoker control.

See Also

vdxActionInvokerCollection Class | Deag.Vdx.Controls.Core Namespace | vdxActionInvokerCollection.Remove Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem Class

A vdxActionItem provides an easy way to handle all the controls, menu items or toolbar buttons that trigger the same action.

For a list of all members of this type, see vdxActionItem Members.

System.Object
MarshalByRefObject
Component
vdxActionItem

public class vdxActionItem : Component

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxActionItem Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem Members

vdxActionItem overview

Public Instance Constructors

vdxActionItem Constructor Initializes a new instance of the vdxActionItem class.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
Enabled | Enables or disables the controls, menu items or toolbar buttons associated with the action
Site (inherited from Component) | Gets or sets the ISite of the Component.
Visible | Shows or hides the controls, menu items or toolbar buttons associated with the action

Public Instance Methods

AddInvoker | Overloaded. Adds a control to the list of associated controls
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invoke | Invokes the action.
RemoveInvoker | Overloaded. Removes a control from the list of assoctiated controls
ToString (inherited from Component) |

Public Instance Events

ActionInvoked | Occurs when one of the registered invokers were activated.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.

Protected Instance Properties

ActionInvokers | Collection of controls, menu item or toolbar buttons that are associated with the action
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

Protected Instance Methods

Dispose (inherited from Component) | Overloaded. Releases the unmanaged resources used by the Component and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnActionInvoked | Inform all event listeners about the action invocation.
SetEnable | Enables or disables the controls, menu items or toolbar buttons associated with the action
SetVisible | Shows or hides the controls, menu items or toolbar buttons associated with the action.

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem Constructor

Initializes a new instance of the vdxActionItem class.

public vdxActionItem();

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem Properties

The properties of the vdxActionItem class are listed below. For a complete list of vdxActionItem class members, see the vdxActionItem Members topic.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
Enabled | Enables or disables the controls, menu items or toolbar buttons associated with the action
Site (inherited from Component) | Gets or sets the ISite of the Component.
Visible | Shows or hides the controls, menu items or toolbar buttons associated with the action

Protected Instance Properties

ActionInvokers | Collection of controls, menu item or toolbar buttons that are associated with the action
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem.ActionInvokers Property

Collection of controls, menu item or toolbar buttons that are associated with the action

protected vdxActionInvokerCollection ActionInvokers {get;}

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem.Enabled Property

Enables or disables the controls, menu items or toolbar buttons associated with the action

public bool Enabled {get; set;}

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem.Visible Property

Shows or hides the controls, menu items or toolbar buttons associated with the action

public bool Visible {get; set;}

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem Methods

The methods of the vdxActionItem class are listed below. For a complete list of vdxActionItem class members, see the vdxActionItem Members topic.

Public Instance Methods

AddInvoker | Overloaded. Adds a control to the list of associated controls
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invoke | Invokes the action.
RemoveInvoker | Overloaded. Removes a control from the list of assoctiated controls
ToString (inherited from Component) |

Protected Instance Methods

Dispose (inherited from Component) | Overloaded. Releases the unmanaged resources used by the Component and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnActionInvoked | Inform all event listeners about the action invocation.
SetEnable | Enables or disables the controls, menu items or toolbar buttons associated with the action
SetVisible | Shows or hides the controls, menu items or toolbar buttons associated with the action.

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AddInvoker Method

VDX Framework

vdxActionItem.AddInvoker Method

Adds a control to the list of associated controls

Overload List

Adds a control to the list of associated controls

public void AddInvoker(Control);

Adds a menu item to the list of associated items

public void AddInvoker(MenuItem);

Adds a toolbar button to the list of associated buttons

public void AddInvoker(ToolBarButton);

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem.AddInvoker Method (Control)

Adds a control to the list of associated controls

public void AddInvoker(
Control control
);

Parameters

control
The control to add

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace | vdxActionItem.AddInvoker Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem.AddInvoker Method (MenuItem)

Adds a menu item to the list of associated items

public void AddInvoker(
MenuItem menuitem
);

Parameters

menuitem
The item to add

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace | vdxActionItem.AddInvoker Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem.AddInvoker Method (ToolBarButton)

Adds a toolbar button to the list of associated buttons

public void AddInvoker(
ToolBarButton toolbarbutton
);

Parameters

toolbarbutton
The button to add

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace | vdxActionItem.AddInvoker Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem.Invoke Method

Invokes the action.

public void Invoke();

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem.OnActionInvoked Method

Inform all event listeners about the action invocation.

protected virtual void OnActionInvoked(
EventArgs e
);

Parameters

e
The involved EventArgs

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


RemoveInvoker Method

VDX Framework

vdxActionItem.RemoveInvoker Method

Removes a control from the list of assoctiated controls

Overload List

Removes a control from the list of assoctiated controls

public void RemoveInvoker(Control);

Removes a menu item from the list of associated items

public void RemoveInvoker(MenuItem);

Removes a toolbar button from the list of associated buttons

public void RemoveInvoker(ToolBarButton);

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem.RemoveInvoker Method (Control)

Removes a control from the list of assoctiated controls

public void RemoveInvoker(
Control control
);

Parameters

control
The control to remove

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace | vdxActionItem.RemoveInvoker Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem.RemoveInvoker Method (MenuItem)

Removes a menu item from the list of associated items

public void RemoveInvoker(
MenuItem menuitem
);

Parameters

menuitem
The item to remove

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace | vdxActionItem.RemoveInvoker Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem.RemoveInvoker Method (ToolBarButton)

Removes a toolbar button from the list of associated buttons

public void RemoveInvoker(
ToolBarButton toolbarbutton
);

Parameters

toolbarbutton
The button to remove

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace | vdxActionItem.RemoveInvoker Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem.SetEnable Method

Enables or disables the controls, menu items or toolbar buttons associated with the action

protected virtual void SetEnable(
bool enableValue
);

Parameters

enableValue

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem.SetVisible Method

Shows or hides the controls, menu items or toolbar buttons associated with the action.

protected virtual void SetVisible(
bool visibleValue
);

Parameters

visibleValue
Whether the controls will be shown or hided.

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem Events

The events of the vdxActionItem class are listed below. For a complete list of vdxActionItem class members, see the vdxActionItem Members topic.

Public Instance Events

ActionInvoked | Occurs when one of the registered invokers were activated.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItem.ActionInvoked Event

Occurs when one of the registered invokers were activated.

public event EventHandler ActionInvoked;

See Also

vdxActionItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItemCollection Class

The collection that holds all action items.

For a list of all members of this type, see vdxActionItemCollection Members.

System.Object
CollectionBase
vdxActionItemCollection

public class vdxActionItemCollection : CollectionBase

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxActionItemCollection Members | Deag.Vdx.Controls.Core Namespace | CollectionBase

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItemCollection Members

vdxActionItemCollection overview

Public Instance Constructors

vdxActionItemCollection Constructor Initializes a new instance of the vdxActionItemCollection class.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Gets or sets the action item at the specified index.

Public Instance Methods

Add | Adds the action item to the collection.
AddRange | Adds all action item to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Check if collection contains the given action item.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Removes the action item to the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

vdxActionItemCollection Class | Deag.Vdx.Controls.Core Namespace | CollectionBase

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItemCollection Constructor

Initializes a new instance of the vdxActionItemCollection class.

public vdxActionItemCollection();

See Also

vdxActionItemCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItemCollection Properties

The properties of the vdxActionItemCollection class are listed below. For a complete list of vdxActionItemCollection class members, see the vdxActionItemCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Gets or sets the action item at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

vdxActionItemCollection Class | Deag.Vdx.Controls.Core Namespace | CollectionBase

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItemCollection.Item Property

Gets or sets the action item at the specified index.

public vdxActionItem this[
int index
] {get; set;}

See Also

vdxActionItemCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItemCollection Methods

The methods of the vdxActionItemCollection class are listed below. For a complete list of vdxActionItemCollection class members, see the vdxActionItemCollection Members topic.

Public Instance Methods

Add | Adds the action item to the collection.
AddRange | Adds all action item to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Check if collection contains the given action item.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Removes the action item to the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

vdxActionItemCollection Class | Deag.Vdx.Controls.Core Namespace | CollectionBase

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItemCollection.Add Method

Adds the action item to the collection.

public void Add(
vdxActionItem item
);

Parameters

item
The vdxActionItem that will be added.

See Also

vdxActionItemCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItemCollection.AddRange Method

Adds all action item to the collection.

public void AddRange(
vdxActionItem[] items
);

Parameters

items
The vdxActionItem array that will be added.

See Also

vdxActionItemCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItemCollection.Contains Method

Check if collection contains the given action item.

public bool Contains(
vdxActionItem item
);

Parameters

item
The vdxActionItem to check.

Return Value

Whether the action item is contained by the collection or not.

See Also

vdxActionItemCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionItemCollection.Remove Method

Removes the action item to the collection.

public void Remove(
vdxActionItem item
);

Parameters

item
The vdxActionItem that will be removed.

See Also

vdxActionItemCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionManager Class

A vdxActionManager handles a colletion of vdxActionItems.

For a list of all members of this type, see vdxActionManager Members.

System.Object
MarshalByRefObject
Component
vdxActionManager

public class vdxActionManager : Component

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxActionManager Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionManager Members

vdxActionManager overview

Public Instance Constructors

vdxActionManager Overloaded. Initializes a new instance of the vdxActionManager class.

Public Instance Properties

ActionItems | Gets the collection of vdxActionItem.
Container (inherited from Component) | Gets the IContainer that contains the Component.
Site (inherited from Component) | Gets or sets the ISite of the Component.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Component) |

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

Protected Instance Properties

DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

Protected Instance Methods

Dispose (inherited from Component) | Overloaded. Releases the unmanaged resources used by the Component and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionManager Constructor

Initializes a new instance of the vdxActionManager class.

Overload List

Initializes a new instance of the vdxActionManager class.

public vdxActionManager();

Initializes a new instance of the vdxActionManager class.

public vdxActionManager(IContainer);

See Also

vdxActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionManager Constructor ()

Initializes a new instance of the vdxActionManager class.

public vdxActionManager();

See Also

vdxActionManager Class | Deag.Vdx.Controls.Core Namespace | vdxActionManager Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionManager Constructor (IContainer)

Initializes a new instance of the vdxActionManager class.

public vdxActionManager(
IContainer container
);

Parameters

container
The container. Required for the designer.

See Also

vdxActionManager Class | Deag.Vdx.Controls.Core Namespace | vdxActionManager Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionManager Properties

The properties of the vdxActionManager class are listed below. For a complete list of vdxActionManager class members, see the vdxActionManager Members topic.

Public Instance Properties

ActionItems | Gets the collection of vdxActionItem.
Container (inherited from Component) | Gets the IContainer that contains the Component.
Site (inherited from Component) | Gets or sets the ISite of the Component.

Protected Instance Properties

DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

See Also

vdxActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxActionManager.ActionItems Property

Gets the collection of vdxActionItem.

public virtual vdxActionItemCollection ActionItems {get;}

See Also

vdxActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingManager Class

The default binding manager.

For a list of all members of this type, see vdxBindingManager Members.

System.Object
vdxBindingManager

public class vdxBindingManager : IvdxBindingManager

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxBindingManager Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingManager Members

vdxBindingManager overview

Public Instance Constructors

vdxBindingManager Constructor Creates a new instance of the vdxBindingManager class.

Public Instance Methods

Add | Adds a binding managable to the collection.
AddContainer | Adds the specified control and all its children to the collection of managed controls (only controls that implement IvdxBindingManagable).
Contains | Returns whether the collection contains the specified binding managable.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Overloaded. Refreshs the specified binding managable.
Remove | Removes a binding managable from the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxBindingManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingManager Constructor

Creates a new instance of the vdxBindingManager class.

public vdxBindingManager();

See Also

vdxBindingManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingManager Methods

The methods of the vdxBindingManager class are listed below. For a complete list of vdxBindingManager class members, see the vdxBindingManager Members topic.

Public Instance Methods

Add | Adds a binding managable to the collection.
AddContainer | Adds the specified control and all its children to the collection of managed controls (only controls that implement IvdxBindingManagable).
Contains | Returns whether the collection contains the specified binding managable.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Overloaded. Refreshs the specified binding managable.
Remove | Removes a binding managable from the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxBindingManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingManager.Add Method

Adds a binding managable to the collection.

public void Add(
IvdxBindingManagable bm
);

Parameters

bm
The binding managable that will be added.

Implements

IvdxBindingManager.Add

See Also

vdxBindingManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingManager.AddContainer Method

Adds the specified control and all its children to the collection of managed controls (only controls that implement IvdxBindingManagable).

public void AddContainer(
Control container
);

Parameters

container
The control that will be added to the collection.

Implements

IvdxBindingManager.AddContainer

See Also

vdxBindingManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingManager.Contains Method

Returns whether the collection contains the specified binding managable.

public bool Contains(
IvdxBindingManagable bm
);

Parameters

bm
The binding managable to search for.

Return Value

True if collection contains the binding managable.

Implements

IvdxBindingManager.Contains

See Also

vdxBindingManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Refresh Method

VDX Framework

vdxBindingManager.Refresh Method

Refreshs the specified binding managable.

Overload List

Refreshs the specified binding managable.

public bool Refresh(IvdxBindingManagable);

Loops through all managed objects and calls their Refresh method.

public bool Refresh(vdxBindingManagerRefreshKind);

Refreshs the specified list.

public bool Refresh(vdxBindingManagerRefreshKind,params IvdxBindingManagable[]);

See Also

vdxBindingManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingManager.Refresh Method (IvdxBindingManagable)

Refreshs the specified binding managable.

public bool Refresh(
IvdxBindingManagable bm
);

Parameters

bm
Which object that should be refreshed.

Return Value

Whether the given managed objects were refreshed (due to validation errors for example)

Implements

IvdxBindingManager.Refresh

See Also

vdxBindingManager Class | Deag.Vdx.Controls.Core Namespace | vdxBindingManager.Refresh Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingManager.Refresh Method (vdxBindingManagerRefreshKind)

Loops through all managed objects and calls their Refresh method.

public bool Refresh(
vdxBindingManagerRefreshKind kind
);

Parameters

kind
Which objects should be refreshed.

Return Value

Whether all managed objects were refreshed (due to validation errors for example)

Implements

IvdxBindingManager.Refresh

See Also

vdxBindingManager Class | Deag.Vdx.Controls.Core Namespace | vdxBindingManager.Refresh Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingManager.Refresh Method (vdxBindingManagerRefreshKind, IvdxBindingManagable[])

Refreshs the specified list.

public bool Refresh(
vdxBindingManagerRefreshKind kind,
params IvdxBindingManagable[] bms
);

Parameters

kind
Which objects are refreshed.
bms
List of objects to be refreshed.

Return Value

Whether the given managed objects were refreshed (due to validation errors for example)

Implements

IvdxBindingManager.Refresh

See Also

vdxBindingManager Class | Deag.Vdx.Controls.Core Namespace | vdxBindingManager.Refresh Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingManager.Remove Method

Removes a binding managable from the collection.

public void Remove(
IvdxBindingManagable bm
);

Parameters

bm
The binding managable that will be removed.

Implements

IvdxBindingManager.Remove

See Also

vdxBindingManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingManagerRefreshKind Enumeration

Enumeration for the type of binding manager refresh.

public enum vdxBindingManagerRefreshKind

Members

Member Name | Description
All | Refresh all bindings.
Focused | Refresh only bindings that are focused.

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableControl Class

The default implementation for a cacheable component in the vdxMultiContainer.

For a list of all members of this type, see vdxCacheableControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxCacheableControl

public class vdxCacheableControl : UserControl, IvdxMultiContainerCacheable

Remarks

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxCacheableControl Members | Deag.Vdx.Controls.Core Namespace | vdxDataDetail | vdxExplorer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableControl Members

vdxCacheableControl overview

Public Instance Constructors

vdxCacheableControl Constructor Initializes a new instance of the vdxCacheableControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
Activate | Override this method for your specific cacheable control.
AdjustFormScrollbars (inherited from ContainerControl) |
Create | Override this method for your specific cacheable control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
Deactivate | Override this method for your specific cacheable control.
DeactivateAllowed | Override this method for your specific cacheable control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
Reactivate | Override this method for your specific cacheable control.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxMultiContainerCacheable.Activate
IvdxMultiContainerCacheable.Create
IvdxMultiContainerCacheable.Deactivate
IvdxMultiContainerCacheable.DeactivateAllowed
IvdxMultiContainerCacheable.Reactivate

See Also

vdxCacheableControl Class | Deag.Vdx.Controls.Core Namespace | vdxDataDetail | vdxExplorer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableControl Constructor

Initializes a new instance of the vdxCacheableControl class.

public vdxCacheableControl();

See Also

vdxCacheableControl Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableControl Methods

The methods of the vdxCacheableControl class are listed below. For a complete list of vdxCacheableControl class members, see the vdxCacheableControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
Activate | Override this method for your specific cacheable control.
AdjustFormScrollbars (inherited from ContainerControl) |
Create | Override this method for your specific cacheable control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
Deactivate | Override this method for your specific cacheable control.
DeactivateAllowed | Override this method for your specific cacheable control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
Reactivate | Override this method for your specific cacheable control.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxMultiContainerCacheable.Activate
IvdxMultiContainerCacheable.Create
IvdxMultiContainerCacheable.Deactivate
IvdxMultiContainerCacheable.DeactivateAllowed
IvdxMultiContainerCacheable.Reactivate

See Also

vdxCacheableControl Class | Deag.Vdx.Controls.Core Namespace | vdxDataDetail | vdxExplorer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableControl.Activate Method

Override this method for your specific cacheable control.

protected virtual void Activate();

See Also

vdxCacheableControl Class | Deag.Vdx.Controls.Core Namespace | IvdxMultiContainerCacheable

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableControl.Create Method

Override this method for your specific cacheable control.

protected virtual void Create();

See Also

vdxCacheableControl Class | Deag.Vdx.Controls.Core Namespace | IvdxMultiContainerCacheable

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableControl.Deactivate Method

Override this method for your specific cacheable control.

protected virtual void Deactivate();

See Also

vdxCacheableControl Class | Deag.Vdx.Controls.Core Namespace | IvdxMultiContainerCacheable

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableControl.DeactivateAllowed Method

Override this method for your specific cacheable control.

protected virtual bool DeactivateAllowed();

See Also

vdxCacheableControl Class | Deag.Vdx.Controls.Core Namespace | IvdxMultiContainerCacheable

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableControl.IvdxMultiContainerCacheable.Activate Method

void IvdxMultiContainerCacheable.Activate();

Implements

IvdxMultiContainerCacheable.Activate

See Also

vdxCacheableControl Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableControl.IvdxMultiContainerCacheable.Create Method

void IvdxMultiContainerCacheable.Create();

Implements

IvdxMultiContainerCacheable.Create

See Also

vdxCacheableControl Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableControl.IvdxMultiContainerCacheable.Deactivate Method

void IvdxMultiContainerCacheable.Deactivate();

Implements

IvdxMultiContainerCacheable.Deactivate

See Also

vdxCacheableControl Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableControl.IvdxMultiContainerCacheable.DeactivateAllowed Method

bool IvdxMultiContainerCacheable.DeactivateAllowed();

Implements

IvdxMultiContainerCacheable.DeactivateAllowed

See Also

vdxCacheableControl Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableControl.IvdxMultiContainerCacheable.Reactivate Method

void IvdxMultiContainerCacheable.Reactivate();

Implements

IvdxMultiContainerCacheable.Reactivate

See Also

vdxCacheableControl Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableControl.Reactivate Method

Override this method for your specific cacheable control.

protected virtual void Reactivate();

See Also

vdxCacheableControl Class | Deag.Vdx.Controls.Core Namespace | IvdxMultiContainerCacheable

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxControlResetter Class

Provides the function to reset all child Controls in a container.

For a list of all members of this type, see vdxControlResetter Members.

System.Object
vdxControlResetter

public class vdxControlResetter

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxControlResetter Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxControlResetter Members

vdxControlResetter overview

Public Instance Constructors

vdxControlResetter Constructor Initializes a new instance of the vdxControlResetter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Reset | Reset recursively all controls in the specified container.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxControlResetter Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxControlResetter Constructor

Initializes a new instance of the vdxControlResetter class.

public vdxControlResetter();

See Also

vdxControlResetter Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxControlResetter Methods

The methods of the vdxControlResetter class are listed below. For a complete list of vdxControlResetter class members, see the vdxControlResetter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Reset | Reset recursively all controls in the specified container.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxControlResetter Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxControlResetter.Reset Method

Reset recursively all controls in the specified container.

public virtual void Reset(
Control container
);

Parameters

container
The container, which holds controls.

Remarks

The method reset is called of the container if it does implement IvdxResettable. Otherwise each control in the container collection will be resetted over the Reset method. If the control does not implement IvdxResettable than this method will be called recursively.

See Also

vdxControlResetter Class | Deag.Vdx.Controls.Core Namespace | IvdxResettable | Control

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataActionManager Class

The vdxDataActionManager defines several actions that are associated with data handling.

For a list of all members of this type, see vdxDataActionManager Members.

System.Object
MarshalByRefObject
Component
vdxActionManager
vdxDataActionManager

public class vdxDataActionManager : vdxActionManager, IvdxDsmProvider

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataActionManager Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataActionManager Members

vdxDataActionManager overview

Public Instance Constructors

vdxDataActionManager Overloaded. Initializes a new instance of the vdxDataActionManager class.

Public Instance Properties

ActionItemAdd | Gets or sets the vdxActionItem used to invoke Add.
ActionItemCopy | Gets or sets the vdxActionItem used to invoke Copy.
ActionItemDelete | Gets or sets the vdxActionItem used to invoke Delete.
ActionItemEdit | Gets or sets the vdxActionItem used to invoke Edit.
ActionItemFind | Gets or sets the vdxActionItem used to invoke a Find.
ActionItemRefresh | Gets or sets the vdxActionItem used to invoke a Refresh.
ActionItemRefreshAll | Gets or sets the vdxActionItem used to invoke a RefreshAll.
ActionItems (inherited from vdxActionManager) | Gets the collection of vdxActionItem.
ActionItemSave | Gets or sets the vdxActionItem used to invoke Save.
ActionItemShowDebug | Gets or sets the vdxActionItem used to invoke ShowDebug.
ActionItemUndo | Gets or sets the vdxActionItem used to invoke Undo.
Container (inherited from Component) | Gets the IContainer that contains the Component.
DataStatusManager | Gets or sets the VdxDataStatusManager object.
Site (inherited from Component) | Gets or sets the ISite of the Component.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Component) |

Public Instance Events

Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
PossibleOperationsChanged | Occurs after PossibleOperations has changed.

Protected Instance Properties

DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

Protected Instance Methods

Dispose (inherited from Component) | Overloaded. Releases the unmanaged resources used by the Component and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxDataActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataActionManager Constructor

Initializes a new instance of the vdxDataActionManager class.

Overload List

Initializes a new instance of the vdxDataActionManager class.

public vdxDataActionManager();

Initializes a new instance of the vdxDataActionManager class.

public vdxDataActionManager(IContainer);

See Also

vdxDataActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataActionManager Constructor ()

Initializes a new instance of the vdxDataActionManager class.

public vdxDataActionManager();

See Also

vdxDataActionManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataActionManager Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataActionManager Constructor (IContainer)

Initializes a new instance of the vdxDataActionManager class.

public vdxDataActionManager(
IContainer container
);

Parameters

container
The Container.

See Also

vdxDataActionManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataActionManager Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataActionManager Properties

The properties of the vdxDataActionManager class are listed below. For a complete list of vdxDataActionManager class members, see the vdxDataActionManager Members topic.

Public Instance Properties

ActionItemAdd | Gets or sets the vdxActionItem used to invoke Add.
ActionItemCopy | Gets or sets the vdxActionItem used to invoke Copy.
ActionItemDelete | Gets or sets the vdxActionItem used to invoke Delete.
ActionItemEdit | Gets or sets the vdxActionItem used to invoke Edit.
ActionItemFind | Gets or sets the vdxActionItem used to invoke a Find.
ActionItemRefresh | Gets or sets the vdxActionItem used to invoke a Refresh.
ActionItemRefreshAll | Gets or sets the vdxActionItem used to invoke a RefreshAll.
ActionItems (inherited from vdxActionManager) | Gets the collection of vdxActionItem.
ActionItemSave | Gets or sets the vdxActionItem used to invoke Save.
ActionItemShowDebug | Gets or sets the vdxActionItem used to invoke ShowDebug.
ActionItemUndo | Gets or sets the vdxActionItem used to invoke Undo.
Container (inherited from Component) | Gets the IContainer that contains the Component.
DataStatusManager | Gets or sets the VdxDataStatusManager object.
Site (inherited from Component) | Gets or sets the ISite of the Component.

Protected Instance Properties

DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

See Also

vdxDataActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataActionManager.ActionItemAdd Property

Gets or sets the vdxActionItem used to invoke Add.

public vdxActionItem ActionItemAdd {get; set;}

See Also

vdxDataActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataActionManager.ActionItemCopy Property

Gets or sets the vdxActionItem used to invoke Copy.

public vdxActionItem ActionItemCopy {get; set;}

See Also

vdxDataActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataActionManager.ActionItemDelete Property

Gets or sets the vdxActionItem used to invoke Delete.

public vdxActionItem ActionItemDelete {get; set;}

See Also

vdxDataActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataActionManager.ActionItemEdit Property

Gets or sets the vdxActionItem used to invoke Edit.

public vdxActionItem ActionItemEdit {get; set;}

See Also

vdxDataActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataActionManager.ActionItemFind Property

Gets or sets the vdxActionItem used to invoke a Find.

public vdxActionItem ActionItemFind {get; set;}

See Also

vdxDataActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataActionManager.ActionItemRefresh Property

Gets or sets the vdxActionItem used to invoke a Refresh.

public vdxActionItem ActionItemRefresh {get; set;}

See Also

vdxDataActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataActionManager.ActionItemRefreshAll Property

Gets or sets the vdxActionItem used to invoke a RefreshAll.

public vdxActionItem ActionItemRefreshAll {get; set;}

See Also

vdxDataActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataActionManager.ActionItemSave Property

Gets or sets the vdxActionItem used to invoke Save.

public vdxActionItem ActionItemSave {get; set;}

See Also

vdxDataActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataActionManager.ActionItemShowDebug Property

Gets or sets the vdxActionItem used to invoke ShowDebug.

public vdxActionItem ActionItemShowDebug {get; set;}

See Also

vdxDataActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataActionManager.ActionItemUndo Property

Gets or sets the vdxActionItem used to invoke Undo.

public vdxActionItem ActionItemUndo {get; set;}

See Also

vdxDataActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataActionManager.DataStatusManager Property

Gets or sets the VdxDataStatusManager object.

public vdxDataStatusManager DataStatusManager {get; set;}

Implements

IvdxDsmProvider.DataStatusManager

See Also

vdxDataActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataActionManager Events

The events of the vdxDataActionManager class are listed below. For a complete list of vdxDataActionManager class members, see the vdxDataActionManager Members topic.

Public Instance Events

Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
PossibleOperationsChanged | Occurs after PossibleOperations has changed.

See Also

vdxDataActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataActionManager.PossibleOperationsChanged Event

Occurs after PossibleOperations has changed.

public event vdxPossibleOperationsChangedEventHandler PossibleOperationsChanged;

Event Data

The event handler receives an argument of type vdxPossibleOperationsChangedEventArgs containing data related to this event. The following vdxPossibleOperationsChangedEventArgs property provides information specific to this event.

Property | Description
PossibleOperations | Gets the allowed operations.

See Also

vdxDataActionManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataControl Class

Defines the needed interfaces for a data driven control like a vdxDataDetail or a vdxExplorer.

For a list of all members of this type, see vdxDataControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxCacheableControl
vdxDataControl

public class vdxDataControl : vdxCacheableControl, IvdxChangeable, IvdxDsmProvider

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataControl Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataControl Members

vdxDataControl overview

Public Instance Constructors

vdxDataControl Constructor Initializes a new instance of the vdxDataControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataStatusManager | Gets or sets the corresponding vdxDataStatusManager
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
Activate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
AdjustFormScrollbars (inherited from ContainerControl) |
Create (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
Deactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DeactivateAllowed (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HandleChanges | Activate the element with unsaved changes.
HasChanges | Indicates if a component or one of its subcomponents has pending changes.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
Reactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxChangeable.HandleChanges
IvdxChangeable.HasChanges
IvdxMultiContainerCacheable.Activate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Create (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Deactivate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.DeactivateAllowed (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Reactivate (inherited from vdxCacheableControl)

See Also

vdxDataControl Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataControl Constructor

Initializes a new instance of the vdxDataControl class.

public vdxDataControl();

See Also

vdxDataControl Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataControl Properties

The properties of the vdxDataControl class are listed below. For a complete list of vdxDataControl class members, see the vdxDataControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataStatusManager | Gets or sets the corresponding vdxDataStatusManager
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

vdxDataControl Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataControl.DataStatusManager Property

Gets or sets the corresponding vdxDataStatusManager

public virtual vdxDataStatusManager DataStatusManager {get;}

Implements

IvdxDsmProvider.DataStatusManager

See Also

vdxDataControl Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataControl Methods

The methods of the vdxDataControl class are listed below. For a complete list of vdxDataControl class members, see the vdxDataControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
Activate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
AdjustFormScrollbars (inherited from ContainerControl) |
Create (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
Deactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DeactivateAllowed (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HandleChanges | Activate the element with unsaved changes.
HasChanges | Indicates if a component or one of its subcomponents has pending changes.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
Reactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxChangeable.HandleChanges
IvdxChangeable.HasChanges
IvdxMultiContainerCacheable.Activate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Create (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Deactivate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.DeactivateAllowed (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Reactivate (inherited from vdxCacheableControl)

See Also

vdxDataControl Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataControl.IvdxChangeable.HandleChanges Method

bool IvdxChangeable.HandleChanges();

Implements

IvdxChangeable.HandleChanges

See Also

vdxDataControl Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataControl.IvdxChangeable.HasChanges Method

bool IvdxChangeable.HasChanges();

Implements

IvdxChangeable.HasChanges

See Also

vdxDataControl Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataControl.HandleChanges Method

Activate the element with unsaved changes.

protected virtual bool HandleChanges();

Return Value

True if there are still changes after handling them.

See Also

vdxDataControl Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataControl.HasChanges Method

Indicates if a component or one of its subcomponents has pending changes.

protected virtual bool HasChanges();

Return Value

True if there are changes.

See Also

vdxDataControl Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail Class

Defines the base class for all data detail user controls that can handle data.

For a list of all members of this type, see vdxDataDetail Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxCacheableControl
vdxDataControl
vdxDataDetail

public class vdxDataDetail : vdxDataControl, IvdxDataLoader, IvdxDataManipulator

Remarks

Interacts with a vdxExplorer or a vdxDataMultiContainer to display the corresponding detail data or system data. A vdxExplorer can manage one or many vdxDataDetails. The corresponding vdxDataDetail will be shown in the vdxDataMultiContainer of the vdxExplorer depending on the vdxLoaderInfo an IvdxNavigator communicates over the ControlChanged event to the vdxExplorer. A vdxDataDetail can also be managed by a standing alone vdxDataMultiContainer like the system parameter case.

Example

This example shows how to implement a vdxDataDetail in a person data management scenario. First we must derive from vdxDataDetail:

            public class DataDetailPerson : vdxDataDetail
            {
                ...
            }
Than we must configure the dataStatusManager.
Mandatory Property | Value Example
DataSetType | vdxSampleApplication.vdxSampleWebServices.dsPers
MainDataTableName | Pers
SelectedDataTableName | Pers
 The vdxDataStatusManager provides a dialog to add controls onto the vdxDataDetail by opening the context menu of the dataStatusManager component and clicking Create Control. After all controls were placed onto the vdxDataDetail we override the LoadData method to provide a DataSet that will be filled up into the specified controls by the vdxDataStatusManager.
            protected override DataSet LoadData(vdxSearchParameters searchParameters)
            {
                return WebServiceProvider.wsPers.GetDataSetPers(searchParameters.GetParameters());
            }

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataDetail Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail Members

vdxDataDetail overview

Public Instance Constructors

vdxDataDetail Constructor Initializes a new instance of the vdxDataDetail class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AlwaysLoadData | Gets/sets a vlaue indicating whether the data of this vdxDataDetail should be loading each time a PerformDataLoad is performed or only when the SearchParameters have changed. Default value = false
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataStatusManager | Gets the vdxDataStatusManager object.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
Copied | Occurs after DataStatusManager has copied data.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deleted | Occurs after DataStatusManager has deleted data.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Inserted | Occurs after DataStatusManager has inserted new data.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Undone | Occurs after DataStatusManager has undone data changes.
Updated | Occurs after DataStatusManager has updated data.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

dataStatusManager The vdxDataStatusManager that manages the binded DataSet.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AcceptNewData | Does this manipulator accept new data? By default, the DataStatusManager's HandleChanges() is called to answer this question. If no data have been changed, this method returns true. Otherwise the user is asked whether she want's to save the date or discard all changes or cancel the operation.
AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
Activate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
AdjustFormScrollbars (inherited from ContainerControl) |
Create (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
Deactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DeactivateAllowed (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetManipulatorData | Gets the data that is used to inform all manipulator event listeners.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HandleChanges (inherited from vdxDataControl) | Activate the element with unsaved changes.
HasChanges (inherited from vdxDataControl) | Indicates if a component or one of its subcomponents has pending changes.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsRefreshable | Checks if the component supports refresh.
LoadData | Delegates the components to load the corresponding data for the given search parameters.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataManipulatorCopied | Inform all registered components on Copied about manipulator data copied.
OnDataManipulatorDeleted | Inform all registered components on Deleted about manipulator data deleted.
OnDataManipulatorInserted | Inform all registered components on Inserted about manipulator data inserted.
OnDataManipulatorUndone | Inform all registered components on Undone about manipulator data undone.
OnDataManipulatorUpdated | Inform all registered components on Updated about manipulator data updated.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
PerformDataLoad | Delegates the components to load the corresponding data for the given search parameters.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
Reactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshData | Loads again the data.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDataLoader.SearchParameters

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxChangeable.HandleChanges (inherited from vdxDataControl)
IvdxChangeable.HasChanges (inherited from vdxDataControl)
IvdxDataLoader.ClearSearchParameters
IvdxDataLoader.IsRefreshable
IvdxDataLoader.PerformDataLoad
IvdxDataLoader.RefreshData
IvdxDataManipulator.AcceptNewData
IvdxMultiContainerCacheable.Activate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Create (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Deactivate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.DeactivateAllowed (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Reactivate (inherited from vdxCacheableControl)

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail Constructor

Initializes a new instance of the vdxDataDetail class.

public vdxDataDetail();

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail Fields

The fields of the vdxDataDetail class are listed below. For a complete list of vdxDataDetail class members, see the vdxDataDetail Members topic.

Protected Instance Fields

dataStatusManager The vdxDataStatusManager that manages the binded DataSet.

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.DataStatusManager Property

Gets the vdxDataStatusManager object.

public override vdxDataStatusManager DataStatusManager {get;}

Implements

IvdxDsmProvider.DataStatusManager

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail Properties

The properties of the vdxDataDetail class are listed below. For a complete list of vdxDataDetail class members, see the vdxDataDetail Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AlwaysLoadData | Gets/sets a vlaue indicating whether the data of this vdxDataDetail should be loading each time a PerformDataLoad is performed or only when the SearchParameters have changed. Default value = false
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataStatusManager | Gets the vdxDataStatusManager object.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDataLoader.SearchParameters

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.AlwaysLoadData Property

Gets/sets a vlaue indicating whether the data of this vdxDataDetail should be loading each time a PerformDataLoad is performed or only when the SearchParameters have changed. Default value = false

public bool AlwaysLoadData {get; set;}

Remarks

Set this value to true in the case when you perform a data load on a vdxDataDetail that was already loaded with the same vdxSearchParameters but the underlying data has changed. Otherwise the changed data will not be loaded. If AlwysLoadData is set to false this prvents unnecessary loading of data that would slow down the application. For example if the user navigates in a vdxExplorerTree back and forth.

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.Deag.Vdx.Controls.Core.IvdxDataLoader.SearchParameters Property

private Deag.Vdx.Common.vdxSearchParameters Deag.Vdx.Controls.Core.IvdxDataLoader.SearchParameters {get;}

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail Methods

The methods of the vdxDataDetail class are listed below. For a complete list of vdxDataDetail class members, see the vdxDataDetail Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AcceptNewData | Does this manipulator accept new data? By default, the DataStatusManager's HandleChanges() is called to answer this question. If no data have been changed, this method returns true. Otherwise the user is asked whether she want's to save the date or discard all changes or cancel the operation.
AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
Activate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
AdjustFormScrollbars (inherited from ContainerControl) |
Create (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
Deactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DeactivateAllowed (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetManipulatorData | Gets the data that is used to inform all manipulator event listeners.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HandleChanges (inherited from vdxDataControl) | Activate the element with unsaved changes.
HasChanges (inherited from vdxDataControl) | Indicates if a component or one of its subcomponents has pending changes.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsRefreshable | Checks if the component supports refresh.
LoadData | Delegates the components to load the corresponding data for the given search parameters.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataManipulatorCopied | Inform all registered components on Copied about manipulator data copied.
OnDataManipulatorDeleted | Inform all registered components on Deleted about manipulator data deleted.
OnDataManipulatorInserted | Inform all registered components on Inserted about manipulator data inserted.
OnDataManipulatorUndone | Inform all registered components on Undone about manipulator data undone.
OnDataManipulatorUpdated | Inform all registered components on Updated about manipulator data updated.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
PerformDataLoad | Delegates the components to load the corresponding data for the given search parameters.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
Reactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshData | Loads again the data.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxChangeable.HandleChanges (inherited from vdxDataControl)
IvdxChangeable.HasChanges (inherited from vdxDataControl)
IvdxDataLoader.ClearSearchParameters
IvdxDataLoader.IsRefreshable
IvdxDataLoader.PerformDataLoad
IvdxDataLoader.RefreshData
IvdxDataManipulator.AcceptNewData
IvdxMultiContainerCacheable.Activate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Create (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Deactivate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.DeactivateAllowed (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Reactivate (inherited from vdxCacheableControl)

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.AcceptNewData Method

Does this manipulator accept new data? By default, the DataStatusManager's HandleChanges() is called to answer this question. If no data have been changed, this method returns true. Otherwise the user is asked whether she want's to save the date or discard all changes or cancel the operation.

protected virtual bool AcceptNewData();

Return Value

True if new data is allowed (no pending changes or undo.

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.IvdxDataLoader.ClearSearchParameters Method

void IvdxDataLoader.ClearSearchParameters();

Implements

IvdxDataLoader.ClearSearchParameters

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.IvdxDataLoader.IsRefreshable Method

bool IvdxDataLoader.IsRefreshable();

Implements

IvdxDataLoader.IsRefreshable

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.IvdxDataLoader.PerformDataLoad Method

void IvdxDataLoader.PerformDataLoad(
vdxSearchParameters searchParameters
);

Implements

IvdxDataLoader.PerformDataLoad

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.IvdxDataLoader.RefreshData Method

void IvdxDataLoader.RefreshData();

Implements

IvdxDataLoader.RefreshData

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.IvdxDataManipulator.AcceptNewData Method

bool IvdxDataManipulator.AcceptNewData();

Implements

IvdxDataManipulator.AcceptNewData

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.GetManipulatorData Method

Gets the data that is used to inform all manipulator event listeners.

protected virtual object GetManipulatorData();

Return Value

The data to update the explorer navigators.

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace | vdxDataManipulatorEventArgs | vdxExplorer | IvdxNavigator | vdxDataGridNavigator | vdxTreeView

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.IsRefreshable Method

Checks if the component supports refresh.

protected virtual bool IsRefreshable();

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.LoadData Method

Delegates the components to load the corresponding data for the given search parameters.

protected virtual DataSet LoadData(
vdxSearchParameters searchParameters
);

Parameters

searchParameters
The specific search arguments.

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.OnDataManipulatorCopied Method

Inform all registered components on Copied about manipulator data copied.

protected virtual void OnDataManipulatorCopied();

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.OnDataManipulatorDeleted Method

Inform all registered components on Deleted about manipulator data deleted.

protected virtual void OnDataManipulatorDeleted();

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.OnDataManipulatorInserted Method

Inform all registered components on Inserted about manipulator data inserted.

protected virtual void OnDataManipulatorInserted();

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.OnDataManipulatorUndone Method

Inform all registered components on Undone about manipulator data undone.

protected virtual void OnDataManipulatorUndone();

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.OnDataManipulatorUpdated Method

Inform all registered components on Updated about manipulator data updated.

protected virtual void OnDataManipulatorUpdated();

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.PerformDataLoad Method

Delegates the components to load the corresponding data for the given search parameters.

protected virtual void PerformDataLoad(
vdxSearchParameters searchParameters,
bool refresh
);

Parameters

searchParameters
The specific search arguments.
refresh

Return Value

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.RefreshData Method

Loads again the data.

protected virtual void RefreshData();

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail Events

The events of the vdxDataDetail class are listed below. For a complete list of vdxDataDetail class members, see the vdxDataDetail Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
Copied | Occurs after DataStatusManager has copied data.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deleted | Occurs after DataStatusManager has deleted data.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Inserted | Occurs after DataStatusManager has inserted new data.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Undone | Occurs after DataStatusManager has undone data changes.
Updated | Occurs after DataStatusManager has updated data.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.Copied Event

Occurs after DataStatusManager has copied data.

public event vdxDataManipulatorEventHandler Copied;

Event Data

The event handler receives an argument of type vdxDataManipulatorEventArgs containing data related to this event. The following vdxDataManipulatorEventArgs property provides information specific to this event.

Property | Description
Data | Gets the involved .

Implements

IvdxDataManipulator.Copied

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.Deleted Event

Occurs after DataStatusManager has deleted data.

public event vdxDataManipulatorEventHandler Deleted;

Event Data

The event handler receives an argument of type vdxDataManipulatorEventArgs containing data related to this event. The following vdxDataManipulatorEventArgs property provides information specific to this event.

Property | Description
Data | Gets the involved .

Implements

IvdxDataManipulator.Deleted

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.Inserted Event

Occurs after DataStatusManager has inserted new data.

public event vdxDataManipulatorEventHandler Inserted;

Event Data

The event handler receives an argument of type vdxDataManipulatorEventArgs containing data related to this event. The following vdxDataManipulatorEventArgs property provides information specific to this event.

Property | Description
Data | Gets the involved .

Implements

IvdxDataManipulator.Inserted

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.Undone Event

Occurs after DataStatusManager has undone data changes.

public event vdxDataManipulatorEventHandler Undone;

Event Data

The event handler receives an argument of type vdxDataManipulatorEventArgs containing data related to this event. The following vdxDataManipulatorEventArgs property provides information specific to this event.

Property | Description
Data | Gets the involved .

Implements

IvdxDataManipulator.Undone

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetail.Updated Event

Occurs after DataStatusManager has updated data.

public event vdxDataManipulatorEventHandler Updated;

Event Data

The event handler receives an argument of type vdxDataManipulatorEventArgs containing data related to this event. The following vdxDataManipulatorEventArgs property provides information specific to this event.

Property | Description
Data | Gets the involved .

Implements

IvdxDataManipulator.Updated

See Also

vdxDataDetail Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetailDelayed Class

Specialized vdxDataDetail control that load data delayed.

For a list of all members of this type, see vdxDataDetailDelayed Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxCacheableControl
vdxDataControl
vdxDataDetail
vdxDataDetailDelayed

public class vdxDataDetailDelayed : vdxDataDetail

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataDetailDelayed Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetailDelayed Members

vdxDataDetailDelayed overview

Public Instance Constructors

vdxDataDetailDelayed Constructor Initializes a new instance of the vdxDataDetailDelayed class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AlwaysLoadData (inherited from vdxDataDetail) | Gets/sets a vlaue indicating whether the data of this vdxDataDetail should be loading each time a PerformDataLoad is performed or only when the SearchParameters have changed. Default value = false
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataStatusManager (inherited from vdxDataDetail) | Gets the vdxDataStatusManager object.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetSearchParameters | Gets vdxSearchParameters for the given object id.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
Copied (inherited from vdxDataDetail) | Occurs after DataStatusManager has copied data.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deleted (inherited from vdxDataDetail) | Occurs after DataStatusManager has deleted data.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Inserted (inherited from vdxDataDetail) | Occurs after DataStatusManager has inserted new data.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Undone (inherited from vdxDataDetail) | Occurs after DataStatusManager has undone data changes.
Updated (inherited from vdxDataDetail) | Occurs after DataStatusManager has updated data.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

dataStatusManager (inherited from vdxDataDetail) The vdxDataStatusManager that manages the binded DataSet.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AcceptNewData (inherited from vdxDataDetail) | Does this manipulator accept new data? By default, the DataStatusManager's HandleChanges() is called to answer this question. If no data have been changed, this method returns true. Otherwise the user is asked whether she want's to save the date or discard all changes or cancel the operation.
AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
Activate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
AdjustFormScrollbars (inherited from ContainerControl) |
Create (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
Deactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DeactivateAllowed (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetManipulatorData (inherited from vdxDataDetail) | Gets the data that is used to inform all manipulator event listeners.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HandleChanges (inherited from vdxDataControl) | Activate the element with unsaved changes.
HasChanges (inherited from vdxDataControl) | Indicates if a component or one of its subcomponents has pending changes.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsRefreshable (inherited from vdxDataDetail) | Checks if the component supports refresh.
LoadData | Overloaded. Loads data for the involved object with the given vdxSearchParameters.
LoadDataDelayed | Overloaded. Loads the data for the given object id.
LoadDataInitial | Delegates the components to load the corresponding data for the given search parameters.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataManipulatorCopied (inherited from vdxDataDetail) | Inform all registered components on Copied about manipulator data copied.
OnDataManipulatorDeleted (inherited from vdxDataDetail) | Inform all registered components on Deleted about manipulator data deleted.
OnDataManipulatorInserted (inherited from vdxDataDetail) | Inform all registered components on Inserted about manipulator data inserted.
OnDataManipulatorUndone (inherited from vdxDataDetail) | Inform all registered components on Undone about manipulator data undone.
OnDataManipulatorUpdated (inherited from vdxDataDetail) | Inform all registered components on Updated about manipulator data updated.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
PerformDataLoad (inherited from vdxDataDetail) | Delegates the components to load the corresponding data for the given search parameters.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
Reactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshData (inherited from vdxDataDetail) | Loads again the data.
ResetLoadedObjects | Reset data for all objects that have loaded data.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxChangeable.HandleChanges (inherited from vdxDataControl)
IvdxChangeable.HasChanges (inherited from vdxDataControl)
IvdxDataLoader.ClearSearchParameters (inherited from vdxDataDetail)
IvdxDataLoader.IsRefreshable (inherited from vdxDataDetail)
IvdxDataLoader.PerformDataLoad (inherited from vdxDataDetail)
IvdxDataLoader.RefreshData (inherited from vdxDataDetail)
IvdxDataManipulator.AcceptNewData (inherited from vdxDataDetail)
IvdxMultiContainerCacheable.Activate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Create (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Deactivate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.DeactivateAllowed (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Reactivate (inherited from vdxCacheableControl)

See Also

vdxDataDetailDelayed Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetailDelayed Constructor

Initializes a new instance of the vdxDataDetailDelayed class.

public vdxDataDetailDelayed();

See Also

vdxDataDetailDelayed Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetailDelayed Methods

The methods of the vdxDataDetailDelayed class are listed below. For a complete list of vdxDataDetailDelayed class members, see the vdxDataDetailDelayed Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetSearchParameters | Gets vdxSearchParameters for the given object id.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AcceptNewData (inherited from vdxDataDetail) | Does this manipulator accept new data? By default, the DataStatusManager's HandleChanges() is called to answer this question. If no data have been changed, this method returns true. Otherwise the user is asked whether she want's to save the date or discard all changes or cancel the operation.
AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
Activate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
AdjustFormScrollbars (inherited from ContainerControl) |
Create (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
Deactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DeactivateAllowed (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetManipulatorData (inherited from vdxDataDetail) | Gets the data that is used to inform all manipulator event listeners.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HandleChanges (inherited from vdxDataControl) | Activate the element with unsaved changes.
HasChanges (inherited from vdxDataControl) | Indicates if a component or one of its subcomponents has pending changes.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsRefreshable (inherited from vdxDataDetail) | Checks if the component supports refresh.
LoadData | Overloaded. Loads data for the involved object with the given vdxSearchParameters.
LoadDataDelayed | Overloaded. Loads the data for the given object id.
LoadDataInitial | Delegates the components to load the corresponding data for the given search parameters.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataManipulatorCopied (inherited from vdxDataDetail) | Inform all registered components on Copied about manipulator data copied.
OnDataManipulatorDeleted (inherited from vdxDataDetail) | Inform all registered components on Deleted about manipulator data deleted.
OnDataManipulatorInserted (inherited from vdxDataDetail) | Inform all registered components on Inserted about manipulator data inserted.
OnDataManipulatorUndone (inherited from vdxDataDetail) | Inform all registered components on Undone about manipulator data undone.
OnDataManipulatorUpdated (inherited from vdxDataDetail) | Inform all registered components on Updated about manipulator data updated.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
PerformDataLoad (inherited from vdxDataDetail) | Delegates the components to load the corresponding data for the given search parameters.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
Reactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshData (inherited from vdxDataDetail) | Loads again the data.
ResetLoadedObjects | Reset data for all objects that have loaded data.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxChangeable.HandleChanges (inherited from vdxDataControl)
IvdxChangeable.HasChanges (inherited from vdxDataControl)
IvdxDataLoader.ClearSearchParameters (inherited from vdxDataDetail)
IvdxDataLoader.IsRefreshable (inherited from vdxDataDetail)
IvdxDataLoader.PerformDataLoad (inherited from vdxDataDetail)
IvdxDataLoader.RefreshData (inherited from vdxDataDetail)
IvdxDataManipulator.AcceptNewData (inherited from vdxDataDetail)
IvdxMultiContainerCacheable.Activate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Create (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Deactivate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.DeactivateAllowed (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Reactivate (inherited from vdxCacheableControl)

See Also

vdxDataDetailDelayed Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetailDelayed.GetSearchParameters Method

Gets vdxSearchParameters for the given object id.

public virtual vdxSearchParameters GetSearchParameters(
object id
);

Parameters

id
The identification for the involved object.

Return Value

The corresponding vdxSearchParameters for object id.

Remarks

This method must be implemented by the derived class.

See Also

vdxDataDetailDelayed Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


LoadData Method

VDX Framework

vdxDataDetailDelayed.LoadData Method

Delegates the components to load the corresponding data for the given search parameters for the first time.

Overload List

Delegates the components to load the corresponding data for the given search parameters for the first time.

protected DataSet LoadData(vdxSearchParameters);

Loads data for the involved object with the given vdxSearchParameters.

protected virtual void LoadData(object,vdxSearchParameters);

See Also

vdxDataDetailDelayed Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetailDelayed.LoadData Method (vdxSearchParameters)

Delegates the components to load the corresponding data for the given search parameters for the first time.

protected DataSet LoadData(
vdxSearchParameters searchParameters
);

Parameters

searchParameters
The specific search arguments.

See Also

vdxDataDetailDelayed Class | Deag.Vdx.Controls.Core Namespace | vdxDataDetailDelayed.LoadData Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetailDelayed.LoadData Method (Object, vdxSearchParameters)

Loads data for the involved object with the given vdxSearchParameters.

protected virtual void LoadData(
object id,
vdxSearchParameters searchParameters
);

Parameters

id
searchParameters

Remarks

This method must be implemented by the derived class.

See Also
vdxDataDetailDelayed Class | Deag.Vdx.Controls.Core Namespace | vdxDataDetailDelayed.LoadData Overload List
Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved.

Permission to use, copy, modify, and distribute this
software and its documentation is hereby granted provided
that this copyright notice appears in all copies.

THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


LoadDataDelayed Method

VDX Framework

vdxDataDetailDelayed.LoadDataDelayed Method

Loads the data for the given object id.

Overload List

Loads the data for the given object id.

protected virtual void LoadDataDelayed(object);

Loads the data for the given object id.

protected virtual void LoadDataDelayed(object,bool);

See Also

vdxDataDetailDelayed Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetailDelayed.LoadDataDelayed Method (Object)

Loads the data for the given object id.

protected virtual void LoadDataDelayed(
object id
);

Parameters

id
The identification for the involved object.

See Also

vdxDataDetailDelayed Class | Deag.Vdx.Controls.Core Namespace | vdxDataDetailDelayed.LoadDataDelayed Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetailDelayed.LoadDataDelayed Method (Object, Boolean)

Loads the data for the given object id.

protected virtual void LoadDataDelayed(
object id,
bool forceLoad
);

Parameters

id
The identification for the involved object.
forceLoad
If false, data is loaded if the object is uninitialzed, otherwise reloaded.

Remarks

If forceLoad is set to false, the object will only load the data, if they weren't loaded. Otherwise the data is reloaded.

See Also

vdxDataDetailDelayed Class | Deag.Vdx.Controls.Core Namespace | vdxDataDetailDelayed.LoadDataDelayed Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetailDelayed.LoadDataInitial Method

Delegates the components to load the corresponding data for the given search parameters.

protected virtual DataSet LoadDataInitial(
vdxSearchParameters searchParameters
);

Parameters

searchParameters
The specific search arguments.

See Also

vdxDataDetailDelayed Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetailDelayed.ResetLoadedObjects Method

Reset data for all objects that have loaded data.

protected void ResetLoadedObjects();

See Also

vdxDataDetailDelayed Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetailTab Class

Data detail class with a tab control, whose TabPage only load data when they were clicked.

For a list of all members of this type, see vdxDataDetailTab Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxCacheableControl
vdxDataControl
vdxDataDetail
vdxDataDetailDelayed
vdxDataDetailTab

public class vdxDataDetailTab : vdxDataDetailDelayed

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataDetailTab Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetailTab Members

vdxDataDetailTab overview

Public Instance Constructors

vdxDataDetailTab Constructor Initializes a new instance of the vdxDataDetailTab class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AlwaysLoadData (inherited from vdxDataDetail) | Gets/sets a vlaue indicating whether the data of this vdxDataDetail should be loading each time a PerformDataLoad is performed or only when the SearchParameters have changed. Default value = false
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataStatusManager (inherited from vdxDataDetail) | Gets the vdxDataStatusManager object.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetSearchParameters (inherited from vdxDataDetailDelayed) | Gets vdxSearchParameters for the given object id.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
Copied (inherited from vdxDataDetail) | Occurs after DataStatusManager has copied data.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deleted (inherited from vdxDataDetail) | Occurs after DataStatusManager has deleted data.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Inserted (inherited from vdxDataDetail) | Occurs after DataStatusManager has inserted new data.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Undone (inherited from vdxDataDetail) | Occurs after DataStatusManager has undone data changes.
Updated (inherited from vdxDataDetail) | Occurs after DataStatusManager has updated data.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

dataStatusManager (inherited from vdxDataDetail) | The vdxDataStatusManager that manages the binded DataSet.
tabControl | TabControl which can hold TabPage.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AcceptNewData (inherited from vdxDataDetail) | Does this manipulator accept new data? By default, the DataStatusManager's HandleChanges() is called to answer this question. If no data have been changed, this method returns true. Otherwise the user is asked whether she want's to save the date or discard all changes or cancel the operation.
AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
Activate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
AdjustFormScrollbars (inherited from ContainerControl) |
Create (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
Deactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DeactivateAllowed (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetManipulatorData (inherited from vdxDataDetail) | Gets the data that is used to inform all manipulator event listeners.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HandleChanges (inherited from vdxDataControl) | Activate the element with unsaved changes.
HasChanges (inherited from vdxDataControl) | Indicates if a component or one of its subcomponents has pending changes.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsRefreshable (inherited from vdxDataDetail) | Checks if the component supports refresh.
LoadData (inherited from vdxDataDetailDelayed) | Overloaded. Loads data for the involved object with the given vdxSearchParameters.
LoadDataDelayed (inherited from vdxDataDetailDelayed) | Overloaded. Loads the data for the given object id.
LoadDataInitial (inherited from vdxDataDetailDelayed) | Delegates the components to load the corresponding data for the given search parameters.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataManipulatorCopied (inherited from vdxDataDetail) | Inform all registered components on Copied about manipulator data copied.
OnDataManipulatorDeleted (inherited from vdxDataDetail) | Inform all registered components on Deleted about manipulator data deleted.
OnDataManipulatorInserted (inherited from vdxDataDetail) | Inform all registered components on Inserted about manipulator data inserted.
OnDataManipulatorUndone (inherited from vdxDataDetail) | Inform all registered components on Undone about manipulator data undone.
OnDataManipulatorUpdated (inherited from vdxDataDetail) | Inform all registered components on Updated about manipulator data updated.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
PerformDataLoad (inherited from vdxDataDetail) | Delegates the components to load the corresponding data for the given search parameters.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
Reactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshData (inherited from vdxDataDetail) | Loads again the data.
ResetLoadedObjects (inherited from vdxDataDetailDelayed) | Reset data for all objects that have loaded data.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxChangeable.HandleChanges (inherited from vdxDataControl)
IvdxChangeable.HasChanges (inherited from vdxDataControl)
IvdxDataLoader.ClearSearchParameters (inherited from vdxDataDetail)
IvdxDataLoader.IsRefreshable (inherited from vdxDataDetail)
IvdxDataLoader.PerformDataLoad (inherited from vdxDataDetail)
IvdxDataLoader.RefreshData (inherited from vdxDataDetail)
IvdxDataManipulator.AcceptNewData (inherited from vdxDataDetail)
IvdxMultiContainerCacheable.Activate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Create (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Deactivate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.DeactivateAllowed (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Reactivate (inherited from vdxCacheableControl)

See Also

vdxDataDetailTab Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetailTab Constructor

Initializes a new instance of the vdxDataDetailTab class.

public vdxDataDetailTab();

See Also

vdxDataDetailTab Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetailTab Fields

The fields of the vdxDataDetailTab class are listed below. For a complete list of vdxDataDetailTab class members, see the vdxDataDetailTab Members topic.

Protected Instance Fields

dataStatusManager (inherited from vdxDataDetail) | The vdxDataStatusManager that manages the binded DataSet.
tabControl | TabControl which can hold TabPage.

See Also

vdxDataDetailTab Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataDetailTab.tabControl Field

TabControl which can hold TabPage.

protected vdxTabControl tabControl;

See Also

vdxDataDetailTab Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataMultiContainer Class

Specialized vdxMultiContainer that also is a IvdxDataActionManagerConsumer.

For a list of all members of this type, see vdxDataMultiContainer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxMultiContainer
vdxDataMultiContainer

public class vdxDataMultiContainer : vdxMultiContainer, IvdxDataActionManagerConsumer, IvdxDsmProvider, IvdxBindable

Remarks

First it ensures that this DataActionManager is connected to the Current DataActionManager after that element is activated, and disconnected after that element is deactivated. Second it connects the vdxDataStatusManager of Current element to this DataStatusManager after that element is activated, and disconnected after that element is deactivated.

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataMultiContainer Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataMultiContainer Members

vdxDataMultiContainer overview

Public Instance Constructors

vdxDataMultiContainer Constructor Initializes a new instance of the vdxDataMultiContainer class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Current (inherited from vdxMultiContainer) | Gets the current active control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataActionManager | Gets or sets the vdxDataActionManager, which manage all action items.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataStatusManager | Gets the vdxDataStatusManager of the current element if its implement IvdxDsmProvider.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetElement (inherited from vdxMultiContainer) | Get the element for the given element type, if it is cached, otherwise null.
GetElements (inherited from vdxMultiContainer) | Get all elements cached by this multiContainer.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HideCurrentElement (inherited from vdxMultiContainer) | Hides the currently shown IvdxMultiContainerCacheable element.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Remove (inherited from vdxMultiContainer) | Removes the corresponding element type from the container and disposes the control.
RemoveAll (inherited from vdxMultiContainer) | Removes all elements from the container and dispose each one.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from vdxMultiContainer) | Overloaded. Displays the element of the given IvdxMultiContainerCacheable type.
Show (inherited from Control) | Overloaded. Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
ElementActivated (inherited from vdxMultiContainer) | Occurs after an element is activated.
ElementCreated (inherited from vdxMultiContainer) | Occurs after an element is created.
ElementDeactivated (inherited from vdxMultiContainer) | Occurs after an element is deactivated.
ElementDeactivating (inherited from vdxMultiContainer) | Occurs before an element is deactivated.
ElementReactivated (inherited from vdxMultiContainer) | Occurs after an element is reactivated.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from vdxMultiContainer) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HandleChanges (inherited from vdxMultiContainer) | Activate the element with unsaved changes.
HasChanges (inherited from vdxMultiContainer) | Indicates if a component or one of its subcomponents has pending changes.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnElementActivated | Either connect this DataActionManager with the vdxDataActionManager of the current element or connect the vdxDataStatusManager of the current element with this DataActionManager vdxDataStatusManager.
OnElementCreated (inherited from vdxMultiContainer) | Inform all registered components about ElementCreated event.
OnElementDeactivated | Disconnect DataActionManager from current element and disconnect DataStatusManager from this DataActionManager.
OnElementDeactivating (inherited from vdxMultiContainer) | Inform all registered components about ElementDeactivating event.
OnElementReactivated (inherited from vdxMultiContainer) | Inform all registered components about ElementReactivated event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxChangeable.HandleChanges (inherited from vdxMultiContainer)
IvdxChangeable.HasChanges (inherited from vdxMultiContainer)

See Also

vdxDataMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataMultiContainer Constructor

Initializes a new instance of the vdxDataMultiContainer class.

public vdxDataMultiContainer();

See Also

vdxDataMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataMultiContainer Properties

The properties of the vdxDataMultiContainer class are listed below. For a complete list of vdxDataMultiContainer class members, see the vdxDataMultiContainer Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Current (inherited from vdxMultiContainer) | Gets the current active control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataActionManager | Gets or sets the vdxDataActionManager, which manage all action items.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataStatusManager | Gets the vdxDataStatusManager of the current element if its implement IvdxDsmProvider.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

vdxDataMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataMultiContainer.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxDataMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataMultiContainer.DataActionManager Property

Gets or sets the vdxDataActionManager, which manage all action items.

public vdxDataActionManager DataActionManager {get; set;}

Implements

IvdxDataActionManagerConsumer.DataActionManager

See Also

vdxDataMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataMultiContainer.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxDataMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataMultiContainer.DataStatusManager Property

Gets the vdxDataStatusManager of the current element if its implement IvdxDsmProvider.

public vdxDataStatusManager DataStatusManager {get;}

Implements

IvdxDsmProvider.DataStatusManager

See Also

vdxDataMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataMultiContainer Methods

The methods of the vdxDataMultiContainer class are listed below. For a complete list of vdxDataMultiContainer class members, see the vdxDataMultiContainer Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetElement (inherited from vdxMultiContainer) | Get the element for the given element type, if it is cached, otherwise null.
GetElements (inherited from vdxMultiContainer) | Get all elements cached by this multiContainer.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HideCurrentElement (inherited from vdxMultiContainer) | Hides the currently shown IvdxMultiContainerCacheable element.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Remove (inherited from vdxMultiContainer) | Removes the corresponding element type from the container and disposes the control.
RemoveAll (inherited from vdxMultiContainer) | Removes all elements from the container and dispose each one.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from vdxMultiContainer) | Overloaded. Displays the element of the given IvdxMultiContainerCacheable type.
Show (inherited from Control) | Overloaded. Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from vdxMultiContainer) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HandleChanges (inherited from vdxMultiContainer) | Activate the element with unsaved changes.
HasChanges (inherited from vdxMultiContainer) | Indicates if a component or one of its subcomponents has pending changes.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnElementActivated | Either connect this DataActionManager with the vdxDataActionManager of the current element or connect the vdxDataStatusManager of the current element with this DataActionManager vdxDataStatusManager.
OnElementCreated (inherited from vdxMultiContainer) | Inform all registered components about ElementCreated event.
OnElementDeactivated | Disconnect DataActionManager from current element and disconnect DataStatusManager from this DataActionManager.
OnElementDeactivating (inherited from vdxMultiContainer) | Inform all registered components about ElementDeactivating event.
OnElementReactivated (inherited from vdxMultiContainer) | Inform all registered components about ElementReactivated event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxChangeable.HandleChanges (inherited from vdxMultiContainer)
IvdxChangeable.HasChanges (inherited from vdxMultiContainer)

See Also

vdxDataMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataMultiContainer.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxDataMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataMultiContainer.OnElementActivated Method

Either connect this DataActionManager with the vdxDataActionManager of the current element or connect the vdxDataStatusManager of the current element with this DataActionManager vdxDataStatusManager.

protected override void OnElementActivated();

See Also

vdxDataMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataMultiContainer.OnElementDeactivated Method

Disconnect DataActionManager from current element and disconnect DataStatusManager from this DataActionManager.

protected override void OnElementDeactivated();

See Also

vdxDataMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataMultiContainer.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxDataMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference Class

The vdxDataSetReference component encapsulates a typed DataSet. The type of the DataSet is passed to the component. This causes the creation of a DataSet of the desired type. Afterwards every Control may be bound to the vdxDataSetReference component. If you have several (and big) typed DataSets in your project, the devenv's performance may decrease dramatically, as soon you have some instances of typed DataSets on a Form. To prevent this, you can encapsulate the DataSet by a vdxDataSetReference component. You will also be able to use the vdxControlDesigner of the component to create the bound controls easyly.

For a list of all members of this type, see vdxDataSetReference Members.

System.Object
MarshalByRefObject
Component
vdxDataSetReference

public class vdxDataSetReference : Component, IListSource, IvdxDataSetProvider

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataSetReference Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference Members

vdxDataSetReference overview

Public Instance Constructors

vdxDataSetReference Overloaded. Initializes a new instance of the vdxDataSetReference class.

Public Instance Properties

BindingContainer | Gets or sets the Binding container.
Container (inherited from Component) | Gets the IContainer that contains the Component.
DataSet | Gets the DataSet encapsulated by this component
Name | Gets or sets designer component name. Corresponds to the Property (Name).
RefDataSet | Get or set the type of the DataSet, this component is encapsulating. Normally this property is set during design Time. If the type of the DataSet changes at design time, all existing bindings to this vdxDataSetReference instance are removed.
Site (inherited from Component) | Gets or sets the ISite of the Component.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FillData | Fill Data into the encapsulated DataSet
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ReadBindings | Overloaded. Replace the bindings for the specified control.
ToString (inherited from Component) |

Public Instance Events

Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
OnDataTypeSet | Occurs after the DataSet type was set.

Protected Instance Properties

DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

Protected Instance Methods

Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDataSetProvider.DataSet
Deag.Vdx.Controls.Core.IvdxDataSetProvider.DataSetType
System.ComponentModel.IListSource.ContainsListCollection

Explicit Interface Implementations

IListSource.GetList | Returns an IList that can be bound to a data source from an object that does not implement an IList itself.
IvdxDataSetProvider.Contains |

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference Constructor

Initializes a new instance of the vdxDataSetReference class.

Overload List

Initializes a new instance of the vdxDataSetReference class.

public vdxDataSetReference();

Initializes a new instance of the vdxDataSetReference class.

public vdxDataSetReference(IContainer);

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference Constructor ()

Initializes a new instance of the vdxDataSetReference class.

public vdxDataSetReference();

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace | vdxDataSetReference Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference Constructor (IContainer)

Initializes a new instance of the vdxDataSetReference class.

public vdxDataSetReference(
IContainer components
);

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace | vdxDataSetReference Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference Properties

The properties of the vdxDataSetReference class are listed below. For a complete list of vdxDataSetReference class members, see the vdxDataSetReference Members topic.

Public Instance Properties

BindingContainer | Gets or sets the Binding container.
Container (inherited from Component) | Gets the IContainer that contains the Component.
DataSet | Gets the DataSet encapsulated by this component
Name | Gets or sets designer component name. Corresponds to the Property (Name).
RefDataSet | Get or set the type of the DataSet, this component is encapsulating. Normally this property is set during design Time. If the type of the DataSet changes at design time, all existing bindings to this vdxDataSetReference instance are removed.
Site (inherited from Component) | Gets or sets the ISite of the Component.

Protected Instance Properties

DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDataSetProvider.DataSet
Deag.Vdx.Controls.Core.IvdxDataSetProvider.DataSetType
System.ComponentModel.IListSource.ContainsListCollection

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference.BindingContainer Property

Gets or sets the Binding container.

public System.Windows.Forms.Control BindingContainer {get; set;}

Remarks

This is the reference to the control, in which's components collection this component resides. Usually, this property has to be set in the vdxDataDetail based control only if the default, which is the current container, is not suitable.

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference.DataSet Property

Gets the DataSet encapsulated by this component

public System.Data.DataSet DataSet {get;}

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference.Deag.Vdx.Controls.Core.IvdxDataSetProvider.DataSet Property

private System.Data.DataSet Deag.Vdx.Controls.Core.IvdxDataSetProvider.DataSet {get; set;}

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference.Deag.Vdx.Controls.Core.IvdxDataSetProvider.DataSetType Property

private System.Type Deag.Vdx.Controls.Core.IvdxDataSetProvider.DataSetType {get; set;}

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference.Name Property

Gets or sets designer component name. Corresponds to the Property (Name).

public string Name {get; set;}

Implements

IvdxDataSetProvider.Name

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference.RefDataSet Property

Get or set the type of the DataSet, this component is encapsulating. Normally this property is set during design Time. If the type of the DataSet changes at design time, all existing bindings to this vdxDataSetReference instance are removed.

public System.Type RefDataSet {get; set;}

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference.System.ComponentModel.IListSource.ContainsListCollection Property

private bool System.ComponentModel.IListSource.ContainsListCollection {get;}

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference Methods

The methods of the vdxDataSetReference class are listed below. For a complete list of vdxDataSetReference class members, see the vdxDataSetReference Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FillData | Fill Data into the encapsulated DataSet
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ReadBindings | Overloaded. Replace the bindings for the specified control.
ToString (inherited from Component) |

Protected Instance Methods

Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Explicit Interface Implementations

IListSource.GetList | Returns an IList that can be bound to a data source from an object that does not implement an IList itself.
IvdxDataSetProvider.Contains |

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference.IvdxDataSetProvider.Contains Method

bool IvdxDataSetProvider.Contains(
DataTable table
);

Implements

IvdxDataSetProvider.Contains

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Dispose Method

VDX Framework

vdxDataSetReference.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference.Dispose Method (Boolean)

Clean up any resources being used.

protected override void Dispose(
bool disposing
);

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace | vdxDataSetReference.Dispose Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference.FillData Method

Fill Data into the encapsulated DataSet

public void FillData(
DataSet Source
);

Parameters

Source
Source containing the data

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ReadBindings Method

VDX Framework

vdxDataSetReference.ReadBindings Method

Replace the bindings for the BindingContainer.

Overload List

Replace the bindings for the BindingContainer.

public void ReadBindings();

Replace the bindings for the specified control.

public void ReadBindings(Control);

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference.ReadBindings Method ()

Replace the bindings for the BindingContainer.

public void ReadBindings();

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace | vdxDataSetReference.ReadBindings Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference.ReadBindings Method (Control)

Replace the bindings for the specified control.

public void ReadBindings(
Control container
);

Parameters

container

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace | vdxDataSetReference.ReadBindings Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference.IListSource.GetList Method

Returns an IList that can be bound to a data source from an object that does not implement an IList itself.

IList IListSource.GetList();

Return Value

The IList

Implements

IListSource.GetList

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference Events

The events of the vdxDataSetReference class are listed below. For a complete list of vdxDataSetReference class members, see the vdxDataSetReference Members topic.

Public Instance Events

Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
OnDataTypeSet | Occurs after the DataSet type was set.

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataSetReference.OnDataTypeSet Event

Occurs after the DataSet type was set.

public event EventHandler OnDataTypeSet;

Implements

IvdxDataSetProvider.OnDataTypeSet

See Also

vdxDataSetReference Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager Class

VDX Data Status Management class.

For a list of all members of this type, see vdxDataStatusManager Members.

System.Object
MarshalByRefObject
Component
vdxDataStatusManager

public class vdxDataStatusManager : Component, IListSource, IvdxGetContextAssembly, IvdxChangeable, IvdxBindingManager, IvdxDataSetProvider

Remarks

Manages the state of a Dataset and allowed operations. Interacts with the vdxTableManager and vdxDataActionManager.

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataStatusManager Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager Members

vdxDataStatusManager overview

Public Instance Constructors

vdxDataStatusManager Overloaded. Initializes a new instance of the vdxDataStatusManager class.

Public Instance Properties

AllowAdd | Gets or sets a bool value indicating whether the data status manager allows add operation.
AllowAutoEdit | Gets or sets a bool value indicating whether the data status manager allows auto edit.
AllowCopy | Gets or sets a bool value indicating whether the data status manager allows copy operation.
AllowDelete | Gets or sets a value indicating whether the data status manager allows delete operation.
AllowEdit | Gets or sets a bool value indicating whether the data status manager allows edit operation.
AllowSave | Gets or sets a bool value indicating whether the data status manager allows save operation.
BindingContainer | Gets or sets the Binding container.
BindingManager | Gets/sets the IvdxBindingManager that handles the bindings of the managed data set.
Container (inherited from Component) | Gets the IContainer that contains the Component.
Context | Gets or sets the description of the data manipulation scenario.
ContextDynamic | Gets the dynamic description of the data manipulation scenario.
DataSet | Gets/sets the managed DataSet.
DataSetType | Gets or sets the managed data set type.
DataStatus | Gets the data current data status.
MainDataTable | Gets or sets the main data table.
MainDataTableName | Gets or sets the main data table.
MainTableManager | Gets the main data table.
MergeUpdateMethod | Gets/sets the method that merges the returned data from the update method into the managed data set.
Name | Gets or sets designer component name. Corresponds to the Property (Name).
QuestionDelete | Gets or sets the delete question string.
QuestionDeleteTitle | Gets or sets the delete title string.
QuestionSaveChanges | Gets or sets the save changes question string.
QuestionSaveChangesTitle | Gets or sets the save changes title string.
QuestionSaveNewRecord | Gets or sets the save new record question string.
QuestionSaveNewRecordTitle | Gets or sets the save new record string.
SelectedDataTable | Gets or sets the table, on which the following operations are performed.
SelectedDataTableName | Gets or sets the table, on which the following operations are performed.
SelectedTableManager | Gets the selected table manager.
Site (inherited from Component) | Gets or sets the ISite of the Component.
StatusTextEdit | Gets or sets the edit string.
StatusTextFilling | gets or sets the filling string.
StatusTextNew | Gets or sets the new string.
StatusTextNoData | gets or sets the no data string.
TableManagers | Gets a collection of vdxTableManagers.
UpdateOnlyChanges | Gets/sets a value indicating whether only changes are sent to the update method.
Updater | Gets/sets the object that handles the updating of the managed data set.
UpdaterMethodName | Gets/sets the name of the method of the Updater that is called for updating the managed data set.

Public Instance Methods

Add | Entry point for the add cascade to add a new record.
AskUser | Displays a message box with the appropriate message.
AutoEdit | Whenever a VDX databound control receives interactive changes, this method gets called.
ChangeContextDynamic | Sets the dynamic context including data status information.
Copy | Entry point for the copy cascade to copy an existing record.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Delete | Entry point for the delete cascade to delete a record.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
Edit | Entry point for the edit cascade to begin editing.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Fill | Overloaded. Fills the managed data set with the data of the specified data set.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetPossibleOperations | Returns a vdxAllowedOpereations object with the allowed operations.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleChanges | Activates and displays the unsaved changes to the user which can decide if he wants to save the changes.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Merge | Overloaded. Merges the specified data table into the managed data set.
ReadBindings | Overloaded. Reads and processes the data bindings.
Save | Entry point for the save cascade to save pending changes within the managed dataset.
SetDataStatus | Internal method to set the desired datastatus.
ShowDebug | Use this Method if you are debugging the VdxDataSet assigned to this vdxDataStatusManager
ToString (inherited from Component) |
Undo | Entry point for the undo cascade to undo changes within the managed dataset.

Public Instance Events

Added | Defines the public event, which is triggered after an add operation has been performed.
Adding | Defines the public event, which is triggered before an add operation occurs.
AllowAddChanged | Occurs when the AllowAdd property changes.
AllowAutoEditChanged | Occurs when the AllowAutoEdit property changes.
AllowCopyChanged | Occurs when the AllowCopy property changes.
AllowDeleteChanged | Occurs when the AllowDelete property changes.
AllowEditChanged | Occurs when the AllowEdit property changes.
AllowPreviewChanged | Occurs when the AllowPreview property changes.
AllowSaveChanged | Occurs when the AllowSave property changes.
AutoEdited | Defines the public event, which is triggered after the autoedit operation has been performed.
AutoEditing | Defines the public event, which is triggered before the autoedit operation occurs.
Copied | Defines the public event, which is triggered after a copy operation has been performed.
Copying | Defines the public event, which is triggered before a copy operation occurs.
DataStatusChanged | Defines the public event, which is triggered after the data status changed.
DataValidating | Defines the public event, which is triggered before the save operation occurs.
Deleted | Defines the public event, which is triggered after a delete operation has been performed.
Deleting | Defines the public event, which is triggered before a delete operation occurs.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
Edited | Defines the public event, which is triggered after an edit operation has been performed.
Editing | Defines the public event, which is triggered before an edit operation occurs.
Filled | Defines the public event, which is triggered after the DataSet was filled.
Filling | Defines the public event, which is triggered before the DataSet is being filled.
OnDataTypeSet | Occurs after the DataSet type was set.
PossibleOperationsChanged | Defines the public event, which is triggered whenever the allowed property changes.
Previewed | Defines the public event, which is triggered after the preview operation has been performed.
Previewing | Defines the public event, which is triggered before the preview operation occurs.
ReadBindingsCompleted | Defines the public event, which is triggered after the VdxReadBindings has been performed.
Saved | Defines the public event, which is triggered after a save operation has been performed.
Saving | Defines the public event, which is triggered before a save operation occurs.
SelectedTableChanged | Defines the public event, which is triggered after the selected table changed.
Undoing | Defines the public event, which is triggered before the undo operation occurs.
Undone | Defines the public event, which is triggered after the undo operation has been performed.

Protected Instance Properties

DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

Protected Instance Methods

AddCore | Core add method, which adds a new record.
CopyCore | Core copy method, which copies a record.
DeleteCore | Invokes the delete method on the SelectedTableManager.
Dispose (inherited from Component) | Overloaded. Releases the unmanaged resources used by the Component and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAdded | Raises the Added event.
OnAdding | Raises the Adding event.
OnAllowAddChanged | Raises an OnAllowAddChanged event.
OnAllowAutoEditChanged | Raises an OnAllowAutoEditChanged event.
OnAllowCopyChanged | Raises an OnAllowCopyChanged event.
OnAllowDeleteChanged | Raises an AllowDeleteChanged event.
OnAllowEditChanged | Raises an OnAllowEditChanged event.
OnAllowPreviewChanged | Raises an OnAllowPreviewChanged event.
OnAllowSaveChanged | Raises an OnAllowSaveChanged event.
OnAutoEdited | Raises the AutoEdited event.
OnAutoEditing | Raises the AutoEditing event.
OnCopied | Raises the Copied event.
OnCopying | Raises the Copying event.
OnDataStatusChanged | Raises the DataStatusChanged event.
OnDataValidating | Raises the DataValidating event.
OnDeleted | Raises the Deleted event.
OnDeleting | Raises the Deleting event.
OnEdited | Raises the Edited event.
OnEditing | Raises the Editing event.
OnFilled | Raises the Filled event.
OnFilling | Raises the Filling event.
OnPossibleOperationsChanged | Raises an PossibleOperationsChanged event.
OnPreviewed | Raises the Previewed event.
OnPreviewing | Raises the Previewing event.
OnReadBindingsCompleted | Raises the ReadBindings event, after VdxReadBindings has been called.
OnSaved | Raises the Saved event.
OnSaving | Raises the Saving event.
OnSelectedTableChanged | Raises the SelectedTableChanged event.
OnUndoing | Raises the Undoing event.
OnUndone | Raises the Undone event.
SaveCore | Core save method, which saves pending changes.
UndoCore | Invokes the undo method on all vdxTableManagers.
Update | Delegates the DataSet changes to the Updater.

Private Instance Properties

System.ComponentModel.IListSource.ContainsListCollection

Explicit Interface Implementations

IListSource.GetList | Returns an IList that can be bound to a data source from an object that does not implement an IList itself.
IvdxBindingManager.Add |
IvdxBindingManager.AddContainer |
IvdxBindingManager.Contains |
IvdxBindingManager.Refresh | Overloaded.
IvdxBindingManager.Remove |
IvdxChangeable.HandleChanges | Activates and displays the unsaved changes to the user which can decide if he wants to save the changes.
IvdxChangeable.HasChanges | Implements the vdxHasChanges method which defines whether pending changes exist.
IvdxDataSetProvider.Contains |
IvdxGetContextAssembly.VdxGetContextAssembly | Used to retrieve the IDesignerHost from the VdxDataSet that is defined on the Control in the DesignMode.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager Constructor

Initializes a new instance of the vdxDataStatusManager class.

Overload List

Initializes a new instance of the vdxDataStatusManager class.

public vdxDataStatusManager();

Initializes a new instance of the vdxDataStatusManager class.

public vdxDataStatusManager(IContainer);

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager Constructor (IContainer)

Initializes a new instance of the vdxDataStatusManager class.

public vdxDataStatusManager(
IContainer container
);

Parameters

container
The container.

Remarks

This contructor is usually used by the designer.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager Constructor ()

Initializes a new instance of the vdxDataStatusManager class.

public vdxDataStatusManager();

Remarks

This is the default constructor.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager Properties

The properties of the vdxDataStatusManager class are listed below. For a complete list of vdxDataStatusManager class members, see the vdxDataStatusManager Members topic.

Public Instance Properties

AllowAdd | Gets or sets a bool value indicating whether the data status manager allows add operation.
AllowAutoEdit | Gets or sets a bool value indicating whether the data status manager allows auto edit.
AllowCopy | Gets or sets a bool value indicating whether the data status manager allows copy operation.
AllowDelete | Gets or sets a value indicating whether the data status manager allows delete operation.
AllowEdit | Gets or sets a bool value indicating whether the data status manager allows edit operation.
AllowSave | Gets or sets a bool value indicating whether the data status manager allows save operation.
BindingContainer | Gets or sets the Binding container.
BindingManager | Gets/sets the IvdxBindingManager that handles the bindings of the managed data set.
Container (inherited from Component) | Gets the IContainer that contains the Component.
Context | Gets or sets the description of the data manipulation scenario.
ContextDynamic | Gets the dynamic description of the data manipulation scenario.
DataSet | Gets/sets the managed DataSet.
DataSetType | Gets or sets the managed data set type.
DataStatus | Gets the data current data status.
MainDataTable | Gets or sets the main data table.
MainDataTableName | Gets or sets the main data table.
MainTableManager | Gets the main data table.
MergeUpdateMethod | Gets/sets the method that merges the returned data from the update method into the managed data set.
Name | Gets or sets designer component name. Corresponds to the Property (Name).
QuestionDelete | Gets or sets the delete question string.
QuestionDeleteTitle | Gets or sets the delete title string.
QuestionSaveChanges | Gets or sets the save changes question string.
QuestionSaveChangesTitle | Gets or sets the save changes title string.
QuestionSaveNewRecord | Gets or sets the save new record question string.
QuestionSaveNewRecordTitle | Gets or sets the save new record string.
SelectedDataTable | Gets or sets the table, on which the following operations are performed.
SelectedDataTableName | Gets or sets the table, on which the following operations are performed.
SelectedTableManager | Gets the selected table manager.
Site (inherited from Component) | Gets or sets the ISite of the Component.
StatusTextEdit | Gets or sets the edit string.
StatusTextFilling | gets or sets the filling string.
StatusTextNew | Gets or sets the new string.
StatusTextNoData | gets or sets the no data string.
TableManagers | Gets a collection of vdxTableManagers.
UpdateOnlyChanges | Gets/sets a value indicating whether only changes are sent to the update method.
Updater | Gets/sets the object that handles the updating of the managed data set.
UpdaterMethodName | Gets/sets the name of the method of the Updater that is called for updating the managed data set.

Protected Instance Properties

DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

Private Instance Properties

System.ComponentModel.IListSource.ContainsListCollection

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.AllowAdd Property

Gets or sets a bool value indicating whether the data status manager allows add operation.

public bool AllowAdd {get; set;}

Remarks

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | DataStatus | GetPossibleOperations

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.AllowAutoEdit Property

Gets or sets a bool value indicating whether the data status manager allows auto edit.

public bool AllowAutoEdit {get; set;}

Remarks

The AutoEdit feature allows the user to start modifying data without the need to prior manually swith into Edit mode. If set, by changing data within any of the VDX databound controls, the datastatus automatically switches into Edit mode.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | DataStatus | GetPossibleOperations

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.AllowCopy Property

Gets or sets a bool value indicating whether the data status manager allows copy operation.

public bool AllowCopy {get; set;}

Remarks

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | DataStatus | GetPossibleOperations

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.AllowDelete Property

Gets or sets a value indicating whether the data status manager allows delete operation.

public bool AllowDelete {get; set;}

Remarks

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | DataStatus | GetPossibleOperations

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.AllowEdit Property

Gets or sets a bool value indicating whether the data status manager allows edit operation.

public bool AllowEdit {get; set;}

Remarks

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | DataStatus | GetPossibleOperations

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.AllowSave Property

Gets or sets a bool value indicating whether the data status manager allows save operation.

public bool AllowSave {get; set;}

Remarks

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | DataStatus | GetPossibleOperations

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.BindingContainer Property

Gets or sets the Binding container.

public System.Windows.Forms.Control BindingContainer {get; set;}

Remarks

This is the reference to the control, in which's components collection this component resides. Usually, this property has to be set in the vdxDataDetail based control only if the default, which is the current container, is not suitable.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.BindingManager Property

Gets/sets the IvdxBindingManager that handles the bindings of the managed data set.

public IvdxBindingManager BindingManager {get; set;}

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Context Property

Gets or sets the description of the data manipulation scenario.

public string Context {get; set;}

Remarks

This is the context description used by the framework. i.e. used to populate the vdxInfoBar in the master table scenario. Usually, this property will be set through the property sheet.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.ContextDynamic Property

Gets the dynamic description of the data manipulation scenario.

public string ContextDynamic {get;}

Remarks

Describes the context prefixed with the current data status info.

Example

Edit - Country

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | Context | DataStatus

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.DataSet Property

Gets/sets the managed DataSet.

public System.Data.DataSet DataSet {get; set;}

Implements

IvdxDataSetProvider.DataSet

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.DataSetType Property

Gets or sets the managed data set type.

public System.Type DataSetType {get; set;}

Implements

IvdxDataSetProvider.DataSetType

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.DataStatus Property

Gets the data current data status.

public Deag.Vdx.Common.Enums.vdxDataStatus DataStatus {get;}

Remarks

The datastatus describes the state of the current data state. Possible datastatus values are defined in the vdxDataStatus enumeration.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.MainDataTable Property

Gets or sets the main data table.

public System.Data.DataTable MainDataTable {get; set;}

Remarks

The selected table defines which tablemanager actually gets used for data manipulations such as deleting or inserting.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.MainDataTableName Property

Gets or sets the main data table.

public string MainDataTableName {get; set;}

Remarks

The selected table defines which tablemanager actually gets used for data manipulations such as deleting or inserting.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.MainTableManager Property

Gets the main data table.

public vdxTableManager MainTableManager {get;}

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.MergeUpdateMethod Property

Gets/sets the method that merges the returned data from the update method into the managed data set.

public vdxDataStatusManager.MergeUpdateDelegate MergeUpdateMethod {get; set;}

Remarks

After the data of the DSM was updated by a call to Updater.UpdaterMessageName the data has to be merged back into the data set of the DSM. This task is executed by the MergeUpdateMethod. If you want to perform your own merging than set this property. Otherwise the default implementation will be used.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Name Property

Gets or sets designer component name. Corresponds to the Property (Name).

public string Name {get; set;}

Implements

IvdxDataSetProvider.Name

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.QuestionDelete Property

Gets or sets the delete question string.

public string QuestionDelete {get; set;}

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.QuestionDeleteTitle Property

Gets or sets the delete title string.

public string QuestionDeleteTitle {get; set;}

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.QuestionSaveChanges Property

Gets or sets the save changes question string.

public string QuestionSaveChanges {get; set;}

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.QuestionSaveChangesTitle Property

Gets or sets the save changes title string.

public string QuestionSaveChangesTitle {get; set;}

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.QuestionSaveNewRecord Property

Gets or sets the save new record question string.

public string QuestionSaveNewRecord {get; set;}

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.QuestionSaveNewRecordTitle Property

Gets or sets the save new record string.

public string QuestionSaveNewRecordTitle {get; set;}

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.SelectedDataTable Property

Gets or sets the table, on which the following operations are performed.

public System.Data.DataTable SelectedDataTable {get; set;}

Remarks

The selected table defines, which table within the managed dataset is actually selected. Basically, all data manipulations are routed to the selected table.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.SelectedDataTableName Property

Gets or sets the table, on which the following operations are performed.

public string SelectedDataTableName {get; set;}

Remarks

The selected table defines, which table within the managed dataset is actually selected. Basically, all data manipulations are routed to the selected table.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.SelectedTableManager Property

Gets the selected table manager.

public vdxTableManager SelectedTableManager {get;}

Remarks

By changing the VdxSelectedTable, this property gets automatically changed if the correspondig table is involved in databinding.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.StatusTextEdit Property

Gets or sets the edit string.

public string StatusTextEdit {get; set;}

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.StatusTextFilling Property

gets or sets the filling string.

public string StatusTextFilling {get; set;}

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.StatusTextNew Property

Gets or sets the new string.

public string StatusTextNew {get; set;}

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.StatusTextNoData Property

gets or sets the no data string.

public string StatusTextNoData {get; set;}

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.System.ComponentModel.IListSource.ContainsListCollection Property

private bool System.ComponentModel.IListSource.ContainsListCollection {get;}

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.TableManagers Property

Gets a collection of vdxTableManagers.

public vdxTableManagerCollection TableManagers {get;}

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.UpdateOnlyChanges Property

Gets/sets a value indicating whether only changes are sent to the update method.

public bool UpdateOnlyChanges {get; set;}

Remarks

Normally, only changes are sent to the Updater. Sometimes it is usefull to send all data because it is needed to do the update (for example if dependencies can not be extracted from the updates only).

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Updater Property

Gets/sets the object that handles the updating of the managed data set.

public object Updater {get; set;}

Remarks

When the Save of the DSM is called then the method with the name equal to UpdaterMethodName on the Updater is called. This method is responsible of updating the data from the DSM into the storage and returning the stored data. This data has to be returned because during the update process values can be changed (for example auto-generated keys).

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.UpdaterMethodName Property

Gets/sets the name of the method of the Updater that is called for updating the managed data set.

public string UpdaterMethodName {get; set;}

Remarks

When the Save of the DSM is called then the method with the name equal to UpdaterMethodName on the Updater is called. This method is responsible of updating the data from the DSM into the storage and returning the stored data. This data has to be returned because during the update process values can be changed (for example auto-generated keys).

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager Methods

The methods of the vdxDataStatusManager class are listed below. For a complete list of vdxDataStatusManager class members, see the vdxDataStatusManager Members topic.

Public Instance Methods

Add | Entry point for the add cascade to add a new record.
AskUser | Displays a message box with the appropriate message.
AutoEdit | Whenever a VDX databound control receives interactive changes, this method gets called.
ChangeContextDynamic | Sets the dynamic context including data status information.
Copy | Entry point for the copy cascade to copy an existing record.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Delete | Entry point for the delete cascade to delete a record.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
Edit | Entry point for the edit cascade to begin editing.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Fill | Overloaded. Fills the managed data set with the data of the specified data set.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetPossibleOperations | Returns a vdxAllowedOpereations object with the allowed operations.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleChanges | Activates and displays the unsaved changes to the user which can decide if he wants to save the changes.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Merge | Overloaded. Merges the specified data table into the managed data set.
ReadBindings | Overloaded. Reads and processes the data bindings.
Save | Entry point for the save cascade to save pending changes within the managed dataset.
SetDataStatus | Internal method to set the desired datastatus.
ShowDebug | Use this Method if you are debugging the VdxDataSet assigned to this vdxDataStatusManager
ToString (inherited from Component) |
Undo | Entry point for the undo cascade to undo changes within the managed dataset.

Protected Instance Methods

AddCore | Core add method, which adds a new record.
CopyCore | Core copy method, which copies a record.
DeleteCore | Invokes the delete method on the SelectedTableManager.
Dispose (inherited from Component) | Overloaded. Releases the unmanaged resources used by the Component and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAdded | Raises the Added event.
OnAdding | Raises the Adding event.
OnAllowAddChanged | Raises an OnAllowAddChanged event.
OnAllowAutoEditChanged | Raises an OnAllowAutoEditChanged event.
OnAllowCopyChanged | Raises an OnAllowCopyChanged event.
OnAllowDeleteChanged | Raises an AllowDeleteChanged event.
OnAllowEditChanged | Raises an OnAllowEditChanged event.
OnAllowPreviewChanged | Raises an OnAllowPreviewChanged event.
OnAllowSaveChanged | Raises an OnAllowSaveChanged event.
OnAutoEdited | Raises the AutoEdited event.
OnAutoEditing | Raises the AutoEditing event.
OnCopied | Raises the Copied event.
OnCopying | Raises the Copying event.
OnDataStatusChanged | Raises the DataStatusChanged event.
OnDataValidating | Raises the DataValidating event.
OnDeleted | Raises the Deleted event.
OnDeleting | Raises the Deleting event.
OnEdited | Raises the Edited event.
OnEditing | Raises the Editing event.
OnFilled | Raises the Filled event.
OnFilling | Raises the Filling event.
OnPossibleOperationsChanged | Raises an PossibleOperationsChanged event.
OnPreviewed | Raises the Previewed event.
OnPreviewing | Raises the Previewing event.
OnReadBindingsCompleted | Raises the ReadBindings event, after VdxReadBindings has been called.
OnSaved | Raises the Saved event.
OnSaving | Raises the Saving event.
OnSelectedTableChanged | Raises the SelectedTableChanged event.
OnUndoing | Raises the Undoing event.
OnUndone | Raises the Undone event.
SaveCore | Core save method, which saves pending changes.
UndoCore | Invokes the undo method on all vdxTableManagers.
Update | Delegates the DataSet changes to the Updater.

Explicit Interface Implementations

IListSource.GetList | Returns an IList that can be bound to a data source from an object that does not implement an IList itself.
IvdxBindingManager.Add |
IvdxBindingManager.AddContainer |
IvdxBindingManager.Contains |
IvdxBindingManager.Refresh | Overloaded.
IvdxBindingManager.Remove |
IvdxChangeable.HandleChanges | Activates and displays the unsaved changes to the user which can decide if he wants to save the changes.
IvdxChangeable.HasChanges | Implements the vdxHasChanges method which defines whether pending changes exist.
IvdxDataSetProvider.Contains |
IvdxGetContextAssembly.VdxGetContextAssembly | Used to retrieve the IDesignerHost from the VdxDataSet that is defined on the Control in the DesignMode.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Add Method

Entry point for the add cascade to add a new record.

public bool Add();

Return Value

True if the record have been added

Remarks

Starts adding a record when the datastatusmanager is already loaded.

Example

This is the sample code from the mainform, which gets executed whenever an add action occurs either by pressing the Add button from the toolbar, or the corresponding menu item. NOTE: To start the add process if the container holding the datastatusmanager is not yet loaded (i.e. directly from within the menu or an outlookbar item), use the method AddInitial.

            private void vdxDataActionManager_ActionItemAdd_ActionInvoked(object sender, System.EventArgs e)
            {
                if(this.vdxDataActionManager.DataStatusManager != null)
                {
                    this.vdxDataActionManager.DataStatusManager.Add();
                }
            }

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataActionManager

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.AddCore Method

Core add method, which adds a new record.

protected bool AddCore();

Return Value

True if Add was successful

Remarks

This operation applies to the currently selected SelectedTableManager

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.AskUser Method

Displays a message box with the appropriate message.

public DialogResult AskUser(
vdxQuestion question
);

Parameters

question
The type of the question.

Return Value

The dialog result.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.AutoEdit Method

Whenever a VDX databound control receives interactive changes, this method gets called.

public bool AutoEdit();

Return Value

Returns true, if this change is allowed and can be performed. Returns false, if this change is not allowed and the edit operation cannot start.

Remarks

Whenever the user tries to change data in a VDX databound control, this method gets called. if the autoedit feature has been set through the property AllowAutoEdit the framework tries to switch the datastatus into edit if the current datastatus has been read.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.ChangeContextDynamic Method

Sets the dynamic context including data status information.

public virtual void ChangeContextDynamic();

Remarks

The dynamic context is the context description of the component prefixed with the current data status.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | DataStatus | Context

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Copy Method

Entry point for the copy cascade to copy an existing record.

public DataRow Copy();

Return Value

True if the record have been copied

Remarks

Copies the currently selected record on the SelectedTableManager.

Example

This is the sample code from the mainform, which gets executed whenever a copy action occurs either by pressing the Copy button from the toolbar, or the corresponding menu item.

            private void vdxDataActionManager_VdxDataActionItemCopy_vdxActionInvoked(object sender, System.EventArgs e)
            {
                if(this.vdxDataActionManager.VdxDataStatusManager != null)
                {
                    try
                    {
                        this.vdxDataActionManager.VdxDataStatusManager.Copy();
                    }
                    catch (Exception ex)
                    {
                        if (ex.Message == "ObjectNotSet CurrencyManager.Current")
                        {
                            MessageBox.Show("There is no row to copy from!");
                        }
                        else
                        {
                            MessageBox.Show(ex.Message);
                        }
                    }
                }
            }

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataActionManager

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.CopyCore Method

Core copy method, which copies a record.

protected DataRow CopyCore();

Return Value

True if copy was successful.

Remarks

This operation applies to the currently selected SelectedTableManager

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.IvdxBindingManager.Add Method

void IvdxBindingManager.Add(
IvdxBindingManagable bm
);

Implements

IvdxBindingManager.Add

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.IvdxBindingManager.AddContainer Method

void IvdxBindingManager.AddContainer(
Control container
);

Implements

IvdxBindingManager.AddContainer

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.IvdxBindingManager.Contains Method

bool IvdxBindingManager.Contains(
IvdxBindingManagable bm
);

Implements

IvdxBindingManager.Contains

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxBindingManager.Refresh Method

VDX Framework

vdxDataStatusManager.IvdxBindingManager.Refresh Method

Overload List

private bool IvdxBindingManager.Refresh(IvdxBindingManagable);

private bool IvdxBindingManager.Refresh(vdxBindingManagerRefreshKind);

private bool IvdxBindingManager.Refresh(vdxBindingManagerRefreshKind,params IvdxBindingManagable[]);

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.IvdxBindingManager.Refresh Method (IvdxBindingManagable)

bool IvdxBindingManager.Refresh(
IvdxBindingManagable bm
);

Implements

IvdxBindingManager.Refresh

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager.IvdxBindingManager.Refresh Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.IvdxBindingManager.Refresh Method (vdxBindingManagerRefreshKind)

bool IvdxBindingManager.Refresh(
vdxBindingManagerRefreshKind kind
);

Implements

IvdxBindingManager.Refresh

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager.IvdxBindingManager.Refresh Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.IvdxBindingManager.Refresh Method (vdxBindingManagerRefreshKind, IvdxBindingManagable[])

bool IvdxBindingManager.Refresh(
vdxBindingManagerRefreshKind kind,
params IvdxBindingManagable[] bms
);

Implements

IvdxBindingManager.Refresh

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager.IvdxBindingManager.Refresh Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.IvdxBindingManager.Remove Method

void IvdxBindingManager.Remove(
IvdxBindingManagable bm
);

Implements

IvdxBindingManager.Remove

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.IvdxChangeable.HandleChanges Method

Activates and displays the unsaved changes to the user which can decide if he wants to save the changes.

bool IvdxChangeable.HandleChanges();

Return Value

True if there are changes.

Implements

IvdxChangeable.HandleChanges

Remarks

If there are no changes, nothing happens. Therefore, you can usually use directly this method.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.IvdxChangeable.HasChanges Method

Implements the vdxHasChanges method which defines whether pending changes exist.

bool IvdxChangeable.HasChanges();

Return Value

True if there are pending changes.

Implements

IvdxChangeable.HasChanges

Remarks

Indicates whether the managed dataset has pending changes or not. If the DataStatus is in Edit or New mode this method return true. The vdxIsDataStatusClean issues a question whether the pending changes have to be saved whereas this method just returns a bool representing the state.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.IvdxDataSetProvider.Contains Method

bool IvdxDataSetProvider.Contains(
DataTable table
);

Implements

IvdxDataSetProvider.Contains

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.IvdxGetContextAssembly.VdxGetContextAssembly Method

Used to retrieve the IDesignerHost from the VdxDataSet that is defined on the Control in the DesignMode.

Assembly IvdxGetContextAssembly.VdxGetContextAssembly();

Return Value

Returns the context assembly of type System.Reflection.Assembly.

Implements

IvdxGetContextAssembly.VdxGetContextAssembly

Remarks

Used internally by the reflection class through type converters to get a reference to the context assembly.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Delete Method

Entry point for the delete cascade to delete a record.

public bool Delete();

Return Value

True if the record have been deleted

Remarks

Deletes the currently selected record on the SelectedTableManager and invokes the update method on the businessobject.

Example

This is the sample code from the mainform, which gets executed whenever a delete action occurs either by pressing the Delete button from the toolbar, or the corresponding menu item. The

            private void vdxDataActionManager_VdxDataActionItemDelete_vdxActionInvoked(object sender, System.EventArgs e)
            {
                if(this.vdxDataActionManager.VdxDataStatusManager != null)
                {
                    try
                    {
                        this.vdxDataActionManager.VdxDataStatusManager.Delete();
                    }
                    catch (System.Exception ex)
                    {
                        // Restore the data that could not be deleted
                        this.vdxDataActionManager.VdxDataStatusManager.Undo();
                        MessageBox.Show(ex.Message);
                    }
                }
            }

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataActionManager

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.DeleteCore Method

Invokes the delete method on the SelectedTableManager.

protected bool DeleteCore();

Return Value

True if successful.

Remarks

This operation applies to the currently selected SelectedTableManager.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Edit Method

Entry point for the edit cascade to begin editing.

public bool Edit();

Remarks

Changes the datastatus to edit. if the autoedit feature is activated through the property AllowAutoEdit, the edit method gets invoked implicitely.

Example

This is the sample code from the mainform, which gets executed whenever an edit action occurs explicitely either by pressing the Edit button from the toolbar, or the corresponding menu item. This method has no core method, since no further actions are required.

            private void vdxDataActionManager_VdxDataActionItemEdit_vdxActionInvoked(object sender, System.EventArgs e)
            {
                if(this.vdxDataActionManager.VdxDataStatusManager != null)
                {
                    this.vdxDataActionManager.VdxDataStatusManager.Edit();
                }
            }

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataActionManager

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Fill Method

VDX Framework

vdxDataStatusManager.Fill Method

Fills the managed data set with the data of the specified data set.

Overload List

Fills the managed data set with the data of the specified data set.

public void Fill(DataSet);

Fills the managed data set with the data of the specified data set.

public void Fill(DataSet,MissingSchemaAction);

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Fill Method (DataSet)

Fills the managed data set with the data of the specified data set.

public void Fill(
DataSet ds
);

Parameters

ds
The data set containing the data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager.Fill Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Fill Method (DataSet, MissingSchemaAction)

Fills the managed data set with the data of the specified data set.

public void Fill(
DataSet ds,
MissingSchemaAction action
);

Parameters

ds
The data set containing the data.
action
The action taken in the merge operation when schema mismatches occure.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager.Fill Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.GetPossibleOperations Method

Returns a vdxAllowedOpereations object with the allowed operations.

public vdxPossibleOperations GetPossibleOperations();

Return Value

Returns an object with the allowed operations.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.HandleChanges Method

Activates and displays the unsaved changes to the user which can decide if he wants to save the changes.

public virtual bool HandleChanges();

Return Value

True if there are changes.

Remarks

If there are no changes, nothing happens. Therefore, you can usually use directly this method.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Merge Method

VDX Framework

vdxDataStatusManager.Merge Method

Merges the specified data table into the managed data set.

Overload List

Merges the specified data table into the managed data set.

public void Merge(DataTable);

Merges the specified data table into the managed data set.

public void Merge(DataTable,bool);

Merges the specified data table into the managed data set.

public void Merge(DataTable,bool,MissingSchemaAction);

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Merge Method (DataTable)

Merges the specified data table into the managed data set.

public void Merge(
DataTable dt
);

Parameters

dt

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager.Merge Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Merge Method (DataTable, Boolean)

Merges the specified data table into the managed data set.

public void Merge(
DataTable dt,
bool clear
);

Parameters

dt
clear
Whether the destination table should first be cleared.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager.Merge Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Merge Method (DataTable, Boolean, MissingSchemaAction)

Merges the specified data table into the managed data set.

public void Merge(
DataTable dt,
bool clear,
MissingSchemaAction action
);

Parameters

dt
clear
Whether the destination table should first be cleared.
action
The merge action.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager.Merge Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnAdded Method

Raises the Added event.

protected virtual void OnAdded(
EventArgs e
);

Parameters

e
System.EventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnAdding Method

Raises the Adding event.

protected virtual void OnAdding(
CancelEventArgs e
);

Parameters

e
System.ComponentModel.CancelEventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnAllowAddChanged Method

Raises an OnAllowAddChanged event.

protected virtual void OnAllowAddChanged();

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnAllowAutoEditChanged Method

Raises an OnAllowAutoEditChanged event.

protected virtual void OnAllowAutoEditChanged();

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnAllowCopyChanged Method

Raises an OnAllowCopyChanged event.

protected virtual void OnAllowCopyChanged();

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnAllowDeleteChanged Method

Raises an AllowDeleteChanged event.

protected virtual void OnAllowDeleteChanged();

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnAllowEditChanged Method

Raises an OnAllowEditChanged event.

protected virtual void OnAllowEditChanged();

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnAllowPreviewChanged Method

Raises an OnAllowPreviewChanged event.

protected virtual void OnAllowPreviewChanged();

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnAllowSaveChanged Method

Raises an OnAllowSaveChanged event.

protected virtual void OnAllowSaveChanged();

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnAutoEdited Method

Raises the AutoEdited event.

protected virtual void OnAutoEdited(
EventArgs e
);

Parameters

e
System.EventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnAutoEditing Method

Raises the AutoEditing event.

protected virtual void OnAutoEditing(
CancelEventArgs e
);

Parameters

e
System.ComponentModel.CancelEventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnCopied Method

Raises the Copied event.

protected virtual void OnCopied(
EventArgs e
);

Parameters

e
System.EventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnCopying Method

Raises the Copying event.

protected virtual void OnCopying(
CancelEventArgs e
);

Parameters

e
System.ComponentModel.CancelEventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnDataStatusChanged Method

Raises the DataStatusChanged event.

protected virtual void OnDataStatusChanged(
vdxDataStatusChangedEventArgs e
);

Parameters

e
vdxDataStatusChangedEventArgs object which contains the old and the new datastatus.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnDataValidating Method

Raises the DataValidating event.

protected virtual void OnDataValidating(
CancelEventArgs e
);

Parameters

e
System.ComponentModel.CancelEventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnDeleted Method

Raises the Deleted event.

protected virtual void OnDeleted(
EventArgs e
);

Parameters

e
System.EventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnDeleting Method

Raises the Deleting event.

protected virtual void OnDeleting(
CancelEventArgs e
);

Parameters

e
System.CancelEventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnEdited Method

Raises the Edited event.

protected virtual void OnEdited(
EventArgs e
);

Parameters

e
System.EventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnEditing Method

Raises the Editing event.

protected virtual void OnEditing(
CancelEventArgs e
);

Parameters

e
System.ComponentModel.CancelEventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnFilled Method

Raises the Filled event.

protected virtual void OnFilled(
EventArgs e
);

Parameters

e
System.EventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnFilling Method

Raises the Filling event.

protected virtual void OnFilling(
CancelEventArgs e
);

Parameters

e
System.EventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnPossibleOperationsChanged Method

Raises an PossibleOperationsChanged event.

protected virtual void OnPossibleOperationsChanged();

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnPreviewed Method

Raises the Previewed event.

protected virtual void OnPreviewed(
EventArgs e
);

Parameters

e
System.EventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnPreviewing Method

Raises the Previewing event.

protected virtual void OnPreviewing(
CancelEventArgs e
);

Parameters

e
System.ComponentModel.CancelEventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnReadBindingsCompleted Method

Raises the ReadBindings event, after VdxReadBindings has been called.

protected virtual void OnReadBindingsCompleted(
EventArgs e
);

Parameters

e
System.EventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnSaved Method

Raises the Saved event.

protected virtual void OnSaved(
EventArgs e
);

Parameters

e
System.EventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnSaving Method

Raises the Saving event.

protected virtual void OnSaving(
CancelEventArgs e
);

Parameters

e
System.CancelEventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnSelectedTableChanged Method

Raises the SelectedTableChanged event.

protected virtual void OnSelectedTableChanged(
EventArgs e
);

Parameters

e
System.EventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnUndoing Method

Raises the Undoing event.

protected virtual void OnUndoing(
CancelEventArgs e
);

Parameters

e
System.ComponentModel.CancelEventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnUndone Method

Raises the Undone event.

protected virtual void OnUndone(
EventArgs e
);

Parameters

e
System.EventArgs that contains the event data.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ReadBindings Method

VDX Framework

vdxDataStatusManager.ReadBindings Method

Reads and processes the data bindings.

Overload List

Reads and processes the data bindings.

public void ReadBindings();

Reads and processes the data bindings for the given control.

public void ReadBindings(Control);

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.ReadBindings Method ()

Reads and processes the data bindings.

public void ReadBindings();

Remarks

Gets invoked each time a user control gets visible and calls ReadBindings (with the control as a parameter) for each VDX control. Call this method if you load dynamically controls on a visible container.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager.ReadBindings Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.ReadBindings Method (Control)

Reads and processes the data bindings for the given control.

public void ReadBindings(
Control control
);

Parameters

control
The involved control.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataStatusManager.ReadBindings Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Save Method

Entry point for the save cascade to save pending changes within the managed dataset.

public bool Save();

Return Value

True if the record have been saved

Remarks

Ends the current edits on the tablemanagers and invokes the update method on the businessobject.

Example

This is the sample code from the mainform, which gets executed whenever a save action occurs either by pressing the Save button from the toolbar, or the corresponding menu item or implicitely by changing the context when pending changes exist.

            private void vdxDataActionManager_VdxDataActionItemSave_vdxActionInvoked(object sender, System.EventArgs e)
            {
                if(this.vdxDataActionManager.VdxDataStatusManager != null)
                {
                    try
                    {
                        this.vdxDataActionManager.VdxDataStatusManager.Save();
                    }
                    catch (System.Exception ex)
                    {
                        MessageBox.Show(ex.Message);
                    }
                }
            }

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataActionManager

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.SaveCore Method

Core save method, which saves pending changes.

protected void SaveCore();

Remarks

This operation applies always to the whole currently managed dataset. This method ends the currentedit of all involved tablemanagers and invokes the businessobject's update method. The corresponding update method can be set in the property sheet through vdxUpdateMethodName.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.SetDataStatus Method

Internal method to set the desired datastatus.

public bool SetDataStatus(
vdxDataStatus newState
);

Parameters

newState
The new data status.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.ShowDebug Method

Use this Method if you are debugging the VdxDataSet assigned to this vdxDataStatusManager

public void ShowDebug();

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.IListSource.GetList Method

Returns an IList that can be bound to a data source from an object that does not implement an IList itself.

IList IListSource.GetList();

Return Value

The IList

Implements

IListSource.GetList

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Undo Method

Entry point for the undo cascade to undo changes within the managed dataset.

public bool Undo();

Return Value

True if undo was successfull

Remarks

Cancels current edits and reject changes.

Example

This is the sample code from the mainform, which gets executed whenever an undo action occurs either by pressing the Undo button from the toolbar, or the corresponding menu item or implicitely by changing the context when pending changes exist and the user says no.

            private void vdxDataActionManager_VdxDataActionItemUndo_vdxActionInvoked(object sender, System.EventArgs e)
            {
                if(this.vdxDataActionManager.VdxDataStatusManager != null)
                {
                    this.vdxDataActionManager.VdxDataStatusManager.Undo();
                }
            }

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace | vdxDataActionManager

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.UndoCore Method

Invokes the undo method on all vdxTableManagers.

protected void UndoCore();

Remarks

All existing tablemanagers within the datamanipulation scenario will cancel their current edits.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Update Method

Delegates the DataSet changes to the Updater.

protected void Update();

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager Events

The events of the vdxDataStatusManager class are listed below. For a complete list of vdxDataStatusManager class members, see the vdxDataStatusManager Members topic.

Public Instance Events

Added | Defines the public event, which is triggered after an add operation has been performed.
Adding | Defines the public event, which is triggered before an add operation occurs.
AllowAddChanged | Occurs when the AllowAdd property changes.
AllowAutoEditChanged | Occurs when the AllowAutoEdit property changes.
AllowCopyChanged | Occurs when the AllowCopy property changes.
AllowDeleteChanged | Occurs when the AllowDelete property changes.
AllowEditChanged | Occurs when the AllowEdit property changes.
AllowPreviewChanged | Occurs when the AllowPreview property changes.
AllowSaveChanged | Occurs when the AllowSave property changes.
AutoEdited | Defines the public event, which is triggered after the autoedit operation has been performed.
AutoEditing | Defines the public event, which is triggered before the autoedit operation occurs.
Copied | Defines the public event, which is triggered after a copy operation has been performed.
Copying | Defines the public event, which is triggered before a copy operation occurs.
DataStatusChanged | Defines the public event, which is triggered after the data status changed.
DataValidating | Defines the public event, which is triggered before the save operation occurs.
Deleted | Defines the public event, which is triggered after a delete operation has been performed.
Deleting | Defines the public event, which is triggered before a delete operation occurs.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
Edited | Defines the public event, which is triggered after an edit operation has been performed.
Editing | Defines the public event, which is triggered before an edit operation occurs.
Filled | Defines the public event, which is triggered after the DataSet was filled.
Filling | Defines the public event, which is triggered before the DataSet is being filled.
OnDataTypeSet | Occurs after the DataSet type was set.
PossibleOperationsChanged | Defines the public event, which is triggered whenever the allowed property changes.
Previewed | Defines the public event, which is triggered after the preview operation has been performed.
Previewing | Defines the public event, which is triggered before the preview operation occurs.
ReadBindingsCompleted | Defines the public event, which is triggered after the VdxReadBindings has been performed.
Saved | Defines the public event, which is triggered after a save operation has been performed.
Saving | Defines the public event, which is triggered before a save operation occurs.
SelectedTableChanged | Defines the public event, which is triggered after the selected table changed.
Undoing | Defines the public event, which is triggered before the undo operation occurs.
Undone | Defines the public event, which is triggered after the undo operation has been performed.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Added Event

Defines the public event, which is triggered after an add operation has been performed.

public event EventHandler Added;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Adding Event

Defines the public event, which is triggered before an add operation occurs.

public event CancelEventHandler Adding;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.AllowAddChanged Event

Occurs when the AllowAdd property changes.

public event EventHandler AllowAddChanged;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.AllowAutoEditChanged Event

Occurs when the AllowAutoEdit property changes.

public event EventHandler AllowAutoEditChanged;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.AllowCopyChanged Event

Occurs when the AllowCopy property changes.

public event EventHandler AllowCopyChanged;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.AllowDeleteChanged Event

Occurs when the AllowDelete property changes.

public event EventHandler AllowDeleteChanged;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.AllowEditChanged Event

Occurs when the AllowEdit property changes.

public event EventHandler AllowEditChanged;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.AllowPreviewChanged Event

Occurs when the AllowPreview property changes.

public event EventHandler AllowPreviewChanged;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.AllowSaveChanged Event

Occurs when the AllowSave property changes.

public event EventHandler AllowSaveChanged;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.AutoEdited Event

Defines the public event, which is triggered after the autoedit operation has been performed.

public event EventHandler AutoEdited;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.AutoEditing Event

Defines the public event, which is triggered before the autoedit operation occurs.

public event CancelEventHandler AutoEditing;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Copied Event

Defines the public event, which is triggered after a copy operation has been performed.

public event EventHandler Copied;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Copying Event

Defines the public event, which is triggered before a copy operation occurs.

public event CancelEventHandler Copying;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.DataStatusChanged Event

Defines the public event, which is triggered after the data status changed.

public event vdxDataStatusChangedEventHandler DataStatusChanged;

Event Data

The event handler receives an argument of type vdxDataStatusChangedEventArgs containing data related to this event. The following vdxDataStatusChangedEventArgs properties provide information specific to this event.

Property | Description
NewState | Gets or sets the new datastatus.
OldState | Gets the old datastatus.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.DataValidating Event

Defines the public event, which is triggered before the save operation occurs.

public event CancelEventHandler DataValidating;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Deleted Event

Defines the public event, which is triggered after a delete operation has been performed.

public event EventHandler Deleted;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Deleting Event

Defines the public event, which is triggered before a delete operation occurs.

public event CancelEventHandler Deleting;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Edited Event

Defines the public event, which is triggered after an edit operation has been performed.

public event EventHandler Edited;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Editing Event

Defines the public event, which is triggered before an edit operation occurs.

public event CancelEventHandler Editing;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Filled Event

Defines the public event, which is triggered after the DataSet was filled.

public event EventHandler Filled;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Filling Event

Defines the public event, which is triggered before the DataSet is being filled.

public event CancelEventHandler Filling;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.OnDataTypeSet Event

Occurs after the DataSet type was set.

public event EventHandler OnDataTypeSet;

Implements

IvdxDataSetProvider.OnDataTypeSet

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.PossibleOperationsChanged Event

Defines the public event, which is triggered whenever the allowed property changes.

public event vdxPossibleOperationsChangedEventHandler PossibleOperationsChanged;

Event Data

The event handler receives an argument of type vdxPossibleOperationsChangedEventArgs containing data related to this event. The following vdxPossibleOperationsChangedEventArgs property provides information specific to this event.

Property | Description
PossibleOperations | Gets the allowed operations.

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Previewed Event

Defines the public event, which is triggered after the preview operation has been performed.

public event EventHandler Previewed;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Previewing Event

Defines the public event, which is triggered before the preview operation occurs.

public event CancelEventHandler Previewing;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.ReadBindingsCompleted Event

Defines the public event, which is triggered after the VdxReadBindings has been performed.

public event EventHandler ReadBindingsCompleted;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Saved Event

Defines the public event, which is triggered after a save operation has been performed.

public event EventHandler Saved;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Saving Event

Defines the public event, which is triggered before a save operation occurs.

public event CancelEventHandler Saving;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.SelectedTableChanged Event

Defines the public event, which is triggered after the selected table changed.

public event EventHandler SelectedTableChanged;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Undoing Event

Defines the public event, which is triggered before the undo operation occurs.

public event CancelEventHandler Undoing;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.Undone Event

Defines the public event, which is triggered after the undo operation has been performed.

public event EventHandler Undone;

See Also

vdxDataStatusManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusManager.MergeUpdateDelegate Delegate

Declare a delegate type for merge DataSet changes.

public delegate void vdxDataStatusManager.MergeUpdateDelegate(
DataSet original,
DataSet changes
);

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer Class

Defines the base class for navigation typed panels.

For a list of all members of this type, see vdxExplorer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxCacheableControl
vdxDataControl
vdxExplorer

public class vdxExplorer : vdxDataControl, IvdxDataLoader, IvdxDataActionManagerConsumer

Remarks

This component supports a search dialog, multi-Navigators and detail part. All the components can be combined with each other. But not all combination make sense. Define a IvdxSearchControl for the search routine which returns vdxSearchParameters. All navigators communicate their selection changes automatically over the explorer.

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxExplorer Members | Deag.Vdx.Controls.Core Namespace | vdxExplorerGrid | vdxExplorerTree

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer Members

vdxExplorer overview

Public Instance Constructors

vdxExplorer Constructor Initializes a new instance of the vdxExplorer class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataActionManager | Gets and sets the current vdxDataActionManager from the vdxDataMultiContainer.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataStatusManager | Gets the current vdxDataStatusManager from the vdxDataMultiContainer.
DisplayMode | Gets or sets the current display mode.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MultiContainer | Gets or sets the container, which can holds typed IvdxMultiContainerCacheable controls.
Name (inherited from Control) | Gets or sets the name of the control.
NavigatorDataSet | Gets the loaded DataSet for all navigators.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SearchControl | Gets the created instance of the SearchControlType.
SearchControlType | Gets or sets the name of the typed SearchControl, which will be instantiated later.
SearchParameters | Gets or sets the search parameters for this explorer.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

AddInitial | Adds a new entry on DataStatusManager for the corresponding dataDetailType.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetLoaderInfo | Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformDataLoad | Delegates the components to load the corresponding data for the given search parameters.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

dataSet | Holds the actual dataSet, which is delegated to all navigators.
multiContainer | Holds the detail container for this explorer.
selectedNavigatorInfo | The actual selected vdxNavigatorInfo in the navigators.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
NavigatorCollection | Gets the NavigatorCollection, which holds IvdxNavigator components.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActionItemFind_ActionInvoked | Implementation of the ActionItemFind event listeners.
ActionItemRefresh_ActionInvoked | Implementation of the ActionItemRefresh event listeners.
ActionItemRefreshAll_ActionInvoked | Implementation of the ActionItemRefreshAll event listeners.
Activate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
AdjustFormScrollbars (inherited from ContainerControl) |
AllowFind | Gets whether to enable the find button.
Create | The method is called once in the lifetime of the cacheable component after this was instantiated.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateNavigatorRow | Creates a new row on the loaded DataSet with the given content of the the vdxDataManipulatorEventArgs.ManipulatorData.
Deactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DeactivateAllowed (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
EnableActions | Enables refresh and find actions on DataActionManager .
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HandleChanges | Activate the element with unsaved changes.
HasChanges | Indicates if a component or one of its subcomponents has pending changes.
InitializeNavigatorCollection | Add all controls that implement IvdxNavigator to the NavigatorCollection.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsRefreshable | Checks if the component supports refresh.
LayoutAll | Method to refresh explorer content depending on DisplayMode.
LoadData | Delegates the components to load the corresponding data for the given search parameters.
Manipulator_RowCopied | Listens to the manipulator copied event of a data detail.
Manipulator_RowDeleted | Listens to the manipulator delete event of a data detail.
Manipulator_RowInserted | Listens to the manipulator insert event of a data detail.
Manipulator_RowUpdated | Listens to the manipulator update event of a data detail.
Manipulator_Undone | Listens to the manipulator undo event of a data detail.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Navigator_ControlChanged | Listens to vdxNavigatorSelectionEventHandler to detect selection changes.
Navigator_SelectionChanged | Listens to vdxNavigatorSelectionEventHandler to detect selection changes.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
Reactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshData | Loads again the data.
RefreshSelectedDataLoader | Reloads the current selected data detail.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
SearchControl_SearchParamsFilled | Inform all navigators about the new loaded DataSet to construct their navigation elements.
Select (inherited from ContainerControl) | Overloaded.
SelectDefault | Selects the default element.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShowDetail |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateNavigatorRow | Update navigator DataRow with the given vdxDataManipulatorEventArgs.ManipulatorData.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxChangeable.HandleChanges (inherited from vdxDataControl)
IvdxChangeable.HasChanges (inherited from vdxDataControl)
IvdxDataLoader.ClearSearchParameters
IvdxDataLoader.IsRefreshable
IvdxDataLoader.PerformDataLoad
IvdxDataLoader.RefreshData
IvdxMultiContainerCacheable.Activate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Create (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Deactivate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.DeactivateAllowed (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Reactivate (inherited from vdxCacheableControl)

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace | vdxExplorerGrid | vdxExplorerTree

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer Constructor

Initializes a new instance of the vdxExplorer class.

public vdxExplorer();

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer Fields

The fields of the vdxExplorer class are listed below. For a complete list of vdxExplorer class members, see the vdxExplorer Members topic.

Protected Instance Fields

dataSet | Holds the actual dataSet, which is delegated to all navigators.
multiContainer | Holds the detail container for this explorer.
selectedNavigatorInfo | The actual selected vdxNavigatorInfo in the navigators.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace | vdxExplorerGrid | vdxExplorerTree

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.dataSet Field

Holds the actual dataSet, which is delegated to all navigators.

protected DataSet dataSet;

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.MultiContainer Property

Gets or sets the container, which can holds typed IvdxMultiContainerCacheable controls.

public vdxMultiContainer MultiContainer {get; set;}

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.selectedNavigatorInfo Field

The actual selected vdxNavigatorInfo in the navigators.

protected vdxNavigatorInfo selectedNavigatorInfo;

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer Properties

The properties of the vdxExplorer class are listed below. For a complete list of vdxExplorer class members, see the vdxExplorer Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataActionManager | Gets and sets the current vdxDataActionManager from the vdxDataMultiContainer.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataStatusManager | Gets the current vdxDataStatusManager from the vdxDataMultiContainer.
DisplayMode | Gets or sets the current display mode.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MultiContainer | Gets or sets the container, which can holds typed IvdxMultiContainerCacheable controls.
Name (inherited from Control) | Gets or sets the name of the control.
NavigatorDataSet | Gets the loaded DataSet for all navigators.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SearchControl | Gets the created instance of the SearchControlType.
SearchControlType | Gets or sets the name of the typed SearchControl, which will be instantiated later.
SearchParameters | Gets or sets the search parameters for this explorer.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
NavigatorCollection | Gets the NavigatorCollection, which holds IvdxNavigator components.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace | vdxExplorerGrid | vdxExplorerTree

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.DataActionManager Property

Gets and sets the current vdxDataActionManager from the vdxDataMultiContainer.

public vdxDataActionManager DataActionManager {get; set;}

Implements

IvdxDataActionManagerConsumer.DataActionManager

Remarks

It only will be returned a vdxDataActionManager if the MultiContainer is an instance of vdxDataMultiContainer.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.DataStatusManager Property

Gets the current vdxDataStatusManager from the vdxDataMultiContainer.

public override vdxDataStatusManager DataStatusManager {get;}

Implements

IvdxDsmProvider.DataStatusManager

Remarks

It only will be returned a DataStatusManager if the MultiContainer is an instance of vdxDataMultiContainer.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.DisplayMode Property

Gets or sets the current display mode.

public virtual Deag.Vdx.Common.Enums.vdxExplorerMode DisplayMode {get; set;}

Remarks

If DisplayMode is set to vdxExplorerMode.Selection, only the SearchControl will be displayed in the Explorer.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.NavigatorCollection Property

Gets the NavigatorCollection, which holds IvdxNavigator components.

protected vdxExplorer.vdxNavigatorCollection NavigatorCollection {get;}

Remarks

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace | vdxExplorer.vdxNavigatorCollection

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.NavigatorDataSet Property

Gets the loaded DataSet for all navigators.

public System.Data.DataSet NavigatorDataSet {get;}

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.SearchControl Property

Gets the created instance of the SearchControlType.

public IvdxSearchControl SearchControl {get;}

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.SearchControlType Property

Gets or sets the name of the typed SearchControl, which will be instantiated later.

public string SearchControlType {get; set;}

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.SearchParameters Property

Gets or sets the search parameters for this explorer.

public Deag.Vdx.Common.vdxSearchParameters SearchParameters {get;}

Implements

IvdxDataLoader.SearchParameters

Remarks

The vdxSearchParameters is the base element to fill up all navigators with the corresponding dataSet.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer Methods

The methods of the vdxExplorer class are listed below. For a complete list of vdxExplorer class members, see the vdxExplorer Members topic.

Public Instance Methods

AddInitial | Adds a new entry on DataStatusManager for the corresponding dataDetailType.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetLoaderInfo | Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformDataLoad | Delegates the components to load the corresponding data for the given search parameters.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActionItemFind_ActionInvoked | Implementation of the ActionItemFind event listeners.
ActionItemRefresh_ActionInvoked | Implementation of the ActionItemRefresh event listeners.
ActionItemRefreshAll_ActionInvoked | Implementation of the ActionItemRefreshAll event listeners.
Activate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
AdjustFormScrollbars (inherited from ContainerControl) |
AllowFind | Gets whether to enable the find button.
Create | The method is called once in the lifetime of the cacheable component after this was instantiated.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateNavigatorRow | Creates a new row on the loaded DataSet with the given content of the the vdxDataManipulatorEventArgs.ManipulatorData.
Deactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DeactivateAllowed (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
EnableActions | Enables refresh and find actions on DataActionManager .
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HandleChanges | Activate the element with unsaved changes.
HasChanges | Indicates if a component or one of its subcomponents has pending changes.
InitializeNavigatorCollection | Add all controls that implement IvdxNavigator to the NavigatorCollection.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsRefreshable | Checks if the component supports refresh.
LayoutAll | Method to refresh explorer content depending on DisplayMode.
LoadData | Delegates the components to load the corresponding data for the given search parameters.
Manipulator_RowCopied | Listens to the manipulator copied event of a data detail.
Manipulator_RowDeleted | Listens to the manipulator delete event of a data detail.
Manipulator_RowInserted | Listens to the manipulator insert event of a data detail.
Manipulator_RowUpdated | Listens to the manipulator update event of a data detail.
Manipulator_Undone | Listens to the manipulator undo event of a data detail.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Navigator_ControlChanged | Listens to vdxNavigatorSelectionEventHandler to detect selection changes.
Navigator_SelectionChanged | Listens to vdxNavigatorSelectionEventHandler to detect selection changes.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
Reactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshData | Loads again the data.
RefreshSelectedDataLoader | Reloads the current selected data detail.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
SearchControl_SearchParamsFilled | Inform all navigators about the new loaded DataSet to construct their navigation elements.
Select (inherited from ContainerControl) | Overloaded.
SelectDefault | Selects the default element.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShowDetail |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateNavigatorRow | Update navigator DataRow with the given vdxDataManipulatorEventArgs.ManipulatorData.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxChangeable.HandleChanges (inherited from vdxDataControl)
IvdxChangeable.HasChanges (inherited from vdxDataControl)
IvdxDataLoader.ClearSearchParameters
IvdxDataLoader.IsRefreshable
IvdxDataLoader.PerformDataLoad
IvdxDataLoader.RefreshData
IvdxMultiContainerCacheable.Activate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Create (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Deactivate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.DeactivateAllowed (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Reactivate (inherited from vdxCacheableControl)

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace | vdxExplorerGrid | vdxExplorerTree

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.ActionItemFind_ActionInvoked Method

Implementation of the ActionItemFind event listeners.

protected virtual void ActionItemFind_ActionInvoked(
object source,
EventArgs eventArgs
);

Parameters

source
not used
eventArgs
not used

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.ActionItemRefresh_ActionInvoked Method

Implementation of the ActionItemRefresh event listeners.

protected virtual void ActionItemRefresh_ActionInvoked(
object source,
EventArgs eventArgs
);

Parameters

source
not used
eventArgs
not used

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.ActionItemRefreshAll_ActionInvoked Method

Implementation of the ActionItemRefreshAll event listeners.

protected virtual void ActionItemRefreshAll_ActionInvoked(
object source,
EventArgs eventArgs
);

Parameters

source
not used
eventArgs
not used

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.AddInitial Method

Adds a new entry on DataStatusManager for the corresponding dataDetailType.

public virtual void AddInitial(
Type dataDetailType
);

Parameters

dataDetailType
The control which holds the DataStatusManager to create new entry

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.AllowFind Method

Gets whether to enable the find button.

protected virtual bool AllowFind();

Remarks

Checks if there is a searchControl set.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.Create Method

The method is called once in the lifetime of the cacheable component after this was instantiated.

protected override void Create();

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.CreateNavigatorRow Method

Creates a new row on the loaded DataSet with the given content of the the vdxDataManipulatorEventArgs.ManipulatorData.

protected virtual DataRow CreateNavigatorRow(
ManipulatorData manipulatorData
);

Parameters

manipulatorData
The data to import from.

Return Value

An instance of the imported navigator row.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace | IvdxDataManipulator | vdxDataDetail | vdxDataManipulatorEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.IvdxDataLoader.ClearSearchParameters Method

void IvdxDataLoader.ClearSearchParameters();

Implements

IvdxDataLoader.ClearSearchParameters

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.IvdxDataLoader.IsRefreshable Method

bool IvdxDataLoader.IsRefreshable();

Implements

IvdxDataLoader.IsRefreshable

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.IvdxDataLoader.PerformDataLoad Method

void IvdxDataLoader.PerformDataLoad(
vdxSearchParameters searchParameters
);

Implements

IvdxDataLoader.PerformDataLoad

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.IvdxDataLoader.RefreshData Method

void IvdxDataLoader.RefreshData();

Implements

IvdxDataLoader.RefreshData

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.EnableActions Method

Enables refresh and find actions on DataActionManager .

protected virtual void EnableActions();

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.GetLoaderInfo Method

Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.

public virtual vdxLoaderInfo GetLoaderInfo(
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorInfo
Contains the DataRow to define the vdxLoaderInfo.

Return Value

The vdxLoaderInfo for the given navigatorInfo.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.HandleChanges Method

Activate the element with unsaved changes.

protected override bool HandleChanges();

Return Value

True if there are still changes after handling them.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.HasChanges Method

Indicates if a component or one of its subcomponents has pending changes.

protected override bool HasChanges();

Return Value

True if there are changes.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.InitializeNavigatorCollection Method

Add all controls that implement IvdxNavigator to the NavigatorCollection.

protected void InitializeNavigatorCollection();

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.IsRefreshable Method

Checks if the component supports refresh.

protected virtual bool IsRefreshable();

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.LayoutAll Method

Method to refresh explorer content depending on DisplayMode.

protected virtual void LayoutAll();

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.LoadData Method

Delegates the components to load the corresponding data for the given search parameters.

protected virtual DataSet LoadData();

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.Manipulator_RowCopied Method

Listens to the manipulator copied event of a data detail.

protected virtual void Manipulator_RowCopied(
object source,
vdxDataManipulatorEventArgs eventArgs
);

Parameters

source
The invoker of the insert event.
eventArgs
Contains the inserted DataRow.

Remarks

This method is called, when the vdxDataStatusManager of a dataDetail has added a new DataRow.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.Manipulator_RowDeleted Method

Listens to the manipulator delete event of a data detail.

protected virtual void Manipulator_RowDeleted(
object source,
vdxDataManipulatorEventArgs eventArgs
);

Parameters

source
The invoker of the delete event.
eventArgs
Contains no DataRow.

Remarks

This method is called, when the vdxDataStatusManager of a dataDetail has deleted a DataRow.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.Manipulator_RowInserted Method

Listens to the manipulator insert event of a data detail.

protected virtual void Manipulator_RowInserted(
object source,
vdxDataManipulatorEventArgs eventArgs
);

Parameters

source
The invoker of the insert event.
eventArgs
Contains the inserted DataRow.

Remarks

This method is called, when the vdxDataStatusManager of a dataDetail has added a new DataRow.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.Manipulator_RowUpdated Method

Listens to the manipulator update event of a data detail.

protected virtual void Manipulator_RowUpdated(
object source,
vdxDataManipulatorEventArgs eventArgs
);

Parameters

source
The invoker of the update event.
eventArgs
Contains the updated DataRow.

Remarks

This method is called, when the vdxDataStatusManager of a dataDetail has updated a DataRow.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.Manipulator_Undone Method

Listens to the manipulator undo event of a data detail.

protected virtual void Manipulator_Undone(
object source,
vdxDataManipulatorEventArgs eventArgs
);

Parameters

source
The invoker of the undo event.
eventArgs
Contains no DataRow.

Remarks

This method is called, when the vdxDataStatusManager of a dataDetail has undone his changes.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.Navigator_ControlChanged Method

Listens to vdxNavigatorSelectionEventHandler to detect selection changes.

protected virtual void Navigator_ControlChanged(
object source,
vdxNavigatorControlEventArgs eventArgs
);

Parameters

source
The navigator which has invoked the event.
eventArgs
Contains the corresponding vdxSearchParameters and the DataDetailType.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.Navigator_SelectionChanged Method

Listens to vdxNavigatorSelectionEventHandler to detect selection changes.

protected virtual void Navigator_SelectionChanged(
object source,
vdxNavigatorSelectionEventArgs eventArgs
);

Parameters

source
The navigator which has invoked the event.
eventArgs
Contains the corresponding vdxSearchParameters and the DataDetailType.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.PerformDataLoad Method

Delegates the components to load the corresponding data for the given search parameters.

public virtual void PerformDataLoad(
vdxSearchParameters searchParameters
);

Parameters

searchParameters
The specific search arguments.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.RefreshData Method

Loads again the data.

protected virtual void RefreshData();

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.RefreshSelectedDataLoader Method

Reloads the current selected data detail.

protected virtual void RefreshSelectedDataLoader();

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.SearchControl_SearchParamsFilled Method

Inform all navigators about the new loaded DataSet to construct their navigation elements.

protected virtual void SearchControl_SearchParamsFilled(
object source,
vdxSearchParametersFilledEventArgs eventArgs
);

Parameters

source
The SearchControl which was filled with parameters.
eventArgs
Contains the specified vdxSearchParameters

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.SelectDefault Method

Selects the default element.

protected virtual void SelectDefault();

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.ShowDetail Method

protected void ShowDetail(
Type detailType
);

Parameters

detailType

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.UpdateNavigatorRow Method

Update navigator DataRow with the given vdxDataManipulatorEventArgs.ManipulatorData.

protected virtual void UpdateNavigatorRow(
ref DataRow navigatorRow,
ManipulatorData manipulatorData
);

Parameters

navigatorRow
DataRow to update.
manipulatorData
Object that contains the given data.

See Also

vdxExplorer Class | Deag.Vdx.Controls.Core Namespace | IvdxDataManipulator | vdxDataDetail | vdxDataManipulatorEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.vdxNavigatorCollection Class

Helper class for vdxExplorer to manage all navigators on it.

For a list of all members of this type, see vdxExplorer.vdxNavigatorCollection Members.

System.Object
CollectionBase
vdxExplorer.vdxNavigatorCollection

protected class vdxExplorer.vdxNavigatorCollection : CollectionBase

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxExplorer.vdxNavigatorCollection Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.vdxNavigatorCollection Members

vdxExplorer.vdxNavigatorCollection overview

Public Instance Constructors

vdxExplorer.vdxNavigatorCollection Constructor Initializes a new instance of the vdxNavigatorCollection class.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Gets the navigator at the position with the given index.

Public Instance Methods

Add | Adds a navigator to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Removes the given navigator from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

vdxExplorer.vdxNavigatorCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.vdxNavigatorCollection Constructor

Initializes a new instance of the vdxNavigatorCollection class.

public vdxExplorer.vdxNavigatorCollection();

See Also

vdxExplorer.vdxNavigatorCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.vdxNavigatorCollection Properties

The properties of the vdxExplorer.vdxNavigatorCollection class are listed below. For a complete list of vdxExplorer.vdxNavigatorCollection class members, see the vdxExplorer.vdxNavigatorCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Gets the navigator at the position with the given index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

vdxExplorer.vdxNavigatorCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.vdxNavigatorCollection.Item Property

Gets the navigator at the position with the given index.

public IvdxNavigator this[
int index
] {get;}

See Also

vdxExplorer.vdxNavigatorCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.vdxNavigatorCollection Methods

The methods of the vdxExplorer.vdxNavigatorCollection class are listed below. For a complete list of vdxExplorer.vdxNavigatorCollection class members, see the vdxExplorer.vdxNavigatorCollection Members topic.

Public Instance Methods

Add | Adds a navigator to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Removes the given navigator from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

vdxExplorer.vdxNavigatorCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.vdxNavigatorCollection.Add Method

Adds a navigator to the collection.

public void Add(
IvdxNavigator navigator
);

Parameters

navigator
The navigator which will be manage through this collection.

See Also

vdxExplorer.vdxNavigatorCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorer.vdxNavigatorCollection.Remove Method

Removes the given navigator from the collection.

public void Remove(
IvdxNavigator navigator
);

Parameters

navigator
The navigastor which will be removed from the collection.

See Also

vdxExplorer.vdxNavigatorCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxFrameLine Class

A horizontal line with caption.

For a list of all members of this type, see vdxFrameLine Members.

System.Object
MarshalByRefObject
Component
Control
vdxFrameLine

public class vdxFrameLine : Control, IvdxBindable

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxFrameLine Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxFrameLine Members

vdxFrameLine overview

Public Instance Constructors

vdxFrameLine Constructor Initializes a new instance of the vdxFrameLine class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LineOffsetFromText | Gets or sets the distance between of the Text right end and the left side of the line.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Gets or sets the text displayed on the left side of the line.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width | Gets or sets width of the line.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Control) | Gets the default size of the control.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
Size | Gets or sets the height and width of the frameline.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint | Overrides the OnPaint to paint the text with a line.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxFrameLine Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxFrameLine Constructor

Initializes a new instance of the vdxFrameLine class.

public vdxFrameLine();

See Also

vdxFrameLine Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxFrameLine Properties

The properties of the vdxFrameLine class are listed below. For a complete list of vdxFrameLine class members, see the vdxFrameLine Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LineOffsetFromText | Gets or sets the distance between of the Text right end and the left side of the line.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Gets or sets the text displayed on the left side of the line.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width | Gets or sets width of the line.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Control) | Gets the default size of the control.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
Size | Gets or sets the height and width of the frameline.

See Also

vdxFrameLine Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxFrameLine.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxFrameLine Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxFrameLine.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxFrameLine Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxFrameLine.LineOffsetFromText Property

Gets or sets the distance between of the Text right end and the left side of the line.

public int LineOffsetFromText {get; set;}

See Also

vdxFrameLine Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxFrameLine.Size Property

Gets or sets the height and width of the frameline.

new protected System.Drawing.Size Size {get; set;}

See Also

vdxFrameLine Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxFrameLine.Text Property

Gets or sets the text displayed on the left side of the line.

public override string Text {get; set;}

See Also

vdxFrameLine Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxFrameLine.Width Property

Gets or sets width of the line.

new public int Width {get; set;}

See Also

vdxFrameLine Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxFrameLine Methods

The methods of the vdxFrameLine class are listed below. For a complete list of vdxFrameLine class members, see the vdxFrameLine Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint | Overrides the OnPaint to paint the text with a line.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxFrameLine Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxFrameLine.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxFrameLine Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxFrameLine.OnPaint Method

Overrides the OnPaint to paint the text with a line.

protected override void OnPaint(
PaintEventArgs pe
);

Parameters

pe
A PaintEventArgs the contains the event data.

See Also

vdxFrameLine Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxFrameLine.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxFrameLine Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLoaderInfo Class

Communication media between IvdxNavigator and vdxExplorer.

For a list of all members of this type, see vdxLoaderInfo Members.

System.Object
vdxLoaderInfo

public class vdxLoaderInfo

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxLoaderInfo Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLoaderInfo Members

vdxLoaderInfo overview

Public Instance Constructors

vdxLoaderInfo Constructor Creates a navigator info for the given searchParameters and detailType.

Public Instance Properties

DetailType | Gets the involved Type of the IvdxMultiContainerCacheable element.
SearchParameters | Gets the involved vdxSearchParameters.

Public Instance Methods

Equals | Checks if this object is equal to given obj and checks if their DataRow are equals.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxLoaderInfo Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLoaderInfo Constructor

Creates a navigator info for the given searchParameters and detailType.

public vdxLoaderInfo(
vdxSearchParameters searchParameters,
Type detailType
);

Parameters

searchParameters
detailType

See Also

vdxLoaderInfo Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLoaderInfo Properties

The properties of the vdxLoaderInfo class are listed below. For a complete list of vdxLoaderInfo class members, see the vdxLoaderInfo Members topic.

Public Instance Properties

DetailType | Gets the involved Type of the IvdxMultiContainerCacheable element.
SearchParameters | Gets the involved vdxSearchParameters.

See Also

vdxLoaderInfo Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLoaderInfo.DetailType Property

Gets the involved Type of the IvdxMultiContainerCacheable element.

public System.Type DetailType {get;}

See Also

vdxLoaderInfo Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLoaderInfo.SearchParameters Property

Gets the involved vdxSearchParameters.

public Deag.Vdx.Common.vdxSearchParameters SearchParameters {get;}

See Also

vdxLoaderInfo Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLoaderInfo Methods

The methods of the vdxLoaderInfo class are listed below. For a complete list of vdxLoaderInfo class members, see the vdxLoaderInfo Members topic.

Public Instance Methods

Equals | Checks if this object is equal to given obj and checks if their DataRow are equals.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxLoaderInfo Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLoaderInfo.Equals Method

Checks if this object is equal to given obj and checks if their DataRow are equals.

public override bool Equals(
object obj
);

Parameters

obj
The object to compare with.

Return Value

True if the

this
is equal to
obj
or if their DataRow are equal, otherwise false.

See Also

vdxLoaderInfo Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxLoaderInfo.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

public override int GetHashCode();

Return Value

A hash code for the current vdxNavigatorInfoItemRow.

See Also

vdxLoaderInfo Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer Class

Manages one instance per IvdxMultiContainerCacheable element type.

For a list of all members of this type, see vdxMultiContainer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxMultiContainer

public class vdxMultiContainer : UserControl, IvdxChangeable

Remarks

Only one element can be shown in the container. Activate an element with the Show method. If the element doesn't exist, one instance is created, otherwise the element is reactivated.

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxMultiContainer Members | Deag.Vdx.Controls.Core Namespace | vdxExplorer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer Members

vdxMultiContainer overview

Public Instance Constructors

vdxMultiContainer Constructor Initializes a new instance of the vdxMultiContainer class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Current | Gets the current active control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetElement | Get the element for the given element type, if it is cached, otherwise null.
GetElements | Get all elements cached by this multiContainer.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HideCurrentElement | Hides the currently shown IvdxMultiContainerCacheable element.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Remove | Removes the corresponding element type from the container and disposes the control.
RemoveAll | Removes all elements from the container and dispose each one.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show | Overloaded. Displays the element of the given IvdxMultiContainerCacheable type.
Show (inherited from Control) | Overloaded. Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
ElementActivated | Occurs after an element is activated.
ElementCreated | Occurs after an element is created.
ElementDeactivated | Occurs after an element is deactivated.
ElementDeactivating | Occurs before an element is deactivated.
ElementReactivated | Occurs after an element is reactivated.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HandleChanges | Activate the element with unsaved changes.
HasChanges | Indicates if a component or one of its subcomponents has pending changes.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnElementActivated | Inform all registered components about ElementActivated event.
OnElementCreated | Inform all registered components about ElementCreated event.
OnElementDeactivated | Inform all registered components about ElementDeactivated event.
OnElementDeactivating | Inform all registered components about ElementDeactivating event.
OnElementReactivated | Inform all registered components about ElementReactivated event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxChangeable.HandleChanges
IvdxChangeable.HasChanges

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace | vdxExplorer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer Constructor

Initializes a new instance of the vdxMultiContainer class.

public vdxMultiContainer();

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer Properties

The properties of the vdxMultiContainer class are listed below. For a complete list of vdxMultiContainer class members, see the vdxMultiContainer Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Current | Gets the current active control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace | vdxExplorer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.Current Property

Gets the current active control.

public IvdxMultiContainerCacheable Current {get;}

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer Methods

The methods of the vdxMultiContainer class are listed below. For a complete list of vdxMultiContainer class members, see the vdxMultiContainer Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetElement | Get the element for the given element type, if it is cached, otherwise null.
GetElements | Get all elements cached by this multiContainer.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HideCurrentElement | Hides the currently shown IvdxMultiContainerCacheable element.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Remove | Removes the corresponding element type from the container and disposes the control.
RemoveAll | Removes all elements from the container and dispose each one.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show | Overloaded. Displays the element of the given IvdxMultiContainerCacheable type.
Show (inherited from Control) | Overloaded. Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HandleChanges | Activate the element with unsaved changes.
HasChanges | Indicates if a component or one of its subcomponents has pending changes.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnElementActivated | Inform all registered components about ElementActivated event.
OnElementCreated | Inform all registered components about ElementCreated event.
OnElementDeactivated | Inform all registered components about ElementDeactivated event.
OnElementDeactivating | Inform all registered components about ElementDeactivating event.
OnElementReactivated | Inform all registered components about ElementReactivated event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxChangeable.HandleChanges
IvdxChangeable.HasChanges

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace | vdxExplorer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.IvdxChangeable.HandleChanges Method

bool IvdxChangeable.HandleChanges();

Implements

IvdxChangeable.HandleChanges

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.IvdxChangeable.HasChanges Method

bool IvdxChangeable.HasChanges();

Implements

IvdxChangeable.HasChanges

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Dispose Method

VDX Framework

vdxMultiContainer.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.Dispose Method (Boolean)

Clean up any resources being used.

protected override void Dispose(
bool disposing
);

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace | vdxMultiContainer.Dispose Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.GetElement Method

Get the element for the given element type, if it is cached, otherwise null.

public IvdxMultiContainerCacheable GetElement(
Type elementType
);

Parameters

elementType
Wich type to get the instance.

Return Value

If type was found, returns an instance from cache.

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.GetElements Method

Get all elements cached by this multiContainer.

public ICollection GetElements();

Return Value

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.HandleChanges Method

Activate the element with unsaved changes.

protected virtual bool HandleChanges();

Return Value

True if there are changes.

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.HasChanges Method

Indicates if a component or one of its subcomponents has pending changes.

protected virtual bool HasChanges();

Return Value

True if there are changes.

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.HideCurrentElement Method

Hides the currently shown IvdxMultiContainerCacheable element.

public void HideCurrentElement();

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.OnElementActivated Method

Inform all registered components about ElementActivated event.

protected virtual void OnElementActivated();

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.OnElementCreated Method

Inform all registered components about ElementCreated event.

protected virtual void OnElementCreated();

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.OnElementDeactivated Method

Inform all registered components about ElementDeactivated event.

protected virtual void OnElementDeactivated();

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.OnElementDeactivating Method

Inform all registered components about ElementDeactivating event.

protected virtual void OnElementDeactivating();

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.OnElementReactivated Method

Inform all registered components about ElementReactivated event.

protected virtual void OnElementReactivated();

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.Remove Method

Removes the corresponding element type from the container and disposes the control.

public void Remove(
Type elementType
);

Parameters

elementType
Wich element type to remove.

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.RemoveAll Method

Removes all elements from the container and dispose each one.

public void RemoveAll();

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Show Method

VDX Framework

vdxMultiContainer.Show Method

Displays the element of the given IvdxMultiContainerCacheable type.

Overload List

Inherited from Control.

public void Show();

Displays the element of the given IvdxMultiContainerCacheable type.

public void Show(Type);

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace | ElementCreated | ElementActivated | ElementDeactivating | ElementDeactivated | ElementReactivated

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.Show Method (Type)

Displays the element of the given IvdxMultiContainerCacheable type.

public void Show(
Type elementType
);

Parameters

elementType
The specified IvdxMultiContainerCacheable element type, which will be shown in the container.

Remarks

Each elementType is only instanciated once, than it will only be reactivated. Every time this method is called the element is activated again. The currently active element is automatically deactivated, before the given element is activated.

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace | vdxMultiContainer.Show Overload List | ElementCreated | ElementActivated | ElementDeactivating | ElementDeactivated | ElementReactivated

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer Events

The events of the vdxMultiContainer class are listed below. For a complete list of vdxMultiContainer class members, see the vdxMultiContainer Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
ElementActivated | Occurs after an element is activated.
ElementCreated | Occurs after an element is created.
ElementDeactivated | Occurs after an element is deactivated.
ElementDeactivating | Occurs before an element is deactivated.
ElementReactivated | Occurs after an element is reactivated.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace | vdxExplorer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.ElementActivated Event

Occurs after an element is activated.

public event vdxCacheableElementEventHandler ElementActivated;

Event Data

The event handler receives an argument of type vdxCacheableElementEventArgs containing data related to this event. The following vdxCacheableElementEventArgs property provides information specific to this event.

Property | Description
CacheableControl | Gets the involved cacheable control.

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.ElementCreated Event

Occurs after an element is created.

public event vdxCacheableElementEventHandler ElementCreated;

Event Data

The event handler receives an argument of type vdxCacheableElementEventArgs containing data related to this event. The following vdxCacheableElementEventArgs property provides information specific to this event.

Property | Description
CacheableControl | Gets the involved cacheable control.

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.ElementDeactivated Event

Occurs after an element is deactivated.

public event vdxCacheableElementEventHandler ElementDeactivated;

Event Data

The event handler receives an argument of type vdxCacheableElementEventArgs containing data related to this event. The following vdxCacheableElementEventArgs property provides information specific to this event.

Property | Description
CacheableControl | Gets the involved cacheable control.

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.ElementDeactivating Event

Occurs before an element is deactivated.

public event vdxCacheableElementEventHandler ElementDeactivating;

Event Data

The event handler receives an argument of type vdxCacheableElementEventArgs containing data related to this event. The following vdxCacheableElementEventArgs property provides information specific to this event.

Property | Description
CacheableControl | Gets the involved cacheable control.

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxMultiContainer.ElementReactivated Event

Occurs after an element is reactivated.

public event vdxCacheableElementEventHandler ElementReactivated;

Event Data

The event handler receives an argument of type vdxCacheableElementEventArgs containing data related to this event. The following vdxCacheableElementEventArgs property provides information specific to this event.

Property | Description
CacheableControl | Gets the involved cacheable control.

See Also

vdxMultiContainer Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfo Class

Communication media between IvdxNavigator and vdxExplorer.

For a list of all members of this type, see vdxNavigatorInfo Members.

System.Object
vdxNavigatorInfo

public class vdxNavigatorInfo

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxNavigatorInfo Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfo Members

vdxNavigatorInfo overview

Public Static Properties

Empty Gets an uniquely empty vdxNavigatorInfo with empty vdxNavigatorInfoItem.

Public Instance Constructors

vdxNavigatorInfo Overloaded. Initializes a new instance of the vdxNavigatorInfo class.

Public Instance Properties

NavInfoItemList | Gets the involved element list for this navigation info.
SelectedNavInfoItem | Gets the involved selected element.
SelectedRow | Gets the DataRow of the SelectedNavInfoItem if it is a vdxNavigatorInfoItemRow.
TopNavInfoItem | Gets the involved top element for the given selected element.

Public Instance Methods

Equals | Checks if this object is equal to given obj and checks if their DataRow are equals.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxNavigatorInfo Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfo Constructor

Creates a navigator info for the given vdxNavigatorInfoItem list.

Overload List

Creates a navigator info for the given vdxNavigatorInfoItem.

public vdxNavigatorInfo(vdxNavigatorInfoItem);

Creates a navigator info for the given selected and top vdxNavigatorInfoItem.

public vdxNavigatorInfo(vdxNavigatorInfoItem,vdxNavigatorInfoItem);

Creates a navigator info for the given vdxNavigatorInfoItem list.

public vdxNavigatorInfo(IList,vdxNavigatorInfoItem);

See Also

vdxNavigatorInfo Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfo Constructor (IList, vdxNavigatorInfoItem)

Creates a navigator info for the given vdxNavigatorInfoItem list.

public vdxNavigatorInfo(
IList navInfoItemList,
vdxNavigatorInfoItem topNavInfoItem
);

Parameters

navInfoItemList
The elements which were transported between IvdxNavigator and vdxExplorer.
topNavInfoItem
The first element in the hierarchy on the navigator for the selected element.

Remarks

The first value

navInfoItemList[0]
in the list must correspond to the top navigation info. The last value
navInfoItemList[navInfoItemList.Count-1]
in the list must correspond to the selected navigation info.

See Also

vdxNavigatorInfo Class | Deag.Vdx.Controls.Core Namespace | vdxNavigatorInfo Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfo Constructor (vdxNavigatorInfoItem, vdxNavigatorInfoItem)

Creates a navigator info for the given selected and top vdxNavigatorInfoItem.

public vdxNavigatorInfo(
vdxNavigatorInfoItem selectedNavInfoItem,
vdxNavigatorInfoItem topNavInfoItem
);

Parameters

selectedNavInfoItem
The selected element on the navigator.
topNavInfoItem
The first element in the hierarchy on the navigator for the selected element.

See Also

vdxNavigatorInfo Class | Deag.Vdx.Controls.Core Namespace | vdxNavigatorInfo Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfo Constructor (vdxNavigatorInfoItem)

Creates a navigator info for the given vdxNavigatorInfoItem.

public vdxNavigatorInfo(
vdxNavigatorInfoItem navInfoItem
);

Parameters

navInfoItem
The element which is transported between IvdxNavigator and vdxExplorer.

See Also

vdxNavigatorInfo Class | Deag.Vdx.Controls.Core Namespace | vdxNavigatorInfo Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfo Properties

The properties of the vdxNavigatorInfo class are listed below. For a complete list of vdxNavigatorInfo class members, see the vdxNavigatorInfo Members topic.

Public Static Properties

Empty Gets an uniquely empty vdxNavigatorInfo with empty vdxNavigatorInfoItem.

Public Instance Properties

NavInfoItemList | Gets the involved element list for this navigation info.
SelectedNavInfoItem | Gets the involved selected element.
SelectedRow | Gets the DataRow of the SelectedNavInfoItem if it is a vdxNavigatorInfoItemRow.
TopNavInfoItem | Gets the involved top element for the given selected element.

See Also

vdxNavigatorInfo Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfo.Empty Property

Gets an uniquely empty vdxNavigatorInfo with empty vdxNavigatorInfoItem.

public static vdxNavigatorInfo Empty {get;}

See Also

vdxNavigatorInfo Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfo.NavInfoItemList Property

Gets the involved element list for this navigation info.

public System.Collections.IList NavInfoItemList {get;}

See Also

vdxNavigatorInfo Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfo.SelectedNavInfoItem Property

Gets the involved selected element.

public vdxNavigatorInfoItem SelectedNavInfoItem {get;}

See Also

vdxNavigatorInfo Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfo.SelectedRow Property

Gets the DataRow of the SelectedNavInfoItem if it is a vdxNavigatorInfoItemRow.

public System.Data.DataRow SelectedRow {get;}

See Also

vdxNavigatorInfo Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfo.TopNavInfoItem Property

Gets the involved top element for the given selected element.

public vdxNavigatorInfoItem TopNavInfoItem {get;}

See Also

vdxNavigatorInfo Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfo Methods

The methods of the vdxNavigatorInfo class are listed below. For a complete list of vdxNavigatorInfo class members, see the vdxNavigatorInfo Members topic.

Public Instance Methods

Equals | Checks if this object is equal to given obj and checks if their DataRow are equals.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxNavigatorInfo Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfo.Equals Method

Checks if this object is equal to given obj and checks if their DataRow are equals.

public override bool Equals(
object obj
);

Parameters

obj
The object to compare with.

Return Value

True if the

this
is equal to
obj
or if their DataRow are equal, otherwise false.

See Also

vdxNavigatorInfo Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfo.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

public override int GetHashCode();

Return Value

A hash code for the current vdxNavigatorInfoItemRow.

See Also

vdxNavigatorInfo Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfoItem Class

Specify the element which is encapsulated in a vdxNavigatorInfo.

For a list of all members of this type, see vdxNavigatorInfoItem Members.

System.Object
vdxNavigatorInfoItem

public class vdxNavigatorInfoItem

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxNavigatorInfoItem Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfoItem Members

vdxNavigatorInfoItem overview

Public Static Properties

Empty Gets an uniquely vdxNavigatorInfoItem.

Public Instance Constructors

vdxNavigatorInfoItem Constructor Initializes a new instance of the vdxNavigatorInfoItem class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsInserted | Check if this element was inserted.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxNavigatorInfoItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfoItem Constructor

Initializes a new instance of the vdxNavigatorInfoItem class.

public vdxNavigatorInfoItem();

See Also

vdxNavigatorInfoItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfoItem Properties

The properties of the vdxNavigatorInfoItem class are listed below. For a complete list of vdxNavigatorInfoItem class members, see the vdxNavigatorInfoItem Members topic.

Public Static Properties

Empty Gets an uniquely vdxNavigatorInfoItem.

See Also

vdxNavigatorInfoItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfoItem.Empty Property

Gets an uniquely vdxNavigatorInfoItem.

public static vdxNavigatorInfoItem Empty {get;}

See Also

vdxNavigatorInfoItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfoItem Methods

The methods of the vdxNavigatorInfoItem class are listed below. For a complete list of vdxNavigatorInfoItem class members, see the vdxNavigatorInfoItem Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsInserted | Check if this element was inserted.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxNavigatorInfoItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfoItem.IsInserted Method

Check if this element was inserted.

public virtual bool IsInserted();

Return Value

True if the element was created, otherwise already exists in the data source.

See Also

vdxNavigatorInfoItem Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfoItemRow Class

Specify the DataRow which is encapsulated in a vdxNavigatorInfoItem.

For a list of all members of this type, see vdxNavigatorInfoItemRow Members.

System.Object
vdxNavigatorInfoItem
vdxNavigatorInfoItemRow

public class vdxNavigatorInfoItemRow : vdxNavigatorInfoItem

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxNavigatorInfoItemRow Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfoItemRow Members

vdxNavigatorInfoItemRow overview

Public Instance Constructors

vdxNavigatorInfoItemRow Overloaded. Initializes a new instance of the vdxNavigatorInfoItemRow class.

Public Instance Properties

DataRow Gets the involved DataRow.

Public Instance Methods

Equals | Checks if this object is equal to given obj and checks if their DataRow are equals.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsInserted | Check if this element was inserted.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxNavigatorInfoItemRow Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfoItemRow Constructor

Creates new instance of vdxNavigatorInfoItemRow for the given dataRow.

Overload List

Creates new instance of vdxNavigatorInfoItemRow for the given dataRow.

public vdxNavigatorInfoItemRow(DataRow);

Creates new instance of vdxNavigatorInfoItemRow for the given dataRow.

public vdxNavigatorInfoItemRow(DataRow,bool);

See Also

vdxNavigatorInfoItemRow Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfoItemRow Constructor (DataRow)

Creates new instance of vdxNavigatorInfoItemRow for the given dataRow.

public vdxNavigatorInfoItemRow(
DataRow dataRow
);

Parameters

dataRow
The involved DataRow.

See Also

vdxNavigatorInfoItemRow Class | Deag.Vdx.Controls.Core Namespace | vdxNavigatorInfoItemRow Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfoItemRow Constructor (DataRow, Boolean)

Creates new instance of vdxNavigatorInfoItemRow for the given dataRow.

public vdxNavigatorInfoItemRow(
DataRow dataRow,
bool isInserted
);

Parameters

dataRow
The involved DataRow.
isInserted
True if dataRow was newly inserted.

See Also

vdxNavigatorInfoItemRow Class | Deag.Vdx.Controls.Core Namespace | vdxNavigatorInfoItemRow Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfoItemRow Properties

The properties of the vdxNavigatorInfoItemRow class are listed below. For a complete list of vdxNavigatorInfoItemRow class members, see the vdxNavigatorInfoItemRow Members topic.

Public Instance Properties

DataRow Gets the involved DataRow.

See Also

vdxNavigatorInfoItemRow Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfoItemRow.DataRow Property

Gets the involved DataRow.

public System.Data.DataRow DataRow {get;}

See Also

vdxNavigatorInfoItemRow Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfoItemRow Methods

The methods of the vdxNavigatorInfoItemRow class are listed below. For a complete list of vdxNavigatorInfoItemRow class members, see the vdxNavigatorInfoItemRow Members topic.

Public Instance Methods

Equals | Checks if this object is equal to given obj and checks if their DataRow are equals.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsInserted | Check if this element was inserted.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxNavigatorInfoItemRow Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfoItemRow.Equals Method

Checks if this object is equal to given obj and checks if their DataRow are equals.

public override bool Equals(
object obj
);

Parameters

obj
The object to compare with.

Return Value

True if the

this
is equal to
obj
or if their DataRow are equal, otherwise false.

See Also

vdxNavigatorInfoItemRow Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfoItemRow.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

public override int GetHashCode();

Return Value

A hash code for the current vdxNavigatorInfoItemRow.

See Also

vdxNavigatorInfoItemRow Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorInfoItemRow.IsInserted Method

Check if this element was inserted.

public override bool IsInserted();

Return Value

True if the element was created, otherwise already exists in the data source.

See Also

vdxNavigatorInfoItemRow Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPossibleOperations Class

Represents an object with the currently possible data operations.

For a list of all members of this type, see vdxPossibleOperations Members.

System.Object
vdxPossibleOperations

public class vdxPossibleOperations

Remarks

Mainly used within the VDX data manipulation scenario by the vdxDataStatusManager and the vdxDataActionManager.

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxPossibleOperations Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPossibleOperations Members

vdxPossibleOperations overview

Public Instance Constructors

vdxPossibleOperations Constructor Initializes a new instance of the vdxPossibleOperations class.

Public Instance Properties

Add | Gets or sets a value indicating the add state.
Copy | Gets or sets a value indicating the copy state.
Delete | Gets or sets a value indicating the delete state.
Edit | Gets or sets a value indicating the edit state.
Find | Gets or sets a value indicating the find state.
Save | Gets or sets a value indicating the save state.
Undo | Gets or sets a value indicating the undo state.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxPossibleOperations Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPossibleOperations Constructor

Initializes a new instance of the vdxPossibleOperations class.

public vdxPossibleOperations();

See Also

vdxPossibleOperations Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPossibleOperations Properties

The properties of the vdxPossibleOperations class are listed below. For a complete list of vdxPossibleOperations class members, see the vdxPossibleOperations Members topic.

Public Instance Properties

Add | Gets or sets a value indicating the add state.
Copy | Gets or sets a value indicating the copy state.
Delete | Gets or sets a value indicating the delete state.
Edit | Gets or sets a value indicating the edit state.
Find | Gets or sets a value indicating the find state.
Save | Gets or sets a value indicating the save state.
Undo | Gets or sets a value indicating the undo state.

See Also

vdxPossibleOperations Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPossibleOperations.Add Property

Gets or sets a value indicating the add state.

public bool Add {get; set;}

See Also

vdxPossibleOperations Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPossibleOperations.Copy Property

Gets or sets a value indicating the copy state.

public bool Copy {get; set;}

See Also

vdxPossibleOperations Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPossibleOperations.Delete Property

Gets or sets a value indicating the delete state.

public bool Delete {get; set;}

See Also

vdxPossibleOperations Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPossibleOperations.Edit Property

Gets or sets a value indicating the edit state.

public bool Edit {get; set;}

See Also

vdxPossibleOperations Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPossibleOperations.Find Property

Gets or sets a value indicating the find state.

public bool Find {get; set;}

See Also

vdxPossibleOperations Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPossibleOperations.Save Property

Gets or sets a value indicating the save state.

public bool Save {get; set;}

See Also

vdxPossibleOperations Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPossibleOperations.Undo Property

Gets or sets a value indicating the undo state.

public bool Undo {get; set;}

See Also

vdxPossibleOperations Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection Class

Default implementation of IvdxSearchControl.

For a list of all members of this type, see vdxSelection Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxCacheableControl
vdxSelection

public class vdxSelection : vdxCacheableControl, IvdxSearchControl

Remarks

This user control provides search functionality. The button "Go" (Search) activate the filling of the vdxSearchParameters that will be communicated to all registered SearchParamsFilled listeners. The button "Clear" (Reset) initializes the state of all placed controls.

Example

This example shows how to implement a search mask. First we must derive from vdxSelection:

            public class SelectionPerson : vdxSelection
            {
                ...
            }
Place four vdxLabels, three vdxTextBoxs and a ComboBox onto the searchPanel in Designer Mode. Override FillSearchParameters to provide the generation of the user specified vdxSearchParameters.

            protected override vdxSearchParameters FillSearchParameters()
            {
                string orderBy = "LastName";
                if (this.cboOrderBy.Text == "Last Name") orderBy = "LastName";
                if (this.cboOrderBy.Text == "First Name") orderBy = "FirstName";
                if (this.cboOrderBy.Text == "Country") orderBy = "Country";

                vdxSearchParameters sp = new vdxSearchParameters("SelectionPersByDescr");

                sp.Add("FirstName", this.txtFirstName.Text, vdxSearchType.StartWith);
                sp.Add("LastName", this.txtLastName.Text, vdxSearchType.StartWith);
                sp.Add("Country", this.txtCountry.Text, vdxSearchType.StartWith);
                sp.Add("OrderBy", orderBy);

                return sp;
            }
Now we can use this class in the derive class from vdxExplorerTree or vdxExplorerGrid or vdxExplorer.

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxSelection Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection Members

vdxSelection overview

Public Instance Constructors

vdxSelection Constructor Initializes a new instance of the vdxSelection class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SearchParameters | The vdxSearchParameters which are used to do the search routine.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear | Clears the text in the contained controls
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SearchParamsFilled | Occurs when the btnGo was clicked.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

bottomPanel | Panel that holds the buttonPanel.
btnClear | Invoker to clear all control textes.
btnGo | Invoker for the search routine.
buttonPanel | Panel that holds the btnGo and btnClear.
searchPanel | Panel on that all controls must be placed in the derived class.

Protected Instance Properties

ControlResetter | Gets or sets the vdxControlResetter for the control.
CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
Activate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
AdjustFormScrollbars (inherited from ContainerControl) |
BtnClear_Click | Handles the Click event of the clear button.
BtnGo_Click | Handles the Click event of the go button.
Create (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
Deactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DeactivateAllowed (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
FillSearchParameters | Returns a vdxSearchParameters object.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSearchParamsFilled | Raises the VdxSearchParamsFilled event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged | Overrides OnVisibleChanged to set accept button of parent form.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
Reactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetAcceptButton | Sets accept button on the corresponding form.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxMultiContainerCacheable.Activate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Create (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Deactivate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.DeactivateAllowed (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Reactivate (inherited from vdxCacheableControl)
IvdxSearchControl.FillSearchParameters

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection Constructor

Initializes a new instance of the vdxSelection class.

public vdxSelection();

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection Fields

The fields of the vdxSelection class are listed below. For a complete list of vdxSelection class members, see the vdxSelection Members topic.

Protected Instance Fields

bottomPanel | Panel that holds the buttonPanel.
btnClear | Invoker to clear all control textes.
btnGo | Invoker for the search routine.
buttonPanel | Panel that holds the btnGo and btnClear.
searchPanel | Panel on that all controls must be placed in the derived class.

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection.bottomPanel Field

Panel that holds the buttonPanel.

protected Panel bottomPanel;

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection.btnClear Field

Invoker to clear all control textes.

protected Button btnClear;

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection.btnGo Field

Invoker for the search routine.

protected Button btnGo;

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection.buttonPanel Field

Panel that holds the btnGo and btnClear.

protected Panel buttonPanel;

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection.searchPanel Field

Panel on that all controls must be placed in the derived class.

protected Panel searchPanel;

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection Properties

The properties of the vdxSelection class are listed below. For a complete list of vdxSelection class members, see the vdxSelection Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SearchParameters | The vdxSearchParameters which are used to do the search routine.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

ControlResetter | Gets or sets the vdxControlResetter for the control.
CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection.ControlResetter Property

Gets or sets the vdxControlResetter for the control.

protected vdxControlResetter ControlResetter {get; set;}

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection.SearchParameters Property

The vdxSearchParameters which are used to do the search routine.

public Deag.Vdx.Common.vdxSearchParameters SearchParameters {get; set;}

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection Methods

The methods of the vdxSelection class are listed below. For a complete list of vdxSelection class members, see the vdxSelection Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear | Clears the text in the contained controls
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
Activate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
AdjustFormScrollbars (inherited from ContainerControl) |
BtnClear_Click | Handles the Click event of the clear button.
BtnGo_Click | Handles the Click event of the go button.
Create (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
Deactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DeactivateAllowed (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
FillSearchParameters | Returns a vdxSearchParameters object.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSearchParamsFilled | Raises the VdxSearchParamsFilled event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged | Overrides OnVisibleChanged to set accept button of parent form.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
Reactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetAcceptButton | Sets accept button on the corresponding form.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxMultiContainerCacheable.Activate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Create (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Deactivate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.DeactivateAllowed (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Reactivate (inherited from vdxCacheableControl)
IvdxSearchControl.FillSearchParameters

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection.BtnClear_Click Method

Handles the Click event of the clear button.

protected virtual void BtnClear_Click(
object sender,
EventArgs e
);

Parameters

sender
The sender.
e
The event parameters.

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection.BtnGo_Click Method

Handles the Click event of the go button.

protected virtual void BtnGo_Click(
object sender,
EventArgs e
);

Parameters

sender
The sender.
e
The event parameters.

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection.Clear Method

Clears the text in the contained controls

public void Clear();

Implements

IvdxSearchControl.Clear

Remarks

The controls must implement the IvdxResettable interface

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection.IvdxSearchControl.FillSearchParameters Method

vdxSearchParameters IvdxSearchControl.FillSearchParameters();

Implements

IvdxSearchControl.FillSearchParameters

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Dispose Method

VDX Framework

vdxSelection.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection.Dispose Method (Boolean)

Clean up any resources being used.

protected override void Dispose(
bool disposing
);

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace | vdxSelection.Dispose Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection.FillSearchParameters Method

Returns a vdxSearchParameters object.

protected virtual vdxSearchParameters FillSearchParameters();

Return Value

A vdxSearchParameters object.

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection.OnSearchParamsFilled Method

Raises the VdxSearchParamsFilled event.

protected virtual void OnSearchParamsFilled();

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection.OnVisibleChanged Method

Overrides OnVisibleChanged to set accept button of parent form.

protected override void OnVisibleChanged(
EventArgs e
);

Parameters

e

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection.SetAcceptButton Method

Sets accept button on the corresponding form.

protected virtual void SetAcceptButton(
bool activate
);

Parameters

activate

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection Events

The events of the vdxSelection class are listed below. For a complete list of vdxSelection class members, see the vdxSelection Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SearchParamsFilled | Occurs when the btnGo was clicked.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelection.SearchParamsFilled Event

Occurs when the btnGo was clicked.

public event vdxSearchParametersFilledEventHandler SearchParamsFilled;

Event Data

The event handler receives an argument of type vdxSearchParametersFilledEventArgs containing data related to this event. The following vdxSearchParametersFilledEventArgs property provides information specific to this event.

Property | Description
SearchParameters | Gets the vdxSearchParameters object.

Implements

IvdxSearchControl.SearchParamsFilled

See Also

vdxSelection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionName Class

This class represents a form where a custom selection which has been dragged and dropped on the outlook bar can be renamed.

For a list of all members of this type, see vdxSelectionName Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
vdxSelectionName

public class vdxSelectionName : Form

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxSelectionName Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionName Members

vdxSelectionName overview

Public Instance Constructors

vdxSelectionName Constructor Default constructor.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextBox | Gets or sets the TextBox containing the selection name.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

vdxSelectionName Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionName Constructor

Default constructor.

public vdxSelectionName();

See Also

vdxSelectionName Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionName Properties

The properties of the vdxSelectionName class are listed below. For a complete list of vdxSelectionName class members, see the vdxSelectionName Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextBox | Gets or sets the TextBox containing the selection name.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

vdxSelectionName Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionName.TextBox Property

Gets or sets the TextBox containing the selection name.

public System.Windows.Forms.TextBox TextBox {get; set;}

See Also

vdxSelectionName Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionName Methods

The methods of the vdxSelectionName class are listed below. For a complete list of vdxSelectionName class members, see the vdxSelectionName Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

vdxSelectionName Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Dispose Method

VDX Framework

vdxSelectionName.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

vdxSelectionName Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionName.Dispose Method (Boolean)

Clean up any resources being used.

protected override void Dispose(
bool disposing
);

See Also

vdxSelectionName Class | Deag.Vdx.Controls.Core Namespace | vdxSelectionName.Dispose Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager Class

Manages one DataTable within the vdxDataStatusManager.

For a list of all members of this type, see vdxTableManager Members.

System.Object
vdxTableManager

public class vdxTableManager : IvdxDsmHost

Remarks

The Dataset, which is used on the client is managed through a vdxDataStatusManager (short: DSM). The DSM is responsible for all the main data manipulation tasks. If a user changes a record, inserts a new one or deletes it, the DSM takes care of it. In a real application, you have a lot of different data manipulation scenarios, every one of them with its own DSM. The DSM itself has so called VDXTableManagers to manage all the tables within the Dataset which are involved in the current databinding. In fact, the table managers are responsible for all the operations on the tables. Every table participating in the databinding with the Dataset has his own VDXTableManager.

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxTableManager Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager Members

vdxTableManager overview

Public Instance Constructors

vdxTableManager Overloaded. Initializes a new instance of the vdxTableManager class.

Public Instance Properties

BindingPath | The binding path of the CurrencyManager.
CurrencyManager | The CurrencyManager associated with this table manager.
CurrentDataRow | Returns a reference to the CurrentDataRowView
CurrentDataRowView | Returns a reference to the CurrentDataRowView
DataStatusManager | The vdxDataStatusManager that this table manager belongs to.
DataView | The of the CurrencyManager associated with this table manager.
VdxDataTable | The DataTable managed by this table manager.

Public Instance Methods

Add | Adds a DataRow on this VdxDataTable
Copy | Overloaded. Copies a new DataRow on the managed DataTable.
Delete | Invokes the Delete method.
Edit | Invokes the Edit method.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Invokes the Save method.
ShowDebug | Use this Method if you are debugging the VdxDataTable assigned to this vdxTableManager
ToString | Returns a string representation of the managed table.
Undo | Rollbacks changes on the managed DataTable.

Public Instance Events

Added | Event fired after Adding a new row.
Adding | Event fired before Adding a new row.
Copied | Event fired after Copying a new row.
Copying | Event fired before Copying a new row.
DataManipulated | Event fired after row added, row copied, row deleted or row undone.
Deleted | Event fired after Deleting a new row.
Deleting | Event fired before Deleting a new row.
Edited | Event fired after Editing a row.
Editing | Event fired before Editiong a row.
Saved | Event fired after Saving a new row.
Saving | Event fired before Saving a new row.
Undoing | Event fired before Undoing a new row.
Undone | Event fired after Undoing a new row.

Protected Instance Methods

AddCore | Adds a new DataRow
CopyCore | Copies a row on the managed DataTable.
DeleteCore | Deletes the current row.
EditCore | Changes into edit state.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAdded | Raises the Added event.
OnAdding | Raises the Adding event.
OnCopied | Raises the Copied event.
OnCopying | Raises the Copying event.
OnDataManipulated | Raises the DataManipulated event.
OnDeleted | Raises the Deleted event.
OnDeleting | Raises the Deleting event.
OnEdited | Raises the Edited event.
OnEditing | Raises the Editing event.
OnSaved | Raises the Saved event.
OnSaving | Raises the Saving event.
OnUndoing | Raises the Undoing event.
OnUndone | Raises the Undone event.
SaveCore | Sets the CurrencyManager state to EndCurrentEdit.
UndoCore | Cancels the current (last) edit operation.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager Constructor

Constructor for use with CurrencyManager and BindingPath

Overload List

Constructor for use with CurrencyManager and BindingPath

public vdxTableManager(vdxDataStatusManager,CurrencyManager,string);

Constructor for use with CurrencyManager and BindingPath

public vdxTableManager(vdxDataStatusManager,CurrencyManager,string,DataTable);

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager Constructor (vdxDataStatusManager, CurrencyManager, String)

Constructor for use with CurrencyManager and BindingPath

public vdxTableManager(
vdxDataStatusManager owner,
CurrencyManager currencyManager,
string bindingPath
);

Parameters

owner
The DataStatusManager witch owns the created object.
currencyManager
The CurrencyManager object.
bindingPath
The name of the managed table.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace | vdxTableManager Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager Constructor (vdxDataStatusManager, CurrencyManager, String, DataTable)

Constructor for use with CurrencyManager and BindingPath

public vdxTableManager(
vdxDataStatusManager owner,
CurrencyManager currencyManager,
string bindingPath,
DataTable vdxDataTable
);

Parameters

owner
The DataStatusManager witch owns the created object.
currencyManager
The CurrencyManager object.
bindingPath
The name of the managed table.
vdxDataTable

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace | vdxTableManager Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager Properties

The properties of the vdxTableManager class are listed below. For a complete list of vdxTableManager class members, see the vdxTableManager Members topic.

Public Instance Properties

BindingPath | The binding path of the CurrencyManager.
CurrencyManager | The CurrencyManager associated with this table manager.
CurrentDataRow | Returns a reference to the CurrentDataRowView
CurrentDataRowView | Returns a reference to the CurrentDataRowView
DataStatusManager | The vdxDataStatusManager that this table manager belongs to.
DataView | The of the CurrencyManager associated with this table manager.
VdxDataTable | The DataTable managed by this table manager.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.BindingPath Property

The binding path of the CurrencyManager.

public string BindingPath {get;}

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.CurrencyManager Property

The CurrencyManager associated with this table manager.

public System.Windows.Forms.CurrencyManager CurrencyManager {get;}

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.CurrentDataRow Property

Returns a reference to the CurrentDataRowView

public System.Data.DataRow CurrentDataRow {get;}

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.CurrentDataRowView Property

Returns a reference to the CurrentDataRowView

public System.Data.DataRowView CurrentDataRowView {get;}

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.DataStatusManager Property

The vdxDataStatusManager that this table manager belongs to.

public vdxDataStatusManager DataStatusManager {get; set;}

Implements

IvdxDsmHost.DataStatusManager

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.DataView Property

The of the CurrencyManager associated with this table manager.

public System.Data.DataView DataView {get;}

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.VdxDataTable Property

The DataTable managed by this table manager.

public System.Data.DataTable VdxDataTable {get;}

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager Methods

The methods of the vdxTableManager class are listed below. For a complete list of vdxTableManager class members, see the vdxTableManager Members topic.

Public Instance Methods

Add | Adds a DataRow on this VdxDataTable
Copy | Overloaded. Copies a new DataRow on the managed DataTable.
Delete | Invokes the Delete method.
Edit | Invokes the Edit method.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Invokes the Save method.
ShowDebug | Use this Method if you are debugging the VdxDataTable assigned to this vdxTableManager
ToString | Returns a string representation of the managed table.
Undo | Rollbacks changes on the managed DataTable.

Protected Instance Methods

AddCore | Adds a new DataRow
CopyCore | Copies a row on the managed DataTable.
DeleteCore | Deletes the current row.
EditCore | Changes into edit state.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAdded | Raises the Added event.
OnAdding | Raises the Adding event.
OnCopied | Raises the Copied event.
OnCopying | Raises the Copying event.
OnDataManipulated | Raises the DataManipulated event.
OnDeleted | Raises the Deleted event.
OnDeleting | Raises the Deleting event.
OnEdited | Raises the Edited event.
OnEditing | Raises the Editing event.
OnSaved | Raises the Saved event.
OnSaving | Raises the Saving event.
OnUndoing | Raises the Undoing event.
OnUndone | Raises the Undone event.
SaveCore | Sets the CurrencyManager state to EndCurrentEdit.
UndoCore | Cancels the current (last) edit operation.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.Add Method

Adds a DataRow on this VdxDataTable

public bool Add();

Return Value

True if successful

Remarks

The new DataRow is detached from the DataTable an accessible trough VdxCurrentDataRowView / VdxCurrentDataRow.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.AddCore Method

Adds a new DataRow

protected virtual bool AddCore();

Return Value

True if Adding was successful.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Copy Method

VDX Framework

vdxTableManager.Copy Method

Copies a new DataRow on the managed DataTable.

Overload List

Copies a new DataRow on the managed DataTable.

public DataRow Copy();

Copies a new DataRow on the managed DataTable.

public DataRow Copy(bool);

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.Copy Method ()

Copies a new DataRow on the managed DataTable.

public DataRow Copy();

Return Value

True if copy was successful.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace | vdxTableManager.Copy Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.Copy Method (Boolean)

Copies a new DataRow on the managed DataTable.

public DataRow Copy(
bool removeSourceRow
);

Parameters

removeSourceRow
True, removes source row after copy.

Return Value

True if copy was successful.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace | vdxTableManager.Copy Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.CopyCore Method

Copies a row on the managed DataTable.

protected virtual DataRow CopyCore(
bool removeSourceRow
);

Return Value

True if Copying was succesful.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.Delete Method

Invokes the Delete method.

public bool Delete();

Return Value

True if successful.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.DeleteCore Method

Deletes the current row.

protected virtual bool DeleteCore();

Return Value

True if Delete was succesful.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.Edit Method

Invokes the Edit method.

public bool Edit();

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.EditCore Method

Changes into edit state.

protected void EditCore();

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.OnAdded Method

Raises the Added event.

protected virtual void OnAdded(
EventArgs e
);

Parameters

e
An System.EventArgs that contains the event data.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.OnAdding Method

Raises the Adding event.

protected virtual void OnAdding(
CancelEventArgs e
);

Parameters

e
An System.CancelEventArgs that contains the event data.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.OnCopied Method

Raises the Copied event.

protected virtual void OnCopied(
EventArgs e
);

Parameters

e
An System.EventArgs that contains the event data.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.OnCopying Method

Raises the Copying event.

protected virtual void OnCopying(
CancelEventArgs e
);

Parameters

e
An System.CancelEventArgs that contains the event data.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.OnDataManipulated Method

Raises the DataManipulated event.

protected virtual void OnDataManipulated(
EventArgs e
);

Parameters

e
An System.EventArgs that contains the event data.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.OnDeleted Method

Raises the Deleted event.

protected virtual void OnDeleted(
EventArgs e
);

Parameters

e
An System.EventArgs that contains the event data.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.OnDeleting Method

Raises the Deleting event.

protected virtual void OnDeleting(
CancelEventArgs e
);

Parameters

e
An System.CancelEventArgs that contains the event data.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.OnEdited Method

Raises the Edited event.

protected virtual void OnEdited(
EventArgs e
);

Parameters

e
System.EventArgs that contains the event data.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.OnEditing Method

Raises the Editing event.

protected virtual void OnEditing(
CancelEventArgs e
);

Parameters

e
System.ComponentModel.CancelEventArgs that contains the event data.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.OnSaved Method

Raises the Saved event.

protected virtual void OnSaved(
EventArgs e
);

Parameters

e
An System.EventArgs that contains the event data.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.OnSaving Method

Raises the Saving event.

protected virtual void OnSaving(
CancelEventArgs e
);

Parameters

e
An System.CancelEventArgs that contains the event data.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.OnUndoing Method

Raises the Undoing event.

protected virtual void OnUndoing(
CancelEventArgs e
);

Parameters

e
An System.CancelEventArgs that contains the event data.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.OnUndone Method

Raises the Undone event.

protected virtual void OnUndone(
EventArgs e
);

Parameters

e
An System.EventArgs that contains the event data.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.Save Method

Invokes the Save method.

public bool Save();

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.SaveCore Method

Sets the CurrencyManager state to EndCurrentEdit.

protected bool SaveCore();

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.ShowDebug Method

Use this Method if you are debugging the VdxDataTable assigned to this vdxTableManager

public void ShowDebug();

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.ToString Method

Returns a string representation of the managed table.

public override string ToString();

Return Value

A string representation of the managed table.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.Undo Method

Rollbacks changes on the managed DataTable.

public bool Undo();

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.UndoCore Method

Cancels the current (last) edit operation.

protected virtual bool UndoCore();

Return Value

True if undo was succesful.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager Events

The events of the vdxTableManager class are listed below. For a complete list of vdxTableManager class members, see the vdxTableManager Members topic.

Public Instance Events

Added | Event fired after Adding a new row.
Adding | Event fired before Adding a new row.
Copied | Event fired after Copying a new row.
Copying | Event fired before Copying a new row.
DataManipulated | Event fired after row added, row copied, row deleted or row undone.
Deleted | Event fired after Deleting a new row.
Deleting | Event fired before Deleting a new row.
Edited | Event fired after Editing a row.
Editing | Event fired before Editiong a row.
Saved | Event fired after Saving a new row.
Saving | Event fired before Saving a new row.
Undoing | Event fired before Undoing a new row.
Undone | Event fired after Undoing a new row.

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.Added Event

Event fired after Adding a new row.

public event EventHandler Added;

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.Adding Event

Event fired before Adding a new row.

public event CancelEventHandler Adding;

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.Copied Event

Event fired after Copying a new row.

public event EventHandler Copied;

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.Copying Event

Event fired before Copying a new row.

public event CancelEventHandler Copying;

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.DataManipulated Event

Event fired after row added, row copied, row deleted or row undone.

public event EventHandler DataManipulated;

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.Deleted Event

Event fired after Deleting a new row.

public event EventHandler Deleted;

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.Deleting Event

Event fired before Deleting a new row.

public event CancelEventHandler Deleting;

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.Edited Event

Event fired after Editing a row.

public event EventHandler Edited;

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.Editing Event

Event fired before Editiong a row.

public event CancelEventHandler Editing;

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.Saved Event

Event fired after Saving a new row.

public event EventHandler Saved;

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.Saving Event

Event fired before Saving a new row.

public event CancelEventHandler Saving;

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.Undoing Event

Event fired before Undoing a new row.

public event CancelEventHandler Undoing;

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManager.Undone Event

Event fired after Undoing a new row.

public event EventHandler Undone;

See Also

vdxTableManager Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManagerCollection Class

A collection if vdxTableManagers.

For a list of all members of this type, see vdxTableManagerCollection Members.

System.Object
vdxTableManagerCollection

public class vdxTableManagerCollection : IEnumerable

Requirements

Namespace: Deag.Vdx.Controls.Core

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxTableManagerCollection Members | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManagerCollection Members

vdxTableManagerCollection overview

Public Instance Constructors

vdxTableManagerCollection Constructor Initializes a new instance of the vdxTableManagerCollection class.

Public Instance Properties

Count | Gets the number of table managers in this collection.
Item | Overloaded. Returns the vdxTableManager at the given index.

Public Instance Methods

Add | Adds a vdxTableManager to the collection.
Clear | Removes all vdxTableManagers from the collection.
Contains | Check if collection contains the given binding path.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Gets the enumerator for this collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Removes a vdxTableManager from the collection for the given binding path.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxTableManagerCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManagerCollection Constructor

Initializes a new instance of the vdxTableManagerCollection class.

public vdxTableManagerCollection();

See Also

vdxTableManagerCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManagerCollection Properties

The properties of the vdxTableManagerCollection class are listed below. For a complete list of vdxTableManagerCollection class members, see the vdxTableManagerCollection Members topic.

Public Instance Properties

Count | Gets the number of table managers in this collection.
Item | Overloaded. Returns the vdxTableManager at the given index.

See Also

vdxTableManagerCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManagerCollection.Count Property

Gets the number of table managers in this collection.

public int Count {get;}

See Also

vdxTableManagerCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Item Property

VDX Framework

vdxTableManagerCollection.Item Property

Returns the vdxTableManager at the given index.

Overload List

Returns the vdxTableManager at the given index.

public vdxTableManager this[int] {get;}

Returns the vdxTableManager for the given binding path.

public vdxTableManager this[string] {get;}

See Also

vdxTableManagerCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManagerCollection.Item Property

Returns the vdxTableManager at the given index.

public vdxTableManager this[
int index
] {get;}

See Also

vdxTableManagerCollection Class | Deag.Vdx.Controls.Core Namespace | vdxTableManagerCollection.Item Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManagerCollection.Item Property

Returns the vdxTableManager for the given binding path.

public vdxTableManager this[
string bindingPath
] {get;}

See Also

vdxTableManagerCollection Class | Deag.Vdx.Controls.Core Namespace | vdxTableManagerCollection.Item Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManagerCollection Methods

The methods of the vdxTableManagerCollection class are listed below. For a complete list of vdxTableManagerCollection class members, see the vdxTableManagerCollection Members topic.

Public Instance Methods

Add | Adds a vdxTableManager to the collection.
Clear | Removes all vdxTableManagers from the collection.
Contains | Check if collection contains the given binding path.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Gets the enumerator for this collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Removes a vdxTableManager from the collection for the given binding path.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxTableManagerCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManagerCollection.Add Method

Adds a vdxTableManager to the collection.

public void Add(
string bindingPath,
vdxTableManager tm
);

Parameters

bindingPath
The corresponding binding path.
tm
The vdxTableManager to add to the collection.

See Also

vdxTableManagerCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManagerCollection.Clear Method

Removes all vdxTableManagers from the collection.

public void Clear();

See Also

vdxTableManagerCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManagerCollection.Contains Method

Check if collection contains the given binding path.

public bool Contains(
string bindingPath
);

Parameters

bindingPath
The binding path to search for.

Return Value

True if binding path is in collection.

See Also

vdxTableManagerCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManagerCollection.GetEnumerator Method

Gets the enumerator for this collection.

public IEnumerator GetEnumerator();

Return Value

The enumerator of this collection.

Implements

IEnumerable.GetEnumerator

See Also

vdxTableManagerCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxTableManagerCollection.Remove Method

Removes a vdxTableManager from the collection for the given binding path.

public void Remove(
string bindingPath
);

Parameters

bindingPath
The corresponding binding path.

See Also

vdxTableManagerCollection Class | Deag.Vdx.Controls.Core Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Controls.Core.Bindings

VDX Framework

Deag.Vdx.Controls.Core.Bindings Namespace

Classes

Class | Description
vdxBindingInfo | Represents the simple binding between the property value of an object and the property value of a control during Design Time. At Runtime it is converted to Binding.
vdxBindingInfoCollection | Manages an amount of vdxBindingInfos in a ArrayList.

Interfaces

Interface | Description
IvdxBindable | IvdxBindable is implemented by every control that is treated by the vdxBinding mecano.

Delegates

Delegate | Description
vdxBindingInfoChangedHandler | Delegate to inform registered listeners about binding information changes.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxBindable Interface

IvdxBindable is implemented by every control that is treated by the vdxBinding mecano.

For a list of all members of this type, see IvdxBindable Members.

public interface IvdxBindable

Requirements

Namespace: Deag.Vdx.Controls.Core.Bindings

Assembly: vdxControls (in vdxControls.dll)

See Also

IvdxBindable Members | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxBindable Members

IvdxBindable overview

Public Instance Properties

BindingInfos Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

Public Instance Methods

GetBindingInfo | Get the binding info for the Property specified
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed

See Also

IvdxBindable Interface | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxBindable Properties

The properties of the IvdxBindable interface are listed below. For a complete list of IvdxBindable interface members, see the IvdxBindable Members topic.

Public Instance Properties

BindingInfos Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

See Also

IvdxBindable Interface | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxBindable.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

System.Collections.IList BindingInfos {get;}

See Also

IvdxBindable Interface | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxBindable Methods

The methods of the IvdxBindable interface are listed below. For a complete list of IvdxBindable interface members, see the IvdxBindable Members topic.

Public Instance Methods

GetBindingInfo | Get the binding info for the Property specified
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed

See Also

IvdxBindable Interface | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxBindable.GetBindingInfo Method

Get the binding info for the Property specified

vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

See Also

IvdxBindable Interface | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IvdxBindable.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed

void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

See Also

IvdxBindable Interface | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfo Class

Represents the simple binding between the property value of an object and the property value of a control during Design Time. At Runtime it is converted to Binding.

For a list of all members of this type, see vdxBindingInfo Members.

System.Object
vdxBindingInfo

public class vdxBindingInfo

Requirements

Namespace: Deag.Vdx.Controls.Core.Bindings

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxBindingInfo Members | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfo Members

vdxBindingInfo overview

Public Instance Constructors

vdxBindingInfo Constructor Initializes a new instance of the vdxBindingInfo class with a specified property, provider and binding path.

Public Instance Properties

BindingPath | Gets the binding path to bind on the IvdxDataSetProvider.
DsProviderName | Gets the name of the IvdxDataSetProvider that holds the DataSet to bind on.
PropertyName | Gets or sets the property name to bind.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetBindingInformation | Sets the properties of this vdxBindingInfo with the given val.
ToString | Returns a String that represent the vdxBindingInfo.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxBindingInfo Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfo Constructor

Initializes a new instance of the vdxBindingInfo class with a specified property, provider and binding path.

public vdxBindingInfo(
string aPropertyName,
string adsProviderName,
string aBindingPath
);

Parameters

aPropertyName
The property to bind.
adsProviderName
The provider that holds the DataSet.
aBindingPath
The path to bind.

See Also

vdxBindingInfo Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfo Properties

The properties of the vdxBindingInfo class are listed below. For a complete list of vdxBindingInfo class members, see the vdxBindingInfo Members topic.

Public Instance Properties

BindingPath | Gets the binding path to bind on the IvdxDataSetProvider.
DsProviderName | Gets the name of the IvdxDataSetProvider that holds the DataSet to bind on.
PropertyName | Gets or sets the property name to bind.

See Also

vdxBindingInfo Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfo.BindingPath Property

Gets the binding path to bind on the IvdxDataSetProvider.

public string BindingPath {get;}

See Also

vdxBindingInfo Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfo.DsProviderName Property

Gets the name of the IvdxDataSetProvider that holds the DataSet to bind on.

public string DsProviderName {get;}

See Also

vdxBindingInfo Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfo.PropertyName Property

Gets or sets the property name to bind.

public string PropertyName {get; set;}

See Also

vdxBindingInfo Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfo Methods

The methods of the vdxBindingInfo class are listed below. For a complete list of vdxBindingInfo class members, see the vdxBindingInfo Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetBindingInformation | Sets the properties of this vdxBindingInfo with the given val.
ToString | Returns a String that represent the vdxBindingInfo.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxBindingInfo Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfo.SetBindingInformation Method

Sets the properties of this vdxBindingInfo with the given val.

public void SetBindingInformation(
vdxBindingInfo val
);

Parameters

val
The vdxBindingInfo to copy properties from.

See Also

vdxBindingInfo Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfo.ToString Method

Returns a String that represent the vdxBindingInfo.

public override string ToString();

Return Value

The formatted text that contains the name of IvdxDataSetProvider and the binding path.

See Also

vdxBindingInfo Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfoChangedHandler Delegate

Delegate to inform registered listeners about binding information changes.

public delegate void vdxBindingInfoChangedHandler(
vdxBindingInfoCollection sender,
vdxBindingInfo addedInfo
);

Requirements

Namespace: Deag.Vdx.Controls.Core.Bindings

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfoCollection Class

Manages an amount of vdxBindingInfos in a ArrayList.

For a list of all members of this type, see vdxBindingInfoCollection Members.

System.Object
ArrayList
vdxBindingInfoCollection

public class vdxBindingInfoCollection : ArrayList, IDisposable

Requirements

Namespace: Deag.Vdx.Controls.Core.Bindings

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxBindingInfoCollection Members | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfoCollection Members

vdxBindingInfoCollection overview

Public Instance Constructors

vdxBindingInfoCollection Constructor Initializes a new instance of the vdxBindingInfoCollection class.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item | Overloaded. Gets the vdxBindingInfo for the specified property name.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

Public Instance Methods

Add (inherited from ArrayList) | Overloaded. Adds an object to the end of the ArrayList.
Add | Overloaded. Adds the specified value to this list.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Dispose | Clears the managed list.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Remove (inherited from ArrayList) | Overloaded. Removes the first occurrence of a specific object from the ArrayList.
Remove | Overloaded. Removes the vdxBindingInfo with the specified property name from this list.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString | Returns a String that represent the vdxBindingInfoCollection.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

Public Instance Events

OnBindingInfoAdded | Occurs after a vdxBindingInfo was added to the list.
OnBindingInfoRemoved | Occurs after a vdxBindingInfo was remove from the list.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxBindingInfoCollection Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfoCollection Constructor

Initializes a new instance of the vdxBindingInfoCollection class.

public vdxBindingInfoCollection();

See Also

vdxBindingInfoCollection Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfoCollection Properties

The properties of the vdxBindingInfoCollection class are listed below. For a complete list of vdxBindingInfoCollection class members, see the vdxBindingInfoCollection Members topic.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item | Overloaded. Gets the vdxBindingInfo for the specified property name.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

See Also

vdxBindingInfoCollection Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfoCollection.Item Property

Gets the vdxBindingInfo for the specified property name.

public vdxBindingInfo this[
string propertyName
] {get;}

See Also

vdxBindingInfoCollection Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfoCollection Methods

The methods of the vdxBindingInfoCollection class are listed below. For a complete list of vdxBindingInfoCollection class members, see the vdxBindingInfoCollection Members topic.

Public Instance Methods

Add (inherited from ArrayList) | Overloaded. Adds an object to the end of the ArrayList.
Add | Overloaded. Adds the specified value to this list.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Dispose | Clears the managed list.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Remove (inherited from ArrayList) | Overloaded. Removes the first occurrence of a specific object from the ArrayList.
Remove | Overloaded. Removes the vdxBindingInfo with the specified property name from this list.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString | Returns a String that represent the vdxBindingInfoCollection.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxBindingInfoCollection Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Add Method

VDX Framework

vdxBindingInfoCollection.Add Method

Adds the specified value to this list.

Overload List

Adds the specified value to this list.

public int Add(vdxBindingInfo);

Inherited from ArrayList.

public virtual int Add(object);

See Also

vdxBindingInfoCollection Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfoCollection.Add Method (vdxBindingInfo)

Adds the specified value to this list.

public int Add(
vdxBindingInfo value
);

Parameters

value
The vdxBindingInfo to add.

Return Value

See Also

vdxBindingInfoCollection Class | Deag.Vdx.Controls.Core.Bindings Namespace | vdxBindingInfoCollection.Add Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfoCollection.Dispose Method

Clears the managed list.

public void Dispose();

Implements

IDisposable.Dispose

See Also

vdxBindingInfoCollection Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Remove Method

VDX Framework

vdxBindingInfoCollection.Remove Method

Removes the vdxBindingInfo with the specified property name from this list.

Overload List

Inherited from ArrayList.

public virtual void Remove(object);

Removes the vdxBindingInfo with the specified property name from this list.

public void Remove(string);

See Also

vdxBindingInfoCollection Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfoCollection.Remove Method (String)

Removes the vdxBindingInfo with the specified property name from this list.

public void Remove(
string propertyName
);

Parameters

propertyName
The vdxBindingInfo for the specified property name.

See Also

vdxBindingInfoCollection Class | Deag.Vdx.Controls.Core.Bindings Namespace | vdxBindingInfoCollection.Remove Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfoCollection.ToString Method

Returns a String that represent the vdxBindingInfoCollection.

public override string ToString();

Return Value

The formatted text of all vdxBindingInfos.

See Also

vdxBindingInfoCollection Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfoCollection Events

The events of the vdxBindingInfoCollection class are listed below. For a complete list of vdxBindingInfoCollection class members, see the vdxBindingInfoCollection Members topic.

Public Instance Events

OnBindingInfoAdded | Occurs after a vdxBindingInfo was added to the list.
OnBindingInfoRemoved | Occurs after a vdxBindingInfo was remove from the list.

See Also

vdxBindingInfoCollection Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfoCollection.OnBindingInfoAdded Event

Occurs after a vdxBindingInfo was added to the list.

public event vdxBindingInfoChangedHandler OnBindingInfoAdded;

See Also

vdxBindingInfoCollection Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxBindingInfoCollection.OnBindingInfoRemoved Event

Occurs after a vdxBindingInfo was remove from the list.

public event vdxBindingInfoChangedHandler OnBindingInfoRemoved;

See Also

vdxBindingInfoCollection Class | Deag.Vdx.Controls.Core.Bindings Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Controls.Core.Bindings.Design

VDX Framework

Deag.Vdx.Controls.Core.Bindings.Design Namespace

Classes

Class | Description
vdxAdvancedBindableAttribute | Attribut to set which property provides advanced bindings.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxAdvancedBindableAttribute Class

Attribut to set which property provides advanced bindings.

For a list of all members of this type, see vdxAdvancedBindableAttribute Members.

System.Object
Attribute
vdxAdvancedBindableAttribute

public class vdxAdvancedBindableAttribute : Attribute

Requirements

Namespace: Deag.Vdx.Controls.Core.Bindings.Design

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxAdvancedBindableAttribute Members | Deag.Vdx.Controls.Core.Bindings.Design Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxAdvancedBindableAttribute Members

vdxAdvancedBindableAttribute overview

Public Instance Constructors

vdxAdvancedBindableAttribute Constructor Initializes a new instance of the vdxAdvancedBindableAttribute class with the specified property names.

Public Instance Properties

TypeId (inherited from Attribute) When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) |
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsAdvancedBindable | Returns true if the specified property has advanced bindings.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, returns an indication whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value indicating whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxAdvancedBindableAttribute Class | Deag.Vdx.Controls.Core.Bindings.Design Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxAdvancedBindableAttribute Constructor

Initializes a new instance of the vdxAdvancedBindableAttribute class with the specified property names.

public vdxAdvancedBindableAttribute(
params string[] propertyNames
);

Parameters

propertyNames

See Also

vdxAdvancedBindableAttribute Class | Deag.Vdx.Controls.Core.Bindings.Design Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxAdvancedBindableAttribute Methods

The methods of the vdxAdvancedBindableAttribute class are listed below. For a complete list of vdxAdvancedBindableAttribute class members, see the vdxAdvancedBindableAttribute Members topic.

Public Instance Methods

Equals (inherited from Attribute) |
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsAdvancedBindable | Returns true if the specified property has advanced bindings.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, returns an indication whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value indicating whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxAdvancedBindableAttribute Class | Deag.Vdx.Controls.Core.Bindings.Design Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxAdvancedBindableAttribute.IsAdvancedBindable Method

Returns true if the specified property has advanced bindings.

public bool IsAdvancedBindable(
string pName
);

Parameters

pName

Return Value

See Also

vdxAdvancedBindableAttribute Class | Deag.Vdx.Controls.Core.Bindings.Design Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Controls.Core.Diagnostics

VDX Framework

Deag.Vdx.Controls.Core.Diagnostics Namespace

Classes

Class | Description
EventItem | Item represention a hooked event. IComparable is implemented to perform a user defined sort (Category, event name)
vdxEventHooker | This class is an event hooker. A control is attatched to the class and some events ot this control are selected to be hooked. During runtime all selected events are displayed in a log window.

Delegates

Delegate | Description
HookEventHandler | Delegate called when a hooked event occurred

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EventItem Class

Item represention a hooked event. IComparable is implemented to perform a user defined sort (Category, event name)

For a list of all members of this type, see EventItem Members.

System.Object
EventItem

public class EventItem : IComparable

Requirements

Namespace: Deag.Vdx.Controls.Core.Diagnostics

Assembly: vdxControls (in vdxControls.dll)

See Also

EventItem Members | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EventItem Members

EventItem overview

Public Instance Constructors

EventItem Overloaded. Initializes a new instance of the EventItem class.

Public Instance Properties

Category | Gets the category of the event
EventInfo | Gets the uderlying EventInfo
Text | Gets the textual representation ot the EventItem

Public Instance Methods

CompareTo | Sort order is category, then event name.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventItem Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EventItem Constructor

Standard constructor: Do not use

Overload List

Standard constructor: Do not use

public EventItem();

Construct as EventItem using the information reflected by EventInfo (represents an event not a category)

public EventItem(EventInfo,string);

Creates a EventItem with category set only (represents a category not an event)

public EventItem(string);

See Also

EventItem Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EventItem Constructor ()

Standard constructor: Do not use

public EventItem();

See Also

EventItem Class | Deag.Vdx.Controls.Core.Diagnostics Namespace | EventItem Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EventItem Constructor (EventInfo, String)

Construct as EventItem using the information reflected by EventInfo (represents an event not a category)

public EventItem(
EventInfo ei,
string Cat
);

See Also

EventItem Class | Deag.Vdx.Controls.Core.Diagnostics Namespace | EventItem Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EventItem Constructor (String)

Creates a EventItem with category set only (represents a category not an event)

public EventItem(
string Cat
);

Parameters

Cat

See Also

EventItem Class | Deag.Vdx.Controls.Core.Diagnostics Namespace | EventItem Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EventItem Properties

The properties of the EventItem class are listed below. For a complete list of EventItem class members, see the EventItem Members topic.

Public Instance Properties

Category | Gets the category of the event
EventInfo | Gets the uderlying EventInfo
Text | Gets the textual representation ot the EventItem

See Also

EventItem Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EventItem.Category Property

Gets the category of the event

public string Category {get;}

See Also

EventItem Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EventItem.EventInfo Property

Gets the uderlying EventInfo

public System.Reflection.EventInfo EventInfo {get;}

See Also

EventItem Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EventItem.Text Property

Gets the textual representation ot the EventItem

public string Text {get;}

See Also

EventItem Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EventItem Methods

The methods of the EventItem class are listed below. For a complete list of EventItem class members, see the EventItem Members topic.

Public Instance Methods

CompareTo | Sort order is category, then event name.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventItem Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EventItem.CompareTo Method

Sort order is category, then event name.

public int CompareTo(
object trg
);

Parameters

trg

Return Value

Implements

IComparable.CompareTo

See Also

EventItem Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EventItem.ToString Method

public override string ToString();

See Also

EventItem Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


HookEventHandler Delegate

Delegate called when a hooked event occurred

public delegate void HookEventHandler(
EventInfo ei,
object[] EventParams
);

Requirements

Namespace: Deag.Vdx.Controls.Core.Diagnostics

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxEventHooker Class

This class is an event hooker. A control is attatched to the class and some events ot this control are selected to be hooked. During runtime all selected events are displayed in a log window.

For a list of all members of this type, see vdxEventHooker Members.

System.Object
MarshalByRefObject
Component
vdxEventHooker

public class vdxEventHooker : Component

Requirements

Namespace: Deag.Vdx.Controls.Core.Diagnostics

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxEventHooker Members | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxEventHooker Members

vdxEventHooker overview

Public Static Methods

HookeEvent | This method is called by the dynamic event handlers and logs the events
LogEvent |

Public Instance Constructors

vdxEventHooker Constructor Initializes a new instance of the vdxEventHooker class.

Public Instance Properties

AttatchedControl |
AttEvents |
Container (inherited from Component) | Gets the IContainer that contains the Component.
IgnoreDublicates |
LogEvents |
Site (inherited from Component) | Gets or sets the ISite of the Component.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Component) |

Public Instance Events

Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
OnHookEvent |

Protected Instance Properties

DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

Protected Instance Methods

Dispose (inherited from Component) | Overloaded. Releases the unmanaged resources used by the Component and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxEventHooker Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxEventHooker Constructor

Initializes a new instance of the vdxEventHooker class.

public vdxEventHooker();

See Also

vdxEventHooker Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxEventHooker Properties

The properties of the vdxEventHooker class are listed below. For a complete list of vdxEventHooker class members, see the vdxEventHooker Members topic.

Public Instance Properties

AttatchedControl |
AttEvents |
Container (inherited from Component) | Gets the IContainer that contains the Component.
IgnoreDublicates |
LogEvents |
Site (inherited from Component) | Gets or sets the ISite of the Component.

Protected Instance Properties

DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

See Also

vdxEventHooker Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxEventHooker.AttatchedControl Property

public System.ComponentModel.Component AttatchedControl {get; set;}

See Also

vdxEventHooker Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxEventHooker.AttEvents Property

public string AttEvents {get; set;}

See Also

vdxEventHooker Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxEventHooker.IgnoreDublicates Property

public bool IgnoreDublicates {get; set;}

See Also

vdxEventHooker Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxEventHooker.LogEvents Property

public bool LogEvents {get; set;}

See Also

vdxEventHooker Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxEventHooker Methods

The methods of the vdxEventHooker class are listed below. For a complete list of vdxEventHooker class members, see the vdxEventHooker Members topic.

Public Static Methods

HookeEvent | This method is called by the dynamic event handlers and logs the events
LogEvent |

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Component) |

Protected Instance Methods

Dispose (inherited from Component) | Overloaded. Releases the unmanaged resources used by the Component and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxEventHooker Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxEventHooker.HookeEvent Method

This method is called by the dynamic event handlers and logs the events

public static void HookeEvent(
string EventName,
params object[] pItems
);

Parameters

EventName
pItems

See Also

vdxEventHooker Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxEventHooker.LogEvent Method

public static void LogEvent(
vdxEventHooker hooker,
string EventName,
object[] pItems
);

See Also

vdxEventHooker Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxEventHooker Events

The events of the vdxEventHooker class are listed below. For a complete list of vdxEventHooker class members, see the vdxEventHooker Members topic.

Public Instance Events

Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
OnHookEvent |

See Also

vdxEventHooker Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxEventHooker.OnHookEvent Event

public event HookEventHandler OnHookEvent;

See Also

vdxEventHooker Class | Deag.Vdx.Controls.Core.Diagnostics Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Controls.DataRepeater

VDX Framework

Deag.Vdx.Controls.DataRepeater Namespace

Classes

Class | Description
CurrentDataRowViewChangedEventArgs | The event argument for the CurrentDataRowViewChangedEventHandler.
EndingAddEventArgs | The event argument for the EndingAddEventHandler.
SortChangedEventArgs | The event argument for the SortChangedEventHandler.
vdxDataRepeaterContainer | Displays the data of the DataView as a table.
vdxDataRepeaterDetail | Represents the detail control for one DataRowView in the vdxDataRepeaterContainer.
vdxDataRepeaterDetailTypeConverter | Apply this class as a TypeConverterAttribute to list the available classes based upon your vdxDataDetail controls.
vdxDataRepeaterSort | Represents the header control in the vdxDataRepeaterContainer.
vdxDataRepeaterSortTypeConverter | Apply this class as a TypeConverterAttribute to list the available classes based upon your vdxDataDetail controls.
vdxSortButton | Represents the header control in the vdxDataRepeaterContainer.

Structures

Structure | Description
SortExpression | Component for a sort command.

Delegates

Delegate | Description
CurrentDataRowViewChangedEventHandler | Declares the delegate type that handles the Current DataRowView changes.
EndingAddEventHandler | Declares the delegate type that handles the ending add procedure.
SortChangedEventHandler | Declares the delegate type that handles the sort order changes.

Enumerations

Enumeration | Description
SortType | Available sort type on a SortExpression.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CurrentDataRowViewChangedEventArgs Class

The event argument for the CurrentDataRowViewChangedEventHandler.

For a list of all members of this type, see CurrentDataRowViewChangedEventArgs Members.

System.Object
EventArgs
CurrentDataRowViewChangedEventArgs

public class CurrentDataRowViewChangedEventArgs : EventArgs

Requirements

Namespace: Deag.Vdx.Controls.DataRepeater

Assembly: vdxControls (in vdxControls.dll)

See Also

CurrentDataRowViewChangedEventArgs Members | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CurrentDataRowViewChangedEventArgs Members

CurrentDataRowViewChangedEventArgs overview

Public Instance Constructors

CurrentDataRowViewChangedEventArgs Constructor Initializes a new instance of the CurrentDataRowViewChangedEventArgs class using the specified DataRowView.

Public Instance Properties

Current The involved DataRowView.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CurrentDataRowViewChangedEventArgs Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CurrentDataRowViewChangedEventArgs Constructor

Initializes a new instance of the CurrentDataRowViewChangedEventArgs class using the specified DataRowView.

public CurrentDataRowViewChangedEventArgs(
DataRowView current
);

Parameters

current

See Also

CurrentDataRowViewChangedEventArgs Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CurrentDataRowViewChangedEventArgs Properties

The properties of the CurrentDataRowViewChangedEventArgs class are listed below. For a complete list of CurrentDataRowViewChangedEventArgs class members, see the CurrentDataRowViewChangedEventArgs Members topic.

Public Instance Properties

Current The involved DataRowView.

See Also

CurrentDataRowViewChangedEventArgs Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CurrentDataRowViewChangedEventArgs.Current Property

The involved DataRowView.

public System.Data.DataRowView Current {get;}

See Also

CurrentDataRowViewChangedEventArgs Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CurrentDataRowViewChangedEventHandler Delegate

Declares the delegate type that handles the Current DataRowView changes.

public delegate void CurrentDataRowViewChangedEventHandler(
object sender,
CurrentDataRowViewChangedEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.DataRepeater

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EndingAddEventArgs Class

The event argument for the EndingAddEventHandler.

For a list of all members of this type, see EndingAddEventArgs Members.

System.Object
EventArgs
EndingAddEventArgs

public class EndingAddEventArgs : EventArgs

Requirements

Namespace: Deag.Vdx.Controls.DataRepeater

Assembly: vdxControls (in vdxControls.dll)

See Also

EndingAddEventArgs Members | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EndingAddEventArgs Members

EndingAddEventArgs overview

Public Instance Constructors

EndingAddEventArgs Constructor Initializes a new instance of the EndingAddEventArgs class using the specified DataRowView.

Public Instance Properties

Current The involved DataRowView.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EndingAddEventArgs Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EndingAddEventArgs Constructor

Initializes a new instance of the EndingAddEventArgs class using the specified DataRowView.

public EndingAddEventArgs(
DataRowView current
);

Parameters

current

See Also

EndingAddEventArgs Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EndingAddEventArgs Properties

The properties of the EndingAddEventArgs class are listed below. For a complete list of EndingAddEventArgs class members, see the EndingAddEventArgs Members topic.

Public Instance Properties

Current The involved DataRowView.

See Also

EndingAddEventArgs Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EndingAddEventArgs.Current Property

The involved DataRowView.

public System.Data.DataRowView Current {get;}

See Also

EndingAddEventArgs Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EndingAddEventHandler Delegate

Declares the delegate type that handles the ending add procedure.

public delegate void EndingAddEventHandler(
object sender,
EndingAddEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.DataRepeater

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SortChangedEventArgs Class

The event argument for the SortChangedEventHandler.

For a list of all members of this type, see SortChangedEventArgs Members.

System.Object
EventArgs
SortChangedEventArgs

public class SortChangedEventArgs : EventArgs

Requirements

Namespace: Deag.Vdx.Controls.DataRepeater

Assembly: vdxControls (in vdxControls.dll)

See Also

SortChangedEventArgs Members | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SortChangedEventArgs Members

SortChangedEventArgs overview

Public Instance Constructors

SortChangedEventArgs Constructor Initializes a new instance of the EndingAddEventArgs class using the specified sort string.

Public Instance Properties

Sort | Gets the sort order string format.
Sorts | Gets the sort order expressions.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SortChangedEventArgs Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SortChangedEventArgs Constructor

Initializes a new instance of the EndingAddEventArgs class using the specified sort string.

public SortChangedEventArgs(
string sort
);

Parameters

sort

See Also

SortChangedEventArgs Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SortChangedEventArgs Properties

The properties of the SortChangedEventArgs class are listed below. For a complete list of SortChangedEventArgs class members, see the SortChangedEventArgs Members topic.

Public Instance Properties

Sort | Gets the sort order string format.
Sorts | Gets the sort order expressions.

See Also

SortChangedEventArgs Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SortChangedEventArgs.Sort Property

Gets the sort order string format.

public string Sort {get;}

See Also

SortChangedEventArgs Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SortChangedEventArgs.Sorts Property

Gets the sort order expressions.

public SortExpression[] Sorts {get;}

See Also

SortChangedEventArgs Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SortChangedEventHandler Delegate

Declares the delegate type that handles the sort order changes.

public delegate void SortChangedEventHandler(
object sender,
SortChangedEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.DataRepeater

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SortExpression Structure

Component for a sort command.

For a list of all members of this type, see SortExpression Members.

System.Object
ValueType
SortExpression

public struct SortExpression

Requirements

Namespace: Deag.Vdx.Controls.DataRepeater

Assembly: vdxControls (in vdxControls.dll)

See Also

SortExpression Members | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SortExpression Members

SortExpression overview

Public Instance Fields

ColumnName | Gets or sets the column name to sort after.
SortType | Gets or sets the sort type to sort after.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SortExpression Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SortExpression Fields

The fields of the SortExpression structure are listed below. For a complete list of SortExpression structure members, see the SortExpression Members topic.

Public Instance Fields

ColumnName | Gets or sets the column name to sort after.
SortType | Gets or sets the sort type to sort after.

See Also

SortExpression Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SortExpression.ColumnName Field

Gets or sets the column name to sort after.

public string ColumnName;

See Also

SortExpression Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SortExpression.SortType Field

Gets or sets the sort type to sort after.

public SortType SortType;

See Also

SortExpression Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SortType Enumeration

Available sort type on a SortExpression.

public enum SortType

Members

Member Name | Description
None | No sort order.
ASC | Ascending sort order.
DESC | Descending sort order.

Requirements

Namespace: Deag.Vdx.Controls.DataRepeater

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer Class

Displays the data of the DataView as a table.

For a list of all members of this type, see vdxDataRepeaterContainer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxDataRepeaterContainer

public class vdxDataRepeaterContainer : UserControl, IvdxChangeable

Remarks

The header component can be set over the property SortTypeClassName. Set the detail component (represents one DataRow) over the property DetailTypeClassName.

Requirements

Namespace: Deag.Vdx.Controls.DataRepeater

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataRepeaterContainer Members | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer Members

vdxDataRepeaterContainer overview

Public Static Methods

CreateFilter Overloaded. Creates a filter for the given DataColumns and DataRowView.

Public Instance Constructors

vdxDataRepeaterContainer Constructor Initializes a new instance of the vdxDataRepeaterContainer class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Current | Gets or sets the current DataRowView for current detail control.
CurrentDetailControl | Gets or sets the current detail control, which represents one row of the table.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataView | Gets or sets the DataView for the representing Table.
DetailType | Gets or sets the detail control type, which represents controls to manipulate one row.
DetailTypeClassName | Gets or sets the detail type, which holds all columns controls.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sort | Gets or sets the sort column of the DataView.
SortTypeClassName | Gets or sets he header sort button type.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

AddNew | Adds a new detail control and the a new DataRow.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
CancelAllEdits | Reject changes for all detail controls.
CancelEdit | Reject changes for the CurrentDetailControl.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Delete | Deletes the CurrentDetailControl.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndEdit | Accept changes for the CurrentDetailControl.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
ShowData | Show the data in the DataView.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CurrentDataRowViewChanged | Occurs after Current DataRowView has changed.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
EndingAdd | Occurs during EndEdit is called.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
SortChanged | Occurs after sort order has changed.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCurrentDataRowViewChanged | Raises a CurrentDataRowViewChanged event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEndingAdd | Raises a EndingAdd event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnSortChanged | Raises a SortChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl) |
IvdxChangeable.HandleChanges | Not implemented
IvdxChangeable.HasChanges | ATTENTION: This will only return if there are any detached rows managed by this Control So you need to combine this result with the HasChanges of the vdxDataStatusManger

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer Constructor

Initializes a new instance of the vdxDataRepeaterContainer class.

public vdxDataRepeaterContainer();

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer Properties

The properties of the vdxDataRepeaterContainer class are listed below. For a complete list of vdxDataRepeaterContainer class members, see the vdxDataRepeaterContainer Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Current | Gets or sets the current DataRowView for current detail control.
CurrentDetailControl | Gets or sets the current detail control, which represents one row of the table.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataView | Gets or sets the DataView for the representing Table.
DetailType | Gets or sets the detail control type, which represents controls to manipulate one row.
DetailTypeClassName | Gets or sets the detail type, which holds all columns controls.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sort | Gets or sets the sort column of the DataView.
SortTypeClassName | Gets or sets he header sort button type.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.Current Property

Gets or sets the current DataRowView for current detail control.

public System.Data.DataRowView Current {get; set;}

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.CurrentDetailControl Property

Gets or sets the current detail control, which represents one row of the table.

public vdxDataRepeaterDetail CurrentDetailControl {get; set;}

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.DataView Property

Gets or sets the DataView for the representing Table.

public System.Data.DataView DataView {get; set;}

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.DetailType Property

Gets or sets the detail control type, which represents controls to manipulate one row.

public System.Type DetailType {get; set;}

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.DetailTypeClassName Property

Gets or sets the detail type, which holds all columns controls.

public string DetailTypeClassName {get; set;}

Remarks

Choose the corresponding control for the column data Type. Data Type Control string TextBox bool CheckBox Enum ComboBox ...

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.Sort Property

Gets or sets the sort column of the DataView.

public string Sort {get; set;}

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.SortTypeClassName Property

Gets or sets he header sort button type.

public string SortTypeClassName {get; set;}

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer Methods

The methods of the vdxDataRepeaterContainer class are listed below. For a complete list of vdxDataRepeaterContainer class members, see the vdxDataRepeaterContainer Members topic.

Public Static Methods

CreateFilter Overloaded. Creates a filter for the given DataColumns and DataRowView.

Public Instance Methods

AddNew | Adds a new detail control and the a new DataRow.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
CancelAllEdits | Reject changes for all detail controls.
CancelEdit | Reject changes for the CurrentDetailControl.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Delete | Deletes the CurrentDetailControl.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndEdit | Accept changes for the CurrentDetailControl.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
ShowData | Show the data in the DataView.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCurrentDataRowViewChanged | Raises a CurrentDataRowViewChanged event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEndingAdd | Raises a EndingAdd event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnSortChanged | Raises a SortChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl) |
IvdxChangeable.HandleChanges | Not implemented
IvdxChangeable.HasChanges | ATTENTION: This will only return if there are any detached rows managed by this Control So you need to combine this result with the HasChanges of the vdxDataStatusManger

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.AddNew Method

Adds a new detail control and the a new DataRow.

public void AddNew();

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.CancelAllEdits Method

Reject changes for all detail controls.

public void CancelAllEdits();

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.CancelEdit Method

Reject changes for the CurrentDetailControl.

public void CancelEdit();

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CreateFilter Method

VDX Framework

vdxDataRepeaterContainer.CreateFilter Method

Creates a filter for the given DataColumns and DataRow.

Overload List

Creates a filter for the given DataColumns and DataRow.

public static string CreateFilter(DataColumn[],DataRow);

Creates a filter for the given DataColumns and DataRowView.

public static string CreateFilter(DataColumn[],DataRowView);

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.CreateFilter Method (DataColumn[], DataRow)

Creates a filter for the given DataColumns and DataRow.

public static string CreateFilter(
DataColumn[] dtcs,
DataRow dr
);

Parameters

dtcs
dr

Return Value

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace | vdxDataRepeaterContainer.CreateFilter Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.CreateFilter Method (DataColumn[], DataRowView)

Creates a filter for the given DataColumns and DataRowView.

public static string CreateFilter(
DataColumn[] dtcs,
DataRowView drv
);

Parameters

dtcs
drv

Return Value

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace | vdxDataRepeaterContainer.CreateFilter Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.IvdxChangeable.HandleChanges Method

Not implemented

bool IvdxChangeable.HandleChanges();

Implements

IvdxChangeable.HandleChanges

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.IvdxChangeable.HasChanges Method

ATTENTION: This will only return if there are any detached rows managed by this Control So you need to combine this result with the HasChanges of the vdxDataStatusManger

bool IvdxChangeable.HasChanges();

Return Value

Implements

IvdxChangeable.HasChanges

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.Delete Method

Deletes the CurrentDetailControl.

public void Delete();

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Dispose Method

VDX Framework

vdxDataRepeaterContainer.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.Dispose Method (Boolean)

Clean up any resources being used.

protected override void Dispose(
bool disposing
);

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace | vdxDataRepeaterContainer.Dispose Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.EndEdit Method

Accept changes for the CurrentDetailControl.

public bool EndEdit();

Return Value

True if save was successfull.

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.OnCurrentDataRowViewChanged Method

Raises a CurrentDataRowViewChanged event.

protected void OnCurrentDataRowViewChanged(
CurrentDataRowViewChangedEventArgs e
);

Parameters

e

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.OnEndingAdd Method

Raises a EndingAdd event.

protected void OnEndingAdd(
EndingAddEventArgs e
);

Parameters

e

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.OnSortChanged Method

Raises a SortChanged event.

protected void OnSortChanged(
SortChangedEventArgs e
);

Parameters

e

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.ShowData Method

Show the data in the DataView.

public void ShowData();

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer Events

The events of the vdxDataRepeaterContainer class are listed below. For a complete list of vdxDataRepeaterContainer class members, see the vdxDataRepeaterContainer Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CurrentDataRowViewChanged | Occurs after Current DataRowView has changed.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
EndingAdd | Occurs during EndEdit is called.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
SortChanged | Occurs after sort order has changed.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.CurrentDataRowViewChanged Event

Occurs after Current DataRowView has changed.

public event CurrentDataRowViewChangedEventHandler CurrentDataRowViewChanged;

Event Data

The event handler receives an argument of type CurrentDataRowViewChangedEventArgs containing data related to this event. The following CurrentDataRowViewChangedEventArgs property provides information specific to this event.

Property | Description
Current | The involved .

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.EndingAdd Event

Occurs during EndEdit is called.

public event EndingAddEventHandler EndingAdd;

Event Data

The event handler receives an argument of type EndingAddEventArgs containing data related to this event. The following EndingAddEventArgs property provides information specific to this event.

Property | Description
Current | The involved .

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterContainer.SortChanged Event

Occurs after sort order has changed.

public event SortChangedEventHandler SortChanged;

Event Data

The event handler receives an argument of type SortChangedEventArgs containing data related to this event. The following SortChangedEventArgs properties provide information specific to this event.

Property | Description
Sort | Gets the sort order string format.
Sorts | Gets the sort order expressions.

See Also

vdxDataRepeaterContainer Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetail Class

Represents the detail control for one DataRowView in the vdxDataRepeaterContainer.

For a list of all members of this type, see vdxDataRepeaterDetail Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxDataRepeaterDetail

public class vdxDataRepeaterDetail : UserControl

Remarks

Must be derived and designed by the user. Each DataColumn must have a corresponding user control.

Requirements

Namespace: Deag.Vdx.Controls.DataRepeater

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataRepeaterDetail Members | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetail Members

vdxDataRepeaterDetail overview

Public Instance Constructors

vdxDataRepeaterDetail Constructor Initializes a new instance of the vdxDataRepeaterDetail class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Current | Gets the current DataRowView.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataRepeaterContainer | Gets or sets the parent vdxDataRepeaterContainer.
DataView | Gets or sets the DataView that DataRowView is displayed.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Filter | Gets or sets the expression used to filter which rows are viewed in the filtered DataView.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

AddNew | Adds new DataRow on the filtered DataView.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RefreshData | Refresh data on the filtered DataView.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetFocus | Set focus on the this detail control.
Show | Shows the detail DataRowView.
ShowState | Shows state of the current DataRowView.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

filteredDataView The data view with the active filter and sort expressions.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded | Overrides OnControlAdded.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShowData | Shows the data binding all controls to the DataView.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

vdxDataRepeaterDetail Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetail Constructor

Initializes a new instance of the vdxDataRepeaterDetail class.

public vdxDataRepeaterDetail();

See Also

vdxDataRepeaterDetail Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetail Fields

The fields of the vdxDataRepeaterDetail class are listed below. For a complete list of vdxDataRepeaterDetail class members, see the vdxDataRepeaterDetail Members topic.

Protected Instance Fields

filteredDataView The data view with the active filter and sort expressions.

See Also

vdxDataRepeaterDetail Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetail.filteredDataView Field

The data view with the active filter and sort expressions.

protected DataView filteredDataView;

See Also

vdxDataRepeaterDetail Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetail Properties

The properties of the vdxDataRepeaterDetail class are listed below. For a complete list of vdxDataRepeaterDetail class members, see the vdxDataRepeaterDetail Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Current | Gets the current DataRowView.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataRepeaterContainer | Gets or sets the parent vdxDataRepeaterContainer.
DataView | Gets or sets the DataView that DataRowView is displayed.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Filter | Gets or sets the expression used to filter which rows are viewed in the filtered DataView.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

vdxDataRepeaterDetail Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetail.Current Property

Gets the current DataRowView.

public System.Data.DataRowView Current {get;}

See Also

vdxDataRepeaterDetail Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetail.DataRepeaterContainer Property

Gets or sets the parent vdxDataRepeaterContainer.

public vdxDataRepeaterContainer DataRepeaterContainer {get; set;}

See Also

vdxDataRepeaterDetail Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetail.DataView Property

Gets or sets the DataView that DataRowView is displayed.

public System.Data.DataView DataView {get; set;}

See Also

vdxDataRepeaterDetail Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetail.Filter Property

Gets or sets the expression used to filter which rows are viewed in the filtered DataView.

public string Filter {get; set;}

See Also

vdxDataRepeaterDetail Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetail Methods

The methods of the vdxDataRepeaterDetail class are listed below. For a complete list of vdxDataRepeaterDetail class members, see the vdxDataRepeaterDetail Members topic.

Public Instance Methods

AddNew | Adds new DataRow on the filtered DataView.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RefreshData | Refresh data on the filtered DataView.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetFocus | Set focus on the this detail control.
Show | Shows the detail DataRowView.
ShowState | Shows state of the current DataRowView.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded | Overrides OnControlAdded.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShowData | Shows the data binding all controls to the DataView.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

vdxDataRepeaterDetail Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetail.AddNew Method

Adds new DataRow on the filtered DataView.

public void AddNew();

See Also

vdxDataRepeaterDetail Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Dispose Method

VDX Framework

vdxDataRepeaterDetail.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

vdxDataRepeaterDetail Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetail.Dispose Method (Boolean)

Clean up any resources being used.

protected override void Dispose(
bool disposing
);

See Also

vdxDataRepeaterDetail Class | Deag.Vdx.Controls.DataRepeater Namespace | vdxDataRepeaterDetail.Dispose Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetail.OnControlAdded Method

Overrides OnControlAdded.

protected override void OnControlAdded(
ControlEventArgs e
);

Parameters

e

See Also

vdxDataRepeaterDetail Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetail.RefreshData Method

Refresh data on the filtered DataView.

public void RefreshData();

See Also

vdxDataRepeaterDetail Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetail.SetFocus Method

Set focus on the this detail control.

public void SetFocus();

See Also

vdxDataRepeaterDetail Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetail.Show Method

Shows the detail DataRowView.

new public void Show();

See Also

vdxDataRepeaterDetail Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetail.ShowData Method

Shows the data binding all controls to the DataView.

protected virtual void ShowData();

Remarks

Must be overridden by the derived class.

Example

The following example shows how to add the data bindings to controls.

            protected override void ShowData()
            {
                this.cboLanguage.DataBindings.Add("SelectedValue", this.filteredDataView, "LanguageID");
                this.txtText.DataBindings.Add("Text", this.filteredDataView, "Text");
                this.txtCaption.DataBindings.Add("Text", this.filteredDataView, "Caption");
            }

See Also

vdxDataRepeaterDetail Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetail.ShowState Method

Shows state of the current DataRowView.

public bool ShowState();

Return Value

See Also

vdxDataRepeaterDetail Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetailTypeConverter Class

Apply this class as a TypeConverterAttribute to list the available classes based upon your vdxDataDetail controls.

For a list of all members of this type, see vdxDataRepeaterDetailTypeConverter Members.

System.Object
TypeConverter
StringConverter
vdxTypeConverterBase
vdxDataRepeaterDetailTypeConverter

public class vdxDataRepeaterDetailTypeConverter : vdxTypeConverterBase

Requirements

Namespace: Deag.Vdx.Controls.DataRepeater

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataRepeaterDetailTypeConverter Members | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetailTypeConverter Members

vdxDataRepeaterDetailTypeConverter overview

Public Instance Constructors

vdxDataRepeaterDetailTypeConverter Constructor Initializes a new instance of the vdxDataDetailTypeConverter class.

Public Instance Methods

CanConvertFrom (inherited from StringConverter) | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from StringConverter) | Overloaded. Converts the specified value object to a String object.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from vdxTypeConverterBase) | Overloaded. Gets the collection of supported standard values.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from vdxTypeConverterBase) | Overloaded. Gets whether only standard values are supported or not.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from vdxTypeConverterBase) | Overloaded. Gets whether standard values are supported or not.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxGetAllKnownAssemblies (inherited from vdxTypeConverterBase) | Retrieves all referenced assemblies and the context assembly for the given context.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.
VdxGetContextAssembly (inherited from vdxTypeConverterBase) | Gets a reference to the client assembly. Used by the type converters in design mode.
VdxGetEffectiveType (inherited from vdxTypeConverterBase) | Gets the effective type.

See Also

vdxDataRepeaterDetailTypeConverter Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterDetailTypeConverter Constructor

Initializes a new instance of the vdxDataDetailTypeConverter class.

public vdxDataRepeaterDetailTypeConverter();

See Also

vdxDataRepeaterDetailTypeConverter Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterSort Class

Represents the header control in the vdxDataRepeaterContainer.

For a list of all members of this type, see vdxDataRepeaterSort Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxDataRepeaterSort

public class vdxDataRepeaterSort : UserControl

Remarks

Must be derived and designed by the user. Each DataColumn must have a corresponding sort button.

Requirements

Namespace: Deag.Vdx.Controls.DataRepeater

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataRepeaterSort Members | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterSort Members

vdxDataRepeaterSort overview

Public Instance Constructors

vdxDataRepeaterSort Constructor Initializes a new instance of the vdxDataRepeaterSort class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataRepeaterContainer | Gets or sets the parent vdxDataRepeaterContainer.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

slSortButtons Contains all sort buttons.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded | Overrides OnControlAdded
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetSort | Sets the vdxSortButton.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SortChanged | Evaluates sort order changes.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
vdxSortButton_Clicked | Set the active sort button.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

vdxDataRepeaterSort Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterSort Constructor

Initializes a new instance of the vdxDataRepeaterSort class.

public vdxDataRepeaterSort();

See Also

vdxDataRepeaterSort Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterSort Fields

The fields of the vdxDataRepeaterSort class are listed below. For a complete list of vdxDataRepeaterSort class members, see the vdxDataRepeaterSort Members topic.

Protected Instance Fields

slSortButtons Contains all sort buttons.

See Also

vdxDataRepeaterSort Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterSort.slSortButtons Field

Contains all sort buttons.

protected SortedList slSortButtons;

See Also

vdxDataRepeaterSort Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterSort Properties

The properties of the vdxDataRepeaterSort class are listed below. For a complete list of vdxDataRepeaterSort class members, see the vdxDataRepeaterSort Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataRepeaterContainer | Gets or sets the parent vdxDataRepeaterContainer.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

vdxDataRepeaterSort Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterSort.DataRepeaterContainer Property

Gets or sets the parent vdxDataRepeaterContainer.

public vdxDataRepeaterContainer DataRepeaterContainer {get; set;}

See Also

vdxDataRepeaterSort Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterSort Methods

The methods of the vdxDataRepeaterSort class are listed below. For a complete list of vdxDataRepeaterSort class members, see the vdxDataRepeaterSort Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded | Overrides OnControlAdded
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetSort | Sets the vdxSortButton.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SortChanged | Evaluates sort order changes.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
vdxSortButton_Clicked | Set the active sort button.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

vdxDataRepeaterSort Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Dispose Method

VDX Framework

vdxDataRepeaterSort.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

vdxDataRepeaterSort Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterSort.Dispose Method (Boolean)

Clean up any resources being used.

protected override void Dispose(
bool disposing
);

See Also

vdxDataRepeaterSort Class | Deag.Vdx.Controls.DataRepeater Namespace | vdxDataRepeaterSort.Dispose Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterSort.OnControlAdded Method

Overrides OnControlAdded

protected override void OnControlAdded(
ControlEventArgs e
);

Parameters

e

See Also

vdxDataRepeaterSort Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterSort.SetSort Method

Sets the vdxSortButton.

protected void SetSort(
vdxSortButton changedSortButton
);

Parameters

changedSortButton

See Also

vdxDataRepeaterSort Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterSort.SortChanged Method

Evaluates sort order changes.

protected virtual void SortChanged(
string sort,
SortExpression[] sorts
);

Parameters

sort
sorts

See Also

vdxDataRepeaterSort Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterSort.vdxSortButton_Clicked Method

Set the active sort button.

protected void vdxSortButton_Clicked(
object sender,
EventArgs e
);

Parameters

sender
e

See Also

vdxDataRepeaterSort Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterSortTypeConverter Class

Apply this class as a TypeConverterAttribute to list the available classes based upon your vdxDataDetail controls.

For a list of all members of this type, see vdxDataRepeaterSortTypeConverter Members.

System.Object
TypeConverter
StringConverter
vdxTypeConverterBase
vdxDataRepeaterSortTypeConverter

public class vdxDataRepeaterSortTypeConverter : vdxTypeConverterBase

Requirements

Namespace: Deag.Vdx.Controls.DataRepeater

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataRepeaterSortTypeConverter Members | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterSortTypeConverter Members

vdxDataRepeaterSortTypeConverter overview

Public Instance Constructors

vdxDataRepeaterSortTypeConverter Constructor Initializes a new instance of the vdxDataDetailTypeConverter class.

Public Instance Methods

CanConvertFrom (inherited from StringConverter) | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from StringConverter) | Overloaded. Converts the specified value object to a String object.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from vdxTypeConverterBase) | Overloaded. Gets the collection of supported standard values.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from vdxTypeConverterBase) | Overloaded. Gets whether only standard values are supported or not.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from vdxTypeConverterBase) | Overloaded. Gets whether standard values are supported or not.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.
VdxGetAllKnownAssemblies (inherited from vdxTypeConverterBase) | Retrieves all referenced assemblies and the context assembly for the given context.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.
VdxGetContextAssembly (inherited from vdxTypeConverterBase) | Gets a reference to the client assembly. Used by the type converters in design mode.
VdxGetEffectiveType (inherited from vdxTypeConverterBase) | Gets the effective type.

See Also

vdxDataRepeaterSortTypeConverter Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataRepeaterSortTypeConverter Constructor

Initializes a new instance of the vdxDataDetailTypeConverter class.

public vdxDataRepeaterSortTypeConverter();

See Also

vdxDataRepeaterSortTypeConverter Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSortButton Class

Represents the header control in the vdxDataRepeaterContainer.

For a list of all members of this type, see vdxSortButton Members.

System.Object
MarshalByRefObject
Component
Control
ButtonBase
Button
vdxButton
vdxSortButton

public class vdxSortButton : vdxButton

Requirements

Namespace: Deag.Vdx.Controls.DataRepeater

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxSortButton Members | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSortButton Members

vdxSortButton overview

Public Instance Constructors

vdxSortButton Constructor Initializes a new instance of the vdxSortButton class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxButton) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColumnName | Gets or sets the column name this sort button belongs to.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos (inherited from vdxButton) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DialogResult (inherited from Button) | Gets or sets a value that is returned to the parent form when the button is clicked.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SortString | Gets the sort expression for the corresponding ColumnName and SortType
SortType | Gets or sets the sort type for this sort button.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Gets or sets the text displayed on the sort button.
TextAlign (inherited from ButtonBase) | Gets or sets the alignment of the text on the button control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxButton) | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyDefault (inherited from Button) | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly.
PerformClick (inherited from Button) | Generates a Click event for a button.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Reset | Resets the SortType to SortType.None and reset sort button text to original text.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo (inherited from vdxButton) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Button) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Button) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from ButtonBase) |
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Button) |
DefaultImeMode (inherited from ButtonBase) | Gets the default Input Method Editor (IME) mode supported by this control.
DefaultSize (inherited from ButtonBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
IsDefault (inherited from ButtonBase) | Gets or sets a value indicating whether the button control is the default button.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ChangeText | Changes the text of sort button.
CreateAccessibilityInstance (inherited from ButtonBase) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick | Overrides OnClick.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from ButtonBase) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from ButtonBase) |
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from ButtonBase) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from ButtonBase) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from ButtonBase) |
OnMouseDown (inherited from ButtonBase) |
OnMouseEnter (inherited from ButtonBase) |
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from ButtonBase) |
OnMouseMove (inherited from ButtonBase) |
OnMouseUp (inherited from Button) |
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from ButtonBase) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ButtonBase) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from ButtonBase) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ButtonBase) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Button) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetFlagsandPaint (inherited from ButtonBase) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Button) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxSortButton Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSortButton Constructor

Initializes a new instance of the vdxSortButton class.

public vdxSortButton();

See Also

vdxSortButton Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSortButton Properties

The properties of the vdxSortButton class are listed below. For a complete list of vdxSortButton class members, see the vdxSortButton Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxButton) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColumnName | Gets or sets the column name this sort button belongs to.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos (inherited from vdxButton) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DialogResult (inherited from Button) | Gets or sets a value that is returned to the parent form when the button is clicked.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SortString | Gets the sort expression for the corresponding ColumnName and SortType
SortType | Gets or sets the sort type for this sort button.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Gets or sets the text displayed on the sort button.
TextAlign (inherited from ButtonBase) | Gets or sets the alignment of the text on the button control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Button) |
DefaultImeMode (inherited from ButtonBase) | Gets the default Input Method Editor (IME) mode supported by this control.
DefaultSize (inherited from ButtonBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
IsDefault (inherited from ButtonBase) | Gets or sets a value indicating whether the button control is the default button.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxSortButton Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSortButton.ColumnName Property

Gets or sets the column name this sort button belongs to.

public string ColumnName {get; set;}

See Also

vdxSortButton Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSortButton.SortString Property

Gets the sort expression for the corresponding ColumnName and SortType

public string SortString {get;}

See Also

vdxSortButton Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSortButton.SortType Property

Gets or sets the sort type for this sort button.

public SortType SortType {get; set;}

See Also

vdxSortButton Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSortButton.Text Property

Gets or sets the text displayed on the sort button.

public override string Text {get; set;}

See Also

vdxSortButton Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSortButton Methods

The methods of the vdxSortButton class are listed below. For a complete list of vdxSortButton class members, see the vdxSortButton Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxButton) | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyDefault (inherited from Button) | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly.
PerformClick (inherited from Button) | Generates a Click event for a button.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Reset | Resets the SortType to SortType.None and reset sort button text to original text.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo (inherited from vdxButton) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Button) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ChangeText | Changes the text of sort button.
CreateAccessibilityInstance (inherited from ButtonBase) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick | Overrides OnClick.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from ButtonBase) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from ButtonBase) |
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from ButtonBase) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from ButtonBase) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from ButtonBase) |
OnMouseDown (inherited from ButtonBase) |
OnMouseEnter (inherited from ButtonBase) |
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from ButtonBase) |
OnMouseMove (inherited from ButtonBase) |
OnMouseUp (inherited from Button) |
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from ButtonBase) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ButtonBase) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from ButtonBase) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ButtonBase) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Button) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetFlagsandPaint (inherited from ButtonBase) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Button) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxSortButton Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSortButton.ChangeText Method

Changes the text of sort button.

protected void ChangeText();

See Also

vdxSortButton Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Dispose Method

VDX Framework

vdxSortButton.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

vdxSortButton Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSortButton.Dispose Method (Boolean)

Clean up any resources being used.

protected override void Dispose(
bool disposing
);

See Also

vdxSortButton Class | Deag.Vdx.Controls.DataRepeater Namespace | vdxSortButton.Dispose Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSortButton.OnClick Method

Overrides OnClick.

protected override void OnClick(
EventArgs e
);

Parameters

e

See Also

vdxSortButton Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSortButton.Reset Method

Resets the SortType to SortType.None and reset sort button text to original text.

public void Reset();

See Also

vdxSortButton Class | Deag.Vdx.Controls.DataRepeater Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Controls.Delegates

VDX Framework

Deag.Vdx.Controls.Delegates Namespace

Delegates

Delegate | Description
vdxCacheableElementEventHandler | Defines the signature of the CacheableControl event used by a vdxMultiContainer to inform about creation, activation, deactivation or reactivation of a vdxCacheableControl.
vdxDataManipulatorEventHandler | Defines the signature of the DataManipulator event used by the IvdxDataManipulator to inform a vdxExplorer about data changes in a vdxDataDetail.
vdxDataStatusChangedEventHandler | Defines the signature of the DataStatusChanged event used by the vdxDataStatusManager to inform about vdxDataStatus changes.
vdxInteractiveChangedEventHandler | Defines the signature of the InteractiveChanged event used in the class vdxComboBox and vdxComboBoxEdit to detect changes by an user.
vdxNavigatorControlEventHandler | Defines the signature of the NavigatorControlChanged event used by an IvdxNavigator. to inform a vdxExplorer to change the current displayed vdxCacheableControl in the vdxDataMultiContainer of the vdxExplorer.
vdxNavigatorSelectionEventHandler | Defines the signature of the NavigatorSelectionChanged event used by an IvdxNavigator. to inform a vdxExplorer about selection changes to synchronize all registereds IvdxNavigator.
vdxOutlookBarExpandedEventHandler | Defines the signature of the OutlookbarExpanded event.
vdxOutlookBarGroupClickedEventHandler | Defines the signature of the OutlookbarGroupClicked event.
vdxOutlookBarGroupClickingEventHandler | Defines the signature of the OutlookbarGroupClicking event.
vdxOutlookBarIconClickedEventHandler | Defines the signature of the OutlookbarIconClicked event.
vdxOutlookBarIconClickingEventHandler | Defines the signature of the OutlookbarIconClicking event.
vdxOutlookBarIconSelectionClickedEventHandler | Defines the signature of the OutlookbarIconSelectionClicked event.
vdxOutlookBarIconSelectionClickingEventHandler | Defines the signature of the OutlookbarIconSelectionClicking event.
vdxOutlookBarIconSelectionDeletedEventHandler | Defines the signature of the OutlookbarIconSelectionDeleted event.
vdxOutlookBarIconSelectionRenamedEventHandler | Defines the signature of the OutlookbarIconSelectionRenamed event.
vdxOutlookBarIconSelectionSizeChangedEventHandler | Defines the signature of the OutlookbarIconSizeChanged event.
vdxOutlookBarMinimizedEventHandler | Defines the signature of the OutlookbarMinimized event.
vdxPickerEventHandler | Defines the signature of the Picker event used by the a IvdxPicker. to inform about a vdxPickerInfo was accepted.
vdxPossibleOperationsChangedEventHandler | Defines the signature of the AllowOperationsChanged event used by vdxDataActionManager to inform about changes of the allowed actions on the vdxDataStatusManager.
vdxSearchParametersFilledEventHandler | Defines the signature of the SearchParametersFilled event used by a IvdxSearchControl to inform about the vdxSearchParameters were filled to invoke the search routine.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableElementEventHandler Delegate

Defines the signature of the CacheableControl event used by a vdxMultiContainer to inform about creation, activation, deactivation or reactivation of a vdxCacheableControl.

public delegate void vdxCacheableElementEventHandler(
object sender,
vdxCacheableElementEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | vdxMultiContainer | vdxCacheableControl | vdxCacheableElementEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventHandler Delegate

Defines the signature of the DataManipulator event used by the IvdxDataManipulator to inform a vdxExplorer about data changes in a vdxDataDetail.

public delegate void vdxDataManipulatorEventHandler(
object sender,
vdxDataManipulatorEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | IvdxDataManipulator | vdxExplorer | vdxDataDetail | vdxDataManipulatorEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusChangedEventHandler Delegate

Defines the signature of the DataStatusChanged event used by the vdxDataStatusManager to inform about vdxDataStatus changes.

public delegate void vdxDataStatusChangedEventHandler(
object sender,
vdxDataStatusChangedEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | vdxDataStatusManager | vdxDataStatus | vdxDataStatusChangedEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxInteractiveChangedEventHandler Delegate

Defines the signature of the InteractiveChanged event used in the class vdxComboBox and vdxComboBoxEdit to detect changes by an user.

public delegate void vdxInteractiveChangedEventHandler(
object sender,
vdxInteractiveChangedEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | vdxComboBox | vdxComboBoxEdit | vdxInteractiveChangedEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorControlEventHandler Delegate

Defines the signature of the NavigatorControlChanged event used by an IvdxNavigator. to inform a vdxExplorer to change the current displayed vdxCacheableControl in the vdxDataMultiContainer of the vdxExplorer.

public delegate void vdxNavigatorControlEventHandler(
object sender,
vdxNavigatorControlEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | IvdxNavigator | vdxExplorer | vdxDataMultiContainer | vdxCacheableControl | vdxNavigatorControlEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorSelectionEventHandler Delegate

Defines the signature of the NavigatorSelectionChanged event used by an IvdxNavigator. to inform a vdxExplorer about selection changes to synchronize all registereds IvdxNavigator.

public delegate void vdxNavigatorSelectionEventHandler(
object sender,
vdxNavigatorSelectionEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | IvdxNavigator | vdxExplorer | vdxNavigatorSelectionEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarExpandedEventHandler Delegate

Defines the signature of the OutlookbarExpanded event.

public delegate void vdxOutlookBarExpandedEventHandler(
object sender,
EventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | vdxOutlookBar | EventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupClickedEventHandler Delegate

Defines the signature of the OutlookbarGroupClicked event.

public delegate void vdxOutlookBarGroupClickedEventHandler(
object sender,
vdxOutlookBarGroupClickedEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | vdxOutlookBar | vdxOutlookBarGroupClickedEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupClickingEventHandler Delegate

Defines the signature of the OutlookbarGroupClicking event.

public delegate void vdxOutlookBarGroupClickingEventHandler(
object sender,
vdxOutlookBarGroupClickingEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | vdxOutlookBar | vdxOutlookBarGroupClickingEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconClickedEventHandler Delegate

Defines the signature of the OutlookbarIconClicked event.

public delegate void vdxOutlookBarIconClickedEventHandler(
object sender,
vdxOutlookBarIconClickedEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | vdxOutlookBar | vdxOutlookBarIconClickedEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconClickingEventHandler Delegate

Defines the signature of the OutlookbarIconClicking event.

public delegate void vdxOutlookBarIconClickingEventHandler(
object sender,
vdxOutlookBarIconClickingEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | vdxOutlookBar | vdxOutlookBarIconClickingEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionClickedEventHandler Delegate

Defines the signature of the OutlookbarIconSelectionClicked event.

public delegate void vdxOutlookBarIconSelectionClickedEventHandler(
object sender,
vdxOutlookBarIconSelectionClickedEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | vdxOutlookBar | vdxOutlookBarIconSelectionClickedEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionClickingEventHandler Delegate

Defines the signature of the OutlookbarIconSelectionClicking event.

public delegate void vdxOutlookBarIconSelectionClickingEventHandler(
object sender,
vdxOutlookBarIconSelectionClickingEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | vdxOutlookBar | vdxOutlookBarIconSelectionClickingEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionDeletedEventHandler Delegate

Defines the signature of the OutlookbarIconSelectionDeleted event.

public delegate void vdxOutlookBarIconSelectionDeletedEventHandler(
object sender,
vdxOutlookBarIconSelectionDeletedEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | vdxOutlookBar | vdxOutlookBarIconSelectionDeletedEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionRenamedEventHandler Delegate

Defines the signature of the OutlookbarIconSelectionRenamed event.

public delegate void vdxOutlookBarIconSelectionRenamedEventHandler(
object sender,
vdxOutlookBarIconSelectionRenamedEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | vdxOutlookBar | vdxOutlookBarIconSelectionRenamedEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionSizeChangedEventHandler Delegate

Defines the signature of the OutlookbarIconSizeChanged event.

public delegate void vdxOutlookBarIconSelectionSizeChangedEventHandler(
object sender,
vdxOutlookBarIconSelectionSizeChangedEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | vdxOutlookBar | vdxOutlookBarIconSelectionSizeChangedEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarMinimizedEventHandler Delegate

Defines the signature of the OutlookbarMinimized event.

public delegate void vdxOutlookBarMinimizedEventHandler(
object sender,
EventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | vdxOutlookBar | EventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerEventHandler Delegate

Defines the signature of the Picker event used by the a IvdxPicker. to inform about a vdxPickerInfo was accepted.

public delegate void vdxPickerEventHandler(
object sender,
vdxPickerEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | IvdxPicker | vdxPickerInfo | vdxPickerDialog | vdxPickerEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPossibleOperationsChangedEventHandler Delegate

Defines the signature of the AllowOperationsChanged event used by vdxDataActionManager to inform about changes of the allowed actions on the vdxDataStatusManager.

public delegate void vdxPossibleOperationsChangedEventHandler(
object sender,
vdxPossibleOperationsChangedEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | vdxDataActionManager | vdxDataStatusManager | vdxPossibleOperationsChangedEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParametersFilledEventHandler Delegate

Defines the signature of the SearchParametersFilled event used by a IvdxSearchControl to inform about the vdxSearchParameters were filled to invoke the search routine.

public delegate void vdxSearchParametersFilledEventHandler(
object sender,
vdxSearchParametersFilledEventArgs e
);

Requirements

Namespace: Deag.Vdx.Controls.Delegates

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Delegates Namespace | IvdxSearchControl | vdxSearchParameters | vdxSelection | vdxSearchParametersFilledEventArgs

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Controls.EventArguments

VDX Framework

Deag.Vdx.Controls.EventArguments Namespace

Classes

Class | Description
vdxCacheableElementEventArgs | Provides data for a DataRowSelected event.
vdxDataManipulatorEventArgs | Provides data for a the SelectedChanged event.
vdxDataManipulatorEventArgs.ManipulatorData | Contains the information to update all navigators from the vdxExplorer after new record was inserted or a record was updated.
vdxDataStatusChangedEventArgs | Provides data for a DataStatusChanged event.
vdxInteractiveChangedEventArgs | Provides data for a InteractiveChanged event.
vdxNavigatorControlEventArgs | Provides data for a the SelectedChanged event.
vdxNavigatorSelectionEventArgs | Provides data for a the SelectedChanged event.
vdxOutlookBarGroupClickedEventArgs | Provides data for the OutlookBarGroupClicked event.
vdxOutlookBarGroupClickingEventArgs | Provides data for the OutlookBarGroupClicking event.
vdxOutlookBarIconClickedEventArgs | Provides data for the OutlookbarIconClicked event.
vdxOutlookBarIconClickingEventArgs | Provides data for the OutlookbarIconClicking event.
vdxOutlookBarIconSelectionClickedEventArgs | Provides data for the OutlookbarIconSelectionClicked event.
vdxOutlookBarIconSelectionClickingEventArgs | Provides data for the OutlookbarIconSelectionClicking event.
vdxOutlookBarIconSelectionDeletedEventArgs | Provides data for the OutlookbarIconSelectionDeleted event.
vdxOutlookBarIconSelectionRenamedEventArgs | Provides data for the OutlookbarIconSelectionRenamed event.
vdxOutlookBarIconSelectionSizeChangedEventArgs | Provides data for the OutlookbarIconSelectionSizeChanged event.
vdxPickerEventArgs | Provides data for a vdxPickerEventArgs event.
vdxPossibleOperationsChangedEventArgs | Provides data for a PossibleOperationsChanged event.
vdxSearchParametersFilledEventArgs | Provides data for a vdxSearchParametersFilled event.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableElementEventArgs Class

Provides data for a DataRowSelected event.

For a list of all members of this type, see vdxCacheableElementEventArgs Members.

System.Object
EventArgs
vdxCacheableElementEventArgs

public class vdxCacheableElementEventArgs : EventArgs

Requirements

Namespace: Deag.Vdx.Controls.EventArguments

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxCacheableElementEventArgs Members | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableElementEventArgs Members

vdxCacheableElementEventArgs overview

Public Instance Constructors

vdxCacheableElementEventArgs Constructor Initializes a new instance of the vdxCacheableElementEventArgs class.

Public Instance Properties

CacheableControl Gets the involved cacheable control.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxCacheableElementEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableElementEventArgs Constructor

Initializes a new instance of the vdxCacheableElementEventArgs class.

public vdxCacheableElementEventArgs(
IvdxMultiContainerCacheable cacheable
);

Parameters

cacheable
The involved cacheable control.

See Also

vdxCacheableElementEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableElementEventArgs Properties

The properties of the vdxCacheableElementEventArgs class are listed below. For a complete list of vdxCacheableElementEventArgs class members, see the vdxCacheableElementEventArgs Members topic.

Public Instance Properties

CacheableControl Gets the involved cacheable control.

See Also

vdxCacheableElementEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCacheableElementEventArgs.CacheableControl Property

Gets the involved cacheable control.

public Deag.Vdx.Controls.Core.IvdxMultiContainerCacheable CacheableControl {get;}

See Also

vdxCacheableElementEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventArgs Class

Provides data for a the SelectedChanged event.

For a list of all members of this type, see vdxDataManipulatorEventArgs Members.

System.Object
EventArgs
vdxDataManipulatorEventArgs

public class vdxDataManipulatorEventArgs : EventArgs

Requirements

Namespace: Deag.Vdx.Controls.EventArguments

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataManipulatorEventArgs Members | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventArgs Members

vdxDataManipulatorEventArgs overview

Public Instance Constructors

vdxDataManipulatorEventArgs Overloaded. Initializes a new instance of the vdxDataManipulatorEventArgs class.

Public Instance Properties

Data Gets the involved DataRow.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxDataManipulatorEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventArgs Constructor

Initializes a new instance of the vdxDataManipulatorEventArgs class for the specified data.

Overload List

Initializes a new instance of the vdxDataManipulatorEventArgs class for the specified DataRow.

public vdxDataManipulatorEventArgs(DataRow);

Initializes a new instance of the vdxDataManipulatorEventArgs class for the specified DataSet.

public vdxDataManipulatorEventArgs(DataSet);

Initializes a new instance of the vdxDataManipulatorEventArgs class for the specified data.

public vdxDataManipulatorEventArgs(object);

See Also

vdxDataManipulatorEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventArgs Constructor (Object)

Initializes a new instance of the vdxDataManipulatorEventArgs class for the specified data.

public vdxDataManipulatorEventArgs(
object data
);

Parameters

data
The involved data.

See Also

vdxDataManipulatorEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace | vdxDataManipulatorEventArgs Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventArgs Constructor (DataSet)

Initializes a new instance of the vdxDataManipulatorEventArgs class for the specified DataSet.

public vdxDataManipulatorEventArgs(
DataSet data
);

Parameters

data
The involved DataSet.

See Also

vdxDataManipulatorEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace | vdxDataManipulatorEventArgs Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventArgs Constructor (DataRow)

Initializes a new instance of the vdxDataManipulatorEventArgs class for the specified DataRow.

public vdxDataManipulatorEventArgs(
DataRow data
);

Parameters

data
The involved DataRow.

See Also

vdxDataManipulatorEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace | vdxDataManipulatorEventArgs Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventArgs Properties

The properties of the vdxDataManipulatorEventArgs class are listed below. For a complete list of vdxDataManipulatorEventArgs class members, see the vdxDataManipulatorEventArgs Members topic.

Public Instance Properties

Data Gets the involved DataRow.

See Also

vdxDataManipulatorEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventArgs.Data Property

Gets the involved DataRow.

public vdxDataManipulatorEventArgs.ManipulatorData Data {get;}

See Also

vdxDataManipulatorEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventArgs.ManipulatorData Class

Contains the information to update all navigators from the vdxExplorer after new record was inserted or a record was updated.

For a list of all members of this type, see vdxDataManipulatorEventArgs.ManipulatorData Members.

System.Object
vdxDataManipulatorEventArgs.ManipulatorData

public class vdxDataManipulatorEventArgs.ManipulatorData

Requirements

Namespace: Deag.Vdx.Controls.EventArguments

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataManipulatorEventArgs.ManipulatorData Members | Deag.Vdx.Controls.EventArguments Namespace | IvdxNavigator | IvdxDataManipulator | vdxDataDetail | vdxExplorer | vdxDataGridNavigator | vdxTreeView

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventArgs.ManipulatorData Members

vdxDataManipulatorEventArgs.ManipulatorData overview

Public Instance Constructors

vdxDataManipulatorEventArgs.ManipulatorData Constructor Initializes a new instance of the vdxDataManipulatorEventArgs.ManipulatorData class using the specified object.

Public Instance Properties

Data | Gets the involved data.
DataRow | Gets the involved DataRow.
DataSet | Gets the involved DataSet.
DataTable | Gets the involved DataTable.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetManipulatorTable | Gets the manipulator DataTable for this vdxDataManipulatorEventArgs.ManipulatorData.
GetNavigatorTable | Gets the navigator DataTable of the specified navigatorDataSet for this vdxDataManipulatorEventArgs.ManipulatorData.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxDataManipulatorEventArgs.ManipulatorData Class | Deag.Vdx.Controls.EventArguments Namespace | IvdxNavigator | IvdxDataManipulator | vdxDataDetail | vdxExplorer | vdxDataGridNavigator | vdxTreeView

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventArgs.ManipulatorData Constructor

Initializes a new instance of the vdxDataManipulatorEventArgs.ManipulatorData class using the specified object.

public vdxDataManipulatorEventArgs.ManipulatorData(
object data
);

Parameters

data
Usually a DataRow or DataSet

See Also

vdxDataManipulatorEventArgs.ManipulatorData Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventArgs.ManipulatorData Properties

The properties of the vdxDataManipulatorEventArgs.ManipulatorData class are listed below. For a complete list of vdxDataManipulatorEventArgs.ManipulatorData class members, see the vdxDataManipulatorEventArgs.ManipulatorData Members topic.

Public Instance Properties

Data | Gets the involved data.
DataRow | Gets the involved DataRow.
DataSet | Gets the involved DataSet.
DataTable | Gets the involved DataTable.

See Also

vdxDataManipulatorEventArgs.ManipulatorData Class | Deag.Vdx.Controls.EventArguments Namespace | IvdxNavigator | IvdxDataManipulator | vdxDataDetail | vdxExplorer | vdxDataGridNavigator | vdxTreeView

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventArgs.ManipulatorData.Data Property

Gets the involved data.

public object Data {get;}

See Also

vdxDataManipulatorEventArgs.ManipulatorData Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventArgs.ManipulatorData.DataRow Property

Gets the involved DataRow.

public System.Data.DataRow DataRow {get;}

See Also

vdxDataManipulatorEventArgs.ManipulatorData Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventArgs.ManipulatorData.DataSet Property

Gets the involved DataSet.

public System.Data.DataSet DataSet {get;}

See Also

vdxDataManipulatorEventArgs.ManipulatorData Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventArgs.ManipulatorData.DataTable Property

Gets the involved DataTable.

public System.Data.DataTable DataTable {get;}

See Also

vdxDataManipulatorEventArgs.ManipulatorData Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventArgs.ManipulatorData Methods

The methods of the vdxDataManipulatorEventArgs.ManipulatorData class are listed below. For a complete list of vdxDataManipulatorEventArgs.ManipulatorData class members, see the vdxDataManipulatorEventArgs.ManipulatorData Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetManipulatorTable | Gets the manipulator DataTable for this vdxDataManipulatorEventArgs.ManipulatorData.
GetNavigatorTable | Gets the navigator DataTable of the specified navigatorDataSet for this vdxDataManipulatorEventArgs.ManipulatorData.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxDataManipulatorEventArgs.ManipulatorData Class | Deag.Vdx.Controls.EventArguments Namespace | IvdxNavigator | IvdxDataManipulator | vdxDataDetail | vdxExplorer | vdxDataGridNavigator | vdxTreeView

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventArgs.ManipulatorData.GetManipulatorTable Method

Gets the manipulator DataTable for this vdxDataManipulatorEventArgs.ManipulatorData.

public virtual DataTable GetManipulatorTable();

Return Value

The specified manipulator DataTable otherwise null.

See Also

vdxDataManipulatorEventArgs.ManipulatorData Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataManipulatorEventArgs.ManipulatorData.GetNavigatorTable Method

Gets the navigator DataTable of the specified navigatorDataSet for this vdxDataManipulatorEventArgs.ManipulatorData.

public virtual DataTable GetNavigatorTable(
DataSet navigatorDataSet
);

Parameters

navigatorDataSet
The dataSet that contains the contains the navigator DataTable.

Return Value

The specified navigator DataTable otherwise null.

See Also

vdxDataManipulatorEventArgs.ManipulatorData Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusChangedEventArgs Class

Provides data for a DataStatusChanged event.

For a list of all members of this type, see vdxDataStatusChangedEventArgs Members.

System.Object
EventArgs
vdxDataStatusChangedEventArgs

public class vdxDataStatusChangedEventArgs : EventArgs

Requirements

Namespace: Deag.Vdx.Controls.EventArguments

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataStatusChangedEventArgs Members | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusChangedEventArgs Members

vdxDataStatusChangedEventArgs overview

Public Instance Constructors

vdxDataStatusChangedEventArgs Constructor Initializes a new instance of vdxDataStatusChangedEventArgs class.

Public Instance Properties

NewState | Gets or sets the new datastatus.
OldState | Gets the old datastatus.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Overrides ToString and returns old state and new state.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxDataStatusChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusChangedEventArgs Constructor

Initializes a new instance of vdxDataStatusChangedEventArgs class.

public vdxDataStatusChangedEventArgs(
vdxDataStatus oldState,
vdxDataStatus newState
);

Parameters

oldState
The old datastatus.
newState
The new datastatus.

See Also

vdxDataStatusChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusChangedEventArgs Properties

The properties of the vdxDataStatusChangedEventArgs class are listed below. For a complete list of vdxDataStatusChangedEventArgs class members, see the vdxDataStatusChangedEventArgs Members topic.

Public Instance Properties

NewState | Gets or sets the new datastatus.
OldState | Gets the old datastatus.

See Also

vdxDataStatusChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusChangedEventArgs.NewState Property

Gets or sets the new datastatus.

public Deag.Vdx.Common.Enums.vdxDataStatus NewState {get; set;}

See Also

vdxDataStatusChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusChangedEventArgs.OldState Property

Gets the old datastatus.

public Deag.Vdx.Common.Enums.vdxDataStatus OldState {get;}

See Also

vdxDataStatusChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusChangedEventArgs Methods

The methods of the vdxDataStatusChangedEventArgs class are listed below. For a complete list of vdxDataStatusChangedEventArgs class members, see the vdxDataStatusChangedEventArgs Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Overrides ToString and returns old state and new state.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxDataStatusChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataStatusChangedEventArgs.ToString Method

Overrides ToString and returns old state and new state.

public override string ToString();

Return Value

: oldState -> newState

See Also

vdxDataStatusChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxInteractiveChangedEventArgs Class

Provides data for a InteractiveChanged event.

For a list of all members of this type, see vdxInteractiveChangedEventArgs Members.

System.Object
EventArgs
vdxInteractiveChangedEventArgs

public class vdxInteractiveChangedEventArgs : EventArgs

Requirements

Namespace: Deag.Vdx.Controls.EventArguments

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxInteractiveChangedEventArgs Members | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxInteractiveChangedEventArgs Members

vdxInteractiveChangedEventArgs overview

Public Instance Constructors

vdxInteractiveChangedEventArgs Constructor Initializes a new instance of the vdxInteractiveChangedEventArgs class.

Public Instance Properties

NewIndex | Gets the New Index.
NewItem | Gets the New Item.
NewValue | Gets the New Value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxInteractiveChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxInteractiveChangedEventArgs Constructor

Initializes a new instance of the vdxInteractiveChangedEventArgs class.

public vdxInteractiveChangedEventArgs(
int newIndex,
object newValue,
object newItem
);

Parameters

newIndex
newValue
newItem

See Also

vdxInteractiveChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxInteractiveChangedEventArgs Properties

The properties of the vdxInteractiveChangedEventArgs class are listed below. For a complete list of vdxInteractiveChangedEventArgs class members, see the vdxInteractiveChangedEventArgs Members topic.

Public Instance Properties

NewIndex | Gets the New Index.
NewItem | Gets the New Item.
NewValue | Gets the New Value.

See Also

vdxInteractiveChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxInteractiveChangedEventArgs.NewIndex Property

Gets the New Index.

public int NewIndex {get;}

See Also

vdxInteractiveChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxInteractiveChangedEventArgs.NewItem Property

Gets the New Item.

public object NewItem {get;}

See Also

vdxInteractiveChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxInteractiveChangedEventArgs.NewValue Property

Gets the New Value.

public object NewValue {get;}

See Also

vdxInteractiveChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorControlEventArgs Class

Provides data for a the SelectedChanged event.

For a list of all members of this type, see vdxNavigatorControlEventArgs Members.

System.Object
EventArgs
vdxNavigatorControlEventArgs

public class vdxNavigatorControlEventArgs : EventArgs

Requirements

Namespace: Deag.Vdx.Controls.EventArguments

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxNavigatorControlEventArgs Members | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorControlEventArgs Members

vdxNavigatorControlEventArgs overview

Public Instance Constructors

vdxNavigatorControlEventArgs Constructor Initializes a new instance of the vdxNavigatorControlEventArgs class.

Public Instance Properties

LoaderInfo Gets the involved vdxLoaderInfo.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxNavigatorControlEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorControlEventArgs Constructor

Initializes a new instance of the vdxNavigatorControlEventArgs class.

public vdxNavigatorControlEventArgs(
vdxLoaderInfo loaderInfo
);

Parameters

loaderInfo
The involved loaderInfo.

See Also

vdxNavigatorControlEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorControlEventArgs Properties

The properties of the vdxNavigatorControlEventArgs class are listed below. For a complete list of vdxNavigatorControlEventArgs class members, see the vdxNavigatorControlEventArgs Members topic.

Public Instance Properties

LoaderInfo Gets the involved vdxLoaderInfo.

See Also

vdxNavigatorControlEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorControlEventArgs.LoaderInfo Property

Gets the involved vdxLoaderInfo.

public Deag.Vdx.Controls.Core.vdxLoaderInfo LoaderInfo {get;}

See Also

vdxNavigatorControlEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorSelectionEventArgs Class

Provides data for a the SelectedChanged event.

For a list of all members of this type, see vdxNavigatorSelectionEventArgs Members.

System.Object
EventArgs
vdxNavigatorSelectionEventArgs

public class vdxNavigatorSelectionEventArgs : EventArgs

Requirements

Namespace: Deag.Vdx.Controls.EventArguments

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxNavigatorSelectionEventArgs Members | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorSelectionEventArgs Members

vdxNavigatorSelectionEventArgs overview

Public Instance Constructors

vdxNavigatorSelectionEventArgs Constructor Initializes a new instance of the vdxDataRowSelectedEventArgs class.

Public Instance Properties

NavigatorInfo Gets the involved vdxNavigatorInfo.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxNavigatorSelectionEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorSelectionEventArgs Constructor

Initializes a new instance of the vdxDataRowSelectedEventArgs class.

public vdxNavigatorSelectionEventArgs(
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorInfo
The selected data row.

See Also

vdxNavigatorSelectionEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorSelectionEventArgs Properties

The properties of the vdxNavigatorSelectionEventArgs class are listed below. For a complete list of vdxNavigatorSelectionEventArgs class members, see the vdxNavigatorSelectionEventArgs Members topic.

Public Instance Properties

NavigatorInfo Gets the involved vdxNavigatorInfo.

See Also

vdxNavigatorSelectionEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxNavigatorSelectionEventArgs.NavigatorInfo Property

Gets the involved vdxNavigatorInfo.

public Deag.Vdx.Controls.Core.vdxNavigatorInfo NavigatorInfo {get;}

See Also

vdxNavigatorSelectionEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupClickedEventArgs Class

Provides data for the OutlookBarGroupClicked event.

For a list of all members of this type, see vdxOutlookBarGroupClickedEventArgs Members.

System.Object
EventArgs
vdxOutlookBarGroupClickedEventArgs

public class vdxOutlookBarGroupClickedEventArgs : EventArgs

Requirements

Namespace: Deag.Vdx.Controls.EventArguments

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxOutlookBarGroupClickedEventArgs Members | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupClickedEventArgs Members

vdxOutlookBarGroupClickedEventArgs overview

Public Instance Constructors

vdxOutlookBarGroupClickedEventArgs Constructor Constructor.

Public Instance Properties

VdxOutlookBarGroup Gets the outlookbar group.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxOutlookBarGroupClickedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupClickedEventArgs Constructor

Constructor.

public vdxOutlookBarGroupClickedEventArgs(
vdxOutlookBarGroup vdxOutlookBarGroup
);

Parameters

vdxOutlookBarGroup
The clicked outlookbar group

See Also

vdxOutlookBarGroupClickedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupClickedEventArgs Properties

The properties of the vdxOutlookBarGroupClickedEventArgs class are listed below. For a complete list of vdxOutlookBarGroupClickedEventArgs class members, see the vdxOutlookBarGroupClickedEventArgs Members topic.

Public Instance Properties

VdxOutlookBarGroup Gets the outlookbar group.

See Also

vdxOutlookBarGroupClickedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupClickedEventArgs.VdxOutlookBarGroup Property

Gets the outlookbar group.

public Deag.Vdx.Controls.Standard.vdxOutlookBarGroup VdxOutlookBarGroup {get;}

See Also

vdxOutlookBarGroupClickedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupClickingEventArgs Class

Provides data for the OutlookBarGroupClicking event.

For a list of all members of this type, see vdxOutlookBarGroupClickingEventArgs Members.

System.Object
EventArgs
CancelEventArgs
vdxOutlookBarGroupClickingEventArgs

public class vdxOutlookBarGroupClickingEventArgs : CancelEventArgs

Requirements

Namespace: Deag.Vdx.Controls.EventArguments

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxOutlookBarGroupClickingEventArgs Members | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupClickingEventArgs Members

vdxOutlookBarGroupClickingEventArgs overview

Public Instance Constructors

vdxOutlookBarGroupClickingEventArgs Constructor Constructor.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
VdxOutlookBarGroup | Gets the outlookbar group.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxOutlookBarGroupClickingEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupClickingEventArgs Constructor

Constructor.

public vdxOutlookBarGroupClickingEventArgs(
vdxOutlookBarGroup vdxOutlookBarGroup,
bool cancel
);

Parameters

vdxOutlookBarGroup
The clicked outlookbar group
cancel
The flag to cancel the event.

See Also

vdxOutlookBarGroupClickingEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupClickingEventArgs Properties

The properties of the vdxOutlookBarGroupClickingEventArgs class are listed below. For a complete list of vdxOutlookBarGroupClickingEventArgs class members, see the vdxOutlookBarGroupClickingEventArgs Members topic.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
VdxOutlookBarGroup | Gets the outlookbar group.

See Also

vdxOutlookBarGroupClickingEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupClickingEventArgs.VdxOutlookBarGroup Property

Gets the outlookbar group.

public Deag.Vdx.Controls.Standard.vdxOutlookBarGroup VdxOutlookBarGroup {get;}

See Also

vdxOutlookBarGroupClickingEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconClickedEventArgs Class

Provides data for the OutlookbarIconClicked event.

For a list of all members of this type, see vdxOutlookBarIconClickedEventArgs Members.

System.Object
EventArgs
vdxOutlookBarIconClickedEventArgs

public class vdxOutlookBarIconClickedEventArgs : EventArgs

Requirements

Namespace: Deag.Vdx.Controls.EventArguments

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxOutlookBarIconClickedEventArgs Members | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconClickedEventArgs Members

vdxOutlookBarIconClickedEventArgs overview

Public Instance Constructors

vdxOutlookBarIconClickedEventArgs Constructor Constructor.

Public Instance Properties

VdxOutlookBarIcon Gets the outlookbar icon.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxOutlookBarIconClickedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconClickedEventArgs Constructor

Constructor.

public vdxOutlookBarIconClickedEventArgs(
vdxOutlookBarIcon vdxOutlookBarIcon
);

Parameters

vdxOutlookBarIcon
The clicked outlookbar icon.

See Also

vdxOutlookBarIconClickedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconClickedEventArgs Properties

The properties of the vdxOutlookBarIconClickedEventArgs class are listed below. For a complete list of vdxOutlookBarIconClickedEventArgs class members, see the vdxOutlookBarIconClickedEventArgs Members topic.

Public Instance Properties

VdxOutlookBarIcon Gets the outlookbar icon.

See Also

vdxOutlookBarIconClickedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconClickedEventArgs.VdxOutlookBarIcon Property

Gets the outlookbar icon.

public Deag.Vdx.Controls.Standard.vdxOutlookBarIcon VdxOutlookBarIcon {get;}

See Also

vdxOutlookBarIconClickedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconClickingEventArgs Class

Provides data for the OutlookbarIconClicking event.

For a list of all members of this type, see vdxOutlookBarIconClickingEventArgs Members.

System.Object
EventArgs
CancelEventArgs
vdxOutlookBarIconClickingEventArgs

public class vdxOutlookBarIconClickingEventArgs : CancelEventArgs

Requirements

Namespace: Deag.Vdx.Controls.EventArguments

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxOutlookBarIconClickingEventArgs Members | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconClickingEventArgs Members

vdxOutlookBarIconClickingEventArgs overview

Public Instance Constructors

vdxOutlookBarIconClickingEventArgs Constructor Constructor.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
VdxOutlookBarIcon | Gets the outlookbar icon.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxOutlookBarIconClickingEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconClickingEventArgs Constructor

Constructor.

public vdxOutlookBarIconClickingEventArgs(
vdxOutlookBarIcon vdxOutlookBarIcon,
bool cancel
);

Parameters

vdxOutlookBarIcon
The clicked outlookbar icon.
cancel
The flag to cancel the event.

See Also

vdxOutlookBarIconClickingEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconClickingEventArgs Properties

The properties of the vdxOutlookBarIconClickingEventArgs class are listed below. For a complete list of vdxOutlookBarIconClickingEventArgs class members, see the vdxOutlookBarIconClickingEventArgs Members topic.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
VdxOutlookBarIcon | Gets the outlookbar icon.

See Also

vdxOutlookBarIconClickingEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconClickingEventArgs.VdxOutlookBarIcon Property

Gets the outlookbar icon.

public Deag.Vdx.Controls.Standard.vdxOutlookBarIcon VdxOutlookBarIcon {get;}

See Also

vdxOutlookBarIconClickingEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionClickedEventArgs Class

Provides data for the OutlookbarIconSelectionClicked event.

For a list of all members of this type, see vdxOutlookBarIconSelectionClickedEventArgs Members.

System.Object
EventArgs
vdxOutlookBarIconSelectionClickedEventArgs

public class vdxOutlookBarIconSelectionClickedEventArgs : EventArgs

Requirements

Namespace: Deag.Vdx.Controls.EventArguments

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxOutlookBarIconSelectionClickedEventArgs Members | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionClickedEventArgs Members

vdxOutlookBarIconSelectionClickedEventArgs overview

Public Instance Constructors

vdxOutlookBarIconSelectionClickedEventArgs Constructor Constructor.

Public Instance Properties

SearchParameters | Gets the outlookbar icon.
VdxOutlookBarIcon | Gets the outlookbar icon.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxOutlookBarIconSelectionClickedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionClickedEventArgs Constructor

Constructor.

public vdxOutlookBarIconSelectionClickedEventArgs(
vdxOutlookBarIconSelection icon,
vdxSearchParameters sp
);

Parameters

icon
The clicked outlookbar icon.
sp
vdxSearchParameters

See Also

vdxOutlookBarIconSelectionClickedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionClickedEventArgs Properties

The properties of the vdxOutlookBarIconSelectionClickedEventArgs class are listed below. For a complete list of vdxOutlookBarIconSelectionClickedEventArgs class members, see the vdxOutlookBarIconSelectionClickedEventArgs Members topic.

Public Instance Properties

SearchParameters | Gets the outlookbar icon.
VdxOutlookBarIcon | Gets the outlookbar icon.

See Also

vdxOutlookBarIconSelectionClickedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionClickedEventArgs.SearchParameters Property

Gets the outlookbar icon.

public Deag.Vdx.Common.vdxSearchParameters SearchParameters {get;}

See Also

vdxOutlookBarIconSelectionClickedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionClickedEventArgs.VdxOutlookBarIcon Property

Gets the outlookbar icon.

public Deag.Vdx.Controls.Standard.vdxOutlookBarIconSelection VdxOutlookBarIcon {get;}

See Also

vdxOutlookBarIconSelectionClickedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionClickingEventArgs Class

Provides data for the OutlookbarIconSelectionClicking event.

For a list of all members of this type, see vdxOutlookBarIconSelectionClickingEventArgs Members.

System.Object
EventArgs
CancelEventArgs
vdxOutlookBarIconSelectionClickingEventArgs

public class vdxOutlookBarIconSelectionClickingEventArgs : CancelEventArgs

Requirements

Namespace: Deag.Vdx.Controls.EventArguments

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxOutlookBarIconSelectionClickingEventArgs Members | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionClickingEventArgs Members

vdxOutlookBarIconSelectionClickingEventArgs overview

Public Instance Constructors

vdxOutlookBarIconSelectionClickingEventArgs Constructor Constructor.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
SearchParameters | Gets the outlookbar icon.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxOutlookBarIconSelectionClickingEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionClickingEventArgs Constructor

Constructor.

public vdxOutlookBarIconSelectionClickingEventArgs(
vdxSearchParameters sp,
bool cancel
);

Parameters

sp
vdxSearchParameters
cancel
The flag to cancel the event.

See Also

vdxOutlookBarIconSelectionClickingEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionClickingEventArgs Properties

The properties of the vdxOutlookBarIconSelectionClickingEventArgs class are listed below. For a complete list of vdxOutlookBarIconSelectionClickingEventArgs class members, see the vdxOutlookBarIconSelectionClickingEventArgs Members topic.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
SearchParameters | Gets the outlookbar icon.

See Also

vdxOutlookBarIconSelectionClickingEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionClickingEventArgs.SearchParameters Property

Gets the outlookbar icon.

public Deag.Vdx.Common.vdxSearchParameters SearchParameters {get;}

See Also

vdxOutlookBarIconSelectionClickingEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionDeletedEventArgs Class

Provides data for the OutlookbarIconSelectionDeleted event.

For a list of all members of this type, see vdxOutlookBarIconSelectionDeletedEventArgs Members.

System.Object
EventArgs
vdxOutlookBarIconSelectionDeletedEventArgs

public class vdxOutlookBarIconSelectionDeletedEventArgs : EventArgs

Requirements

Namespace: Deag.Vdx.Controls.EventArguments

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxOutlookBarIconSelectionDeletedEventArgs Members | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionDeletedEventArgs Members

vdxOutlookBarIconSelectionDeletedEventArgs overview

Public Instance Constructors

vdxOutlookBarIconSelectionDeletedEventArgs Constructor Constructor.

Public Instance Properties

VdxOutlookBarIcon Gets the outlookbar icon.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxOutlookBarIconSelectionDeletedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionDeletedEventArgs Constructor

Constructor.

public vdxOutlookBarIconSelectionDeletedEventArgs(
vdxOutlookBarIconSelection icon
);

Parameters

icon
The clicked outlookbar icon.

See Also

vdxOutlookBarIconSelectionDeletedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionDeletedEventArgs Properties

The properties of the vdxOutlookBarIconSelectionDeletedEventArgs class are listed below. For a complete list of vdxOutlookBarIconSelectionDeletedEventArgs class members, see the vdxOutlookBarIconSelectionDeletedEventArgs Members topic.

Public Instance Properties

VdxOutlookBarIcon Gets the outlookbar icon.

See Also

vdxOutlookBarIconSelectionDeletedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionDeletedEventArgs.VdxOutlookBarIcon Property

Gets the outlookbar icon.

public Deag.Vdx.Controls.Standard.vdxOutlookBarIconSelection VdxOutlookBarIcon {get;}

See Also

vdxOutlookBarIconSelectionDeletedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionRenamedEventArgs Class

Provides data for the OutlookbarIconSelectionRenamed event.

For a list of all members of this type, see vdxOutlookBarIconSelectionRenamedEventArgs Members.

System.Object
EventArgs
vdxOutlookBarIconSelectionRenamedEventArgs

public class vdxOutlookBarIconSelectionRenamedEventArgs : EventArgs

Requirements

Namespace: Deag.Vdx.Controls.EventArguments

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxOutlookBarIconSelectionRenamedEventArgs Members | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionRenamedEventArgs Members

vdxOutlookBarIconSelectionRenamedEventArgs overview

Public Instance Constructors

vdxOutlookBarIconSelectionRenamedEventArgs Constructor Constructor.

Public Instance Properties

VdxOutlookBarIcon Gets the outlookbar icon.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxOutlookBarIconSelectionRenamedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionRenamedEventArgs Constructor

Constructor.

public vdxOutlookBarIconSelectionRenamedEventArgs(
vdxOutlookBarIconSelection icon
);

Parameters

icon
The clicked outlookbar icon.

See Also

vdxOutlookBarIconSelectionRenamedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionRenamedEventArgs Properties

The properties of the vdxOutlookBarIconSelectionRenamedEventArgs class are listed below. For a complete list of vdxOutlookBarIconSelectionRenamedEventArgs class members, see the vdxOutlookBarIconSelectionRenamedEventArgs Members topic.

Public Instance Properties

VdxOutlookBarIcon Gets the outlookbar icon.

See Also

vdxOutlookBarIconSelectionRenamedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionRenamedEventArgs.VdxOutlookBarIcon Property

Gets the outlookbar icon.

public Deag.Vdx.Controls.Standard.vdxOutlookBarIconSelection VdxOutlookBarIcon {get;}

See Also

vdxOutlookBarIconSelectionRenamedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionSizeChangedEventArgs Class

Provides data for the OutlookbarIconSelectionSizeChanged event.

For a list of all members of this type, see vdxOutlookBarIconSelectionSizeChangedEventArgs Members.

System.Object
EventArgs
vdxOutlookBarIconSelectionSizeChangedEventArgs

public class vdxOutlookBarIconSelectionSizeChangedEventArgs : EventArgs

Requirements

Namespace: Deag.Vdx.Controls.EventArguments

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxOutlookBarIconSelectionSizeChangedEventArgs Members | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionSizeChangedEventArgs Members

vdxOutlookBarIconSelectionSizeChangedEventArgs overview

Public Instance Constructors

vdxOutlookBarIconSelectionSizeChangedEventArgs Constructor Constructor.

Public Instance Properties

VdxOutlookBarIconSelectionList Gets the outlookbar icon.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxOutlookBarIconSelectionSizeChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionSizeChangedEventArgs Constructor

Constructor.

public vdxOutlookBarIconSelectionSizeChangedEventArgs(
vdxOutlookBarIconSelectionList iconList
);

See Also

vdxOutlookBarIconSelectionSizeChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionSizeChangedEventArgs Properties

The properties of the vdxOutlookBarIconSelectionSizeChangedEventArgs class are listed below. For a complete list of vdxOutlookBarIconSelectionSizeChangedEventArgs class members, see the vdxOutlookBarIconSelectionSizeChangedEventArgs Members topic.

Public Instance Properties

VdxOutlookBarIconSelectionList Gets the outlookbar icon.

See Also

vdxOutlookBarIconSelectionSizeChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionSizeChangedEventArgs.VdxOutlookBarIconSelectionList Property

Gets the outlookbar icon.

public Deag.Vdx.Controls.Standard.vdxOutlookBarIconSelectionList VdxOutlookBarIconSelectionList {get;}

See Also

vdxOutlookBarIconSelectionSizeChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerEventArgs Class

Provides data for a vdxPickerEventArgs event.

For a list of all members of this type, see vdxPickerEventArgs Members.

System.Object
EventArgs
vdxPickerEventArgs

public class vdxPickerEventArgs : EventArgs

Requirements

Namespace: Deag.Vdx.Controls.EventArguments

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxPickerEventArgs Members | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerEventArgs Members

vdxPickerEventArgs overview

Public Instance Constructors

vdxPickerEventArgs Constructor Initializes a new instance of the vdxPickerEventArgs class.

Public Instance Properties

PickerInfo Gets the vdxPickerInfo object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxPickerEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerEventArgs Constructor

Initializes a new instance of the vdxPickerEventArgs class.

public vdxPickerEventArgs(
vdxPickerInfo pickerInfo
);

Parameters

pickerInfo
The vdxPickerInfo object.

See Also

vdxPickerEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerEventArgs Properties

The properties of the vdxPickerEventArgs class are listed below. For a complete list of vdxPickerEventArgs class members, see the vdxPickerEventArgs Members topic.

Public Instance Properties

PickerInfo Gets the vdxPickerInfo object.

See Also

vdxPickerEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerEventArgs.PickerInfo Property

Gets the vdxPickerInfo object.

public Deag.Vdx.Controls.Standard.vdxPickerInfo PickerInfo {get;}

See Also

vdxPickerEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPossibleOperationsChangedEventArgs Class

Provides data for a PossibleOperationsChanged event.

For a list of all members of this type, see vdxPossibleOperationsChangedEventArgs Members.

System.Object
EventArgs
vdxPossibleOperationsChangedEventArgs

public class vdxPossibleOperationsChangedEventArgs : EventArgs

Requirements

Namespace: Deag.Vdx.Controls.EventArguments

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxPossibleOperationsChangedEventArgs Members | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPossibleOperationsChangedEventArgs Members

vdxPossibleOperationsChangedEventArgs overview

Public Instance Constructors

vdxPossibleOperationsChangedEventArgs Constructor Initializes a new instance of the vdxAllowOperationsChangedEventArgs class.

Public Instance Properties

PossibleOperations Gets the allowed operations.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | A string representation of the possible operations.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxPossibleOperationsChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPossibleOperationsChangedEventArgs Constructor

Initializes a new instance of the vdxAllowOperationsChangedEventArgs class.

public vdxPossibleOperationsChangedEventArgs(
vdxPossibleOperations possibleOperations
);

Parameters

possibleOperations
The allowed operations.

See Also

vdxPossibleOperationsChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPossibleOperationsChangedEventArgs Properties

The properties of the vdxPossibleOperationsChangedEventArgs class are listed below. For a complete list of vdxPossibleOperationsChangedEventArgs class members, see the vdxPossibleOperationsChangedEventArgs Members topic.

Public Instance Properties

PossibleOperations Gets the allowed operations.

See Also

vdxPossibleOperationsChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPossibleOperationsChangedEventArgs.PossibleOperations Property

Gets the allowed operations.

public Deag.Vdx.Controls.Core.vdxPossibleOperations PossibleOperations {get;}

See Also

vdxPossibleOperationsChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPossibleOperationsChangedEventArgs Methods

The methods of the vdxPossibleOperationsChangedEventArgs class are listed below. For a complete list of vdxPossibleOperationsChangedEventArgs class members, see the vdxPossibleOperationsChangedEventArgs Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | A string representation of the possible operations.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxPossibleOperationsChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPossibleOperationsChangedEventArgs.ToString Method

A string representation of the possible operations.

public override string ToString();

Return Value

String representation of the possible operations.

Remarks

This method can conveniently be used during debugging.

See Also

vdxPossibleOperationsChangedEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParametersFilledEventArgs Class

Provides data for a vdxSearchParametersFilled event.

For a list of all members of this type, see vdxSearchParametersFilledEventArgs Members.

System.Object
EventArgs
vdxSearchParametersFilledEventArgs

public class vdxSearchParametersFilledEventArgs : EventArgs

Requirements

Namespace: Deag.Vdx.Controls.EventArguments

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxSearchParametersFilledEventArgs Members | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParametersFilledEventArgs Members

vdxSearchParametersFilledEventArgs overview

Public Instance Constructors

vdxSearchParametersFilledEventArgs Constructor Initializes a new instance of the vdxSearchParametersFilledEventArgs class.

Public Instance Properties

SearchParameters Gets the vdxSearchParameters object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxSearchParametersFilledEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParametersFilledEventArgs Constructor

Initializes a new instance of the vdxSearchParametersFilledEventArgs class.

public vdxSearchParametersFilledEventArgs(
vdxSearchParameters vdxSearchParams
);

Parameters

vdxSearchParams
The vdxSearchParameters object.

See Also

vdxSearchParametersFilledEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParametersFilledEventArgs Properties

The properties of the vdxSearchParametersFilledEventArgs class are listed below. For a complete list of vdxSearchParametersFilledEventArgs class members, see the vdxSearchParametersFilledEventArgs Members topic.

Public Instance Properties

SearchParameters Gets the vdxSearchParameters object.

See Also

vdxSearchParametersFilledEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSearchParametersFilledEventArgs.SearchParameters Property

Gets the vdxSearchParameters object.

public Deag.Vdx.Common.vdxSearchParameters SearchParameters {get;}

See Also

vdxSearchParametersFilledEventArgs Class | Deag.Vdx.Controls.EventArguments Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Controls.Standard

VDX Framework

Deag.Vdx.Controls.Standard Namespace

Classes

Class | Description
vdxCheckGroupBox | Specialized GroupBox with a CheckBox as titled component.
vdxDataPickField |
vdxDatePickerDialog | Popup Form with a Calendar control to pick a valid date.
vdxDatePickField | Derived vdxPickField class that handles a date field.
vdxExplorerGrid | Explorer used for the reference tables management.
vdxExplorerGridView | A specialized vdxDataGridNavigator which can delegate commands to a vdxExplorerGrid.
vdxExplorerTree | Control used for standard exploring capabilities with a treeview.
vdxExplorerTreeView | Specialized treeView used in the standard vdxExplorerTree.
vdxListChooser | Use this control to select one or more elements from a pool of items.
vdxOutlookBar | The vdxOutlookBar control.
vdxOutlookBarGroup | The class which represents an outlookbar group item.
vdxOutlookBarGroupList | Array list of all vdxOutlookBar groups within the outlookbar.
vdxOutlookBarIcon | The individual outlookbar icon where the user can click on to invoke an action.
vdxOutlookBarIconList | Array list of vdxOutlookBarIcon objects for a specific vdxOutlookBarGroup.
vdxOutlookBarIconSelection | Class which represents a vdxOutlookBarIcon which has been dragged and dropped on the outlookbar.
vdxOutlookBarIconSelectionList | Array list of vdxOutlookBarIconSelection objects.
vdxPickerDialog | The base class for all picker dialogs in a foreign key picklist scenario used in the vdxPickField class.
vdxPickerInfo | Communication media between vdxPickField and IvdxPicker.
vdxPickField | Base class for a foreign key validation scenario.
vdxSelectionGrid | A specialized vdxDataGridNavigator which also is a IvdxMultiContainerCacheable control.

Enumerations

Enumeration | Description
vdxDateRangeType | Defines the range types of the Date property of a vdxDataPickField.
vdxListChooserAppearance | The appeareance types for the ListChooser.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox Class

Specialized GroupBox with a CheckBox as titled component.

For a list of all members of this type, see vdxCheckGroupBox Members.

System.Object
MarshalByRefObject
Component
Control
GroupBox
vdxCheckGroupBox

public class vdxCheckGroupBox : GroupBox, IvdxInputControl, IvdxDsmHost, IvdxResettable, IvdxBindingManagable, IvdxBindable

Remarks

All child controls placed on this control are enabled or disabled, if the titled check box is checked or unchecked.

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxCheckGroupBox Members | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox Members

vdxCheckGroupBox overview

Public Instance Constructors

vdxCheckGroupBox Constructor The default constructor.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from GroupBox) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindEmptyValuesAsNull | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus | See CanFocus
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Checked | Gets or set a value indicating whether the check box is in the checked state.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings | Gets the data bindings for the control.
DisplayRectangle (inherited from GroupBox) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled | Gets or sets indicating whether the groupBox and its child controls are enabled or disabled.
FlatStyle (inherited from GroupBox) | Gets or sets the flat style appearance of the group box control.
Focused | Overrides Focused
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM | Gets/sets a value indicating whether the CheckBox interacts with the DSM. If set to true then the CheckBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from GroupBox) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Gets or sets the title of the group box.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from GroupBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from GroupBox) |
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from GroupBox) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from GroupBox) |
KeyPress (inherited from GroupBox) |
KeyUp (inherited from GroupBox) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from GroupBox) |
MouseEnter (inherited from GroupBox) |
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from GroupBox) |
MouseMove (inherited from GroupBox) |
MouseUp (inherited from GroupBox) |
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from GroupBox) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

checkBox | The check box of the title component.
label | The label of the title component.

Protected Instance Properties

CreateParams (inherited from GroupBox) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from GroupBox) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl | Overrides OnCreateControl to disable all child controls.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from GroupBox) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from GroupBox) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from GroupBox) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from GroupBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager

Explicit Interface Implementations

IvdxInputControl.InitializeBinding | Do any initializing work like converting format.
IvdxResettable.Reset |

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox Constructor

The default constructor.

public vdxCheckGroupBox();

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox Fields

The fields of the vdxCheckGroupBox class are listed below. For a complete list of vdxCheckGroupBox class members, see the vdxCheckGroupBox Members topic.

Protected Instance Fields

checkBox | The check box of the title component.
label | The label of the title component.

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox.checkBox Field

The check box of the title component.

protected vdxCheckBox checkBox;

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox.label Field

The label of the title component.

protected Label label;

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox Properties

The properties of the vdxCheckGroupBox class are listed below. For a complete list of vdxCheckGroupBox class members, see the vdxCheckGroupBox Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from GroupBox) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindEmptyValuesAsNull | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus | See CanFocus
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Checked | Gets or set a value indicating whether the check box is in the checked state.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings | Gets the data bindings for the control.
DisplayRectangle (inherited from GroupBox) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled | Gets or sets indicating whether the groupBox and its child controls are enabled or disabled.
FlatStyle (inherited from GroupBox) | Gets or sets the flat style appearance of the group box control.
Focused | Overrides Focused
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM | Gets/sets a value indicating whether the CheckBox interacts with the DSM. If set to true then the CheckBox will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from GroupBox) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Gets or sets the title of the group box.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from GroupBox) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from GroupBox) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox.BindEmptyValuesAsNull Property

Gets or sets whether the empty values must be binded as null.

public bool BindEmptyValuesAsNull {get; set;}

Implements

IvdxInputControl.BindEmptyValuesAsNull

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox.CanFocus Property

See CanFocus

new public bool CanFocus {get;}

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox.Checked Property

Gets or set a value indicating whether the check box is in the checked state.

public bool Checked {get; set;}

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox.DataBindings Property

Gets the data bindings for the control.

new public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox.Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager Property

private Deag.Vdx.Controls.Core.vdxDataStatusManager Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager {get; set;}

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox.Enabled Property

Gets or sets indicating whether the groupBox and its child controls are enabled or disabled.

new public bool Enabled {get; set;}

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox.Focused Property

Overrides Focused

public override bool Focused {get;}

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox.InteractWithDSM Property

Gets/sets a value indicating whether the CheckBox interacts with the DSM. If set to true then the CheckBox will not force an AutoEdit on the DSM. Default value = true;

public bool InteractWithDSM {get; set;}

Implements

IvdxInputControl.InteractWithDSM

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox.Text Property

Gets or sets the title of the group box.

new public string Text {get; set;}

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox Methods

The methods of the vdxCheckGroupBox class are listed below. For a complete list of vdxCheckGroupBox class members, see the vdxCheckGroupBox Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from GroupBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl | Overrides OnCreateControl to disable all child controls.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from GroupBox) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from GroupBox) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from GroupBox) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from GroupBox) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IvdxInputControl.InitializeBinding | Do any initializing work like converting format.
IvdxResettable.Reset |

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox.IvdxInputControl.InitializeBinding Method

Do any initializing work like converting format.

void IvdxInputControl.InitializeBinding(
Binding binding
);

Implements

IvdxInputControl.InitializeBinding

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox.IvdxResettable.Reset Method

void IvdxResettable.Reset();

Implements

IvdxResettable.Reset

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Dispose Method

VDX Framework

vdxCheckGroupBox.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox.Dispose Method (Boolean)

Clean up any resources being used.

protected override void Dispose(
bool disposing
);

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace | vdxCheckGroupBox.Dispose Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox.OnCreateControl Method

Overrides OnCreateControl to disable all child controls.

protected override void OnCreateControl();

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxCheckGroupBox.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxCheckGroupBox Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataPickField Class

For a list of all members of this type, see vdxDataPickField Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxPickField
vdxDataPickField

public class vdxDataPickField : vdxPickField

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDataPickField Members | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataPickField Members

vdxDataPickField overview

Public Instance Constructors

vdxDataPickField Constructor Default constructor.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoStartPicker (inherited from vdxPickField) | Gets or sets if this IvdxPicker should be started automatically if code field validation fails.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindEmptyValuesAsNull (inherited from vdxPickField) | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from ContainerControl) |
BindingInfos (inherited from vdxPickField) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from vdxPickField) | See CanFocus
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CodeWidth (inherited from vdxPickField) | Gets or sets the width of the Code Textbox.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos (inherited from vdxPickField) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from vdxPickField) | Gets or sets a value indicating whether control can respond to user interaction.
Focused (inherited from vdxPickField) | Overrides Focused
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideButtonOpenPicker (inherited from vdxPickField) | Gets or sets whether the button open picker is visible or not.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM (inherited from vdxPickField) | Gets/sets a value indicating whether the PickField interacts with the DSM. If set to true then the PickField will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PickCode (inherited from vdxPickField) | Gets or sets the code that can be uniquely identified.
PickCodeIsNull (inherited from vdxPickField) | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
PickDescription (inherited from vdxPickField) | Gets or sets the description the correspond to the code field or foreign key.
PickDescriptionIsNull (inherited from vdxPickField) | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
PickerClassName (inherited from vdxPickField) | Gets or sets the full qualified string representation of the derived IvdxPicker.
PickForeignKey (inherited from vdxPickField) | Gets or sets the foreign key.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from vdxPickField) | Gets or sets a value indicating whether text in text box code is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxPickField) | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Reset (inherited from vdxPickField) | Resets the vdxPickField
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBindingInfo (inherited from vdxPickField) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetPickValues (inherited from vdxPickField) | Overloaded. Sets the values of the vdxPickField.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PickCodeChanged (inherited from vdxPickField) | Occurs after the PickCode field has changed.
PickDescriptionChanged (inherited from vdxPickField) | Occurs after the PickDescription field has changed.
PickForeignKeyChanged (inherited from vdxPickField) | Occurs after the PickForeignKey field has changed.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

btnClear (inherited from vdxPickField) | Clear button.
btnOpenPicker (inherited from vdxPickField) | Open picker button.
manuallyChanged (inherited from vdxPickField) | Indicates whether the code field was changed by code flow or by user inter action.
picker (inherited from vdxPickField) | Picker instance.
txtCode (inherited from vdxPickField) | Code field.
txtDescription (inherited from vdxPickField) | Description field.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from vdxPickField) | Overloaded. Releases all resources used by the Component.
FillData | Overloaded. Override this method to set the description after the pickfield has return from the server round trip to validate the entered code. Use only when the code textbox is visible.
FillSearchParameters | Override this method to fill the searchparameter used for validate the value that was entered in the code field. Use only when the code field is visible.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsValid | Checks if code field is valid.
LoadData | Loads the data for the corresponding vdxSearchParameters.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from vdxPickField) | Overrides OnPaint.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from vdxPickField) | Overrides OnResize.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from vdxPickField) | Overrides OnValidating.
OnVisibleChanged (inherited from ScrollableControl) |
OpenPicker (inherited from vdxPickField) | Opens the picker to select an entry.
Picker_PickerAccepted (inherited from vdxPickField) | Event listener to react on PickerClassName acception of an new entry.
PickerActivated (inherited from vdxPickField) | Occurs when the IvdxPicker is activated. Can be used to set the values from the pickfield to the IvdxPicker.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RemovePicker (inherited from vdxPickField) | Removes the instance of the picker
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl) |
IvdxInputControl.InitializeBinding (inherited from vdxPickField) | Do any initializing work like converting format.
IvdxResettable.Reset (inherited from vdxPickField) | Resets the values of the fields to the empty string.

See Also

vdxDataPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataPickField Constructor

Default constructor.

public vdxDataPickField();

See Also

vdxDataPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataPickField Methods

The methods of the vdxDataPickField class are listed below. For a complete list of vdxDataPickField class members, see the vdxDataPickField Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxPickField) | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Reset (inherited from vdxPickField) | Resets the vdxPickField
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBindingInfo (inherited from vdxPickField) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetPickValues (inherited from vdxPickField) | Overloaded. Sets the values of the vdxPickField.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from vdxPickField) | Overloaded. Releases all resources used by the Component.
FillData | Overloaded. Override this method to set the description after the pickfield has return from the server round trip to validate the entered code. Use only when the code textbox is visible.
FillSearchParameters | Override this method to fill the searchparameter used for validate the value that was entered in the code field. Use only when the code field is visible.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsValid | Checks if code field is valid.
LoadData | Loads the data for the corresponding vdxSearchParameters.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from vdxPickField) | Overrides OnPaint.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from vdxPickField) | Overrides OnResize.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from vdxPickField) | Overrides OnValidating.
OnVisibleChanged (inherited from ScrollableControl) |
OpenPicker (inherited from vdxPickField) | Opens the picker to select an entry.
Picker_PickerAccepted (inherited from vdxPickField) | Event listener to react on PickerClassName acception of an new entry.
PickerActivated (inherited from vdxPickField) | Occurs when the IvdxPicker is activated. Can be used to set the values from the pickfield to the IvdxPicker.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RemovePicker (inherited from vdxPickField) | Removes the instance of the picker
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl) |
IvdxInputControl.InitializeBinding (inherited from vdxPickField) | Do any initializing work like converting format.
IvdxResettable.Reset (inherited from vdxPickField) | Resets the values of the fields to the empty string.

See Also

vdxDataPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FillData Method

VDX Framework

vdxDataPickField.FillData Method

Fill up description field.

Overload List

Fill up description field.

protected override void FillData();

Override this method to set the description after the pickfield has return from the server round trip to validate the entered code. Use only when the code textbox is visible.

protected virtual void FillData(DataSet);

See Also

vdxDataPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataPickField.FillData Method ()

Fill up description field.

protected override void FillData();

See Also

vdxDataPickField Class | Deag.Vdx.Controls.Standard Namespace | vdxDataPickField.FillData Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataPickField.FillData Method (DataSet)

Override this method to set the description after the pickfield has return from the server round trip to validate the entered code. Use only when the code textbox is visible.

protected virtual void FillData(
DataSet dataSet
);

Parameters

dataSet
The dataset returned by the server

See Also

vdxDataPickField Class | Deag.Vdx.Controls.Standard Namespace | vdxDataPickField.FillData Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataPickField.FillSearchParameters Method

Override this method to fill the searchparameter used for validate the value that was entered in the code field. Use only when the code field is visible.

protected virtual vdxSearchParameters FillSearchParameters();

Return Value

See Also

vdxDataPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataPickField.IsValid Method

Checks if code field is valid.

protected override bool IsValid();

Return Value

True if code field contains a valid value.

See Also

vdxDataPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDataPickField.LoadData Method

Loads the data for the corresponding vdxSearchParameters.

protected virtual DataSet LoadData(
vdxSearchParameters searchParameters
);

Parameters

searchParameters
A collection of search parameter.

Return Value

The corresponding dataSet for the given searchParameters.

See Also

vdxDataPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog Class

Popup Form with a Calendar control to pick a valid date.

For a list of all members of this type, see vdxDatePickerDialog Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
vdxDatePickerDialog

public class vdxDatePickerDialog : Form, IvdxPicker

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDatePickerDialog Members | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog Members

vdxDatePickerDialog overview

Public Instance Constructors

vdxDatePickerDialog Constructor Initializes a new instance of the vdxDatePickerDialog class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Date | Gets or sets the DateTime value.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PickField |
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PickerAccepted | Occurs when the value or values were accepted.
PickerCancelled | Occurs when the picker routine was canceled.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

btnCancel
btnOK
calMonthCalendar
pickField
pnlButtons
pnlCalendar

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
btnCancel_Click | Handles the Click event of the Cancel Button object.
btnOK_Click | Handles the Click event of the OK Button object.
CalMonthCalendar_DateSelected | Handles the DateSelected event of the calendar object.
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPickerAccepted | Raises the PickerAccepted event.
OnPickerCancelled | Raises the PickerCancelled event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
vdxCalendarPopupForm_Resize | Handles the Resize event of the form. It makes sure that the form is always big enough to show the complete calendar.
WndProc (inherited from Form) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxPicker.Clear
IvdxPicker.Close
IvdxPicker.Show

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog Constructor

Initializes a new instance of the vdxDatePickerDialog class.

public vdxDatePickerDialog();

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog Fields

The fields of the vdxDatePickerDialog class are listed below. For a complete list of vdxDatePickerDialog class members, see the vdxDatePickerDialog Members topic.

Protected Instance Fields

btnCancel
btnOK
calMonthCalendar
pickField
pnlButtons
pnlCalendar

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog.btnCancel Field

protected Button btnCancel;

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog.btnOK Field

protected Button btnOK;

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog.calMonthCalendar Field

protected MonthCalendar calMonthCalendar;

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog.PickField Property

public System.Windows.Forms.Control PickField {get; set;}

Implements

IvdxPicker.PickField

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog.pnlButtons Field

protected Panel pnlButtons;

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog.pnlCalendar Field

protected Panel pnlCalendar;

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog Properties

The properties of the vdxDatePickerDialog class are listed below. For a complete list of vdxDatePickerDialog class members, see the vdxDatePickerDialog Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Date | Gets or sets the DateTime value.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PickField |
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog.Date Property

Gets or sets the DateTime value.

public System.DateTime Date {get; set;}

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog Methods

The methods of the vdxDatePickerDialog class are listed below. For a complete list of vdxDatePickerDialog class members, see the vdxDatePickerDialog Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
btnCancel_Click | Handles the Click event of the Cancel Button object.
btnOK_Click | Handles the Click event of the OK Button object.
CalMonthCalendar_DateSelected | Handles the DateSelected event of the calendar object.
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPickerAccepted | Raises the PickerAccepted event.
OnPickerCancelled | Raises the PickerCancelled event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
vdxCalendarPopupForm_Resize | Handles the Resize event of the form. It makes sure that the form is always big enough to show the complete calendar.
WndProc (inherited from Form) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxPicker.Clear
IvdxPicker.Close
IvdxPicker.Show

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog.btnCancel_Click Method

Handles the Click event of the Cancel Button object.

protected virtual void btnCancel_Click(
object sender,
EventArgs e
);

Parameters

sender
The sender object.
e
The event args.

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog.btnOK_Click Method

Handles the Click event of the OK Button object.

protected virtual void btnOK_Click(
object sender,
EventArgs e
);

Parameters

sender
The sender object.
e
The event args.

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog.CalMonthCalendar_DateSelected Method

Handles the DateSelected event of the calendar object.

protected virtual void CalMonthCalendar_DateSelected(
object sender,
DateRangeEventArgs e
);

Parameters

sender
The sender object.
e
The event args.

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog.IvdxPicker.Clear Method

void IvdxPicker.Clear();

Implements

IvdxPicker.Clear

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog.IvdxPicker.Close Method

void IvdxPicker.Close();

Implements

IvdxPicker.Close

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog.IvdxPicker.Show Method

void IvdxPicker.Show();

Implements

IvdxPicker.Show

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Dispose Method

VDX Framework

vdxDatePickerDialog.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog.Dispose Method (Boolean)

Clean up any resources being used.

protected override void Dispose(
bool disposing
);

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace | vdxDatePickerDialog.Dispose Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog.OnPickerAccepted Method

Raises the PickerAccepted event.

protected virtual void OnPickerAccepted();

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog.OnPickerCancelled Method

Raises the PickerCancelled event.

protected virtual void OnPickerCancelled();

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog.vdxCalendarPopupForm_Resize Method

Handles the Resize event of the form. It makes sure that the form is always big enough to show the complete calendar.

protected virtual void vdxCalendarPopupForm_Resize(
object sender,
EventArgs e
);

Parameters

sender
The form
e
The event args

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog Events

The events of the vdxDatePickerDialog class are listed below. For a complete list of vdxDatePickerDialog class members, see the vdxDatePickerDialog Members topic.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PickerAccepted | Occurs when the value or values were accepted.
PickerCancelled | Occurs when the picker routine was canceled.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog.PickerAccepted Event

Occurs when the value or values were accepted.

public event vdxPickerEventHandler PickerAccepted;

Event Data

The event handler receives an argument of type vdxPickerEventArgs containing data related to this event. The following vdxPickerEventArgs property provides information specific to this event.

Property | Description
PickerInfo | Gets the vdxPickerInfo object.

Implements

IvdxPicker.PickerAccepted

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickerDialog.PickerCancelled Event

Occurs when the picker routine was canceled.

public event vdxPickerEventHandler PickerCancelled;

Event Data

The event handler receives an argument of type vdxPickerEventArgs containing data related to this event. The following vdxPickerEventArgs property provides information specific to this event.

Property | Description
PickerInfo | Gets the vdxPickerInfo object.

Implements

IvdxPicker.PickerCancelled

See Also

vdxDatePickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickField Class

Derived vdxPickField class that handles a date field.

For a list of all members of this type, see vdxDatePickField Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxPickField
vdxDatePickField

public class vdxDatePickField : vdxPickField

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxDatePickField Members | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickField Members

vdxDatePickField overview

Public Instance Constructors

vdxDatePickField Constructor Default constructor.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoStartPicker (inherited from vdxPickField) | Gets or sets if this IvdxPicker should be started automatically if code field validation fails.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindEmptyValuesAsNull | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from ContainerControl) |
BindingInfos (inherited from vdxPickField) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from vdxPickField) | See CanFocus
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CodeWidth (inherited from vdxPickField) | Gets or sets the width of the Code Textbox.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos (inherited from vdxPickField) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Date | Gets or sets the date value.
DateFormat | Gets or sets the date format for the property Date.
DateIsNull | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from vdxPickField) | Gets or sets a value indicating whether control can respond to user interaction.
Focused (inherited from vdxPickField) | Overrides Focused
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideButtonOpenPicker (inherited from vdxPickField) | Gets or sets whether the button open picker is visible or not.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM (inherited from vdxPickField) | Gets/sets a value indicating whether the PickField interacts with the DSM. If set to true then the PickField will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PickCode | Overloaded. Gets or sets the code that can be uniquely identified.
PickCodeIsNull (inherited from vdxPickField) | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
PickDescription | Overloaded. Gets or sets the description the correspond to the code field or foreign key.
PickDescriptionIsNull (inherited from vdxPickField) | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
PickerClassName (inherited from vdxPickField) | Gets or sets the full qualified string representation of the derived IvdxPicker.
PickForeignKey | Gets or sets the foreign key.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RangeType | Gets or sets the vdxDateRangeType for the property Date.
ReadOnly (inherited from vdxPickField) | Gets or sets a value indicating whether text in text box code is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxPickField) | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Reset (inherited from vdxPickField) | Resets the vdxPickField
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBindingInfo (inherited from vdxPickField) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetPickValues (inherited from vdxPickField) | Overloaded. Sets the values of the vdxPickField.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
DateChanged | Occurs after the property Date changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PickCodeChanged (inherited from vdxPickField) | Occurs after the PickCode field has changed.
PickDescriptionChanged (inherited from vdxPickField) | Occurs after the PickDescription field has changed.
PickForeignKeyChanged (inherited from vdxPickField) | Occurs after the PickForeignKey field has changed.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged | Occurs after text code changes. Equivalent to txtCode.TextChanged event.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

btnClear (inherited from vdxPickField) | Clear button.
btnOpenPicker (inherited from vdxPickField) | Open picker button.
manuallyChanged (inherited from vdxPickField) | Indicates whether the code field was changed by code flow or by user inter action.
picker (inherited from vdxPickField) | Picker instance.
txtCode (inherited from vdxPickField) | Code field.
txtDescription (inherited from vdxPickField) | Description field.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from vdxPickField) | Overloaded. Releases all resources used by the Component.
FillData (inherited from vdxPickField) | Fill up description field.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsValid | Checks if code field is valid.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from vdxPickField) | Overrides OnPaint.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from vdxPickField) | Overrides OnResize.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from vdxPickField) | Overrides OnValidating.
OnVisibleChanged (inherited from ScrollableControl) |
OpenPicker (inherited from vdxPickField) | Opens the picker to select an entry.
Picker_PickerAccepted (inherited from vdxPickField) | Event listener to react on PickerClassName acception of an new entry.
PickerActivated | Occurs when the IvdxPicker is activated. Can be used to set the values from the pickfield to the IvdxPicker.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RemovePicker (inherited from vdxPickField) | Removes the instance of the picker
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl) |
IvdxInputControl.InitializeBinding (inherited from vdxPickField) | Do any initializing work like converting format.
IvdxResettable.Reset (inherited from vdxPickField) | Resets the values of the fields to the empty string.

See Also

vdxDatePickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickField Constructor

Default constructor.

public vdxDatePickField();

See Also

vdxDatePickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickField Properties

The properties of the vdxDatePickField class are listed below. For a complete list of vdxDatePickField class members, see the vdxDatePickField Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoStartPicker (inherited from vdxPickField) | Gets or sets if this IvdxPicker should be started automatically if code field validation fails.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindEmptyValuesAsNull | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from ContainerControl) |
BindingInfos (inherited from vdxPickField) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from vdxPickField) | See CanFocus
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CodeWidth (inherited from vdxPickField) | Gets or sets the width of the Code Textbox.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos (inherited from vdxPickField) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Date | Gets or sets the date value.
DateFormat | Gets or sets the date format for the property Date.
DateIsNull | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from vdxPickField) | Gets or sets a value indicating whether control can respond to user interaction.
Focused (inherited from vdxPickField) | Overrides Focused
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideButtonOpenPicker (inherited from vdxPickField) | Gets or sets whether the button open picker is visible or not.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM (inherited from vdxPickField) | Gets/sets a value indicating whether the PickField interacts with the DSM. If set to true then the PickField will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PickCode | Overloaded. Gets or sets the code that can be uniquely identified.
PickCodeIsNull (inherited from vdxPickField) | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
PickDescription | Overloaded. Gets or sets the description the correspond to the code field or foreign key.
PickDescriptionIsNull (inherited from vdxPickField) | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
PickerClassName (inherited from vdxPickField) | Gets or sets the full qualified string representation of the derived IvdxPicker.
PickForeignKey | Gets or sets the foreign key.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RangeType | Gets or sets the vdxDateRangeType for the property Date.
ReadOnly (inherited from vdxPickField) | Gets or sets a value indicating whether text in text box code is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

vdxDatePickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickField.BindEmptyValuesAsNull Property

Gets or sets whether the empty values must be binded as null.

new public bool BindEmptyValuesAsNull {get; set;}

Implements

IvdxInputControl.BindEmptyValuesAsNull

See Also

vdxDatePickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickField.Date Property

Gets or sets the date value.

public object Date {get; set;}

See Also

vdxDatePickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickField.DateFormat Property

Gets or sets the date format for the property Date.

public Deag.Vdx.Common.Enums.vdxDateFormat DateFormat {get; set;}

See Also

vdxDatePickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickField.DateIsNull Property

This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.

public virtual bool DateIsNull {get; set;}

See Also

vdxDatePickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickField.PickCode Property

Gets or sets the code that can be uniquely identified.

new public object PickCode {get; set;}

See Also

vdxDatePickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickField.PickDescription Property

Gets or sets the description the correspond to the code field or foreign key.

new public object PickDescription {get; set;}

See Also

vdxDatePickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickField.PickForeignKey Property

Gets or sets the foreign key.

new public object PickForeignKey {get; set;}

See Also

vdxDatePickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickField.RangeType Property

Gets or sets the vdxDateRangeType for the property Date.

public vdxDateRangeType RangeType {get; set;}

Remarks

See Also

vdxDatePickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickField Methods

The methods of the vdxDatePickField class are listed below. For a complete list of vdxDatePickField class members, see the vdxDatePickField Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxPickField) | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Reset (inherited from vdxPickField) | Resets the vdxPickField
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBindingInfo (inherited from vdxPickField) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetPickValues (inherited from vdxPickField) | Overloaded. Sets the values of the vdxPickField.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from vdxPickField) | Overloaded. Releases all resources used by the Component.
FillData (inherited from vdxPickField) | Fill up description field.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsValid | Checks if code field is valid.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from vdxPickField) | Overrides OnPaint.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from vdxPickField) | Overrides OnResize.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from vdxPickField) | Overrides OnValidating.
OnVisibleChanged (inherited from ScrollableControl) |
OpenPicker (inherited from vdxPickField) | Opens the picker to select an entry.
Picker_PickerAccepted (inherited from vdxPickField) | Event listener to react on PickerClassName acception of an new entry.
PickerActivated | Occurs when the IvdxPicker is activated. Can be used to set the values from the pickfield to the IvdxPicker.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RemovePicker (inherited from vdxPickField) | Removes the instance of the picker
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl) |
IvdxInputControl.InitializeBinding (inherited from vdxPickField) | Do any initializing work like converting format.
IvdxResettable.Reset (inherited from vdxPickField) | Resets the values of the fields to the empty string.

See Also

vdxDatePickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickField.IsValid Method

Checks if code field is valid.

protected override bool IsValid();

Return Value

True if code field contains a valid value.

See Also

vdxDatePickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickField.PickerActivated Method

Occurs when the IvdxPicker is activated. Can be used to set the values from the pickfield to the IvdxPicker.

protected override void PickerActivated();

See Also

vdxDatePickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickField Events

The events of the vdxDatePickField class are listed below. For a complete list of vdxDatePickField class members, see the vdxDatePickField Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
DateChanged | Occurs after the property Date changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PickCodeChanged (inherited from vdxPickField) | Occurs after the PickCode field has changed.
PickDescriptionChanged (inherited from vdxPickField) | Occurs after the PickDescription field has changed.
PickForeignKeyChanged (inherited from vdxPickField) | Occurs after the PickForeignKey field has changed.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged | Occurs after text code changes. Equivalent to txtCode.TextChanged event.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

vdxDatePickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickField.DateChanged Event

Occurs after the property Date changes.

public event EventHandler DateChanged;

See Also

vdxDatePickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDatePickField.TextChanged Event

Occurs after text code changes. Equivalent to txtCode.TextChanged event.

public event EventHandler TextChanged;

See Also

vdxDatePickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxDateRangeType Enumeration

Defines the range types of the Date property of a vdxDataPickField.

public enum vdxDateRangeType

Members

Member Name | Description
Default | Don't adapt hour, minute, second and millisecond field of the Property Date
StartOfDay | Adapt hour, minute, second and millisecond field to zero (Midnight) as AM
EndOfDay | Adapt hour = 11, minute = 59, second = 59 and millisecond = 999 (before Midnight) as PM

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGrid Class

Explorer used for the reference tables management.

For a list of all members of this type, see vdxExplorerGrid Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxCacheableControl
vdxDataControl
vdxExplorer
vdxExplorerGrid

public class vdxExplorerGrid : vdxExplorer

Remarks

Used as a base for simple exploring capabilities without a treeview. Usually used for reference table management with list and detail control visible at the same time.

Example

The methods that must be overridden to provide the base funcionality are following: LoadDataGetLoaderInfo Override the LoadData method to provide a DataSet that contains all data to fill up the vdxExplorerGridView.

            protected override void LoadData()
            {
                dsPersList ds = WebServiceProvider.wsCountry.GetDataSetCountry(this.SearchParameters.GetParameters());

                if (ds.Country.Count > 0)
                {
                    return ds;
                }
                else
                {
                    MessageBox.Show(
                        "No country found. Please try again!",
                        "VDX Sample Application",
                        MessageBoxButtons.OK,
                        MessageBoxIcon.Information);

                    return null;
                }
            }
Note The property SearchParameters is set after either - the user has clicked the search button in the SearchControlType or - it is automatically set in the initializing sequence of the vdxExplorerTree if no SearchControlType was configured.
Override the GetLoaderInfo method to define the vdxSearchParameters to perform data load and the Type of vdxDataDetail to display in the MultiContainer.
            protected override void GetLoaderInfo(vdxNavigatorInfo navigatorInfo)
            {
                vdxSearchParameters searchParameters = null;
                dsCountry.CountryRow row = navigatorInfo.SelectedRow as dsCountry.CountryRow;

                if (row != null)
                {
                    int persId = (int)row.PersID;
                    searchParameters = new vdxSearchParameters("SelectionCountryById");
                    searchParameters.Add("Country", row.Country);
                }
                return new vdxLoaderInfo(searchParameters, typeof(DataDetailCountry));
            }

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxExplorerGrid Members | Deag.Vdx.Controls.Standard Namespace | vdxExplorer | vdxDataDetail | vdxSearchParameters | IvdxSearchControl | vdxExplorerGridView | vdxDataMultiContainer | vdxNavigatorInfo | vdxLoaderInfo

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGrid Members

vdxExplorerGrid overview

Public Instance Constructors

vdxExplorerGrid Constructor Default contructor.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataActionManager (inherited from vdxExplorer) | Gets and sets the current vdxDataActionManager from the vdxDataMultiContainer.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataStatusManager (inherited from vdxExplorer) | Gets the current vdxDataStatusManager from the vdxDataMultiContainer.
DisplayMode (inherited from vdxExplorer) | Gets or sets the current display mode.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MultiContainer | Overrides MultiContainer to hide the property in Design Mode.
Name (inherited from Control) | Gets or sets the name of the control.
NavigatorDataSet (inherited from vdxExplorer) | Gets the loaded DataSet for all navigators.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SearchControl (inherited from vdxExplorer) | Gets the created instance of the SearchControlType.
SearchControlType (inherited from vdxExplorer) | Gets or sets the name of the typed SearchControl, which will be instantiated later.
SearchParameters (inherited from vdxExplorer) | Gets or sets the search parameters for this explorer.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

AddInitial (inherited from vdxExplorer) | Adds a new entry on DataStatusManager for the corresponding dataDetailType.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetLoaderInfo (inherited from vdxExplorer) | Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformDataLoad (inherited from vdxExplorer) | Delegates the components to load the corresponding data for the given search parameters.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

dataGrid | Holds the navigator for this explorer.
dataMultiContainer | Holds the container to display the corresponding selected navigator element.
dataSet (inherited from vdxExplorer) | Holds the actual dataSet, which is delegated to all navigators.
multiContainer (inherited from vdxExplorer) | Holds the detail container for this explorer.
selectedNavigatorInfo (inherited from vdxExplorer) | The actual selected vdxNavigatorInfo in the navigators.
splitter | Holds the splitter which divide dataGrid and dataMultiContainer.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
NavigatorCollection (inherited from vdxExplorer) | Gets the NavigatorCollection, which holds IvdxNavigator components.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActionItemFind_ActionInvoked (inherited from vdxExplorer) | Implementation of the ActionItemFind event listeners.
ActionItemRefresh_ActionInvoked (inherited from vdxExplorer) | Implementation of the ActionItemRefresh event listeners.
ActionItemRefreshAll_ActionInvoked (inherited from vdxExplorer) | Implementation of the ActionItemRefreshAll event listeners.
Activate | Overrides Activate to hide multiContainer if NavigatorDataSet is null or contains no data.
AdjustFormScrollbars (inherited from ContainerControl) |
AllowFind (inherited from vdxExplorer) | Gets whether to enable the find button.
Create | Overrides Create to perform a data load if no SearchControl is set.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateNavigatorRow (inherited from vdxExplorer) | Creates a new row on the loaded DataSet with the given content of the the vdxDataManipulatorEventArgs.ManipulatorData.
Deactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DeactivateAllowed (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
EnableActions (inherited from vdxExplorer) | Enables refresh and find actions on DataActionManager .
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HandleChanges (inherited from vdxExplorer) | Activate the element with unsaved changes.
HasChanges (inherited from vdxExplorer) | Indicates if a component or one of its subcomponents has pending changes.
InitializeNavigatorCollection (inherited from vdxExplorer) | Add all controls that implement IvdxNavigator to the NavigatorCollection.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsRefreshable (inherited from vdxExplorer) | Checks if the component supports refresh.
LayoutAll | Change visibility of splitter.
LoadData (inherited from vdxExplorer) | Delegates the components to load the corresponding data for the given search parameters.
Manipulator_RowCopied (inherited from vdxExplorer) | Listens to the manipulator copied event of a data detail.
Manipulator_RowDeleted | Overrides Manipulator_RowDeleted to hide multiContainer if NavigatorDataSet is null or contains no data after a row was deleted.
Manipulator_RowInserted (inherited from vdxExplorer) | Listens to the manipulator insert event of a data detail.
Manipulator_RowUpdated (inherited from vdxExplorer) | Listens to the manipulator update event of a data detail.
Manipulator_Undone | Overrides Manipulator_Undone to hide multiContainer if NavigatorDataSet is null or contains no data after an undone changes.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Navigator_ControlChanged (inherited from vdxExplorer) | Listens to vdxNavigatorSelectionEventHandler to detect selection changes.
Navigator_SelectionChanged (inherited from vdxExplorer) | Listens to vdxNavigatorSelectionEventHandler to detect selection changes.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
Reactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshData (inherited from vdxExplorer) | Loads again the data.
RefreshSelectedDataLoader (inherited from vdxExplorer) | Reloads the current selected data detail.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
SearchControl_SearchParamsFilled (inherited from vdxExplorer) | Inform all navigators about the new loaded DataSet to construct their navigation elements.
Select (inherited from ContainerControl) | Overloaded.
SelectDefault | Overrides SelectDefault to delegate the default selection to the dataGrid.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShowDetail (inherited from vdxExplorer) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateNavigatorRow (inherited from vdxExplorer) | Update navigator DataRow with the given vdxDataManipulatorEventArgs.ManipulatorData.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxChangeable.HandleChanges (inherited from vdxDataControl)
IvdxChangeable.HasChanges (inherited from vdxDataControl)
IvdxDataLoader.ClearSearchParameters (inherited from vdxExplorer)
IvdxDataLoader.IsRefreshable (inherited from vdxExplorer)
IvdxDataLoader.PerformDataLoad (inherited from vdxExplorer)
IvdxDataLoader.RefreshData (inherited from vdxExplorer)
IvdxMultiContainerCacheable.Activate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Create (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Deactivate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.DeactivateAllowed (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Reactivate (inherited from vdxCacheableControl)

See Also

vdxExplorerGrid Class | Deag.Vdx.Controls.Standard Namespace | vdxExplorer | vdxDataDetail | vdxSearchParameters | IvdxSearchControl | vdxExplorerGridView | vdxDataMultiContainer | vdxNavigatorInfo | vdxLoaderInfo

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGrid Constructor

Default contructor.

public vdxExplorerGrid();

See Also

vdxExplorerGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGrid Fields

The fields of the vdxExplorerGrid class are listed below. For a complete list of vdxExplorerGrid class members, see the vdxExplorerGrid Members topic.

Protected Instance Fields

dataGrid | Holds the navigator for this explorer.
dataMultiContainer | Holds the container to display the corresponding selected navigator element.
dataSet (inherited from vdxExplorer) | Holds the actual dataSet, which is delegated to all navigators.
multiContainer (inherited from vdxExplorer) | Holds the detail container for this explorer.
selectedNavigatorInfo (inherited from vdxExplorer) | The actual selected vdxNavigatorInfo in the navigators.
splitter | Holds the splitter which divide dataGrid and dataMultiContainer.

See Also

vdxExplorerGrid Class | Deag.Vdx.Controls.Standard Namespace | vdxExplorer | vdxDataDetail | vdxSearchParameters | IvdxSearchControl | vdxExplorerGridView | vdxDataMultiContainer | vdxNavigatorInfo | vdxLoaderInfo

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGrid.dataGrid Field

Holds the navigator for this explorer.

protected vdxExplorerGridView dataGrid;

See Also

vdxExplorerGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGrid.dataMultiContainer Field

Holds the container to display the corresponding selected navigator element.

protected vdxDataMultiContainer dataMultiContainer;

See Also

vdxExplorerGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGrid.splitter Field

Holds the splitter which divide dataGrid and dataMultiContainer.

protected Splitter splitter;

See Also

vdxExplorerGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGrid Properties

The properties of the vdxExplorerGrid class are listed below. For a complete list of vdxExplorerGrid class members, see the vdxExplorerGrid Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataActionManager (inherited from vdxExplorer) | Gets and sets the current vdxDataActionManager from the vdxDataMultiContainer.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataStatusManager (inherited from vdxExplorer) | Gets the current vdxDataStatusManager from the vdxDataMultiContainer.
DisplayMode (inherited from vdxExplorer) | Gets or sets the current display mode.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MultiContainer | Overrides MultiContainer to hide the property in Design Mode.
Name (inherited from Control) | Gets or sets the name of the control.
NavigatorDataSet (inherited from vdxExplorer) | Gets the loaded DataSet for all navigators.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SearchControl (inherited from vdxExplorer) | Gets the created instance of the SearchControlType.
SearchControlType (inherited from vdxExplorer) | Gets or sets the name of the typed SearchControl, which will be instantiated later.
SearchParameters (inherited from vdxExplorer) | Gets or sets the search parameters for this explorer.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
NavigatorCollection (inherited from vdxExplorer) | Gets the NavigatorCollection, which holds IvdxNavigator components.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

vdxExplorerGrid Class | Deag.Vdx.Controls.Standard Namespace | vdxExplorer | vdxDataDetail | vdxSearchParameters | IvdxSearchControl | vdxExplorerGridView | vdxDataMultiContainer | vdxNavigatorInfo | vdxLoaderInfo

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGrid.MultiContainer Property

Overrides MultiContainer to hide the property in Design Mode.

new public Deag.Vdx.Controls.Core.vdxMultiContainer MultiContainer {get; set;}

See Also

vdxExplorerGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGrid Methods

The methods of the vdxExplorerGrid class are listed below. For a complete list of vdxExplorerGrid class members, see the vdxExplorerGrid Members topic.

Public Instance Methods

AddInitial (inherited from vdxExplorer) | Adds a new entry on DataStatusManager for the corresponding dataDetailType.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetLoaderInfo (inherited from vdxExplorer) | Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformDataLoad (inherited from vdxExplorer) | Delegates the components to load the corresponding data for the given search parameters.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActionItemFind_ActionInvoked (inherited from vdxExplorer) | Implementation of the ActionItemFind event listeners.
ActionItemRefresh_ActionInvoked (inherited from vdxExplorer) | Implementation of the ActionItemRefresh event listeners.
ActionItemRefreshAll_ActionInvoked (inherited from vdxExplorer) | Implementation of the ActionItemRefreshAll event listeners.
Activate | Overrides Activate to hide multiContainer if NavigatorDataSet is null or contains no data.
AdjustFormScrollbars (inherited from ContainerControl) |
AllowFind (inherited from vdxExplorer) | Gets whether to enable the find button.
Create | Overrides Create to perform a data load if no SearchControl is set.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateNavigatorRow (inherited from vdxExplorer) | Creates a new row on the loaded DataSet with the given content of the the vdxDataManipulatorEventArgs.ManipulatorData.
Deactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DeactivateAllowed (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
EnableActions (inherited from vdxExplorer) | Enables refresh and find actions on DataActionManager .
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HandleChanges (inherited from vdxExplorer) | Activate the element with unsaved changes.
HasChanges (inherited from vdxExplorer) | Indicates if a component or one of its subcomponents has pending changes.
InitializeNavigatorCollection (inherited from vdxExplorer) | Add all controls that implement IvdxNavigator to the NavigatorCollection.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsRefreshable (inherited from vdxExplorer) | Checks if the component supports refresh.
LayoutAll | Change visibility of splitter.
LoadData (inherited from vdxExplorer) | Delegates the components to load the corresponding data for the given search parameters.
Manipulator_RowCopied (inherited from vdxExplorer) | Listens to the manipulator copied event of a data detail.
Manipulator_RowDeleted | Overrides Manipulator_RowDeleted to hide multiContainer if NavigatorDataSet is null or contains no data after a row was deleted.
Manipulator_RowInserted (inherited from vdxExplorer) | Listens to the manipulator insert event of a data detail.
Manipulator_RowUpdated (inherited from vdxExplorer) | Listens to the manipulator update event of a data detail.
Manipulator_Undone | Overrides Manipulator_Undone to hide multiContainer if NavigatorDataSet is null or contains no data after an undone changes.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Navigator_ControlChanged (inherited from vdxExplorer) | Listens to vdxNavigatorSelectionEventHandler to detect selection changes.
Navigator_SelectionChanged (inherited from vdxExplorer) | Listens to vdxNavigatorSelectionEventHandler to detect selection changes.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
Reactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshData (inherited from vdxExplorer) | Loads again the data.
RefreshSelectedDataLoader (inherited from vdxExplorer) | Reloads the current selected data detail.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
SearchControl_SearchParamsFilled (inherited from vdxExplorer) | Inform all navigators about the new loaded DataSet to construct their navigation elements.
Select (inherited from ContainerControl) | Overloaded.
SelectDefault | Overrides SelectDefault to delegate the default selection to the dataGrid.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShowDetail (inherited from vdxExplorer) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateNavigatorRow (inherited from vdxExplorer) | Update navigator DataRow with the given vdxDataManipulatorEventArgs.ManipulatorData.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxChangeable.HandleChanges (inherited from vdxDataControl)
IvdxChangeable.HasChanges (inherited from vdxDataControl)
IvdxDataLoader.ClearSearchParameters (inherited from vdxExplorer)
IvdxDataLoader.IsRefreshable (inherited from vdxExplorer)
IvdxDataLoader.PerformDataLoad (inherited from vdxExplorer)
IvdxDataLoader.RefreshData (inherited from vdxExplorer)
IvdxMultiContainerCacheable.Activate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Create (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Deactivate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.DeactivateAllowed (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Reactivate (inherited from vdxCacheableControl)

See Also

vdxExplorerGrid Class | Deag.Vdx.Controls.Standard Namespace | vdxExplorer | vdxDataDetail | vdxSearchParameters | IvdxSearchControl | vdxExplorerGridView | vdxDataMultiContainer | vdxNavigatorInfo | vdxLoaderInfo

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGrid.Activate Method

Overrides Activate to hide multiContainer if NavigatorDataSet is null or contains no data.

protected override void Activate();

See Also

vdxExplorerGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGrid.Create Method

Overrides Create to perform a data load if no SearchControl is set.

protected override void Create();

See Also

vdxExplorerGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGrid.LayoutAll Method

Change visibility of splitter.

protected override void LayoutAll();

See Also

vdxExplorerGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGrid.Manipulator_RowDeleted Method

Overrides Manipulator_RowDeleted to hide multiContainer if NavigatorDataSet is null or contains no data after a row was deleted.

protected override void Manipulator_RowDeleted(
object source,
vdxDataManipulatorEventArgs eventArgs
);

Parameters

source
eventArgs

See Also

vdxExplorerGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGrid.Manipulator_Undone Method

Overrides Manipulator_Undone to hide multiContainer if NavigatorDataSet is null or contains no data after an undone changes.

protected override void Manipulator_Undone(
object source,
vdxDataManipulatorEventArgs eventArgs
);

Parameters

source
eventArgs

See Also

vdxExplorerGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGrid.SelectDefault Method

Overrides SelectDefault to delegate the default selection to the dataGrid.

protected override void SelectDefault();

See Also

vdxExplorerGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGridView Class

A specialized vdxDataGridNavigator which can delegate commands to a vdxExplorerGrid.

For a list of all members of this type, see vdxExplorerGridView Members.

System.Object
MarshalByRefObject
Component
Control
DataGrid
vdxDataGrid
vdxDataGridNavigator
vdxExplorerGridView

public class vdxExplorerGridView : vdxDataGridNavigator

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxExplorerGridView Members | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGridView Members

vdxExplorerGridView overview

Public Instance Constructors

vdxExplorerGridView Constructor Initializes a new instance of the vdxExplorerGridView class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowNavigation (inherited from vdxDataGridNavigator) | Gets or sets a value indicating whether navigation is allowed.
AllowSorting (inherited from DataGrid) | Gets or sets a value indicating whether the grid can be resorted by clicking on a column header.
AlternatingBackColor (inherited from DataGrid) | Gets or sets the background color of odd-numbered rows of the grid.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from DataGrid) | Gets or sets the background color of even-numbered rows of the grid.
BackgroundColor (inherited from DataGrid) | Gets or sets the color of the non-row area of the grid.
BackgroundImage (inherited from DataGrid) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxDataGrid) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from DataGrid) | Gets or sets the grid's border style.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CaptionBackColor (inherited from DataGrid) | Gets or sets the background color of the caption area.
CaptionFont (inherited from DataGrid) | Gets or sets the font of the grid's caption.
CaptionForeColor (inherited from DataGrid) | Gets or sets the foreground color of the caption area.
CaptionText (inherited from DataGrid) | Gets or sets the text of the grid's window caption.
CaptionVisible | Gets or sets a value indicating whether the grid's caption is visible.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColumnHeadersVisible (inherited from DataGrid) | Gets or sets a value indicating whether the column headers a table are visible.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrencyManager (inherited from vdxDataGrid) | Gets the managed CurrencyManager of this data grid.
CurrentCell (inherited from DataGrid) | Gets or sets which cell has the focus. Not available at design time.
CurrentDataRow (inherited from vdxDataGrid) | Gets or sets the dataRows which are selected.
CurrentRowIndex (inherited from DataGrid) | Gets or sets index of the selected row.
Cursor (inherited from DataGrid) |
DataBindingInfos (inherited from vdxDataGrid) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataMember (inherited from vdxDataGrid) |
DataSource (inherited from vdxDataGrid) | Gets or sets the data source that this grid is displaying data for.
DataView (inherited from vdxDataGrid) | Gets the managed DataView of this data grid.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
ExplorerGrid | Gets or sets the corresponding explorerTree.
FirstVisibleColumn (inherited from DataGrid) | Gets the index of the first visible column in a grid.
FlatMode (inherited from DataGrid) | Gets or sets a value indicating whether the grid displays in flat mode.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from DataGrid) | Gets or sets the foreground color (typically the color of the text) property of the DataGrid control.
GridLineColor (inherited from DataGrid) | Gets or sets the color of the grid lines.
GridLineStyle (inherited from DataGrid) | Gets or sets the line style of the grid.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HeaderBackColor (inherited from DataGrid) | Gets or sets the background color of all row and column headers.
HeaderFont (inherited from DataGrid) | Gets or sets the font used for column headers.
HeaderForeColor (inherited from DataGrid) | Gets or sets the foreground color of headers.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Item (inherited from DataGrid) | Gets or sets the value of the cell at the specified the row and column.
Item (inherited from DataGrid) | Gets or sets the value of a specified DataGridCell .
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LinkColor (inherited from DataGrid) | Gets or sets the color of the text that you can click to navigate to a child table.
LinkHoverColor (inherited from DataGrid) | Gets or sets the color a link changes to when the mouse pointer moves over it.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentRowsBackColor (inherited from DataGrid) | Gets or sets the background color of parent rows.
ParentRowsForeColor (inherited from DataGrid) | Gets or sets the foreground color of parent rows.
ParentRowsLabelStyle (inherited from DataGrid) | Gets or sets the way parent row labels are displayed.
ParentRowsVisible (inherited from DataGrid) | Gets or sets a value indicating whether the parent rows of a table are visible.
PreferredColumnWidth (inherited from DataGrid) | Gets or sets the default width of the grid columns in pixels.
PreferredRowHeight (inherited from DataGrid) | Gets or sets the preferred row height for the DataGrid control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly | Gets or sets a value indicating whether the grid is a read-only mode.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RowHeadersVisible (inherited from DataGrid) | Gets or sets a value that specifies whether row headers are visible.
RowHeaderWidth (inherited from DataGrid) | Gets or sets the width of row headers.
SelectedDataRows (inherited from vdxDataGrid) | Gets or sets the dataRows which are selected.
SelectionBackColor (inherited from DataGrid) | Gets or sets the background color of selected rows.
SelectionForeColor (inherited from DataGrid) | Gets or set the foreground color of selected rows.
Site (inherited from DataGrid) |
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TableStyles (inherited from DataGrid) | Gets the collection of DataGridTableStyle objects for the grid.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from DataGrid) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisibleColumnCount (inherited from DataGrid) | Gets the number of visible columns.
VisibleRowCount (inherited from DataGrid) | Gets the number of rows visible.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginEdit (inherited from DataGrid) | Attempts to put the grid into a state where editing is allowed.
BeginInit (inherited from DataGrid) | Begins the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Collapse (inherited from DataGrid) | Collapses child relations, if any exist for all rows, or for a specified row.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndEdit (inherited from DataGrid) | Requests an end to an edit operation taking place on the DataGrid control.
EndInit (inherited from DataGrid) | Ends the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from DataGrid) | Displays child relations, if any exist, for all rows or a specific row.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindRows (inherited from vdxDataGrid) | Find rows by a SQL where clause.
FindText (inherited from vdxDataGrid) | Full text search for the passed Text. Every row is scanned for the Text. If the row contains the text, it is added to the resultion row collection.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxDataGrid) | Get the binding info for the Property specified.
GetCellBounds (inherited from DataGrid) | Overloaded. Gets the Rectangle of the cell specified by row and column number.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetCurrentCellBounds (inherited from DataGrid) | Gets a Rectangle that specifies the four corners of the selected cell.
GetDataRowAT (inherited from vdxDataGrid) | Gets the Datarow with the specified index
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetRowIndex (inherited from vdxDataGrid) | Returns the (momentary) index of a row in the grid. The returned index depends on the momentary sort order.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HitTest (inherited from DataGrid) | Overloaded. Gets information, such as row and column number of a clicked point on the grid, using the x and y coordinate passed to the method.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
IsExpanded (inherited from DataGrid) | Gets a value that indicates whether a specified row's node is expanded or collapsed.
IsSelected (inherited from DataGrid) | Gets a value indicating whether a specified row is selected.
MoveFirst (inherited from vdxDataGrid) | Moves to the first record in the grid
MoveLast (inherited from vdxDataGrid) | Move to the last record of the grid if possible
MoveNext (inherited from vdxDataGrid) | Moves to the next record in the grid. If we are already on the last record, moves to the first record.
MovePrevious (inherited from vdxDataGrid) | Moves to the previous record in the grid. If we are already on the first recorde, moves to the last record
NavigateBack (inherited from DataGrid) | Navigates back to the table previously displayed in the grid.
NavigateTo (inherited from DataGrid) | Navigates to the table specified by row and relation name.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetAlternatingBackColor (inherited from DataGrid) | Resets the AlternatingBackColor property to its default color.
ResetBackColor (inherited from DataGrid) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from DataGrid) | Resets the ForeColor property to its default value.
ResetGridLineColor (inherited from DataGrid) | Resets the GridLineColor property to its default value.
ResetHeaderBackColor (inherited from DataGrid) | Resets the HeaderBackColor property to its default value.
ResetHeaderFont (inherited from DataGrid) | Resets the HeaderFont property to its default value.
ResetHeaderForeColor (inherited from DataGrid) | Resets the HeaderForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetLinkColor (inherited from DataGrid) | Resets the LinkColor property to its default value.
ResetLinkHoverColor (inherited from DataGrid) |
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetSelectionBackColor (inherited from DataGrid) | Resets the SelectionBackColor property to its default value.
ResetSelectionForeColor (inherited from DataGrid) | Resets the SelectionForeColor property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from DataGrid) | Overloaded. Selects a specified row.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo (inherited from vdxDataGrid) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDataBinding (inherited from DataGrid) | Sets the DataSource and DataMember properties at run time.
Show (inherited from Control) | Displays the control to the user.
SubObjectsSiteChange (inherited from DataGrid) |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
UnSelect (inherited from DataGrid) | Unselects a specified row.
Update (inherited from Control) | Overloaded. Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AllowNavigationChanged (inherited from DataGrid) | Occurs when the AllowNavigation property has changed.
BackButtonClick (inherited from DataGrid) | Occurs when the Back button on a child table is clicked.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundColorChanged (inherited from DataGrid) | Occurs when the BackgroundColor has changed.
BackgroundImageChanged (inherited from DataGrid) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
BorderStyleChanged (inherited from DataGrid) | Occurs when the BorderStyle has changed.
CaptionVisibleChanged (inherited from DataGrid) | Occurs when the CaptionVisible property has changed.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlChanged (inherited from vdxDataGridNavigator) | Occurs when an other cacheable control had to be shown.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CurrentCellChanged (inherited from DataGrid) | Occurs when the CurrentCell property has changed.
CursorChanged (inherited from DataGrid) |
DataSourceChanged (inherited from DataGrid) | Occurs when the DataSource property value has changed.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
Filled (inherited from vdxDataGridNavigator) | Occurs after Fill was called.
FlatModeChanged (inherited from DataGrid) | Occurs when the FlatMode has changed.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Navigate (inherited from DataGrid) | Occurs when the user navigates to a new table.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
ParentRowsLabelStyleChanged (inherited from DataGrid) | Occurs when the label style of the parent row is changed.
ParentRowsVisibleChanged (inherited from DataGrid) | Occurs when the ParentRowsVisible property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
ReadOnlyChanged (inherited from DataGrid) | Occurs when the ReadOnly property value changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from DataGrid) | Occurs when the user scrolls the DataGrid control.
SelectionChanged (inherited from vdxDataGridNavigator) | Occurs when an other DataRow was selected.
ShowParentDetailsButtonClick (inherited from DataGrid) | Occurs when the ShowParentDetails button is clicked.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from DataGrid) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

fireEvent (inherited from vdxDataGridNavigator) | Activate/Deactivate event firing for OnSelectionChanged and OnControlChanged.
mousePosition (inherited from vdxDataGridNavigator) | Mouse position after mouse click event.

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DataSet (inherited from vdxDataGrid) | Gets or sets DataSet on DataSource.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from DataGrid) | Gets the default size of the control.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HorizScrollBar (inherited from DataGrid) | Gets the horizontal scrollbar for the grid.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
SelectedDataRow (inherited from vdxDataGrid) | Gets the corresponding selected data row.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VertScrollBar (inherited from DataGrid) | Gets the vertical scroll bar of the control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AddRow (inherited from vdxDataGridNavigator) | Adds gridDataRow to data source table.
AttatchCurrencyManagerEventHandlers (inherited from vdxDataGridNavigator) | Register CurrencyManager listeners.
CancelEditing (inherited from DataGrid) | Cancels the current edit operation and rolls back all changes.
ChangeSelection (inherited from vdxDataGridNavigator) | Changes current selection to the given row.
Clear (inherited from vdxDataGridNavigator) | Remove all rows from the grid.
CreateAccessibilityInstance (inherited from DataGrid) | Constructs a new instance of the accessibility object for this control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateGridColumn (inherited from DataGrid) | Overloaded. Creates a new DataGridColumnStyle with the specified PropertyDescriptor.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateNavigatorInfoItem (inherited from vdxDataGridNavigator) | Creates a vdxNavigatorInfoItem for the given dataRow.
CurrencyManager_PositionChanged (inherited from vdxDataGridNavigator) | Event listener on CurrencyManager to detect position changes.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
Delete (inherited from vdxDataGridNavigator) | Deletes the selected row.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from DataGrid) | Overloaded.
Fill (inherited from vdxDataGridNavigator) | Builds a dataGrid for the given DataSet;
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetDataRowKey (inherited from vdxDataGridNavigator) | Gets an unique key to differ TreeNodes on the same hierarchy level.
GetGridDataRow (inherited from vdxDataGridNavigator) | Gets the corresponding grid DataRow for the given navigator DataRow.
GetLoaderInfo | Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.
GetNavigatorInfo (inherited from vdxDataGridNavigator) | Gets the corresponding navigation info for the given item.
GetNavigatorInfoItemForGridRow (inherited from vdxDataGridNavigator) | Gets the corresponding navigator DataRow for the given grid DataRow.
GetOutputTextDelimiter (inherited from DataGrid) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GridHScrolled (inherited from DataGrid) | Listens for the horizontal scrollbar's scroll event.
GridVScrolled (inherited from DataGrid) | Listens for the vertical scrollbar's scroll event.
InitLayout (inherited from Control) | Called after the control has been added to another container.
Insert (inherited from vdxDataGridNavigator) | Inserts a new navigator row for the corresponding navigator row.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsRefreshable (inherited from vdxDataGridNavigator) | Checks if the component supports refresh.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAllowNavigationChanged (inherited from DataGrid) | Raises the AllowNavigationChanged event.
OnBackButtonClicked (inherited from DataGrid) | Listens for the caption's back button clicked event.
OnBackColorChanged (inherited from DataGrid) | Raises the BackColorChanged event.
OnBackgroundColorChanged (inherited from DataGrid) | Raises the BackgroundColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from DataGrid) | Raises the BindingContextChanged event.
OnBorderStyleChanged (inherited from DataGrid) | Raises the BorderStyleChanged event.
OnCaptionVisibleChanged (inherited from DataGrid) | Raises the CaptionVisibleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlChanged (inherited from vdxDataGridNavigator) | Inform all registered components on ControlChanged about a control change.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCurrentCellChanged (inherited from DataGrid) | Raises the CurrentCellChanged event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from DataGrid) | Raises the DataSourceChanged event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from DataGrid) | Raises the Enter event.
OnFilled (inherited from vdxDataGridNavigator) | Raises the Filled event.
OnFlatModeChanged (inherited from DataGrid) | Raises the FlatModeChanged event.
OnFontChanged (inherited from DataGrid) | Raises the FontChanged event.
OnForeColorChanged (inherited from DataGrid) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from DataGrid) | Raises the CreateHandle event.
OnHandleDestroyed (inherited from DataGrid) | Raises the DestroyHandle event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from DataGrid) | Raises the KeyDown event.
OnKeyPress (inherited from DataGrid) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from DataGrid) | Raises the Layout event that repositions controls and updates scroll bars.
OnLeave (inherited from DataGrid) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from DataGrid) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from DataGrid) | Creates the MouseLeave event.
OnMouseMove (inherited from DataGrid) | Raises the MouseMove event.
OnMouseUp (inherited from DataGrid) | Raises the MouseUp event.
OnMouseWheel (inherited from DataGrid) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNavigate (inherited from DataGrid) | Raises the Navigate event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from DataGrid) | Raises the Paint event.
OnPaintBackground (inherited from DataGrid) | Overrides OnPaintBackground to prevent painting the background of the DataGrid control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentRowsLabelStyleChanged (inherited from DataGrid) | Raises the ParentRowsLabelStyleChanged event.
OnParentRowsVisibleChanged (inherited from DataGrid) | Raises the ParentRowsVisibleChanged event.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from DataGrid) | Raises the ReadOnlyChanged event
OnResize (inherited from DataGrid) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnRowHeaderClick (inherited from DataGrid) | Raises the RowHeaderClick event.
OnScroll (inherited from DataGrid) | Raises the Scroll event.
OnSelectionChanged (inherited from vdxDataGridNavigator) | Inform all registered components on SelectionChanged about a selection change.
OnShowParentDetailsButtonClicked (inherited from DataGrid) | Raises the ShowParentDetailsButtonClick event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from DataGrid) | Gets or sets a value that indicates whether a key should be processed further.
ProcessGridKey (inherited from DataGrid) | Processes keys for grid navigation.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from DataGrid) | Previews a keyboard message and returns a value indicating if the key was consumed.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
ProcessTabKey (inherited from DataGrid) | Gets a value indicating whether the Tab key should be processed.
ProviderToSet_OnDataTypeSet (inherited from vdxDataGrid) | Listens to the Event OnDataTypeSet that was set on DataSource and set the DataSource with the sender.
ProviderToSet_OnDataTypeSetDM (inherited from vdxDataGrid) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshData (inherited from vdxDataGridNavigator) | Remove all elements from the navigator and fill up the given dataSet.
RemoveRow (inherited from vdxDataGridNavigator) | Adds gridDataRow to data source table.
RemoveSelectedRow (inherited from vdxDataGridNavigator) | Removes current selected gridDataRow from data source table.
ResetMouseEventArgs (inherited from Control) |
ResetSelection (inherited from DataGrid) | Turns off selection for all rows that are selected.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SelectDefault | Selects the default element.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShouldSerializeAlternatingBackColor (inherited from DataGrid) | Indicates whether the AlternatingBackColor property should be persisted.
ShouldSerializeBackgroundColor (inherited from DataGrid) | Indicates whether the BackgroundColor property should be persisted.
ShouldSerializeCaptionBackColor (inherited from DataGrid) | Gets a value indicating whether the CaptionBackColor property should be persisted.
ShouldSerializeCaptionForeColor (inherited from DataGrid) | Gets a value indicating whether the CaptionForeColor property should be persisted.
ShouldSerializeGridLineColor (inherited from DataGrid) | Indicates whether the GridLineColor property should be persisted.
ShouldSerializeHeaderBackColor (inherited from DataGrid) | Indicates whether the HeaderBackColor property should be persisted.
ShouldSerializeHeaderFont (inherited from DataGrid) | Indicates whether the HeaderFont property should be persisted.
ShouldSerializeHeaderForeColor (inherited from DataGrid) | Indicates whether the HeaderForeColor property should be persisted.
ShouldSerializeLinkHoverColor (inherited from DataGrid) | Indicates whether the LinkHoverColor property should be persisted.
ShouldSerializeParentRowsBackColor (inherited from DataGrid) | Indicates whether the ParentRowsBackColor property should be persisted.
ShouldSerializeParentRowsForeColor (inherited from DataGrid) | Indicates whether the ParentRowsForeColor property should be persisted.
ShouldSerializePreferredRowHeight (inherited from DataGrid) | Indicates whether the PreferredRowHeight property should be persisted.
ShouldSerializeSelectionBackColor (inherited from DataGrid) | Indicates whether the SelectionBackColor property should be persisted.
ShouldSerializeSelectionForeColor (inherited from DataGrid) | Indicates whether the SelectionForeColor property should be persisted.
Undo (inherited from vdxDataGridNavigator) | Undo changes for the corresponding navigatorDataRow.
Update (inherited from vdxDataGridNavigator) | Overloaded. Updates the corresponding navigator row with the given manipulator row.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Instance Events

RowHeaderClick (inherited from DataGrid) Occurs when a row header is clicked.

Protected Internal Instance Properties

ListManager (inherited from DataGrid) Gets the CurrencyManager for this DataGrid control.

Protected Internal Instance Methods

ColumnStartedEditing (inherited from DataGrid) | Overloaded. Informs the DataGrid control when the user begins to edit a column using the specified control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.

Explicit Interface Implementations

IvdxNavigator.ChangeSelection (inherited from vdxDataGridNavigator)
IvdxNavigator.Clear (inherited from vdxDataGridNavigator)
IvdxNavigator.Copy (inherited from vdxDataGridNavigator)
IvdxNavigator.Delete (inherited from vdxDataGridNavigator)
IvdxNavigator.Fill (inherited from vdxDataGridNavigator)
IvdxNavigator.GetLoaderInfo (inherited from vdxDataGridNavigator)
IvdxNavigator.Insert (inherited from vdxDataGridNavigator)
IvdxNavigator.IsRefreshable (inherited from vdxDataGridNavigator)
IvdxNavigator.RefreshData (inherited from vdxDataGridNavigator)
IvdxNavigator.SelectDefault (inherited from vdxDataGridNavigator)
IvdxNavigator.Undo (inherited from vdxDataGridNavigator)
IvdxNavigator.Update (inherited from vdxDataGridNavigator)

See Also

vdxExplorerGridView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGridView Constructor

Initializes a new instance of the vdxExplorerGridView class.

public vdxExplorerGridView();

See Also

vdxExplorerGridView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGridView Properties

The properties of the vdxExplorerGridView class are listed below. For a complete list of vdxExplorerGridView class members, see the vdxExplorerGridView Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowNavigation (inherited from vdxDataGridNavigator) | Gets or sets a value indicating whether navigation is allowed.
AllowSorting (inherited from DataGrid) | Gets or sets a value indicating whether the grid can be resorted by clicking on a column header.
AlternatingBackColor (inherited from DataGrid) | Gets or sets the background color of odd-numbered rows of the grid.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from DataGrid) | Gets or sets the background color of even-numbered rows of the grid.
BackgroundColor (inherited from DataGrid) | Gets or sets the color of the non-row area of the grid.
BackgroundImage (inherited from DataGrid) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxDataGrid) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from DataGrid) | Gets or sets the grid's border style.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CaptionBackColor (inherited from DataGrid) | Gets or sets the background color of the caption area.
CaptionFont (inherited from DataGrid) | Gets or sets the font of the grid's caption.
CaptionForeColor (inherited from DataGrid) | Gets or sets the foreground color of the caption area.
CaptionText (inherited from DataGrid) | Gets or sets the text of the grid's window caption.
CaptionVisible | Gets or sets a value indicating whether the grid's caption is visible.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColumnHeadersVisible (inherited from DataGrid) | Gets or sets a value indicating whether the column headers a table are visible.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrencyManager (inherited from vdxDataGrid) | Gets the managed CurrencyManager of this data grid.
CurrentCell (inherited from DataGrid) | Gets or sets which cell has the focus. Not available at design time.
CurrentDataRow (inherited from vdxDataGrid) | Gets or sets the dataRows which are selected.
CurrentRowIndex (inherited from DataGrid) | Gets or sets index of the selected row.
Cursor (inherited from DataGrid) |
DataBindingInfos (inherited from vdxDataGrid) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataMember (inherited from vdxDataGrid) |
DataSource (inherited from vdxDataGrid) | Gets or sets the data source that this grid is displaying data for.
DataView (inherited from vdxDataGrid) | Gets the managed DataView of this data grid.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
ExplorerGrid | Gets or sets the corresponding explorerTree.
FirstVisibleColumn (inherited from DataGrid) | Gets the index of the first visible column in a grid.
FlatMode (inherited from DataGrid) | Gets or sets a value indicating whether the grid displays in flat mode.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from DataGrid) | Gets or sets the foreground color (typically the color of the text) property of the DataGrid control.
GridLineColor (inherited from DataGrid) | Gets or sets the color of the grid lines.
GridLineStyle (inherited from DataGrid) | Gets or sets the line style of the grid.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HeaderBackColor (inherited from DataGrid) | Gets or sets the background color of all row and column headers.
HeaderFont (inherited from DataGrid) | Gets or sets the font used for column headers.
HeaderForeColor (inherited from DataGrid) | Gets or sets the foreground color of headers.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Item (inherited from DataGrid) | Gets or sets the value of the cell at the specified the row and column.
Item (inherited from DataGrid) | Gets or sets the value of a specified DataGridCell .
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LinkColor (inherited from DataGrid) | Gets or sets the color of the text that you can click to navigate to a child table.
LinkHoverColor (inherited from DataGrid) | Gets or sets the color a link changes to when the mouse pointer moves over it.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentRowsBackColor (inherited from DataGrid) | Gets or sets the background color of parent rows.
ParentRowsForeColor (inherited from DataGrid) | Gets or sets the foreground color of parent rows.
ParentRowsLabelStyle (inherited from DataGrid) | Gets or sets the way parent row labels are displayed.
ParentRowsVisible (inherited from DataGrid) | Gets or sets a value indicating whether the parent rows of a table are visible.
PreferredColumnWidth (inherited from DataGrid) | Gets or sets the default width of the grid columns in pixels.
PreferredRowHeight (inherited from DataGrid) | Gets or sets the preferred row height for the DataGrid control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly | Gets or sets a value indicating whether the grid is a read-only mode.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RowHeadersVisible (inherited from DataGrid) | Gets or sets a value that specifies whether row headers are visible.
RowHeaderWidth (inherited from DataGrid) | Gets or sets the width of row headers.
SelectedDataRows (inherited from vdxDataGrid) | Gets or sets the dataRows which are selected.
SelectionBackColor (inherited from DataGrid) | Gets or sets the background color of selected rows.
SelectionForeColor (inherited from DataGrid) | Gets or set the foreground color of selected rows.
Site (inherited from DataGrid) |
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TableStyles (inherited from DataGrid) | Gets the collection of DataGridTableStyle objects for the grid.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from DataGrid) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisibleColumnCount (inherited from DataGrid) | Gets the number of visible columns.
VisibleRowCount (inherited from DataGrid) | Gets the number of rows visible.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DataSet (inherited from vdxDataGrid) | Gets or sets DataSet on DataSource.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from DataGrid) | Gets the default size of the control.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HorizScrollBar (inherited from DataGrid) | Gets the horizontal scrollbar for the grid.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
SelectedDataRow (inherited from vdxDataGrid) | Gets the corresponding selected data row.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VertScrollBar (inherited from DataGrid) | Gets the vertical scroll bar of the control.

Protected Internal Instance Properties

ListManager (inherited from DataGrid) Gets the CurrencyManager for this DataGrid control.

See Also

vdxExplorerGridView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGridView.CaptionVisible Property

Gets or sets a value indicating whether the grid's caption is visible.

new public bool CaptionVisible {get; set;}

See Also

vdxExplorerGridView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGridView.ExplorerGrid Property

Gets or sets the corresponding explorerTree.

public vdxExplorerGrid ExplorerGrid {get; set;}

See Also

vdxExplorerGridView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGridView.ReadOnly Property

Gets or sets a value indicating whether the grid is a read-only mode.

new public bool ReadOnly {get; set;}

See Also

vdxExplorerGridView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGridView Methods

The methods of the vdxExplorerGridView class are listed below. For a complete list of vdxExplorerGridView class members, see the vdxExplorerGridView Members topic.

Public Instance Methods

BeginEdit (inherited from DataGrid) | Attempts to put the grid into a state where editing is allowed.
BeginInit (inherited from DataGrid) | Begins the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Collapse (inherited from DataGrid) | Collapses child relations, if any exist for all rows, or for a specified row.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndEdit (inherited from DataGrid) | Requests an end to an edit operation taking place on the DataGrid control.
EndInit (inherited from DataGrid) | Ends the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from DataGrid) | Displays child relations, if any exist, for all rows or a specific row.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindRows (inherited from vdxDataGrid) | Find rows by a SQL where clause.
FindText (inherited from vdxDataGrid) | Full text search for the passed Text. Every row is scanned for the Text. If the row contains the text, it is added to the resultion row collection.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxDataGrid) | Get the binding info for the Property specified.
GetCellBounds (inherited from DataGrid) | Overloaded. Gets the Rectangle of the cell specified by row and column number.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetCurrentCellBounds (inherited from DataGrid) | Gets a Rectangle that specifies the four corners of the selected cell.
GetDataRowAT (inherited from vdxDataGrid) | Gets the Datarow with the specified index
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetRowIndex (inherited from vdxDataGrid) | Returns the (momentary) index of a row in the grid. The returned index depends on the momentary sort order.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HitTest (inherited from DataGrid) | Overloaded. Gets information, such as row and column number of a clicked point on the grid, using the x and y coordinate passed to the method.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
IsExpanded (inherited from DataGrid) | Gets a value that indicates whether a specified row's node is expanded or collapsed.
IsSelected (inherited from DataGrid) | Gets a value indicating whether a specified row is selected.
MoveFirst (inherited from vdxDataGrid) | Moves to the first record in the grid
MoveLast (inherited from vdxDataGrid) | Move to the last record of the grid if possible
MoveNext (inherited from vdxDataGrid) | Moves to the next record in the grid. If we are already on the last record, moves to the first record.
MovePrevious (inherited from vdxDataGrid) | Moves to the previous record in the grid. If we are already on the first recorde, moves to the last record
NavigateBack (inherited from DataGrid) | Navigates back to the table previously displayed in the grid.
NavigateTo (inherited from DataGrid) | Navigates to the table specified by row and relation name.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetAlternatingBackColor (inherited from DataGrid) | Resets the AlternatingBackColor property to its default color.
ResetBackColor (inherited from DataGrid) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from DataGrid) | Resets the ForeColor property to its default value.
ResetGridLineColor (inherited from DataGrid) | Resets the GridLineColor property to its default value.
ResetHeaderBackColor (inherited from DataGrid) | Resets the HeaderBackColor property to its default value.
ResetHeaderFont (inherited from DataGrid) | Resets the HeaderFont property to its default value.
ResetHeaderForeColor (inherited from DataGrid) | Resets the HeaderForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetLinkColor (inherited from DataGrid) | Resets the LinkColor property to its default value.
ResetLinkHoverColor (inherited from DataGrid) |
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetSelectionBackColor (inherited from DataGrid) | Resets the SelectionBackColor property to its default value.
ResetSelectionForeColor (inherited from DataGrid) | Resets the SelectionForeColor property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from DataGrid) | Overloaded. Selects a specified row.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo (inherited from vdxDataGrid) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDataBinding (inherited from DataGrid) | Sets the DataSource and DataMember properties at run time.
Show (inherited from Control) | Displays the control to the user.
SubObjectsSiteChange (inherited from DataGrid) |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
UnSelect (inherited from DataGrid) | Unselects a specified row.
Update (inherited from Control) | Overloaded. Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AddRow (inherited from vdxDataGridNavigator) | Adds gridDataRow to data source table.
AttatchCurrencyManagerEventHandlers (inherited from vdxDataGridNavigator) | Register CurrencyManager listeners.
CancelEditing (inherited from DataGrid) | Cancels the current edit operation and rolls back all changes.
ChangeSelection (inherited from vdxDataGridNavigator) | Changes current selection to the given row.
Clear (inherited from vdxDataGridNavigator) | Remove all rows from the grid.
CreateAccessibilityInstance (inherited from DataGrid) | Constructs a new instance of the accessibility object for this control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateGridColumn (inherited from DataGrid) | Overloaded. Creates a new DataGridColumnStyle with the specified PropertyDescriptor.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateNavigatorInfoItem (inherited from vdxDataGridNavigator) | Creates a vdxNavigatorInfoItem for the given dataRow.
CurrencyManager_PositionChanged (inherited from vdxDataGridNavigator) | Event listener on CurrencyManager to detect position changes.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
Delete (inherited from vdxDataGridNavigator) | Deletes the selected row.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from DataGrid) | Overloaded.
Fill (inherited from vdxDataGridNavigator) | Builds a dataGrid for the given DataSet;
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetDataRowKey (inherited from vdxDataGridNavigator) | Gets an unique key to differ TreeNodes on the same hierarchy level.
GetGridDataRow (inherited from vdxDataGridNavigator) | Gets the corresponding grid DataRow for the given navigator DataRow.
GetLoaderInfo | Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.
GetNavigatorInfo (inherited from vdxDataGridNavigator) | Gets the corresponding navigation info for the given item.
GetNavigatorInfoItemForGridRow (inherited from vdxDataGridNavigator) | Gets the corresponding navigator DataRow for the given grid DataRow.
GetOutputTextDelimiter (inherited from DataGrid) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GridHScrolled (inherited from DataGrid) | Listens for the horizontal scrollbar's scroll event.
GridVScrolled (inherited from DataGrid) | Listens for the vertical scrollbar's scroll event.
InitLayout (inherited from Control) | Called after the control has been added to another container.
Insert (inherited from vdxDataGridNavigator) | Inserts a new navigator row for the corresponding navigator row.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsRefreshable (inherited from vdxDataGridNavigator) | Checks if the component supports refresh.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAllowNavigationChanged (inherited from DataGrid) | Raises the AllowNavigationChanged event.
OnBackButtonClicked (inherited from DataGrid) | Listens for the caption's back button clicked event.
OnBackColorChanged (inherited from DataGrid) | Raises the BackColorChanged event.
OnBackgroundColorChanged (inherited from DataGrid) | Raises the BackgroundColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from DataGrid) | Raises the BindingContextChanged event.
OnBorderStyleChanged (inherited from DataGrid) | Raises the BorderStyleChanged event.
OnCaptionVisibleChanged (inherited from DataGrid) | Raises the CaptionVisibleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlChanged (inherited from vdxDataGridNavigator) | Inform all registered components on ControlChanged about a control change.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCurrentCellChanged (inherited from DataGrid) | Raises the CurrentCellChanged event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from DataGrid) | Raises the DataSourceChanged event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from DataGrid) | Raises the Enter event.
OnFilled (inherited from vdxDataGridNavigator) | Raises the Filled event.
OnFlatModeChanged (inherited from DataGrid) | Raises the FlatModeChanged event.
OnFontChanged (inherited from DataGrid) | Raises the FontChanged event.
OnForeColorChanged (inherited from DataGrid) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from DataGrid) | Raises the CreateHandle event.
OnHandleDestroyed (inherited from DataGrid) | Raises the DestroyHandle event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from DataGrid) | Raises the KeyDown event.
OnKeyPress (inherited from DataGrid) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from DataGrid) | Raises the Layout event that repositions controls and updates scroll bars.
OnLeave (inherited from DataGrid) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from DataGrid) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from DataGrid) | Creates the MouseLeave event.
OnMouseMove (inherited from DataGrid) | Raises the MouseMove event.
OnMouseUp (inherited from DataGrid) | Raises the MouseUp event.
OnMouseWheel (inherited from DataGrid) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNavigate (inherited from DataGrid) | Raises the Navigate event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from DataGrid) | Raises the Paint event.
OnPaintBackground (inherited from DataGrid) | Overrides OnPaintBackground to prevent painting the background of the DataGrid control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentRowsLabelStyleChanged (inherited from DataGrid) | Raises the ParentRowsLabelStyleChanged event.
OnParentRowsVisibleChanged (inherited from DataGrid) | Raises the ParentRowsVisibleChanged event.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from DataGrid) | Raises the ReadOnlyChanged event
OnResize (inherited from DataGrid) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnRowHeaderClick (inherited from DataGrid) | Raises the RowHeaderClick event.
OnScroll (inherited from DataGrid) | Raises the Scroll event.
OnSelectionChanged (inherited from vdxDataGridNavigator) | Inform all registered components on SelectionChanged about a selection change.
OnShowParentDetailsButtonClicked (inherited from DataGrid) | Raises the ShowParentDetailsButtonClick event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from DataGrid) | Gets or sets a value that indicates whether a key should be processed further.
ProcessGridKey (inherited from DataGrid) | Processes keys for grid navigation.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from DataGrid) | Previews a keyboard message and returns a value indicating if the key was consumed.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
ProcessTabKey (inherited from DataGrid) | Gets a value indicating whether the Tab key should be processed.
ProviderToSet_OnDataTypeSet (inherited from vdxDataGrid) | Listens to the Event OnDataTypeSet that was set on DataSource and set the DataSource with the sender.
ProviderToSet_OnDataTypeSetDM (inherited from vdxDataGrid) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshData (inherited from vdxDataGridNavigator) | Remove all elements from the navigator and fill up the given dataSet.
RemoveRow (inherited from vdxDataGridNavigator) | Adds gridDataRow to data source table.
RemoveSelectedRow (inherited from vdxDataGridNavigator) | Removes current selected gridDataRow from data source table.
ResetMouseEventArgs (inherited from Control) |
ResetSelection (inherited from DataGrid) | Turns off selection for all rows that are selected.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SelectDefault | Selects the default element.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShouldSerializeAlternatingBackColor (inherited from DataGrid) | Indicates whether the AlternatingBackColor property should be persisted.
ShouldSerializeBackgroundColor (inherited from DataGrid) | Indicates whether the BackgroundColor property should be persisted.
ShouldSerializeCaptionBackColor (inherited from DataGrid) | Gets a value indicating whether the CaptionBackColor property should be persisted.
ShouldSerializeCaptionForeColor (inherited from DataGrid) | Gets a value indicating whether the CaptionForeColor property should be persisted.
ShouldSerializeGridLineColor (inherited from DataGrid) | Indicates whether the GridLineColor property should be persisted.
ShouldSerializeHeaderBackColor (inherited from DataGrid) | Indicates whether the HeaderBackColor property should be persisted.
ShouldSerializeHeaderFont (inherited from DataGrid) | Indicates whether the HeaderFont property should be persisted.
ShouldSerializeHeaderForeColor (inherited from DataGrid) | Indicates whether the HeaderForeColor property should be persisted.
ShouldSerializeLinkHoverColor (inherited from DataGrid) | Indicates whether the LinkHoverColor property should be persisted.
ShouldSerializeParentRowsBackColor (inherited from DataGrid) | Indicates whether the ParentRowsBackColor property should be persisted.
ShouldSerializeParentRowsForeColor (inherited from DataGrid) | Indicates whether the ParentRowsForeColor property should be persisted.
ShouldSerializePreferredRowHeight (inherited from DataGrid) | Indicates whether the PreferredRowHeight property should be persisted.
ShouldSerializeSelectionBackColor (inherited from DataGrid) | Indicates whether the SelectionBackColor property should be persisted.
ShouldSerializeSelectionForeColor (inherited from DataGrid) | Indicates whether the SelectionForeColor property should be persisted.
Undo (inherited from vdxDataGridNavigator) | Undo changes for the corresponding navigatorDataRow.
Update (inherited from vdxDataGridNavigator) | Overloaded. Updates the corresponding navigator row with the given manipulator row.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ColumnStartedEditing (inherited from DataGrid) | Overloaded. Informs the DataGrid control when the user begins to edit a column using the specified control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.

Explicit Interface Implementations

IvdxNavigator.ChangeSelection (inherited from vdxDataGridNavigator)
IvdxNavigator.Clear (inherited from vdxDataGridNavigator)
IvdxNavigator.Copy (inherited from vdxDataGridNavigator)
IvdxNavigator.Delete (inherited from vdxDataGridNavigator)
IvdxNavigator.Fill (inherited from vdxDataGridNavigator)
IvdxNavigator.GetLoaderInfo (inherited from vdxDataGridNavigator)
IvdxNavigator.Insert (inherited from vdxDataGridNavigator)
IvdxNavigator.IsRefreshable (inherited from vdxDataGridNavigator)
IvdxNavigator.RefreshData (inherited from vdxDataGridNavigator)
IvdxNavigator.SelectDefault (inherited from vdxDataGridNavigator)
IvdxNavigator.Undo (inherited from vdxDataGridNavigator)
IvdxNavigator.Update (inherited from vdxDataGridNavigator)

See Also

vdxExplorerGridView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGridView.GetLoaderInfo Method

Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.

protected override vdxLoaderInfo GetLoaderInfo(
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorInfo
Contains the DataRow to define the vdxLoaderInfo.

Return Value

The vdxLoaderInfo for the given navigatorInfo.

See Also

vdxExplorerGridView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerGridView.SelectDefault Method

Selects the default element.

protected override void SelectDefault();

See Also

vdxExplorerGridView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree Class

Control used for standard exploring capabilities with a treeview.

For a list of all members of this type, see vdxExplorerTree Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxCacheableControl
vdxDataControl
vdxExplorer
vdxExplorerTree

public class vdxExplorerTree : vdxExplorer

Remarks

This class gets used to implement your data exploring scenarios.

Example

This example shows how to implement a vdxExplorerTree. First we must derive from vdxExplorerTree:

            public class ExplorerTreePerson : vdxExplorerTree
            {
                ...
            }
Than these methods must be overridden to provide the base funcionality: LoadDataGetTreeNodeGetLoaderInfo Override the LoadData method to provide a DataSet that contains all data to build the vdxExplorerTreeView and to fill up the SelectionGridType.
            protected override void LoadData()
            {
                dsPersList ds = WebServiceProvider.wsPers.GetDataSetPersList(this.SearchParameters.GetParameters());

                if (ds.Pers.Count > 0)
                {
                    return ds;
                }
                else
                {
                    MessageBox.Show(
                        "No person found. Please try again!",
                        "VDX Sample Application",
                        MessageBoxButtons.OK,
                        MessageBoxIcon.Information);

                    return null;
                }
            }
Note The property SearchParameters is set after either - the user has clicked the search button in the SearchControlType or - it is automatically set in the initializing sequence of the vdxExplorerTree if no SearchControlType was configured.
Override the GetTreeNode method to define the look and feel of a TreeNode.
            protected override void GetTreeNode(vdxNavigatorInfoItem navInfoItem, vdxTreeNode parentNode)
            {
                StringBuilder sb = new StringBuilder();
                dsPersList.PersRow row = ((vdxNavigatorInfoItemRow)navInfoItem).DataRow as dsPersList.PersRow;

                if (row != null)
                {
                    if (!navInfoItem.IsInserted() && (!(Convert.IsDBNull(row.LastName) && Convert.IsDBNull(row.FirstName))))
                    {
                        sb.Append(row.LastName);
                        sb.Append(" ");
                        sb.Append(row.FirstName);
                    }
                    else
                    {
                        sb.Append("New person");
                    }
                }
                return new vdxTreeNode(sb.ToString(), 2, 1, false);
            }
Override the GetLoaderInfo method to define the vdxSearchParameters to perform data load and the Type of vdxDataDetail to display in the MultiContainer.
            protected override void GetLoaderInfo(vdxNavigatorInfo navigatorInfo)
            {
                vdxSearchParameters searchParameters = null;
                dsPersList.PersRow row = navigatorInfo.SelectedRow as dsPersList.PersRow;

                if (row != null)
                {
                    int persId = (int)row.PersID;
                    searchParameters = new vdxSearchParameters("Person");
                    searchParameters.Add("PersId", persId);
                }
                return new vdxLoaderInfo(searchParameters, typeof(DataDetailPerson));
            }

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxExplorerTree Members | Deag.Vdx.Controls.Standard Namespace | vdxExplorer | vdxDataDetail | vdxSearchParameters | IvdxSearchControl | vdxSelectionGrid | vdxExplorerTreeView | vdxDataMultiContainer | vdxNavigatorInfo | vdxLoaderInfo

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree Members

vdxExplorerTree overview

Public Instance Constructors

vdxExplorerTree Constructor Default constructor.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataActionManager (inherited from vdxExplorer) | Gets and sets the current vdxDataActionManager from the vdxDataMultiContainer.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataStatusManager (inherited from vdxExplorer) | Gets the current vdxDataStatusManager from the vdxDataMultiContainer.
DisplayMode (inherited from vdxExplorer) | Gets or sets the current display mode.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MultiContainer | Overrides MultiContainer to hide the property in Design Mode.
Name (inherited from Control) | Gets or sets the name of the control.
NavigatorDataSet (inherited from vdxExplorer) | Gets the loaded DataSet for all navigators.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SearchControl (inherited from vdxExplorer) | Gets the created instance of the SearchControlType.
SearchControlType (inherited from vdxExplorer) | Gets or sets the name of the typed SearchControl, which will be instantiated later.
SearchParameters (inherited from vdxExplorer) | Gets or sets the search parameters for this explorer.
SelectionGridType | Gets or sets the selectionGridType for the selection node.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

AddInitial (inherited from vdxExplorer) | Adds a new entry on DataStatusManager for the corresponding dataDetailType.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DesiredTable | Gets the desired table in the dataSet for the corresponding searchParameters.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Fill | Builds the tree.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GenerateSubNodeSearchParameters | Generates vdxSearchParameters to load subnodes.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetLoaderInfo (inherited from vdxExplorer) | Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetRootNode | Gets the root node that correspond to the SelectionGridType.
GetTreeNode | Gets the corresponding TreeNode for the row and parentNode.
GetTreeNodeKey | Gets an unique key to differ TreeNodes on the same hierarchy level.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LoadData | Overloaded. Delegates the components to load the corresponding data for the given search parameters.
PerformDataLoad (inherited from vdxExplorer) | Delegates the components to load the corresponding data for the given search parameters.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

dataMultiContainer | Holds the container to display the corresponding selected navigator element.
dataSet (inherited from vdxExplorer) | Holds the actual dataSet, which is delegated to all navigators.
multiContainer (inherited from vdxExplorer) | Holds the detail container for this explorer.
selectedNavigatorInfo (inherited from vdxExplorer) | The actual selected vdxNavigatorInfo in the navigators.
splitter | Holds the splitter which divide treeView and dataMultiContainer.
treeView | Holds the navigator for this explorer.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
NavigatorCollection (inherited from vdxExplorer) | Gets the NavigatorCollection, which holds IvdxNavigator components.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActionItemFind_ActionInvoked (inherited from vdxExplorer) | Implementation of the ActionItemFind event listeners.
ActionItemRefresh_ActionInvoked (inherited from vdxExplorer) | Implementation of the ActionItemRefresh event listeners.
ActionItemRefreshAll_ActionInvoked (inherited from vdxExplorer) | Implementation of the ActionItemRefreshAll event listeners.
Activate | Overrides Activate to hide multiContainer if NavigatorDataSet is null or contains no data.
AdjustFormScrollbars (inherited from ContainerControl) |
AllowFind (inherited from vdxExplorer) | Gets whether to enable the find button.
Create | The method is called once in the lifetime of the cacheable component after this was instantiated.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateNavigatorRow | Overrides CreateNavigatorRow and use DesiredTable.
Deactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DeactivateAllowed (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
EnableActions (inherited from vdxExplorer) | Enables refresh and find actions on DataActionManager .
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HandleChanges (inherited from vdxExplorer) | Activate the element with unsaved changes.
HasChanges (inherited from vdxExplorer) | Indicates if a component or one of its subcomponents has pending changes.
InitializeNavigatorCollection (inherited from vdxExplorer) | Add all controls that implement IvdxNavigator to the NavigatorCollection.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsRefreshable (inherited from vdxExplorer) | Checks if the component supports refresh.
LayoutAll | Change visibility of splitter.
LoadData (inherited from vdxExplorer) | Overloaded. Delegates the components to load the corresponding data for the given search parameters.
Manipulator_RowCopied (inherited from vdxExplorer) | Listens to the manipulator copied event of a data detail.
Manipulator_RowDeleted | Overrides Manipulator_RowDeleted to hide multiContainer if NavigatorDataSet is null or contains no data after a row was deleted.
Manipulator_RowInserted (inherited from vdxExplorer) | Listens to the manipulator insert event of a data detail.
Manipulator_RowUpdated (inherited from vdxExplorer) | Listens to the manipulator update event of a data detail.
Manipulator_Undone | Overrides Manipulator_Undone to hide multiContainer if NavigatorDataSet is null or contains no data after an undone changes.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Navigator_ControlChanged | Fire also selection changes for SelectionGridType.
Navigator_SelectionChanged | Avoid selection changes for SelectionGridType.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
Reactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshData (inherited from vdxExplorer) | Loads again the data.
RefreshSelectedDataLoader (inherited from vdxExplorer) | Reloads the current selected data detail.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
SearchControl_SearchParamsFilled (inherited from vdxExplorer) | Inform all navigators about the new loaded DataSet to construct their navigation elements.
Select (inherited from ContainerControl) | Overloaded.
SelectDefault | Selects the default element.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShowDetail (inherited from vdxExplorer) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateNavigatorRow (inherited from vdxExplorer) | Update navigator DataRow with the given vdxDataManipulatorEventArgs.ManipulatorData.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxChangeable.HandleChanges (inherited from vdxDataControl)
IvdxChangeable.HasChanges (inherited from vdxDataControl)
IvdxDataLoader.ClearSearchParameters (inherited from vdxExplorer)
IvdxDataLoader.IsRefreshable (inherited from vdxExplorer)
IvdxDataLoader.PerformDataLoad (inherited from vdxExplorer)
IvdxDataLoader.RefreshData (inherited from vdxExplorer)
IvdxMultiContainerCacheable.Activate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Create (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Deactivate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.DeactivateAllowed (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Reactivate (inherited from vdxCacheableControl)

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace | vdxExplorer | vdxDataDetail | vdxSearchParameters | IvdxSearchControl | vdxSelectionGrid | vdxExplorerTreeView | vdxDataMultiContainer | vdxNavigatorInfo | vdxLoaderInfo

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree Constructor

Default constructor.

public vdxExplorerTree();

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree Fields

The fields of the vdxExplorerTree class are listed below. For a complete list of vdxExplorerTree class members, see the vdxExplorerTree Members topic.

Protected Instance Fields

dataMultiContainer | Holds the container to display the corresponding selected navigator element.
dataSet (inherited from vdxExplorer) | Holds the actual dataSet, which is delegated to all navigators.
multiContainer (inherited from vdxExplorer) | Holds the detail container for this explorer.
selectedNavigatorInfo (inherited from vdxExplorer) | The actual selected vdxNavigatorInfo in the navigators.
splitter | Holds the splitter which divide treeView and dataMultiContainer.
treeView | Holds the navigator for this explorer.

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace | vdxExplorer | vdxDataDetail | vdxSearchParameters | IvdxSearchControl | vdxSelectionGrid | vdxExplorerTreeView | vdxDataMultiContainer | vdxNavigatorInfo | vdxLoaderInfo

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.dataMultiContainer Field

Holds the container to display the corresponding selected navigator element.

protected vdxDataMultiContainer dataMultiContainer;

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.splitter Field

Holds the splitter which divide treeView and dataMultiContainer.

protected Splitter splitter;

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.treeView Field

Holds the navigator for this explorer.

protected vdxExplorerTreeView treeView;

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree Properties

The properties of the vdxExplorerTree class are listed below. For a complete list of vdxExplorerTree class members, see the vdxExplorerTree Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataActionManager (inherited from vdxExplorer) | Gets and sets the current vdxDataActionManager from the vdxDataMultiContainer.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataStatusManager (inherited from vdxExplorer) | Gets the current vdxDataStatusManager from the vdxDataMultiContainer.
DisplayMode (inherited from vdxExplorer) | Gets or sets the current display mode.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MultiContainer | Overrides MultiContainer to hide the property in Design Mode.
Name (inherited from Control) | Gets or sets the name of the control.
NavigatorDataSet (inherited from vdxExplorer) | Gets the loaded DataSet for all navigators.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SearchControl (inherited from vdxExplorer) | Gets the created instance of the SearchControlType.
SearchControlType (inherited from vdxExplorer) | Gets or sets the name of the typed SearchControl, which will be instantiated later.
SearchParameters (inherited from vdxExplorer) | Gets or sets the search parameters for this explorer.
SelectionGridType | Gets or sets the selectionGridType for the selection node.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
NavigatorCollection (inherited from vdxExplorer) | Gets the NavigatorCollection, which holds IvdxNavigator components.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace | vdxExplorer | vdxDataDetail | vdxSearchParameters | IvdxSearchControl | vdxSelectionGrid | vdxExplorerTreeView | vdxDataMultiContainer | vdxNavigatorInfo | vdxLoaderInfo

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.MultiContainer Property

Overrides MultiContainer to hide the property in Design Mode.

new public Deag.Vdx.Controls.Core.vdxMultiContainer MultiContainer {get; set;}

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.SelectionGridType Property

Gets or sets the selectionGridType for the selection node.

public string SelectionGridType {get; set;}

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree Methods

The methods of the vdxExplorerTree class are listed below. For a complete list of vdxExplorerTree class members, see the vdxExplorerTree Members topic.

Public Instance Methods

AddInitial (inherited from vdxExplorer) | Adds a new entry on DataStatusManager for the corresponding dataDetailType.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DesiredTable | Gets the desired table in the dataSet for the corresponding searchParameters.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Fill | Builds the tree.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GenerateSubNodeSearchParameters | Generates vdxSearchParameters to load subnodes.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetLoaderInfo (inherited from vdxExplorer) | Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetRootNode | Gets the root node that correspond to the SelectionGridType.
GetTreeNode | Gets the corresponding TreeNode for the row and parentNode.
GetTreeNodeKey | Gets an unique key to differ TreeNodes on the same hierarchy level.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LoadData | Overloaded. Delegates the components to load the corresponding data for the given search parameters.
PerformDataLoad (inherited from vdxExplorer) | Delegates the components to load the corresponding data for the given search parameters.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActionItemFind_ActionInvoked (inherited from vdxExplorer) | Implementation of the ActionItemFind event listeners.
ActionItemRefresh_ActionInvoked (inherited from vdxExplorer) | Implementation of the ActionItemRefresh event listeners.
ActionItemRefreshAll_ActionInvoked (inherited from vdxExplorer) | Implementation of the ActionItemRefreshAll event listeners.
Activate | Overrides Activate to hide multiContainer if NavigatorDataSet is null or contains no data.
AdjustFormScrollbars (inherited from ContainerControl) |
AllowFind (inherited from vdxExplorer) | Gets whether to enable the find button.
Create | The method is called once in the lifetime of the cacheable component after this was instantiated.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateNavigatorRow | Overrides CreateNavigatorRow and use DesiredTable.
Deactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DeactivateAllowed (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
EnableActions (inherited from vdxExplorer) | Enables refresh and find actions on DataActionManager .
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HandleChanges (inherited from vdxExplorer) | Activate the element with unsaved changes.
HasChanges (inherited from vdxExplorer) | Indicates if a component or one of its subcomponents has pending changes.
InitializeNavigatorCollection (inherited from vdxExplorer) | Add all controls that implement IvdxNavigator to the NavigatorCollection.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsRefreshable (inherited from vdxExplorer) | Checks if the component supports refresh.
LayoutAll | Change visibility of splitter.
LoadData (inherited from vdxExplorer) | Overloaded. Delegates the components to load the corresponding data for the given search parameters.
Manipulator_RowCopied (inherited from vdxExplorer) | Listens to the manipulator copied event of a data detail.
Manipulator_RowDeleted | Overrides Manipulator_RowDeleted to hide multiContainer if NavigatorDataSet is null or contains no data after a row was deleted.
Manipulator_RowInserted (inherited from vdxExplorer) | Listens to the manipulator insert event of a data detail.
Manipulator_RowUpdated (inherited from vdxExplorer) | Listens to the manipulator update event of a data detail.
Manipulator_Undone | Overrides Manipulator_Undone to hide multiContainer if NavigatorDataSet is null or contains no data after an undone changes.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Navigator_ControlChanged | Fire also selection changes for SelectionGridType.
Navigator_SelectionChanged | Avoid selection changes for SelectionGridType.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
Reactivate (inherited from vdxCacheableControl) | Override this method for your specific cacheable control.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshData (inherited from vdxExplorer) | Loads again the data.
RefreshSelectedDataLoader (inherited from vdxExplorer) | Reloads the current selected data detail.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
SearchControl_SearchParamsFilled (inherited from vdxExplorer) | Inform all navigators about the new loaded DataSet to construct their navigation elements.
Select (inherited from ContainerControl) | Overloaded.
SelectDefault | Selects the default element.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShowDetail (inherited from vdxExplorer) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateNavigatorRow (inherited from vdxExplorer) | Update navigator DataRow with the given vdxDataManipulatorEventArgs.ManipulatorData.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxChangeable.HandleChanges (inherited from vdxDataControl)
IvdxChangeable.HasChanges (inherited from vdxDataControl)
IvdxDataLoader.ClearSearchParameters (inherited from vdxExplorer)
IvdxDataLoader.IsRefreshable (inherited from vdxExplorer)
IvdxDataLoader.PerformDataLoad (inherited from vdxExplorer)
IvdxDataLoader.RefreshData (inherited from vdxExplorer)
IvdxMultiContainerCacheable.Activate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Create (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Deactivate (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.DeactivateAllowed (inherited from vdxCacheableControl)
IvdxMultiContainerCacheable.Reactivate (inherited from vdxCacheableControl)

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace | vdxExplorer | vdxDataDetail | vdxSearchParameters | IvdxSearchControl | vdxSelectionGrid | vdxExplorerTreeView | vdxDataMultiContainer | vdxNavigatorInfo | vdxLoaderInfo

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.Activate Method

Overrides Activate to hide multiContainer if NavigatorDataSet is null or contains no data.

protected override void Activate();

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.Create Method

The method is called once in the lifetime of the cacheable component after this was instantiated.

protected override void Create();

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.CreateNavigatorRow Method

Overrides CreateNavigatorRow and use DesiredTable.

protected override DataRow CreateNavigatorRow(
ManipulatorData manipulatorData
);

Parameters

manipulatorData
The data to import from.

Return Value

An instance of the imported navigator row.

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.DesiredTable Method

Gets the desired table in the dataSet for the corresponding searchParameters.

public virtual DataTable DesiredTable(
DataSet dataSet
);

Parameters

dataSet
The dataSet, which holds the table(s).

Return Value

The table corresponding to the searchParameter.

Remarks

Default table is the first one in the dataSet.

dataSet.Tables[0]
Is called in the Fill method to define from which table the rows had to be extracted.

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.Fill Method

Builds the tree.

public virtual void Fill(
DataSet dataSet
);

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.GenerateSubNodeSearchParameters Method

Generates vdxSearchParameters to load subnodes.

public virtual vdxSearchParameters GenerateSubNodeSearchParameters(
vdxNavigatorInfoItem navInfoItem
);

Parameters

navInfoItem
The row, which contains information to build the searchParameters.

Return Value

The corresponding searchParameters for the given row.

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.GetRootNode Method

Gets the root node that correspond to the SelectionGridType.

public virtual vdxTreeNode GetRootNode();

Return Value

The root node.

Remarks

Default implementation returns

new vdxTreeNode("Selection", 0, 0)
. To disable root node override method and return
null
.

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.GetTreeNode Method

Gets the corresponding TreeNode for the row and parentNode.

public virtual vdxTreeNode GetTreeNode(
vdxNavigatorInfoItem navInfoItem,
vdxTreeNode parentNode
);

Parameters

navInfoItem
The row to extract treeNode parameters.
parentNode
The parent node of the new treeNode.

Return Value

The corresponding vdxTreeNode.

Remarks

Must be implemented by the derived class.

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.GetTreeNodeKey Method

Gets an unique key to differ TreeNodes on the same hierarchy level.

public virtual object GetTreeNodeKey(
vdxNavigatorInfo navInfo
);

Parameters

navInfo
The vdxNavigatorInfo to extract key out of.

Return Value

The unique key of the treeNode.

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.LayoutAll Method

Change visibility of splitter.

protected override void LayoutAll();

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


LoadData Method

VDX Framework

vdxExplorerTree.LoadData Method

Delegates the components to load the corresponding data for the given search parameters.

Overload List

Inherited from vdxExplorer.

protected virtual DataSet LoadData();

Delegates the components to load the corresponding data for the given search parameters.

public virtual DataSet LoadData(vdxSearchParameters);

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.LoadData Method (vdxSearchParameters)

Delegates the components to load the corresponding data for the given search parameters.

public virtual DataSet LoadData(
vdxSearchParameters searchParameters
);

Parameters

searchParameters
The specific search arguments.

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace | vdxExplorerTree.LoadData Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.Manipulator_RowDeleted Method

Overrides Manipulator_RowDeleted to hide multiContainer if NavigatorDataSet is null or contains no data after a row was deleted.

protected override void Manipulator_RowDeleted(
object source,
vdxDataManipulatorEventArgs eventArgs
);

Parameters

source
eventArgs

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.Manipulator_Undone Method

Overrides Manipulator_Undone to hide multiContainer if NavigatorDataSet is null or contains no data after an undone changes.

protected override void Manipulator_Undone(
object source,
vdxDataManipulatorEventArgs eventArgs
);

Parameters

source
eventArgs

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.Navigator_ControlChanged Method

Fire also selection changes for SelectionGridType.

protected override void Navigator_ControlChanged(
object source,
vdxNavigatorControlEventArgs eventArgs
);

Parameters

source
The navigator that has fired the event.
eventArgs
Contains the involved vdxLoaderInfo.

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.Navigator_SelectionChanged Method

Avoid selection changes for SelectionGridType.

protected override void Navigator_SelectionChanged(
object source,
vdxNavigatorSelectionEventArgs eventArgs
);

Parameters

source
The navigator that has fired the event.
eventArgs
Contains the involved vdxNavigatorInfo.

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTree.SelectDefault Method

Selects the default element.

protected override void SelectDefault();

See Also

vdxExplorerTree Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView Class

Specialized treeView used in the standard vdxExplorerTree.

For a list of all members of this type, see vdxExplorerTreeView Members.

System.Object
MarshalByRefObject
Component
Control
TreeView
vdxTreeView
vdxExplorerTreeView

public class vdxExplorerTreeView : vdxTreeView

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxExplorerTreeView Members | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView Members

vdxExplorerTreeView overview

Public Instance Constructors

vdxExplorerTreeView Constructor Creates an instance of the class vdxExplorerTreeView.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from TreeView) |
BackgroundImage (inherited from TreeView) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxTreeView) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from TreeView) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CheckBoxes (inherited from TreeView) | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos (inherited from vdxTreeView) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
ExplorerTree | Gets or sets the corresponding explorerTree.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TreeView) |
FullRowSelect (inherited from TreeView) | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TreeView) | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus.
HotTracking (inherited from TreeView) | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it.
ImageIndex (inherited from TreeView) | Gets or sets the image-list index value of the default image that is displayed by the tree nodes.
ImageList (inherited from TreeView) | Gets or sets the ImageList that contains the Image objects used by the tree nodes.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
Indent (inherited from TreeView) | Gets or sets the distance to indent each of the child tree node levels.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from TreeView) | Gets or sets the height of each tree node in the tree view control.
LabelEdit (inherited from TreeView) | Gets or sets a value indicating whether the label text of the tree nodes can be edited.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Nodes (inherited from TreeView) | Gets the collection of tree nodes that are assigned to the tree view control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PathSeparator (inherited from TreeView) | Gets or sets the delimiter string that the tree node path uses.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
RefreshAlgorithm (inherited from vdxTreeView) | Gets or sets the algorithm to expand nodes after refresh.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RootNode | Gets the root node.
Scrollable (inherited from TreeView) | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed.
SelectedImageIndex (inherited from TreeView) | Gets or sets the image list index value of the image that is displayed when a tree node is selected.
SelectedNode (inherited from TreeView) | Gets or sets the tree node that is currently selected in the tree view control.
ShowLines (inherited from TreeView) | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control.
ShowPlusMinus (inherited from TreeView) | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes.
ShowRootLines (inherited from TreeView) | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from TreeView) | Gets or sets a value indicating whether the tree nodes in the tree view are sorted.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from TreeView) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopNode (inherited from TreeView) | Gets the first fully-visible tree node in the tree view control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisibleCount (inherited from TreeView) | Gets the number of tree nodes that can be fully visible in the tree view control.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

AddNode | Overloaded. Made method public to be accessed from vdxExplorerTree to implement an individual fill of the tree view.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from TreeView) | Disables any redrawing of the tree view.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear | Remove all nodes from the tree.
CollapseAll (inherited from TreeView) | Collapses all the tree nodes.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateNavigatorInfoItem | Made method public to be accessed from vdxExplorerTree to implement an individual fill of the tree view.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from TreeView) | Enables the redrawing of the tree view.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandAll (inherited from TreeView) | Expands all the tree nodes.
Fill | Overloaded. Builds the first level of the tree.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxTreeView) | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetNodeAt (inherited from TreeView) | Overloaded. Retrieves the tree node that is at the specified point.
GetNodeCount (inherited from TreeView) | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control.
GetTreeNode (inherited from vdxTreeView) | Overloaded. Creates a vdxTreeNode for the given DataRow.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RefreshData (inherited from vdxTreeView) | Remove all elements from the navigator and fill up the given dataSet.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectDefault | Selects the default element.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo (inherited from vdxTreeView) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TreeView) |
Update (inherited from Control) | Overloaded. Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AfterCheck (inherited from TreeView) | Occurs after the tree node check box is checked.
AfterCollapse (inherited from TreeView) | Occurs after the tree node is collapsed.
AfterExpand (inherited from TreeView) | Occurs after the tree node is expanded.
AfterLabelEdit (inherited from TreeView) | Occurs after the tree node label text is edited.
AfterSelect (inherited from TreeView) | Occurs after the tree node is selected.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from TreeView) |
BeforeCheck (inherited from TreeView) | Occurs before the tree node check box is checked.
BeforeCollapse (inherited from TreeView) | Occurs before the tree node is collapsed.
BeforeExpand (inherited from TreeView) | Occurs before the tree node is expanded.
BeforeLabelEdit (inherited from TreeView) | Occurs before the tree node label text is edited.
BeforeSelect (inherited from TreeView) | Occurs before the tree node is selected.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlChanged (inherited from vdxTreeView) | Occurs when an other cacheable control had to be shown.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
ItemDrag (inherited from TreeView) | Occurs when an item is dragged into the tree view control.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from TreeView) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectionChanged (inherited from vdxTreeView) | Occurs when an other DataRow was selected.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from TreeView) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from TreeView) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from TreeView) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AddNode (inherited from vdxTreeView) | Overloaded. Adds a node to the given parent node.
AddNodeToTree | Adds a node to the given parent node.
ChangeSelection (inherited from vdxTreeView) | Changes current selection to the row corresponding treeNode.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from TreeView) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
Delete (inherited from vdxTreeView) | Overloaded. Deletes the given node.
DesiredTable | Gets the desired table in the dataSet for the corresponding searchParameters.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from TreeView) | Overloaded.
ExpandTreeNodesAfterRefresh (inherited from vdxTreeView) | Expands recursively all corresponding TreeNodes.
Fill (inherited from vdxTreeView) | Overloaded. Builds the first level of the tree.
FillSubTree (inherited from vdxTreeView) | Builds child nodes for parent node.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GenerateSubNodeSearchParameters | Generates vdxSearchParameters to load subnodes.
GetAllTreeNodesToExpand (inherited from vdxTreeView) | Gets all TreeNodes that are expanded.
GetItemRenderStyles (inherited from TreeView) |
GetLoaderInfo | Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.
GetNavigatorInfo (inherited from vdxTreeView) | Gets the corresponding navigation info for the given item.
GetNavigatorInfoItem (inherited from vdxTreeView) | Gets the corresponding DataRow for the given TreeNode.
GetNodeToSelectAfterDelete (inherited from vdxTreeView) | Gets the node to select after deleting an node.
GetNoneTreeNodeToExpand (inherited from vdxTreeView) | Gets an empty collection that expand no TreeNodes.
GetSelectedTreeNodeToExpand (inherited from vdxTreeView) | Gets only the expanded TreeNode hierarchy of the selected node.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GetTopTreeNode | Gets the top level node for the given treeNode.
GetTreeNode | Overloaded. Gets the corresponding TreeNode for the row and parentNode.
GetTreeNodeInfo (inherited from vdxTreeView) | Gets the text and image information to build a treeNode.
GetTreeNodeKey | Gets an unique key to differ TreeNodes on the same hierarchy level.
GetTreeNodesToExpandAfterRefresh (inherited from vdxTreeView) | Gets all TreeNodes that are expanded depending on RefreshAlgorithmType.
InitLayout (inherited from Control) | Called after the control has been added to another container.
Insert (inherited from vdxTreeView) | Inserts a new treeNode for the corresponding row.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from TreeView) |
IsRefreshable (inherited from vdxTreeView) | Checks if the component supports refresh.
LoadData | Loads data for the given search parameters.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAfterCheck (inherited from TreeView) | Raises the AfterCheck event.
OnAfterCollapse (inherited from TreeView) | Raises the AfterCollapse event.
OnAfterExpand (inherited from TreeView) | Raises the AfterExpand event.
OnAfterLabelEdit (inherited from TreeView) | Raises the AfterLabelEdit event.
OnAfterSelect (inherited from TreeView) | Raises the AfterSelect event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBeforeCheck (inherited from TreeView) | Raises the BeforeCheck event.
OnBeforeCollapse (inherited from TreeView) | Raises the BeforeCollapse event.
OnBeforeExpand (inherited from TreeView) | Raises the BeforeExpand event.
OnBeforeLabelEdit (inherited from TreeView) | Raises the BeforeLabelEdit event.
OnBeforeSelect (inherited from TreeView) | Raises the BeforeSelect event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlChanged (inherited from vdxTreeView) | Inform all registered components on ControlChanged about a control change.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from TreeView) |
OnHandleDestroyed (inherited from TreeView) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnItemDrag (inherited from TreeView) | Raises the ItemDrag event.
OnKeyDown (inherited from TreeView) |
OnKeyPress (inherited from TreeView) |
OnKeyUp (inherited from TreeView) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSelectionChanged (inherited from vdxTreeView) | Inform all registered components on SelectionChanged about a selection change.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
Undo (inherited from vdxTreeView) | Undo changes for the corresponding navigatorDataRow.
Update (inherited from vdxTreeView) | Overloaded. Updates the node for given vdxNavigatorInfo.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from TreeView) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IvdxNavigator.ChangeSelection (inherited from vdxTreeView)
IvdxNavigator.Clear (inherited from vdxTreeView)
IvdxNavigator.Copy (inherited from vdxTreeView)
IvdxNavigator.Delete (inherited from vdxTreeView)
IvdxNavigator.Fill (inherited from vdxTreeView)
IvdxNavigator.GetLoaderInfo (inherited from vdxTreeView)
IvdxNavigator.Insert (inherited from vdxTreeView)
IvdxNavigator.IsRefreshable (inherited from vdxTreeView)
IvdxNavigator.RefreshData (inherited from vdxTreeView)
IvdxNavigator.Undo (inherited from vdxTreeView)
IvdxNavigator.Update (inherited from vdxTreeView)

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView Constructor

Creates an instance of the class vdxExplorerTreeView.

public vdxExplorerTreeView();

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView Properties

The properties of the vdxExplorerTreeView class are listed below. For a complete list of vdxExplorerTreeView class members, see the vdxExplorerTreeView Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from TreeView) |
BackgroundImage (inherited from TreeView) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxTreeView) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from TreeView) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CheckBoxes (inherited from TreeView) | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos (inherited from vdxTreeView) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
ExplorerTree | Gets or sets the corresponding explorerTree.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TreeView) |
FullRowSelect (inherited from TreeView) | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TreeView) | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus.
HotTracking (inherited from TreeView) | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it.
ImageIndex (inherited from TreeView) | Gets or sets the image-list index value of the default image that is displayed by the tree nodes.
ImageList (inherited from TreeView) | Gets or sets the ImageList that contains the Image objects used by the tree nodes.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
Indent (inherited from TreeView) | Gets or sets the distance to indent each of the child tree node levels.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from TreeView) | Gets or sets the height of each tree node in the tree view control.
LabelEdit (inherited from TreeView) | Gets or sets a value indicating whether the label text of the tree nodes can be edited.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Nodes (inherited from TreeView) | Gets the collection of tree nodes that are assigned to the tree view control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PathSeparator (inherited from TreeView) | Gets or sets the delimiter string that the tree node path uses.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
RefreshAlgorithm (inherited from vdxTreeView) | Gets or sets the algorithm to expand nodes after refresh.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RootNode | Gets the root node.
Scrollable (inherited from TreeView) | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed.
SelectedImageIndex (inherited from TreeView) | Gets or sets the image list index value of the image that is displayed when a tree node is selected.
SelectedNode (inherited from TreeView) | Gets or sets the tree node that is currently selected in the tree view control.
ShowLines (inherited from TreeView) | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control.
ShowPlusMinus (inherited from TreeView) | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes.
ShowRootLines (inherited from TreeView) | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from TreeView) | Gets or sets a value indicating whether the tree nodes in the tree view are sorted.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from TreeView) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopNode (inherited from TreeView) | Gets the first fully-visible tree node in the tree view control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisibleCount (inherited from TreeView) | Gets the number of tree nodes that can be fully visible in the tree view control.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from TreeView) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from TreeView) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView.ExplorerTree Property

Gets or sets the corresponding explorerTree.

public vdxExplorerTree ExplorerTree {get; set;}

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView.RootNode Property

Gets the root node.

public Deag.Vdx.Controls.Base.vdxTreeNode RootNode {get;}

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView Methods

The methods of the vdxExplorerTreeView class are listed below. For a complete list of vdxExplorerTreeView class members, see the vdxExplorerTreeView Members topic.

Public Instance Methods

AddNode | Overloaded. Made method public to be accessed from vdxExplorerTree to implement an individual fill of the tree view.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from TreeView) | Disables any redrawing of the tree view.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear | Remove all nodes from the tree.
CollapseAll (inherited from TreeView) | Collapses all the tree nodes.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateNavigatorInfoItem | Made method public to be accessed from vdxExplorerTree to implement an individual fill of the tree view.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from TreeView) | Enables the redrawing of the tree view.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandAll (inherited from TreeView) | Expands all the tree nodes.
Fill | Overloaded. Builds the first level of the tree.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxTreeView) | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetNodeAt (inherited from TreeView) | Overloaded. Retrieves the tree node that is at the specified point.
GetNodeCount (inherited from TreeView) | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control.
GetTreeNode (inherited from vdxTreeView) | Overloaded. Creates a vdxTreeNode for the given DataRow.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RefreshData (inherited from vdxTreeView) | Remove all elements from the navigator and fill up the given dataSet.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectDefault | Selects the default element.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo (inherited from vdxTreeView) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TreeView) |
Update (inherited from Control) | Overloaded. Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AddNode (inherited from vdxTreeView) | Overloaded. Adds a node to the given parent node.
AddNodeToTree | Adds a node to the given parent node.
ChangeSelection (inherited from vdxTreeView) | Changes current selection to the row corresponding treeNode.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from TreeView) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
Delete (inherited from vdxTreeView) | Overloaded. Deletes the given node.
DesiredTable | Gets the desired table in the dataSet for the corresponding searchParameters.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from TreeView) | Overloaded.
ExpandTreeNodesAfterRefresh (inherited from vdxTreeView) | Expands recursively all corresponding TreeNodes.
Fill (inherited from vdxTreeView) | Overloaded. Builds the first level of the tree.
FillSubTree (inherited from vdxTreeView) | Builds child nodes for parent node.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GenerateSubNodeSearchParameters | Generates vdxSearchParameters to load subnodes.
GetAllTreeNodesToExpand (inherited from vdxTreeView) | Gets all TreeNodes that are expanded.
GetItemRenderStyles (inherited from TreeView) |
GetLoaderInfo | Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.
GetNavigatorInfo (inherited from vdxTreeView) | Gets the corresponding navigation info for the given item.
GetNavigatorInfoItem (inherited from vdxTreeView) | Gets the corresponding DataRow for the given TreeNode.
GetNodeToSelectAfterDelete (inherited from vdxTreeView) | Gets the node to select after deleting an node.
GetNoneTreeNodeToExpand (inherited from vdxTreeView) | Gets an empty collection that expand no TreeNodes.
GetSelectedTreeNodeToExpand (inherited from vdxTreeView) | Gets only the expanded TreeNode hierarchy of the selected node.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GetTopTreeNode | Gets the top level node for the given treeNode.
GetTreeNode | Overloaded. Gets the corresponding TreeNode for the row and parentNode.
GetTreeNodeInfo (inherited from vdxTreeView) | Gets the text and image information to build a treeNode.
GetTreeNodeKey | Gets an unique key to differ TreeNodes on the same hierarchy level.
GetTreeNodesToExpandAfterRefresh (inherited from vdxTreeView) | Gets all TreeNodes that are expanded depending on RefreshAlgorithmType.
InitLayout (inherited from Control) | Called after the control has been added to another container.
Insert (inherited from vdxTreeView) | Inserts a new treeNode for the corresponding row.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from TreeView) |
IsRefreshable (inherited from vdxTreeView) | Checks if the component supports refresh.
LoadData | Loads data for the given search parameters.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAfterCheck (inherited from TreeView) | Raises the AfterCheck event.
OnAfterCollapse (inherited from TreeView) | Raises the AfterCollapse event.
OnAfterExpand (inherited from TreeView) | Raises the AfterExpand event.
OnAfterLabelEdit (inherited from TreeView) | Raises the AfterLabelEdit event.
OnAfterSelect (inherited from TreeView) | Raises the AfterSelect event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBeforeCheck (inherited from TreeView) | Raises the BeforeCheck event.
OnBeforeCollapse (inherited from TreeView) | Raises the BeforeCollapse event.
OnBeforeExpand (inherited from TreeView) | Raises the BeforeExpand event.
OnBeforeLabelEdit (inherited from TreeView) | Raises the BeforeLabelEdit event.
OnBeforeSelect (inherited from TreeView) | Raises the BeforeSelect event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlChanged (inherited from vdxTreeView) | Inform all registered components on ControlChanged about a control change.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from TreeView) |
OnHandleDestroyed (inherited from TreeView) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnItemDrag (inherited from TreeView) | Raises the ItemDrag event.
OnKeyDown (inherited from TreeView) |
OnKeyPress (inherited from TreeView) |
OnKeyUp (inherited from TreeView) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSelectionChanged (inherited from vdxTreeView) | Inform all registered components on SelectionChanged about a selection change.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
Undo (inherited from vdxTreeView) | Undo changes for the corresponding navigatorDataRow.
Update (inherited from vdxTreeView) | Overloaded. Updates the node for given vdxNavigatorInfo.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from TreeView) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IvdxNavigator.ChangeSelection (inherited from vdxTreeView)
IvdxNavigator.Clear (inherited from vdxTreeView)
IvdxNavigator.Copy (inherited from vdxTreeView)
IvdxNavigator.Delete (inherited from vdxTreeView)
IvdxNavigator.Fill (inherited from vdxTreeView)
IvdxNavigator.GetLoaderInfo (inherited from vdxTreeView)
IvdxNavigator.Insert (inherited from vdxTreeView)
IvdxNavigator.IsRefreshable (inherited from vdxTreeView)
IvdxNavigator.RefreshData (inherited from vdxTreeView)
IvdxNavigator.Undo (inherited from vdxTreeView)
IvdxNavigator.Update (inherited from vdxTreeView)

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AddNode Method

VDX Framework

vdxExplorerTreeView.AddNode Method

Made method public to be accessed from vdxExplorerTree to implement an individual fill of the tree view.

Overload List

Made method public to be accessed from vdxExplorerTree to implement an individual fill of the tree view.

new public void AddNode(vdxNavigatorInfoItem,vdxTreeNode,vdxTreeNode);

Inherited from vdxTreeView.

protected void AddNode(vdxNavigatorInfoItem,vdxTreeNode,vdxTreeNode,int);

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView.AddNode Method (vdxNavigatorInfoItem, vdxTreeNode, vdxTreeNode)

Made method public to be accessed from vdxExplorerTree to implement an individual fill of the tree view.

new public void AddNode(
vdxNavigatorInfoItem navInfoItem,
vdxTreeNode treeNode,
vdxTreeNode parentNode
);

Parameters

navInfoItem
The vdxNavigatorInfoItem that contains the information to construct a tree node.
treeNode
The child vdxTreeNode that must be added to parentNode list.
parentNode
The vdxTreeNode that will hold the child treeNode.

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace | vdxExplorerTreeView.AddNode Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView.AddNodeToTree Method

Adds a node to the given parent node.

protected override void AddNodeToTree(
vdxTreeNode treeNode,
vdxTreeNode parentNode,
int index
);

Parameters

treeNode
The node to be added.
parentNode
The parent node where the node will be added.
index
At which position, the treeNode has to be inserted.

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView.Clear Method

Remove all nodes from the tree.

public override void Clear();

Remarks

Calls Clear and adds the rootNode.

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView.CreateNavigatorInfoItem Method

Made method public to be accessed from vdxExplorerTree to implement an individual fill of the tree view.

new public vdxNavigatorInfoItem CreateNavigatorInfoItem(
DataRow dataRow
);

Parameters

dataRow
The DataRow to create a vdxNavigatorInfoItem out of.

Return Value

A vdxNavigatorInfoItem that encapsulate a DataRow.

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView.DesiredTable Method

Gets the desired table in the dataSet for the corresponding searchParameters.

protected override DataTable DesiredTable(
DataSet dataSet
);

Parameters

dataSet
The dataSet, which holds the table(s).

Return Value

The table corresponding to the searchParameter.

Remarks

Default table is the first one in the dataSet.

dataSet.Tables[0]
Is called in the Fill method to define from which table the rows had to be extracted.

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Fill Method

VDX Framework

vdxExplorerTreeView.Fill Method

Builds the first level of the tree.

Overload List

Inherited from vdxTreeView.

protected virtual void Fill(vdxTreeNode);

Builds the first level of the tree.

public override void Fill(DataSet);

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView.Fill Method (DataSet)

Builds the first level of the tree.

public override void Fill(
DataSet dataSet
);

Parameters

dataSet
The dataSet, which the navigator extract all rows out of.

Remarks

The other levels are build, after a treeNode is expanded.

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace | vdxExplorerTreeView.Fill Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView.GenerateSubNodeSearchParameters Method

Generates vdxSearchParameters to load subnodes.

protected override vdxSearchParameters GenerateSubNodeSearchParameters(
vdxNavigatorInfoItem navInfoItem
);

Parameters

navInfoItem
The row, which contains information to build the searchParameters.

Return Value

The corresponding searchParameters for the given row.

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView.GetLoaderInfo Method

Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.

protected override vdxLoaderInfo GetLoaderInfo(
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorInfo
Contains the DataRow to define the vdxLoaderInfo.

Return Value

The vdxLoaderInfo for the given navigatorInfo.

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView.GetTopTreeNode Method

Gets the top level node for the given treeNode.

protected override vdxTreeNode GetTopTreeNode(
vdxTreeNode treeNode
);

Parameters

treeNode
The treeNode, to get the corresponding top level treeNode

Return Value

The top level tree node.

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


GetTreeNode Method

VDX Framework

vdxExplorerTreeView.GetTreeNode Method

Gets the corresponding TreeNode for the row and parentNode.

Overload List

Inherited from vdxTreeView.

public vdxTreeNode GetTreeNode(vdxNavigatorInfoItem);

Gets the corresponding TreeNode for the row and parentNode.

protected override vdxTreeNode GetTreeNode(vdxNavigatorInfoItem,vdxTreeNode);

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView.GetTreeNode Method (vdxNavigatorInfoItem, vdxTreeNode)

Gets the corresponding TreeNode for the row and parentNode.

protected override vdxTreeNode GetTreeNode(
vdxNavigatorInfoItem navInfoItem,
vdxTreeNode parentNode
);

Parameters

navInfoItem
The row to extract treeNode parameters.
parentNode
The parent node of the new treeNode.

Return Value

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace | vdxExplorerTreeView.GetTreeNode Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView.GetTreeNodeKey Method

Gets an unique key to differ TreeNodes on the same hierarchy level.

protected override object GetTreeNodeKey(
TreeNode treeNode
);

Parameters

treeNode
The node to extract key out of.

Return Value

The unique key of the treeNode.

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView.LoadData Method

Loads data for the given search parameters.

protected override DataSet LoadData(
vdxSearchParameters searchParameters
);

Parameters

searchParameters
The specific search arguments.

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxExplorerTreeView.SelectDefault Method

Selects the default element.

public override void SelectDefault();

Implements

IvdxNavigator.SelectDefault

See Also

vdxExplorerTreeView Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser Class

Use this control to select one or more elements from a pool of items.

For a list of all members of this type, see vdxListChooser Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxListChooser

public class vdxListChooser : UserControl, IvdxDsmHost, IvdxResettable, IvdxBindable

Remarks

            Supported Appearances

            Chooser:
             -----------             -----------
            |           |   | > |   |           |
            |           |   |   |   |           |
                /// |           |           |           |
            |           |   | >> |  |           |
            |           |   |    |  |           |
             -----------             -----------

            SelectionList:
             -----------     ---
            |           |   |...|
            |           |    ---
            |           |
            |           |
            |           |
             -----------

             TextField:
              ------------------------------   ---
             |                              | |...|
              ------------------------------   ---

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxListChooser Members | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser Members

vdxListChooser overview

Public Instance Constructors

vdxListChooser Constructor Default constructor

Public Instance Properties

AcceptButtonText | Gets or sets the accept button control text in the ListChooserDialog.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
Appearance | Gets or sets the appearance type of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
ButtonCursor | Gets or sets the cursor that is displayed when the mouse pointer is over the button controls.
ButtonFlatStyle | Gets or sets the flat style appearance of all button controls.
CancelButtonText | Gets or sets the cancel button control text in the ListChooserDialog.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataTableAvailable | Gets or sets the data table for the available list box.
DataTableSelection | Gets or sets the data table for the selection list box.
DisplayMemberAvailable | Gets or sets the display member of the available list box.
DisplayMemberSelection | Gets or sets the display member of the selection list box.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
ListHeight | Gets or sets the Heigth of both listboxes.
ListWidth | Gets or sets the Width of both listboxes.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectionSelectedValue | Gets the selected value of the selection list box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
TextFieldWidth | Gets or sets the Width of the text box.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
ValueMemberAvailable | Gets or sets the value member of the available list box.
ValueMemberSelection | Gets or sets the value member of the selection list box.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetChanges | Sets data tables to the initialized tables.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
ListChooserDialogActivated | happens when the vdxlistChooserDialog is activated use this to set the values from the SelectionList/TextField to the listChooser dialog
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl) |
IvdxResettable.Reset | Resets the value of the text box

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser Constructor

Default constructor

public vdxListChooser();

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser Properties

The properties of the vdxListChooser class are listed below. For a complete list of vdxListChooser class members, see the vdxListChooser Members topic.

Public Instance Properties

AcceptButtonText | Gets or sets the accept button control text in the ListChooserDialog.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
Appearance | Gets or sets the appearance type of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
ButtonCursor | Gets or sets the cursor that is displayed when the mouse pointer is over the button controls.
ButtonFlatStyle | Gets or sets the flat style appearance of all button controls.
CancelButtonText | Gets or sets the cancel button control text in the ListChooserDialog.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataTableAvailable | Gets or sets the data table for the available list box.
DataTableSelection | Gets or sets the data table for the selection list box.
DisplayMemberAvailable | Gets or sets the display member of the available list box.
DisplayMemberSelection | Gets or sets the display member of the selection list box.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
ListHeight | Gets or sets the Heigth of both listboxes.
ListWidth | Gets or sets the Width of both listboxes.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectionSelectedValue | Gets the selected value of the selection list box.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
TextFieldWidth | Gets or sets the Width of the text box.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
ValueMemberAvailable | Gets or sets the value member of the available list box.
ValueMemberSelection | Gets or sets the value member of the selection list box.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.AcceptButtonText Property

Gets or sets the accept button control text in the ListChooserDialog.

public string AcceptButtonText {get; set;}

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.Appearance Property

Gets or sets the appearance type of the control.

public vdxListChooserAppearance Appearance {get; set;}

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.ButtonCursor Property

Gets or sets the cursor that is displayed when the mouse pointer is over the button controls.

public System.Windows.Forms.Cursor ButtonCursor {get; set;}

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.ButtonFlatStyle Property

Gets or sets the flat style appearance of all button controls.

public System.Windows.Forms.FlatStyle ButtonFlatStyle {get; set;}

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.CancelButtonText Property

Gets or sets the cancel button control text in the ListChooserDialog.

public string CancelButtonText {get; set;}

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.DataTableAvailable Property

Gets or sets the data table for the available list box.

public System.Data.DataTable DataTableAvailable {get; set;}

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.DataTableSelection Property

Gets or sets the data table for the selection list box.

public System.Data.DataTable DataTableSelection {get; set;}

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager Property

private Deag.Vdx.Controls.Core.vdxDataStatusManager Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager {get; set;}

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.DisplayMemberAvailable Property

Gets or sets the display member of the available list box.

public string DisplayMemberAvailable {get; set;}

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.DisplayMemberSelection Property

Gets or sets the display member of the selection list box.

public string DisplayMemberSelection {get; set;}

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.ListHeight Property

Gets or sets the Heigth of both listboxes.

public int ListHeight {get; set;}

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.ListWidth Property

Gets or sets the Width of both listboxes.

public int ListWidth {get; set;}

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.SelectionSelectedValue Property

Gets the selected value of the selection list box.

public object SelectionSelectedValue {get;}

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.TextFieldWidth Property

Gets or sets the Width of the text box.

public int TextFieldWidth {get; set;}

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.ValueMemberAvailable Property

Gets or sets the value member of the available list box.

public string ValueMemberAvailable {get; set;}

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.ValueMemberSelection Property

Gets or sets the value member of the selection list box.

public string ValueMemberSelection {get; set;}

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser Methods

The methods of the vdxListChooser class are listed below. For a complete list of vdxListChooser class members, see the vdxListChooser Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetChanges | Sets data tables to the initialized tables.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
ListChooserDialogActivated | happens when the vdxlistChooserDialog is activated use this to set the values from the SelectionList/TextField to the listChooser dialog
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl) |
IvdxResettable.Reset | Resets the value of the text box

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.IvdxResettable.Reset Method

Resets the value of the text box

void IvdxResettable.Reset();

Implements

IvdxResettable.Reset

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Dispose Method

VDX Framework

vdxListChooser.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.Dispose Method (Boolean)

Clean up any resources being used.

protected override void Dispose(
bool disposing
);

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace | vdxListChooser.Dispose Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.ListChooserDialogActivated Method

happens when the vdxlistChooserDialog is activated use this to set the values from the SelectionList/TextField to the listChooser dialog

protected virtual void ListChooserDialogActivated();

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.ResetChanges Method

Sets data tables to the initialized tables.

public void ResetChanges();

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooser.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxListChooser Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxListChooserAppearance Enumeration

The appeareance types for the ListChooser.

public enum vdxListChooserAppearance

Members

Member Name | Description
TextField | As text box followed by a browse button.
SelectionList | As list box with the selected values followed by a browse button.
Chooser | As two list boxes with add and remove buttons.

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar Class

The vdxOutlookBar control.

For a list of all members of this type, see vdxOutlookBar Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxOutlookBar

public class vdxOutlookBar : UserControl, IvdxBindable

Remarks

This control gets used directly on your main form and represents your outlookbar.

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxOutlookBar Members | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar Members

vdxOutlookBar overview

Public Instance Constructors

vdxOutlookBar Constructor Default Constructor.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveGroup | Gets the active group.
ActiveIconBorderColor | Gets or sets the border color of an active icon. Works in conjunction with the 'ActiveIconOutlookStyle' property.
ActiveIconOutlookStyle | Gets or sets whether to display an active icon in outlook style. Default value is false.
AllowDragDrop | Gets or sets whether to allow the receiving of DragDrop Events. Default value is false.
AllowDrop | Gets whether to allow drop objects.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll | Gets whether to display the auto scrollbar.
AutoScrollBar | Gets or sets whether to display the standard auto scrollbar or the outlookstyle scrollbar. Default value is true.
AutoScrollMargin | Gets the margin of the auto scrollbar.
AutoScrollMinSize | Gets the minimum size of the auto scrollbar.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor | Gets or sets the backcolor.
BackgroundImage | Gets the background image.
BindingContext (inherited from ContainerControl) |
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ChangeIconSizeMenu | Gets or sets whether to display a context menu where you can change the icon size. Default value is false.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu | Gets the context menu.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor | Gets or sets the cursor.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font | Gets or sets the font.
ForeColor | Gets or sets the forecolor.
GroupList | Gets the group item collection.
GroupStyle | Gets or sets whether the vdxOutlookBarGroups must set their FlatStyle as Popup. Default value is true.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
IconBackColor | Gets or sets the basic backcolor of an icon. The final color can be set directly on the properties of an icon.
IconFont | Gets or sets the basic font of an icon. The final font can be set directly on the properties of an icon.
IconForeColor | Gets or sets the basic forecolor of an icon. The final color can be set directly on the properties of an icon.
IconHeight | Gets or sets the icon height. Default value is 75.
IconSelectionList | Gets or sets the icon list containing the dragged icons.
ImageListLarge | Gets or sets the ImageList containing the large icons. Default value is null.
ImageListSmall | Gets or sets the ImageList containing the small icons. Default value is null.
ImeMode | Gets the IME mode.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MinimizeBarBackColor | Gets or sets the backcolor of the minimized bar.
MinimizeBarFont | Gets or sets the font used in the minimized bar.
MinimizeBarForeColor | Gets or sets the forecolor of the minimized bar.
MinimizeBarText | Gets or sets the text of the minimized bar. Default value is VDX OutlookBar.
MinimizeBarWidth | Gets or sets the width of the minimized bar. Default value is 0.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft | Overloaded. Gets whether to display text from right to left.
ScrollInterval | Gets or sets the scroll interval time for moving the icons. Default value is 350.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SmallIcons | Gets or sets whether to display small icons or not. Default value is false.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
TitleBar | Gets or sets whether to display the titlebar. Default value is false.
TitleBarBackColor | Gets or sets the backcolor of the titlebar.
TitleBarDockLeft | Gets or sets whether the titlebar is docked to the left border. Default value is false.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView | Overloaded. Scrolls the specified icon into view. Works only if scrollbar is set to auto scrollbar.
ScrollControlIntoView (inherited from ScrollableControl) | Overloaded.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetActiveGroup | Overloaded. Sets the active group.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetIconLocations | Calculates the locations of the icon items depending on the clicked scrollbar button.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
OutlookBarExpanded | Gets triggered eachtime after the outlookbar gets expanded.
OutlookBarGroupClicked | Gets triggered eachtime an user clicks on a group button. It's possible to cancel this event in the previous triggered 'clicking' event.
OutlookBarGroupClicking | Gets first triggered eachtime an user clicks on a group button. Inthere, it's possible to cancel the final 'clicked' event.
OutlookBarIconClicked | Gets triggered eachtime an user clicks on a icon button. It's possible to cancel this event in the previous triggered 'clicking' event.
OutlookBarIconClicking | Gets first triggered eachtime an user clicks on a icon button. Therein, it's possible to cancel the final 'clicked' event.
OutlookBarIconSelectionClicked | Gets triggered eachtime an user clicks on a icon button. It's possible to cancel this event in the previous triggered 'clicking' event.
OutlookBarIconSelectionClicking | Gets first triggered eachtime a user clicks on a icon button. Inthere, it's possible to cancel the final 'clicked' event.
OutlookBarIconSelectionDeleted | Gets triggered eachtime an user has deleted a custom icon button.
OutlookBarIconSelectionRenamed | Gets triggered eachtime an user has renamed a custom icon button.
OutlookBarIconSelectionSizeChanged | Gets triggered eachtime the size of a custom icon changes. You can get the actual icon size by reading the 'SmallIcons' boolean property.
OutlookBarMinimized | Gets triggered eachtime after the outlookbar gets minimized.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad | Occurs whenever the outlookbar is loading.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown | Occurs whenever an user presses a mouse button.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint | Occurs whenever the outlookbar is redrawn.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize | Occurs whenever the outlookbar is resizing.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar Constructor

Default Constructor.

public vdxOutlookBar();

Remarks

Initializes the layout and sets the default values.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar Properties

The properties of the vdxOutlookBar class are listed below. For a complete list of vdxOutlookBar class members, see the vdxOutlookBar Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveGroup | Gets the active group.
ActiveIconBorderColor | Gets or sets the border color of an active icon. Works in conjunction with the 'ActiveIconOutlookStyle' property.
ActiveIconOutlookStyle | Gets or sets whether to display an active icon in outlook style. Default value is false.
AllowDragDrop | Gets or sets whether to allow the receiving of DragDrop Events. Default value is false.
AllowDrop | Gets whether to allow drop objects.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll | Gets whether to display the auto scrollbar.
AutoScrollBar | Gets or sets whether to display the standard auto scrollbar or the outlookstyle scrollbar. Default value is true.
AutoScrollMargin | Gets the margin of the auto scrollbar.
AutoScrollMinSize | Gets the minimum size of the auto scrollbar.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor | Gets or sets the backcolor.
BackgroundImage | Gets the background image.
BindingContext (inherited from ContainerControl) |
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ChangeIconSizeMenu | Gets or sets whether to display a context menu where you can change the icon size. Default value is false.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu | Gets the context menu.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor | Gets or sets the cursor.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font | Gets or sets the font.
ForeColor | Gets or sets the forecolor.
GroupList | Gets the group item collection.
GroupStyle | Gets or sets whether the vdxOutlookBarGroups must set their FlatStyle as Popup. Default value is true.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
IconBackColor | Gets or sets the basic backcolor of an icon. The final color can be set directly on the properties of an icon.
IconFont | Gets or sets the basic font of an icon. The final font can be set directly on the properties of an icon.
IconForeColor | Gets or sets the basic forecolor of an icon. The final color can be set directly on the properties of an icon.
IconHeight | Gets or sets the icon height. Default value is 75.
IconSelectionList | Gets or sets the icon list containing the dragged icons.
ImageListLarge | Gets or sets the ImageList containing the large icons. Default value is null.
ImageListSmall | Gets or sets the ImageList containing the small icons. Default value is null.
ImeMode | Gets the IME mode.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MinimizeBarBackColor | Gets or sets the backcolor of the minimized bar.
MinimizeBarFont | Gets or sets the font used in the minimized bar.
MinimizeBarForeColor | Gets or sets the forecolor of the minimized bar.
MinimizeBarText | Gets or sets the text of the minimized bar. Default value is VDX OutlookBar.
MinimizeBarWidth | Gets or sets the width of the minimized bar. Default value is 0.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft | Overloaded. Gets whether to display text from right to left.
ScrollInterval | Gets or sets the scroll interval time for moving the icons. Default value is 350.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SmallIcons | Gets or sets whether to display small icons or not. Default value is false.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
TitleBar | Gets or sets whether to display the titlebar. Default value is false.
TitleBarBackColor | Gets or sets the backcolor of the titlebar.
TitleBarDockLeft | Gets or sets whether the titlebar is docked to the left border. Default value is false.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.ActiveGroup Property

Gets the active group.

public vdxOutlookBarGroup ActiveGroup {get;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.ActiveIconBorderColor Property

Gets or sets the border color of an active icon. Works in conjunction with the 'ActiveIconOutlookStyle' property.

public System.Drawing.Color ActiveIconBorderColor {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.ActiveIconOutlookStyle Property

Gets or sets whether to display an active icon in outlook style. Default value is false.

public bool ActiveIconOutlookStyle {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.AllowDragDrop Property

Gets or sets whether to allow the receiving of DragDrop Events. Default value is false.

public bool AllowDragDrop {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.AllowDrop Property

Gets whether to allow drop objects.

new public bool AllowDrop {get;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.AutoScroll Property

Gets whether to display the auto scrollbar.

new public bool AutoScroll {get;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.AutoScrollBar Property

Gets or sets whether to display the standard auto scrollbar or the outlookstyle scrollbar. Default value is true.

public bool AutoScrollBar {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.AutoScrollMargin Property

Gets the margin of the auto scrollbar.

new public System.Drawing.Size AutoScrollMargin {get;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.AutoScrollMinSize Property

Gets the minimum size of the auto scrollbar.

new public System.Drawing.Size AutoScrollMinSize {get;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.BackColor Property

Gets or sets the backcolor.

new public System.Drawing.Color BackColor {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.BackgroundImage Property

Gets the background image.

new public System.Drawing.Image BackgroundImage {get;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.ChangeIconSizeMenu Property

Gets or sets whether to display a context menu where you can change the icon size. Default value is false.

public bool ChangeIconSizeMenu {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.ContextMenu Property

Gets the context menu.

new public System.Windows.Forms.ContextMenu ContextMenu {get;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.Cursor Property

Gets or sets the cursor.

new public System.Windows.Forms.Cursor Cursor {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.Font Property

Gets or sets the font.

new public System.Drawing.Font Font {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.ForeColor Property

Gets or sets the forecolor.

new public System.Drawing.Color ForeColor {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.GroupList Property

Gets the group item collection.

public vdxOutlookBarGroupList GroupList {get;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.GroupStyle Property

Gets or sets whether the vdxOutlookBarGroups must set their FlatStyle as Popup. Default value is true.

public bool GroupStyle {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.IconBackColor Property

Gets or sets the basic backcolor of an icon. The final color can be set directly on the properties of an icon.

public System.Drawing.Color IconBackColor {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.IconFont Property

Gets or sets the basic font of an icon. The final font can be set directly on the properties of an icon.

public System.Drawing.Font IconFont {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.IconForeColor Property

Gets or sets the basic forecolor of an icon. The final color can be set directly on the properties of an icon.

public System.Drawing.Color IconForeColor {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.IconHeight Property

Gets or sets the icon height. Default value is 75.

public int IconHeight {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.IconSelectionList Property

Gets or sets the icon list containing the dragged icons.

public vdxOutlookBarIconSelectionList IconSelectionList {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.ImageListLarge Property

Gets or sets the ImageList containing the large icons. Default value is null.

public System.Windows.Forms.ImageList ImageListLarge {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.ImageListSmall Property

Gets or sets the ImageList containing the small icons. Default value is null.

public System.Windows.Forms.ImageList ImageListSmall {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.ImeMode Property

Gets the IME mode.

new public System.Windows.Forms.ImeMode ImeMode {get;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.MinimizeBarBackColor Property

Gets or sets the backcolor of the minimized bar.

public System.Drawing.Color MinimizeBarBackColor {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.MinimizeBarFont Property

Gets or sets the font used in the minimized bar.

public System.Drawing.Font MinimizeBarFont {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.MinimizeBarForeColor Property

Gets or sets the forecolor of the minimized bar.

public System.Drawing.Color MinimizeBarForeColor {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.MinimizeBarText Property

Gets or sets the text of the minimized bar. Default value is VDX OutlookBar.

public string MinimizeBarText {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.MinimizeBarWidth Property

Gets or sets the width of the minimized bar. Default value is 0.

public int MinimizeBarWidth {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.RightToLeft Property

Gets whether to display text from right to left.

new public bool RightToLeft {get;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.ScrollInterval Property

Gets or sets the scroll interval time for moving the icons. Default value is 350.

public int ScrollInterval {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.SmallIcons Property

Gets or sets whether to display small icons or not. Default value is false.

public bool SmallIcons {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.TitleBar Property

Gets or sets whether to display the titlebar. Default value is false.

public bool TitleBar {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.TitleBarBackColor Property

Gets or sets the backcolor of the titlebar.

public System.Drawing.Color TitleBarBackColor {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.TitleBarDockLeft Property

Gets or sets whether the titlebar is docked to the left border. Default value is false.

public bool TitleBarDockLeft {get; set;}

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar Methods

The methods of the vdxOutlookBar class are listed below. For a complete list of vdxOutlookBar class members, see the vdxOutlookBar Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView | Overloaded. Scrolls the specified icon into view. Works only if scrollbar is set to auto scrollbar.
ScrollControlIntoView (inherited from ScrollableControl) | Overloaded.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetActiveGroup | Overloaded. Sets the active group.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetIconLocations | Calculates the locations of the icon items depending on the clicked scrollbar button.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad | Occurs whenever the outlookbar is loading.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown | Occurs whenever an user presses a mouse button.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint | Occurs whenever the outlookbar is redrawn.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize | Occurs whenever the outlookbar is resizing.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Dispose Method

VDX Framework

vdxOutlookBar.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.Dispose Method (Boolean)

Clean up any resources being used.

protected override void Dispose(
bool disposing
);

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace | vdxOutlookBar.Dispose Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.OnLoad Method

Occurs whenever the outlookbar is loading.

protected override void OnLoad(
EventArgs e
);

Parameters

e
The EventArgs object.

Remarks

Arranges the group items.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.OnMouseDown Method

Occurs whenever an user presses a mouse button.

protected override void OnMouseDown(
MouseEventArgs e
);

Parameters

e
The MouseEventArgs object.

Remarks

Opens the contextmenu.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.OnPaint Method

Occurs whenever the outlookbar is redrawn.

protected override void OnPaint(
PaintEventArgs e
);

Parameters

e
The EventArgs object.

Remarks

Repaints the text of the minimized bar.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.OnResize Method

Occurs whenever the outlookbar is resizing.

protected override void OnResize(
EventArgs e
);

Parameters

e
The EventArgs object.

Remarks

Calls the basic OnResize method and arranges the scrollbar buttons.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ScrollControlIntoView Method

VDX Framework

vdxOutlookBar.ScrollControlIntoView Method

Scrolls the specified icon into view. Works only if scrollbar is set to auto scrollbar.

Overload List

Scrolls the specified icon into view. Works only if scrollbar is set to auto scrollbar.

public void ScrollControlIntoView(vdxOutlookBarIcon);

Inherited from ScrollableControl.

public void ScrollControlIntoView(Control);

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.ScrollControlIntoView Method (vdxOutlookBarIcon)

Scrolls the specified icon into view. Works only if scrollbar is set to auto scrollbar.

public void ScrollControlIntoView(
vdxOutlookBarIcon icon
);

Parameters

icon
The icon to display.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace | vdxOutlookBar.ScrollControlIntoView Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SetActiveGroup Method

VDX Framework

vdxOutlookBar.SetActiveGroup Method

Sets the active group.

Overload List

Sets the active group.

public void SetActiveGroup(vdxOutlookBarGroup);

Sets the active group.

public void SetActiveGroup(int);

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.SetActiveGroup Method (vdxOutlookBarGroup)

Sets the active group.

public void SetActiveGroup(
vdxOutlookBarGroup group
);

Parameters

group
The group to be activated.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace | vdxOutlookBar.SetActiveGroup Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.SetActiveGroup Method (Int32)

Sets the active group.

public void SetActiveGroup(
int index
);

Parameters

index
The index of the group within the ArrayList.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace | vdxOutlookBar.SetActiveGroup Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.SetIconLocations Method

Calculates the locations of the icon items depending on the clicked scrollbar button.

public void SetIconLocations(
vdxOutlookBarGroup group
);

Parameters

group
The group of which to arrange the icons.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar Events

The events of the vdxOutlookBar class are listed below. For a complete list of vdxOutlookBar class members, see the vdxOutlookBar Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
OutlookBarExpanded | Gets triggered eachtime after the outlookbar gets expanded.
OutlookBarGroupClicked | Gets triggered eachtime an user clicks on a group button. It's possible to cancel this event in the previous triggered 'clicking' event.
OutlookBarGroupClicking | Gets first triggered eachtime an user clicks on a group button. Inthere, it's possible to cancel the final 'clicked' event.
OutlookBarIconClicked | Gets triggered eachtime an user clicks on a icon button. It's possible to cancel this event in the previous triggered 'clicking' event.
OutlookBarIconClicking | Gets first triggered eachtime an user clicks on a icon button. Therein, it's possible to cancel the final 'clicked' event.
OutlookBarIconSelectionClicked | Gets triggered eachtime an user clicks on a icon button. It's possible to cancel this event in the previous triggered 'clicking' event.
OutlookBarIconSelectionClicking | Gets first triggered eachtime a user clicks on a icon button. Inthere, it's possible to cancel the final 'clicked' event.
OutlookBarIconSelectionDeleted | Gets triggered eachtime an user has deleted a custom icon button.
OutlookBarIconSelectionRenamed | Gets triggered eachtime an user has renamed a custom icon button.
OutlookBarIconSelectionSizeChanged | Gets triggered eachtime the size of a custom icon changes. You can get the actual icon size by reading the 'SmallIcons' boolean property.
OutlookBarMinimized | Gets triggered eachtime after the outlookbar gets minimized.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.OutlookBarExpanded Event

Gets triggered eachtime after the outlookbar gets expanded.

public event vdxOutlookBarExpandedEventHandler OutlookBarExpanded;

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.OutlookBarGroupClicked Event

Gets triggered eachtime an user clicks on a group button. It's possible to cancel this event in the previous triggered 'clicking' event.

public event vdxOutlookBarGroupClickedEventHandler OutlookBarGroupClicked;

Event Data

The event handler receives an argument of type vdxOutlookBarGroupClickedEventArgs containing data related to this event. The following vdxOutlookBarGroupClickedEventArgs property provides information specific to this event.

Property | Description
VdxOutlookBarGroup | Gets the outlookbar group.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.OutlookBarGroupClicking Event

Gets first triggered eachtime an user clicks on a group button. Inthere, it's possible to cancel the final 'clicked' event.

public event vdxOutlookBarGroupClickingEventHandler OutlookBarGroupClicking;

Event Data

The event handler receives an argument of type vdxOutlookBarGroupClickingEventArgs containing data related to this event. The following vdxOutlookBarGroupClickingEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
VdxOutlookBarGroup | Gets the outlookbar group.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.OutlookBarIconClicked Event

Gets triggered eachtime an user clicks on a icon button. It's possible to cancel this event in the previous triggered 'clicking' event.

public event vdxOutlookBarIconClickedEventHandler OutlookBarIconClicked;

Event Data

The event handler receives an argument of type vdxOutlookBarIconClickedEventArgs containing data related to this event. The following vdxOutlookBarIconClickedEventArgs property provides information specific to this event.

Property | Description
VdxOutlookBarIcon | Gets the outlookbar icon.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.OutlookBarIconClicking Event

Gets first triggered eachtime an user clicks on a icon button. Therein, it's possible to cancel the final 'clicked' event.

public event vdxOutlookBarIconClickingEventHandler OutlookBarIconClicking;

Event Data

The event handler receives an argument of type vdxOutlookBarIconClickingEventArgs containing data related to this event. The following vdxOutlookBarIconClickingEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
VdxOutlookBarIcon | Gets the outlookbar icon.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.OutlookBarIconSelectionClicked Event

Gets triggered eachtime an user clicks on a icon button. It's possible to cancel this event in the previous triggered 'clicking' event.

public event vdxOutlookBarIconSelectionClickedEventHandler OutlookBarIconSelectionClicked;

Event Data

The event handler receives an argument of type vdxOutlookBarIconSelectionClickedEventArgs containing data related to this event. The following vdxOutlookBarIconSelectionClickedEventArgs properties provide information specific to this event.

Property | Description
SearchParameters | Gets the outlookbar icon.
VdxOutlookBarIcon | Gets the outlookbar icon.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.OutlookBarIconSelectionClicking Event

Gets first triggered eachtime a user clicks on a icon button. Inthere, it's possible to cancel the final 'clicked' event.

public event vdxOutlookBarIconSelectionClickingEventHandler OutlookBarIconSelectionClicking;

Event Data

The event handler receives an argument of type vdxOutlookBarIconSelectionClickingEventArgs containing data related to this event. The following vdxOutlookBarIconSelectionClickingEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
SearchParameters | Gets the outlookbar icon.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.OutlookBarIconSelectionDeleted Event

Gets triggered eachtime an user has deleted a custom icon button.

public event vdxOutlookBarIconSelectionDeletedEventHandler OutlookBarIconSelectionDeleted;

Event Data

The event handler receives an argument of type vdxOutlookBarIconSelectionDeletedEventArgs containing data related to this event. The following vdxOutlookBarIconSelectionDeletedEventArgs property provides information specific to this event.

Property | Description
VdxOutlookBarIcon | Gets the outlookbar icon.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.OutlookBarIconSelectionRenamed Event

Gets triggered eachtime an user has renamed a custom icon button.

public event vdxOutlookBarIconSelectionRenamedEventHandler OutlookBarIconSelectionRenamed;

Event Data

The event handler receives an argument of type vdxOutlookBarIconSelectionRenamedEventArgs containing data related to this event. The following vdxOutlookBarIconSelectionRenamedEventArgs property provides information specific to this event.

Property | Description
VdxOutlookBarIcon | Gets the outlookbar icon.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.OutlookBarIconSelectionSizeChanged Event

Gets triggered eachtime the size of a custom icon changes. You can get the actual icon size by reading the 'SmallIcons' boolean property.

public event vdxOutlookBarIconSelectionSizeChangedEventHandler OutlookBarIconSelectionSizeChanged;

Event Data

The event handler receives an argument of type vdxOutlookBarIconSelectionSizeChangedEventArgs containing data related to this event. The following vdxOutlookBarIconSelectionSizeChangedEventArgs property provides information specific to this event.

Property | Description
VdxOutlookBarIconSelectionList | Gets the outlookbar icon.

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBar.OutlookBarMinimized Event

Gets triggered eachtime after the outlookbar gets minimized.

public event vdxOutlookBarMinimizedEventHandler OutlookBarMinimized;

See Also

vdxOutlookBar Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup Class

The class which represents an outlookbar group item.

For a list of all members of this type, see vdxOutlookBarGroup Members.

System.Object
MarshalByRefObject
Component
Control
ButtonBase
Button
vdxOutlookBarGroup

public class vdxOutlookBarGroup : Button

Remarks

The group is the main button under which multiple items are managed. Selecting a group opens the corresponding items in your outlookbar.

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxOutlookBarGroup Members | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup Members

vdxOutlookBarGroup overview

Public Instance Constructors

vdxOutlookBarGroup Constructor Default Constructor.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription | Hides the basic property.
AccessibleDescription | Hides the basic property.
AccessibleName | Hides the basic property.
AccessibleRole | Hides the basic property.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor | Hides the basic property.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage | Hides the basic property.
BindingContext | Hides the basic property.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation | Hides the basic property.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings | Hides the basic property.
DialogResult (inherited from Button) | Gets or sets a value that is returned to the parent form when the button is clicked.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock | Hides the basic property.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle | Hides the basic property.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
IconList | Gets or sets the icon item ArrayList.
Image | Hides the basic property.
ImageAlign | Hides the basic property.
ImageIndex | Hides the basic property.
ImageList | Hides the basic property.
ImeMode | Hides the basic property.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location | Hides the basic property.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size | Hides the basic property.
TabIndex | Hides the basic property.
TabStop | Hides the basic property.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from ButtonBase) | Gets or sets the alignment of the text on the button control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyDefault (inherited from Button) | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly.
PerformClick (inherited from Button) | Generates a Click event for a button.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Button) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Button) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from ButtonBase) |
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Button) |
DefaultImeMode (inherited from ButtonBase) | Gets the default Input Method Editor (IME) mode supported by this control.
DefaultSize (inherited from ButtonBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
IsDefault | Hides the basic property.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from ButtonBase) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ButtonBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick | Occurs when a user clicks a group item.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from ButtonBase) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from ButtonBase) |
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from ButtonBase) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from ButtonBase) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from ButtonBase) |
OnMouseDown | Occurs when the mouse button is pressed.
OnMouseEnter (inherited from ButtonBase) |
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from ButtonBase) |
OnMouseMove (inherited from ButtonBase) |
OnMouseUp | Overrides OnMouseUp to set isPressed as false.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint | Overrides OnPaint to paint the group as popup style if GroupStyle is set.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ButtonBase) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from ButtonBase) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ButtonBase) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Button) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetFlagsandPaint (inherited from ButtonBase) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Button) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup Constructor

Default Constructor.

public vdxOutlookBarGroup();

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup Properties

The properties of the vdxOutlookBarGroup class are listed below. For a complete list of vdxOutlookBarGroup class members, see the vdxOutlookBarGroup Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription | Hides the basic property.
AccessibleDescription | Hides the basic property.
AccessibleName | Hides the basic property.
AccessibleRole | Hides the basic property.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor | Hides the basic property.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage | Hides the basic property.
BindingContext | Hides the basic property.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation | Hides the basic property.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings | Hides the basic property.
DialogResult (inherited from Button) | Gets or sets a value that is returned to the parent form when the button is clicked.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock | Hides the basic property.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle | Hides the basic property.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
IconList | Gets or sets the icon item ArrayList.
Image | Hides the basic property.
ImageAlign | Hides the basic property.
ImageIndex | Hides the basic property.
ImageList | Hides the basic property.
ImeMode | Hides the basic property.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location | Hides the basic property.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size | Hides the basic property.
TabIndex | Hides the basic property.
TabStop | Hides the basic property.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from ButtonBase) | Gets or sets the alignment of the text on the button control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Button) |
DefaultImeMode (inherited from ButtonBase) | Gets the default Input Method Editor (IME) mode supported by this control.
DefaultSize (inherited from ButtonBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
IsDefault | Hides the basic property.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.AccessibleDefaultActionDescription Property

Hides the basic property.

new public string AccessibleDefaultActionDescription {get;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.AccessibleDescription Property

Hides the basic property.

new public string AccessibleDescription {get;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.AccessibleName Property

Hides the basic property.

new public string AccessibleName {get;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.AccessibleRole Property

Hides the basic property.

new public System.Windows.Forms.AccessibleRole AccessibleRole {get;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.Anchor Property

Hides the basic property.

new public System.Windows.Forms.AnchorStyles Anchor {get; set;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.BackgroundImage Property

Hides the basic property.

new public System.Drawing.Image BackgroundImage {get;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.BindingContext Property

Hides the basic property.

new public System.Windows.Forms.BindingContext BindingContext {get;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.CausesValidation Property

Hides the basic property.

new public bool CausesValidation {get;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.DataBindings Property

Hides the basic property.

new public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.Dock Property

Hides the basic property.

new public System.Windows.Forms.DockStyle Dock {get; set;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.FlatStyle Property

Hides the basic property.

new public System.Windows.Forms.FlatStyle FlatStyle {get;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.IconList Property

Gets or sets the icon item ArrayList.

public vdxOutlookBarIconList IconList {get; set;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.Image Property

Hides the basic property.

new public System.Drawing.Image Image {get; set;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.ImageAlign Property

Hides the basic property.

new public System.Drawing.ContentAlignment ImageAlign {get; set;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.ImageIndex Property

Hides the basic property.

new public int ImageIndex {get; set;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.ImageList Property

Hides the basic property.

new public System.Windows.Forms.ImageList ImageList {get; set;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.ImeMode Property

Hides the basic property.

new public System.Windows.Forms.ImeMode ImeMode {get;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.IsDefault Property

Hides the basic property.

new protected bool IsDefault {get;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.Location Property

Hides the basic property.

new public System.Drawing.Point Location {get; set;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.Size Property

Hides the basic property.

new public System.Drawing.Size Size {get; set;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.TabIndex Property

Hides the basic property.

new public int TabIndex {get;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.TabStop Property

Hides the basic property.

new public bool TabStop {get;}

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup Methods

The methods of the vdxOutlookBarGroup class are listed below. For a complete list of vdxOutlookBarGroup class members, see the vdxOutlookBarGroup Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyDefault (inherited from Button) | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly.
PerformClick (inherited from Button) | Generates a Click event for a button.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Button) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from ButtonBase) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ButtonBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick | Occurs when a user clicks a group item.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from ButtonBase) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from ButtonBase) |
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from ButtonBase) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from ButtonBase) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from ButtonBase) |
OnMouseDown | Occurs when the mouse button is pressed.
OnMouseEnter (inherited from ButtonBase) |
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from ButtonBase) |
OnMouseMove (inherited from ButtonBase) |
OnMouseUp | Overrides OnMouseUp to set isPressed as false.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint | Overrides OnPaint to paint the group as popup style if GroupStyle is set.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ButtonBase) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from ButtonBase) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ButtonBase) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Button) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetFlagsandPaint (inherited from ButtonBase) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Button) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.OnClick Method

Occurs when a user clicks a group item.

protected override void OnClick(
EventArgs e
);

Parameters

e
The EventArgs object.

Remarks

Raises the outlookbar group click and the standard click event.

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.OnMouseDown Method

Occurs when the mouse button is pressed.

protected override void OnMouseDown(
MouseEventArgs e
);

Parameters

e
The MouseEventArgs object.

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.OnMouseUp Method

Overrides OnMouseUp to set isPressed as false.

protected override void OnMouseUp(
MouseEventArgs e
);

Parameters

e

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroup.OnPaint Method

Overrides OnPaint to paint the group as popup style if GroupStyle is set.

protected override void OnPaint(
PaintEventArgs e
);

Parameters

e

See Also

vdxOutlookBarGroup Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupList Class

Array list of all vdxOutlookBar groups within the outlookbar.

For a list of all members of this type, see vdxOutlookBarGroupList Members.

System.Object
ArrayList
vdxOutlookBarGroupList

public class vdxOutlookBarGroupList : ArrayList

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxOutlookBarGroupList Members | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupList Members

vdxOutlookBarGroupList overview

Public Instance Constructors

vdxOutlookBarGroupList Constructor Constructor.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item | Overloaded. Gets or sets a certain group item from the ArrayList.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

Public Instance Methods

Add | Adds an new group to the ArrayList.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Overloaded. Determines whether an element is in the ArrayList.
Contains | Overloaded. Checks if the ArrayList contains the specified group.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
IndexOf | Overloaded. Gets the ArrayList index of a specified group.
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxOutlookBarGroupList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupList Constructor

Constructor.

public vdxOutlookBarGroupList(
vdxOutlookBar outlookBar
);

Parameters

outlookBar
The outlookbar object.

See Also

vdxOutlookBarGroupList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupList Properties

The properties of the vdxOutlookBarGroupList class are listed below. For a complete list of vdxOutlookBarGroupList class members, see the vdxOutlookBarGroupList Members topic.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item | Overloaded. Gets or sets a certain group item from the ArrayList.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

See Also

vdxOutlookBarGroupList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupList.Item Property

Gets or sets a certain group item from the ArrayList.

public vdxOutlookBarGroup this[
int index
] {get; set;}

See Also

vdxOutlookBarGroupList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupList Methods

The methods of the vdxOutlookBarGroupList class are listed below. For a complete list of vdxOutlookBarGroupList class members, see the vdxOutlookBarGroupList Members topic.

Public Instance Methods

Add | Adds an new group to the ArrayList.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Overloaded. Determines whether an element is in the ArrayList.
Contains | Overloaded. Checks if the ArrayList contains the specified group.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
IndexOf | Overloaded. Gets the ArrayList index of a specified group.
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxOutlookBarGroupList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupList.Add Method

Adds an new group to the ArrayList.

public override int Add(
object groupObject
);

Parameters

groupObject
The group as type object.

Return Value

The ArrayList index where the object was inserted.

Implements

IList.Add

Remarks

Gets invoked eachtime an user adds a new icon (also with the collection editor).

See Also

vdxOutlookBarGroupList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Contains Method

VDX Framework

vdxOutlookBarGroupList.Contains Method

Checks if the ArrayList contains the specified group.

Overload List

Checks if the ArrayList contains the specified group.

public bool Contains(vdxOutlookBarGroup);

Inherited from ArrayList.

public virtual bool Contains(object);

See Also

vdxOutlookBarGroupList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupList.Contains Method (vdxOutlookBarGroup)

Checks if the ArrayList contains the specified group.

public bool Contains(
vdxOutlookBarGroup group
);

Parameters

group
The group to look for.

Return Value

True if the group is in the ArrayList.

See Also

vdxOutlookBarGroupList Class | Deag.Vdx.Controls.Standard Namespace | vdxOutlookBarGroupList.Contains Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IndexOf Method

VDX Framework

vdxOutlookBarGroupList.IndexOf Method

Gets the ArrayList index of a specified group.

Overload List

Gets the ArrayList index of a specified group.

public int IndexOf(vdxOutlookBarGroup);

Inherited from ArrayList.

public virtual int IndexOf(object);

Inherited from ArrayList.

public virtual int IndexOf(object,int);

Inherited from ArrayList.

public virtual int IndexOf(object,int,int);

See Also

vdxOutlookBarGroupList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarGroupList.IndexOf Method (vdxOutlookBarGroup)

Gets the ArrayList index of a specified group.

public int IndexOf(
vdxOutlookBarGroup group
);

Parameters

group
The group to look for.

Return Value

The ArrayList index.

See Also

vdxOutlookBarGroupList Class | Deag.Vdx.Controls.Standard Namespace | vdxOutlookBarGroupList.IndexOf Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon Class

The individual outlookbar icon where the user can click on to invoke an action.

For a list of all members of this type, see vdxOutlookBarIcon Members.

System.Object
MarshalByRefObject
Component
Control
ButtonBase
Button
vdxOutlookBarIcon

public class vdxOutlookBarIcon : Button

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxOutlookBarIcon Members | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon Members

vdxOutlookBarIcon overview

Public Instance Constructors

vdxOutlookBarIcon Constructor Default Constructor.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor | Hides the basic property.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage | Hides the basic property.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DialogResult (inherited from Button) | Gets or sets a value that is returned to the parent form when the button is clicked.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock | Hides the basic property.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle | Hides the basic property.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image | Hides the basic property.
ImageAlign | Hides the basic property.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList | Hides the basic property.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location | Hides the basic property.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft | Hides the basic property.
Site (inherited from Control) | Gets or sets the site of the control.
Size | Hides the basic property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign | Hides the basic property.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible | Gets or sets whether the icon is visible or not.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyDefault (inherited from Button) | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly.
PerformClick (inherited from Button) | Generates a Click event for a button.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Button) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Button) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from ButtonBase) |
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

contextMenu | The context menu of the icon.
image | The icon image.
isActive | Defines whether the icon is active or not.
isPressed | Defines whether the icon is pressed or not.
menuShowLargeIcons | The context menu item to change the icon size to large.
menuShowSmallIcons | The context menu item to change the icon size to small.
rectImage | The rectangle around the icon.

Protected Instance Properties

CreateParams (inherited from Button) |
DefaultImeMode (inherited from ButtonBase) | Gets the default Input Method Editor (IME) mode supported by this control.
DefaultSize (inherited from ButtonBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
IsDefault (inherited from ButtonBase) | Gets or sets a value indicating whether the button control is the default button.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from ButtonBase) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ButtonBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick | Occurs when the icon is clicked.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from ButtonBase) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from ButtonBase) |
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from ButtonBase) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from ButtonBase) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus | Occurs when the icon has lost focus. It deletes the mouse over rectangle.
OnMouseDown | Occurs when the mouse pointer is over the icon and a mouse button is pressed. It paints a mouse click rectangle on the button or builds the appropriate context menu.
OnMouseEnter | Occurs when a user enters the icon with the mouse.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave | Occurs when the mouse leaves the icon. It deletes the mouse over rectangle.
OnMouseMove (inherited from ButtonBase) |
OnMouseUp | Occurs when the mouse pointer is over the icon and a mouse button is released. It paints a mouse over rectangle on the button.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint | Occurs when the icon is redrawn.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ButtonBase) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from ButtonBase) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ButtonBase) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Button) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetFlagsandPaint (inherited from ButtonBase) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Button) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon Constructor

Default Constructor.

public vdxOutlookBarIcon();

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon Fields

The fields of the vdxOutlookBarIcon class are listed below. For a complete list of vdxOutlookBarIcon class members, see the vdxOutlookBarIcon Members topic.

Protected Instance Fields

contextMenu | The context menu of the icon.
image | The icon image.
isActive | Defines whether the icon is active or not.
isPressed | Defines whether the icon is pressed or not.
menuShowLargeIcons | The context menu item to change the icon size to large.
menuShowSmallIcons | The context menu item to change the icon size to small.
rectImage | The rectangle around the icon.

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.contextMenu Field

The context menu of the icon.

protected ContextMenu contextMenu;

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.Image Property

Hides the basic property.

new public System.Drawing.Image Image {get; set;}

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.isActive Field

Defines whether the icon is active or not.

protected bool isActive;

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.isPressed Field

Defines whether the icon is pressed or not.

protected bool isPressed;

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.menuShowLargeIcons Field

The context menu item to change the icon size to large.

protected MenuItem menuShowLargeIcons;

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.menuShowSmallIcons Field

The context menu item to change the icon size to small.

protected MenuItem menuShowSmallIcons;

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.rectImage Field

The rectangle around the icon.

protected Rectangle rectImage;

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon Properties

The properties of the vdxOutlookBarIcon class are listed below. For a complete list of vdxOutlookBarIcon class members, see the vdxOutlookBarIcon Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor | Hides the basic property.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage | Hides the basic property.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DialogResult (inherited from Button) | Gets or sets a value that is returned to the parent form when the button is clicked.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock | Hides the basic property.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle | Hides the basic property.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image | Hides the basic property.
ImageAlign | Hides the basic property.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList | Hides the basic property.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location | Hides the basic property.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft | Hides the basic property.
Site (inherited from Control) | Gets or sets the site of the control.
Size | Hides the basic property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign | Hides the basic property.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible | Gets or sets whether the icon is visible or not.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Button) |
DefaultImeMode (inherited from ButtonBase) | Gets the default Input Method Editor (IME) mode supported by this control.
DefaultSize (inherited from ButtonBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
IsDefault (inherited from ButtonBase) | Gets or sets a value indicating whether the button control is the default button.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.Anchor Property

Hides the basic property.

new public System.Windows.Forms.AnchorStyles Anchor {get; set;}

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.BackgroundImage Property

Hides the basic property.

new public System.Drawing.Image BackgroundImage {get; set;}

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.Dock Property

Hides the basic property.

new public System.Windows.Forms.DockStyle Dock {get;}

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.FlatStyle Property

Hides the basic property.

new public System.Windows.Forms.FlatStyle FlatStyle {get;}

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.ImageAlign Property

Hides the basic property.

new public System.Drawing.ContentAlignment ImageAlign {get;}

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.ImageList Property

Hides the basic property.

new public System.Windows.Forms.ImageList ImageList {get; set;}

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.Location Property

Hides the basic property.

new public System.Drawing.Point Location {get; set;}

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.RightToLeft Property

Hides the basic property.

new public System.Windows.Forms.RightToLeft RightToLeft {get;}

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.Size Property

Hides the basic property.

new public System.Drawing.Size Size {get; set;}

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.TextAlign Property

Hides the basic property.

new public System.Drawing.ContentAlignment TextAlign {get;}

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.Visible Property

Gets or sets whether the icon is visible or not.

new public bool Visible {get; set;}

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon Methods

The methods of the vdxOutlookBarIcon class are listed below. For a complete list of vdxOutlookBarIcon class members, see the vdxOutlookBarIcon Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyDefault (inherited from Button) | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly.
PerformClick (inherited from Button) | Generates a Click event for a button.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Button) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from ButtonBase) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ButtonBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick | Occurs when the icon is clicked.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from ButtonBase) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from ButtonBase) |
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from ButtonBase) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from ButtonBase) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus | Occurs when the icon has lost focus. It deletes the mouse over rectangle.
OnMouseDown | Occurs when the mouse pointer is over the icon and a mouse button is pressed. It paints a mouse click rectangle on the button or builds the appropriate context menu.
OnMouseEnter | Occurs when a user enters the icon with the mouse.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave | Occurs when the mouse leaves the icon. It deletes the mouse over rectangle.
OnMouseMove (inherited from ButtonBase) |
OnMouseUp | Occurs when the mouse pointer is over the icon and a mouse button is released. It paints a mouse over rectangle on the button.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint | Occurs when the icon is redrawn.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ButtonBase) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from ButtonBase) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ButtonBase) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Button) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetFlagsandPaint (inherited from ButtonBase) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Button) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.OnClick Method

Occurs when the icon is clicked.

protected override void OnClick(
EventArgs e
);

Parameters

e
The EventArgs object.

Remarks

It triggers the own IconClick and the standard Click event.

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.OnLostFocus Method

Occurs when the icon has lost focus. It deletes the mouse over rectangle.

protected override void OnLostFocus(
EventArgs e
);

Parameters

e
The EventArgs object.

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.OnMouseDown Method

Occurs when the mouse pointer is over the icon and a mouse button is pressed. It paints a mouse click rectangle on the button or builds the appropriate context menu.

protected override void OnMouseDown(
MouseEventArgs e
);

Parameters

e
The MouseEventArgs object.

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.OnMouseEnter Method

Occurs when a user enters the icon with the mouse.

protected override void OnMouseEnter(
EventArgs e
);

Parameters

e
The EventArgs object.

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.OnMouseLeave Method

Occurs when the mouse leaves the icon. It deletes the mouse over rectangle.

protected override void OnMouseLeave(
EventArgs e
);

Parameters

e
The EventArgs object.

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.OnMouseUp Method

Occurs when the mouse pointer is over the icon and a mouse button is released. It paints a mouse over rectangle on the button.

protected override void OnMouseUp(
MouseEventArgs e
);

Parameters

e
The MouseEventArgs object.

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIcon.OnPaint Method

Occurs when the icon is redrawn.

protected override void OnPaint(
PaintEventArgs e
);

Parameters

e
The PaintEventArgs object.

Remarks

Paints its own graphics on the graphics context.

See Also

vdxOutlookBarIcon Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconList Class

Array list of vdxOutlookBarIcon objects for a specific vdxOutlookBarGroup.

For a list of all members of this type, see vdxOutlookBarIconList Members.

System.Object
ArrayList
vdxOutlookBarIconList

public class vdxOutlookBarIconList : ArrayList

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxOutlookBarIconList Members | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconList Members

vdxOutlookBarIconList overview

Public Instance Constructors

vdxOutlookBarIconList Constructor Constructor.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item | Overloaded. Gets or sets an icon specified by its index.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.
VdxOutlookBar | Gets or sets the reference to the outlookbar object.
VdxOutlookBarGroup | Gets the reference to the outlookbar group.

Public Instance Methods

Add | Adds an new icon to the ArrayList.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxOutlookBarIconList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconList Constructor

Constructor.

public vdxOutlookBarIconList(
vdxOutlookBarGroup group
);

Parameters

group
The group which this ArrayList belongs to.

See Also

vdxOutlookBarIconList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconList Properties

The properties of the vdxOutlookBarIconList class are listed below. For a complete list of vdxOutlookBarIconList class members, see the vdxOutlookBarIconList Members topic.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item | Overloaded. Gets or sets an icon specified by its index.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.
VdxOutlookBar | Gets or sets the reference to the outlookbar object.
VdxOutlookBarGroup | Gets the reference to the outlookbar group.

See Also

vdxOutlookBarIconList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconList.Item Property

Gets or sets an icon specified by its index.

public vdxOutlookBarIcon this[
int index
] {get; set;}

See Also

vdxOutlookBarIconList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconList.VdxOutlookBar Property

Gets or sets the reference to the outlookbar object.

public vdxOutlookBar VdxOutlookBar {get; set;}

See Also

vdxOutlookBarIconList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconList.VdxOutlookBarGroup Property

Gets the reference to the outlookbar group.

public vdxOutlookBarGroup VdxOutlookBarGroup {get; set;}

See Also

vdxOutlookBarIconList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconList Methods

The methods of the vdxOutlookBarIconList class are listed below. For a complete list of vdxOutlookBarIconList class members, see the vdxOutlookBarIconList Members topic.

Public Instance Methods

Add | Adds an new icon to the ArrayList.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxOutlookBarIconList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconList.Add Method

Adds an new icon to the ArrayList.

public override int Add(
object iconObject
);

Parameters

iconObject
The icon as type object.

Return Value

The ArrayList index where the object was inserted.

Implements

IList.Add

Remarks

Gets invoked eachtime an user adds a new icon (also with the collection editor).

See Also

vdxOutlookBarIconList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelection Class

Class which represents a vdxOutlookBarIcon which has been dragged and dropped on the outlookbar.

For a list of all members of this type, see vdxOutlookBarIconSelection Members.

System.Object
MarshalByRefObject
Component
Control
ButtonBase
Button
vdxOutlookBarIcon
vdxOutlookBarIconSelection

public class vdxOutlookBarIconSelection : vdxOutlookBarIcon

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxOutlookBarIconSelection Members | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelection Members

vdxOutlookBarIconSelection overview

Public Instance Constructors

vdxOutlookBarIconSelection Constructor Default Constructor.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from vdxOutlookBarIcon) | Hides the basic property.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from vdxOutlookBarIcon) | Hides the basic property.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DialogResult (inherited from Button) | Gets or sets a value that is returned to the parent form when the button is clicked.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from vdxOutlookBarIcon) | Hides the basic property.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from vdxOutlookBarIcon) | Hides the basic property.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from vdxOutlookBarIcon) | Hides the basic property.
ImageAlign (inherited from vdxOutlookBarIcon) | Hides the basic property.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from vdxOutlookBarIcon) | Hides the basic property.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from vdxOutlookBarIcon) | Hides the basic property.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from vdxOutlookBarIcon) | Hides the basic property.
SearchParameters | Gets or sets the search parameters.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from vdxOutlookBarIcon) | Hides the basic property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from vdxOutlookBarIcon) | Hides the basic property.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
VdxOutlookBarGroup | Gets or sets the corresponding group item.
VdxSelectionId | Gets or sets the SelectionID.
Visible (inherited from vdxOutlookBarIcon) | Gets or sets whether the icon is visible or not.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyDefault (inherited from Button) | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly.
PerformClick (inherited from Button) | Generates a Click event for a button.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Button) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Button) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from ButtonBase) |
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

image (inherited from vdxOutlookBarIcon) | The icon image.
isActive (inherited from vdxOutlookBarIcon) | Defines whether the icon is active or not.
isPressed (inherited from vdxOutlookBarIcon) | Defines whether the icon is pressed or not.
menuShowLargeIcons (inherited from vdxOutlookBarIcon) | The context menu item to change the icon size to large.
menuShowSmallIcons (inherited from vdxOutlookBarIcon) | The context menu item to change the icon size to small.
rectImage (inherited from vdxOutlookBarIcon) | The rectangle around the icon.

Protected Instance Properties

CreateParams (inherited from Button) |
DefaultImeMode (inherited from ButtonBase) | Gets the default Input Method Editor (IME) mode supported by this control.
DefaultSize (inherited from ButtonBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
IsDefault (inherited from ButtonBase) | Gets or sets a value indicating whether the button control is the default button.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from ButtonBase) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ButtonBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick | Occurs when the icon is clicked.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from ButtonBase) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from ButtonBase) |
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from ButtonBase) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from ButtonBase) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from vdxOutlookBarIcon) | Occurs when the icon has lost focus. It deletes the mouse over rectangle.
OnMouseDown | Occurs when the mouse pointer is over the icon and a mouse button is pressed. It paints a mouse click rectangle on the button or builds the appropriate context menu.
OnMouseEnter (inherited from vdxOutlookBarIcon) | Occurs when a user enters the icon with the mouse.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from vdxOutlookBarIcon) | Occurs when the mouse leaves the icon. It deletes the mouse over rectangle.
OnMouseMove (inherited from ButtonBase) |
OnMouseUp (inherited from vdxOutlookBarIcon) | Occurs when the mouse pointer is over the icon and a mouse button is released. It paints a mouse over rectangle on the button.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint | Occurs when the icon is redrawn.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ButtonBase) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from ButtonBase) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ButtonBase) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Button) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetFlagsandPaint (inherited from ButtonBase) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Button) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxOutlookBarIconSelection Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelection Constructor

Default Constructor.

public vdxOutlookBarIconSelection();

See Also

vdxOutlookBarIconSelection Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelection Properties

The properties of the vdxOutlookBarIconSelection class are listed below. For a complete list of vdxOutlookBarIconSelection class members, see the vdxOutlookBarIconSelection Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from vdxOutlookBarIcon) | Hides the basic property.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from vdxOutlookBarIcon) | Hides the basic property.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DialogResult (inherited from Button) | Gets or sets a value that is returned to the parent form when the button is clicked.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from vdxOutlookBarIcon) | Hides the basic property.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from vdxOutlookBarIcon) | Hides the basic property.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from vdxOutlookBarIcon) | Hides the basic property.
ImageAlign (inherited from vdxOutlookBarIcon) | Hides the basic property.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from vdxOutlookBarIcon) | Hides the basic property.
ImeMode (inherited from ButtonBase) | Gets or sets the Input Method Editor (IME) mode supported by this control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from vdxOutlookBarIcon) | Hides the basic property.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from vdxOutlookBarIcon) | Hides the basic property.
SearchParameters | Gets or sets the search parameters.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from vdxOutlookBarIcon) | Hides the basic property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from vdxOutlookBarIcon) | Hides the basic property.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
VdxOutlookBarGroup | Gets or sets the corresponding group item.
VdxSelectionId | Gets or sets the SelectionID.
Visible (inherited from vdxOutlookBarIcon) | Gets or sets whether the icon is visible or not.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Button) |
DefaultImeMode (inherited from ButtonBase) | Gets the default Input Method Editor (IME) mode supported by this control.
DefaultSize (inherited from ButtonBase) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
IsDefault (inherited from ButtonBase) | Gets or sets a value indicating whether the button control is the default button.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

See Also

vdxOutlookBarIconSelection Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelection.SearchParameters Property

Gets or sets the search parameters.

public Deag.Vdx.Common.vdxSearchParameters SearchParameters {get; set;}

See Also

vdxOutlookBarIconSelection Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelection.VdxOutlookBarGroup Property

Gets or sets the corresponding group item.

public vdxOutlookBarGroup VdxOutlookBarGroup {get; set;}

See Also

vdxOutlookBarIconSelection Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelection.VdxSelectionId Property

Gets or sets the SelectionID.

public int VdxSelectionId {get; set;}

See Also

vdxOutlookBarIconSelection Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelection Methods

The methods of the vdxOutlookBarIconSelection class are listed below. For a complete list of vdxOutlookBarIconSelection class members, see the vdxOutlookBarIconSelection Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
NotifyDefault (inherited from Button) | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly.
PerformClick (inherited from Button) | Generates a Click event for a button.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Button) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from ButtonBase) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ButtonBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick | Occurs when the icon is clicked.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from ButtonBase) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from ButtonBase) |
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from ButtonBase) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from ButtonBase) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from vdxOutlookBarIcon) | Occurs when the icon has lost focus. It deletes the mouse over rectangle.
OnMouseDown | Occurs when the mouse pointer is over the icon and a mouse button is pressed. It paints a mouse click rectangle on the button or builds the appropriate context menu.
OnMouseEnter (inherited from vdxOutlookBarIcon) | Occurs when a user enters the icon with the mouse.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from vdxOutlookBarIcon) | Occurs when the mouse leaves the icon. It deletes the mouse over rectangle.
OnMouseMove (inherited from ButtonBase) |
OnMouseUp (inherited from vdxOutlookBarIcon) | Occurs when the mouse pointer is over the icon and a mouse button is released. It paints a mouse over rectangle on the button.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint | Occurs when the icon is redrawn.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ButtonBase) |
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from ButtonBase) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ButtonBase) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Button) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetFlagsandPaint (inherited from ButtonBase) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Button) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

vdxOutlookBarIconSelection Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelection.OnClick Method

Occurs when the icon is clicked.

protected override void OnClick(
EventArgs e
);

Parameters

e
The EventArgs object.

Remarks

It triggers the own IconClick and the standard Click event.

See Also

vdxOutlookBarIconSelection Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelection.OnMouseDown Method

Occurs when the mouse pointer is over the icon and a mouse button is pressed. It paints a mouse click rectangle on the button or builds the appropriate context menu.

protected override void OnMouseDown(
MouseEventArgs e
);

Parameters

e
The MouseEventArgs object.

See Also

vdxOutlookBarIconSelection Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelection.OnPaint Method

Occurs when the icon is redrawn.

protected override void OnPaint(
PaintEventArgs e
);

Parameters

e
The PaintEventArgs object.

Remarks

Paints its own graphics on the graphics context.

See Also

vdxOutlookBarIconSelection Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionList Class

Array list of vdxOutlookBarIconSelection objects.

For a list of all members of this type, see vdxOutlookBarIconSelectionList Members.

System.Object
ArrayList
vdxOutlookBarIconSelectionList

public class vdxOutlookBarIconSelectionList : ArrayList

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxOutlookBarIconSelectionList Members | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionList Members

vdxOutlookBarIconSelectionList overview

Public Instance Constructors

vdxOutlookBarIconSelectionList Constructor Constructor.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item | Overloaded. Gets or sets an icon specified by its index.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

Public Instance Methods

Add | Adds an new icon to the ArrayList.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxOutlookBarIconSelectionList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionList Constructor

Constructor.

public vdxOutlookBarIconSelectionList(
vdxOutlookBar outlookBar
);

Parameters

outlookBar
Reference to the outlookbar control.

See Also

vdxOutlookBarIconSelectionList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionList Properties

The properties of the vdxOutlookBarIconSelectionList class are listed below. For a complete list of vdxOutlookBarIconSelectionList class members, see the vdxOutlookBarIconSelectionList Members topic.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item | Overloaded. Gets or sets an icon specified by its index.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

See Also

vdxOutlookBarIconSelectionList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionList.Item Property

Gets or sets an icon specified by its index.

public vdxOutlookBarIconSelection this[
int index
] {get; set;}

See Also

vdxOutlookBarIconSelectionList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionList Methods

The methods of the vdxOutlookBarIconSelectionList class are listed below. For a complete list of vdxOutlookBarIconSelectionList class members, see the vdxOutlookBarIconSelectionList Members topic.

Public Instance Methods

Add | Adds an new icon to the ArrayList.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxOutlookBarIconSelectionList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxOutlookBarIconSelectionList.Add Method

Adds an new icon to the ArrayList.

public override int Add(
object iconObject
);

Parameters

iconObject
The icon as type object.

Return Value

The ArrayList index where the object was inserted.

Implements

IList.Add

Remarks

Gets invoked eachtime an user adds a new icon (also with the collection editor).

See Also

vdxOutlookBarIconSelectionList Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog Class

The base class for all picker dialogs in a foreign key picklist scenario used in the vdxPickField class.

For a list of all members of this type, see vdxPickerDialog Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
vdxPickerDialog

public class vdxPickerDialog : Form, IvdxPicker

Remarks

The picker dialog contains a searchPanel to hold a IvdxSearchControl, a navigatorPanel to hold a IvdxNavigator and a buttonPanel to hold the button btnAccept and btnCancel.

Example

This example shows how to implement an item pickerDialog of an ordering management scenario that can search for recorded items and to accept an entry. First we must derive from vdxPickerDialog:

            public class PickerDialogItem : vdxPickerDialog
            {
                ...
            }
Configure the properties of the pickerDialog as following:
NavigatorClassName vdxSampleApplication.Item.SelectionGridItem (see vdxSelectionGrid)SearchControlClassName vdxSampleApplication.Item.SelectionItem (see vdxSelection)
Property Value
Override the method LoadData to load the corresponding DataSet.

            protected override System.Data.DataSet LoadData(vdxSearchParameters searchParameters)
            {
                return WebServiceProvider.wsItem.GetDataSetItem(searchParameters.GetParameters());
            }
Override the method GetPickerInfo to communicate the selected vdxPickerInfo to the vdxPickField.

            protected override vdxPickerInfo GetPickerInfo(vdxNavigatorInfo navigatorInfo)
            {
                dsItem._ItemRow itemRow = navigatorInfo.SelectedRow as dsItem._ItemRow;
                if (itemRow != null)
                {
                    return new vdxPickerInfo(itemRow.ItemDescr, null, itemRow.ItemID);
                }
                return null;
            }
This pickerDialog can now be set as PickerClassName.

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxPickerDialog Members | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog Members

vdxPickerDialog overview

Public Instance Constructors

vdxPickerDialog Constructor Default constructor.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
NavigatorClassName | Full qualified string representation of the derived vdxSelectionList class.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PickField | Gets or sets the calling pick field.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SearchControlClassName | Gets or sets the full qualified string representation of the derived IvdxSearchControl class.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PickerAccepted | Occurs when the value or values were accepted.
PickerCancelled | Occurs when the picker routine was canceled.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

bottomPanel | Panel that holds buttonPanel.
btnAccept | Accept button.
btnCancel | Cancel button.
buttonPanel | Panel that holds btnAccept and btnCancel.
navigatorPanel | Panel that holds IvdxNavigator.
searchPanel | Panel that holds IvdxSearchControl.
Splitter | Splitter that separates searchPanel and navigatorPanel.

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
Navigator | Gets the navigator used in the context.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
SearchControl | Gets the searchControl used in the context.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetPickerInfo | Gets the vdxPickerInfo for the given navigatorInfo.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadData | Loads the data for the given searchParameters.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPickerAccepted | Raises the PickerAccepted event.
OnPickerCancelled | Raises the PickerCancelled event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxPicker.Clear
IvdxPicker.Close
IvdxPicker.Show

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog Constructor

Default constructor.

public vdxPickerDialog();

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog Fields

The fields of the vdxPickerDialog class are listed below. For a complete list of vdxPickerDialog class members, see the vdxPickerDialog Members topic.

Protected Instance Fields

bottomPanel | Panel that holds buttonPanel.
btnAccept | Accept button.
btnCancel | Cancel button.
buttonPanel | Panel that holds btnAccept and btnCancel.
navigatorPanel | Panel that holds IvdxNavigator.
searchPanel | Panel that holds IvdxSearchControl.
Splitter | Splitter that separates searchPanel and navigatorPanel.

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.bottomPanel Field

Panel that holds buttonPanel.

protected Panel bottomPanel;

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.btnAccept Field

Accept button.

protected vdxButton btnAccept;

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.btnCancel Field

Cancel button.

protected vdxButton btnCancel;

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.buttonPanel Field

Panel that holds btnAccept and btnCancel.

protected Panel buttonPanel;

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.navigatorPanel Field

Panel that holds IvdxNavigator.

protected Panel navigatorPanel;

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.searchPanel Field

Panel that holds IvdxSearchControl.

protected Panel searchPanel;

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.Splitter Field

Splitter that separates searchPanel and navigatorPanel.

protected Splitter Splitter;

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog Properties

The properties of the vdxPickerDialog class are listed below. For a complete list of vdxPickerDialog class members, see the vdxPickerDialog Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
NavigatorClassName | Full qualified string representation of the derived vdxSelectionList class.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PickField | Gets or sets the calling pick field.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SearchControlClassName | Gets or sets the full qualified string representation of the derived IvdxSearchControl class.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
Navigator | Gets the navigator used in the context.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
SearchControl | Gets the searchControl used in the context.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.Navigator Property

Gets the navigator used in the context.

protected Deag.Vdx.Controls.Core.IvdxNavigator Navigator {get;}

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.NavigatorClassName Property

Full qualified string representation of the derived vdxSelectionList class.

public string NavigatorClassName {get; set;}

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.PickField Property

Gets or sets the calling pick field.

public System.Windows.Forms.Control PickField {get; set;}

Implements

IvdxPicker.PickField

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.SearchControl Property

Gets the searchControl used in the context.

protected Deag.Vdx.Controls.Core.IvdxSearchControl SearchControl {get;}

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.SearchControlClassName Property

Gets or sets the full qualified string representation of the derived IvdxSearchControl class.

public string SearchControlClassName {get; set;}

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog Methods

The methods of the vdxPickerDialog class are listed below. For a complete list of vdxPickerDialog class members, see the vdxPickerDialog Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetPickerInfo | Gets the vdxPickerInfo for the given navigatorInfo.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadData | Loads the data for the given searchParameters.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPickerAccepted | Raises the PickerAccepted event.
OnPickerCancelled | Raises the PickerCancelled event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)
IvdxPicker.Clear
IvdxPicker.Close
IvdxPicker.Show

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.IvdxPicker.Clear Method

void IvdxPicker.Clear();

Implements

IvdxPicker.Clear

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.IvdxPicker.Close Method

void IvdxPicker.Close();

Implements

IvdxPicker.Close

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.IvdxPicker.Show Method

void IvdxPicker.Show();

Implements

IvdxPicker.Show

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Dispose Method

VDX Framework

vdxPickerDialog.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.Dispose Method (Boolean)

Clean up any resources being used.

protected override void Dispose(
bool disposing
);

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace | vdxPickerDialog.Dispose Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.GetPickerInfo Method

Gets the vdxPickerInfo for the given navigatorInfo.

protected virtual vdxPickerInfo GetPickerInfo(
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorInfo
Contains the selected navigatorItem.

Return Value

The corresponding picker info element.

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.LoadData Method

Loads the data for the given searchParameters.

protected virtual DataSet LoadData(
vdxSearchParameters searchParameters
);

Parameters

searchParameters
Contains the parameters for search routine.

Return Value

The corresponding dataSet for the given searchParameters.

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.OnPickerAccepted Method

Raises the PickerAccepted event.

protected virtual void OnPickerAccepted();

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.OnPickerCancelled Method

Raises the PickerCancelled event.

protected virtual void OnPickerCancelled();

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog Events

The events of the vdxPickerDialog class are listed below. For a complete list of vdxPickerDialog class members, see the vdxPickerDialog Members topic.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PickerAccepted | Occurs when the value or values were accepted.
PickerCancelled | Occurs when the picker routine was canceled.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.PickerAccepted Event

Occurs when the value or values were accepted.

public event vdxPickerEventHandler PickerAccepted;

Event Data

The event handler receives an argument of type vdxPickerEventArgs containing data related to this event. The following vdxPickerEventArgs property provides information specific to this event.

Property | Description
PickerInfo | Gets the vdxPickerInfo object.

Implements

IvdxPicker.PickerAccepted

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerDialog.PickerCancelled Event

Occurs when the picker routine was canceled.

public event vdxPickerEventHandler PickerCancelled;

Event Data

The event handler receives an argument of type vdxPickerEventArgs containing data related to this event. The following vdxPickerEventArgs property provides information specific to this event.

Property | Description
PickerInfo | Gets the vdxPickerInfo object.

Implements

IvdxPicker.PickerCancelled

See Also

vdxPickerDialog Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerInfo Class

Communication media between vdxPickField and IvdxPicker.

For a list of all members of this type, see vdxPickerInfo Members.

System.Object
vdxPickerInfo

public class vdxPickerInfo

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxPickerInfo Members | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerInfo Members

vdxPickerInfo overview

Public Instance Constructors

vdxPickerInfo Overloaded. Initializes a new instance of the vdxPickerInfo class.

Public Instance Properties

Code | Gets the code.
Description | Gets the description.
ForeignKey | Gets the foreignKey.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vdxPickerInfo Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerInfo Constructor

Instantiate vdxPickerInfo for description, foreign key and code.

Overload List

Instantiate vdxPickerInfo for description, foreign key and code.

public vdxPickerInfo(object,object,object);

Instantiate vdxPickerInfo for description, foreign key and code.

public vdxPickerInfo(string,object,string);

See Also

vdxPickerInfo Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerInfo Constructor (Object, Object, Object)

Instantiate vdxPickerInfo for description, foreign key and code.

public vdxPickerInfo(
object description,
object foreignKey,
object code
);

Parameters

description
The description to be data bounded on vdxPickField.
foreignKey
The foreignKey to be data bounded on vdxPickField.
code
The code to be data bounded on vdxPickField.

See Also

vdxPickerInfo Class | Deag.Vdx.Controls.Standard Namespace | vdxPickerInfo Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerInfo Constructor (String, Object, String)

Instantiate vdxPickerInfo for description, foreign key and code.

public vdxPickerInfo(
string description,
object foreignKey,
string code
);

Parameters

description
The description to be data bounded on vdxPickField.
foreignKey
The foreignKey to be data bounded on vdxPickField.
code
The code to be data bounded on vdxPickField.

See Also

vdxPickerInfo Class | Deag.Vdx.Controls.Standard Namespace | vdxPickerInfo Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerInfo Properties

The properties of the vdxPickerInfo class are listed below. For a complete list of vdxPickerInfo class members, see the vdxPickerInfo Members topic.

Public Instance Properties

Code | Gets the code.
Description | Gets the description.
ForeignKey | Gets the foreignKey.

See Also

vdxPickerInfo Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerInfo.Code Property

Gets the code.

public string Code {get;}

See Also

vdxPickerInfo Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerInfo.Description Property

Gets the description.

public string Description {get;}

See Also

vdxPickerInfo Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickerInfo.ForeignKey Property

Gets the foreignKey.

public object ForeignKey {get;}

See Also

vdxPickerInfo Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField Class

Base class for a foreign key validation scenario.

For a list of all members of this type, see vdxPickField Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
vdxPickField

public class vdxPickField : UserControl, IvdxInputControl, IvdxDsmHost, IvdxResettable, IvdxBindingManagable, IvdxBindable

Remarks

Known derived classes: vdxDataPickFieldvdxDatePickField There are two textboxes txtCode and txtDescription and two buttons btnOpenPicker and btnClear that can be configured individually. Set your own IvdxPicker as foreign key chooser.

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxPickField Members | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField Members

vdxPickField overview

Public Instance Constructors

vdxPickField Constructor Default constructor.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoStartPicker | Gets or sets if this IvdxPicker should be started automatically if code field validation fails.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindEmptyValuesAsNull | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from ContainerControl) |
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus | See CanFocus
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CodeWidth | Gets or sets the width of the Code Textbox.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled | Gets or sets a value indicating whether control can respond to user interaction.
Focused | Overrides Focused
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideButtonOpenPicker | Gets or sets whether the button open picker is visible or not.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM | Gets/sets a value indicating whether the PickField interacts with the DSM. If set to true then the PickField will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PickCode | Gets or sets the code that can be uniquely identified.
PickCodeIsNull | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
PickDescription | Gets or sets the description the correspond to the code field or foreign key.
PickDescriptionIsNull | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
PickerClassName | Gets or sets the full qualified string representation of the derived IvdxPicker.
PickForeignKey | Gets or sets the foreign key.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly | Gets or sets a value indicating whether text in text box code is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Reset | Resets the vdxPickField
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetPickValues | Overloaded. Sets the values of the vdxPickField.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PickCodeChanged | Occurs after the PickCode field has changed.
PickDescriptionChanged | Occurs after the PickDescription field has changed.
PickForeignKeyChanged | Occurs after the PickForeignKey field has changed.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

btnClear | Clear button.
btnOpenPicker | Open picker button.
manuallyChanged | Indicates whether the code field was changed by code flow or by user inter action.
picker | Picker instance.
txtCode | Code field.
txtDescription | Description field.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
FillData | Fill up description field.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsValid | Checks if code field is valid.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint | Overrides OnPaint.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize | Overrides OnResize.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating | Overrides OnValidating.
OnVisibleChanged (inherited from ScrollableControl) |
OpenPicker | Opens the picker to select an entry.
Picker_PickerAccepted | Event listener to react on PickerClassName acception of an new entry.
PickerActivated | Occurs when the IvdxPicker is activated. Can be used to set the values from the pickfield to the IvdxPicker.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RemovePicker | Removes the instance of the picker
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl) |
IvdxInputControl.InitializeBinding | Do any initializing work like converting format.
IvdxResettable.Reset | Resets the values of the fields to the empty string.

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField Constructor

Default constructor.

public vdxPickField();

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField Fields

The fields of the vdxPickField class are listed below. For a complete list of vdxPickField class members, see the vdxPickField Members topic.

Protected Instance Fields

btnClear | Clear button.
btnOpenPicker | Open picker button.
manuallyChanged | Indicates whether the code field was changed by code flow or by user inter action.
picker | Picker instance.
txtCode | Code field.
txtDescription | Description field.

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.btnClear Field

Clear button.

protected Button btnClear;

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.btnOpenPicker Field

Open picker button.

protected Button btnOpenPicker;

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.manuallyChanged Field

Indicates whether the code field was changed by code flow or by user inter action.

protected bool manuallyChanged;

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.picker Field

Picker instance.

protected IvdxPicker picker;

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.txtCode Field

Code field.

protected vdxTextBox txtCode;

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.txtDescription Field

Description field.

protected vdxTextBox txtDescription;

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField Properties

The properties of the vdxPickField class are listed below. For a complete list of vdxPickField class members, see the vdxPickField Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoStartPicker | Gets or sets if this IvdxPicker should be started automatically if code field validation fails.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindEmptyValuesAsNull | Gets or sets whether the empty values must be binded as null.
BindingContext (inherited from ContainerControl) |
BindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus | See CanFocus
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CodeWidth | Gets or sets the width of the Code Textbox.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindingInfos | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled | Gets or sets a value indicating whether control can respond to user interaction.
Focused | Overrides Focused
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideButtonOpenPicker | Gets or sets whether the button open picker is visible or not.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InteractWithDSM | Gets/sets a value indicating whether the PickField interacts with the DSM. If set to true then the PickField will not force an AutoEdit on the DSM. Default value = true;
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PickCode | Gets or sets the code that can be uniquely identified.
PickCodeIsNull | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
PickDescription | Gets or sets the description the correspond to the code field or foreign key.
PickDescriptionIsNull | This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.
PickerClassName | Gets or sets the full qualified string representation of the derived IvdxPicker.
PickForeignKey | Gets or sets the foreign key.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly | Gets or sets a value indicating whether text in text box code is read-only.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Private Instance Properties

Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.AutoStartPicker Property

Gets or sets if this IvdxPicker should be started automatically if code field validation fails.

public bool AutoStartPicker {get; set;}

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.BindEmptyValuesAsNull Property

Gets or sets whether the empty values must be binded as null.

public bool BindEmptyValuesAsNull {get; set;}

Implements

IvdxInputControl.BindEmptyValuesAsNull

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.BindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public System.Collections.IList BindingInfos {get;}

Implements

IvdxBindable.BindingInfos

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.CanFocus Property

See CanFocus

new public bool CanFocus {get;}

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.CodeWidth Property

Gets or sets the width of the Code Textbox.

public int CodeWidth {get; set;}

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.DataBindingInfos Property

Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.

public Deag.Vdx.Controls.Core.Bindings.vdxBindingInfoCollection DataBindingInfos {get;}

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager Property

private Deag.Vdx.Controls.Core.vdxDataStatusManager Deag.Vdx.Controls.Core.IvdxDsmHost.DataStatusManager {get; set;}

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.Enabled Property

Gets or sets a value indicating whether control can respond to user interaction.

new public bool Enabled {get; set;}

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.Focused Property

Overrides Focused

public override bool Focused {get;}

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.HideButtonOpenPicker Property

Gets or sets whether the button open picker is visible or not.

public bool HideButtonOpenPicker {get; set;}

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.InteractWithDSM Property

Gets/sets a value indicating whether the PickField interacts with the DSM. If set to true then the PickField will not force an AutoEdit on the DSM. Default value = true;

public bool InteractWithDSM {get; set;}

Implements

IvdxInputControl.InteractWithDSM

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.PickCode Property

Gets or sets the code that can be uniquely identified.

public string PickCode {get; set;}

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.PickCodeIsNull Property

This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.

public virtual bool PickCodeIsNull {get; set;}

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.PickDescription Property

Gets or sets the description the correspond to the code field or foreign key.

public string PickDescription {get; set;}

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.PickDescriptionIsNull Property

This method is used by the .NET Framework to set the data in a databound szenario. If it returns true, null is written instead of the text, which can be an emtpy string.

public virtual bool PickDescriptionIsNull {get; set;}

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.PickerClassName Property

Gets or sets the full qualified string representation of the derived IvdxPicker.

public virtual string PickerClassName {get; set;}

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.PickForeignKey Property

Gets or sets the foreign key.

public object PickForeignKey {get; set;}

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.ReadOnly Property

Gets or sets a value indicating whether text in text box code is read-only.

public bool ReadOnly {get; set;}

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField Methods

The methods of the vdxPickField class are listed below. For a complete list of vdxPickField class members, see the vdxPickField Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo | Get the binding info for the Property specified.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Reset | Resets the vdxPickField
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBindingInfo | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetPickValues | Overloaded. Sets the values of the vdxPickField.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
FillData | Fill up description field.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsValid | Checks if code field is valid.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint | Overrides OnPaint.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize | Overrides OnResize.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating | Overrides OnValidating.
OnVisibleChanged (inherited from ScrollableControl) |
OpenPicker | Opens the picker to select an entry.
Picker_PickerAccepted | Event listener to react on PickerClassName acception of an new entry.
PickerActivated | Occurs when the IvdxPicker is activated. Can be used to set the values from the pickfield to the IvdxPicker.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RemovePicker | Removes the instance of the picker
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl) |
IvdxInputControl.InitializeBinding | Do any initializing work like converting format.
IvdxResettable.Reset | Resets the values of the fields to the empty string.

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.IvdxInputControl.InitializeBinding Method

Do any initializing work like converting format.

void IvdxInputControl.InitializeBinding(
Binding binding
);

Implements

IvdxInputControl.InitializeBinding

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.IvdxResettable.Reset Method

Resets the values of the fields to the empty string.

void IvdxResettable.Reset();

Implements

IvdxResettable.Reset

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Dispose Method

VDX Framework

vdxPickField.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.Dispose Method (Boolean)

Clean up any resources being used.

protected override void Dispose(
bool disposing
);

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace | vdxPickField.Dispose Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.FillData Method

Fill up description field.

protected virtual void FillData();

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.GetBindingInfo Method

Get the binding info for the Property specified.

public vdxBindingInfo GetBindingInfo(
string PropertyName
);

Parameters

PropertyName
Name of the property

Return Value

The vdxBindinInfo object or null if no binding information present

Implements

IvdxBindable.GetBindingInfo

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.IsValid Method

Checks if code field is valid.

protected virtual bool IsValid();

Return Value

True if code field contains a valid value.

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.OnPaint Method

Overrides OnPaint.

protected override void OnPaint(
PaintEventArgs e
);

Parameters

e

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.OnResize Method

Overrides OnResize.

protected override void OnResize(
EventArgs e
);

Parameters

e

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.OnValidating Method

Overrides OnValidating.

protected override void OnValidating(
CancelEventArgs e
);

Parameters

e

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.OpenPicker Method

Opens the picker to select an entry.

protected virtual void OpenPicker();

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.Picker_PickerAccepted Method

Event listener to react on PickerClassName acception of an new entry.

protected virtual void Picker_PickerAccepted(
object source,
vdxPickerEventArgs eventArgs
);

Parameters

source
not used
eventArgs
A vdxPickerEventArgs that contains a vdxPickerInfo.

Remarks

The pickField must go in edit if a vdxDataStatusManager(DSM) is set and the pickField interacts with the DSM and allows edit. Default all fields PickCode, PickForeignKey and PickDescription will be set.

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.PickerActivated Method

Occurs when the IvdxPicker is activated. Can be used to set the values from the pickfield to the IvdxPicker.

protected virtual void PickerActivated();

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.RemovePicker Method

Removes the instance of the picker

protected virtual void RemovePicker();

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.Reset Method

Resets the vdxPickField

public virtual void Reset();

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.SetBindingInfo Method

Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.

public void SetBindingInfo(
string PropertyName,
vdxBindingInfo bInfo
);

Parameters

PropertyName
Name of the property
bInfo
The Binding Information

Implements

IvdxBindable.SetBindingInfo

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SetPickValues Method

VDX Framework

vdxPickField.SetPickValues Method

Sets the values of the vdxPickField.

Overload List

Sets the values of the vdxPickField.

public void SetPickValues(string,object,string);

Sets the values of the vdxPickField.

public void SetPickValues(string,string);

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.SetPickValues Method (String, Object, String)

Sets the values of the vdxPickField.

public void SetPickValues(
string code,
object foreignkey,
string description
);

Parameters

code
The value for the PickCode property.
foreignkey
The value for the PickForeignKey property.
description
The value for the PickDescription property.

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace | vdxPickField.SetPickValues Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.SetPickValues Method (String, String)

Sets the values of the vdxPickField.

public void SetPickValues(
string code,
string description
);

Parameters

code
The value for the PickCode property.
description
The value for the PickDescription property.

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace | vdxPickField.SetPickValues Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField Events

The events of the vdxPickField class are listed below. For a complete list of vdxPickField class members, see the vdxPickField Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PickCodeChanged | Occurs after the PickCode field has changed.
PickDescriptionChanged | Occurs after the PickDescription field has changed.
PickForeignKeyChanged | Occurs after the PickForeignKey field has changed.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.PickCodeChanged Event

Occurs after the PickCode field has changed.

public event EventHandler PickCodeChanged;

Remarks

A change is only done if the old value is not equal the new value.

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.PickDescriptionChanged Event

Occurs after the PickDescription field has changed.

public event EventHandler PickDescriptionChanged;

Remarks

A change is only done if the old value is not equal the new value.

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxPickField.PickForeignKeyChanged Event

Occurs after the PickForeignKey field has changed.

public event EventHandler PickForeignKeyChanged;

Remarks

A change is only done if the old value is not equal the new value.

See Also

vdxPickField Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid Class

A specialized vdxDataGridNavigator which also is a IvdxMultiContainerCacheable control.

For a list of all members of this type, see vdxSelectionGrid Members.

System.Object
MarshalByRefObject
Component
Control
DataGrid
vdxDataGrid
vdxDataGridNavigator
vdxSelectionGrid

public class vdxSelectionGrid : vdxDataGridNavigator, IvdxMultiContainerCacheable

Remarks

Used in the context of a vdxExplorerTree to represent the selection root node. This class is also used in the vdxPickField context.

Example

This example shows how to implement a selection grid for the person data management scenario. First we must derive from vdxSelectionGrid:

            public class SelectionGridPerson : vdxSelectionGrid
            {
                ...
            }
Add a vdxDataSetReference onto the SelectionGridPerson control in Design Mode. Configure the properties of the vdxDataSetReference1 as following:
Name dsrPerListRefDataSet vdxSampleApplication.vdxSampleWebServices.dsPersList
Property Value
Bind SelectionGridPerson to the dsrPersList and configure the properties of the SelectionGridPerson as following:
DataSource dsrPerListDataMember Pers
Property Value
Generate the DataGridTableStyle over the command "Generate ColumnStyles" in the Property Sheet of SelectionGridPerson and configure they individually.

Requirements

Namespace: Deag.Vdx.Controls.Standard

Assembly: vdxControls (in vdxControls.dll)

See Also

vdxSelectionGrid Members | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid Members

vdxSelectionGrid overview

Public Instance Constructors

vdxSelectionGrid Constructor Creates an instance of the class vdxSelectionGrid.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowNavigation (inherited from vdxDataGridNavigator) | Gets or sets a value indicating whether navigation is allowed.
AllowSorting (inherited from DataGrid) | Gets or sets a value indicating whether the grid can be resorted by clicking on a column header.
AlternatingBackColor (inherited from DataGrid) | Gets or sets the background color of odd-numbered rows of the grid.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from DataGrid) | Gets or sets the background color of even-numbered rows of the grid.
BackgroundColor (inherited from DataGrid) | Gets or sets the color of the non-row area of the grid.
BackgroundImage (inherited from DataGrid) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxDataGrid) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from DataGrid) | Gets or sets the grid's border style.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CaptionBackColor (inherited from DataGrid) | Gets or sets the background color of the caption area.
CaptionFont (inherited from DataGrid) | Gets or sets the font of the grid's caption.
CaptionForeColor (inherited from DataGrid) | Gets or sets the foreground color of the caption area.
CaptionText (inherited from DataGrid) | Gets or sets the text of the grid's window caption.
CaptionVisible | Gets or sets a value indicating whether the grid's caption is visible.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColumnHeadersVisible (inherited from DataGrid) | Gets or sets a value indicating whether the column headers a table are visible.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrencyManager (inherited from vdxDataGrid) | Gets the managed CurrencyManager of this data grid.
CurrentCell (inherited from DataGrid) | Gets or sets which cell has the focus. Not available at design time.
CurrentDataRow (inherited from vdxDataGrid) | Gets or sets the dataRows which are selected.
CurrentRowIndex (inherited from DataGrid) | Gets or sets index of the selected row.
Cursor (inherited from DataGrid) |
DataBindingInfos (inherited from vdxDataGrid) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataMember (inherited from vdxDataGrid) |
DataSource (inherited from vdxDataGrid) | Gets or sets the data source that this grid is displaying data for.
DataView (inherited from vdxDataGrid) | Gets the managed DataView of this data grid.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
ExplorerTree | Gets or sets the corresponding explorerTree.
FirstVisibleColumn (inherited from DataGrid) | Gets the index of the first visible column in a grid.
FlatMode (inherited from DataGrid) | Gets or sets a value indicating whether the grid displays in flat mode.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from DataGrid) | Gets or sets the foreground color (typically the color of the text) property of the DataGrid control.
GridLineColor (inherited from DataGrid) | Gets or sets the color of the grid lines.
GridLineStyle (inherited from DataGrid) | Gets or sets the line style of the grid.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HeaderBackColor (inherited from DataGrid) | Gets or sets the background color of all row and column headers.
HeaderFont (inherited from DataGrid) | Gets or sets the font used for column headers.
HeaderForeColor (inherited from DataGrid) | Gets or sets the foreground color of headers.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Item (inherited from DataGrid) | Gets or sets the value of the cell at the specified the row and column.
Item (inherited from DataGrid) | Gets or sets the value of a specified DataGridCell .
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LinkColor (inherited from DataGrid) | Gets or sets the color of the text that you can click to navigate to a child table.
LinkHoverColor (inherited from DataGrid) | Gets or sets the color a link changes to when the mouse pointer moves over it.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentRowsBackColor (inherited from DataGrid) | Gets or sets the background color of parent rows.
ParentRowsForeColor (inherited from DataGrid) | Gets or sets the foreground color of parent rows.
ParentRowsLabelStyle (inherited from DataGrid) | Gets or sets the way parent row labels are displayed.
ParentRowsVisible (inherited from DataGrid) | Gets or sets a value indicating whether the parent rows of a table are visible.
PreferredColumnWidth (inherited from DataGrid) | Gets or sets the default width of the grid columns in pixels.
PreferredRowHeight (inherited from DataGrid) | Gets or sets the preferred row height for the DataGrid control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly | Gets or sets a value indicating whether the grid is a read-only mode.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RowHeadersVisible (inherited from DataGrid) | Gets or sets a value that specifies whether row headers are visible.
RowHeaderWidth (inherited from DataGrid) | Gets or sets the width of row headers.
SelectedDataRows (inherited from vdxDataGrid) | Gets or sets the dataRows which are selected.
SelectionBackColor (inherited from DataGrid) | Gets or sets the background color of selected rows.
SelectionForeColor (inherited from DataGrid) | Gets or set the foreground color of selected rows.
Site (inherited from DataGrid) |
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TableStyles (inherited from DataGrid) | Gets the collection of DataGridTableStyle objects for the grid.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from DataGrid) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisibleColumnCount (inherited from DataGrid) | Gets the number of visible columns.
VisibleRowCount (inherited from DataGrid) | Gets the number of rows visible.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginEdit (inherited from DataGrid) | Attempts to put the grid into a state where editing is allowed.
BeginInit (inherited from DataGrid) | Begins the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Collapse (inherited from DataGrid) | Collapses child relations, if any exist for all rows, or for a specified row.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndEdit (inherited from DataGrid) | Requests an end to an edit operation taking place on the DataGrid control.
EndInit (inherited from DataGrid) | Ends the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from DataGrid) | Displays child relations, if any exist, for all rows or a specific row.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindRows (inherited from vdxDataGrid) | Find rows by a SQL where clause.
FindText (inherited from vdxDataGrid) | Full text search for the passed Text. Every row is scanned for the Text. If the row contains the text, it is added to the resultion row collection.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxDataGrid) | Get the binding info for the Property specified.
GetCellBounds (inherited from DataGrid) | Overloaded. Gets the Rectangle of the cell specified by row and column number.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetCurrentCellBounds (inherited from DataGrid) | Gets a Rectangle that specifies the four corners of the selected cell.
GetDataRowAT (inherited from vdxDataGrid) | Gets the Datarow with the specified index
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetRowIndex (inherited from vdxDataGrid) | Returns the (momentary) index of a row in the grid. The returned index depends on the momentary sort order.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HitTest (inherited from DataGrid) | Overloaded. Gets information, such as row and column number of a clicked point on the grid, using the x and y coordinate passed to the method.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
IsExpanded (inherited from DataGrid) | Gets a value that indicates whether a specified row's node is expanded or collapsed.
IsSelected (inherited from DataGrid) | Gets a value indicating whether a specified row is selected.
MoveFirst (inherited from vdxDataGrid) | Moves to the first record in the grid
MoveLast (inherited from vdxDataGrid) | Move to the last record of the grid if possible
MoveNext (inherited from vdxDataGrid) | Moves to the next record in the grid. If we are already on the last record, moves to the first record.
MovePrevious (inherited from vdxDataGrid) | Moves to the previous record in the grid. If we are already on the first recorde, moves to the last record
NavigateBack (inherited from DataGrid) | Navigates back to the table previously displayed in the grid.
NavigateTo (inherited from DataGrid) | Navigates to the table specified by row and relation name.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetAlternatingBackColor (inherited from DataGrid) | Resets the AlternatingBackColor property to its default color.
ResetBackColor (inherited from DataGrid) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from DataGrid) | Resets the ForeColor property to its default value.
ResetGridLineColor (inherited from DataGrid) | Resets the GridLineColor property to its default value.
ResetHeaderBackColor (inherited from DataGrid) | Resets the HeaderBackColor property to its default value.
ResetHeaderFont (inherited from DataGrid) | Resets the HeaderFont property to its default value.
ResetHeaderForeColor (inherited from DataGrid) | Resets the HeaderForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetLinkColor (inherited from DataGrid) | Resets the LinkColor property to its default value.
ResetLinkHoverColor (inherited from DataGrid) |
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetSelectionBackColor (inherited from DataGrid) | Resets the SelectionBackColor property to its default value.
ResetSelectionForeColor (inherited from DataGrid) | Resets the SelectionForeColor property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from DataGrid) | Overloaded. Selects a specified row.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo (inherited from vdxDataGrid) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDataBinding (inherited from DataGrid) | Sets the DataSource and DataMember properties at run time.
Show (inherited from Control) | Displays the control to the user.
SubObjectsSiteChange (inherited from DataGrid) |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
UnSelect (inherited from DataGrid) | Unselects a specified row.
Update (inherited from Control) | Overloaded. Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AllowNavigationChanged (inherited from DataGrid) | Occurs when the AllowNavigation property has changed.
BackButtonClick (inherited from DataGrid) | Occurs when the Back button on a child table is clicked.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundColorChanged (inherited from DataGrid) | Occurs when the BackgroundColor has changed.
BackgroundImageChanged (inherited from DataGrid) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
BorderStyleChanged (inherited from DataGrid) | Occurs when the BorderStyle has changed.
CaptionVisibleChanged (inherited from DataGrid) | Occurs when the CaptionVisible property has changed.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlChanged (inherited from vdxDataGridNavigator) | Occurs when an other cacheable control had to be shown.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CurrentCellChanged (inherited from DataGrid) | Occurs when the CurrentCell property has changed.
CursorChanged (inherited from DataGrid) |
DataSourceChanged (inherited from DataGrid) | Occurs when the DataSource property value has changed.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
Filled (inherited from vdxDataGridNavigator) | Occurs after Fill was called.
FlatModeChanged (inherited from DataGrid) | Occurs when the FlatMode has changed.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Navigate (inherited from DataGrid) | Occurs when the user navigates to a new table.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
ParentRowsLabelStyleChanged (inherited from DataGrid) | Occurs when the label style of the parent row is changed.
ParentRowsVisibleChanged (inherited from DataGrid) | Occurs when the ParentRowsVisible property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
ReadOnlyChanged (inherited from DataGrid) | Occurs when the ReadOnly property value changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from DataGrid) | Occurs when the user scrolls the DataGrid control.
SelectionChanged (inherited from vdxDataGridNavigator) | Occurs when an other DataRow was selected.
ShowParentDetailsButtonClick (inherited from DataGrid) | Occurs when the ShowParentDetails button is clicked.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from DataGrid) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

fireEvent (inherited from vdxDataGridNavigator) | Activate/Deactivate event firing for OnSelectionChanged and OnControlChanged.
mousePosition (inherited from vdxDataGridNavigator) | Mouse position after mouse click event.

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DataSet (inherited from vdxDataGrid) | Gets or sets DataSet on DataSource.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from DataGrid) | Gets the default size of the control.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HorizScrollBar (inherited from DataGrid) | Gets the horizontal scrollbar for the grid.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
SelectedDataRow (inherited from vdxDataGrid) | Gets the corresponding selected data row.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VertScrollBar (inherited from DataGrid) | Gets the vertical scroll bar of the control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
Activate | Override this method for your specific cacheable control.
AddRow (inherited from vdxDataGridNavigator) | Adds gridDataRow to data source table.
AttatchCurrencyManagerEventHandlers (inherited from vdxDataGridNavigator) | Register CurrencyManager listeners.
CancelEditing (inherited from DataGrid) | Cancels the current edit operation and rolls back all changes.
ChangeSelection (inherited from vdxDataGridNavigator) | Changes current selection to the given row.
Clear (inherited from vdxDataGridNavigator) | Remove all rows from the grid.
Create | Override this method for your specific cacheable control.
CreateAccessibilityInstance (inherited from DataGrid) | Constructs a new instance of the accessibility object for this control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateGridColumn (inherited from DataGrid) | Overloaded. Creates a new DataGridColumnStyle with the specified PropertyDescriptor.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateNavigatorInfoItem (inherited from vdxDataGridNavigator) | Creates a vdxNavigatorInfoItem for the given dataRow.
CurrencyManager_PositionChanged | Overrides vdxDataGridNavigator CurrencyManager_PositionChanged.
Deactivate | Override this method for your specific cacheable control.
DeactivateAllowed | Override this method for your specific cacheable control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
Delete | Deletes the selected row.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from DataGrid) | Overloaded.
Fill (inherited from vdxDataGridNavigator) | Builds a dataGrid for the given DataSet;
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetDataRowKey (inherited from vdxDataGridNavigator) | Gets an unique key to differ TreeNodes on the same hierarchy level.
GetGridDataRow (inherited from vdxDataGridNavigator) | Gets the corresponding grid DataRow for the given navigator DataRow.
GetLoaderInfo | Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.
GetNavigatorInfo (inherited from vdxDataGridNavigator) | Gets the corresponding navigation info for the given item.
GetNavigatorInfoItemForGridRow (inherited from vdxDataGridNavigator) | Gets the corresponding navigator DataRow for the given grid DataRow.
GetOutputTextDelimiter (inherited from DataGrid) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GridHScrolled (inherited from DataGrid) | Listens for the horizontal scrollbar's scroll event.
GridVScrolled (inherited from DataGrid) | Listens for the vertical scrollbar's scroll event.
InitLayout (inherited from Control) | Called after the control has been added to another container.
Insert (inherited from vdxDataGridNavigator) | Inserts a new navigator row for the corresponding navigator row.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsRefreshable (inherited from vdxDataGridNavigator) | Checks if the component supports refresh.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAllowNavigationChanged (inherited from DataGrid) | Raises the AllowNavigationChanged event.
OnBackButtonClicked (inherited from DataGrid) | Listens for the caption's back button clicked event.
OnBackColorChanged (inherited from DataGrid) | Raises the BackColorChanged event.
OnBackgroundColorChanged (inherited from DataGrid) | Raises the BackgroundColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from DataGrid) | Raises the BindingContextChanged event.
OnBorderStyleChanged (inherited from DataGrid) | Raises the BorderStyleChanged event.
OnCaptionVisibleChanged (inherited from DataGrid) | Raises the CaptionVisibleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlChanged (inherited from vdxDataGridNavigator) | Inform all registered components on ControlChanged about a control change.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCurrentCellChanged (inherited from DataGrid) | Raises the CurrentCellChanged event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from DataGrid) | Raises the DataSourceChanged event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from DataGrid) | Raises the Enter event.
OnFilled (inherited from vdxDataGridNavigator) | Raises the Filled event.
OnFlatModeChanged (inherited from DataGrid) | Raises the FlatModeChanged event.
OnFontChanged (inherited from DataGrid) | Raises the FontChanged event.
OnForeColorChanged (inherited from DataGrid) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from DataGrid) | Raises the CreateHandle event.
OnHandleDestroyed (inherited from DataGrid) | Raises the DestroyHandle event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from DataGrid) | Raises the KeyDown event.
OnKeyPress (inherited from DataGrid) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from DataGrid) | Raises the Layout event that repositions controls and updates scroll bars.
OnLeave (inherited from DataGrid) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from DataGrid) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from DataGrid) | Creates the MouseLeave event.
OnMouseMove (inherited from DataGrid) | Raises the MouseMove event.
OnMouseUp (inherited from DataGrid) | Raises the MouseUp event.
OnMouseWheel (inherited from DataGrid) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNavigate (inherited from DataGrid) | Raises the Navigate event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from DataGrid) | Raises the Paint event.
OnPaintBackground (inherited from DataGrid) | Overrides OnPaintBackground to prevent painting the background of the DataGrid control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentRowsLabelStyleChanged (inherited from DataGrid) | Raises the ParentRowsLabelStyleChanged event.
OnParentRowsVisibleChanged (inherited from DataGrid) | Raises the ParentRowsVisibleChanged event.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from DataGrid) | Raises the ReadOnlyChanged event
OnResize (inherited from DataGrid) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnRowHeaderClick (inherited from DataGrid) | Raises the RowHeaderClick event.
OnScroll (inherited from DataGrid) | Raises the Scroll event.
OnSelectionChanged (inherited from vdxDataGridNavigator) | Inform all registered components on SelectionChanged about a selection change.
OnShowParentDetailsButtonClicked (inherited from DataGrid) | Raises the ShowParentDetailsButtonClick event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from DataGrid) | Gets or sets a value that indicates whether a key should be processed further.
ProcessGridKey (inherited from DataGrid) | Processes keys for grid navigation.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from DataGrid) | Previews a keyboard message and returns a value indicating if the key was consumed.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
ProcessTabKey (inherited from DataGrid) | Gets a value indicating whether the Tab key should be processed.
ProviderToSet_OnDataTypeSet (inherited from vdxDataGrid) | Listens to the Event OnDataTypeSet that was set on DataSource and set the DataSource with the sender.
ProviderToSet_OnDataTypeSetDM (inherited from vdxDataGrid) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
Reactivate | Override this method for your specific cacheable control.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshData (inherited from vdxDataGridNavigator) | Remove all elements from the navigator and fill up the given dataSet.
RemoveRow (inherited from vdxDataGridNavigator) | Adds gridDataRow to data source table.
RemoveSelectedRow (inherited from vdxDataGridNavigator) | Removes current selected gridDataRow from data source table.
ResetMouseEventArgs (inherited from Control) |
ResetSelection (inherited from DataGrid) | Turns off selection for all rows that are selected.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SelectDefault (inherited from vdxDataGridNavigator) | Selects the default element.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShouldSerializeAlternatingBackColor (inherited from DataGrid) | Indicates whether the AlternatingBackColor property should be persisted.
ShouldSerializeBackgroundColor (inherited from DataGrid) | Indicates whether the BackgroundColor property should be persisted.
ShouldSerializeCaptionBackColor (inherited from DataGrid) | Gets a value indicating whether the CaptionBackColor property should be persisted.
ShouldSerializeCaptionForeColor (inherited from DataGrid) | Gets a value indicating whether the CaptionForeColor property should be persisted.
ShouldSerializeGridLineColor (inherited from DataGrid) | Indicates whether the GridLineColor property should be persisted.
ShouldSerializeHeaderBackColor (inherited from DataGrid) | Indicates whether the HeaderBackColor property should be persisted.
ShouldSerializeHeaderFont (inherited from DataGrid) | Indicates whether the HeaderFont property should be persisted.
ShouldSerializeHeaderForeColor (inherited from DataGrid) | Indicates whether the HeaderForeColor property should be persisted.
ShouldSerializeLinkHoverColor (inherited from DataGrid) | Indicates whether the LinkHoverColor property should be persisted.
ShouldSerializeParentRowsBackColor (inherited from DataGrid) | Indicates whether the ParentRowsBackColor property should be persisted.
ShouldSerializeParentRowsForeColor (inherited from DataGrid) | Indicates whether the ParentRowsForeColor property should be persisted.
ShouldSerializePreferredRowHeight (inherited from DataGrid) | Indicates whether the PreferredRowHeight property should be persisted.
ShouldSerializeSelectionBackColor (inherited from DataGrid) | Indicates whether the SelectionBackColor property should be persisted.
ShouldSerializeSelectionForeColor (inherited from DataGrid) | Indicates whether the SelectionForeColor property should be persisted.
Undo (inherited from vdxDataGridNavigator) | Undo changes for the corresponding navigatorDataRow.
Update (inherited from vdxDataGridNavigator) | Overloaded. Updates the corresponding navigator row with the given manipulator row.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Instance Events

RowHeaderClick (inherited from DataGrid) Occurs when a row header is clicked.

Protected Internal Instance Properties

ListManager (inherited from DataGrid) Gets the CurrencyManager for this DataGrid control.

Protected Internal Instance Methods

ColumnStartedEditing (inherited from DataGrid) | Overloaded. Informs the DataGrid control when the user begins to edit a column using the specified control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.

Explicit Interface Implementations

IvdxMultiContainerCacheable.Activate
IvdxMultiContainerCacheable.Create
IvdxMultiContainerCacheable.Deactivate
IvdxMultiContainerCacheable.DeactivateAllowed
IvdxMultiContainerCacheable.Reactivate
IvdxNavigator.ChangeSelection (inherited from vdxDataGridNavigator)
IvdxNavigator.Clear (inherited from vdxDataGridNavigator)
IvdxNavigator.Copy (inherited from vdxDataGridNavigator)
IvdxNavigator.Delete (inherited from vdxDataGridNavigator)
IvdxNavigator.Fill (inherited from vdxDataGridNavigator)
IvdxNavigator.GetLoaderInfo (inherited from vdxDataGridNavigator)
IvdxNavigator.Insert (inherited from vdxDataGridNavigator)
IvdxNavigator.IsRefreshable (inherited from vdxDataGridNavigator)
IvdxNavigator.RefreshData (inherited from vdxDataGridNavigator)
IvdxNavigator.SelectDefault (inherited from vdxDataGridNavigator)
IvdxNavigator.Undo (inherited from vdxDataGridNavigator)
IvdxNavigator.Update (inherited from vdxDataGridNavigator)

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid Constructor

Creates an instance of the class vdxSelectionGrid.

public vdxSelectionGrid();

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid Properties

The properties of the vdxSelectionGrid class are listed below. For a complete list of vdxSelectionGrid class members, see the vdxSelectionGrid Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowNavigation (inherited from vdxDataGridNavigator) | Gets or sets a value indicating whether navigation is allowed.
AllowSorting (inherited from DataGrid) | Gets or sets a value indicating whether the grid can be resorted by clicking on a column header.
AlternatingBackColor (inherited from DataGrid) | Gets or sets the background color of odd-numbered rows of the grid.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from DataGrid) | Gets or sets the background color of even-numbered rows of the grid.
BackgroundColor (inherited from DataGrid) | Gets or sets the color of the non-row area of the grid.
BackgroundImage (inherited from DataGrid) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BindingInfos (inherited from vdxDataGrid) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
BorderStyle (inherited from DataGrid) | Gets or sets the grid's border style.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CaptionBackColor (inherited from DataGrid) | Gets or sets the background color of the caption area.
CaptionFont (inherited from DataGrid) | Gets or sets the font of the grid's caption.
CaptionForeColor (inherited from DataGrid) | Gets or sets the foreground color of the caption area.
CaptionText (inherited from DataGrid) | Gets or sets the text of the grid's window caption.
CaptionVisible | Gets or sets a value indicating whether the grid's caption is visible.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColumnHeadersVisible (inherited from DataGrid) | Gets or sets a value indicating whether the column headers a table are visible.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrencyManager (inherited from vdxDataGrid) | Gets the managed CurrencyManager of this data grid.
CurrentCell (inherited from DataGrid) | Gets or sets which cell has the focus. Not available at design time.
CurrentDataRow (inherited from vdxDataGrid) | Gets or sets the dataRows which are selected.
CurrentRowIndex (inherited from DataGrid) | Gets or sets index of the selected row.
Cursor (inherited from DataGrid) |
DataBindingInfos (inherited from vdxDataGrid) | Gets the data binding infos for the control. This will be converted to DataBindings during Runtime.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataMember (inherited from vdxDataGrid) |
DataSource (inherited from vdxDataGrid) | Gets or sets the data source that this grid is displaying data for.
DataView (inherited from vdxDataGrid) | Gets the managed DataView of this data grid.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
ExplorerTree | Gets or sets the corresponding explorerTree.
FirstVisibleColumn (inherited from DataGrid) | Gets the index of the first visible column in a grid.
FlatMode (inherited from DataGrid) | Gets or sets a value indicating whether the grid displays in flat mode.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from DataGrid) | Gets or sets the foreground color (typically the color of the text) property of the DataGrid control.
GridLineColor (inherited from DataGrid) | Gets or sets the color of the grid lines.
GridLineStyle (inherited from DataGrid) | Gets or sets the line style of the grid.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HeaderBackColor (inherited from DataGrid) | Gets or sets the background color of all row and column headers.
HeaderFont (inherited from DataGrid) | Gets or sets the font used for column headers.
HeaderForeColor (inherited from DataGrid) | Gets or sets the foreground color of headers.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Item (inherited from DataGrid) | Gets or sets the value of the cell at the specified the row and column.
Item (inherited from DataGrid) | Gets or sets the value of a specified DataGridCell .
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LinkColor (inherited from DataGrid) | Gets or sets the color of the text that you can click to navigate to a child table.
LinkHoverColor (inherited from DataGrid) | Gets or sets the color a link changes to when the mouse pointer moves over it.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentRowsBackColor (inherited from DataGrid) | Gets or sets the background color of parent rows.
ParentRowsForeColor (inherited from DataGrid) | Gets or sets the foreground color of parent rows.
ParentRowsLabelStyle (inherited from DataGrid) | Gets or sets the way parent row labels are displayed.
ParentRowsVisible (inherited from DataGrid) | Gets or sets a value indicating whether the parent rows of a table are visible.
PreferredColumnWidth (inherited from DataGrid) | Gets or sets the default width of the grid columns in pixels.
PreferredRowHeight (inherited from DataGrid) | Gets or sets the preferred row height for the DataGrid control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly | Gets or sets a value indicating whether the grid is a read-only mode.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RowHeadersVisible (inherited from DataGrid) | Gets or sets a value that specifies whether row headers are visible.
RowHeaderWidth (inherited from DataGrid) | Gets or sets the width of row headers.
SelectedDataRows (inherited from vdxDataGrid) | Gets or sets the dataRows which are selected.
SelectionBackColor (inherited from DataGrid) | Gets or sets the background color of selected rows.
SelectionForeColor (inherited from DataGrid) | Gets or set the foreground color of selected rows.
Site (inherited from DataGrid) |
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TableStyles (inherited from DataGrid) | Gets the collection of DataGridTableStyle objects for the grid.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from DataGrid) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisibleColumnCount (inherited from DataGrid) | Gets the number of visible columns.
VisibleRowCount (inherited from DataGrid) | Gets the number of rows visible.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DataSet (inherited from vdxDataGrid) | Gets or sets DataSet on DataSource.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from DataGrid) | Gets the default size of the control.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HorizScrollBar (inherited from DataGrid) | Gets the horizontal scrollbar for the grid.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
SelectedDataRow (inherited from vdxDataGrid) | Gets the corresponding selected data row.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VertScrollBar (inherited from DataGrid) | Gets the vertical scroll bar of the control.

Protected Internal Instance Properties

ListManager (inherited from DataGrid) Gets the CurrencyManager for this DataGrid control.

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid.CaptionVisible Property

Gets or sets a value indicating whether the grid's caption is visible.

new public bool CaptionVisible {get; set;}

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid.ExplorerTree Property

Gets or sets the corresponding explorerTree.

public vdxExplorerTree ExplorerTree {get; set;}

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid.ReadOnly Property

Gets or sets a value indicating whether the grid is a read-only mode.

new public bool ReadOnly {get; set;}

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid Methods

The methods of the vdxSelectionGrid class are listed below. For a complete list of vdxSelectionGrid class members, see the vdxSelectionGrid Members topic.

Public Instance Methods

BeginEdit (inherited from DataGrid) | Attempts to put the grid into a state where editing is allowed.
BeginInit (inherited from DataGrid) | Begins the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Collapse (inherited from DataGrid) | Collapses child relations, if any exist for all rows, or for a specified row.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndEdit (inherited from DataGrid) | Requests an end to an edit operation taking place on the DataGrid control.
EndInit (inherited from DataGrid) | Ends the initialization of a DataGrid that is used on a form or used by another component. The initialization occurs at run time.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from DataGrid) | Displays child relations, if any exist, for all rows or a specific row.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindRows (inherited from vdxDataGrid) | Find rows by a SQL where clause.
FindText (inherited from vdxDataGrid) | Full text search for the passed Text. Every row is scanned for the Text. If the row contains the text, it is added to the resultion row collection.
Focus (inherited from Control) | Sets input focus to the control.
GetBindingInfo (inherited from vdxDataGrid) | Get the binding info for the Property specified.
GetCellBounds (inherited from DataGrid) | Overloaded. Gets the Rectangle of the cell specified by row and column number.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetCurrentCellBounds (inherited from DataGrid) | Gets a Rectangle that specifies the four corners of the selected cell.
GetDataRowAT (inherited from vdxDataGrid) | Gets the Datarow with the specified index
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetRowIndex (inherited from vdxDataGrid) | Returns the (momentary) index of a row in the grid. The returned index depends on the momentary sort order.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HitTest (inherited from DataGrid) | Overloaded. Gets information, such as row and column number of a clicked point on the grid, using the x and y coordinate passed to the method.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
IsExpanded (inherited from DataGrid) | Gets a value that indicates whether a specified row's node is expanded or collapsed.
IsSelected (inherited from DataGrid) | Gets a value indicating whether a specified row is selected.
MoveFirst (inherited from vdxDataGrid) | Moves to the first record in the grid
MoveLast (inherited from vdxDataGrid) | Move to the last record of the grid if possible
MoveNext (inherited from vdxDataGrid) | Moves to the next record in the grid. If we are already on the last record, moves to the first record.
MovePrevious (inherited from vdxDataGrid) | Moves to the previous record in the grid. If we are already on the first recorde, moves to the last record
NavigateBack (inherited from DataGrid) | Navigates back to the table previously displayed in the grid.
NavigateTo (inherited from DataGrid) | Navigates to the table specified by row and relation name.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetAlternatingBackColor (inherited from DataGrid) | Resets the AlternatingBackColor property to its default color.
ResetBackColor (inherited from DataGrid) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from DataGrid) | Resets the ForeColor property to its default value.
ResetGridLineColor (inherited from DataGrid) | Resets the GridLineColor property to its default value.
ResetHeaderBackColor (inherited from DataGrid) | Resets the HeaderBackColor property to its default value.
ResetHeaderFont (inherited from DataGrid) | Resets the HeaderFont property to its default value.
ResetHeaderForeColor (inherited from DataGrid) | Resets the HeaderForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetLinkColor (inherited from DataGrid) | Resets the LinkColor property to its default value.
ResetLinkHoverColor (inherited from DataGrid) |
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetSelectionBackColor (inherited from DataGrid) | Resets the SelectionBackColor property to its default value.
ResetSelectionForeColor (inherited from DataGrid) | Resets the SelectionForeColor property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from DataGrid) | Overloaded. Selects a specified row.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBindingInfo (inherited from vdxDataGrid) | Set the vdxBindingInfo for the property specified. If already a binding is defined for this property, the binding information is overridden. If null is passed as bInfo, th existing binding is removed.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDataBinding (inherited from DataGrid) | Sets the DataSource and DataMember properties at run time.
Show (inherited from Control) | Displays the control to the user.
SubObjectsSiteChange (inherited from DataGrid) |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
UnSelect (inherited from DataGrid) | Unselects a specified row.
Update (inherited from Control) | Overloaded. Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
Activate | Override this method for your specific cacheable control.
AddRow (inherited from vdxDataGridNavigator) | Adds gridDataRow to data source table.
AttatchCurrencyManagerEventHandlers (inherited from vdxDataGridNavigator) | Register CurrencyManager listeners.
CancelEditing (inherited from DataGrid) | Cancels the current edit operation and rolls back all changes.
ChangeSelection (inherited from vdxDataGridNavigator) | Changes current selection to the given row.
Clear (inherited from vdxDataGridNavigator) | Remove all rows from the grid.
Create | Override this method for your specific cacheable control.
CreateAccessibilityInstance (inherited from DataGrid) | Constructs a new instance of the accessibility object for this control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateGridColumn (inherited from DataGrid) | Overloaded. Creates a new DataGridColumnStyle with the specified PropertyDescriptor.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateNavigatorInfoItem (inherited from vdxDataGridNavigator) | Creates a vdxNavigatorInfoItem for the given dataRow.
CurrencyManager_PositionChanged | Overrides vdxDataGridNavigator CurrencyManager_PositionChanged.
Deactivate | Override this method for your specific cacheable control.
DeactivateAllowed | Override this method for your specific cacheable control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
Delete | Deletes the selected row.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from DataGrid) | Overloaded.
Fill (inherited from vdxDataGridNavigator) | Builds a dataGrid for the given DataSet;
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetDataRowKey (inherited from vdxDataGridNavigator) | Gets an unique key to differ TreeNodes on the same hierarchy level.
GetGridDataRow (inherited from vdxDataGridNavigator) | Gets the corresponding grid DataRow for the given navigator DataRow.
GetLoaderInfo | Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.
GetNavigatorInfo (inherited from vdxDataGridNavigator) | Gets the corresponding navigation info for the given item.
GetNavigatorInfoItemForGridRow (inherited from vdxDataGridNavigator) | Gets the corresponding navigator DataRow for the given grid DataRow.
GetOutputTextDelimiter (inherited from DataGrid) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GridHScrolled (inherited from DataGrid) | Listens for the horizontal scrollbar's scroll event.
GridVScrolled (inherited from DataGrid) | Listens for the vertical scrollbar's scroll event.
InitLayout (inherited from Control) | Called after the control has been added to another container.
Insert (inherited from vdxDataGridNavigator) | Inserts a new navigator row for the corresponding navigator row.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsRefreshable (inherited from vdxDataGridNavigator) | Checks if the component supports refresh.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAllowNavigationChanged (inherited from DataGrid) | Raises the AllowNavigationChanged event.
OnBackButtonClicked (inherited from DataGrid) | Listens for the caption's back button clicked event.
OnBackColorChanged (inherited from DataGrid) | Raises the BackColorChanged event.
OnBackgroundColorChanged (inherited from DataGrid) | Raises the BackgroundColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from DataGrid) | Raises the BindingContextChanged event.
OnBorderStyleChanged (inherited from DataGrid) | Raises the BorderStyleChanged event.
OnCaptionVisibleChanged (inherited from DataGrid) | Raises the CaptionVisibleChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlChanged (inherited from vdxDataGridNavigator) | Inform all registered components on ControlChanged about a control change.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCurrentCellChanged (inherited from DataGrid) | Raises the CurrentCellChanged event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from DataGrid) | Raises the DataSourceChanged event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from DataGrid) | Raises the Enter event.
OnFilled (inherited from vdxDataGridNavigator) | Raises the Filled event.
OnFlatModeChanged (inherited from DataGrid) | Raises the FlatModeChanged event.
OnFontChanged (inherited from DataGrid) | Raises the FontChanged event.
OnForeColorChanged (inherited from DataGrid) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from DataGrid) | Raises the CreateHandle event.
OnHandleDestroyed (inherited from DataGrid) | Raises the DestroyHandle event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from DataGrid) | Raises the KeyDown event.
OnKeyPress (inherited from DataGrid) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from DataGrid) | Raises the Layout event that repositions controls and updates scroll bars.
OnLeave (inherited from DataGrid) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from DataGrid) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from DataGrid) | Creates the MouseLeave event.
OnMouseMove (inherited from DataGrid) | Raises the MouseMove event.
OnMouseUp (inherited from DataGrid) | Raises the MouseUp event.
OnMouseWheel (inherited from DataGrid) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNavigate (inherited from DataGrid) | Raises the Navigate event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from DataGrid) | Raises the Paint event.
OnPaintBackground (inherited from DataGrid) | Overrides OnPaintBackground to prevent painting the background of the DataGrid control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentRowsLabelStyleChanged (inherited from DataGrid) | Raises the ParentRowsLabelStyleChanged event.
OnParentRowsVisibleChanged (inherited from DataGrid) | Raises the ParentRowsVisibleChanged event.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnReadOnlyChanged (inherited from DataGrid) | Raises the ReadOnlyChanged event
OnResize (inherited from DataGrid) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnRowHeaderClick (inherited from DataGrid) | Raises the RowHeaderClick event.
OnScroll (inherited from DataGrid) | Raises the Scroll event.
OnSelectionChanged (inherited from vdxDataGridNavigator) | Inform all registered components on SelectionChanged about a selection change.
OnShowParentDetailsButtonClicked (inherited from DataGrid) | Raises the ShowParentDetailsButtonClick event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from DataGrid) | Gets or sets a value that indicates whether a key should be processed further.
ProcessGridKey (inherited from DataGrid) | Processes keys for grid navigation.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from DataGrid) | Previews a keyboard message and returns a value indicating if the key was consumed.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
ProcessTabKey (inherited from DataGrid) | Gets a value indicating whether the Tab key should be processed.
ProviderToSet_OnDataTypeSet (inherited from vdxDataGrid) | Listens to the Event OnDataTypeSet that was set on DataSource and set the DataSource with the sender.
ProviderToSet_OnDataTypeSetDM (inherited from vdxDataGrid) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
Reactivate | Override this method for your specific cacheable control.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshData (inherited from vdxDataGridNavigator) | Remove all elements from the navigator and fill up the given dataSet.
RemoveRow (inherited from vdxDataGridNavigator) | Adds gridDataRow to data source table.
RemoveSelectedRow (inherited from vdxDataGridNavigator) | Removes current selected gridDataRow from data source table.
ResetMouseEventArgs (inherited from Control) |
ResetSelection (inherited from DataGrid) | Turns off selection for all rows that are selected.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SelectDefault (inherited from vdxDataGridNavigator) | Selects the default element.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShouldSerializeAlternatingBackColor (inherited from DataGrid) | Indicates whether the AlternatingBackColor property should be persisted.
ShouldSerializeBackgroundColor (inherited from DataGrid) | Indicates whether the BackgroundColor property should be persisted.
ShouldSerializeCaptionBackColor (inherited from DataGrid) | Gets a value indicating whether the CaptionBackColor property should be persisted.
ShouldSerializeCaptionForeColor (inherited from DataGrid) | Gets a value indicating whether the CaptionForeColor property should be persisted.
ShouldSerializeGridLineColor (inherited from DataGrid) | Indicates whether the GridLineColor property should be persisted.
ShouldSerializeHeaderBackColor (inherited from DataGrid) | Indicates whether the HeaderBackColor property should be persisted.
ShouldSerializeHeaderFont (inherited from DataGrid) | Indicates whether the HeaderFont property should be persisted.
ShouldSerializeHeaderForeColor (inherited from DataGrid) | Indicates whether the HeaderForeColor property should be persisted.
ShouldSerializeLinkHoverColor (inherited from DataGrid) | Indicates whether the LinkHoverColor property should be persisted.
ShouldSerializeParentRowsBackColor (inherited from DataGrid) | Indicates whether the ParentRowsBackColor property should be persisted.
ShouldSerializeParentRowsForeColor (inherited from DataGrid) | Indicates whether the ParentRowsForeColor property should be persisted.
ShouldSerializePreferredRowHeight (inherited from DataGrid) | Indicates whether the PreferredRowHeight property should be persisted.
ShouldSerializeSelectionBackColor (inherited from DataGrid) | Indicates whether the SelectionBackColor property should be persisted.
ShouldSerializeSelectionForeColor (inherited from DataGrid) | Indicates whether the SelectionForeColor property should be persisted.
Undo (inherited from vdxDataGridNavigator) | Undo changes for the corresponding navigatorDataRow.
Update (inherited from vdxDataGridNavigator) | Overloaded. Updates the corresponding navigator row with the given manipulator row.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ColumnStartedEditing (inherited from DataGrid) | Overloaded. Informs the DataGrid control when the user begins to edit a column using the specified control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.

Explicit Interface Implementations

IvdxMultiContainerCacheable.Activate
IvdxMultiContainerCacheable.Create
IvdxMultiContainerCacheable.Deactivate
IvdxMultiContainerCacheable.DeactivateAllowed
IvdxMultiContainerCacheable.Reactivate
IvdxNavigator.ChangeSelection (inherited from vdxDataGridNavigator)
IvdxNavigator.Clear (inherited from vdxDataGridNavigator)
IvdxNavigator.Copy (inherited from vdxDataGridNavigator)
IvdxNavigator.Delete (inherited from vdxDataGridNavigator)
IvdxNavigator.Fill (inherited from vdxDataGridNavigator)
IvdxNavigator.GetLoaderInfo (inherited from vdxDataGridNavigator)
IvdxNavigator.Insert (inherited from vdxDataGridNavigator)
IvdxNavigator.IsRefreshable (inherited from vdxDataGridNavigator)
IvdxNavigator.RefreshData (inherited from vdxDataGridNavigator)
IvdxNavigator.SelectDefault (inherited from vdxDataGridNavigator)
IvdxNavigator.Undo (inherited from vdxDataGridNavigator)
IvdxNavigator.Update (inherited from vdxDataGridNavigator)

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid.Activate Method

Override this method for your specific cacheable control.

protected virtual void Activate();

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace | IvdxMultiContainerCacheable

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid.Create Method

Override this method for your specific cacheable control.

protected virtual void Create();

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace | IvdxMultiContainerCacheable

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid.CurrencyManager_PositionChanged Method

Overrides vdxDataGridNavigator CurrencyManager_PositionChanged.

protected override void CurrencyManager_PositionChanged(
object sender,
EventArgs e
);

Parameters

sender
e

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid.Deactivate Method

Override this method for your specific cacheable control.

protected virtual void Deactivate();

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace | IvdxMultiContainerCacheable

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid.DeactivateAllowed Method

Override this method for your specific cacheable control.

protected virtual bool DeactivateAllowed();

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace | IvdxMultiContainerCacheable

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid.IvdxMultiContainerCacheable.Activate Method

void IvdxMultiContainerCacheable.Activate();

Implements

IvdxMultiContainerCacheable.Activate

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid.IvdxMultiContainerCacheable.Create Method

void IvdxMultiContainerCacheable.Create();

Implements

IvdxMultiContainerCacheable.Create

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid.IvdxMultiContainerCacheable.Deactivate Method

void IvdxMultiContainerCacheable.Deactivate();

Implements

IvdxMultiContainerCacheable.Deactivate

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid.IvdxMultiContainerCacheable.DeactivateAllowed Method

bool IvdxMultiContainerCacheable.DeactivateAllowed();

Implements

IvdxMultiContainerCacheable.DeactivateAllowed

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid.IvdxMultiContainerCacheable.Reactivate Method

void IvdxMultiContainerCacheable.Reactivate();

Implements

IvdxMultiContainerCacheable.Reactivate

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid.Delete Method

Deletes the selected row.

protected override void Delete(
vdxNavigatorInfo navInfo
);

Parameters

navInfo
The last selected navigator row.

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid.GetLoaderInfo Method

Generates the corresponding vdxLoaderInfo for the given vdxNavigatorInfo.

protected override vdxLoaderInfo GetLoaderInfo(
vdxNavigatorInfo navigatorInfo
);

Parameters

navigatorInfo
Contains the DataRow to define the vdxLoaderInfo.

Return Value

The vdxLoaderInfo for the given navigatorInfo.

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


vdxSelectionGrid.Reactivate Method

Override this method for your specific cacheable control.

protected virtual void Reactivate();

See Also

vdxSelectionGrid Class | Deag.Vdx.Controls.Standard Namespace | IvdxMultiContainerCacheable

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Server.DAL

VDX Framework

Deag.Vdx.Server.DAL Namespace

The Deag.Vdx.Server.DAL namespace contains generic classes for accessing data from a storage. The main classes are the following:

  • DataAccess
  • Parameter
  • Transaction
  • Viewer

Classes

Class | Description
ConnectionInfo | The ConnectionInfo class stores information about the connection in a storage independent manner.
DataAccess | Base class for all storage dependent access classes.
DataAccessCollection | A collection of DataAccess.
Parameter | A Parameter is a storage independent construct that associats a name to a Filter.
ParameterCollection | A Collection of Parameter.
Transaction | A storage independent transaction.
Transaction.Setting | Isolation level settings of a Transaction.
Viewer | A Viewer is a container for views. A view is used to read a specific 'view' of the data from the storage.
Viewer.View | A view is used togehter with a Viewer for reading data from the storage into a DataSet. .

Interfaces

Interface | Description
Viewer.IView | Interface defining a view.

Delegates

Delegate | Description
ConnectionInfo.CreateConnectionStringCallback | Delegate for the storage dependent GetConnectionString method.
ConnectionInfo.IsConnectionAvailableCallback | Delegate for the storage dependent method that checks whether the connection is available.
Transaction.CommitCallback | Delegate for the storage dependent Commit method.
Transaction.RollbackCallback | Delegate for the storage dependent Rollback method.

Enumerations

Enumeration | Description
Operation | Defines the type of an operation.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConnectionInfo Class

The ConnectionInfo class stores information about the connection in a storage independent manner.

For a list of all members of this type, see ConnectionInfo Members.

System.Object
ConnectionInfo

public class ConnectionInfo

Remarks

The ConnectionInfo object gets the storage dependent information by calling external methods that will be assign to it by a DataAccess object at runtime.

Requirements

Namespace: Deag.Vdx.Server.DAL

Assembly: vdxServer (in vdxServer.dll)

See Also

ConnectionInfo Members | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConnectionInfo Members

ConnectionInfo overview

Public Instance Constructors

ConnectionInfo Constructor Initializes a new instance of the ConnectionInfo class.

Public Instance Fields

ApplicationName | The application wich is connecting
DBName | The name of the storage.
DBServer | The name of the server that holds the storage.
Pooling | Whether connection pooling is used.
Pwd | The password to log on.
Trusted | Whether it is a trusted connection.
User | The user identification.

Public Instance Methods

Copy | Creates an equivalent copy of the ConnectionInfo.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetConnectionString | Returns the connection string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsAvailable | Returns whether the connection is available.
SetConnectionString | Sets the connection string that can be used for DataAccess.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConnectionInfo Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConnectionInfo Constructor

Initializes a new instance of the ConnectionInfo class.

public ConnectionInfo();

See Also

ConnectionInfo Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConnectionInfo Fields

The fields of the ConnectionInfo class are listed below. For a complete list of ConnectionInfo class members, see the ConnectionInfo Members topic.

Public Instance Fields

ApplicationName | The application wich is connecting
DBName | The name of the storage.
DBServer | The name of the server that holds the storage.
Pooling | Whether connection pooling is used.
Pwd | The password to log on.
Trusted | Whether it is a trusted connection.
User | The user identification.

See Also

ConnectionInfo Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConnectionInfo.ApplicationName Field

The application wich is connecting

public string ApplicationName;

See Also

ConnectionInfo Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConnectionInfo.DBName Field

The name of the storage.

public string DBName;

See Also

ConnectionInfo Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConnectionInfo.DBServer Field

The name of the server that holds the storage.

public string DBServer;

See Also

ConnectionInfo Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConnectionInfo.Pooling Field

Whether connection pooling is used.

public bool Pooling;

See Also

ConnectionInfo Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConnectionInfo.Pwd Field

The password to log on.

public string Pwd;

See Also

ConnectionInfo Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConnectionInfo.Trusted Field

Whether it is a trusted connection.

public bool Trusted;

See Also

ConnectionInfo Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConnectionInfo.User Field

The user identification.

public string User;

See Also

ConnectionInfo Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConnectionInfo Methods

The methods of the ConnectionInfo class are listed below. For a complete list of ConnectionInfo class members, see the ConnectionInfo Members topic.

Public Instance Methods

Copy | Creates an equivalent copy of the ConnectionInfo.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetConnectionString | Returns the connection string.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsAvailable | Returns whether the connection is available.
SetConnectionString | Sets the connection string that can be used for DataAccess.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConnectionInfo Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConnectionInfo.Copy Method

Creates an equivalent copy of the ConnectionInfo.

public ConnectionInfo Copy();

Return Value

A new, identical copy of the ConnectionInfo

See Also

ConnectionInfo Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConnectionInfo.GetConnectionString Method

Returns the connection string.

public string GetConnectionString();

Return Value

Connectionstring

Remarks

If the connection string is requested for the first time then the ConnectionStringDelegate is used call the method that creates the connection string. Afterwards the connection string is chached. Subsequent requests will return the cached connection string.

See Also

ConnectionInfo Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConnectionInfo.IsAvailable Method

Returns whether the connection is available.

public bool IsAvailable();

Return Value

Whether the connection is available.

See Also

ConnectionInfo Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConnectionInfo.SetConnectionString Method

Sets the connection string that can be used for DataAccess.

public void SetConnectionString(
string con
);

Parameters

con
Connectionstring

See Also

ConnectionInfo Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConnectionInfo.CreateConnectionStringCallback Delegate

Delegate for the storage dependent GetConnectionString method.

public delegate string ConnectionInfo.CreateConnectionStringCallback(
ConnectionInfo info
);

Requirements

Namespace: Deag.Vdx.Server.DAL

Assembly: vdxServer (in vdxServer.dll)

See Also

Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ConnectionInfo.IsConnectionAvailableCallback Delegate

Delegate for the storage dependent method that checks whether the connection is available.

public delegate bool ConnectionInfo.IsConnectionAvailableCallback(
ConnectionInfo info
);

Requirements

Namespace: Deag.Vdx.Server.DAL

Assembly: vdxServer (in vdxServer.dll)

See Also

Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess Class

Base class for all storage dependent access classes.

For a list of all members of this type, see DataAccess Members.

System.Object
DataAccess

public abstract class DataAccess

Remarks

The derived classes implement the storage dependent implementations for reading, writing, deleting.

If a Table is specified, the read data (data returned by the execution of the Read method) is stored in this table.

The DataAccess object contains a collection of storage independent Parameters. An EntityObject, EntityList or Viewer talks to the DataAccess object via storage independent Parameters. The DataAccess converts these parameters to storage dependent parameters by assign time.

Requirements

Namespace: Deag.Vdx.Server.DAL

Assembly: vdxServer (in vdxServer.dll)

See Also

DataAccess Members | Deag.Vdx.Server.DAL Namespace | Transaction | ConnectionInfo | ParameterCollection

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess Members

DataAccess overview

Public Instance Constructors

DataAccess Overloaded. Initializes a new instance of the DataAccess class.

Public Instance Properties

CanDelete | Derived classes return a value indicating whether this DataAccess can delete.
CanInsert | Derived classes return a value indicating whether this DataAccess can insert.
CanRead | Derived classes return a value indicating whether this DataAccess can read.
CanUpdate | Derived classes return a value indicating whether this DataAccess can update.
ConnectionInfo | Gets/sets the ConnectionInfo that is used to create the connection string.
DeletingEnabled | Gets/sets a value that indicates whether the DataAccess object should take part in an deleting operation. Default value = true
HasMissingSchemaAction | Gets/sets a value indicating whether a MissingSchemaAction is set.
HasTableName | Gets a value that indicates whether there is a TableName set.
InsertingEnabled | Gets/sets a value that indicates whether the DataAccess object should take part in an inserting operation. Default value = true
Key | Gets/sets the key that identifies this DataAccess object.
MissingSchemaAction | Determines the action to take when Cache DataSet schema does not match data read by the DataAccess object. Default is Error.
Parameters | Gets the collection of parameters containging storage dependent Filter
ReadingEnabled | Gets/sets a value that indicates whether the DataAccess object should take part in a reading operation. Default value = true
SortingEnabled | Gets/sets a value that indicates whether the DataAccess object should take part in the sorting process. Default value = true
Table | Gets/sets the DataTable that is filled with the data this DataAccess object returns.
TableName | Gets/sets the name of the DataTable the data (provided by this DataAccess object) is merged in.
Transaction | Gets/sets the transaction for the following operations.
UpdatingEnabled | Gets/sets a value that indicates whether the DataAccess object should take part in an updating operation. Default value = true

Public Instance Methods

AddParameter | Overloaded. Adds a parameter to the collection of parameters.
AddParameters | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters | Clears the collection of parameters.
DataDrivenUpdate | Derived classes override this method to perform operations depending on the data in the Table.
Delete | Derived classes override this method to perform a delete operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Derived classes override this method to perform an insert operation.
IsOperationEnabled | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation | Executes the specified Operation.
Read | Derived classes override this method to perform a read operation.
ReadCount | Derived classes override this method to perform a count operation.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update | Derived classes override this method to perform an update operation.

Protected Instance Methods

CreateStorageDependentFilter | Derived classes convert the specified Filter (can be storage dependent or independent) to a according storage dependent filter.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback | Returns the delegate for the storage dependent method that performs a commit.
GetRollbackCallback | Returns the delegate for the storage dependent method that performs a rollback.
GetStorageDependentParameterPrefix | Derived classes return the storage dependent prefix for parameters.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection | Derived classes refresh the connection within this method.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | Transaction | ConnectionInfo | ParameterCollection

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess Constructor

Creates an DataAccess object without a Key.

Overload List

Creates an DataAccess object without a Key.

public DataAccess();

Creates a DataAccess object with a MissingSchemaAction.

public DataAccess(MissingSchemaAction);

Creates a DataAccess object with a Key.

public DataAccess(string);

Creates a DataAccess object with a Key and MissingSchemaAction.

public DataAccess(string,MissingSchemaAction);

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess Constructor ()

Creates an DataAccess object without a Key.

public DataAccess();

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | DataAccess Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess Constructor (String)

Creates a DataAccess object with a Key.

public DataAccess(
string key
);

Parameters

key
A key identifing this DataAccess object.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | DataAccess Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess Constructor (MissingSchemaAction)

Creates a DataAccess object with a MissingSchemaAction.

public DataAccess(
MissingSchemaAction missingSchemaAction
);

Parameters

missingSchemaAction
The missing schema action to be used for this data access.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | DataAccess Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess Constructor (String, MissingSchemaAction)

Creates a DataAccess object with a Key and MissingSchemaAction.

public DataAccess(
string key,
MissingSchemaAction missingSchemaAction
);

Parameters

key
A key identifing this DataAccess object.
missingSchemaAction
The missing schema action to be used for this data access.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | DataAccess Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess Properties

The properties of the DataAccess class are listed below. For a complete list of DataAccess class members, see the DataAccess Members topic.

Public Instance Properties

CanDelete | Derived classes return a value indicating whether this DataAccess can delete.
CanInsert | Derived classes return a value indicating whether this DataAccess can insert.
CanRead | Derived classes return a value indicating whether this DataAccess can read.
CanUpdate | Derived classes return a value indicating whether this DataAccess can update.
ConnectionInfo | Gets/sets the ConnectionInfo that is used to create the connection string.
DeletingEnabled | Gets/sets a value that indicates whether the DataAccess object should take part in an deleting operation. Default value = true
HasMissingSchemaAction | Gets/sets a value indicating whether a MissingSchemaAction is set.
HasTableName | Gets a value that indicates whether there is a TableName set.
InsertingEnabled | Gets/sets a value that indicates whether the DataAccess object should take part in an inserting operation. Default value = true
Key | Gets/sets the key that identifies this DataAccess object.
MissingSchemaAction | Determines the action to take when Cache DataSet schema does not match data read by the DataAccess object. Default is Error.
Parameters | Gets the collection of parameters containging storage dependent Filter
ReadingEnabled | Gets/sets a value that indicates whether the DataAccess object should take part in a reading operation. Default value = true
SortingEnabled | Gets/sets a value that indicates whether the DataAccess object should take part in the sorting process. Default value = true
Table | Gets/sets the DataTable that is filled with the data this DataAccess object returns.
TableName | Gets/sets the name of the DataTable the data (provided by this DataAccess object) is merged in.
Transaction | Gets/sets the transaction for the following operations.
UpdatingEnabled | Gets/sets a value that indicates whether the DataAccess object should take part in an updating operation. Default value = true

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | Transaction | ConnectionInfo | ParameterCollection

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.CanDelete Property

Derived classes return a value indicating whether this DataAccess can delete.

public virtual bool CanDelete {get;}

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.CanInsert Property

Derived classes return a value indicating whether this DataAccess can insert.

public virtual bool CanInsert {get;}

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.CanRead Property

Derived classes return a value indicating whether this DataAccess can read.

public virtual bool CanRead {get;}

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.CanUpdate Property

Derived classes return a value indicating whether this DataAccess can update.

public virtual bool CanUpdate {get;}

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.ConnectionInfo Property

Gets/sets the ConnectionInfo that is used to create the connection string.

public ConnectionInfo ConnectionInfo {get; set;}

Remarks

When a ConnectionInfo is set then the storage dependent ConnectionStringDelegate and IsAvailableDelegate are assigned to it.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.DeletingEnabled Property

Gets/sets a value that indicates whether the DataAccess object should take part in an deleting operation. Default value = true

public bool DeletingEnabled {get; set;}

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.HasMissingSchemaAction Property

Gets/sets a value indicating whether a MissingSchemaAction is set.

public bool HasMissingSchemaAction {get;}

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.HasTableName Property

Gets a value that indicates whether there is a TableName set.

public bool HasTableName {get;}

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.InsertingEnabled Property

Gets/sets a value that indicates whether the DataAccess object should take part in an inserting operation. Default value = true

public bool InsertingEnabled {get; set;}

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.Key Property

Gets/sets the key that identifies this DataAccess object.

public string Key {get; set;}

Remarks

The key can be used to tell apart multiple DataAccess object. For example in RefreshDataAccessObject.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.MissingSchemaAction Property

Determines the action to take when Cache DataSet schema does not match data read by the DataAccess object. Default is Error.

public System.Data.MissingSchemaAction MissingSchemaAction {get; set;}

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.Parameters Property

Gets the collection of parameters containging storage dependent Filter

public ParameterCollection Parameters {get;}

Remarks

The parameters of a DataAccess object contains always storage dependent Filters. Whenever a Parameter is added to the DataAccess object. The contained Filter is converted to the correct storage dependent instance.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.ReadingEnabled Property

Gets/sets a value that indicates whether the DataAccess object should take part in a reading operation. Default value = true

public bool ReadingEnabled {get; set;}

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.SortingEnabled Property

Gets/sets a value that indicates whether the DataAccess object should take part in the sorting process. Default value = true

public bool SortingEnabled {get; set;}

Remarks

If sorting is enabled then the framework tries to sort all DataAccess objects in a wy that there occure no constraint violations.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | EntityBase.DataAccessSortType

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.Table Property

Gets/sets the DataTable that is filled with the data this DataAccess object returns.

public System.Data.DataTable Table {get; set;}

Remarks

Internally, the framework always uses this property to set the DataTable that should be filled by the DataAccess object. Therefore specifying the table directly is better than specifying the TableName .

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | TableName

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.TableName Property

Gets/sets the name of the DataTable the data (provided by this DataAccess object) is merged in.

public string TableName {get; set;}

Remarks

If possible, you should specify the DataTable directly by Table.

Internally, the framework resolves the table by searching the cache DataSet of the EntityObject, EntityList or Viewer.IView for a table with the corresponding name.

If there is specified a Table as well as a TableName, the TableName will be used. That means, you can overdrive the behaviour by setting the TableName.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | Table

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.Transaction Property

Gets/sets the transaction for the following operations.

public Transaction Transaction {get; set;}

Remarks

When a transaction is set, the storage dependent commit and rollback methods are assigned to the transaction. The ConnectionInfo of the transaction is assigned to this DataAccess object.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | GetCommitCallback | GetRollbackCallback | CommitDelegate | RollbackDelegate | ConnectionInfo

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.UpdatingEnabled Property

Gets/sets a value that indicates whether the DataAccess object should take part in an updating operation. Default value = true

public bool UpdatingEnabled {get; set;}

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess Methods

The methods of the DataAccess class are listed below. For a complete list of DataAccess class members, see the DataAccess Members topic.

Public Instance Methods

AddParameter | Overloaded. Adds a parameter to the collection of parameters.
AddParameters | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters | Clears the collection of parameters.
DataDrivenUpdate | Derived classes override this method to perform operations depending on the data in the Table.
Delete | Derived classes override this method to perform a delete operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Derived classes override this method to perform an insert operation.
IsOperationEnabled | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation | Executes the specified Operation.
Read | Derived classes override this method to perform a read operation.
ReadCount | Derived classes override this method to perform a count operation.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update | Derived classes override this method to perform an update operation.

Protected Instance Methods

CreateStorageDependentFilter | Derived classes convert the specified Filter (can be storage dependent or independent) to a according storage dependent filter.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback | Returns the delegate for the storage dependent method that performs a commit.
GetRollbackCallback | Returns the delegate for the storage dependent method that performs a rollback.
GetStorageDependentParameterPrefix | Derived classes return the storage dependent prefix for parameters.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection | Derived classes refresh the connection within this method.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | Transaction | ConnectionInfo | ParameterCollection

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AddParameter Method

VDX Framework

DataAccess.AddParameter Method

Adds a parameter to the collection of parameters.

Overload List

Adds a parameter to the collection of parameters.

public void AddParameter(Parameter);

Adds a parameter to the collection of parameters.

public void AddParameter(Parameter,bool);

Adds a parameter to the collection of parameters.

public void AddParameter(string,Filter);

Adds a parameter to the collection of parameters.

public void AddParameter(string,Filter,bool);

Adds a parameter to the collection of parameters.

public void AddParameter(string,object);

Adds a parameter to the collection of parameters.

public void AddParameter(string,object,bool);

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | Filter | Parameter

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.AddParameter Method (Parameter)

Adds a parameter to the collection of parameters.

public void AddParameter(
Parameter param
);

Parameters

param
This parameter will be added.

Remarks

When a parameter is added to the collection of parameters of a DataAccess object, the contained filter is converted to be storage dependent. Actually this is an upcast.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | DataAccess.AddParameter Overload List | Filter | Parameter

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.AddParameter Method (Parameter, Boolean)

Adds a parameter to the collection of parameters.

public void AddParameter(
Parameter param,
bool throwOnError
);

Parameters

param
This parameter will be added.
throwOnError
Whether an exception should be throw if a parameter with the same name does already exist in the collection of parameters.

Remarks

When a parameter is added to the collection of parameters of a DataAccess object, the contained filter is converted to be storage dependent. Actually this is an upcast.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | DataAccess.AddParameter Overload List | Filter | Parameter

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.AddParameter Method (String, Filter)

Adds a parameter to the collection of parameters.

public void AddParameter(
string name,
Filter value
);

Parameters

name
The name of the parameter.
value
The Filter that the added parameter will contain.

Remarks

A new parameter is created and added to the collection. When a parameter is added to the collection of parameters of a DataAccess object, the contained filter is converted to be storage dependent. Actually this is an upcast.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | DataAccess.AddParameter Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.AddParameter Method (String, Filter, Boolean)

Adds a parameter to the collection of parameters.

public void AddParameter(
string name,
Filter value,
bool throwOnError
);

Parameters

name
The name of the parameter.
value
The Filter that the added parameter will contain.
throwOnError
Whether there should be thrown an exception if there exists already a parameter with the same name. If set to false the newly added parameter overwrites the old one.

Remarks

A new parameter is created and added to the collection. When a parameter is added to the collection of parameters of a DataAccess object, the contained filter is converted to be storage dependent. Actually this is an upcast.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | DataAccess.AddParameter Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.AddParameter Method (String, Object)

Adds a parameter to the collection of parameters.

public void AddParameter(
string name,
object value
);

Parameters

name
The name of the parameter.
value
The value of the parameter

Remarks

The framework will generate automatically a parameter containing a FilterEQUAL. When a parameter is added to the collection of parameters of a DataAccess object, the contained filter is converted to be storage dependent. Actually this is an upcast.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | DataAccess.AddParameter Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.AddParameter Method (String, Object, Boolean)

Adds a parameter to the collection of parameters.

public void AddParameter(
string name,
object value,
bool throwOnError
);

Parameters

name
The name of the parameter.
value
The value of the parameter.
throwOnError
Whether there should be thrown an exception if there exists already a parameter with the same name. If set to false the newly added parameter overwrites the old one.

Remarks

The framework will generate automatically a parameter containing a FilterEQUAL.

When a parameter is added to the collection of parameters of a DataAccess object, the contained filter is converted to be storage dependent. Actually this is an upcast.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | DataAccess.AddParameter Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AddParameters Method

VDX Framework

DataAccess.AddParameters Method

Adds the specified Parameters to the data access's collection of parameters.

Overload List

Adds the specified Parameters to the data access's collection of parameters.

public void AddParameters(ParameterCollection);

Adds the specified Parameters to the data access's collection of parameters.

public void AddParameters(ParameterCollection,bool);

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | Filter | Parameter

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.AddParameters Method (ParameterCollection)

Adds the specified Parameters to the data access's collection of parameters.

public void AddParameters(
ParameterCollection parameters
);

Parameters

parameters
The colelction of parameters to add.

Remarks

When a parameter is added to the collection of parameters of a DataAccess object, the contained filter is converted to be storage dependent. Actually this is an upcast.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | DataAccess.AddParameters Overload List | Filter | Parameter

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.AddParameters Method (ParameterCollection, Boolean)

Adds the specified Parameters to the data access's collection of parameters.

public void AddParameters(
ParameterCollection parameters,
bool throwOnError
);

Parameters

parameters
The colelction of parameters to add.
throwOnError
Whether an exception should be throw if a parameter with the same name does already exist in the collection of parameters.

Remarks

When a parameter is added to the collection of parameters of a DataAccess object, the contained filter is converted to be storage dependent. Actually this is an upcast.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | DataAccess.AddParameters Overload List | Filter | Parameter

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.ClearParameters Method

Clears the collection of parameters.

public void ClearParameters();

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.CreateStorageDependentFilter Method

Derived classes convert the specified Filter (can be storage dependent or independent) to a according storage dependent filter.

protected virtual Filter CreateStorageDependentFilter(
Filter filter
);

Parameters

filter
Storage dependent or independent filter.

Return Value

Storage dependent filter.

Remarks

When a filter that is already of the right type for the specific storage, it will be returned unchanged.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.DataDrivenUpdate Method

Derived classes override this method to perform operations depending on the data in the Table.

public virtual void DataDrivenUpdate();

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.Delete Method

Derived classes override this method to perform a delete operation.

public virtual void Delete();

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.GetCommitCallback Method

Returns the delegate for the storage dependent method that performs a commit.

protected virtual CommitCallback GetCommitCallback();

Return Value

Method that performs a commit

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.GetParameter Method

Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.

public Parameter GetParameter(
string name
);

Parameters

name
The name of the requested parameter.

Return Value

The requested parameter or null.

Remarks

Parameters are requested in the case of return values. An operation of the DataAccess object can also return values in the Filters (additionally to or instead of results in a DataTable). After the execution of such an operation, you can request the affected parameter and read the result value from its Filter.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.GetRollbackCallback Method

Returns the delegate for the storage dependent method that performs a rollback.

protected virtual RollbackCallback GetRollbackCallback();

Return Value

Method that performs a rollback

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.GetStorageDependentParameterPrefix Method

Derived classes return the storage dependent prefix for parameters.

protected virtual string GetStorageDependentParameterPrefix();

Return Value

prefix for parameters

Remarks

This method can be overriden if the parameters used to communicate with the specific storage have a common prefix.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.Insert Method

Derived classes override this method to perform an insert operation.

public virtual void Insert();

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.IsOperationEnabled Method

Returns a value indicating whether the specified Operation is enabled.

public bool IsOperationEnabled(
Operation op
);

Parameters

op
The Operation that is requested.

Return Value

Whether the operation is enabled.

Remarks

Data access objects can be enabled/disabled for certain operations. For example if you want to use two different data access objects to read data. And depending of a state you decide wich one will be used, then you can enable/disable them accordingly.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.IsOperationSupported Method

Returns a value indicating whether the specified Operation can be performed by this DataAccess.

public bool IsOperationSupported(
Operation op
);

Parameters

op
The Operation that is requested.

Return Value

Whether the operation is supported.

Remarks

A DataDrivenUpdate is always supported.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace | CanRead | CanInsert | CanUpdate | CanDelete

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.PerformOperation Method

Executes the specified Operation.

public void PerformOperation(
Operation op
);

Parameters

op
The operation to be executed.

Remarks

The specified operation is performed by executing either the Read, Insert, Update, Delete or DataDrivenUpdate method.

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.Read Method

Derived classes override this method to perform a read operation.

public virtual void Read();

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.ReadCount Method

Derived classes override this method to perform a count operation.

public virtual int ReadCount();

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.RefreshConnection Method

Derived classes refresh the connection within this method.

protected virtual void RefreshConnection();

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccess.Update Method

Derived classes override this method to perform an update operation.

public virtual void Update();

See Also

DataAccess Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccessCollection Class

A collection of DataAccess.

For a list of all members of this type, see DataAccessCollection Members.

System.Object
CollectionBase
DataAccessCollection

public class DataAccessCollection : CollectionBase

Requirements

Namespace: Deag.Vdx.Server.DAL

Assembly: vdxServer (in vdxServer.dll)

See Also

DataAccessCollection Members | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccessCollection Members

DataAccessCollection overview

Public Instance Constructors

DataAccessCollection Overloaded. Initializes a new instance of the DataAccessCollection class.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Overloaded. Returns the DataAccess at the specified index .

Public Instance Methods

Add | Adds a DataAccess object to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Removes the specified DataAccess object from the list.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

DataAccessCollection Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccessCollection Constructor

Creates an collection of DataAccess

Overload List

Creates an collection of DataAccess

public DataAccessCollection();

Creates an collection of DataAccess from the specified array.

public DataAccessCollection(DataAccess[]);

See Also

DataAccessCollection Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccessCollection Constructor ()

Creates an collection of DataAccess

public DataAccessCollection();

See Also

DataAccessCollection Class | Deag.Vdx.Server.DAL Namespace | DataAccessCollection Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccessCollection Constructor (DataAccess[])

Creates an collection of DataAccess from the specified array.

public DataAccessCollection(
DataAccess[] array
);

Parameters

array
Array of DataAccess for initialization.

See Also

DataAccessCollection Class | Deag.Vdx.Server.DAL Namespace | DataAccessCollection Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccessCollection Properties

The properties of the DataAccessCollection class are listed below. For a complete list of DataAccessCollection class members, see the DataAccessCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Overloaded. Returns the DataAccess at the specified index .

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

DataAccessCollection Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Item Property

VDX Framework

DataAccessCollection.Item Property

Returns the DataAccess at the specified index .

Overload List

Returns the DataAccess at the specified index .

public DataAccess this[int] {get; set;}

Returns the DataAccess with the specified key.

public DataAccess this[string] {get;}

See Also

DataAccessCollection Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccessCollection.Item Property

Returns the DataAccess at the specified index .

public DataAccess this[
int index
] {get; set;}

See Also

DataAccessCollection Class | Deag.Vdx.Server.DAL Namespace | DataAccessCollection.Item Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccessCollection.Item Property

Returns the DataAccess with the specified key.

public DataAccess this[
string key
] {get;}

Exceptions

Exception Type | Condition
Exception | If no DataAccess with the specified key can be found then an exception will be fired.

See Also

DataAccessCollection Class | Deag.Vdx.Server.DAL Namespace | DataAccessCollection.Item Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccessCollection Methods

The methods of the DataAccessCollection class are listed below. For a complete list of DataAccessCollection class members, see the DataAccessCollection Members topic.

Public Instance Methods

Add | Adds a DataAccess object to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Removes the specified DataAccess object from the list.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

DataAccessCollection Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccessCollection.Add Method

Adds a DataAccess object to the collection.

public void Add(
DataAccess accessObject
);

Parameters

accessObject

See Also

DataAccessCollection Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataAccessCollection.Remove Method

Removes the specified DataAccess object from the list.

public void Remove(
DataAccess accessObject
);

Parameters

accessObject

See Also

DataAccessCollection Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Operation Enumeration

Defines the type of an operation.

public enum Operation

Remarks

The DataDrivenUpdate operation is not exactly an operation for itself. Instead it is used in the execution cascade when an data driven update is performed that leads to either a read, insert, update or delete operation. When an data driven update is executed then the current operation is DataDrivenUpdate as long as it is not clear which operation (read, insert, update, delete) will be perform to accomplish the data driven update.

Members

Member Name | Description
Read | Defines a read operation.
Insert | Defines an insert operation.
Update | Defines an update (modification) operation.
Delete | Defines a delete operation.
DataDrivenUpdate | The data defines the operation.

Requirements

Namespace: Deag.Vdx.Server.DAL

Assembly: vdxServer (in vdxServer.dll)

See Also

Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Parameter Class

A Parameter is a storage independent construct that associats a name to a Filter.

For a list of all members of this type, see Parameter Members.

System.Object
Parameter

public class Parameter

Remarks

Parameters are used by classes derived from EntityBase to communicate with their associated DataAccess objects. The parameter is used for mapping to the storage-dependent parameter (e.g. a SQL-parameter).

Each Parameter can contain one Filter. This filter contains the value that will be placed for the parameter in the query and the way it will be used. This is defined by the type of the filter. E.g. an equal filter is used for searching an exact match and a between filter is used to perform a range query. Filter for more information.

Requirements

Namespace: Deag.Vdx.Server.DAL

Assembly: vdxServer (in vdxServer.dll)

See Also

Parameter Members | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Parameter Members

Parameter overview

Public Instance Constructors

Parameter Overloaded. Initializes a new instance of the Parameter class.

Public Instance Properties

Filter | Gets/sets the Filter of the Parameter.
Name | Gets/sets the name of the Parameter.
Prefix | Gets/sets the prefix of the Parameter that is used in the communication with the storage.
Value | Gets/sets the value of the contained Filter if it has a one.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Parameter Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Parameter Constructor

Creates an instance of a Parameter.

Overload List

Creates an instance of a Parameter.

public Parameter();

Creates a named instance of a Parameter.

public Parameter(string);

Creates a named Parameter and sets its Filter.

public Parameter(string,Filter);

Creates a named Parameter with an FilterEQUAL containing the specified value.

public Parameter(string,object);

See Also

Parameter Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Parameter Constructor ()

Creates an instance of a Parameter.

public Parameter();

See Also

Parameter Class | Deag.Vdx.Server.DAL Namespace | Parameter Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Parameter Constructor (String)

Creates a named instance of a Parameter.

public Parameter(
string name
);

Parameters

name
The name of the Parameter.

See Also

Parameter Class | Deag.Vdx.Server.DAL Namespace | Parameter Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Parameter Constructor (String, Object)

Creates a named Parameter with an FilterEQUAL containing the specified value.

public Parameter(
string name,
object paramValue
);

Parameters

name
The name of the Parameter.
paramValue
Value that is assigned to the value of the created FilterEQUAL

See Also

Parameter Class | Deag.Vdx.Server.DAL Namespace | Parameter Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Parameter Constructor (String, Filter)

Creates a named Parameter and sets its Filter.

public Parameter(
string name,
Filter filter
);

Parameters

name
The name of the Parameter.
filter
The Filter that is assigned to this Parameter

See Also

Parameter Class | Deag.Vdx.Server.DAL Namespace | Parameter Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Parameter Properties

The properties of the Parameter class are listed below. For a complete list of Parameter class members, see the Parameter Members topic.

Public Instance Properties

Filter | Gets/sets the Filter of the Parameter.
Name | Gets/sets the name of the Parameter.
Prefix | Gets/sets the prefix of the Parameter that is used in the communication with the storage.
Value | Gets/sets the value of the contained Filter if it has a one.

See Also

Parameter Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Parameter.Filter Property

Gets/sets the Filter of the Parameter.

public Filters.Filter Filter {get; set;}

Remarks

Parent is set to this Parameter. If the Filter belongs already to another Parameter then an exception is thrown.

Exceptions

Exception Type | Condition
Exception | The filter belongs already to another Parameter

See Also

Parameter Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Parameter.Name Property

Gets/sets the name of the Parameter.

public string Name {get; set;}

See Also

Parameter Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Parameter.Prefix Property

Gets/sets the prefix of the Parameter that is used in the communication with the storage.

public string Prefix {get; set;}

Remarks

Because this prefix is data storage dependent this value is set when a parameter is added to a DataAccess.

See Also

Parameter Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Parameter.Value Property

Gets/sets the value of the contained Filter if it has a one.

public object Value {get; set;}

Remarks

If the contained Filter is a FilterOneValue then its Value is get/set. Otherwise an Exception is thrown. If there is no contained filter then an FilterEQUAL is created.

You can use this property if you don't want to matter about filter types. Internally, this property is used to set the returned values of an operation back to the parameters/filters.

See Also

Parameter Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterCollection Class

A Collection of Parameter.

For a list of all members of this type, see ParameterCollection Members.

System.Object
CollectionBase
ParameterCollection

public class ParameterCollection : CollectionBase

Requirements

Namespace: Deag.Vdx.Server.DAL

Assembly: vdxServer (in vdxServer.dll)

See Also

ParameterCollection Members | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterCollection Members

ParameterCollection overview

Public Instance Constructors

ParameterCollection Constructor Initializes a new instance of the ParameterCollection class.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Overloaded. Returns the parameter at the given index.

Public Instance Methods

Add | Adds a Parameter to the collection.
Clear | Removes all Parameters from the collection.
Copy | Returns a copy of the collection.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Removes a Parameter from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ParameterCollection Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterCollection Constructor

Initializes a new instance of the ParameterCollection class.

public ParameterCollection();

See Also

ParameterCollection Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterCollection Properties

The properties of the ParameterCollection class are listed below. For a complete list of ParameterCollection class members, see the ParameterCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Overloaded. Returns the parameter at the given index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

ParameterCollection Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Item Property

VDX Framework

ParameterCollection.Item Property

Returns the parameter at the given index.

Overload List

Returns the parameter at the given index.

public Parameter this[int] {get;}

Returns the parameter with the given name.

public Parameter this[string] {get;}

See Also

ParameterCollection Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterCollection.Item Property

Returns the parameter at the given index.

public Parameter this[
int index
] {get;}

See Also

ParameterCollection Class | Deag.Vdx.Server.DAL Namespace | ParameterCollection.Item Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterCollection.Item Property

Returns the parameter with the given name.

public Parameter this[
string paramName
] {get;}

Remarks

If no parameter with the specified name is contained in the collection then null is returned.

See Also

ParameterCollection Class | Deag.Vdx.Server.DAL Namespace | ParameterCollection.Item Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterCollection Methods

The methods of the ParameterCollection class are listed below. For a complete list of ParameterCollection class members, see the ParameterCollection Members topic.

Public Instance Methods

Add | Adds a Parameter to the collection.
Clear | Removes all Parameters from the collection.
Copy | Returns a copy of the collection.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Removes a Parameter from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ParameterCollection Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterCollection.Add Method

Adds a Parameter to the collection.

public void Add(
Parameter p
);

Parameters

p
The Parameter to add to the collection.

See Also

ParameterCollection Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterCollection.Clear Method

Removes all Parameters from the collection.

new public void Clear();

Implements

IList.Clear

See Also

ParameterCollection Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterCollection.Copy Method

Returns a copy of the collection.

public ParameterCollection Copy();

Return Value

Copy of the collection.

See Also

ParameterCollection Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterCollection.Remove Method

Removes a Parameter from the collection.

public void Remove(
Parameter p
);

Parameters

p
The Parameter to remove from the collection.

See Also

ParameterCollection Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction Class

A storage independent transaction.

For a list of all members of this type, see Transaction Members.

System.Object
Transaction

public class Transaction

Remarks

An VDX Transaction is used as any other transaction for keeping different operation together in one single operation that is either committed or rollback as a whole.

Furthermore Transactions can be used to collect validation errors (or any other error). This is especially usefull if data provided by a user is validated and several errors due to invalid data occure. Rather than throwing an exception on each error (and therefore presenting each single error) they are collected through the validation process and then one validation error is thrown to present all errors at once to the user.

A commit and rollback delegate can be set on the transaction to perform the storage dependent commit and rollback operations. If used with DataAccess objects, they will set these callbacks when they access their storage.

Example

This example shows the different steps in using an transaction. First we define a new transaction:

            Transaction transaction = new Transaction();
Then the transaction is used in an operation. Person represents an EntityObject.
            try
            {
                Person p = new Person();
                p.Name    = "Tech";
                p.Prename = "Nick";
                p.Update(transaction);
During the update operation the entity will be validated. If a validation rules is broken then either an exception can be thrown or the exception can be recorded on the transaction.
            class Person : EntityObject
            {
            ...
            protected override Validate(Transaction transaction, Operation op, ref bool cancel)
            {
                // throw an exception if the error cannot be handled
                throw new vdxException("Catastrophic Error!");

                // record the exception if further validations should take place
                // cancel will be set to true when this method call returns
                RecordException(transaction, new vdxException("Error that stops operation but not the validation."), ref bool cancel)
            }
            ...
            }
If everything went okay (no exception thrown) then try to commit the transaction. if there were exception recorded then the commit will fail and an exception containing the messages of all recorded exception will be thrown.
                transaction.Commit();
If an exception was thrown then rollback the transaction
            }
            catch
            {
                transaction.Rollback();
            }

Requirements

Namespace: Deag.Vdx.Server.DAL

Assembly: vdxServer (in vdxServer.dll)

See Also

Transaction Members | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction Members

Transaction overview

Public Instance Constructors

Transaction Overloaded. Initializes a new instance of the Transaction class.

Public Instance Properties

CommitDelegate | Sets the method that performs the storage dependent commit operation.
ConnectionInfo | Gets the ConnectionInfo of the Transaction.
Exception | Gets/sets the exception that will be thrown if there are recorded exceptions if the transaction is committed.
ExceptionSeverity | The vdxErrorSeverity of the exception thrown when the transaction is tried to be commited but there are recorded exceptions.
HasRecordedExceptions | Gets a value indicating whether exceptions were recorded.
Id | Gets the unique identifier that idetifies this transaction.
RollbackDelegate | Sets the method that performs the storage dependent rollback operation.
Settings | Gets the Isolation-Level Settings of this Transaction.

Public Instance Methods

Commit | Commit the transaction.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRecordedExceptionText | Overloaded. Returns the messages of all recorded exception in a single string.
GetType (inherited from Object) | Gets the Type of the current instance.
RecordException | Overloaded. Records an exception.
Rollback | Rollback the transaction.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction Constructor

Creates a Transaction instance.

Overload List

Creates a Transaction instance.

public Transaction();

Creates a Transaction and sets its ConnectionInfo.

public Transaction(ConnectionInfo);

Creates a Transaction and sets its ConnectionInfo and IsolationLevel.

public Transaction(ConnectionInfo,IsolationLevel);

Creates a Transaction instance and sets its IsolationLevel.

public Transaction(IsolationLevel);

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction Constructor ()

Creates a Transaction instance.

public Transaction();

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace | Transaction Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction Constructor (IsolationLevel)

Creates a Transaction instance and sets its IsolationLevel.

public Transaction(
IsolationLevel isolationLevel
);

Parameters

isolationLevel

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace | Transaction Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction Constructor (ConnectionInfo)

Creates a Transaction and sets its ConnectionInfo.

public Transaction(
ConnectionInfo info
);

Parameters

info

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace | Transaction Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction Constructor (ConnectionInfo, IsolationLevel)

Creates a Transaction and sets its ConnectionInfo and IsolationLevel.

public Transaction(
ConnectionInfo info,
IsolationLevel isolationLevel
);

Parameters

info
isolationLevel

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace | Transaction Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction Properties

The properties of the Transaction class are listed below. For a complete list of Transaction class members, see the Transaction Members topic.

Public Instance Properties

CommitDelegate | Sets the method that performs the storage dependent commit operation.
ConnectionInfo | Gets the ConnectionInfo of the Transaction.
Exception | Gets/sets the exception that will be thrown if there are recorded exceptions if the transaction is committed.
ExceptionSeverity | The vdxErrorSeverity of the exception thrown when the transaction is tried to be commited but there are recorded exceptions.
HasRecordedExceptions | Gets a value indicating whether exceptions were recorded.
Id | Gets the unique identifier that idetifies this transaction.
RollbackDelegate | Sets the method that performs the storage dependent rollback operation.
Settings | Gets the Isolation-Level Settings of this Transaction.

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.CommitDelegate Property

Sets the method that performs the storage dependent commit operation.

public Transaction.CommitCallback CommitDelegate {set;}

Remarks

Before a Transaction can be commited, a method that performs the storage dependent commit has be assigned.

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.ConnectionInfo Property

Gets the ConnectionInfo of the Transaction.

public ConnectionInfo ConnectionInfo {get;}

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.Exception Property

Gets/sets the exception that will be thrown if there are recorded exceptions if the transaction is committed.

public Deag.Vdx.Common.Exceptions.vdxException Exception {get; set;}

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace | Commit | RecordException

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.ExceptionSeverity Property

The vdxErrorSeverity of the exception thrown when the transaction is tried to be commited but there are recorded exceptions.

public Deag.Vdx.Common.Enums.vdxErrorSeverity ExceptionSeverity {get; set;}

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.HasRecordedExceptions Property

Gets a value indicating whether exceptions were recorded.

public bool HasRecordedExceptions {get;}

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.Id Property

Gets the unique identifier that idetifies this transaction.

public System.Guid Id {get;}

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.RollbackDelegate Property

Sets the method that performs the storage dependent rollback operation.

public Transaction.RollbackCallback RollbackDelegate {set;}

Remarks

Before a Transaction can be rollbacked, a method that performs the storage dependent rollback has be assigned.

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.Settings Property

Gets the Isolation-Level Settings of this Transaction.

public Transaction.Setting Settings {get;}

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction Methods

The methods of the Transaction class are listed below. For a complete list of Transaction class members, see the Transaction Members topic.

Public Instance Methods

Commit | Commit the transaction.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRecordedExceptionText | Overloaded. Returns the messages of all recorded exception in a single string.
GetType (inherited from Object) | Gets the Type of the current instance.
RecordException | Overloaded. Records an exception.
Rollback | Rollback the transaction.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.Commit Method

Commit the transaction.

public void Commit();

Remarks

The storage dependent commit method is called. If this transaction was never used in a storage access then the delegate will not be set and therefore no action will be performed.

If there are recorded exception then the transaction is not commited and the Exception is thrown and the error messages of all recorded exceptions are added to the Argument list of this exception.

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace | Exception

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


GetRecordedExceptionText Method

VDX Framework

Transaction.GetRecordedExceptionText Method

Returns the messages of all recorded exception in a single string.

Overload List

Returns the messages of all recorded exception in a single string.

public string GetRecordedExceptionText();

Returns the messages of all recorded exception as a single string delimited by the specified delimiting string.

public string GetRecordedExceptionText(string);

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.GetRecordedExceptionText Method ()

Returns the messages of all recorded exception in a single string.

public string GetRecordedExceptionText();

Return Value

All recorded exception messages.

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace | Transaction.GetRecordedExceptionText Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.GetRecordedExceptionText Method (String)

Returns the messages of all recorded exception as a single string delimited by the specified delimiting string.

public string GetRecordedExceptionText(
string delimiter
);

Parameters

delimiter
Delimiter that seperates the single messages.

Return Value

All recorded exception messages.

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace | Transaction.GetRecordedExceptionText Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


RecordException Method

VDX Framework

Transaction.RecordException Method

Records an exception.

Overload List

Records an exception.

public void RecordException(vdxException);

Records an Exception with the specified message.

public void RecordException(string);

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace | HasRecordedExceptions | Commit

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.RecordException Method (vdxException)

Records an exception.

public void RecordException(
vdxException e
);

Parameters

e
The exception to record.

Remarks

Recorded exceptions have the advantage that in case of an error you can continue the current operation and collect further errors. For example, this is especially useful if you want to show all data the user missed to enter at once.

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace | Transaction.RecordException Overload List | HasRecordedExceptions | Commit

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.RecordException Method (String)

Records an Exception with the specified message.

public void RecordException(
string message
);

Parameters

message
The exception message to record.

Remarks

Recorded exceptions have the advantage that in case of an error you can continue the current operation and collect further errors. For example, this is especially useful if you want to show all data the user missed to enter at once.

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace | Transaction.RecordException Overload List | HasRecordedExceptions | Commit

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.Rollback Method

Rollback the transaction.

public void Rollback();

Remarks

The storage dependent rollback method is called. If this transaction was never used in a storage access then the delegate will not be set and therefore no action will be performed.

See Also

Transaction Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.CommitCallback Delegate

Delegate for the storage dependent Commit method.

public delegate void Transaction.CommitCallback(
Guid guid
);

Remarks

Before a transaction is comitted this delegate has to be set.

Requirements

Namespace: Deag.Vdx.Server.DAL

Assembly: vdxServer (in vdxServer.dll)

See Also

Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.RollbackCallback Delegate

Delegate for the storage dependent Rollback method.

public delegate void Transaction.RollbackCallback(
Guid guid
);

Remarks

Before a transaction is rollbacked this delegate has to be set.

Requirements

Namespace: Deag.Vdx.Server.DAL

Assembly: vdxServer (in vdxServer.dll)

See Also

Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.Setting Class

Isolation level settings of a Transaction.

For a list of all members of this type, see Transaction.Setting Members.

System.Object
Transaction.Setting

public class Transaction.Setting

Requirements

Namespace: Deag.Vdx.Server.DAL

Assembly: vdxServer (in vdxServer.dll)

See Also

Transaction.Setting Members | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.Setting Members

Transaction.Setting overview

Public Instance Constructors

Transaction.Setting Constructor Initializes a new instance of the Setting class.

Public Instance Properties

IsolationLevel Gets/sets the IsolationLevel.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Transaction.Setting Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.Setting Constructor

Initializes a new instance of the Setting class.

public Transaction.Setting();

See Also

Transaction.Setting Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.Setting Properties

The properties of the Transaction.Setting class are listed below. For a complete list of Transaction.Setting class members, see the Transaction.Setting Members topic.

Public Instance Properties

IsolationLevel Gets/sets the IsolationLevel.

See Also

Transaction.Setting Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Transaction.Setting.IsolationLevel Property

Gets/sets the IsolationLevel.

public System.Data.IsolationLevel IsolationLevel {get; set;}

See Also

Transaction.Setting Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer Class

A Viewer is a container for views. A view is used to read a specific 'view' of the data from the storage.

For a list of all members of this type, see Viewer Members.

System.Object
Viewer

public abstract class Viewer

Remarks

A viewer along with its views is used for reading special purpose DataSets, e.g. the data for a tree view.

In contrast to EntityObject and EntityList that can hold only a DataSet, which contains exactly one DataTable, a view can return a DataSet consisting of several tables.

Example

The following example shows a Viewer that contains two different Viewer.IViews:

            public class DVPerson : Viewer
            {
                // define the view constants
                public const string viewPerson         = "Person";
                public const string viewPersonDetailed = "PersonDetailed";

                // define the possible search criterias
                private Parameter parName    = new Parameter("Name");
                private Parameter parAge = new Parameter("Age");

                public DVPerson()
                {
                    // register the views
                    AddView(viewPerson);
                    AddView(viewPersonDetailed);
                }

                // properties for setting the search criteria filters
                public Filter Name
                {
                    set { parName.Filter = value; }
                }

                public Filter Age
                {
                    set { parAge.Filter = value; }
                }

                // refresh the data access object of the current view
                protected override void RefreshDataAccessObject(string viewName, DataAccess accessObject)
                {
                    base.RefreshDataAccessObject(viewName, accessObject);

                    switch (viewName)
                    {
                        case viewPerson:
                            // the view Person can find persons depending on a name and age
                            accessObject.AddParameter(parName);
                            accessObject.AddParameter(parAge);
                            break;

                        case viewPersonDetailed:
                            // view PersonDetailed finds persons by name only
                            accessObject.AddParameter(parName);
                            break;
                    }
                }

                protected override void InitView(string viewName, Deag.Vdx.Server.DAL.Viewer.IView view)
                {
                    switch (viewName)
                    {
                        case viewPerson:
                            // define the data set that the view will return and the data access that
                            // reads the data into the data set
                            view.DataSetType = typeof(DSPerson);
                            DAPerson da = new DAPerson();
                            // define the table name. The table can not be set because the data set
                            // will not be instantiated until the view is requested.
                            da.TableName = "Person";
                            view.AddAccessObjects(da);
                            break;

                        case viewPersonDetailed:
                            // DSPersonDetailed is a data set with two tables. Therefore we need two data access
                            view.DataSetType = typeof(DSPersonDetailed);
                            // note that we pass the table name as an constructor argument here
                            view.AddAccessObjects(new DAPerson("Person"), new DAPersonDetail("PersonDetail"));
                            break;
                    }
                }
Now we can use this viewer:
            public void Test()
            {
                DVPerson dv = new DVPerson();
                dv.Name = new FilterSTARTWITH("Tech");

                // read all persons with a name that start with "Tech" along with its details
                DSPersonDetail detail = dv[DVPerson.viewPersonDetail] as DSPersonDetail;

                dv.Age = new FilterBETWEEN(20, 30);

                // read all persons that are also between 20 and 30
                DSPerson persons = dv[DVPerson.viewPerson] as DSPerson;
            }

Requirements

Namespace: Deag.Vdx.Server.DAL

Assembly: vdxServer (in vdxServer.dll)

See Also

Viewer Members | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer Members

Viewer overview

Public Instance Constructors

Viewer Constructor Initializes a new instance of the Viewer class.

Public Instance Properties

Item Gets the DataSet represented by the view with the specified name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddView | Registers a view with the specified name.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCurrentCache | Returns a copy of the DataSet of the current view. Only valid while executing the RefreshDataAccessObject or RefreshDataAccessObjects methods. Otherwise nul is returned.
InitView | Initializes the specified view.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshDataAccessObject | Refreshes a single DataAccess of the current view.
RefreshDataAccessObjects | Refreshes all DataAccess in the collection of DataAccesses of the current view.
RemoveView | Removes a view.

See Also

Viewer Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer Constructor

Initializes a new instance of the Viewer class.

public Viewer();

See Also

Viewer Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer Properties

The properties of the Viewer class are listed below. For a complete list of Viewer class members, see the Viewer Members topic.

Public Instance Properties

Item Gets the DataSet represented by the view with the specified name.

See Also

Viewer Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.Item Property

Gets the DataSet represented by the view with the specified name.

public System.Data.DataSet this[
string viewName
] {get;}

See Also

Viewer Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer Methods

The methods of the Viewer class are listed below. For a complete list of Viewer class members, see the Viewer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddView | Registers a view with the specified name.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCurrentCache | Returns a copy of the DataSet of the current view. Only valid while executing the RefreshDataAccessObject or RefreshDataAccessObjects methods. Otherwise nul is returned.
InitView | Initializes the specified view.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshDataAccessObject | Refreshes a single DataAccess of the current view.
RefreshDataAccessObjects | Refreshes all DataAccess in the collection of DataAccesses of the current view.
RemoveView | Removes a view.

See Also

Viewer Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.AddView Method

Registers a view with the specified name.

protected void AddView(
string viewName
);

Parameters

viewName
name of the view to register.

See Also

Viewer Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.GetCurrentCache Method

Returns a copy of the DataSet of the current view. Only valid while executing the RefreshDataAccessObject or RefreshDataAccessObjects methods. Otherwise nul is returned.

protected DataSet GetCurrentCache();

Return Value

The DataSet of the current view.

Remarks

This method can be used to refresh a DataAccess depending on the data another DataAccess has already read into the DataSet that will be returned, e.g. foreign key dependencies.

See Also

Viewer Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.InitView Method

Initializes the specified view.

protected virtual void InitView(
string viewName,
IView view
);

Parameters

viewName
view

See Also

Viewer Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.RefreshDataAccessObject Method

Refreshes a single DataAccess of the current view.

protected virtual void RefreshDataAccessObject(
string viewName,
DataAccess accessObject
);

Parameters

viewName
Name of the current view.
accessObject
The DataAccess to be refreshed.

Remarks

If you have not overriden the RefreshDataAccessObjects method then this method is called once for each DataAccess object of the current view.

See Also

Viewer Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.RefreshDataAccessObjects Method

Refreshes all DataAccess in the collection of DataAccesses of the current view.

protected virtual void RefreshDataAccessObjects(
string viewName,
DataAccessCollection accessObjects
);

Parameters

viewName
Name of the current view.
accessObjects
Collection of all DataAccess of the current view.

Remarks

The default behaviour is to call RefreshDataAccessObject for each DataAccess.

See Also

Viewer Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.RemoveView Method

Removes a view.

protected void RemoveView(
string viewName
);

Parameters

viewName
Name of the view.

See Also

Viewer Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.IView Interface

Interface defining a view.

For a list of all members of this type, see Viewer.IView Members.

public interface Viewer.IView

Requirements

Namespace: Deag.Vdx.Server.DAL

Assembly: vdxServer (in vdxServer.dll)

See Also

Viewer.IView Members | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.IView Members

Viewer.IView overview

Public Instance Properties

ConstraintAction | Gets/sets the constraint action.
DataAccessRefreshing | Gets/sets the way the DataAccess objects are refreshed.
DataAccessSorting | Gets/sets the way the DataAccess objects are sorted.
DataSetType | The type of the DataSet this view returns.

Public Instance Methods

AddAccessObject | Adds the specified DataAccess to the view.
AddAccessObjects | Adds the specified DataAccess to the view.

See Also

Viewer.IView Interface | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.IView Properties

The properties of the Viewer.IView interface are listed below. For a complete list of Viewer.IView interface members, see the Viewer.IView Members topic.

Public Instance Properties

ConstraintAction | Gets/sets the constraint action.
DataAccessRefreshing | Gets/sets the way the DataAccess objects are refreshed.
DataAccessSorting | Gets/sets the way the DataAccess objects are sorted.
DataSetType | The type of the DataSet this view returns.

See Also

Viewer.IView Interface | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.IView.ConstraintAction Property

Gets/sets the constraint action.

Deag.Vdx.Server.Entity.EntityBase.ConstraintActionType ConstraintAction {get; set;}

See Also

Viewer.IView Interface | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.IView.DataAccessRefreshing Property

Gets/sets the way the DataAccess objects are refreshed.

Deag.Vdx.Server.Entity.EntityBase.DataAccessRefreshType DataAccessRefreshing {get; set;}

See Also

Viewer.IView Interface | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.IView.DataAccessSorting Property

Gets/sets the way the DataAccess objects are sorted.

Deag.Vdx.Server.Entity.EntityBase.DataAccessSortType DataAccessSorting {get; set;}

See Also

Viewer.IView Interface | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.IView.DataSetType Property

The type of the DataSet this view returns.

System.Type DataSetType {set;}

See Also

Viewer.IView Interface | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.IView Methods

The methods of the Viewer.IView interface are listed below. For a complete list of Viewer.IView interface members, see the Viewer.IView Members topic.

Public Instance Methods

AddAccessObject | Adds the specified DataAccess to the view.
AddAccessObjects | Adds the specified DataAccess to the view.

See Also

Viewer.IView Interface | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.IView.AddAccessObject Method

Adds the specified DataAccess to the view.

void AddAccessObject(
DataAccess da
);

Parameters

da

See Also

Viewer.IView Interface | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.IView.AddAccessObjects Method

Adds the specified DataAccess to the view.

void AddAccessObjects(
params DataAccess[] das
);

Parameters

das

See Also

Viewer.IView Interface | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.View Class

A view is used togehter with a Viewer for reading data from the storage into a DataSet. .

For a list of all members of this type, see Viewer.View Members.

System.Object
EntityBase
Viewer.View

public class Viewer.View : EntityBase, IView

Requirements

Namespace: Deag.Vdx.Server.DAL

Assembly: vdxServer (in vdxServer.dll)

See Also

Viewer.View Members | Deag.Vdx.Server.DAL Namespace | Viewer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.View Members

Viewer.View overview

Public Instance Properties

ConstraintAction | ConstraintAction
DataAccessRefreshing | DataAccessRefreshing
DataAccessSorting | DataAccessSorting
DataSetType | DataSetType
Parent (inherited from EntityBase) | Gets/sets the EntityBase that is the parent of this entity. Default value = null.
Status (inherited from EntityBase) | Returns a value that indicats the EntityStatus of the entity. Default value (after creation) = Unspecified.
StatusDriver (inherited from EntityBase) | Gets the EntityStatusDriver. Default value = DataDriven

Public Instance Methods

AddAccessObject | AddAccessObject
AddAccessObjects | AddAccessObjects
ClearAlternativeTable (inherited from EntityBase) | Deletes the information about alternative data --> no alternative data is read any more.
Deserialize (inherited from EntityBase) | Overloaded. Fills the DsCache with the data in the passed DataRow. It is merged with Ignore.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Read | Perform the read operation.
Serialize (inherited from EntityBase) | Returns a copy of the DsCache.
SerializeAlternativeData (inherited from EntityBase) | Serializes the alternative data into a DataTable.
SetAlternativeData (inherited from EntityBase) | Overloaded. Sets the information which alternative data should be read and by which operations.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate (inherited from EntityBase) | Validates the Entity.

Protected Instance Fields

entityStatus (inherited from EntityBase) The internal EntityStatus.

Protected Instance Properties

EnforceCacheConstraints (inherited from EntityBase) Gets or sets EnforceConstraints on DsCache. Default value = true.

Protected Instance Methods

CheckCacheIntegrity (inherited from EntityBase) | Checks the integrity of the DsCache.
ClearCache (inherited from EntityBase) | Clears the DsCache.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAccessObject (inherited from EntityBase) | Returns the DataAccess object with the specified key from the collection of data access objects.
GetCacheTable (inherited from EntityBase) | Returns the DataTable from the DsCache.
GetDataDrivenStatus (inherited from EntityBase) | Returns the currently set internal status. See SetEntityStatus.
GetParametersFromCache (inherited from EntityBase) | Derived classes creates for each item in the Cache a Parameter.
GetRowStateDrivenStatus (inherited from EntityBase) | Derived classes override this method to return the row state driven Status.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PerformOperation (inherited from EntityBase) | Executes the specified Operation in the specified Transaction on the specified DataAccess.
PerformRead (inherited from EntityBase) | Fills the DsCache by executing the Read operation on all reading enabled DataAccess objects. Not to be called directly. Use Read or Read.
PerformReadCount (inherited from EntityBase) | Returns the maximal number of rows a DataAccess of this entity would return in a read operation. Not to be called directly. Use ReadCount.
ProcessReturnedParameters (inherited from EntityBase) | Called after a read, insert, update or delete operation. Derived classes use this methode to access parameters that contain result values.
ReadAlternativeData (inherited from EntityBase) | Overloaded. Reads the alternative data.
RecordException (inherited from EntityBase) | Records an Exception onto a Transaction. If the specified transaction is null then the exception is thrown instead. If the exception was recorded then cancel will be set to true.
RefreshDataAccessObject | Calls the RefreshDataAccessObject method of the parent.
RefreshDataAccessObjects | Calls the RefreshDataAccessObjects method of the parent.
RemoveAccessObject (inherited from EntityBase) | Removes a DataAccess object form the collection of data access objects.
SetConstraintsAfterOperation (inherited from EntityBase) | Re-enables the constraints of the specified dataset if the specified action demands it.
SetConstraintsBeforeOperation (inherited from EntityBase) | Disables the constraints of the DsCache if the specified action demands it.
SetEntityStatus (inherited from EntityBase) | Sets the Status to the specified 'status'.
SetEntityStatusDriver (inherited from EntityBase) | Sets the EntityStatusDriver.
SortAccessObjects (inherited from EntityBase) | Sorts the DataAccess objects by relations and constriants. Loop are not supported. This method is called internally when a read operation is executed.

Protected Internal Instance Properties

AccessObjects (inherited from EntityBase) | Gets the collection of DataAccess objects of this object. Do not modify this collection use AddAccessObject and RemoveAccessObject instead.
AlternativeData (inherited from EntityBase) | Gets the AlternativeData information of this EntityBase.

See Also

Viewer.View Class | Deag.Vdx.Server.DAL Namespace | Viewer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.View Properties

The properties of the Viewer.View class are listed below. For a complete list of Viewer.View class members, see the Viewer.View Members topic.

Public Instance Properties

ConstraintAction | ConstraintAction
DataAccessRefreshing | DataAccessRefreshing
DataAccessSorting | DataAccessSorting
DataSetType | DataSetType
Parent (inherited from EntityBase) | Gets/sets the EntityBase that is the parent of this entity. Default value = null.
Status (inherited from EntityBase) | Returns a value that indicats the EntityStatus of the entity. Default value (after creation) = Unspecified.
StatusDriver (inherited from EntityBase) | Gets the EntityStatusDriver. Default value = DataDriven

Protected Instance Properties

EnforceCacheConstraints (inherited from EntityBase) Gets or sets EnforceConstraints on DsCache. Default value = true.

Protected Internal Instance Properties

AccessObjects (inherited from EntityBase) | Gets the collection of DataAccess objects of this object. Do not modify this collection use AddAccessObject and RemoveAccessObject instead.
AlternativeData (inherited from EntityBase) | Gets the AlternativeData information of this EntityBase.

See Also

Viewer.View Class | Deag.Vdx.Server.DAL Namespace | Viewer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.View.ConstraintAction Property

ConstraintAction

new public Deag.Vdx.Server.Entity.EntityBase.ConstraintActionType ConstraintAction {get; set;}

Implements

IView.ConstraintAction

See Also

Viewer.View Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.View.DataAccessRefreshing Property

DataAccessRefreshing

new public Deag.Vdx.Server.Entity.EntityBase.DataAccessRefreshType DataAccessRefreshing {get; set;}

Implements

IView.DataAccessRefreshing

See Also

Viewer.View Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.View.DataAccessSorting Property

DataAccessSorting

new public Deag.Vdx.Server.Entity.EntityBase.DataAccessSortType DataAccessSorting {get; set;}

Implements

IView.DataAccessSorting

See Also

Viewer.View Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.View.DataSetType Property

DataSetType

new public System.Type DataSetType {set;}

Implements

IView.DataSetType

See Also

Viewer.View Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.View Methods

The methods of the Viewer.View class are listed below. For a complete list of Viewer.View class members, see the Viewer.View Members topic.

Public Instance Methods

AddAccessObject | AddAccessObject
AddAccessObjects | AddAccessObjects
ClearAlternativeTable (inherited from EntityBase) | Deletes the information about alternative data --> no alternative data is read any more.
Deserialize (inherited from EntityBase) | Overloaded. Fills the DsCache with the data in the passed DataRow. It is merged with Ignore.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Read | Perform the read operation.
Serialize (inherited from EntityBase) | Returns a copy of the DsCache.
SerializeAlternativeData (inherited from EntityBase) | Serializes the alternative data into a DataTable.
SetAlternativeData (inherited from EntityBase) | Overloaded. Sets the information which alternative data should be read and by which operations.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate (inherited from EntityBase) | Validates the Entity.

Protected Instance Methods

CheckCacheIntegrity (inherited from EntityBase) | Checks the integrity of the DsCache.
ClearCache (inherited from EntityBase) | Clears the DsCache.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAccessObject (inherited from EntityBase) | Returns the DataAccess object with the specified key from the collection of data access objects.
GetCacheTable (inherited from EntityBase) | Returns the DataTable from the DsCache.
GetDataDrivenStatus (inherited from EntityBase) | Returns the currently set internal status. See SetEntityStatus.
GetParametersFromCache (inherited from EntityBase) | Derived classes creates for each item in the Cache a Parameter.
GetRowStateDrivenStatus (inherited from EntityBase) | Derived classes override this method to return the row state driven Status.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PerformOperation (inherited from EntityBase) | Executes the specified Operation in the specified Transaction on the specified DataAccess.
PerformRead (inherited from EntityBase) | Fills the DsCache by executing the Read operation on all reading enabled DataAccess objects. Not to be called directly. Use Read or Read.
PerformReadCount (inherited from EntityBase) | Returns the maximal number of rows a DataAccess of this entity would return in a read operation. Not to be called directly. Use ReadCount.
ProcessReturnedParameters (inherited from EntityBase) | Called after a read, insert, update or delete operation. Derived classes use this methode to access parameters that contain result values.
ReadAlternativeData (inherited from EntityBase) | Overloaded. Reads the alternative data.
RecordException (inherited from EntityBase) | Records an Exception onto a Transaction. If the specified transaction is null then the exception is thrown instead. If the exception was recorded then cancel will be set to true.
RefreshDataAccessObject | Calls the RefreshDataAccessObject method of the parent.
RefreshDataAccessObjects | Calls the RefreshDataAccessObjects method of the parent.
RemoveAccessObject (inherited from EntityBase) | Removes a DataAccess object form the collection of data access objects.
SetConstraintsAfterOperation (inherited from EntityBase) | Re-enables the constraints of the specified dataset if the specified action demands it.
SetConstraintsBeforeOperation (inherited from EntityBase) | Disables the constraints of the DsCache if the specified action demands it.
SetEntityStatus (inherited from EntityBase) | Sets the Status to the specified 'status'.
SetEntityStatusDriver (inherited from EntityBase) | Sets the EntityStatusDriver.
SortAccessObjects (inherited from EntityBase) | Sorts the DataAccess objects by relations and constriants. Loop are not supported. This method is called internally when a read operation is executed.

See Also

Viewer.View Class | Deag.Vdx.Server.DAL Namespace | Viewer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.View.AddAccessObject Method

AddAccessObject

new public void AddAccessObject(
DataAccess da
);

Parameters

da
Added DataAccess object.

Implements

IView.AddAccessObject

See Also

Viewer.View Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.View.AddAccessObjects Method

AddAccessObjects

new public void AddAccessObjects(
params DataAccess[] das
);

Parameters

das
Collection of DataAccess objects.

Implements

IView.AddAccessObjects

See Also

Viewer.View Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.View.Read Method

Perform the read operation.

public void Read();

See Also

Viewer.View Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.View.RefreshDataAccessObject Method

Calls the RefreshDataAccessObject method of the parent.

protected override void RefreshDataAccessObject(
DataAccess accessObject,
Operation op
);

Parameters

accessObject
The DataAccess to be refreshed.
op
Operation currently executed.

See Also

Viewer.View Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Viewer.View.RefreshDataAccessObjects Method

Calls the RefreshDataAccessObjects method of the parent.

protected override void RefreshDataAccessObjects(
DataAccessCollection accessObjects,
Operation op
);

Parameters

accessObjects
Collection of DataAccess to be refreshed.
op
Operation currently executed.

See Also

Viewer.View Class | Deag.Vdx.Server.DAL Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Server.DAL.Commands

VDX Framework

Deag.Vdx.Server.DAL.Commands Namespace

The Deag.Vdx.Server.DAL.Commands namespace provides classes that are used to define a command (query) that is sent to the storage. In the current version (2.0) there are only SQL commands available. For the ease of the user there exist several commands for reading (select commands) that allow he creation of queries depending on search criterias:

  • SelectCommandWhereTerms
  • SelectCommandNWheres
  • SelectCommandDynamicWhere
The commands are used by SQLDataAccess classes to hold and build the queries that are sent to the data base.

Classes

Class | Description
Command | Base class for all Commands.
DeleteCommand | Used to delete data into a storage using SQL.
InsertCommand | Used to insert data into a storage using SQL.
ParameterMapping | Maps a vdxServer Parameter name to a DB parameter name.
ParameterMappingCollection | A collection ParameterMappings.
SelectCommand | A select command is used the read data from the storage.
SelectCommandBase | Base class for all select commands.
SelectCommandDynamicWhere | Select command with a dynamic where clause
SelectCommandNWheres | A SelectCommandBase with multiple WhereClauses.
SelectCommandWhereTerms | A select command that uses a where clause that is composed of 'terms'. A term is taken if all the contained Parameters are present, i.e. they were passed to the command.
UpdateCommand | Used to update data into a storage using SQL.
WhereClause | A single where clause.
WhereClauseCollection | Collection of WhereClauses

Delegates

Delegate | Description
Command.ParametersNamesCallback | Delegate for the storage dependent method that parses a Query for all contained Parameters.

Enumerations

Enumeration | Description
CommandType | Defines the type of a command.
SelectCommandDynamicWhere.WhereOp | The Operator used in the dynamic where clause.
SelectCommandWhereTerms.WhereOp | The operator to be used in the where clause between the different where clauses.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Command Class

Base class for all Commands.

For a list of all members of this type, see Command Members.

System.Object
Command

public class Command

Remarks

A Command defines a collection of parameters that can be requested by GetParameters and the Sql Query string. When the command is executed, the parameters and the query are combined to form a correct Sql statement.

Requirements

Namespace: Deag.Vdx.Server.DAL.Commands

Assembly: vdxServer (in vdxServer.dll)

See Also

Command Members | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Command Members

Command overview

Public Instance Constructors

Command Overloaded. Initializes a new instance of the Command class.

Public Instance Properties

ParameterNamesDelegate | Gets/sets the method that parses the Query for all contained Parameters.
Parameters | Gets/sets the collection of Parameters of this Command.
Query | Gets the query of the Command.
TrimUnusedParameters | Gets/sets a value indicating whether Parameters that are not contained in the Query should be ignored. Default = false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameters | Return the collection of Parameters.
GetType (inherited from Object) | Gets the Type of the current instance.
RefreshQuery | Refreshes the Query of the Command.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

query Query string des Commands. Wird dem SqlCommand als CommandText übergeben

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
TrimParameters | Removes all Parameters from Parameters that are not contained in the Query.

See Also

Command Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Command Constructor

Initializes a new instance of the Command class.

Overload List

Initializes a new instance of the Command class.

public Command();

Initializes a new instance of the Command class with the specified Query.

public Command(string);

See Also

Command Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Command Constructor ()

Initializes a new instance of the Command class.

public Command();

See Also

Command Class | Deag.Vdx.Server.DAL.Commands Namespace | Command Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Command Constructor (String)

Initializes a new instance of the Command class with the specified Query.

public Command(
string query
);

Parameters

query
Query Statement

See Also

Command Class | Deag.Vdx.Server.DAL.Commands Namespace | Command Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Command Fields

The fields of the Command class are listed below. For a complete list of Command class members, see the Command Members topic.

Protected Instance Fields

query Query string des Commands. Wird dem SqlCommand als CommandText übergeben

See Also

Command Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Command.Query Property

Gets the query of the Command.

public string Query {get;}

See Also

Command Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Command Properties

The properties of the Command class are listed below. For a complete list of Command class members, see the Command Members topic.

Public Instance Properties

ParameterNamesDelegate | Gets/sets the method that parses the Query for all contained Parameters.
Parameters | Gets/sets the collection of Parameters of this Command.
Query | Gets the query of the Command.
TrimUnusedParameters | Gets/sets a value indicating whether Parameters that are not contained in the Query should be ignored. Default = false.

See Also

Command Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Command.ParameterNamesDelegate Property

Gets/sets the method that parses the Query for all contained Parameters.

public Command.ParametersNamesCallback ParameterNamesDelegate {get; set;}

Remarks

The DataAccess that holds this command sets this delegate before the RefreshQuery method is called.

The called delegate returns all parameter names the were found in the passed query.

See Also

Command Class | Deag.Vdx.Server.DAL.Commands Namespace | Command.ParametersNamesCallback

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Command.Parameters Property

Gets/sets the collection of Parameters of this Command.

public Deag.Vdx.Server.DAL.ParameterCollection Parameters {get; set;}

Remarks

The Parameters of a Command are always storage dependent. Before a command is executed the DataAccess that holds that command set this collection of parameters.

See Also

Command Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Command.TrimUnusedParameters Property

Gets/sets a value indicating whether Parameters that are not contained in the Query should be ignored. Default = false.

public bool TrimUnusedParameters {get; set;}

Remarks

Set this value to true when you wish to process the parameters of the command after the query was refreshed and you want only to deal with paramaeters that are really used in the query.

See Also

Command Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Command Methods

The methods of the Command class are listed below. For a complete list of Command class members, see the Command Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameters | Return the collection of Parameters.
GetType (inherited from Object) | Gets the Type of the current instance.
RefreshQuery | Refreshes the Query of the Command.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
TrimParameters | Removes all Parameters from Parameters that are not contained in the Query.

See Also

Command Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Command.GetParameters Method

Return the collection of Parameters.

public ParameterCollection GetParameters();

Return Value

The collection of parameters.

See Also

Command Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Command.RefreshQuery Method

Refreshes the Query of the Command.

public virtual void RefreshQuery();

Remarks

Before a Command is executed it has to be refreshed. Derived classes use the RefreshQuery method to generate the Query. If you want to build your own query programmatically then derive a class from Command od of one of its derived classes. Then you can override this method in order to build your query depending on all the Parameters that were assigned to this command.

See Also

Command Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Command.TrimParameters Method

Removes all Parameters from Parameters that are not contained in the Query.

protected void TrimParameters();

Remarks

If TrimUnusedParameters is set to false then all Parameters remain in the collection of parameters.

To parse the Query for all contained parameters the ParameterNamesDelegate is called.

Exceptions

Exception Type | Condition
Exception | No ParameterNamesDelegate is assigned.

See Also

Command Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Command.ParametersNamesCallback Delegate

Delegate for the storage dependent method that parses a Query for all contained Parameters.

public delegate Hashtable Command.ParametersNamesCallback(
string text
);

Requirements

Namespace: Deag.Vdx.Server.DAL.Commands

Assembly: vdxServer (in vdxServer.dll)

See Also

Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CommandType Enumeration

Defines the type of a command.

public enum CommandType

Members

Member Name | Description
Select | Select Command.
Update | Update Command.
Insert | Insert Command.
Delete | Delete Command.

Requirements

Namespace: Deag.Vdx.Server.DAL.Commands

Assembly: vdxServer (in vdxServer.dll)

See Also

Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DeleteCommand Class

Used to delete data into a storage using SQL.

For a list of all members of this type, see DeleteCommand Members.

System.Object
Command
DeleteCommand

public class DeleteCommand : Command

Remarks

SQLDataAccess objects use DeleteCommands for deleting data in the data base. A delete command knows only a query string that will be executed.

Requirements

Namespace: Deag.Vdx.Server.DAL.Commands

Assembly: vdxServer (in vdxServer.dll)

See Also

DeleteCommand Members | Deag.Vdx.Server.DAL.Commands Namespace | SQLDataAccessQuery

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DeleteCommand Members

DeleteCommand overview

Public Instance Constructors

DeleteCommand Overloaded. Initializes a new instance of the DeleteCommand class.

Public Instance Properties

ParameterNamesDelegate (inherited from Command) | Gets/sets the method that parses the Query for all contained Parameters.
Parameters (inherited from Command) | Gets/sets the collection of Parameters of this Command.
Query | Gets/sets the delete query.
TrimUnusedParameters (inherited from Command) | Gets/sets a value indicating whether Parameters that are not contained in the Query should be ignored. Default = false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameters (inherited from Command) | Return the collection of Parameters.
GetType (inherited from Object) | Gets the Type of the current instance.
RefreshQuery (inherited from Command) | Refreshes the Query of the Command.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

query (inherited from Command) Query string des Commands. Wird dem SqlCommand als CommandText übergeben

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
TrimParameters (inherited from Command) | Removes all Parameters from Parameters that are not contained in the Query.

See Also

DeleteCommand Class | Deag.Vdx.Server.DAL.Commands Namespace | SQLDataAccessQuery

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DeleteCommand Constructor

Initializes a new instance of the DeleteCommand class.

Overload List

Initializes a new instance of the DeleteCommand class.

public DeleteCommand();

Initializes a new instance of the DeleteCommand class using the specified query.

public DeleteCommand(string);

See Also

DeleteCommand Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DeleteCommand Constructor ()

Initializes a new instance of the DeleteCommand class.

public DeleteCommand();

See Also

DeleteCommand Class | Deag.Vdx.Server.DAL.Commands Namespace | DeleteCommand Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DeleteCommand Constructor (String)

Initializes a new instance of the DeleteCommand class using the specified query.

public DeleteCommand(
string query
);

Parameters

query
The query.

See Also

DeleteCommand Class | Deag.Vdx.Server.DAL.Commands Namespace | DeleteCommand Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DeleteCommand Properties

The properties of the DeleteCommand class are listed below. For a complete list of DeleteCommand class members, see the DeleteCommand Members topic.

Public Instance Properties

ParameterNamesDelegate (inherited from Command) | Gets/sets the method that parses the Query for all contained Parameters.
Parameters (inherited from Command) | Gets/sets the collection of Parameters of this Command.
Query | Gets/sets the delete query.
TrimUnusedParameters (inherited from Command) | Gets/sets a value indicating whether Parameters that are not contained in the Query should be ignored. Default = false.

See Also

DeleteCommand Class | Deag.Vdx.Server.DAL.Commands Namespace | SQLDataAccessQuery

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DeleteCommand.Query Property

Gets/sets the delete query.

new public string Query {get; set;}

See Also

DeleteCommand Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


InsertCommand Class

Used to insert data into a storage using SQL.

For a list of all members of this type, see InsertCommand Members.

System.Object
Command
InsertCommand

public class InsertCommand : Command

Remarks

SQLDataAccess objects use InsertCommands for inserting data into the data base. An insert command knows only a query string that will be executed.

Requirements

Namespace: Deag.Vdx.Server.DAL.Commands

Assembly: vdxServer (in vdxServer.dll)

See Also

InsertCommand Members | Deag.Vdx.Server.DAL.Commands Namespace | SQLDataAccessQuery

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


InsertCommand Members

InsertCommand overview

Public Instance Constructors

InsertCommand Overloaded. Initializes a new instance of the InsertCommand class.

Public Instance Properties

ParameterNamesDelegate (inherited from Command) | Gets/sets the method that parses the Query for all contained Parameters.
Parameters (inherited from Command) | Gets/sets the collection of Parameters of this Command.
Query | Gets/sets the insert query.
TrimUnusedParameters (inherited from Command) | Gets/sets a value indicating whether Parameters that are not contained in the Query should be ignored. Default = false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameters (inherited from Command) | Return the collection of Parameters.
GetType (inherited from Object) | Gets the Type of the current instance.
RefreshQuery (inherited from Command) | Refreshes the Query of the Command.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

query (inherited from Command) Query string des Commands. Wird dem SqlCommand als CommandText übergeben

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
TrimParameters (inherited from Command) | Removes all Parameters from Parameters that are not contained in the Query.

See Also

InsertCommand Class | Deag.Vdx.Server.DAL.Commands Namespace | SQLDataAccessQuery

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


InsertCommand Constructor

Initializes a new instance of the InsertCommand class.

Overload List

Initializes a new instance of the InsertCommand class.

public InsertCommand();

Initializes a new instance of the InsertCommand class using the specified query.

public InsertCommand(string);

See Also

InsertCommand Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


InsertCommand Constructor ()

Initializes a new instance of the InsertCommand class.

public InsertCommand();

See Also

InsertCommand Class | Deag.Vdx.Server.DAL.Commands Namespace | InsertCommand Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


InsertCommand Constructor (String)

Initializes a new instance of the InsertCommand class using the specified query.

public InsertCommand(
string query
);

Parameters

query
The query.

See Also

InsertCommand Class | Deag.Vdx.Server.DAL.Commands Namespace | InsertCommand Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


InsertCommand Properties

The properties of the InsertCommand class are listed below. For a complete list of InsertCommand class members, see the InsertCommand Members topic.

Public Instance Properties

ParameterNamesDelegate (inherited from Command) | Gets/sets the method that parses the Query for all contained Parameters.
Parameters (inherited from Command) | Gets/sets the collection of Parameters of this Command.
Query | Gets/sets the insert query.
TrimUnusedParameters (inherited from Command) | Gets/sets a value indicating whether Parameters that are not contained in the Query should be ignored. Default = false.

See Also

InsertCommand Class | Deag.Vdx.Server.DAL.Commands Namespace | SQLDataAccessQuery

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


InsertCommand.Query Property

Gets/sets the insert query.

new public string Query {get; set;}

See Also

InsertCommand Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterMapping Class

Maps a vdxServer Parameter name to a DB parameter name.

For a list of all members of this type, see ParameterMapping Members.

System.Object
ParameterMapping

public class ParameterMapping

Remarks

SelectCommandDynamicWhere commands use ParameterMappings to map the names of the Parameters used in the middle tier to the names of the columns in the data base.

Requirements

Namespace: Deag.Vdx.Server.DAL.Commands

Assembly: vdxServer (in vdxServer.dll)

See Also

ParameterMapping Members | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterMapping Members

ParameterMapping overview

Public Instance Constructors

ParameterMapping Overloaded. Initializes a new instance of the ParameterMapping class.

Public Instance Properties

Destination | Name of the DB parameter.
Source | Name of the vdxServer Parameter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParameterMapping Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterMapping Constructor

Iniitlaizes a new instance of the ParameterMapping class.

Overload List

Iniitlaizes a new instance of the ParameterMapping class.

public ParameterMapping();

Iniitlaizes a new instance of the ParameterMapping class using the specified source and destination names.

public ParameterMapping(string,string);

See Also

ParameterMapping Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterMapping Constructor ()

Iniitlaizes a new instance of the ParameterMapping class.

public ParameterMapping();

See Also

ParameterMapping Class | Deag.Vdx.Server.DAL.Commands Namespace | ParameterMapping Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterMapping Constructor (String, String)

Iniitlaizes a new instance of the ParameterMapping class using the specified source and destination names.

public ParameterMapping(
string source,
string destination
);

Parameters

source
Name of the vdxServer Parameter name.
destination
Name of the parameter in the DB.

See Also

ParameterMapping Class | Deag.Vdx.Server.DAL.Commands Namespace | ParameterMapping Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterMapping Properties

The properties of the ParameterMapping class are listed below. For a complete list of ParameterMapping class members, see the ParameterMapping Members topic.

Public Instance Properties

Destination | Name of the DB parameter.
Source | Name of the vdxServer Parameter.

See Also

ParameterMapping Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterMapping.Destination Property

Name of the DB parameter.

public string Destination {get; set;}

See Also

ParameterMapping Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterMapping.Source Property

Name of the vdxServer Parameter.

public string Source {get; set;}

See Also

ParameterMapping Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterMappingCollection Class

A collection ParameterMappings.

For a list of all members of this type, see ParameterMappingCollection Members.

System.Object
CollectionBase
ParameterMappingCollection

public class ParameterMappingCollection : CollectionBase

Requirements

Namespace: Deag.Vdx.Server.DAL.Commands

Assembly: vdxServer (in vdxServer.dll)

See Also

ParameterMappingCollection Members | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterMappingCollection Members

ParameterMappingCollection overview

Public Instance Constructors

ParameterMappingCollection Constructor Initializes a new instance of the ParameterMappingCollection class.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Returns the ParameterMapping at the specified index.

Public Instance Methods

Add | Adds a ParameterMapping to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Removes a ParameterMapping from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ParameterMappingCollection Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterMappingCollection Constructor

Initializes a new instance of the ParameterMappingCollection class.

public ParameterMappingCollection();

See Also

ParameterMappingCollection Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterMappingCollection Properties

The properties of the ParameterMappingCollection class are listed below. For a complete list of ParameterMappingCollection class members, see the ParameterMappingCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Returns the ParameterMapping at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

ParameterMappingCollection Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterMappingCollection.Item Property

Returns the ParameterMapping at the specified index.

public ParameterMapping this[
int index
] {get;}

See Also

ParameterMappingCollection Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterMappingCollection Methods

The methods of the ParameterMappingCollection class are listed below. For a complete list of ParameterMappingCollection class members, see the ParameterMappingCollection Members topic.

Public Instance Methods

Add | Adds a ParameterMapping to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Removes a ParameterMapping from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

ParameterMappingCollection Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterMappingCollection.Add Method

Adds a ParameterMapping to the collection.

public void Add(
ParameterMapping mapping
);

Parameters

mapping
The added ParameterMapping.

See Also

ParameterMappingCollection Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ParameterMappingCollection.Remove Method

Removes a ParameterMapping from the collection.

public void Remove(
ParameterMapping mapping
);

Parameters

mapping
The removed ParameterMapping.

See Also

ParameterMappingCollection Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommand Class

A select command is used the read data from the storage.

For a list of all members of this type, see SelectCommand Members.

System.Object
Command
SelectCommandBase
SelectCommand

public sealed class SelectCommand : SelectCommandBase

Remarks

SQLDataAccess objects use SelectCommands for reading data from the data base. An select command knows only a query string that will be executed. Use this class when you have a static SELECT query or you want to build your query programmatically on your own. Otherwise have a look at SelectCommandWhereTerms, SelectCommandDynamicWhere and SelectCommandNWheres.

Requirements

Namespace: Deag.Vdx.Server.DAL.Commands

Assembly: vdxServer (in vdxServer.dll)

See Also

SelectCommand Members | Deag.Vdx.Server.DAL.Commands Namespace | SelectCommandWhereTerms | SelectCommandDynamicWhere | SelectCommandNWheres

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommand Members

SelectCommand overview

Public Instance Constructors

SelectCommand Overloaded. Initializes a new instance of the SelectCommand class.

Public Instance Properties

ParameterNamesDelegate (inherited from Command) | Gets/sets the method that parses the Query for all contained Parameters.
Parameters (inherited from Command) | Gets/sets the collection of Parameters of this Command.
Query | Gets/sets the query of the select command.
TrimUnusedParameters (inherited from Command) | Gets/sets a value indicating whether Parameters that are not contained in the Query should be ignored. Default = false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameters (inherited from Command) | Return the collection of Parameters.
GetType (inherited from Object) | Gets the Type of the current instance.
RefreshQuery | Refreshes the query depending on the Parameters that were passed to the command.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

query (inherited from Command) Query string des Commands. Wird dem SqlCommand als CommandText übergeben

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
TrimParameters (inherited from Command) | Removes all Parameters from Parameters that are not contained in the Query.

Protected Internal Instance Methods

ReplaceParameters (inherited from SelectCommandBase) Replaces all parameter "#@paramName" with "operator @paramName" in the Query. @ stands for the storage dependent parameter prefix.

See Also

SelectCommand Class | Deag.Vdx.Server.DAL.Commands Namespace | SelectCommandWhereTerms | SelectCommandDynamicWhere | SelectCommandNWheres

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommand Constructor

Initializes a new instance of the SelectCommand class.

Overload List

Initializes a new instance of the SelectCommand class.

public SelectCommand();

Initializes a new instance of the SelectCommand class using the specified query.

public SelectCommand(string);

See Also

SelectCommand Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommand Constructor ()

Initializes a new instance of the SelectCommand class.

public SelectCommand();

See Also

SelectCommand Class | Deag.Vdx.Server.DAL.Commands Namespace | SelectCommand Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommand Constructor (String)

Initializes a new instance of the SelectCommand class using the specified query.

public SelectCommand(
string query
);

Parameters

query
The query to initialize the SelectCommand.

See Also

SelectCommand Class | Deag.Vdx.Server.DAL.Commands Namespace | SelectCommand Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommand Properties

The properties of the SelectCommand class are listed below. For a complete list of SelectCommand class members, see the SelectCommand Members topic.

Public Instance Properties

ParameterNamesDelegate (inherited from Command) | Gets/sets the method that parses the Query for all contained Parameters.
Parameters (inherited from Command) | Gets/sets the collection of Parameters of this Command.
Query | Gets/sets the query of the select command.
TrimUnusedParameters (inherited from Command) | Gets/sets a value indicating whether Parameters that are not contained in the Query should be ignored. Default = false.

See Also

SelectCommand Class | Deag.Vdx.Server.DAL.Commands Namespace | SelectCommandWhereTerms | SelectCommandDynamicWhere | SelectCommandNWheres

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommand.Query Property

Gets/sets the query of the select command.

new public string Query {get; set;}

See Also

SelectCommand Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommand Methods

The methods of the SelectCommand class are listed below. For a complete list of SelectCommand class members, see the SelectCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameters (inherited from Command) | Return the collection of Parameters.
GetType (inherited from Object) | Gets the Type of the current instance.
RefreshQuery | Refreshes the query depending on the Parameters that were passed to the command.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
TrimParameters (inherited from Command) | Removes all Parameters from Parameters that are not contained in the Query.

Protected Internal Instance Methods

ReplaceParameters (inherited from SelectCommandBase) Replaces all parameter "#@paramName" with "operator @paramName" in the Query. @ stands for the storage dependent parameter prefix.

See Also

SelectCommand Class | Deag.Vdx.Server.DAL.Commands Namespace | SelectCommandWhereTerms | SelectCommandDynamicWhere | SelectCommandNWheres

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommand.RefreshQuery Method

Refreshes the query depending on the Parameters that were passed to the command.

public override void RefreshQuery();

See Also

SelectCommand Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandBase Class

Base class for all select commands.

For a list of all members of this type, see SelectCommandBase Members.

System.Object
Command
SelectCommandBase

public class SelectCommandBase : Command

Remarks

The SelectCommandBase class implements the functionality to replace the # in the select query with the operator corresponding to the used Filter.

Requirements

Namespace: Deag.Vdx.Server.DAL.Commands

Assembly: vdxServer (in vdxServer.dll)

See Also

SelectCommandBase Members | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandBase Members

SelectCommandBase overview

Public Instance Constructors

SelectCommandBase Constructor Initializes a new instance of the SelectCommandBase class.

Public Instance Properties

ParameterNamesDelegate (inherited from Command) | Gets/sets the method that parses the Query for all contained Parameters.
Parameters (inherited from Command) | Gets/sets the collection of Parameters of this Command.
Query (inherited from Command) | Gets the query of the Command.
TrimUnusedParameters (inherited from Command) | Gets/sets a value indicating whether Parameters that are not contained in the Query should be ignored. Default = false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameters (inherited from Command) | Return the collection of Parameters.
GetType (inherited from Object) | Gets the Type of the current instance.
RefreshQuery (inherited from Command) | Refreshes the Query of the Command.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

query (inherited from Command) Query string des Commands. Wird dem SqlCommand als CommandText übergeben

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
TrimParameters (inherited from Command) | Removes all Parameters from Parameters that are not contained in the Query.

Protected Internal Instance Methods

ReplaceParameters Replaces all parameter "#@paramName" with "operator @paramName" in the Query. @ stands for the storage dependent parameter prefix.

See Also

SelectCommandBase Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandBase Constructor

Initializes a new instance of the SelectCommandBase class.

public SelectCommandBase();

See Also

SelectCommandBase Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandBase Methods

The methods of the SelectCommandBase class are listed below. For a complete list of SelectCommandBase class members, see the SelectCommandBase Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameters (inherited from Command) | Return the collection of Parameters.
GetType (inherited from Object) | Gets the Type of the current instance.
RefreshQuery (inherited from Command) | Refreshes the Query of the Command.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
TrimParameters (inherited from Command) | Removes all Parameters from Parameters that are not contained in the Query.

Protected Internal Instance Methods

ReplaceParameters Replaces all parameter "#@paramName" with "operator @paramName" in the Query. @ stands for the storage dependent parameter prefix.

See Also

SelectCommandBase Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandBase.ReplaceParameters Method

Replaces all parameter "#@paramName" with "operator @paramName" in the Query. @ stands for the storage dependent parameter prefix.

protected internal void ReplaceParameters();

Remarks

This method is called to set the operator according to the used filter type.

See Also

SelectCommandBase Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandDynamicWhere Class

Select command with a dynamic where clause

For a list of all members of this type, see SelectCommandDynamicWhere Members.

System.Object
Command
SelectCommandBase
SelectCommandDynamicWhere

public class SelectCommandDynamicWhere : SelectCommandBase

Remarks

A SelectCommandDynamicWhere can be used in the case where you have a lot of combinations of Parameters that can be passed to your SelectCommand. The where clause is created dynamically by adding all Parameters given to this command that are defined in the ParameterMapping.

Requirements

Namespace: Deag.Vdx.Server.DAL.Commands

Assembly: vdxServer (in vdxServer.dll)

See Also

SelectCommandDynamicWhere Members | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandDynamicWhere Members

SelectCommandDynamicWhere overview

Public Instance Constructors

SelectCommandDynamicWhere Constructor Kreiert ein Select Command für dynamische Wheres

Public Instance Properties

Operator | Gets/sets the operator to join the where terms. Default value = AND
OrderBy | The part after the generated where clause.
ParameterMapping | Gets/Sets the parameter mappings.
ParameterNamesDelegate (inherited from Command) | Gets/sets the method that parses the Query for all contained Parameters.
Parameters (inherited from Command) | Gets/sets the collection of Parameters of this Command.
Query (inherited from Command) | Gets the query of the Command.
Statement | The part of the query in front of the generated where clause (without "WHERE").
TrimUnusedParameters (inherited from Command) | Gets/sets a value indicating whether Parameters that are not contained in the Query should be ignored. Default = false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameters (inherited from Command) | Return the collection of Parameters.
GetType (inherited from Object) | Gets the Type of the current instance.
RefreshQuery | Refreshes the query by generating the dynamic where.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

query (inherited from Command) Query string des Commands. Wird dem SqlCommand als CommandText übergeben

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
TrimParameters (inherited from Command) | Removes all Parameters from Parameters that are not contained in the Query.

Protected Internal Instance Methods

ReplaceParameters (inherited from SelectCommandBase) Replaces all parameter "#@paramName" with "operator @paramName" in the Query. @ stands for the storage dependent parameter prefix.

See Also

SelectCommandDynamicWhere Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandDynamicWhere Constructor

Kreiert ein Select Command für dynamische Wheres

public SelectCommandDynamicWhere();

See Also

SelectCommandDynamicWhere Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandDynamicWhere Properties

The properties of the SelectCommandDynamicWhere class are listed below. For a complete list of SelectCommandDynamicWhere class members, see the SelectCommandDynamicWhere Members topic.

Public Instance Properties

Operator | Gets/sets the operator to join the where terms. Default value = AND
OrderBy | The part after the generated where clause.
ParameterMapping | Gets/Sets the parameter mappings.
ParameterNamesDelegate (inherited from Command) | Gets/sets the method that parses the Query for all contained Parameters.
Parameters (inherited from Command) | Gets/sets the collection of Parameters of this Command.
Query (inherited from Command) | Gets the query of the Command.
Statement | The part of the query in front of the generated where clause (without "WHERE").
TrimUnusedParameters (inherited from Command) | Gets/sets a value indicating whether Parameters that are not contained in the Query should be ignored. Default = false.

See Also

SelectCommandDynamicWhere Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandDynamicWhere.Operator Property

Gets/sets the operator to join the where terms. Default value = AND

public SelectCommandDynamicWhere.WhereOp Operator {get; set;}

See Also

SelectCommandDynamicWhere Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandDynamicWhere.OrderBy Property

The part after the generated where clause.

public string OrderBy {get; set;}

See Also

SelectCommandDynamicWhere Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandDynamicWhere.ParameterMapping Property

Gets/Sets the parameter mappings.

public ParameterMappingCollection ParameterMapping {get; set;}

See Also

SelectCommandDynamicWhere Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandDynamicWhere.Statement Property

The part of the query in front of the generated where clause (without "WHERE").

public string Statement {get; set;}

See Also

SelectCommandDynamicWhere Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandDynamicWhere Methods

The methods of the SelectCommandDynamicWhere class are listed below. For a complete list of SelectCommandDynamicWhere class members, see the SelectCommandDynamicWhere Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameters (inherited from Command) | Return the collection of Parameters.
GetType (inherited from Object) | Gets the Type of the current instance.
RefreshQuery | Refreshes the query by generating the dynamic where.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
TrimParameters (inherited from Command) | Removes all Parameters from Parameters that are not contained in the Query.

Protected Internal Instance Methods

ReplaceParameters (inherited from SelectCommandBase) Replaces all parameter "#@paramName" with "operator @paramName" in the Query. @ stands for the storage dependent parameter prefix.

See Also

SelectCommandDynamicWhere Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandDynamicWhere.RefreshQuery Method

Refreshes the query by generating the dynamic where.

public override void RefreshQuery();

See Also

SelectCommandDynamicWhere Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandDynamicWhere.WhereOp Enumeration

The Operator used in the dynamic where clause.

public enum SelectCommandDynamicWhere.WhereOp

Members

Member Name | Description
AND | Join operands with 'AND'.
OR | Join operands with 'OR'.

Requirements

Namespace: Deag.Vdx.Server.DAL.Commands

Assembly: vdxServer (in vdxServer.dll)

See Also

Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandNWheres Class

A SelectCommandBase with multiple WhereClauses.

For a list of all members of this type, see SelectCommandNWheres Members.

System.Object
Command
SelectCommandBase
SelectCommandNWheres

public class SelectCommandNWheres : SelectCommandBase

Remarks

From the collection of WhereClauses the where clause is chosen that matchs best the collection of Parameters that were assigned to the SelectCommandNWheres. If no where clause can be used then a vdxWhereClauseException is thrown. You can specify a specific where clause by its Key that will be used instead of the one selected by the framework.

Requirements

Namespace: Deag.Vdx.Server.DAL.Commands

Assembly: vdxServer (in vdxServer.dll)

See Also

SelectCommandNWheres Members | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandNWheres Members

SelectCommandNWheres overview

Public Instance Constructors

SelectCommandNWheres Constructor Initializes a new instance of the SelectCommandNWheres class.

Public Instance Properties

ActiveWhereKey | Gets/sets a specific WhereClause (Key) that should be used instead of the where clause selected by the framework.
AllowEmptyWhere | Whether no where clause is allowed if there is no executable WhereClause. Default value = false
OrderBy | Gets/sets the part of the query after the WHERE part.
ParameterNamesDelegate (inherited from Command) | Gets/sets the method that parses the Query for all contained Parameters.
Parameters (inherited from Command) | Gets/sets the collection of Parameters of this Command.
Query (inherited from Command) | Gets the query of the Command.
Statement | Gets/sets the part of the query in front of the WHERE part.
TrimUnusedParameters (inherited from Command) | Gets/sets a value indicating whether Parameters that are not contained in the Query should be ignored. Default = false.
Wheres | Gets the collection of WhereClauses for this select command.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameters (inherited from Command) | Return the collection of Parameters.
GetType (inherited from Object) | Gets the Type of the current instance.
RefreshQuery | Refreshes the query depending of the Parameters that were given to this object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

query (inherited from Command) Query string des Commands. Wird dem SqlCommand als CommandText übergeben

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
TrimParameters (inherited from Command) | Removes all Parameters from Parameters that are not contained in the Query.

Protected Internal Instance Methods

ReplaceParameters (inherited from SelectCommandBase) Replaces all parameter "#@paramName" with "operator @paramName" in the Query. @ stands for the storage dependent parameter prefix.

See Also

SelectCommandNWheres Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandNWheres Constructor

Initializes a new instance of the SelectCommandNWheres class.

public SelectCommandNWheres();

See Also

SelectCommandNWheres Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandNWheres Properties

The properties of the SelectCommandNWheres class are listed below. For a complete list of SelectCommandNWheres class members, see the SelectCommandNWheres Members topic.

Public Instance Properties

ActiveWhereKey | Gets/sets a specific WhereClause (Key) that should be used instead of the where clause selected by the framework.
AllowEmptyWhere | Whether no where clause is allowed if there is no executable WhereClause. Default value = false
OrderBy | Gets/sets the part of the query after the WHERE part.
ParameterNamesDelegate (inherited from Command) | Gets/sets the method that parses the Query for all contained Parameters.
Parameters (inherited from Command) | Gets/sets the collection of Parameters of this Command.
Query (inherited from Command) | Gets the query of the Command.
Statement | Gets/sets the part of the query in front of the WHERE part.
TrimUnusedParameters (inherited from Command) | Gets/sets a value indicating whether Parameters that are not contained in the Query should be ignored. Default = false.
Wheres | Gets the collection of WhereClauses for this select command.

See Also

SelectCommandNWheres Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandNWheres.ActiveWhereKey Property

Gets/sets a specific WhereClause (Key) that should be used instead of the where clause selected by the framework.

public string ActiveWhereKey {get; set;}

Remarks

You can use this property in the case if the framework does not select the WhereClause you wish.

See Also

SelectCommandNWheres Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandNWheres.AllowEmptyWhere Property

Whether no where clause is allowed if there is no executable WhereClause. Default value = false

public bool AllowEmptyWhere {get; set;}

Remarks

If no executable WhereClause exists then no where clause is used if this property is set to true. Otherwise an vdxWhereClauseException is thrown.

See Also

SelectCommandNWheres Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandNWheres.OrderBy Property

Gets/sets the part of the query after the WHERE part.

public string OrderBy {get; set;}

See Also

SelectCommandNWheres Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandNWheres.Statement Property

Gets/sets the part of the query in front of the WHERE part.

public string Statement {get; set;}

See Also

SelectCommandNWheres Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandNWheres.Wheres Property

Gets the collection of WhereClauses for this select command.

public WhereClauseCollection Wheres {get;}

See Also

SelectCommandNWheres Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandNWheres Methods

The methods of the SelectCommandNWheres class are listed below. For a complete list of SelectCommandNWheres class members, see the SelectCommandNWheres Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameters (inherited from Command) | Return the collection of Parameters.
GetType (inherited from Object) | Gets the Type of the current instance.
RefreshQuery | Refreshes the query depending of the Parameters that were given to this object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
TrimParameters (inherited from Command) | Removes all Parameters from Parameters that are not contained in the Query.

Protected Internal Instance Methods

ReplaceParameters (inherited from SelectCommandBase) Replaces all parameter "#@paramName" with "operator @paramName" in the Query. @ stands for the storage dependent parameter prefix.

See Also

SelectCommandNWheres Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandNWheres.RefreshQuery Method

Refreshes the query depending of the Parameters that were given to this object.

public override void RefreshQuery();

Remarks

All WhereClauses in the WhereClauseCollection are testet whether they can be used, i.e. that all needed Parameters are present. From all executable WhereClauses the one is chosen that with the highest number of matching parameters. If there is not a "best" where clause then a vdxWhereClauseException is thrown.

See Also

SelectCommandNWheres Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandWhereTerms Class

A select command that uses a where clause that is composed of 'terms'. A term is taken if all the contained Parameters are present, i.e. they were passed to the command.

For a list of all members of this type, see SelectCommandWhereTerms Members.

System.Object
Command
SelectCommandBase
SelectCommandWhereTerms

public class SelectCommandWhereTerms : SelectCommandBase

Remarks

You can use this select command to build very complex where clauses. When the query of theis command is refreshed (by a call to RefreshQuery) from the outside (this is normally done by a DataAccess) then all Terms are parsed for parameters. If all parameters of a term were assigned to the command (Parameters, normally set by a data access object) then this terms is included in the WHERE clause. The resulting WHERE clause is appended to the Statement and the OrderBy part is appended, too.

Example

The following example shows how a SelectCommandWhereTerms can be used together with an DataAccess for MS SQL Server. The shown data access is able to read persons from the table 'person' either by name, prename or by town and country; or by a combination of this three terms. The terms for 'name' and 'prename' use dynamic operators (#). The # is replaced by the operation the corresponds to the Filter that is set in the according parameter. In the AdaptSqlParameters method the types of the parameters in the data base are set.

            public class DAPerson : DataAccess
            {
                public DAPerson()
                {
                    SelectCommandWhereTerms sc = new SelectCommandWhereTerms(
                        "SELECT * FROM Person");

                    sc.Terms.Add("Name #@Name");
                    sc.Terms.Add("Prename #@Prename");
                    sc.Terms.Add("Town = @Town AND Country = @Country");
                    sc.OrderBy = "Name";
                    SqlSelect = sc;
                }

                protected override void AdaptSqlParameters(System.Data.SqlClient.SqlParameterCollection sqlParameters, Deag.Vdx.Server.DAL.Commands.CommandType commandType)
                {
                    TransformParameter("Name",		SqlDbType.VarChar);
                    TransformParameter("Prename",	SqlDbType.VarChar);
                    TransformParameter("Town",		SqlDbType.VarChar, 40);
                    TransformParameter("Country",	SqlDbType.VarChar, 50);
                }

Requirements

Namespace: Deag.Vdx.Server.DAL.Commands

Assembly: vdxServer (in vdxServer.dll)

See Also

SelectCommandWhereTerms Members | Deag.Vdx.Server.DAL.Commands Namespace | Filter

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandWhereTerms Members

SelectCommandWhereTerms overview

Public Instance Constructors

SelectCommandWhereTerms Overloaded. Initializes a new instance of the SelectCommandWhereTerms class.

Public Instance Properties

Operator | Gets/sets the operator to link the where terms.
OrderBy | Gets/sets the ORDERBY part of the query
ParameterNamesDelegate (inherited from Command) | Gets/sets the method that parses the Query for all contained Parameters.
Parameters (inherited from Command) | Gets/sets the collection of Parameters of this Command.
Query (inherited from Command) | Gets the query of the Command.
Statement | Gets/sets the SELECT part of the query.
Terms | Gets the collection of where terms of whom the where clause is built.
TrimUnusedParameters (inherited from Command) | Gets/sets a value indicating whether Parameters that are not contained in the Query should be ignored. Default = false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameters (inherited from Command) | Return the collection of Parameters.
GetType (inherited from Object) | Gets the Type of the current instance.
RefreshQuery | Refreshes the query depending on the Parameters that were passed to the command.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

query (inherited from Command) Query string des Commands. Wird dem SqlCommand als CommandText übergeben

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
TrimParameters (inherited from Command) | Removes all Parameters from Parameters that are not contained in the Query.

Protected Internal Instance Methods

ReplaceParameters (inherited from SelectCommandBase) Replaces all parameter "#@paramName" with "operator @paramName" in the Query. @ stands for the storage dependent parameter prefix.

See Also

SelectCommandWhereTerms Class | Deag.Vdx.Server.DAL.Commands Namespace | Filter

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandWhereTerms Constructor

Initializes a new instance of the SelectCommandWhereTerms class.

Overload List

Initializes a new instance of the SelectCommandWhereTerms class.

public SelectCommandWhereTerms();

Initializes a new instance of the SelectCommandWhereTerms class with the specified statement.

public SelectCommandWhereTerms(string);

See Also

SelectCommandWhereTerms Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandWhereTerms Constructor ()

Initializes a new instance of the SelectCommandWhereTerms class.

public SelectCommandWhereTerms();

See Also

SelectCommandWhereTerms Class | Deag.Vdx.Server.DAL.Commands Namespace | SelectCommandWhereTerms Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandWhereTerms Constructor (String)

Initializes a new instance of the SelectCommandWhereTerms class with the specified statement.

public SelectCommandWhereTerms(
string statement
);

See Also

SelectCommandWhereTerms Class | Deag.Vdx.Server.DAL.Commands Namespace | SelectCommandWhereTerms Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandWhereTerms Properties

The properties of the SelectCommandWhereTerms class are listed below. For a complete list of SelectCommandWhereTerms class members, see the SelectCommandWhereTerms Members topic.

Public Instance Properties

Operator | Gets/sets the operator to link the where terms.
OrderBy | Gets/sets the ORDERBY part of the query
ParameterNamesDelegate (inherited from Command) | Gets/sets the method that parses the Query for all contained Parameters.
Parameters (inherited from Command) | Gets/sets the collection of Parameters of this Command.
Query (inherited from Command) | Gets the query of the Command.
Statement | Gets/sets the SELECT part of the query.
Terms | Gets the collection of where terms of whom the where clause is built.
TrimUnusedParameters (inherited from Command) | Gets/sets a value indicating whether Parameters that are not contained in the Query should be ignored. Default = false.

See Also

SelectCommandWhereTerms Class | Deag.Vdx.Server.DAL.Commands Namespace | Filter

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandWhereTerms.Operator Property

Gets/sets the operator to link the where terms.

public SelectCommandWhereTerms.WhereOp Operator {get; set;}

See Also

SelectCommandWhereTerms Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandWhereTerms.OrderBy Property

Gets/sets the ORDERBY part of the query

public string OrderBy {get; set;}

See Also

SelectCommandWhereTerms Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandWhereTerms.Statement Property

Gets/sets the SELECT part of the query.

public string Statement {get; set;}

See Also

SelectCommandWhereTerms Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandWhereTerms.Terms Property

Gets the collection of where terms of whom the where clause is built.

public System.Collections.Specialized.StringCollection Terms {get;}

See Also

SelectCommandWhereTerms Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandWhereTerms Methods

The methods of the SelectCommandWhereTerms class are listed below. For a complete list of SelectCommandWhereTerms class members, see the SelectCommandWhereTerms Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameters (inherited from Command) | Return the collection of Parameters.
GetType (inherited from Object) | Gets the Type of the current instance.
RefreshQuery | Refreshes the query depending on the Parameters that were passed to the command.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
TrimParameters (inherited from Command) | Removes all Parameters from Parameters that are not contained in the Query.

Protected Internal Instance Methods

ReplaceParameters (inherited from SelectCommandBase) Replaces all parameter "#@paramName" with "operator @paramName" in the Query. @ stands for the storage dependent parameter prefix.

See Also

SelectCommandWhereTerms Class | Deag.Vdx.Server.DAL.Commands Namespace | Filter

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandWhereTerms.RefreshQuery Method

Refreshes the query depending on the Parameters that were passed to the command.

public override void RefreshQuery();

Remarks

The where clause is generated from the terms that can be executed.

See Also

SelectCommandWhereTerms Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SelectCommandWhereTerms.WhereOp Enumeration

The operator to be used in the where clause between the different where clauses.

public enum SelectCommandWhereTerms.WhereOp

Members

Member Name | Description
AND | The operands are linked with the AND operator
OR | The operands are linked with the OR operator

Requirements

Namespace: Deag.Vdx.Server.DAL.Commands

Assembly: vdxServer (in vdxServer.dll)

See Also

Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


UpdateCommand Class

Used to update data into a storage using SQL.

For a list of all members of this type, see UpdateCommand Members.

System.Object
Command
UpdateCommand

public class UpdateCommand : Command

Remarks

SQLDataAccess objects use UpdateCommands for updating data in the data base. An update command knows only a query string that will be executed.

Requirements

Namespace: Deag.Vdx.Server.DAL.Commands

Assembly: vdxServer (in vdxServer.dll)

See Also

UpdateCommand Members | Deag.Vdx.Server.DAL.Commands Namespace | SQLDataAccessQuery

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


UpdateCommand Members

UpdateCommand overview

Public Instance Constructors

UpdateCommand Overloaded. Initializes a new instance of the UpdateCommand class.

Public Instance Properties

ParameterNamesDelegate (inherited from Command) | Gets/sets the method that parses the Query for all contained Parameters.
Parameters (inherited from Command) | Gets/sets the collection of Parameters of this Command.
Query | Gets/sets the update query.
TrimUnusedParameters (inherited from Command) | Gets/sets a value indicating whether Parameters that are not contained in the Query should be ignored. Default = false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameters (inherited from Command) | Return the collection of Parameters.
GetType (inherited from Object) | Gets the Type of the current instance.
RefreshQuery (inherited from Command) | Refreshes the Query of the Command.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

query (inherited from Command) Query string des Commands. Wird dem SqlCommand als CommandText übergeben

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
TrimParameters (inherited from Command) | Removes all Parameters from Parameters that are not contained in the Query.

See Also

UpdateCommand Class | Deag.Vdx.Server.DAL.Commands Namespace | SQLDataAccessQuery

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


UpdateCommand Constructor

Initializes a new instance of the UpdateCommand class.

Overload List

Initializes a new instance of the UpdateCommand class.

public UpdateCommand();

Initializes a new instance of the UpdateCommand class using the specified query.

public UpdateCommand(string);

See Also

UpdateCommand Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


UpdateCommand Constructor ()

Initializes a new instance of the UpdateCommand class.

public UpdateCommand();

See Also

UpdateCommand Class | Deag.Vdx.Server.DAL.Commands Namespace | UpdateCommand Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


UpdateCommand Constructor (String)

Initializes a new instance of the UpdateCommand class using the specified query.

public UpdateCommand(
string query
);

Parameters

query
The query.

See Also

UpdateCommand Class | Deag.Vdx.Server.DAL.Commands Namespace | UpdateCommand Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


UpdateCommand Properties

The properties of the UpdateCommand class are listed below. For a complete list of UpdateCommand class members, see the UpdateCommand Members topic.

Public Instance Properties

ParameterNamesDelegate (inherited from Command) | Gets/sets the method that parses the Query for all contained Parameters.
Parameters (inherited from Command) | Gets/sets the collection of Parameters of this Command.
Query | Gets/sets the update query.
TrimUnusedParameters (inherited from Command) | Gets/sets a value indicating whether Parameters that are not contained in the Query should be ignored. Default = false.

See Also

UpdateCommand Class | Deag.Vdx.Server.DAL.Commands Namespace | SQLDataAccessQuery

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


UpdateCommand.Query Property

Gets/sets the update query.

new public string Query {get; set;}

See Also

UpdateCommand Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WhereClause Class

A single where clause.

For a list of all members of this type, see WhereClause Members.

System.Object
WhereClause

public class WhereClause

Requirements

Namespace: Deag.Vdx.Server.DAL.Commands

Assembly: vdxServer (in vdxServer.dll)

See Also

WhereClause Members | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WhereClause Members

WhereClause overview

Public Instance Constructors

WhereClause Overloaded. Initializes a new instance of the WhereClause class.

Public Instance Properties

Key | The key idetifying the where clause.
Query | Where clause statement.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WhereClause Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WhereClause Constructor

Initializes a nes instance of the WhereClause class.

Overload List

Initializes a nes instance of the WhereClause class.

public WhereClause();

Initializes a new instance of the WhereClause class using the specified where clause.

public WhereClause(string);

Kreiert eine gefüllte Where-Klausel mit Key

public WhereClause(string,string);

See Also

WhereClause Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WhereClause Constructor ()

Initializes a nes instance of the WhereClause class.

public WhereClause();

See Also

WhereClause Class | Deag.Vdx.Server.DAL.Commands Namespace | WhereClause Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WhereClause Constructor (String)

Initializes a new instance of the WhereClause class using the specified where clause.

public WhereClause(
string query
);

Parameters

query
where clause (WHERE ...)

See Also

WhereClause Class | Deag.Vdx.Server.DAL.Commands Namespace | WhereClause Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WhereClause Constructor (String, String)

Kreiert eine gefüllte Where-Klausel mit Key

public WhereClause(
string key,
string query
);

Parameters

key
query

See Also

WhereClause Class | Deag.Vdx.Server.DAL.Commands Namespace | WhereClause Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WhereClause Properties

The properties of the WhereClause class are listed below. For a complete list of WhereClause class members, see the WhereClause Members topic.

Public Instance Properties

Key | The key idetifying the where clause.
Query | Where clause statement.

See Also

WhereClause Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WhereClause.Key Property

The key idetifying the where clause.

public string Key {get; set;}

See Also

WhereClause Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WhereClause.Query Property

Where clause statement.

public string Query {get; set;}

Remarks

This statement is appended to the Statement.

See Also

WhereClause Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WhereClauseCollection Class

Collection of WhereClauses

For a list of all members of this type, see WhereClauseCollection Members.

System.Object
CollectionBase
WhereClauseCollection

public class WhereClauseCollection : CollectionBase

Requirements

Namespace: Deag.Vdx.Server.DAL.Commands

Assembly: vdxServer (in vdxServer.dll)

See Also

WhereClauseCollection Members | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WhereClauseCollection Members

WhereClauseCollection overview

Public Instance Constructors

WhereClauseCollection Constructor Initializes a new instance of the WhereClauseCollection class.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Returns the WhereClause at the specified index.

Public Instance Methods

Add | Adds a WhereClause to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Returns a value indicating whether the a WhereClause is in the collection.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Removes a WhereClause from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

WhereClauseCollection Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WhereClauseCollection Constructor

Initializes a new instance of the WhereClauseCollection class.

public WhereClauseCollection();

See Also

WhereClauseCollection Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WhereClauseCollection Properties

The properties of the WhereClauseCollection class are listed below. For a complete list of WhereClauseCollection class members, see the WhereClauseCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Returns the WhereClause at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

WhereClauseCollection Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WhereClauseCollection.Item Property

Returns the WhereClause at the specified index.

public WhereClause this[
int index
] {get;}

See Also

WhereClauseCollection Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WhereClauseCollection Methods

The methods of the WhereClauseCollection class are listed below. For a complete list of WhereClauseCollection class members, see the WhereClauseCollection Members topic.

Public Instance Methods

Add | Adds a WhereClause to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Returns a value indicating whether the a WhereClause is in the collection.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Removes a WhereClause from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

Explicit Interface Implementations

ICollection.CopyTo (inherited from CollectionBase)
IList.Add (inherited from CollectionBase)
IList.Contains (inherited from CollectionBase)
IList.IndexOf (inherited from CollectionBase)
IList.Insert (inherited from CollectionBase)
IList.Remove (inherited from CollectionBase)

See Also

WhereClauseCollection Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WhereClauseCollection.Add Method

Adds a WhereClause to the collection.

public void Add(
WhereClause whereClause
);

Parameters

whereClause
The WhereClause to be added.

See Also

WhereClauseCollection Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WhereClauseCollection.Contains Method

Returns a value indicating whether the a WhereClause is in the collection.

public bool Contains(
WhereClause whereClause
);

Parameters

whereClause
The WhereClause to look for.

Return Value

Whether the passed WhereClause is part of the collection.

See Also

WhereClauseCollection Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


WhereClauseCollection.Remove Method

Removes a WhereClause from the collection.

public void Remove(
WhereClause whereClause
);

Parameters

whereClause
The WhereClause to be removed.

See Also

WhereClauseCollection Class | Deag.Vdx.Server.DAL.Commands Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Server.DAL.Filters

VDX Framework

Deag.Vdx.Server.DAL.Filters Namespace

The Deag.Vdx.Server.DAL.Filters namespace contains the storage independent Filters that are used within the middle tier.

Filters are used to combine a matching value together with a matching criteria (exact, contains, smaller, ...). Along with Parameters, which combine a filter with a name, filters are used to pass values between the data base independent part of the middle tier and the data base dependent (data access layer).

Classes

Class | Description
Filter | Base class for all filters
FilterBETWEEN | Filter class for finding data items that are between both the filter values.
FilterCONTAINS | Filter class for finding data items that contain the filter value.
FilterEQUAL | Filter class for finding/writing data items the are equal to the filter value.
FilterISNOTNULL | Filter class for testing against/setting not DBNull.
FilterISNULL | Filter class for testing against/setting DBNull.
FilterLARGERAS | Filter class for finding data items that are larger than the filter value.
FilterLARGEREQUALAS | Filter class for finding data items that are larger or equal than/to the filter value.
FilterNoValues | Base class for all filters that do not contain a value.
FilterOneValue | Base class for all filters that contain exactly one value.
FilterOUTPUT | Special filter class for return values.
FilterSMALLERAS | Filter class for finding data items that are smaller than the filter value.
FilterSMALLEREQUALAS | Filter class for finding data items that are smaller or equal than/to the filter value.
FilterSTARTWITH | Filter class for finding data items that start with the filter value.
FilterTwoValues | Base class for all filters that contain 2 values

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Filter Class

Base class for all filters

For a list of all members of this type, see Filter Members.

System.Object
Filter

public abstract class Filter

Remarks

Along with Parameters, filters are used for the communication between entities and DataAccess objects. Filters are used to define matching criterias and matching values. Each filter that is assigned to a parameter has that parameter as its Parent. This is used to access parameter information and to guarantee that a single filter can only belong to one parameter. When a Parameter is added to a DataAccess object (AddParameter) the DataAccess object converts the filter into the corresponding storage dependent filter (CreateStorageDependentFilter) and assigns it to the parameter. That means that from now on the parameter contains a storage dependent filter. However, because of the class hierarchy all entities can handle the filters/parameters as if there were storage independent. To make your query (especially your search criterias) depending on the type of the filter you can use the # syntax in your queries. The # will be replaced by the operator corresponding to the type of the filter. SelectCommand.

Requirements

Namespace: Deag.Vdx.Server.DAL.Filters

Assembly: vdxServer (in vdxServer.dll)

See Also

Filter Members | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Filter Members

Filter overview

Public Static Methods

CreateFilter | Overloaded. Creates a typed filter.
CreateFilterEQUAL | Creates an equal filter from a vdxSearchParameter.
CreateRangeFilter | Creates either a FilterSMALLEEQUALRAS, FilterBETWEEN or FilterLARGEREQUALAS depending on the existance of the specified search parameters.

Public Instance Properties

Parent The Parameter that contains this filter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetOperator | Returns a string containing the operator (defined by the filter type) and the parameter-name.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Filter Constructor Initializes a new instance of the Filter class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Filter Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Filter Constructor

Initializes a new instance of the Filter class.

protected Filter();

See Also

Filter Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Filter Properties

The properties of the Filter class are listed below. For a complete list of Filter class members, see the Filter Members topic.

Public Instance Properties

Parent The Parameter that contains this filter.

See Also

Filter Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Filter.Parent Property

The Parameter that contains this filter.

public Deag.Vdx.Server.DAL.Parameter Parent {get; set;}

Remarks

The Parent is used to access information about the parameter and to guarantee that a filter can only belong to one parameter.

See Also

Filter Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Filter Methods

The methods of the Filter class are listed below. For a complete list of Filter class members, see the Filter Members topic.

Public Static Methods

CreateFilter | Overloaded. Creates a typed filter.
CreateFilterEQUAL | Creates an equal filter from a vdxSearchParameter.
CreateRangeFilter | Creates either a FilterSMALLEEQUALRAS, FilterBETWEEN or FilterLARGEREQUALAS depending on the existance of the specified search parameters.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetOperator | Returns a string containing the operator (defined by the filter type) and the parameter-name.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Filter Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CreateFilter Method

VDX Framework

Filter.CreateFilter Method

Creates a typed filter from a vdxSearchParameter.

Overload List

Creates a typed filter from a vdxSearchParameter.

public static Filter CreateFilter(vdxSearchParameter);

Creates a typed filter from a vdxSearchParameter.

public static Filter CreateFilter(vdxSearchParameters,string);

Creates a typed filter.

public static Filter CreateFilter(Type,params object[]);

See Also

Filter Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Filter.CreateFilter Method (vdxSearchParameter)

Creates a typed filter from a vdxSearchParameter.

public static Filter CreateFilter(
vdxSearchParameter sp
);

Parameters

sp
The vdxSearchParameter.

Return Value

Filter

Remarks

The filter is created depending on the vdxSearchType of the vdxSearchParameter. If null is passed or the value of the SearchParameter is null then null is returned.

See Also

Filter Class | Deag.Vdx.Server.DAL.Filters Namespace | Filter.CreateFilter Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Filter.CreateFilter Method (vdxSearchParameters, String)

Creates a typed filter from a vdxSearchParameter.

public static Filter CreateFilter(
vdxSearchParameters sp,
string key
);

Parameters

sp
The collection of vdxSearchParameter.
key
The key of the vdxSearchParameter for that the filter is created.

Return Value

Filter

See Also

Filter Class | Deag.Vdx.Server.DAL.Filters Namespace | Filter.CreateFilter Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Filter.CreateFilter Method (Type, Object[])

Creates a typed filter.

public static Filter CreateFilter(
Type filtertype,
params object[] values
);

Parameters

filtertype
Type of the filter to create.
values
Values that are passed to the constructor of the created filter.

See Also

Filter Class | Deag.Vdx.Server.DAL.Filters Namespace | Filter.CreateFilter Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Filter.CreateFilterEQUAL Method

Creates an equal filter from a vdxSearchParameter.

public static FilterEQUAL CreateFilterEQUAL(
vdxSearchParameters sps,
string key
);

Parameters

sps
key

Return Value

See Also

Filter Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Filter.CreateRangeFilter Method

Creates either a FilterSMALLEEQUALRAS, FilterBETWEEN or FilterLARGEREQUALAS depending on the existance of the specified search parameters.

public static Filter CreateRangeFilter(
vdxSearchParameters sps,
string spFromKey,
string spToKey
);

Parameters

sps
The collection of search parameters.
spFromKey
The name of the search parameter to be used a "from".
spToKey
The name of the search parameter to be used a "to".

Return Value

A range filter.

See Also

Filter Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Filter.GetOperator Method

Returns a string containing the operator (defined by the filter type) and the parameter-name.

public virtual string GetOperator();

Return Value

The concatenation of the operator, parameter prefix and parametername

Remarks

If a query (assumed you use string queries to communicate with your storage) contains a parameter placeholder with a leading '#' then the framework inserts the operator for this occurence of the parameter.

Example

In the query "SELECT * FROM Person WHERE Age #@ParamAge" the "#@ParamAge" will be replaced with "SMALLER AS @ParamAge" if the Parameter "ParamAge" contains a "smaller as" filter.

See Also

Filter Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterBETWEEN Class

Filter class for finding data items that are between both the filter values.

For a list of all members of this type, see FilterBETWEEN Members.

System.Object
Filter
FilterTwoValues
FilterBETWEEN

public class FilterBETWEEN : FilterTwoValues

Requirements

Namespace: Deag.Vdx.Server.DAL.Filters

Assembly: vdxServer (in vdxServer.dll)

See Also

FilterBETWEEN Members | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterBETWEEN Members

FilterBETWEEN overview

Public Instance Constructors

FilterBETWEEN Constructor Initializes a new instance of the FilterBETWEEN class with the specified values.

Public Instance Properties

From | Gets/sets the start value of the allowed range.
Parent (inherited from Filter) | The Parameter that contains this filter.
To | Gets/sets the end value of the allowed range.
Value1 (inherited from FilterTwoValues) | Gets/sets the first value of the filter.
Value2 (inherited from FilterTwoValues) | Gets/sets the second value of the filter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetOperator (inherited from Filter) | Returns a string containing the operator (defined by the filter type) and the parameter-name.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterBETWEEN Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterBETWEEN Constructor

Initializes a new instance of the FilterBETWEEN class with the specified values.

public FilterBETWEEN(
object from,
object to
);

See Also

FilterBETWEEN Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterBETWEEN Properties

The properties of the FilterBETWEEN class are listed below. For a complete list of FilterBETWEEN class members, see the FilterBETWEEN Members topic.

Public Instance Properties

From | Gets/sets the start value of the allowed range.
Parent (inherited from Filter) | The Parameter that contains this filter.
To | Gets/sets the end value of the allowed range.
Value1 (inherited from FilterTwoValues) | Gets/sets the first value of the filter.
Value2 (inherited from FilterTwoValues) | Gets/sets the second value of the filter.

See Also

FilterBETWEEN Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterBETWEEN.From Property

Gets/sets the start value of the allowed range.

public object From {get; set;}

See Also

FilterBETWEEN Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterBETWEEN.To Property

Gets/sets the end value of the allowed range.

public object To {get; set;}

See Also

FilterBETWEEN Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterCONTAINS Class

Filter class for finding data items that contain the filter value.

For a list of all members of this type, see FilterCONTAINS Members.

System.Object
Filter
FilterOneValue
FilterCONTAINS

public class FilterCONTAINS : FilterOneValue

Requirements

Namespace: Deag.Vdx.Server.DAL.Filters

Assembly: vdxServer (in vdxServer.dll)

See Also

FilterCONTAINS Members | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterCONTAINS Members

FilterCONTAINS overview

Public Instance Constructors

FilterCONTAINS Overloaded. Initializes a new instance of the FilterCONTAINS class.

Public Instance Properties

Parent (inherited from Filter) | The Parameter that contains this filter.
Value (inherited from FilterOneValue) | Gets/sets the value of the filter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetOperator (inherited from Filter) | Returns a string containing the operator (defined by the filter type) and the parameter-name.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterCONTAINS Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterCONTAINS Constructor

Initializes a new instance of the FilterCONTAINS class.

Overload List

Initializes a new instance of the FilterCONTAINS class.

public FilterCONTAINS();

Initializes a new instance of the FilterCONTAINS class with the specified value.

public FilterCONTAINS(object);

See Also

FilterCONTAINS Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterCONTAINS Constructor ()

Initializes a new instance of the FilterCONTAINS class.

public FilterCONTAINS();

See Also

FilterCONTAINS Class | Deag.Vdx.Server.DAL.Filters Namespace | FilterCONTAINS Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterCONTAINS Constructor (Object)

Initializes a new instance of the FilterCONTAINS class with the specified value.

public FilterCONTAINS(
object filterValue
);

See Also

FilterCONTAINS Class | Deag.Vdx.Server.DAL.Filters Namespace | FilterCONTAINS Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterEQUAL Class

Filter class for finding/writing data items the are equal to the filter value.

For a list of all members of this type, see FilterEQUAL Members.

System.Object
Filter
FilterOneValue
FilterEQUAL

public class FilterEQUAL : FilterOneValue

Requirements

Namespace: Deag.Vdx.Server.DAL.Filters

Assembly: vdxServer (in vdxServer.dll)

See Also

FilterEQUAL Members | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterEQUAL Members

FilterEQUAL overview

Public Instance Constructors

FilterEQUAL Overloaded. Initializes a new instance of the FilterEQUAL class.

Public Instance Properties

Parent (inherited from Filter) | The Parameter that contains this filter.
Value (inherited from FilterOneValue) | Gets/sets the value of the filter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetOperator (inherited from Filter) | Returns a string containing the operator (defined by the filter type) and the parameter-name.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterEQUAL Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterEQUAL Constructor

Initializes a new instance of the FilterEQUAL class.

Overload List

Initializes a new instance of the FilterEQUAL class.

public FilterEQUAL();

Initializes a new instance of the FilterEQUAL class with the specified value.

public FilterEQUAL(object);

See Also

FilterEQUAL Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterEQUAL Constructor ()

Initializes a new instance of the FilterEQUAL class.

public FilterEQUAL();

See Also

FilterEQUAL Class | Deag.Vdx.Server.DAL.Filters Namespace | FilterEQUAL Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterEQUAL Constructor (Object)

Initializes a new instance of the FilterEQUAL class with the specified value.

public FilterEQUAL(
object filterValue
);

See Also

FilterEQUAL Class | Deag.Vdx.Server.DAL.Filters Namespace | FilterEQUAL Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterISNOTNULL Class

Filter class for testing against/setting not DBNull.

For a list of all members of this type, see FilterISNOTNULL Members.

System.Object
Filter
FilterNoValues
FilterISNOTNULL

public class FilterISNOTNULL : FilterNoValues

Requirements

Namespace: Deag.Vdx.Server.DAL.Filters

Assembly: vdxServer (in vdxServer.dll)

See Also

FilterISNOTNULL Members | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterISNOTNULL Members

FilterISNOTNULL overview

Public Instance Constructors

FilterISNOTNULL Constructor Initializes a new instance of the FilterISNOTNULL class.

Public Instance Properties

Parent (inherited from Filter) The Parameter that contains this filter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetOperator (inherited from Filter) | Returns a string containing the operator (defined by the filter type) and the parameter-name.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterISNOTNULL Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterISNOTNULL Constructor

Initializes a new instance of the FilterISNOTNULL class.

public FilterISNOTNULL();

See Also

FilterISNOTNULL Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterISNULL Class

Filter class for testing against/setting DBNull.

For a list of all members of this type, see FilterISNULL Members.

System.Object
Filter
FilterNoValues
FilterISNULL

public class FilterISNULL : FilterNoValues

Requirements

Namespace: Deag.Vdx.Server.DAL.Filters

Assembly: vdxServer (in vdxServer.dll)

See Also

FilterISNULL Members | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterISNULL Members

FilterISNULL overview

Public Instance Constructors

FilterISNULL Constructor Initializes a new instance of the FilterISNULL class.

Public Instance Properties

Parent (inherited from Filter) The Parameter that contains this filter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetOperator (inherited from Filter) | Returns a string containing the operator (defined by the filter type) and the parameter-name.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterISNULL Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterISNULL Constructor

Initializes a new instance of the FilterISNULL class.

public FilterISNULL();

See Also

FilterISNULL Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterLARGERAS Class

Filter class for finding data items that are larger than the filter value.

For a list of all members of this type, see FilterLARGERAS Members.

System.Object
Filter
FilterOneValue
FilterLARGERAS

public class FilterLARGERAS : FilterOneValue

Requirements

Namespace: Deag.Vdx.Server.DAL.Filters

Assembly: vdxServer (in vdxServer.dll)

See Also

FilterLARGERAS Members | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterLARGERAS Members

FilterLARGERAS overview

Public Instance Constructors

FilterLARGERAS Overloaded. Initializes a new instance of the FilterLARGERAS class.

Public Instance Properties

Parent (inherited from Filter) | The Parameter that contains this filter.
Value (inherited from FilterOneValue) | Gets/sets the value of the filter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetOperator (inherited from Filter) | Returns a string containing the operator (defined by the filter type) and the parameter-name.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterLARGERAS Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterLARGERAS Constructor

Initializes a new instance of the FilterLARGERAS class.

Overload List

Initializes a new instance of the FilterLARGERAS class.

public FilterLARGERAS();

Initializes a new instance of the FilterLARGERAS class with the specified value.

public FilterLARGERAS(object);

See Also

FilterLARGERAS Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterLARGERAS Constructor ()

Initializes a new instance of the FilterLARGERAS class.

public FilterLARGERAS();

See Also

FilterLARGERAS Class | Deag.Vdx.Server.DAL.Filters Namespace | FilterLARGERAS Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterLARGERAS Constructor (Object)

Initializes a new instance of the FilterLARGERAS class with the specified value.

public FilterLARGERAS(
object filterValue
);

See Also

FilterLARGERAS Class | Deag.Vdx.Server.DAL.Filters Namespace | FilterLARGERAS Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterLARGEREQUALAS Class

Filter class for finding data items that are larger or equal than/to the filter value.

For a list of all members of this type, see FilterLARGEREQUALAS Members.

System.Object
Filter
FilterOneValue
FilterLARGEREQUALAS

public class FilterLARGEREQUALAS : FilterOneValue

Requirements

Namespace: Deag.Vdx.Server.DAL.Filters

Assembly: vdxServer (in vdxServer.dll)

See Also

FilterLARGEREQUALAS Members | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterLARGEREQUALAS Members

FilterLARGEREQUALAS overview

Public Instance Constructors

FilterLARGEREQUALAS Overloaded. Initializes a new instance of the FilterLARGEREQUALAS class.

Public Instance Properties

Parent (inherited from Filter) | The Parameter that contains this filter.
Value (inherited from FilterOneValue) | Gets/sets the value of the filter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetOperator (inherited from Filter) | Returns a string containing the operator (defined by the filter type) and the parameter-name.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterLARGEREQUALAS Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterLARGEREQUALAS Constructor

Initializes a new instance of the FilterLARGEREQUALAS class.

Overload List

Initializes a new instance of the FilterLARGEREQUALAS class.

public FilterLARGEREQUALAS();

Initializes a new instance of the FilterLARGEREQUALAS class with the specified value.

public FilterLARGEREQUALAS(object);

See Also

FilterLARGEREQUALAS Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterLARGEREQUALAS Constructor ()

Initializes a new instance of the FilterLARGEREQUALAS class.

public FilterLARGEREQUALAS();

See Also

FilterLARGEREQUALAS Class | Deag.Vdx.Server.DAL.Filters Namespace | FilterLARGEREQUALAS Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterLARGEREQUALAS Constructor (Object)

Initializes a new instance of the FilterLARGEREQUALAS class with the specified value.

public FilterLARGEREQUALAS(
object filterValue
);

See Also

FilterLARGEREQUALAS Class | Deag.Vdx.Server.DAL.Filters Namespace | FilterLARGEREQUALAS Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterNoValues Class

Base class for all filters that do not contain a value.

For a list of all members of this type, see FilterNoValues Members.

System.Object
Filter
FilterNoValues

public class FilterNoValues : Filter

Requirements

Namespace: Deag.Vdx.Server.DAL.Filters

Assembly: vdxServer (in vdxServer.dll)

See Also

FilterNoValues Members | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterNoValues Members

FilterNoValues overview

Public Instance Constructors

FilterNoValues Constructor Initializes a new instance of the FilterNoValues class.

Public Instance Properties

Parent (inherited from Filter) The Parameter that contains this filter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetOperator (inherited from Filter) | Returns a string containing the operator (defined by the filter type) and the parameter-name.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterNoValues Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterNoValues Constructor

Initializes a new instance of the FilterNoValues class.

public FilterNoValues();

See Also

FilterNoValues Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterOneValue Class

Base class for all filters that contain exactly one value.

For a list of all members of this type, see FilterOneValue Members.

System.Object
Filter
FilterOneValue

public class FilterOneValue : Filter

Requirements

Namespace: Deag.Vdx.Server.DAL.Filters

Assembly: vdxServer (in vdxServer.dll)

See Also

FilterOneValue Members | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterOneValue Members

FilterOneValue overview

Public Instance Constructors

FilterOneValue Overloaded. Initializes a new instance of the FilterOneValue class.

Public Instance Properties

Parent (inherited from Filter) | The Parameter that contains this filter.
Value | Gets/sets the value of the filter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetOperator (inherited from Filter) | Returns a string containing the operator (defined by the filter type) and the parameter-name.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterOneValue Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterOneValue Constructor

Creates an instance of the class FilterOneValue.

Overload List

Creates an instance of the class FilterOneValue.

public FilterOneValue();

Creates an instance of the class FilterOneValue and sets its value

public FilterOneValue(object);

See Also

FilterOneValue Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterOneValue Constructor ()

Creates an instance of the class FilterOneValue.

public FilterOneValue();

See Also

FilterOneValue Class | Deag.Vdx.Server.DAL.Filters Namespace | FilterOneValue Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterOneValue Constructor (Object)

Creates an instance of the class FilterOneValue and sets its value

public FilterOneValue(
object filterValue
);

See Also

FilterOneValue Class | Deag.Vdx.Server.DAL.Filters Namespace | FilterOneValue Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterOneValue Properties

The properties of the FilterOneValue class are listed below. For a complete list of FilterOneValue class members, see the FilterOneValue Members topic.

Public Instance Properties

Parent (inherited from Filter) | The Parameter that contains this filter.
Value | Gets/sets the value of the filter.

See Also

FilterOneValue Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterOneValue.Value Property

Gets/sets the value of the filter.

public object Value {get; set;}

See Also

FilterOneValue Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterOUTPUT Class

Special filter class for return values.

For a list of all members of this type, see FilterOUTPUT Members.

System.Object
Filter
FilterOneValue
FilterOUTPUT

public class FilterOUTPUT : FilterOneValue

Requirements

Namespace: Deag.Vdx.Server.DAL.Filters

Assembly: vdxServer (in vdxServer.dll)

See Also

FilterOUTPUT Members | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterOUTPUT Members

FilterOUTPUT overview

Public Instance Constructors

FilterOUTPUT Constructor Initializes a new instance of the FilterOUTPUT class.

Public Instance Properties

Parent (inherited from Filter) | The Parameter that contains this filter.
Value (inherited from FilterOneValue) | Gets/sets the value of the filter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetOperator (inherited from Filter) | Returns a string containing the operator (defined by the filter type) and the parameter-name.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterOUTPUT Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterOUTPUT Constructor

Initializes a new instance of the FilterOUTPUT class.

public FilterOUTPUT();

See Also

FilterOUTPUT Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterSMALLERAS Class

Filter class for finding data items that are smaller than the filter value.

For a list of all members of this type, see FilterSMALLERAS Members.

System.Object
Filter
FilterOneValue
FilterSMALLERAS

public class FilterSMALLERAS : FilterOneValue

Requirements

Namespace: Deag.Vdx.Server.DAL.Filters

Assembly: vdxServer (in vdxServer.dll)

See Also

FilterSMALLERAS Members | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterSMALLERAS Members

FilterSMALLERAS overview

Public Instance Constructors

FilterSMALLERAS Overloaded. Initializes a new instance of the FilterSMALLERAS class.

Public Instance Properties

Parent (inherited from Filter) | The Parameter that contains this filter.
Value (inherited from FilterOneValue) | Gets/sets the value of the filter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetOperator (inherited from Filter) | Returns a string containing the operator (defined by the filter type) and the parameter-name.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterSMALLERAS Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterSMALLERAS Constructor

Initializes a new instance of the FilterSMALLERAS class.

Overload List

Initializes a new instance of the FilterSMALLERAS class.

public FilterSMALLERAS();

Initializes a new instance of the FilterSMALLERAS class with the specified value.

public FilterSMALLERAS(object);

See Also

FilterSMALLERAS Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterSMALLERAS Constructor ()

Initializes a new instance of the FilterSMALLERAS class.

public FilterSMALLERAS();

See Also

FilterSMALLERAS Class | Deag.Vdx.Server.DAL.Filters Namespace | FilterSMALLERAS Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterSMALLERAS Constructor (Object)

Initializes a new instance of the FilterSMALLERAS class with the specified value.

public FilterSMALLERAS(
object filterValue
);

See Also

FilterSMALLERAS Class | Deag.Vdx.Server.DAL.Filters Namespace | FilterSMALLERAS Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterSMALLEREQUALAS Class

Filter class for finding data items that are smaller or equal than/to the filter value.

For a list of all members of this type, see FilterSMALLEREQUALAS Members.

System.Object
Filter
FilterOneValue
FilterSMALLEREQUALAS

public class FilterSMALLEREQUALAS : FilterOneValue

Requirements

Namespace: Deag.Vdx.Server.DAL.Filters

Assembly: vdxServer (in vdxServer.dll)

See Also

FilterSMALLEREQUALAS Members | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterSMALLEREQUALAS Members

FilterSMALLEREQUALAS overview

Public Instance Constructors

FilterSMALLEREQUALAS Overloaded. Initializes a new instance of the FilterSMALLEREQUALAS class.

Public Instance Properties

Parent (inherited from Filter) | The Parameter that contains this filter.
Value (inherited from FilterOneValue) | Gets/sets the value of the filter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetOperator (inherited from Filter) | Returns a string containing the operator (defined by the filter type) and the parameter-name.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterSMALLEREQUALAS Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterSMALLEREQUALAS Constructor

Initializes a new instance of the FilterSMALLEREQUALAS class.

Overload List

Initializes a new instance of the FilterSMALLEREQUALAS class.

public FilterSMALLEREQUALAS();

Initializes a new instance of the FilterSMALLEREQUALAS class with the specified value.

public FilterSMALLEREQUALAS(object);

See Also

FilterSMALLEREQUALAS Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterSMALLEREQUALAS Constructor ()

Initializes a new instance of the FilterSMALLEREQUALAS class.

public FilterSMALLEREQUALAS();

See Also

FilterSMALLEREQUALAS Class | Deag.Vdx.Server.DAL.Filters Namespace | FilterSMALLEREQUALAS Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterSMALLEREQUALAS Constructor (Object)

Initializes a new instance of the FilterSMALLEREQUALAS class with the specified value.

public FilterSMALLEREQUALAS(
object filterValue
);

See Also

FilterSMALLEREQUALAS Class | Deag.Vdx.Server.DAL.Filters Namespace | FilterSMALLEREQUALAS Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterSTARTWITH Class

Filter class for finding data items that start with the filter value.

For a list of all members of this type, see FilterSTARTWITH Members.

System.Object
Filter
FilterOneValue
FilterSTARTWITH

public class FilterSTARTWITH : FilterOneValue

Requirements

Namespace: Deag.Vdx.Server.DAL.Filters

Assembly: vdxServer (in vdxServer.dll)

See Also

FilterSTARTWITH Members | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterSTARTWITH Members

FilterSTARTWITH overview

Public Instance Constructors

FilterSTARTWITH Overloaded. Initializes a new instance of the FilterSTARTWITH class.

Public Instance Properties

Parent (inherited from Filter) | The Parameter that contains this filter.
Value (inherited from FilterOneValue) | Gets/sets the value of the filter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetOperator (inherited from Filter) | Returns a string containing the operator (defined by the filter type) and the parameter-name.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterSTARTWITH Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterSTARTWITH Constructor

Initializes a new instance of the FilterSTARTWITH class.

Overload List

Initializes a new instance of the FilterSTARTWITH class.

public FilterSTARTWITH();

Initializes a new instance of the FilterSTARTWITH class with the specified value.

public FilterSTARTWITH(object);

See Also

FilterSTARTWITH Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterSTARTWITH Constructor ()

Initializes a new instance of the FilterSTARTWITH class.

public FilterSTARTWITH();

See Also

FilterSTARTWITH Class | Deag.Vdx.Server.DAL.Filters Namespace | FilterSTARTWITH Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterSTARTWITH Constructor (Object)

Initializes a new instance of the FilterSTARTWITH class with the specified value.

public FilterSTARTWITH(
object filterValue
);

See Also

FilterSTARTWITH Class | Deag.Vdx.Server.DAL.Filters Namespace | FilterSTARTWITH Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterTwoValues Class

Base class for all filters that contain 2 values

For a list of all members of this type, see FilterTwoValues Members.

System.Object
Filter
FilterTwoValues

public class FilterTwoValues : Filter

Requirements

Namespace: Deag.Vdx.Server.DAL.Filters

Assembly: vdxServer (in vdxServer.dll)

See Also

FilterTwoValues Members | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterTwoValues Members

FilterTwoValues overview

Public Instance Constructors

FilterTwoValues Overloaded. Initializes a new instance of the FilterTwoValues class.

Public Instance Properties

Parent (inherited from Filter) | The Parameter that contains this filter.
Value1 | Gets/sets the first value of the filter.
Value2 | Gets/sets the second value of the filter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetOperator (inherited from Filter) | Returns a string containing the operator (defined by the filter type) and the parameter-name.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterTwoValues Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterTwoValues Constructor

Initializes a new instance of the FilterTwoValues class.

Overload List

Initializes a new instance of the FilterTwoValues class.

public FilterTwoValues();

Initializes a new instance of the FilterTwoValues class.

public FilterTwoValues(object,object);

See Also

FilterTwoValues Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterTwoValues Constructor ()

Initializes a new instance of the FilterTwoValues class.

public FilterTwoValues();

See Also

FilterTwoValues Class | Deag.Vdx.Server.DAL.Filters Namespace | FilterTwoValues Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterTwoValues Constructor (Object, Object)

Initializes a new instance of the FilterTwoValues class.

public FilterTwoValues(
object value1,
object value2
);

See Also

FilterTwoValues Class | Deag.Vdx.Server.DAL.Filters Namespace | FilterTwoValues Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterTwoValues Properties

The properties of the FilterTwoValues class are listed below. For a complete list of FilterTwoValues class members, see the FilterTwoValues Members topic.

Public Instance Properties

Parent (inherited from Filter) | The Parameter that contains this filter.
Value1 | Gets/sets the first value of the filter.
Value2 | Gets/sets the second value of the filter.

See Also

FilterTwoValues Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterTwoValues.Value1 Property

Gets/sets the first value of the filter.

public object Value1 {get; set;}

See Also

FilterTwoValues Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


FilterTwoValues.Value2 Property

Gets/sets the second value of the filter.

public object Value2 {get; set;}

See Also

FilterTwoValues Class | Deag.Vdx.Server.DAL.Filters Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Server.DAL.SQLServer

VDX Framework

Deag.Vdx.Server.DAL.SQLServer Namespace

The Deag.Vdx.Server.DAL.SQLServer namespace contains classes for accessing data of a MS SQL Server data base.

Provided are SQL Server specific DataAccess classes, SQL Server specific Filter classes and manager classes that are responsible of building the link between the data base independent VDX Server classes and the SQL Server (SQLTransactionManager and SQLDatabaseManager).

Additionally, there exist some special data access classes for common data base task (create/drop a data base, run scripts, ...) in the namespace Deag.Vdx.Server.DAL.SQLServer.Defaults.

Classes

Class | Description
SQLDataAccess | Base class for all SQL specific DataAccess classes that are used for reading only.
SQLDataAccessDataset | Base class for all application specific SQL data access classes that want to use the functionality of DataSets to read/write from/to the DB.
SQLDataAccessQuery | Base class for all application specific data access objects for that the functionality of SQLDataAccessDataset is not sufficient.
SQLDatabaseManager | Manager for interaction with SQL Server.

Enumerations

Enumeration | Description
SQLDatabaseManager.CommandBuilderTasks | Defines which commands should be built from the select command.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess Class

Base class for all SQL specific DataAccess classes that are used for reading only.

For a list of all members of this type, see SQLDataAccess Members.

System.Object
DataAccess
SQLDataAccess

public class SQLDataAccess : DataAccess

Remarks

Inherit directly form this class if you wish to implement a data access for SQL Server that is used only for reading. To read data from the data base the SqlSelect command and the ConnectionString have to be set.

Example

The following example shows how a SQLDataAccess can be used to read data about persons.

            public class DAPerson : DataAccess
            {
                public DAPerson()
                {
                    // define a SELECT command that can be used to read persons either by their
                    // name, prename or town and country; or by a combination of this three terms.
                    SelectCommandWhereTerms sc = new SelectCommandWhereTerms(
                        "SELECT * FROM Person");

                    sc.Terms.Add("Name #@Name");
                    sc.Terms.Add("Prename #@Prename");
                    sc.Terms.Add("Town = @Town AND Country = @Country");
                    sc.OrderBy = "Name";
                    SqlSelect = sc;
                }

                // transform the parameters from VDX to SQL Server
                protected override void AdaptSqlParameters(System.Data.SqlClient.SqlParameterCollection sqlParameters, Deag.Vdx.Server.DAL.Commands.CommandType commandType)
                {
                    TransformParameter("Name",		SqlDbType.VarChar);
                    TransformParameter("Prename",	SqlDbType.VarChar);
                    TransformParameter("Town",		SqlDbType.VarChar, 40);
                    TransformParameter("Country",	SqlDbType.VarChar, 50);
                }

Requirements

Namespace: Deag.Vdx.Server.DAL.SQLServer

Assembly: vdxServer (in vdxServer.dll)

See Also

SQLDataAccess Members | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess Members

SQLDataAccess overview

Public Static Methods

ExploreDataSetErrors Gibt alle Fehler im DataSet als string zurück.

Public Instance Constructors

SQLDataAccess Overloaded. Initializes a new instance of the SQLDataAccess class.

Public Instance Properties

CanDelete | Gets a value indicating whether the SQLDataAccess can be used for deleting.
CanInsert | Gets a value indicating whether the SQLDataAccess can be used for inserting.
CanRead | Gets a value indicating whether the SQLDataAccess can be used for reading.
CanUpdate | Gets a value indicating whether the SQLDataAccess can be used for updating.
CommandTimeOut | Gets/sets the time out used for the commands.
ConnectionInfo (inherited from DataAccess) | Gets/sets the ConnectionInfo that is used to create the connection string.
ConnectionString | Gets/sets the connection string used to connect to the DB.
DeletingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an deleting operation. Default value = true
HasMissingSchemaAction (inherited from DataAccess) | Gets/sets a value indicating whether a MissingSchemaAction is set.
HasTableName (inherited from DataAccess) | Gets a value that indicates whether there is a TableName set.
InsertingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an inserting operation. Default value = true
Key (inherited from DataAccess) | Gets/sets the key that identifies this DataAccess object.
MissingSchemaAction (inherited from DataAccess) | Determines the action to take when Cache DataSet schema does not match data read by the DataAccess object. Default is Error.
Parameters (inherited from DataAccess) | Gets the collection of parameters containging storage dependent Filter
ReadingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in a reading operation. Default value = true
SortingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in the sorting process. Default value = true
SqlSelect | Gets/sets the select command.
Table (inherited from DataAccess) | Gets/sets the DataTable that is filled with the data this DataAccess object returns.
TableName (inherited from DataAccess) | Gets/sets the name of the DataTable the data (provided by this DataAccess object) is merged in.
Transaction (inherited from DataAccess) | Gets/sets the transaction for the following operations.
UpdatingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an updating operation. Default value = true

Public Instance Methods

AddParameter (inherited from DataAccess) | Overloaded. Adds a parameter to the collection of parameters.
AddParameters (inherited from DataAccess) | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters (inherited from DataAccess) | Clears the collection of parameters.
DataDrivenUpdate (inherited from DataAccess) | Derived classes override this method to perform operations depending on the data in the Table.
Delete (inherited from DataAccess) | Derived classes override this method to perform a delete operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter (inherited from DataAccess) | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert (inherited from DataAccess) | Derived classes override this method to perform an insert operation.
IsOperationEnabled (inherited from DataAccess) | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported (inherited from DataAccess) | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation (inherited from DataAccess) | Executes the specified Operation.
Read | Executes the SqlSelect command and writes the returned data into the Table if defined.
ReadCount | Returnes the number of rows the SqlSelect command would return.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from DataAccess) | Derived classes override this method to perform an update operation.

Protected Instance Methods

AdaptSqlParameters | Derived classes can override this method to change the types of the parameters.
CatchSqlException | Transforms the specified SqlException to a vdxDatabaseException.
CreateStorageDependentFilter | Creates SQL Server dependent Filter from a DB independent Filter.
DebugSqlQuery | Overloaded. Can be overriden to debug the query that will be sent to the DB.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback | Returns the delegate to the SQL Server specific commit method.
GetRollbackCallback | Returns the delegate to the SQL Server specific rollback method.
GetStorageDependentParameterPrefix | Returns the SQL Server parameter prefix. Gibt den SQL Server Parameter Präfix zurück.
InitCountCommand | Initializes the SqlCount command with the Parameters of this data access.
InitSelectCommand | Initializes the SqlSelect command with the Parameters of this data access and calls the RefreshQuery method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection | Updates the ConnectionString depending on the ConnectionInfo.
SetAdapterProperties | Sets the CommandTimeout properties of the SqlDataAdapter.
TransformParameter | Overloaded. Transforms a parameter's type.

Protected Internal Instance Fields

actualparams Parameter des aktuellen Commands --> wird von TransformSQLParameter gebraucht.

Protected Internal Instance Methods

DebugSqlQuery | Overloaded. Calls the DebugSqlQuery method if in DEBUG mode.
GetParameterList | Creates from all parameters of the specified command a string.
UpdateParameters | Writes the returned SQL output parameters back to the Parameters.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess Constructor

Initializes a new instance of the SQLDataAccess class.

Overload List

Initializes a new instance of the SQLDataAccess class.

public SQLDataAccess();

Initializes a new instance of the SQLDataAccess class using the specified Key.

public SQLDataAccess(string);

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess Constructor ()

Initializes a new instance of the SQLDataAccess class.

public SQLDataAccess();

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccess Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess Constructor (String)

Initializes a new instance of the SQLDataAccess class using the specified Key.

public SQLDataAccess(
string key
);

Parameters

key
The key identifying the SQLDataAccess.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccess Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess Fields

The fields of the SQLDataAccess class are listed below. For a complete list of SQLDataAccess class members, see the SQLDataAccess Members topic.

Protected Internal Instance Fields

actualparams Parameter des aktuellen Commands --> wird von TransformSQLParameter gebraucht.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.actualparams Field

Parameter des aktuellen Commands --> wird von TransformSQLParameter gebraucht.

protected internal SqlParameterCollection actualparams;

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess Properties

The properties of the SQLDataAccess class are listed below. For a complete list of SQLDataAccess class members, see the SQLDataAccess Members topic.

Public Instance Properties

CanDelete | Gets a value indicating whether the SQLDataAccess can be used for deleting.
CanInsert | Gets a value indicating whether the SQLDataAccess can be used for inserting.
CanRead | Gets a value indicating whether the SQLDataAccess can be used for reading.
CanUpdate | Gets a value indicating whether the SQLDataAccess can be used for updating.
CommandTimeOut | Gets/sets the time out used for the commands.
ConnectionInfo (inherited from DataAccess) | Gets/sets the ConnectionInfo that is used to create the connection string.
ConnectionString | Gets/sets the connection string used to connect to the DB.
DeletingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an deleting operation. Default value = true
HasMissingSchemaAction (inherited from DataAccess) | Gets/sets a value indicating whether a MissingSchemaAction is set.
HasTableName (inherited from DataAccess) | Gets a value that indicates whether there is a TableName set.
InsertingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an inserting operation. Default value = true
Key (inherited from DataAccess) | Gets/sets the key that identifies this DataAccess object.
MissingSchemaAction (inherited from DataAccess) | Determines the action to take when Cache DataSet schema does not match data read by the DataAccess object. Default is Error.
Parameters (inherited from DataAccess) | Gets the collection of parameters containging storage dependent Filter
ReadingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in a reading operation. Default value = true
SortingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in the sorting process. Default value = true
SqlSelect | Gets/sets the select command.
Table (inherited from DataAccess) | Gets/sets the DataTable that is filled with the data this DataAccess object returns.
TableName (inherited from DataAccess) | Gets/sets the name of the DataTable the data (provided by this DataAccess object) is merged in.
Transaction (inherited from DataAccess) | Gets/sets the transaction for the following operations.
UpdatingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an updating operation. Default value = true

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.CanDelete Property

Gets a value indicating whether the SQLDataAccess can be used for deleting.

public override bool CanDelete {get;}

Remarks

A SQLDataAccess can only read therefore the result is always false.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.CanInsert Property

Gets a value indicating whether the SQLDataAccess can be used for inserting.

public override bool CanInsert {get;}

Remarks

A SQLDataAccess can only read therefore the result is always false.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.CanRead Property

Gets a value indicating whether the SQLDataAccess can be used for reading.

public override bool CanRead {get;}

Remarks

If there is a SqlSelect defined then the SQLDataAccess can be used for reading.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.CanUpdate Property

Gets a value indicating whether the SQLDataAccess can be used for updating.

public override bool CanUpdate {get;}

Remarks

A SQLDataAccess can only read therefore the result is always false.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.CommandTimeOut Property

Gets/sets the time out used for the commands.

public int CommandTimeOut {get; set;}

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.ConnectionString Property

Gets/sets the connection string used to connect to the DB.

public virtual string ConnectionString {get; set;}

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.SqlSelect Property

Gets/sets the select command.

public Deag.Vdx.Server.DAL.Commands.SelectCommandBase SqlSelect {get; set;}

Remarks

If you assign a select command then this data access is able to read data, i.e. CanRead is true.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess Methods

The methods of the SQLDataAccess class are listed below. For a complete list of SQLDataAccess class members, see the SQLDataAccess Members topic.

Public Static Methods

ExploreDataSetErrors Gibt alle Fehler im DataSet als string zurück.

Public Instance Methods

AddParameter (inherited from DataAccess) | Overloaded. Adds a parameter to the collection of parameters.
AddParameters (inherited from DataAccess) | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters (inherited from DataAccess) | Clears the collection of parameters.
DataDrivenUpdate (inherited from DataAccess) | Derived classes override this method to perform operations depending on the data in the Table.
Delete (inherited from DataAccess) | Derived classes override this method to perform a delete operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter (inherited from DataAccess) | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert (inherited from DataAccess) | Derived classes override this method to perform an insert operation.
IsOperationEnabled (inherited from DataAccess) | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported (inherited from DataAccess) | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation (inherited from DataAccess) | Executes the specified Operation.
Read | Executes the SqlSelect command and writes the returned data into the Table if defined.
ReadCount | Returnes the number of rows the SqlSelect command would return.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from DataAccess) | Derived classes override this method to perform an update operation.

Protected Instance Methods

AdaptSqlParameters | Derived classes can override this method to change the types of the parameters.
CatchSqlException | Transforms the specified SqlException to a vdxDatabaseException.
CreateStorageDependentFilter | Creates SQL Server dependent Filter from a DB independent Filter.
DebugSqlQuery | Overloaded. Can be overriden to debug the query that will be sent to the DB.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback | Returns the delegate to the SQL Server specific commit method.
GetRollbackCallback | Returns the delegate to the SQL Server specific rollback method.
GetStorageDependentParameterPrefix | Returns the SQL Server parameter prefix. Gibt den SQL Server Parameter Präfix zurück.
InitCountCommand | Initializes the SqlCount command with the Parameters of this data access.
InitSelectCommand | Initializes the SqlSelect command with the Parameters of this data access and calls the RefreshQuery method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection | Updates the ConnectionString depending on the ConnectionInfo.
SetAdapterProperties | Sets the CommandTimeout properties of the SqlDataAdapter.
TransformParameter | Overloaded. Transforms a parameter's type.

Protected Internal Instance Methods

DebugSqlQuery | Overloaded. Calls the DebugSqlQuery method if in DEBUG mode.
GetParameterList | Creates from all parameters of the specified command a string.
UpdateParameters | Writes the returned SQL output parameters back to the Parameters.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.AdaptSqlParameters Method

Derived classes can override this method to change the types of the parameters.

protected virtual void AdaptSqlParameters(
SqlParameterCollection sqlParameters,
CommandType commandType
);

Parameters

sqlParameters
The collection of parameters to be changed.
commandType
The currently executed command.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.CatchSqlException Method

Transforms the specified SqlException to a vdxDatabaseException.

protected virtual Exception CatchSqlException(
SqlException e
);

Parameters

e
The SqlException to transform.

Return Value

Remarks

You can override this method to add your specific implementation.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.CreateStorageDependentFilter Method

Creates SQL Server dependent Filter from a DB independent Filter.

protected Filter CreateStorageDependentFilter(
Filter filter
);

Parameters

filter
The filter for which the equivalent is returned.

Return Value

SQL equivalent of the passed filter.

Remarks

If 'null' is passed as an argument then 'null' is returned. If a SQL filter is passed then this instance will be returned. If no equivalent exists then 'null' is returned.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DebugSqlQuery Method

VDX Framework

SQLDataAccess.DebugSqlQuery Method

Calls the DebugSqlQuery method if in DEBUG mode.

Overload List

Calls the DebugSqlQuery method if in DEBUG mode.

protected internal void DebugSqlQuery(SqlCommand,CommandType);

Can be overriden to debug the query that will be sent to the DB.

protected virtual void DebugSqlQuery(string,string,string,CommandType);

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.DebugSqlQuery Method (SqlCommand, CommandType)

Calls the DebugSqlQuery method if in DEBUG mode.

protected internal void DebugSqlQuery(
SqlCommand cmd,
CommandType commandType
);

Parameters

cmd
commandType

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccess.DebugSqlQuery Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.DebugSqlQuery Method (String, String, String, CommandType)

Can be overriden to debug the query that will be sent to the DB.

protected virtual void DebugSqlQuery(
string query,
string parameters,
string combined,
CommandType commandType
);

Parameters

query
Query that will be sent to the DB
parameters
List of all Parameters present.
combined
A preview of the command.
commandType
Type of the command (select, insert, delete, update)

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccess.DebugSqlQuery Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.ExploreDataSetErrors Method

Gibt alle Fehler im DataSet als string zurück.

public static string ExploreDataSetErrors(
DataSet ds
);

Parameters

ds
DataSet mit Fehlern

Return Value

String Repräsentation der Fehler im DataSet

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.GetCommitCallback Method

Returns the delegate to the SQL Server specific commit method.

protected CommitCallback GetCommitCallback();

Return Value

SQL Server specific commit method.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.GetParameterList Method

Creates from all parameters of the specified command a string.

protected internal string GetParameterList(
SqlCommand cmd
);

Parameters

cmd
The command

Return Value

String representation of all parameters of the command.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.GetRollbackCallback Method

Returns the delegate to the SQL Server specific rollback method.

protected RollbackCallback GetRollbackCallback();

Return Value

SQL Server specific rollback method.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.GetStorageDependentParameterPrefix Method

Returns the SQL Server parameter prefix. Gibt den SQL Server Parameter Präfix zurück.

protected string GetStorageDependentParameterPrefix();

Return Value

Parameter-Präfix

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.InitCountCommand Method

Initializes the SqlCount command with the Parameters of this data access.

protected void InitCountCommand();

Remarks

The count command uses the select command.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.InitSelectCommand Method

Initializes the SqlSelect command with the Parameters of this data access and calls the RefreshQuery method.

protected void InitSelectCommand();

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.Read Method

Executes the SqlSelect command and writes the returned data into the Table if defined.

public override void Read();

Return Value

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.ReadCount Method

Returnes the number of rows the SqlSelect command would return.

public override int ReadCount();

Return Value

Number of rows the SqlSelect command would return.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.RefreshConnection Method

Updates the ConnectionString depending on the ConnectionInfo.

protected override void RefreshConnection();

Remarks

This method is called every time a ConnectionInfo object is passed.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.SetAdapterProperties Method

Sets the CommandTimeout properties of the SqlDataAdapter.

protected virtual void SetAdapterProperties(
SqlDataAdapter adapt
);

Parameters

adapt

Remarks

You can override this method to set additional properties of the SqlDataAdapter.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


TransformParameter Method

VDX Framework

SQLDataAccess.TransformParameter Method

Transforms a parameter's type.

Overload List

Transforms a parameter's type.

protected void TransformParameter(string,SqlDbType);

Transforms a parameter's type.

protected void TransformParameter(string,SqlDbType,ParameterDirection);

Transforms a parameter's type.

protected void TransformParameter(string,SqlDbType,int);

Transforms a parameter's type.

protected void TransformParameter(string,SqlDbType,int,ParameterDirection);

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.TransformParameter Method (String, SqlDbType)

Transforms a parameter's type.

protected void TransformParameter(
string parameter,
SqlDbType type
);

Parameters

parameter
Name of the parameter to transform.
type
Type to which the parameter is transformed.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccess.TransformParameter Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.TransformParameter Method (String, SqlDbType, ParameterDirection)

Transforms a parameter's type.

protected void TransformParameter(
string parameter,
SqlDbType type,
ParameterDirection direction
);

Parameters

parameter
Name of the parameter to transform.
type
Type to which the parameter is transformed.
direction
The direction of the parameter.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccess.TransformParameter Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.TransformParameter Method (String, SqlDbType, Int32)

Transforms a parameter's type.

protected void TransformParameter(
string parameter,
SqlDbType type,
int size
);

Parameters

parameter
Name of the parameter to transform.
type
Type to which the parameter is transformed.
size
The size of the type.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccess.TransformParameter Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.TransformParameter Method (String, SqlDbType, Int32, ParameterDirection)

Transforms a parameter's type.

protected void TransformParameter(
string parameter,
SqlDbType type,
int size,
ParameterDirection direction
);

Parameters

parameter
Name of the parameter to transform.
type
Type to which the parameter is transformed.
size
The size of the type.
direction
The direction of the parameter.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccess.TransformParameter Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccess.UpdateParameters Method

Writes the returned SQL output parameters back to the Parameters.

protected internal void UpdateParameters(
SqlParameterCollection parameters
);

Parameters

parameters
The returnd SQL parameters.

See Also

SQLDataAccess Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessDataset Class

Base class for all application specific SQL data access classes that want to use the functionality of DataSets to read/write from/to the DB.

For a list of all members of this type, see SQLDataAccessDataset Members.

System.Object
DataAccess
SQLDataAccess
SQLDataAccessDataset

public class SQLDataAccessDataset : SQLDataAccess

Remarks

A SQLDataAccessDataset can be used to read/write from/into DBs managed by SQL Server.

A SQLDataAccessDataSet is specially useful in the case of writing multiple data records at once, because the parameters used in the query are built directly from the data in the Table. Note that this table has to contain all the original values that are stored in the data base. Therefore you should use a SQLDataAccessDataSet together with EntityLists without items.

The usage of SQLDataAccessDataSet is unfortunately very limited due to the fact that all commands are built from the SELECT command. Therefore if you use for example a JOIN in your SELECT command then the generation of the other commands will probably fail. In such a case make use of SQLDataAccessQuery.

Example

The following example shows a SQLDataAccessQuery for manipulating data of persons:

            public class DAPerson : SQLDataAccessDataSet
            {
                public DAPerson()
                {
                    // define the SELECT command
                    SelectCommandWhereTerms sc = new SelectCommandWhereTerms(
                        "SELECT	* FROM Person");

                    sc.Terms.Add("PersonID = @ID");		// allow only exact match for ID
                    sc.Terms.Add("Name #@Name");		// # --> match criteria is given by the filter
                    sc.Terms.Add("Prename #@Prename");	// of corresponding parameter
                    sc.Terms.Add("Age #@Age");
                    sc.OrderBy = "ORDER BY Name";		// sort the result
                    SqlSelect = sc;

                    // define that values should be read back after an insert or update
                    // normally this would be set from the outside
                    this.ReadAfterWrite = true;

                    // define the WHERE clause that should be used for a "read after write"
                    this.ReadAfterWriteWhere = "WHERE PersonID = @@IDENTITY";
                }

                // transform the vdx parameters to sql parameters
                protected override void AdaptSqlParameters(System.Data.SqlClient.SqlParameterCollection sqlParameters, Deag.Vdx.Server.DAL.Commands.CommandType commandType)
                {
                    TransformParameter("ID",		SqlDbType.Int);
                    TransformParameter("Name",		SqlDbType.Char, 50);
                    TransformParameter("Prename",	SqlDbType.Char, 50);
                    TransformParameter("Age",		SqlDbType.Int, 3);
                }
            }

Requirements

Namespace: Deag.Vdx.Server.DAL.SQLServer

Assembly: vdxServer (in vdxServer.dll)

See Also

SQLDataAccessDataset Members | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccessQuery

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessDataset Members

SQLDataAccessDataset overview

Public Instance Constructors

SQLDataAccessDataset Overloaded. Initializes a new instance of the SQLDataAccessDataset class.

Public Instance Properties

CanDelete | Gets a value indicating whether the SQLDataAccess can be used for deleting.
CanInsert | Gets a value indicating whether the SQLDataAccess can be used for inserting.
CanRead (inherited from SQLDataAccess) | Gets a value indicating whether the SQLDataAccess can be used for reading.
CanUpdate | Gets a value indicating whether the SQLDataAccess can be used for updating.
CommandTimeOut (inherited from SQLDataAccess) | Gets/sets the time out used for the commands.
ConnectionInfo (inherited from DataAccess) | Gets/sets the ConnectionInfo that is used to create the connection string.
ConnectionString (inherited from SQLDataAccess) | Gets/sets the connection string used to connect to the DB.
DeletingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an deleting operation. Default value = true
HasMissingSchemaAction (inherited from DataAccess) | Gets/sets a value indicating whether a MissingSchemaAction is set.
HasTableName (inherited from DataAccess) | Gets a value that indicates whether there is a TableName set.
InsertingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an inserting operation. Default value = true
Key (inherited from DataAccess) | Gets/sets the key that identifies this DataAccess object.
MissingSchemaAction (inherited from DataAccess) | Determines the action to take when Cache DataSet schema does not match data read by the DataAccess object. Default is Error.
Parameters (inherited from DataAccess) | Gets the collection of parameters containging storage dependent Filter
ReadAfterWrite | Whether the data record should be read back after an insert or update operation.
ReadingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in a reading operation. Default value = true
SortingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in the sorting process. Default value = true
SqlSelect (inherited from SQLDataAccess) | Gets/sets the select command.
Table (inherited from DataAccess) | Gets/sets the DataTable that is filled with the data this DataAccess object returns.
TableName (inherited from DataAccess) | Gets/sets the name of the DataTable the data (provided by this DataAccess object) is merged in.
Transaction (inherited from DataAccess) | Gets/sets the transaction for the following operations.
UpdatingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an updating operation. Default value = true

Public Instance Methods

AddParameter (inherited from DataAccess) | Overloaded. Adds a parameter to the collection of parameters.
AddParameters (inherited from DataAccess) | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters (inherited from DataAccess) | Clears the collection of parameters.
DataDrivenUpdate | Updates the data in Table into the DB depending of the RowState of each row.
Delete | Deletes all rows in the Table from the DB.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter (inherited from DataAccess) | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Inserts the data in Table into the DB. All rows must have a row state equal to Added.
IsOperationEnabled (inherited from DataAccess) | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported (inherited from DataAccess) | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation (inherited from DataAccess) | Executes the specified Operation.
Read (inherited from SQLDataAccess) | Executes the SqlSelect command and writes the returned data into the Table if defined.
ReadCount (inherited from SQLDataAccess) | Returnes the number of rows the SqlSelect command would return.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update | Updates the data in Table in the DB. All rows must have a row state equal to Modified.

Protected Instance Properties

ReadAfterWriteWhere Gets/sets the where clause (including the WHERE keyword) to read back data.

Protected Instance Methods

AdaptSqlParameters (inherited from SQLDataAccess) | Derived classes can override this method to change the types of the parameters.
CatchSqlException (inherited from SQLDataAccess) | Transforms the specified SqlException to a vdxDatabaseException.
CreateStorageDependentFilter (inherited from SQLDataAccess) | Creates SQL Server dependent Filter from a DB independent Filter.
DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific commit method.
GetRollbackCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific rollback method.
GetStorageDependentParameterPrefix (inherited from SQLDataAccess) | Returns the SQL Server parameter prefix. Gibt den SQL Server Parameter Präfix zurück.
InitCountCommand (inherited from SQLDataAccess) | Initializes the SqlCount command with the Parameters of this data access.
InitSelectCommand (inherited from SQLDataAccess) | Initializes the SqlSelect command with the Parameters of this data access and calls the RefreshQuery method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection (inherited from SQLDataAccess) | Updates the ConnectionString depending on the ConnectionInfo.
SetAdapterProperties (inherited from SQLDataAccess) | Sets the CommandTimeout properties of the SqlDataAdapter.
TransformParameter (inherited from SQLDataAccess) | Overloaded. Transforms a parameter's type.

Protected Internal Instance Fields

actualparams (inherited from SQLDataAccess) Parameter des aktuellen Commands --> wird von TransformSQLParameter gebraucht.

Protected Internal Instance Methods

DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
GetParameterList (inherited from SQLDataAccess) | Creates from all parameters of the specified command a string.
UpdateParameters (inherited from SQLDataAccess) | Writes the returned SQL output parameters back to the Parameters.

See Also

SQLDataAccessDataset Class | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccessQuery

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessDataset Constructor

Initializes a new instance of the SQLDataAccessDataset class.

Overload List

Initializes a new instance of the SQLDataAccessDataset class.

public SQLDataAccessDataset();

Initializes a new instance of the SQLDataAccessDataset class using the specified Key.

public SQLDataAccessDataset(string);

See Also

SQLDataAccessDataset Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessDataset Constructor ()

Initializes a new instance of the SQLDataAccessDataset class.

public SQLDataAccessDataset();

See Also

SQLDataAccessDataset Class | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccessDataset Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessDataset Constructor (String)

Initializes a new instance of the SQLDataAccessDataset class using the specified Key.

public SQLDataAccessDataset(
string key
);

Parameters

key
Key identifying the data access.

See Also

SQLDataAccessDataset Class | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccessDataset Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessDataset Properties

The properties of the SQLDataAccessDataset class are listed below. For a complete list of SQLDataAccessDataset class members, see the SQLDataAccessDataset Members topic.

Public Instance Properties

CanDelete | Gets a value indicating whether the SQLDataAccess can be used for deleting.
CanInsert | Gets a value indicating whether the SQLDataAccess can be used for inserting.
CanRead (inherited from SQLDataAccess) | Gets a value indicating whether the SQLDataAccess can be used for reading.
CanUpdate | Gets a value indicating whether the SQLDataAccess can be used for updating.
CommandTimeOut (inherited from SQLDataAccess) | Gets/sets the time out used for the commands.
ConnectionInfo (inherited from DataAccess) | Gets/sets the ConnectionInfo that is used to create the connection string.
ConnectionString (inherited from SQLDataAccess) | Gets/sets the connection string used to connect to the DB.
DeletingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an deleting operation. Default value = true
HasMissingSchemaAction (inherited from DataAccess) | Gets/sets a value indicating whether a MissingSchemaAction is set.
HasTableName (inherited from DataAccess) | Gets a value that indicates whether there is a TableName set.
InsertingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an inserting operation. Default value = true
Key (inherited from DataAccess) | Gets/sets the key that identifies this DataAccess object.
MissingSchemaAction (inherited from DataAccess) | Determines the action to take when Cache DataSet schema does not match data read by the DataAccess object. Default is Error.
Parameters (inherited from DataAccess) | Gets the collection of parameters containging storage dependent Filter
ReadAfterWrite | Whether the data record should be read back after an insert or update operation.
ReadingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in a reading operation. Default value = true
SortingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in the sorting process. Default value = true
SqlSelect (inherited from SQLDataAccess) | Gets/sets the select command.
Table (inherited from DataAccess) | Gets/sets the DataTable that is filled with the data this DataAccess object returns.
TableName (inherited from DataAccess) | Gets/sets the name of the DataTable the data (provided by this DataAccess object) is merged in.
Transaction (inherited from DataAccess) | Gets/sets the transaction for the following operations.
UpdatingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an updating operation. Default value = true

Protected Instance Properties

ReadAfterWriteWhere Gets/sets the where clause (including the WHERE keyword) to read back data.

See Also

SQLDataAccessDataset Class | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccessQuery

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessDataset.CanDelete Property

Gets a value indicating whether the SQLDataAccess can be used for deleting.

public override bool CanDelete {get;}

Remarks

A SQLDataAccess can be used for deleting if it can read.

See Also

SQLDataAccessDataset Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessDataset.CanInsert Property

Gets a value indicating whether the SQLDataAccess can be used for inserting.

public override bool CanInsert {get;}

Remarks

A SQLDataAccess can be used for inserting if it can read.

See Also

SQLDataAccessDataset Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessDataset.CanUpdate Property

Gets a value indicating whether the SQLDataAccess can be used for updating.

public override bool CanUpdate {get;}

Remarks

A SQLDataAccess can be used for updating if it can read.

See Also

SQLDataAccessDataset Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessDataset.ReadAfterWrite Property

Whether the data record should be read back after an insert or update operation.

public bool ReadAfterWrite {get; set;}

Remarks

Set this vlaue to true if you wish to read for example generated keys back into your entities.

See Also

SQLDataAccessDataset Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessDataset.ReadAfterWriteWhere Property

Gets/sets the where clause (including the WHERE keyword) to read back data.

protected string ReadAfterWriteWhere {get; set;}

Example

"WHERE ID = @@IDENTITY" for autogenerated keys "WHERE ID = @ID" else

See Also

SQLDataAccessDataset Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessDataset Methods

The methods of the SQLDataAccessDataset class are listed below. For a complete list of SQLDataAccessDataset class members, see the SQLDataAccessDataset Members topic.

Public Instance Methods

AddParameter (inherited from DataAccess) | Overloaded. Adds a parameter to the collection of parameters.
AddParameters (inherited from DataAccess) | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters (inherited from DataAccess) | Clears the collection of parameters.
DataDrivenUpdate | Updates the data in Table into the DB depending of the RowState of each row.
Delete | Deletes all rows in the Table from the DB.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter (inherited from DataAccess) | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Inserts the data in Table into the DB. All rows must have a row state equal to Added.
IsOperationEnabled (inherited from DataAccess) | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported (inherited from DataAccess) | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation (inherited from DataAccess) | Executes the specified Operation.
Read (inherited from SQLDataAccess) | Executes the SqlSelect command and writes the returned data into the Table if defined.
ReadCount (inherited from SQLDataAccess) | Returnes the number of rows the SqlSelect command would return.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update | Updates the data in Table in the DB. All rows must have a row state equal to Modified.

Protected Instance Methods

AdaptSqlParameters (inherited from SQLDataAccess) | Derived classes can override this method to change the types of the parameters.
CatchSqlException (inherited from SQLDataAccess) | Transforms the specified SqlException to a vdxDatabaseException.
CreateStorageDependentFilter (inherited from SQLDataAccess) | Creates SQL Server dependent Filter from a DB independent Filter.
DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific commit method.
GetRollbackCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific rollback method.
GetStorageDependentParameterPrefix (inherited from SQLDataAccess) | Returns the SQL Server parameter prefix. Gibt den SQL Server Parameter Präfix zurück.
InitCountCommand (inherited from SQLDataAccess) | Initializes the SqlCount command with the Parameters of this data access.
InitSelectCommand (inherited from SQLDataAccess) | Initializes the SqlSelect command with the Parameters of this data access and calls the RefreshQuery method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection (inherited from SQLDataAccess) | Updates the ConnectionString depending on the ConnectionInfo.
SetAdapterProperties (inherited from SQLDataAccess) | Sets the CommandTimeout properties of the SqlDataAdapter.
TransformParameter (inherited from SQLDataAccess) | Overloaded. Transforms a parameter's type.

Protected Internal Instance Methods

DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
GetParameterList (inherited from SQLDataAccess) | Creates from all parameters of the specified command a string.
UpdateParameters (inherited from SQLDataAccess) | Writes the returned SQL output parameters back to the Parameters.

See Also

SQLDataAccessDataset Class | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccessQuery

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessDataset.DataDrivenUpdate Method

Updates the data in Table into the DB depending of the RowState of each row.

public override void DataDrivenUpdate();

See Also

SQLDataAccessDataset Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessDataset.Delete Method

Deletes all rows in the Table from the DB.

public override void Delete();

See Also

SQLDataAccessDataset Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessDataset.Insert Method

Inserts the data in Table into the DB. All rows must have a row state equal to Added.

public override void Insert();

Exceptions

Exception Type | Condition
NotSupportedException | If not all rows in Table have a row state equal to "Added".

See Also

SQLDataAccessDataset Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessDataset.Update Method

Updates the data in Table in the DB. All rows must have a row state equal to Modified.

public override void Update();

Exceptions

Exception Type | Condition
NotSupportedException | If not all rows in Table have a row state equal to "Modified".

See Also

SQLDataAccessDataset Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessQuery Class

Base class for all application specific data access objects for that the functionality of SQLDataAccessDataset is not sufficient.

For a list of all members of this type, see SQLDataAccessQuery Members.

System.Object
DataAccess
SQLDataAccess
SQLDataAccessQuery

public class SQLDataAccessQuery : SQLDataAccess

Remarks

In a SQLDataAccessQuery you can define a select (SqlSelect), insert (SqlInsert), update (SqlUpdate) and delete (SqlDelete) command to be executed when the corresponding operation is performed.

Example

The following example shows a SQLDataAccessQuery for manipulating data of persons:

            public class DAPerson : SQLDataAccessQuery
            {
                public DAPerson()
                {
                    // define the SELECT command
                    SelectCommandWhereTerms sc = new SelectCommandWhereTerms(
                        "SELECT	* FROM Person");

                    sc.Terms.Add("PersonID = @ID");		// allow only exact match for ID
                    sc.Terms.Add("Name #@Name");		// # --> match criteria is given by the filter
                    sc.Terms.Add("Prename #@Prename");	// of corresponding parameter
                    sc.Terms.Add("Age #@Age");
                    sc.OrderBy = "ORDER BY Name";		// sort the result
                    SqlSelect = sc;

                    // define the INSERT command
                    SqlInsert = new InsertCommand(
                        "INSERT INTO Person \n" +
                        "       (Name, Prename, Age) \n" +
                        "VALUES (@Name, @Prename, @Age)");

                    // define the UPDATE command
                    SqlUpdate = new UpdateCommand(
                        "UPDATE    Person \n" +
                        "SET  Name = @Name, Prename = @Prename, Town = @Town, Age = @Age \n"
                        "WHERE PersonID = @ID");

                    // define the DELETE command
                    SqlDelete = new DeleteCommand(
                        "DELETE FROM Person WHERE PersonID = @ID");
                }

                // transform the vdx parameters to sql parameters
                protected override void AdaptSqlParameters(System.Data.SqlClient.SqlParameterCollection sqlParameters, Deag.Vdx.Server.DAL.Commands.CommandType commandType)
                {
                    TransformParameter("ID",		SqlDbType.Int);
                    TransformParameter("Name",		SqlDbType.Char, 50);
                    TransformParameter("Prename",	SqlDbType.Char, 50);
                    TransformParameter("Age",		SqlDbType.Int, 3);
                }
            }

Requirements

Namespace: Deag.Vdx.Server.DAL.SQLServer

Assembly: vdxServer (in vdxServer.dll)

See Also

SQLDataAccessQuery Members | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccessDataset

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessQuery Members

SQLDataAccessQuery overview

Public Instance Constructors

SQLDataAccessQuery Overloaded. Initializes a new instance of the SQLDataAccessQuery class.

Public Instance Properties

CanDelete | Returns a value indicating whether this data access can perform a delete operation.
CanInsert | Returns a value indicating whether this data access can perform a read operation.
CanRead (inherited from SQLDataAccess) | Gets a value indicating whether the SQLDataAccess can be used for reading.
CanUpdate | Returns a value indicating whether this data access can perform an update operation.
CommandTimeOut (inherited from SQLDataAccess) | Gets/sets the time out used for the commands.
ConnectionInfo (inherited from DataAccess) | Gets/sets the ConnectionInfo that is used to create the connection string.
ConnectionString (inherited from SQLDataAccess) | Gets/sets the connection string used to connect to the DB.
DeletingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an deleting operation. Default value = true
HasMissingSchemaAction (inherited from DataAccess) | Gets/sets a value indicating whether a MissingSchemaAction is set.
HasTableName (inherited from DataAccess) | Gets a value that indicates whether there is a TableName set.
InsertingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an inserting operation. Default value = true
Key (inherited from DataAccess) | Gets/sets the key that identifies this DataAccess object.
MissingSchemaAction (inherited from DataAccess) | Determines the action to take when Cache DataSet schema does not match data read by the DataAccess object. Default is Error.
Parameters (inherited from DataAccess) | Gets the collection of parameters containging storage dependent Filter
ReadingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in a reading operation. Default value = true
SortingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in the sorting process. Default value = true
SqlDelete | Gets/sets the delete command.
SqlInsert | Gets/sets the insert command.
SqlSelect (inherited from SQLDataAccess) | Gets/sets the select command.
SqlUpdate | Gets/sets the update command.
Table (inherited from DataAccess) | Gets/sets the DataTable that is filled with the data this DataAccess object returns.
TableName (inherited from DataAccess) | Gets/sets the name of the DataTable the data (provided by this DataAccess object) is merged in.
Transaction (inherited from DataAccess) | Gets/sets the transaction for the following operations.
UpdatingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an updating operation. Default value = true

Public Instance Methods

AddParameter (inherited from DataAccess) | Overloaded. Adds a parameter to the collection of parameters.
AddParameters (inherited from DataAccess) | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters (inherited from DataAccess) | Clears the collection of parameters.
DataDrivenUpdate | Walks through all rows in the Table and executes an Insert, Update or Delete operation depending on the state of the current row.
Delete | Performs the delete command.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter (inherited from DataAccess) | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Performs the insert command.
IsOperationEnabled (inherited from DataAccess) | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported (inherited from DataAccess) | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation (inherited from DataAccess) | Executes the specified Operation.
Read (inherited from SQLDataAccess) | Executes the SqlSelect command and writes the returned data into the Table if defined.
ReadCount (inherited from SQLDataAccess) | Returnes the number of rows the SqlSelect command would return.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update | Performs the update command.

Protected Instance Methods

AdaptSqlParameters (inherited from SQLDataAccess) | Derived classes can override this method to change the types of the parameters.
CatchSqlException (inherited from SQLDataAccess) | Transforms the specified SqlException to a vdxDatabaseException.
CreateStorageDependentFilter (inherited from SQLDataAccess) | Creates SQL Server dependent Filter from a DB independent Filter.
DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific commit method.
GetRollbackCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific rollback method.
GetStorageDependentParameterPrefix (inherited from SQLDataAccess) | Returns the SQL Server parameter prefix. Gibt den SQL Server Parameter Präfix zurück.
InitCountCommand (inherited from SQLDataAccess) | Initializes the SqlCount command with the Parameters of this data access.
InitSelectCommand (inherited from SQLDataAccess) | Initializes the SqlSelect command with the Parameters of this data access and calls the RefreshQuery method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection (inherited from SQLDataAccess) | Updates the ConnectionString depending on the ConnectionInfo.
SetAdapterProperties (inherited from SQLDataAccess) | Sets the CommandTimeout properties of the SqlDataAdapter.
TransformParameter (inherited from SQLDataAccess) | Overloaded. Transforms a parameter's type.

Protected Internal Instance Fields

actualparams (inherited from SQLDataAccess) Parameter des aktuellen Commands --> wird von TransformSQLParameter gebraucht.

Protected Internal Instance Methods

DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
GetParameterList (inherited from SQLDataAccess) | Creates from all parameters of the specified command a string.
UpdateParameters (inherited from SQLDataAccess) | Writes the returned SQL output parameters back to the Parameters.

See Also

SQLDataAccessQuery Class | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccessDataset

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessQuery Constructor

Initializes a new instance of the SQLDataAccessQuery class.

Overload List

Initializes a new instance of the SQLDataAccessQuery class.

public SQLDataAccessQuery();

Initializes a new instance of the SQLDataAccessQuery class using the specified Key.

public SQLDataAccessQuery(string);

See Also

SQLDataAccessQuery Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessQuery Constructor ()

Initializes a new instance of the SQLDataAccessQuery class.

public SQLDataAccessQuery();

See Also

SQLDataAccessQuery Class | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccessQuery Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessQuery Constructor (String)

Initializes a new instance of the SQLDataAccessQuery class using the specified Key.

public SQLDataAccessQuery(
string key
);

Parameters

key
Key identifying the data access.

See Also

SQLDataAccessQuery Class | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccessQuery Constructor Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessQuery Properties

The properties of the SQLDataAccessQuery class are listed below. For a complete list of SQLDataAccessQuery class members, see the SQLDataAccessQuery Members topic.

Public Instance Properties

CanDelete | Returns a value indicating whether this data access can perform a delete operation.
CanInsert | Returns a value indicating whether this data access can perform a read operation.
CanRead (inherited from SQLDataAccess) | Gets a value indicating whether the SQLDataAccess can be used for reading.
CanUpdate | Returns a value indicating whether this data access can perform an update operation.
CommandTimeOut (inherited from SQLDataAccess) | Gets/sets the time out used for the commands.
ConnectionInfo (inherited from DataAccess) | Gets/sets the ConnectionInfo that is used to create the connection string.
ConnectionString (inherited from SQLDataAccess) | Gets/sets the connection string used to connect to the DB.
DeletingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an deleting operation. Default value = true
HasMissingSchemaAction (inherited from DataAccess) | Gets/sets a value indicating whether a MissingSchemaAction is set.
HasTableName (inherited from DataAccess) | Gets a value that indicates whether there is a TableName set.
InsertingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an inserting operation. Default value = true
Key (inherited from DataAccess) | Gets/sets the key that identifies this DataAccess object.
MissingSchemaAction (inherited from DataAccess) | Determines the action to take when Cache DataSet schema does not match data read by the DataAccess object. Default is Error.
Parameters (inherited from DataAccess) | Gets the collection of parameters containging storage dependent Filter
ReadingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in a reading operation. Default value = true
SortingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in the sorting process. Default value = true
SqlDelete | Gets/sets the delete command.
SqlInsert | Gets/sets the insert command.
SqlSelect (inherited from SQLDataAccess) | Gets/sets the select command.
SqlUpdate | Gets/sets the update command.
Table (inherited from DataAccess) | Gets/sets the DataTable that is filled with the data this DataAccess object returns.
TableName (inherited from DataAccess) | Gets/sets the name of the DataTable the data (provided by this DataAccess object) is merged in.
Transaction (inherited from DataAccess) | Gets/sets the transaction for the following operations.
UpdatingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an updating operation. Default value = true

See Also

SQLDataAccessQuery Class | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccessDataset

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessQuery.CanDelete Property

Returns a value indicating whether this data access can perform a delete operation.

public override bool CanDelete {get;}

Remarks

A read operation can be performed if there is a delete command (SqlDelete) defined.

See Also

SQLDataAccessQuery Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessQuery.CanInsert Property

Returns a value indicating whether this data access can perform a read operation.

public override bool CanInsert {get;}

Remarks

A read operation can be performed if there is a select command (SqlInsert) defined.

See Also

SQLDataAccessQuery Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessQuery.CanUpdate Property

Returns a value indicating whether this data access can perform an update operation.

public override bool CanUpdate {get;}

Remarks

A read operation can be performed if there is an update command (SqlUpdate) defined.

See Also

SQLDataAccessQuery Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessQuery.SqlDelete Property

Gets/sets the delete command.

public Deag.Vdx.Server.DAL.Commands.DeleteCommand SqlDelete {get; set;}

See Also

SQLDataAccessQuery Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessQuery.SqlInsert Property

Gets/sets the insert command.

public Deag.Vdx.Server.DAL.Commands.InsertCommand SqlInsert {get; set;}

See Also

SQLDataAccessQuery Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessQuery.SqlUpdate Property

Gets/sets the update command.

public Deag.Vdx.Server.DAL.Commands.UpdateCommand SqlUpdate {get; set;}

See Also

SQLDataAccessQuery Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessQuery Methods

The methods of the SQLDataAccessQuery class are listed below. For a complete list of SQLDataAccessQuery class members, see the SQLDataAccessQuery Members topic.

Public Instance Methods

AddParameter (inherited from DataAccess) | Overloaded. Adds a parameter to the collection of parameters.
AddParameters (inherited from DataAccess) | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters (inherited from DataAccess) | Clears the collection of parameters.
DataDrivenUpdate | Walks through all rows in the Table and executes an Insert, Update or Delete operation depending on the state of the current row.
Delete | Performs the delete command.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter (inherited from DataAccess) | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Performs the insert command.
IsOperationEnabled (inherited from DataAccess) | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported (inherited from DataAccess) | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation (inherited from DataAccess) | Executes the specified Operation.
Read (inherited from SQLDataAccess) | Executes the SqlSelect command and writes the returned data into the Table if defined.
ReadCount (inherited from SQLDataAccess) | Returnes the number of rows the SqlSelect command would return.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update | Performs the update command.

Protected Instance Methods

AdaptSqlParameters (inherited from SQLDataAccess) | Derived classes can override this method to change the types of the parameters.
CatchSqlException (inherited from SQLDataAccess) | Transforms the specified SqlException to a vdxDatabaseException.
CreateStorageDependentFilter (inherited from SQLDataAccess) | Creates SQL Server dependent Filter from a DB independent Filter.
DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific commit method.
GetRollbackCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific rollback method.
GetStorageDependentParameterPrefix (inherited from SQLDataAccess) | Returns the SQL Server parameter prefix. Gibt den SQL Server Parameter Präfix zurück.
InitCountCommand (inherited from SQLDataAccess) | Initializes the SqlCount command with the Parameters of this data access.
InitSelectCommand (inherited from SQLDataAccess) | Initializes the SqlSelect command with the Parameters of this data access and calls the RefreshQuery method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection (inherited from SQLDataAccess) | Updates the ConnectionString depending on the ConnectionInfo.
SetAdapterProperties (inherited from SQLDataAccess) | Sets the CommandTimeout properties of the SqlDataAdapter.
TransformParameter (inherited from SQLDataAccess) | Overloaded. Transforms a parameter's type.

Protected Internal Instance Methods

DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
GetParameterList (inherited from SQLDataAccess) | Creates from all parameters of the specified command a string.
UpdateParameters (inherited from SQLDataAccess) | Writes the returned SQL output parameters back to the Parameters.

See Also

SQLDataAccessQuery Class | Deag.Vdx.Server.DAL.SQLServer Namespace | SQLDataAccessDataset

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessQuery.DataDrivenUpdate Method

Walks through all rows in the Table and executes an Insert, Update or Delete operation depending on the state of the current row.

public override void DataDrivenUpdate();

Remarks

If you want to generate Parameters from the content of each row then you should override this method, loop through all rows, create the needed parameters from the row content and call the insert, update or delete method according to the RowState of the current row.

See Also

SQLDataAccessQuery Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessQuery.Delete Method

Performs the delete command.

public override void Delete();

Remarks

If CanDelete returns true then the SqlDelete command is refreshed by calling RefreshQuery. If no Transaction was assigned then a local transaction is created to ensure correct connection pooling.

Then a SqlDataAdapter is requested for the SqlDelete command and the query is executed.

If there occures an exception then the local Transaction (only if created) is rollbacked.

See Also

SQLDataAccessQuery Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessQuery.Insert Method

Performs the insert command.

public override void Insert();

Remarks

If CanInsert returns true then the SqlInsert command is refreshed by calling RefreshQuery. If no Transaction was assigned then a local transaction is created to ensure correct connection pooling.

Then a SqlDataAdapter is requested for the SqlDelete command and the query is executed.

If there occures an exception then the local Transaction (only if created) is rollbacked.

See Also

SQLDataAccessQuery Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDataAccessQuery.Update Method

Performs the update command.

public override void Update();

Remarks

If CanUpdate returns true then the SqlUpdate command is refreshed by calling RefreshQuery. If no Transaction was assigned then a local transaction is created to ensure correct connection pooling.

Then a SqlDataAdapter is requested for the SqlUpdate command and the query is executed.

If there occures an exception then the local Transaction (only if created) is rollbacked.

See Also

SQLDataAccessQuery Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDatabaseManager Class

Manager for interaction with SQL Server.

For a list of all members of this type, see SQLDatabaseManager Members.

System.Object
SQLDatabaseManager

public class SQLDatabaseManager

Remarks

The SQLDatabaseManager class is used by the VDX server framework to communicate with MS SQL Server.

Requirements

Namespace: Deag.Vdx.Server.DAL.SQLServer

Assembly: vdxServer (in vdxServer.dll)

See Also

SQLDatabaseManager Members | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDatabaseManager Members

SQLDatabaseManager overview

Public Static Methods

GetParameterNames | Returns all SQL parameter names contained in the specified query text.
IsConnectionAvailable | Returns whether the connection corresponding to the specified ConnectionInfo is available.

Public Instance Constructors

SQLDatabaseManager Constructor Initializes a new instance of the SQLDatabaseManager class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLDatabaseManager Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDatabaseManager Constructor

Initializes a new instance of the SQLDatabaseManager class.

public SQLDatabaseManager();

See Also

SQLDatabaseManager Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDatabaseManager Methods

The methods of the SQLDatabaseManager class are listed below. For a complete list of SQLDatabaseManager class members, see the SQLDatabaseManager Members topic.

Public Static Methods

GetParameterNames | Returns all SQL parameter names contained in the specified query text.
IsConnectionAvailable | Returns whether the connection corresponding to the specified ConnectionInfo is available.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLDatabaseManager Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDatabaseManager.GetParameterNames Method

Returns all SQL parameter names contained in the specified query text.

public static Hashtable GetParameterNames(
string text
);

Parameters

text
The SQL query text.

Return Value

SQL Parameter names.

See Also

SQLDatabaseManager Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDatabaseManager.IsConnectionAvailable Method

Returns whether the connection corresponding to the specified ConnectionInfo is available.

public static bool IsConnectionAvailable(
ConnectionInfo info
);

Parameters

info
The ConnectionInfo defining the connection.

Return Value

Whether the connection is available.

See Also

SQLDatabaseManager Class | Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SQLDatabaseManager.CommandBuilderTasks Enumeration

Defines which commands should be built from the select command.

public enum SQLDatabaseManager.CommandBuilderTasks

Members

Member Name | Description
Nothing | Do not build any other command
Normal | Build update, insert and delete command from the select command

Requirements

Namespace: Deag.Vdx.Server.DAL.SQLServer

Assembly: vdxServer (in vdxServer.dll)

See Also

Deag.Vdx.Server.DAL.SQLServer Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Server.DAL.SQLServer.Defaults

VDX Framework

Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Classes

Class | Description
BulkInsert | Performs a bulk insert.
CheckDB | Checks whether a data base is present or not.
CheckDBTable | Checks whether a table exists or not.
CreateDB | Creates a data base.
DropDB | Removes a data base.
RunScript | Runs a TSQL script.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


BulkInsert Class

Performs a bulk insert.

For a list of all members of this type, see BulkInsert Members.

System.Object
DataAccess
SQLDataAccess
SQLDataAccessQuery
BulkInsert

public class BulkInsert : SQLDataAccessQuery

Requirements

Namespace: Deag.Vdx.Server.DAL.SQLServer.Defaults

Assembly: vdxServer (in vdxServer.dll)

See Also

BulkInsert Members | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


BulkInsert Members

BulkInsert overview

Public Instance Constructors

BulkInsert Constructor

Public Instance Properties

CanDelete (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform a delete operation.
CanInsert (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform a read operation.
CanRead (inherited from SQLDataAccess) | Gets a value indicating whether the SQLDataAccess can be used for reading.
CanUpdate (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform an update operation.
Codepage |
CommandTimeOut (inherited from SQLDataAccess) | Gets/sets the time out used for the commands.
ConnectionInfo (inherited from DataAccess) | Gets/sets the ConnectionInfo that is used to create the connection string.
ConnectionString (inherited from SQLDataAccess) | Gets/sets the connection string used to connect to the DB.
DeletingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an deleting operation. Default value = true
HasMissingSchemaAction (inherited from DataAccess) | Gets/sets a value indicating whether a MissingSchemaAction is set.
HasTableName (inherited from DataAccess) | Gets a value that indicates whether there is a TableName set.
InsertingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an inserting operation. Default value = true
KeepNulls |
Key (inherited from DataAccess) | Gets/sets the key that identifies this DataAccess object.
MissingSchemaAction (inherited from DataAccess) | Determines the action to take when Cache DataSet schema does not match data read by the DataAccess object. Default is Error.
Parameters (inherited from DataAccess) | Gets the collection of parameters containging storage dependent Filter
ReadingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in a reading operation. Default value = true
SortingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in the sorting process. Default value = true
SqlDelete (inherited from SQLDataAccessQuery) | Gets/sets the delete command.
SqlInsert (inherited from SQLDataAccessQuery) | Gets/sets the insert command.
SqlSelect (inherited from SQLDataAccess) | Gets/sets the select command.
SqlUpdate (inherited from SQLDataAccessQuery) | Gets/sets the update command.
Table (inherited from DataAccess) | Gets/sets the DataTable that is filled with the data this DataAccess object returns.
TableName (inherited from DataAccess) | Gets/sets the name of the DataTable the data (provided by this DataAccess object) is merged in.
Transaction (inherited from DataAccess) | Gets/sets the transaction for the following operations.
UpdatingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an updating operation. Default value = true

Public Instance Methods

AddParameter (inherited from DataAccess) | Overloaded. Adds a parameter to the collection of parameters.
AddParameters (inherited from DataAccess) | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters (inherited from DataAccess) | Clears the collection of parameters.
DataDrivenUpdate (inherited from SQLDataAccessQuery) | Walks through all rows in the Table and executes an Insert, Update or Delete operation depending on the state of the current row.
Delete (inherited from SQLDataAccessQuery) | Performs the delete command.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter (inherited from DataAccess) | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert |
IsOperationEnabled (inherited from DataAccess) | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported (inherited from DataAccess) | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation (inherited from DataAccess) | Executes the specified Operation.
Read (inherited from SQLDataAccess) | Executes the SqlSelect command and writes the returned data into the Table if defined.
ReadCount (inherited from SQLDataAccess) | Returnes the number of rows the SqlSelect command would return.
RefreshStatement |
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from SQLDataAccessQuery) | Performs the update command.

Protected Instance Methods

AdaptSqlParameters (inherited from SQLDataAccess) | Derived classes can override this method to change the types of the parameters.
CatchSqlException (inherited from SQLDataAccess) | Transforms the specified SqlException to a vdxDatabaseException.
CreateStorageDependentFilter (inherited from SQLDataAccess) | Creates SQL Server dependent Filter from a DB independent Filter.
DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific commit method.
GetRollbackCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific rollback method.
GetStorageDependentParameterPrefix (inherited from SQLDataAccess) | Returns the SQL Server parameter prefix. Gibt den SQL Server Parameter Präfix zurück.
InitCountCommand (inherited from SQLDataAccess) | Initializes the SqlCount command with the Parameters of this data access.
InitSelectCommand (inherited from SQLDataAccess) | Initializes the SqlSelect command with the Parameters of this data access and calls the RefreshQuery method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection (inherited from SQLDataAccess) | Updates the ConnectionString depending on the ConnectionInfo.
SetAdapterProperties (inherited from SQLDataAccess) | Sets the CommandTimeout properties of the SqlDataAdapter.
TransformParameter (inherited from SQLDataAccess) | Overloaded. Transforms a parameter's type.

Protected Internal Instance Fields

actualparams (inherited from SQLDataAccess) Parameter des aktuellen Commands --> wird von TransformSQLParameter gebraucht.

Protected Internal Instance Methods

DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
GetParameterList (inherited from SQLDataAccess) | Creates from all parameters of the specified command a string.
UpdateParameters (inherited from SQLDataAccess) | Writes the returned SQL output parameters back to the Parameters.

See Also

BulkInsert Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


BulkInsert Constructor

public BulkInsert(
ConnectionInfo info
);

See Also

BulkInsert Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


BulkInsert Properties

The properties of the BulkInsert class are listed below. For a complete list of BulkInsert class members, see the BulkInsert Members topic.

Public Instance Properties

CanDelete (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform a delete operation.
CanInsert (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform a read operation.
CanRead (inherited from SQLDataAccess) | Gets a value indicating whether the SQLDataAccess can be used for reading.
CanUpdate (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform an update operation.
Codepage |
CommandTimeOut (inherited from SQLDataAccess) | Gets/sets the time out used for the commands.
ConnectionInfo (inherited from DataAccess) | Gets/sets the ConnectionInfo that is used to create the connection string.
ConnectionString (inherited from SQLDataAccess) | Gets/sets the connection string used to connect to the DB.
DeletingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an deleting operation. Default value = true
HasMissingSchemaAction (inherited from DataAccess) | Gets/sets a value indicating whether a MissingSchemaAction is set.
HasTableName (inherited from DataAccess) | Gets a value that indicates whether there is a TableName set.
InsertingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an inserting operation. Default value = true
KeepNulls |
Key (inherited from DataAccess) | Gets/sets the key that identifies this DataAccess object.
MissingSchemaAction (inherited from DataAccess) | Determines the action to take when Cache DataSet schema does not match data read by the DataAccess object. Default is Error.
Parameters (inherited from DataAccess) | Gets the collection of parameters containging storage dependent Filter
ReadingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in a reading operation. Default value = true
SortingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in the sorting process. Default value = true
SqlDelete (inherited from SQLDataAccessQuery) | Gets/sets the delete command.
SqlInsert (inherited from SQLDataAccessQuery) | Gets/sets the insert command.
SqlSelect (inherited from SQLDataAccess) | Gets/sets the select command.
SqlUpdate (inherited from SQLDataAccessQuery) | Gets/sets the update command.
Table (inherited from DataAccess) | Gets/sets the DataTable that is filled with the data this DataAccess object returns.
TableName (inherited from DataAccess) | Gets/sets the name of the DataTable the data (provided by this DataAccess object) is merged in.
Transaction (inherited from DataAccess) | Gets/sets the transaction for the following operations.
UpdatingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an updating operation. Default value = true

See Also

BulkInsert Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


BulkInsert.Codepage Property

public string Codepage {get; set;}

See Also

BulkInsert Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


BulkInsert.KeepNulls Property

public bool KeepNulls {get; set;}

See Also

BulkInsert Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


BulkInsert Methods

The methods of the BulkInsert class are listed below. For a complete list of BulkInsert class members, see the BulkInsert Members topic.

Public Instance Methods

AddParameter (inherited from DataAccess) | Overloaded. Adds a parameter to the collection of parameters.
AddParameters (inherited from DataAccess) | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters (inherited from DataAccess) | Clears the collection of parameters.
DataDrivenUpdate (inherited from SQLDataAccessQuery) | Walks through all rows in the Table and executes an Insert, Update or Delete operation depending on the state of the current row.
Delete (inherited from SQLDataAccessQuery) | Performs the delete command.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter (inherited from DataAccess) | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert |
IsOperationEnabled (inherited from DataAccess) | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported (inherited from DataAccess) | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation (inherited from DataAccess) | Executes the specified Operation.
Read (inherited from SQLDataAccess) | Executes the SqlSelect command and writes the returned data into the Table if defined.
ReadCount (inherited from SQLDataAccess) | Returnes the number of rows the SqlSelect command would return.
RefreshStatement |
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from SQLDataAccessQuery) | Performs the update command.

Protected Instance Methods

AdaptSqlParameters (inherited from SQLDataAccess) | Derived classes can override this method to change the types of the parameters.
CatchSqlException (inherited from SQLDataAccess) | Transforms the specified SqlException to a vdxDatabaseException.
CreateStorageDependentFilter (inherited from SQLDataAccess) | Creates SQL Server dependent Filter from a DB independent Filter.
DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific commit method.
GetRollbackCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific rollback method.
GetStorageDependentParameterPrefix (inherited from SQLDataAccess) | Returns the SQL Server parameter prefix. Gibt den SQL Server Parameter Präfix zurück.
InitCountCommand (inherited from SQLDataAccess) | Initializes the SqlCount command with the Parameters of this data access.
InitSelectCommand (inherited from SQLDataAccess) | Initializes the SqlSelect command with the Parameters of this data access and calls the RefreshQuery method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection (inherited from SQLDataAccess) | Updates the ConnectionString depending on the ConnectionInfo.
SetAdapterProperties (inherited from SQLDataAccess) | Sets the CommandTimeout properties of the SqlDataAdapter.
TransformParameter (inherited from SQLDataAccess) | Overloaded. Transforms a parameter's type.

Protected Internal Instance Methods

DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
GetParameterList (inherited from SQLDataAccess) | Creates from all parameters of the specified command a string.
UpdateParameters (inherited from SQLDataAccess) | Writes the returned SQL output parameters back to the Parameters.

See Also

BulkInsert Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


BulkInsert.Insert Method

public override void Insert();

See Also

BulkInsert Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


BulkInsert.RefreshStatement Method

public void RefreshStatement(
string path,
string table
);

See Also

BulkInsert Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CheckDB Class

Checks whether a data base is present or not.

For a list of all members of this type, see CheckDB Members.

System.Object
DataAccess
SQLDataAccess
SQLDataAccessQuery
CheckDB

public class CheckDB : SQLDataAccessQuery

Requirements

Namespace: Deag.Vdx.Server.DAL.SQLServer.Defaults

Assembly: vdxServer (in vdxServer.dll)

See Also

CheckDB Members | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CheckDB Members

CheckDB overview

Public Instance Constructors

CheckDB Constructor

Public Instance Properties

CanDelete (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform a delete operation.
CanInsert (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform a read operation.
CanRead (inherited from SQLDataAccess) | Gets a value indicating whether the SQLDataAccess can be used for reading.
CanUpdate (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform an update operation.
CommandTimeOut (inherited from SQLDataAccess) | Gets/sets the time out used for the commands.
ConnectionInfo (inherited from DataAccess) | Gets/sets the ConnectionInfo that is used to create the connection string.
ConnectionString (inherited from SQLDataAccess) | Gets/sets the connection string used to connect to the DB.
DeletingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an deleting operation. Default value = true
HasMissingSchemaAction (inherited from DataAccess) | Gets/sets a value indicating whether a MissingSchemaAction is set.
HasTableName (inherited from DataAccess) | Gets a value that indicates whether there is a TableName set.
InsertingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an inserting operation. Default value = true
Key (inherited from DataAccess) | Gets/sets the key that identifies this DataAccess object.
MissingSchemaAction (inherited from DataAccess) | Determines the action to take when Cache DataSet schema does not match data read by the DataAccess object. Default is Error.
Parameters (inherited from DataAccess) | Gets the collection of parameters containging storage dependent Filter
ReadingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in a reading operation. Default value = true
SortingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in the sorting process. Default value = true
SqlDelete (inherited from SQLDataAccessQuery) | Gets/sets the delete command.
SqlInsert (inherited from SQLDataAccessQuery) | Gets/sets the insert command.
SqlSelect (inherited from SQLDataAccess) | Gets/sets the select command.
SqlUpdate (inherited from SQLDataAccessQuery) | Gets/sets the update command.
Table (inherited from DataAccess) | Gets/sets the DataTable that is filled with the data this DataAccess object returns.
TableName (inherited from DataAccess) | Gets/sets the name of the DataTable the data (provided by this DataAccess object) is merged in.
Transaction (inherited from DataAccess) | Gets/sets the transaction for the following operations.
UpdatingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an updating operation. Default value = true

Public Instance Methods

AddParameter (inherited from DataAccess) | Overloaded. Adds a parameter to the collection of parameters.
AddParameters (inherited from DataAccess) | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters (inherited from DataAccess) | Clears the collection of parameters.
DataDrivenUpdate (inherited from SQLDataAccessQuery) | Walks through all rows in the Table and executes an Insert, Update or Delete operation depending on the state of the current row.
Delete (inherited from SQLDataAccessQuery) | Performs the delete command.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter (inherited from DataAccess) | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert (inherited from SQLDataAccessQuery) | Performs the insert command.
IsOperationEnabled (inherited from DataAccess) | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported (inherited from DataAccess) | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation (inherited from DataAccess) | Executes the specified Operation.
Read (inherited from SQLDataAccess) | Executes the SqlSelect command and writes the returned data into the Table if defined.
ReadCount (inherited from SQLDataAccess) | Returnes the number of rows the SqlSelect command would return.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from SQLDataAccessQuery) | Performs the update command.

Protected Instance Methods

AdaptSqlParameters |
CatchSqlException (inherited from SQLDataAccess) | Transforms the specified SqlException to a vdxDatabaseException.
CreateStorageDependentFilter (inherited from SQLDataAccess) | Creates SQL Server dependent Filter from a DB independent Filter.
DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific commit method.
GetRollbackCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific rollback method.
GetStorageDependentParameterPrefix (inherited from SQLDataAccess) | Returns the SQL Server parameter prefix. Gibt den SQL Server Parameter Präfix zurück.
InitCountCommand (inherited from SQLDataAccess) | Initializes the SqlCount command with the Parameters of this data access.
InitSelectCommand (inherited from SQLDataAccess) | Initializes the SqlSelect command with the Parameters of this data access and calls the RefreshQuery method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection (inherited from SQLDataAccess) | Updates the ConnectionString depending on the ConnectionInfo.
SetAdapterProperties (inherited from SQLDataAccess) | Sets the CommandTimeout properties of the SqlDataAdapter.
TransformParameter (inherited from SQLDataAccess) | Overloaded. Transforms a parameter's type.

Protected Internal Instance Fields

actualparams (inherited from SQLDataAccess) Parameter des aktuellen Commands --> wird von TransformSQLParameter gebraucht.

Protected Internal Instance Methods

DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
GetParameterList (inherited from SQLDataAccess) | Creates from all parameters of the specified command a string.
UpdateParameters (inherited from SQLDataAccess) | Writes the returned SQL output parameters back to the Parameters.

See Also

CheckDB Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CheckDB Constructor

public CheckDB(
ConnectionInfo info
);

See Also

CheckDB Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CheckDB Methods

The methods of the CheckDB class are listed below. For a complete list of CheckDB class members, see the CheckDB Members topic.

Public Instance Methods

AddParameter (inherited from DataAccess) | Overloaded. Adds a parameter to the collection of parameters.
AddParameters (inherited from DataAccess) | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters (inherited from DataAccess) | Clears the collection of parameters.
DataDrivenUpdate (inherited from SQLDataAccessQuery) | Walks through all rows in the Table and executes an Insert, Update or Delete operation depending on the state of the current row.
Delete (inherited from SQLDataAccessQuery) | Performs the delete command.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter (inherited from DataAccess) | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert (inherited from SQLDataAccessQuery) | Performs the insert command.
IsOperationEnabled (inherited from DataAccess) | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported (inherited from DataAccess) | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation (inherited from DataAccess) | Executes the specified Operation.
Read (inherited from SQLDataAccess) | Executes the SqlSelect command and writes the returned data into the Table if defined.
ReadCount (inherited from SQLDataAccess) | Returnes the number of rows the SqlSelect command would return.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from SQLDataAccessQuery) | Performs the update command.

Protected Instance Methods

AdaptSqlParameters |
CatchSqlException (inherited from SQLDataAccess) | Transforms the specified SqlException to a vdxDatabaseException.
CreateStorageDependentFilter (inherited from SQLDataAccess) | Creates SQL Server dependent Filter from a DB independent Filter.
DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific commit method.
GetRollbackCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific rollback method.
GetStorageDependentParameterPrefix (inherited from SQLDataAccess) | Returns the SQL Server parameter prefix. Gibt den SQL Server Parameter Präfix zurück.
InitCountCommand (inherited from SQLDataAccess) | Initializes the SqlCount command with the Parameters of this data access.
InitSelectCommand (inherited from SQLDataAccess) | Initializes the SqlSelect command with the Parameters of this data access and calls the RefreshQuery method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection (inherited from SQLDataAccess) | Updates the ConnectionString depending on the ConnectionInfo.
SetAdapterProperties (inherited from SQLDataAccess) | Sets the CommandTimeout properties of the SqlDataAdapter.
TransformParameter (inherited from SQLDataAccess) | Overloaded. Transforms a parameter's type.

Protected Internal Instance Methods

DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
GetParameterList (inherited from SQLDataAccess) | Creates from all parameters of the specified command a string.
UpdateParameters (inherited from SQLDataAccess) | Writes the returned SQL output parameters back to the Parameters.

See Also

CheckDB Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CheckDB.AdaptSqlParameters Method

protected override void AdaptSqlParameters(
SqlParameterCollection sqlParameters,
CommandType commandType
);

See Also

CheckDB Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CheckDBTable Class

Checks whether a table exists or not.

For a list of all members of this type, see CheckDBTable Members.

System.Object
DataAccess
SQLDataAccess
SQLDataAccessQuery
CheckDBTable

public class CheckDBTable : SQLDataAccessQuery

Requirements

Namespace: Deag.Vdx.Server.DAL.SQLServer.Defaults

Assembly: vdxServer (in vdxServer.dll)

See Also

CheckDBTable Members | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CheckDBTable Members

CheckDBTable overview

Public Instance Constructors

CheckDBTable Constructor

Public Instance Properties

CanDelete (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform a delete operation.
CanInsert (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform a read operation.
CanRead (inherited from SQLDataAccess) | Gets a value indicating whether the SQLDataAccess can be used for reading.
CanUpdate (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform an update operation.
CommandTimeOut (inherited from SQLDataAccess) | Gets/sets the time out used for the commands.
ConnectionInfo (inherited from DataAccess) | Gets/sets the ConnectionInfo that is used to create the connection string.
ConnectionString (inherited from SQLDataAccess) | Gets/sets the connection string used to connect to the DB.
DeletingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an deleting operation. Default value = true
HasMissingSchemaAction (inherited from DataAccess) | Gets/sets a value indicating whether a MissingSchemaAction is set.
HasTableName (inherited from DataAccess) | Gets a value that indicates whether there is a TableName set.
InsertingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an inserting operation. Default value = true
Key (inherited from DataAccess) | Gets/sets the key that identifies this DataAccess object.
MissingSchemaAction (inherited from DataAccess) | Determines the action to take when Cache DataSet schema does not match data read by the DataAccess object. Default is Error.
Parameters (inherited from DataAccess) | Gets the collection of parameters containging storage dependent Filter
ReadingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in a reading operation. Default value = true
SortingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in the sorting process. Default value = true
SqlDelete (inherited from SQLDataAccessQuery) | Gets/sets the delete command.
SqlInsert (inherited from SQLDataAccessQuery) | Gets/sets the insert command.
SqlSelect (inherited from SQLDataAccess) | Gets/sets the select command.
SqlUpdate (inherited from SQLDataAccessQuery) | Gets/sets the update command.
Table (inherited from DataAccess) | Gets/sets the DataTable that is filled with the data this DataAccess object returns.
TableName (inherited from DataAccess) | Gets/sets the name of the DataTable the data (provided by this DataAccess object) is merged in.
Transaction (inherited from DataAccess) | Gets/sets the transaction for the following operations.
UpdatingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an updating operation. Default value = true

Public Instance Methods

AddParameter (inherited from DataAccess) | Overloaded. Adds a parameter to the collection of parameters.
AddParameters (inherited from DataAccess) | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters (inherited from DataAccess) | Clears the collection of parameters.
DataDrivenUpdate (inherited from SQLDataAccessQuery) | Walks through all rows in the Table and executes an Insert, Update or Delete operation depending on the state of the current row.
Delete (inherited from SQLDataAccessQuery) | Performs the delete command.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter (inherited from DataAccess) | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert (inherited from SQLDataAccessQuery) | Performs the insert command.
IsOperationEnabled (inherited from DataAccess) | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported (inherited from DataAccess) | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation (inherited from DataAccess) | Executes the specified Operation.
Read (inherited from SQLDataAccess) | Executes the SqlSelect command and writes the returned data into the Table if defined.
ReadCount (inherited from SQLDataAccess) | Returnes the number of rows the SqlSelect command would return.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from SQLDataAccessQuery) | Performs the update command.

Protected Instance Methods

AdaptSqlParameters |
CatchSqlException (inherited from SQLDataAccess) | Transforms the specified SqlException to a vdxDatabaseException.
CreateStorageDependentFilter (inherited from SQLDataAccess) | Creates SQL Server dependent Filter from a DB independent Filter.
DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific commit method.
GetRollbackCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific rollback method.
GetStorageDependentParameterPrefix (inherited from SQLDataAccess) | Returns the SQL Server parameter prefix. Gibt den SQL Server Parameter Präfix zurück.
InitCountCommand (inherited from SQLDataAccess) | Initializes the SqlCount command with the Parameters of this data access.
InitSelectCommand (inherited from SQLDataAccess) | Initializes the SqlSelect command with the Parameters of this data access and calls the RefreshQuery method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection (inherited from SQLDataAccess) | Updates the ConnectionString depending on the ConnectionInfo.
SetAdapterProperties (inherited from SQLDataAccess) | Sets the CommandTimeout properties of the SqlDataAdapter.
TransformParameter (inherited from SQLDataAccess) | Overloaded. Transforms a parameter's type.

Protected Internal Instance Fields

actualparams (inherited from SQLDataAccess) Parameter des aktuellen Commands --> wird von TransformSQLParameter gebraucht.

Protected Internal Instance Methods

DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
GetParameterList (inherited from SQLDataAccess) | Creates from all parameters of the specified command a string.
UpdateParameters (inherited from SQLDataAccess) | Writes the returned SQL output parameters back to the Parameters.

See Also

CheckDBTable Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CheckDBTable Constructor

public CheckDBTable(
ConnectionInfo info,
string table
);

See Also

CheckDBTable Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CheckDBTable Methods

The methods of the CheckDBTable class are listed below. For a complete list of CheckDBTable class members, see the CheckDBTable Members topic.

Public Instance Methods

AddParameter (inherited from DataAccess) | Overloaded. Adds a parameter to the collection of parameters.
AddParameters (inherited from DataAccess) | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters (inherited from DataAccess) | Clears the collection of parameters.
DataDrivenUpdate (inherited from SQLDataAccessQuery) | Walks through all rows in the Table and executes an Insert, Update or Delete operation depending on the state of the current row.
Delete (inherited from SQLDataAccessQuery) | Performs the delete command.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter (inherited from DataAccess) | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert (inherited from SQLDataAccessQuery) | Performs the insert command.
IsOperationEnabled (inherited from DataAccess) | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported (inherited from DataAccess) | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation (inherited from DataAccess) | Executes the specified Operation.
Read (inherited from SQLDataAccess) | Executes the SqlSelect command and writes the returned data into the Table if defined.
ReadCount (inherited from SQLDataAccess) | Returnes the number of rows the SqlSelect command would return.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from SQLDataAccessQuery) | Performs the update command.

Protected Instance Methods

AdaptSqlParameters |
CatchSqlException (inherited from SQLDataAccess) | Transforms the specified SqlException to a vdxDatabaseException.
CreateStorageDependentFilter (inherited from SQLDataAccess) | Creates SQL Server dependent Filter from a DB independent Filter.
DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific commit method.
GetRollbackCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific rollback method.
GetStorageDependentParameterPrefix (inherited from SQLDataAccess) | Returns the SQL Server parameter prefix. Gibt den SQL Server Parameter Präfix zurück.
InitCountCommand (inherited from SQLDataAccess) | Initializes the SqlCount command with the Parameters of this data access.
InitSelectCommand (inherited from SQLDataAccess) | Initializes the SqlSelect command with the Parameters of this data access and calls the RefreshQuery method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection (inherited from SQLDataAccess) | Updates the ConnectionString depending on the ConnectionInfo.
SetAdapterProperties (inherited from SQLDataAccess) | Sets the CommandTimeout properties of the SqlDataAdapter.
TransformParameter (inherited from SQLDataAccess) | Overloaded. Transforms a parameter's type.

Protected Internal Instance Methods

DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
GetParameterList (inherited from SQLDataAccess) | Creates from all parameters of the specified command a string.
UpdateParameters (inherited from SQLDataAccess) | Writes the returned SQL output parameters back to the Parameters.

See Also

CheckDBTable Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CheckDBTable.AdaptSqlParameters Method

protected override void AdaptSqlParameters(
SqlParameterCollection sqlParameters,
CommandType commandType
);

See Also

CheckDBTable Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CreateDB Class

Creates a data base.

For a list of all members of this type, see CreateDB Members.

System.Object
DataAccess
SQLDataAccess
SQLDataAccessQuery
CreateDB

public class CreateDB : SQLDataAccessQuery

Requirements

Namespace: Deag.Vdx.Server.DAL.SQLServer.Defaults

Assembly: vdxServer (in vdxServer.dll)

See Also

CreateDB Members | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CreateDB Members

CreateDB overview

Public Instance Constructors

CreateDB Constructor

Public Instance Properties

CanDelete (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform a delete operation.
CanInsert (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform a read operation.
CanRead (inherited from SQLDataAccess) | Gets a value indicating whether the SQLDataAccess can be used for reading.
CanUpdate (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform an update operation.
CommandTimeOut (inherited from SQLDataAccess) | Gets/sets the time out used for the commands.
ConnectionInfo (inherited from DataAccess) | Gets/sets the ConnectionInfo that is used to create the connection string.
ConnectionString (inherited from SQLDataAccess) | Gets/sets the connection string used to connect to the DB.
DeletingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an deleting operation. Default value = true
HasMissingSchemaAction (inherited from DataAccess) | Gets/sets a value indicating whether a MissingSchemaAction is set.
HasTableName (inherited from DataAccess) | Gets a value that indicates whether there is a TableName set.
InsertingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an inserting operation. Default value = true
Key (inherited from DataAccess) | Gets/sets the key that identifies this DataAccess object.
MissingSchemaAction (inherited from DataAccess) | Determines the action to take when Cache DataSet schema does not match data read by the DataAccess object. Default is Error.
Parameters (inherited from DataAccess) | Gets the collection of parameters containging storage dependent Filter
ReadingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in a reading operation. Default value = true
SortingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in the sorting process. Default value = true
SqlDelete (inherited from SQLDataAccessQuery) | Gets/sets the delete command.
SqlInsert (inherited from SQLDataAccessQuery) | Gets/sets the insert command.
SqlSelect (inherited from SQLDataAccess) | Gets/sets the select command.
SqlUpdate (inherited from SQLDataAccessQuery) | Gets/sets the update command.
Table (inherited from DataAccess) | Gets/sets the DataTable that is filled with the data this DataAccess object returns.
TableName (inherited from DataAccess) | Gets/sets the name of the DataTable the data (provided by this DataAccess object) is merged in.
Transaction (inherited from DataAccess) | Gets/sets the transaction for the following operations.
UpdatingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an updating operation. Default value = true

Public Instance Methods

AddParameter (inherited from DataAccess) | Overloaded. Adds a parameter to the collection of parameters.
AddParameters (inherited from DataAccess) | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters (inherited from DataAccess) | Clears the collection of parameters.
DataDrivenUpdate (inherited from SQLDataAccessQuery) | Walks through all rows in the Table and executes an Insert, Update or Delete operation depending on the state of the current row.
Delete (inherited from SQLDataAccessQuery) | Performs the delete command.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter (inherited from DataAccess) | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert |
IsOperationEnabled (inherited from DataAccess) | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported (inherited from DataAccess) | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation (inherited from DataAccess) | Executes the specified Operation.
Read (inherited from SQLDataAccess) | Executes the SqlSelect command and writes the returned data into the Table if defined.
ReadCount (inherited from SQLDataAccess) | Returnes the number of rows the SqlSelect command would return.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from SQLDataAccessQuery) | Performs the update command.

Protected Instance Methods

AdaptSqlParameters (inherited from SQLDataAccess) | Derived classes can override this method to change the types of the parameters.
CatchSqlException (inherited from SQLDataAccess) | Transforms the specified SqlException to a vdxDatabaseException.
CreateStorageDependentFilter (inherited from SQLDataAccess) | Creates SQL Server dependent Filter from a DB independent Filter.
DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific commit method.
GetRollbackCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific rollback method.
GetStorageDependentParameterPrefix (inherited from SQLDataAccess) | Returns the SQL Server parameter prefix. Gibt den SQL Server Parameter Präfix zurück.
InitCountCommand (inherited from SQLDataAccess) | Initializes the SqlCount command with the Parameters of this data access.
InitSelectCommand (inherited from SQLDataAccess) | Initializes the SqlSelect command with the Parameters of this data access and calls the RefreshQuery method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection (inherited from SQLDataAccess) | Updates the ConnectionString depending on the ConnectionInfo.
SetAdapterProperties (inherited from SQLDataAccess) | Sets the CommandTimeout properties of the SqlDataAdapter.
TransformParameter (inherited from SQLDataAccess) | Overloaded. Transforms a parameter's type.

Protected Internal Instance Fields

actualparams (inherited from SQLDataAccess) Parameter des aktuellen Commands --> wird von TransformSQLParameter gebraucht.

Protected Internal Instance Methods

DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
GetParameterList (inherited from SQLDataAccess) | Creates from all parameters of the specified command a string.
UpdateParameters (inherited from SQLDataAccess) | Writes the returned SQL output parameters back to the Parameters.

See Also

CreateDB Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CreateDB Constructor

public CreateDB(
ConnectionInfo info
);

See Also

CreateDB Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CreateDB Methods

The methods of the CreateDB class are listed below. For a complete list of CreateDB class members, see the CreateDB Members topic.

Public Instance Methods

AddParameter (inherited from DataAccess) | Overloaded. Adds a parameter to the collection of parameters.
AddParameters (inherited from DataAccess) | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters (inherited from DataAccess) | Clears the collection of parameters.
DataDrivenUpdate (inherited from SQLDataAccessQuery) | Walks through all rows in the Table and executes an Insert, Update or Delete operation depending on the state of the current row.
Delete (inherited from SQLDataAccessQuery) | Performs the delete command.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter (inherited from DataAccess) | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert |
IsOperationEnabled (inherited from DataAccess) | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported (inherited from DataAccess) | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation (inherited from DataAccess) | Executes the specified Operation.
Read (inherited from SQLDataAccess) | Executes the SqlSelect command and writes the returned data into the Table if defined.
ReadCount (inherited from SQLDataAccess) | Returnes the number of rows the SqlSelect command would return.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from SQLDataAccessQuery) | Performs the update command.

Protected Instance Methods

AdaptSqlParameters (inherited from SQLDataAccess) | Derived classes can override this method to change the types of the parameters.
CatchSqlException (inherited from SQLDataAccess) | Transforms the specified SqlException to a vdxDatabaseException.
CreateStorageDependentFilter (inherited from SQLDataAccess) | Creates SQL Server dependent Filter from a DB independent Filter.
DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific commit method.
GetRollbackCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific rollback method.
GetStorageDependentParameterPrefix (inherited from SQLDataAccess) | Returns the SQL Server parameter prefix. Gibt den SQL Server Parameter Präfix zurück.
InitCountCommand (inherited from SQLDataAccess) | Initializes the SqlCount command with the Parameters of this data access.
InitSelectCommand (inherited from SQLDataAccess) | Initializes the SqlSelect command with the Parameters of this data access and calls the RefreshQuery method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection (inherited from SQLDataAccess) | Updates the ConnectionString depending on the ConnectionInfo.
SetAdapterProperties (inherited from SQLDataAccess) | Sets the CommandTimeout properties of the SqlDataAdapter.
TransformParameter (inherited from SQLDataAccess) | Overloaded. Transforms a parameter's type.

Protected Internal Instance Methods

DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
GetParameterList (inherited from SQLDataAccess) | Creates from all parameters of the specified command a string.
UpdateParameters (inherited from SQLDataAccess) | Writes the returned SQL output parameters back to the Parameters.

See Also

CreateDB Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CreateDB.Insert Method

public override void Insert();

See Also

CreateDB Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DropDB Class

Removes a data base.

For a list of all members of this type, see DropDB Members.

System.Object
DataAccess
SQLDataAccess
SQLDataAccessQuery
DropDB

public class DropDB : SQLDataAccessQuery

Requirements

Namespace: Deag.Vdx.Server.DAL.SQLServer.Defaults

Assembly: vdxServer (in vdxServer.dll)

See Also

DropDB Members | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DropDB Members

DropDB overview

Public Instance Constructors

DropDB Constructor

Public Instance Properties

CanDelete (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform a delete operation.
CanInsert (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform a read operation.
CanRead (inherited from SQLDataAccess) | Gets a value indicating whether the SQLDataAccess can be used for reading.
CanUpdate (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform an update operation.
CommandTimeOut (inherited from SQLDataAccess) | Gets/sets the time out used for the commands.
ConnectionInfo (inherited from DataAccess) | Gets/sets the ConnectionInfo that is used to create the connection string.
ConnectionString (inherited from SQLDataAccess) | Gets/sets the connection string used to connect to the DB.
DeletingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an deleting operation. Default value = true
HasMissingSchemaAction (inherited from DataAccess) | Gets/sets a value indicating whether a MissingSchemaAction is set.
HasTableName (inherited from DataAccess) | Gets a value that indicates whether there is a TableName set.
InsertingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an inserting operation. Default value = true
Key (inherited from DataAccess) | Gets/sets the key that identifies this DataAccess object.
MissingSchemaAction (inherited from DataAccess) | Determines the action to take when Cache DataSet schema does not match data read by the DataAccess object. Default is Error.
Parameters (inherited from DataAccess) | Gets the collection of parameters containging storage dependent Filter
ReadingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in a reading operation. Default value = true
SortingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in the sorting process. Default value = true
SqlDelete (inherited from SQLDataAccessQuery) | Gets/sets the delete command.
SqlInsert (inherited from SQLDataAccessQuery) | Gets/sets the insert command.
SqlSelect (inherited from SQLDataAccess) | Gets/sets the select command.
SqlUpdate (inherited from SQLDataAccessQuery) | Gets/sets the update command.
Table (inherited from DataAccess) | Gets/sets the DataTable that is filled with the data this DataAccess object returns.
TableName (inherited from DataAccess) | Gets/sets the name of the DataTable the data (provided by this DataAccess object) is merged in.
Transaction (inherited from DataAccess) | Gets/sets the transaction for the following operations.
UpdatingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an updating operation. Default value = true

Public Instance Methods

AddParameter (inherited from DataAccess) | Overloaded. Adds a parameter to the collection of parameters.
AddParameters (inherited from DataAccess) | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters (inherited from DataAccess) | Clears the collection of parameters.
DataDrivenUpdate (inherited from SQLDataAccessQuery) | Walks through all rows in the Table and executes an Insert, Update or Delete operation depending on the state of the current row.
Delete (inherited from SQLDataAccessQuery) | Performs the delete command.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter (inherited from DataAccess) | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert |
IsOperationEnabled (inherited from DataAccess) | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported (inherited from DataAccess) | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation (inherited from DataAccess) | Executes the specified Operation.
Read (inherited from SQLDataAccess) | Executes the SqlSelect command and writes the returned data into the Table if defined.
ReadCount (inherited from SQLDataAccess) | Returnes the number of rows the SqlSelect command would return.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from SQLDataAccessQuery) | Performs the update command.

Protected Instance Methods

AdaptSqlParameters (inherited from SQLDataAccess) | Derived classes can override this method to change the types of the parameters.
CatchSqlException (inherited from SQLDataAccess) | Transforms the specified SqlException to a vdxDatabaseException.
CreateStorageDependentFilter (inherited from SQLDataAccess) | Creates SQL Server dependent Filter from a DB independent Filter.
DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific commit method.
GetRollbackCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific rollback method.
GetStorageDependentParameterPrefix (inherited from SQLDataAccess) | Returns the SQL Server parameter prefix. Gibt den SQL Server Parameter Präfix zurück.
InitCountCommand (inherited from SQLDataAccess) | Initializes the SqlCount command with the Parameters of this data access.
InitSelectCommand (inherited from SQLDataAccess) | Initializes the SqlSelect command with the Parameters of this data access and calls the RefreshQuery method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection (inherited from SQLDataAccess) | Updates the ConnectionString depending on the ConnectionInfo.
SetAdapterProperties (inherited from SQLDataAccess) | Sets the CommandTimeout properties of the SqlDataAdapter.
TransformParameter (inherited from SQLDataAccess) | Overloaded. Transforms a parameter's type.

Protected Internal Instance Fields

actualparams (inherited from SQLDataAccess) Parameter des aktuellen Commands --> wird von TransformSQLParameter gebraucht.

Protected Internal Instance Methods

DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
GetParameterList (inherited from SQLDataAccess) | Creates from all parameters of the specified command a string.
UpdateParameters (inherited from SQLDataAccess) | Writes the returned SQL output parameters back to the Parameters.

See Also

DropDB Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DropDB Constructor

public DropDB(
ConnectionInfo info
);

See Also

DropDB Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DropDB Methods

The methods of the DropDB class are listed below. For a complete list of DropDB class members, see the DropDB Members topic.

Public Instance Methods

AddParameter (inherited from DataAccess) | Overloaded. Adds a parameter to the collection of parameters.
AddParameters (inherited from DataAccess) | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters (inherited from DataAccess) | Clears the collection of parameters.
DataDrivenUpdate (inherited from SQLDataAccessQuery) | Walks through all rows in the Table and executes an Insert, Update or Delete operation depending on the state of the current row.
Delete (inherited from SQLDataAccessQuery) | Performs the delete command.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter (inherited from DataAccess) | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert |
IsOperationEnabled (inherited from DataAccess) | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported (inherited from DataAccess) | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation (inherited from DataAccess) | Executes the specified Operation.
Read (inherited from SQLDataAccess) | Executes the SqlSelect command and writes the returned data into the Table if defined.
ReadCount (inherited from SQLDataAccess) | Returnes the number of rows the SqlSelect command would return.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from SQLDataAccessQuery) | Performs the update command.

Protected Instance Methods

AdaptSqlParameters (inherited from SQLDataAccess) | Derived classes can override this method to change the types of the parameters.
CatchSqlException (inherited from SQLDataAccess) | Transforms the specified SqlException to a vdxDatabaseException.
CreateStorageDependentFilter (inherited from SQLDataAccess) | Creates SQL Server dependent Filter from a DB independent Filter.
DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific commit method.
GetRollbackCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific rollback method.
GetStorageDependentParameterPrefix (inherited from SQLDataAccess) | Returns the SQL Server parameter prefix. Gibt den SQL Server Parameter Präfix zurück.
InitCountCommand (inherited from SQLDataAccess) | Initializes the SqlCount command with the Parameters of this data access.
InitSelectCommand (inherited from SQLDataAccess) | Initializes the SqlSelect command with the Parameters of this data access and calls the RefreshQuery method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection (inherited from SQLDataAccess) | Updates the ConnectionString depending on the ConnectionInfo.
SetAdapterProperties (inherited from SQLDataAccess) | Sets the CommandTimeout properties of the SqlDataAdapter.
TransformParameter (inherited from SQLDataAccess) | Overloaded. Transforms a parameter's type.

Protected Internal Instance Methods

DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
GetParameterList (inherited from SQLDataAccess) | Creates from all parameters of the specified command a string.
UpdateParameters (inherited from SQLDataAccess) | Writes the returned SQL output parameters back to the Parameters.

See Also

DropDB Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DropDB.Insert Method

public override void Insert();

See Also

DropDB Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


RunScript Class

Runs a TSQL script.

For a list of all members of this type, see RunScript Members.

System.Object
DataAccess
SQLDataAccess
SQLDataAccessQuery
RunScript

public class RunScript : SQLDataAccessQuery

Requirements

Namespace: Deag.Vdx.Server.DAL.SQLServer.Defaults

Assembly: vdxServer (in vdxServer.dll)

See Also

RunScript Members | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


RunScript Members

RunScript overview

Public Instance Constructors

RunScript Constructor

Public Instance Properties

CanDelete (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform a delete operation.
CanInsert (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform a read operation.
CanRead (inherited from SQLDataAccess) | Gets a value indicating whether the SQLDataAccess can be used for reading.
CanUpdate (inherited from SQLDataAccessQuery) | Returns a value indicating whether this data access can perform an update operation.
CommandTimeOut (inherited from SQLDataAccess) | Gets/sets the time out used for the commands.
ConnectionInfo (inherited from DataAccess) | Gets/sets the ConnectionInfo that is used to create the connection string.
ConnectionString (inherited from SQLDataAccess) | Gets/sets the connection string used to connect to the DB.
DeletingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an deleting operation. Default value = true
HasMissingSchemaAction (inherited from DataAccess) | Gets/sets a value indicating whether a MissingSchemaAction is set.
HasTableName (inherited from DataAccess) | Gets a value that indicates whether there is a TableName set.
InsertingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an inserting operation. Default value = true
Key (inherited from DataAccess) | Gets/sets the key that identifies this DataAccess object.
MissingSchemaAction (inherited from DataAccess) | Determines the action to take when Cache DataSet schema does not match data read by the DataAccess object. Default is Error.
Parameters (inherited from DataAccess) | Gets the collection of parameters containging storage dependent Filter
ReadingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in a reading operation. Default value = true
SortingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in the sorting process. Default value = true
SqlDelete (inherited from SQLDataAccessQuery) | Gets/sets the delete command.
SqlInsert (inherited from SQLDataAccessQuery) | Gets/sets the insert command.
SqlSelect (inherited from SQLDataAccess) | Gets/sets the select command.
SqlUpdate (inherited from SQLDataAccessQuery) | Gets/sets the update command.
Table (inherited from DataAccess) | Gets/sets the DataTable that is filled with the data this DataAccess object returns.
TableName (inherited from DataAccess) | Gets/sets the name of the DataTable the data (provided by this DataAccess object) is merged in.
Transaction (inherited from DataAccess) | Gets/sets the transaction for the following operations.
UpdatingEnabled (inherited from DataAccess) | Gets/sets a value that indicates whether the DataAccess object should take part in an updating operation. Default value = true

Public Instance Methods

AddParameter (inherited from DataAccess) | Overloaded. Adds a parameter to the collection of parameters.
AddParameters (inherited from DataAccess) | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters (inherited from DataAccess) | Clears the collection of parameters.
DataDrivenUpdate (inherited from SQLDataAccessQuery) | Walks through all rows in the Table and executes an Insert, Update or Delete operation depending on the state of the current row.
Delete (inherited from SQLDataAccessQuery) | Performs the delete command.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter (inherited from DataAccess) | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert |
IsOperationEnabled (inherited from DataAccess) | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported (inherited from DataAccess) | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation (inherited from DataAccess) | Executes the specified Operation.
Read (inherited from SQLDataAccess) | Executes the SqlSelect command and writes the returned data into the Table if defined.
ReadCount (inherited from SQLDataAccess) | Returnes the number of rows the SqlSelect command would return.
RefreshStatement |
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from SQLDataAccessQuery) | Performs the update command.

Protected Instance Methods

AdaptSqlParameters (inherited from SQLDataAccess) | Derived classes can override this method to change the types of the parameters.
CatchSqlException (inherited from SQLDataAccess) | Transforms the specified SqlException to a vdxDatabaseException.
CreateStorageDependentFilter (inherited from SQLDataAccess) | Creates SQL Server dependent Filter from a DB independent Filter.
DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific commit method.
GetRollbackCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific rollback method.
GetStorageDependentParameterPrefix (inherited from SQLDataAccess) | Returns the SQL Server parameter prefix. Gibt den SQL Server Parameter Präfix zurück.
InitCountCommand (inherited from SQLDataAccess) | Initializes the SqlCount command with the Parameters of this data access.
InitSelectCommand (inherited from SQLDataAccess) | Initializes the SqlSelect command with the Parameters of this data access and calls the RefreshQuery method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection (inherited from SQLDataAccess) | Updates the ConnectionString depending on the ConnectionInfo.
SetAdapterProperties (inherited from SQLDataAccess) | Sets the CommandTimeout properties of the SqlDataAdapter.
TransformParameter (inherited from SQLDataAccess) | Overloaded. Transforms a parameter's type.

Protected Internal Instance Fields

actualparams (inherited from SQLDataAccess) Parameter des aktuellen Commands --> wird von TransformSQLParameter gebraucht.

Protected Internal Instance Methods

DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
GetParameterList (inherited from SQLDataAccess) | Creates from all parameters of the specified command a string.
UpdateParameters (inherited from SQLDataAccess) | Writes the returned SQL output parameters back to the Parameters.

See Also

RunScript Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


RunScript Constructor

public RunScript(
ConnectionInfo info
);

See Also

RunScript Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


RunScript Methods

The methods of the RunScript class are listed below. For a complete list of RunScript class members, see the RunScript Members topic.

Public Instance Methods

AddParameter (inherited from DataAccess) | Overloaded. Adds a parameter to the collection of parameters.
AddParameters (inherited from DataAccess) | Overloaded. Adds the specified Parameters to the data access's collection of parameters.
ClearParameters (inherited from DataAccess) | Clears the collection of parameters.
DataDrivenUpdate (inherited from SQLDataAccessQuery) | Walks through all rows in the Table and executes an Insert, Update or Delete operation depending on the state of the current row.
Delete (inherited from SQLDataAccessQuery) | Performs the delete command.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetParameter (inherited from DataAccess) | Returns the parameter with the specified name from the collection of parameters. Null is returned if no parameter with the specified name can be found.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert |
IsOperationEnabled (inherited from DataAccess) | Returns a value indicating whether the specified Operation is enabled.
IsOperationSupported (inherited from DataAccess) | Returns a value indicating whether the specified Operation can be performed by this DataAccess.
PerformOperation (inherited from DataAccess) | Executes the specified Operation.
Read (inherited from SQLDataAccess) | Executes the SqlSelect command and writes the returned data into the Table if defined.
ReadCount (inherited from SQLDataAccess) | Returnes the number of rows the SqlSelect command would return.
RefreshStatement |
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from SQLDataAccessQuery) | Performs the update command.

Protected Instance Methods

AdaptSqlParameters (inherited from SQLDataAccess) | Derived classes can override this method to change the types of the parameters.
CatchSqlException (inherited from SQLDataAccess) | Transforms the specified SqlException to a vdxDatabaseException.
CreateStorageDependentFilter (inherited from SQLDataAccess) | Creates SQL Server dependent Filter from a DB independent Filter.
DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCommitCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific commit method.
GetRollbackCallback (inherited from SQLDataAccess) | Returns the delegate to the SQL Server specific rollback method.
GetStorageDependentParameterPrefix (inherited from SQLDataAccess) | Returns the SQL Server parameter prefix. Gibt den SQL Server Parameter Präfix zurück.
InitCountCommand (inherited from SQLDataAccess) | Initializes the SqlCount command with the Parameters of this data access.
InitSelectCommand (inherited from SQLDataAccess) | Initializes the SqlSelect command with the Parameters of this data access and calls the RefreshQuery method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshConnection (inherited from SQLDataAccess) | Updates the ConnectionString depending on the ConnectionInfo.
SetAdapterProperties (inherited from SQLDataAccess) | Sets the CommandTimeout properties of the SqlDataAdapter.
TransformParameter (inherited from SQLDataAccess) | Overloaded. Transforms a parameter's type.

Protected Internal Instance Methods

DebugSqlQuery (inherited from SQLDataAccess) | Overloaded. Can be overriden to debug the query that will be sent to the DB.
GetParameterList (inherited from SQLDataAccess) | Creates from all parameters of the specified command a string.
UpdateParameters (inherited from SQLDataAccess) | Writes the returned SQL output parameters back to the Parameters.

See Also

RunScript Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


RunScript.Insert Method

public override void Insert();

See Also

RunScript Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


RunScript.RefreshStatement Method

public void RefreshStatement(
string query
);

See Also

RunScript Class | Deag.Vdx.Server.DAL.SQLServer.Defaults Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Server.Entity

VDX Framework

Deag.Vdx.Server.Entity Namespace

The Deag.Vdx.Server.Entity namespace contains classes for building entities. An entity is a logical unit of data and functionality for manipulating and managing that data. Entities can be used to abstract the data storage by holding all data specific to a instance of data and all logic involved with this data in one single place. Furthermore entities give you the ability of building complex object models for easier data manipulation.

Classes

Class | Description
EntityBase | Base class for all entities.
EntityList | Manages a collection of EntityObjects.
EntityObject | An EntityObject represents one single logical entity.

Structures

Structure | Description
AlternativeData | Data structure for defining alternative data.

Enumerations

Enumeration | Description
CacheIntegrityCondition | Defines the condition that defines if the DsCache is in a correct state.
EntityBase.ConstraintActionType | Defines how the constraints on the DsCache are handled.
EntityBase.DataAccessRefreshType | Defines how the collection of DataAccess object is refreshed.
EntityBase.DataAccessSortType | Defines the way the DataAccess objects are sorted.
EntityStatus | Defines the state of an entity.
EntityStatusDriver | Defines the way the Status is determined.
ReadStatus | Defines the result of a read operation.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AlternativeData Structure

Data structure for defining alternative data.

For a list of all members of this type, see AlternativeData Members.

System.Object
ValueType
AlternativeData

public struct AlternativeData

Remarks

Alternative data is data that does not belong to the "real" data of an entity. Normally it is additional descriptive data.

Alternative data can be used with EntityBase and Viewer.

The alternative DataTable can be an extra table or an table of the Cache DataSet of the entity.

Example

The following example shows how alternative data is read for a person:

            public DSPersonWithAdditionalData ReadPersonWithAdditionalData(int personID)
            {
                DSPersonWithAdditionalData ds = new DSPersonWithAdditionalData();
                EOPerson eo = new EOPerson();
                eo.ID = personID;
                // set the alternative data information (in which table to read, which
                // DataAccess reads the data,
                // after which operations it should be read and whether the data read for the person
                // should be passed to the data access that reads the alternative data.
                eo.SetAlternativeData(ds.AdditionalData, new DAPersonAdditionalData, true, true, true, false, true);

                // read the data of the person, the alternative data is read simultaniously!
                if (eo.Read())
                {
                    // merge the data of the person into the data set that has an additinal table for the
                    // alternative data
                    ds.Merge(eo.Serialize());

                    // now all data is in this single data set
                    return ds;
                }
                return null;
            }

Requirements

Namespace: Deag.Vdx.Server.Entity

Assembly: vdxServer (in vdxServer.dll)

See Also

AlternativeData Members | Deag.Vdx.Server.Entity Namespace | SetAlternativeData | SerializeAlternativeData | AlternativeTable

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AlternativeData Members

AlternativeData overview

Public Instance Fields

Access | This DataAccess is used to read the alternative data.
AfterDelete | Indicates whether alternative data is read after a delete operation.
AfterInsert | Indicates whether alternative data is read after an insert operation.
AfterRead | Indicates whether alternative data is read after a read operation.
AfterUpdate | Indicates whether alternative data is read after an update operation.
Table | The alternative DataTable.
UseDirectlyReadData | Indicates whether the alternative data can be taken from the "real" data read for the entity.
UseParametersFromCache | Gets/sets whether in the initialization of the alternative DataAccess Parameters created from the data in the DsCache are added.

Public Instance Methods

Clear | Deletes the entry for the alternative data --> no alternative data will be read in the future.
Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEnabled | Returns a value indicating whether the alternative data should be read after the specified op.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AlternativeData Class | Deag.Vdx.Server.Entity Namespace | SetAlternativeData | SerializeAlternativeData | AlternativeTable

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AlternativeData Fields

The fields of the AlternativeData structure are listed below. For a complete list of AlternativeData structure members, see the AlternativeData Members topic.

Public Instance Fields

Access | This DataAccess is used to read the alternative data.
AfterDelete | Indicates whether alternative data is read after a delete operation.
AfterInsert | Indicates whether alternative data is read after an insert operation.
AfterRead | Indicates whether alternative data is read after a read operation.
AfterUpdate | Indicates whether alternative data is read after an update operation.
Table | The alternative DataTable.
UseDirectlyReadData | Indicates whether the alternative data can be taken from the "real" data read for the entity.
UseParametersFromCache | Gets/sets whether in the initialization of the alternative DataAccess Parameters created from the data in the DsCache are added.

See Also

AlternativeData Class | Deag.Vdx.Server.Entity Namespace | SetAlternativeData | SerializeAlternativeData | AlternativeTable

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AlternativeData.Access Field

This DataAccess is used to read the alternative data.

public DataAccess Access;

Remarks

This DataAccess is used to fill the Table with the alternative data.

See Also

AlternativeData Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AlternativeData.AfterDelete Field

Indicates whether alternative data is read after a delete operation.

public bool AfterDelete;

See Also

AlternativeData Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AlternativeData.AfterInsert Field

Indicates whether alternative data is read after an insert operation.

public bool AfterInsert;

See Also

AlternativeData Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AlternativeData.AfterRead Field

Indicates whether alternative data is read after a read operation.

public bool AfterRead;

See Also

AlternativeData Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AlternativeData.AfterUpdate Field

Indicates whether alternative data is read after an update operation.

public bool AfterUpdate;

See Also

AlternativeData Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AlternativeData.Table Field

The alternative DataTable.

public DataTable Table;

Remarks

Alternative data is written to this table.

See Also

AlternativeData Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AlternativeData.UseDirectlyReadData Field

Indicates whether the alternative data can be taken from the "real" data read for the entity.

public bool UseDirectlyReadData;

Remarks

Set this value to true if your DataAccess, which reads the data for the entity, read the alternative data, too. This can be used to read the alternative data in the same operation with the "real" data.

See Also

AlternativeData Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AlternativeData.UseParametersFromCache Field

Gets/sets whether in the initialization of the alternative DataAccess Parameters created from the data in the DsCache are added.

public bool UseParametersFromCache;

Remarks

If your DataAccess for alternative data needs data that was read with the "real" data of the entity then set this value to true. Then for each column of the table where the data was read intom a Parameter is created with the name of the column and with a FilterEQUAL holding the value in that column.

See Also

AlternativeData Class | Deag.Vdx.Server.Entity Namespace | GetParametersFromCache

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AlternativeData Methods

The methods of the AlternativeData structure are listed below. For a complete list of AlternativeData structure members, see the AlternativeData Members topic.

Public Instance Methods

Clear | Deletes the entry for the alternative data --> no alternative data will be read in the future.
Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEnabled | Returns a value indicating whether the alternative data should be read after the specified op.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AlternativeData Class | Deag.Vdx.Server.Entity Namespace | SetAlternativeData | SerializeAlternativeData | AlternativeTable

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AlternativeData.Clear Method

Deletes the entry for the alternative data --> no alternative data will be read in the future.

public void Clear();

See Also

AlternativeData Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


AlternativeData.IsEnabled Method

Returns a value indicating whether the alternative data should be read after the specified op.

public bool IsEnabled(
Operation op
);

Parameters

op
Operation.

Return Value

Whether the alternative data should be read.

See Also

AlternativeData Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


CacheIntegrityCondition Enumeration

Defines the condition that defines if the DsCache is in a correct state.

public enum CacheIntegrityCondition

Members

Member Name | Description
ZeroOrOneRow | 0 or 1 rows are allowed.
ExactlyOneRow | The cache has to contain exactly one row.
Single | Option for EntityObjects. Depending on AutoAddRow this option is equivalent to either ZeroOrOneRow (AutoAddRow = false) or ExactlyOneRow (AutoAddRow = true).
Collection | Option for EntityLists. There is no restriction of the number of rows in the cache ([0,n])

Requirements

Namespace: Deag.Vdx.Server.Entity

Assembly: vdxServer (in vdxServer.dll)

See Also

Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase Class

Base class for all entities.

For a list of all members of this type, see EntityBase Members.

System.Object
EntityBase

public abstract class EntityBase

Remarks

An entity is an abstraction of a part of the storage.

An EntityBase contains a collection of storage dependent DataAccess to comunicate with the storage (read, write, delete data).

Each entity holds a DataSet called its Cache, to store the data that defines the entity. The DataAccess objects are used to fill this cache with data from the storage and to update the data in the storage.

An AlternativeData struct can be assigned to read alternative data for this entity.

A entity can have a Parent entity. For example have all entities of an EntityList this EntityList as their parent.

Requirements

Namespace: Deag.Vdx.Server.Entity

Assembly: vdxServer (in vdxServer.dll)

See Also

EntityBase Members | Deag.Vdx.Server.Entity Namespace | AlternativeData | EntityObject | EntityList | Viewer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase Members

EntityBase overview

Public Instance Constructors

EntityBase Constructor Iniitalizes a new instance of the EntityBase class.

Public Instance Properties

Parent | Gets/sets the EntityBase that is the parent of this entity. Default value = null.
Status | Returns a value that indicats the EntityStatus of the entity. Default value (after creation) = Unspecified.
StatusDriver | Gets the EntityStatusDriver. Default value = DataDriven

Public Instance Methods

ClearAlternativeTable | Deletes the information about alternative data --> no alternative data is read any more.
Deserialize | Overloaded. Fills the DsCache with the data in the passed DataRow. It is merged with Ignore.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Serialize | Returns a copy of the DsCache.
SerializeAlternativeData | Serializes the alternative data into a DataTable.
SetAlternativeData | Overloaded. Sets the information which alternative data should be read and by which operations.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Validates the Entity.

Protected Instance Fields

entityStatus The internal EntityStatus.

Protected Instance Properties

ConstraintAction | Gets/sets a value indicating the way constraints are handled. Default value = Keep.
DataAccessRefreshing | Gets/sets the way the DataAccess objects are refreshed. Default value = All
DataAccessSorting | Gets/sets a value indicating whether the DataAccess objects are sorted. Default value = true
DataSetType | Gets/sets the type of the cache dataset.
DsCache | Gets/sets the cache of the entity.
EnforceCacheConstraints | Gets or sets EnforceConstraints on DsCache. Default value = true.

Protected Instance Methods

AddAccessObject | Adds a DataAccess object to the collection of data access objects.
AddAccessObjects | Adds the specified DataAccess objects to the collection of data access objects.
CheckCacheIntegrity | Checks the integrity of the DsCache.
ClearCache | Clears the DsCache.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAccessObject | Returns the DataAccess object with the specified key from the collection of data access objects.
GetCacheTable | Returns the DataTable from the DsCache.
GetDataDrivenStatus | Returns the currently set internal status. See SetEntityStatus.
GetParametersFromCache | Derived classes creates for each item in the Cache a Parameter.
GetRowStateDrivenStatus | Derived classes override this method to return the row state driven Status.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PerformOperation | Executes the specified Operation in the specified Transaction on the specified DataAccess.
PerformRead | Fills the DsCache by executing the Read operation on all reading enabled DataAccess objects. Not to be called directly. Use Read or Read.
PerformReadCount | Returns the maximal number of rows a DataAccess of this entity would return in a read operation. Not to be called directly. Use ReadCount.
ProcessReturnedParameters | Called after a read, insert, update or delete operation. Derived classes use this methode to access parameters that contain result values.
ReadAlternativeData | Overloaded. Reads the alternative data.
RecordException | Records an Exception onto a Transaction. If the specified transaction is null then the exception is thrown instead. If the exception was recorded then cancel will be set to true.
RefreshDataAccessObject | Refreshs a single DataAccess object.
RefreshDataAccessObjects | Refreshs all DataAccess objects. This method can be overriden if you want refresh all data access in one place.
RemoveAccessObject | Removes a DataAccess object form the collection of data access objects.
SetConstraintsAfterOperation | Re-enables the constraints of the specified dataset if the specified action demands it.
SetConstraintsBeforeOperation | Disables the constraints of the DsCache if the specified action demands it.
SetEntityStatus | Sets the Status to the specified 'status'.
SetEntityStatusDriver | Sets the EntityStatusDriver.
SortAccessObjects | Sorts the DataAccess objects by relations and constriants. Loop are not supported. This method is called internally when a read operation is executed.

Protected Internal Instance Properties

AccessObjects | Gets the collection of DataAccess objects of this object. Do not modify this collection use AddAccessObject and RemoveAccessObject instead.
AlternativeData | Gets the AlternativeData information of this EntityBase.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace | AlternativeData | EntityObject | EntityList | Viewer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase Constructor

Iniitalizes a new instance of the EntityBase class.

public EntityBase();

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase Fields

The fields of the EntityBase class are listed below. For a complete list of EntityBase class members, see the EntityBase Members topic.

Protected Instance Fields

entityStatus The internal EntityStatus.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace | AlternativeData | EntityObject | EntityList | Viewer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.entityStatus Field

The internal EntityStatus.

protected EntityStatus entityStatus;

Remarks

This is the status that was set after the completion of an operation. This value is independent from the EntityStatusDriver.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase Properties

The properties of the EntityBase class are listed below. For a complete list of EntityBase class members, see the EntityBase Members topic.

Public Instance Properties

Parent | Gets/sets the EntityBase that is the parent of this entity. Default value = null.
Status | Returns a value that indicats the EntityStatus of the entity. Default value (after creation) = Unspecified.
StatusDriver | Gets the EntityStatusDriver. Default value = DataDriven

Protected Instance Properties

ConstraintAction | Gets/sets a value indicating the way constraints are handled. Default value = Keep.
DataAccessRefreshing | Gets/sets the way the DataAccess objects are refreshed. Default value = All
DataAccessSorting | Gets/sets a value indicating whether the DataAccess objects are sorted. Default value = true
DataSetType | Gets/sets the type of the cache dataset.
DsCache | Gets/sets the cache of the entity.
EnforceCacheConstraints | Gets or sets EnforceConstraints on DsCache. Default value = true.

Protected Internal Instance Properties

AccessObjects | Gets the collection of DataAccess objects of this object. Do not modify this collection use AddAccessObject and RemoveAccessObject instead.
AlternativeData | Gets the AlternativeData information of this EntityBase.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace | AlternativeData | EntityObject | EntityList | Viewer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.AccessObjects Property

Gets the collection of DataAccess objects of this object. Do not modify this collection use AddAccessObject and RemoveAccessObject instead.

protected internal Deag.Vdx.Server.DAL.DataAccessCollection AccessObjects {get;}

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.AlternativeData Property

Gets the AlternativeData information of this EntityBase.

protected internal AlternativeData AlternativeData {get;}

Remarks

To set the information about alternative data use SetAlternativeData.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.ConstraintAction Property

Gets/sets a value indicating the way constraints are handled. Default value = Keep.

protected EntityBase.ConstraintActionType ConstraintAction {get; set;}

Remarks

The constraint action defines how constraints of the cache data set are handled before and after an operation is executed.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace | EntityBase.ConstraintActionType

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.DataAccessRefreshing Property

Gets/sets the way the DataAccess objects are refreshed. Default value = All

protected EntityBase.DataAccessRefreshType DataAccessRefreshing {get; set;}

Remarks

If set to All then all data access objects are first refreshed and afterwards the current operation is executed one each. If set to Single then each data access object is refreshed and executed and afterwards it is the next data access object's turn.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace | RefreshDataAccessObject | RefreshDataAccessObjects

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.DataAccessSorting Property

Gets/sets a value indicating whether the DataAccess objects are sorted. Default value = true

protected EntityBase.DataAccessSortType DataAccessSorting {get; set;}

Remarks

If set to true then the collection of data access objects is sorted before an operation takes place. The data access objects are sorted according to the relations in the data set.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.DataSetType Property

Gets/sets the type of the cache dataset.

protected virtual System.Type DataSetType {get; set;}

Remarks

The DataSetType is used to instantiate the DsCache. It is automatically created when a type is set.

Exceptions

Exception Type | Condition
vdxEntityException | When getting the type and it is null or a null value is set.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.DsCache Property

Gets/sets the cache of the entity.

protected System.Data.DataSet DsCache {get; set;}

Remarks

The cache is the data storage that holds all data defining the entity. If the cache is not initialized and is requested then a vdxEntityException is thrown.

Exceptions

Exception Type | Condition
vdxEntityException | If the cache is not initialized.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.EnforceCacheConstraints Property

Gets or sets EnforceConstraints on DsCache. Default value = true.

protected bool EnforceCacheConstraints {get; set;}

Remarks

You can use this property to enable/disable the constraints on the cache. It is possible to set this value before the cache is instantiated (before setting DataSetType).

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.Parent Property

Gets/sets the EntityBase that is the parent of this entity. Default value = null.

public EntityBase Parent {get; set;}

Remarks

The Parent property can be used to build hierarchical structures of EntityBase objects.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.Status Property

Returns a value that indicats the EntityStatus of the entity. Default value (after creation) = Unspecified.

public virtual EntityStatus Status {get;}

Remarks

Depending on the StatusDriver either the GetDataDrivenStatus or GetRowStateDrivenStatus method is called to get the Status.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace | GetDataDrivenStatus | GetRowStateDrivenStatus

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.StatusDriver Property

Gets the EntityStatusDriver. Default value = DataDriven

public EntityStatusDriver StatusDriver {get;}

Remarks

The driver defines the way the Status is determined.

The driver is set to RowStateDriven automatically when a Deserialize method is called.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase Methods

The methods of the EntityBase class are listed below. For a complete list of EntityBase class members, see the EntityBase Members topic.

Public Instance Methods

ClearAlternativeTable | Deletes the information about alternative data --> no alternative data is read any more.
Deserialize | Overloaded. Fills the DsCache with the data in the passed DataRow. It is merged with Ignore.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Serialize | Returns a copy of the DsCache.
SerializeAlternativeData | Serializes the alternative data into a DataTable.
SetAlternativeData | Overloaded. Sets the information which alternative data should be read and by which operations.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Validates the Entity.

Protected Instance Methods

AddAccessObject | Adds a DataAccess object to the collection of data access objects.
AddAccessObjects | Adds the specified DataAccess objects to the collection of data access objects.
CheckCacheIntegrity | Checks the integrity of the DsCache.
ClearCache | Clears the DsCache.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAccessObject | Returns the DataAccess object with the specified key from the collection of data access objects.
GetCacheTable | Returns the DataTable from the DsCache.
GetDataDrivenStatus | Returns the currently set internal status. See SetEntityStatus.
GetParametersFromCache | Derived classes creates for each item in the Cache a Parameter.
GetRowStateDrivenStatus | Derived classes override this method to return the row state driven Status.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PerformOperation | Executes the specified Operation in the specified Transaction on the specified DataAccess.
PerformRead | Fills the DsCache by executing the Read operation on all reading enabled DataAccess objects. Not to be called directly. Use Read or Read.
PerformReadCount | Returns the maximal number of rows a DataAccess of this entity would return in a read operation. Not to be called directly. Use ReadCount.
ProcessReturnedParameters | Called after a read, insert, update or delete operation. Derived classes use this methode to access parameters that contain result values.
ReadAlternativeData | Overloaded. Reads the alternative data.
RecordException | Records an Exception onto a Transaction. If the specified transaction is null then the exception is thrown instead. If the exception was recorded then cancel will be set to true.
RefreshDataAccessObject | Refreshs a single DataAccess object.
RefreshDataAccessObjects | Refreshs all DataAccess objects. This method can be overriden if you want refresh all data access in one place.
RemoveAccessObject | Removes a DataAccess object form the collection of data access objects.
SetConstraintsAfterOperation | Re-enables the constraints of the specified dataset if the specified action demands it.
SetConstraintsBeforeOperation | Disables the constraints of the DsCache if the specified action demands it.
SetEntityStatus | Sets the Status to the specified 'status'.
SetEntityStatusDriver | Sets the EntityStatusDriver.
SortAccessObjects | Sorts the DataAccess objects by relations and constriants. Loop are not supported. This method is called internally when a read operation is executed.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace | AlternativeData | EntityObject | EntityList | Viewer

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.AddAccessObject Method

Adds a DataAccess object to the collection of data access objects.

protected void AddAccessObject(
DataAccess accessObject
);

Parameters

accessObject
The DataAccess object that is added.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.AddAccessObjects Method

Adds the specified DataAccess objects to the collection of data access objects.

protected void AddAccessObjects(
params DataAccess[] accessObjects
);

Parameters

accessObjects
DataAccess objects to be added.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.CheckCacheIntegrity Method

Checks the integrity of the DsCache.

protected virtual void CheckCacheIntegrity();

Remarks

Checks whether the DsCache fulfills all axioms.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.ClearAlternativeTable Method

Deletes the information about alternative data --> no alternative data is read any more.

public void ClearAlternativeTable();

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.ClearCache Method

Clears the DsCache.

protected void ClearCache();

Remarks

Afterwards the cache is empty or contains one empty row (depending on AutoAddRow). The Status is Unspecified. The StatusDriver is DataDriven.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deserialize Method

VDX Framework

EntityBase.Deserialize Method

Fills the DsCache with the data in the passed DataRow. It is merged with Ignore.

Overload List

Fills the DsCache with the data in the passed DataRow. It is merged with Ignore.

public virtual void Deserialize(DataRow);

Fills the DsCache with the data found in the specified DataSet. It is merged with Ignore.

public virtual void Deserialize(DataSet);

Fills the DsCache with the data in the specified DataTable. The cache must contain a table with the same table name as the passed table. The cache must be initialized (DataSetType set). It is merged with Ignore.

public virtual void Deserialize(DataTable);

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.Deserialize Method (DataRow)

Fills the DsCache with the data in the passed DataRow. It is merged with Ignore.

public virtual void Deserialize(
DataRow row
);

Parameters

row
The row containing the data.

Remarks

The StatusDriver is set to RowStateDriven.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace | EntityBase.Deserialize Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.Deserialize Method (DataSet)

Fills the DsCache with the data found in the specified DataSet. It is merged with Ignore.

public virtual void Deserialize(
DataSet ds
);

Parameters

ds
DataSet containing the data to fill the DsCache.

Remarks

The StatusDriver is set to RowStateDriven.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace | EntityBase.Deserialize Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.Deserialize Method (DataTable)

Fills the DsCache with the data in the specified DataTable. The cache must contain a table with the same table name as the passed table. The cache must be initialized (DataSetType set). It is merged with Ignore.

public virtual void Deserialize(
DataTable table
);

Parameters

table
The table containing the data.

Remarks

The StatusDriver is set to RowStateDriven.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace | EntityBase.Deserialize Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.GetAccessObject Method

Returns the DataAccess object with the specified key from the collection of data access objects.

protected DataAccess GetAccessObject(
string key
);

Parameters

key
Key of the DataAccess.

Return Value

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.GetCacheTable Method

Returns the DataTable from the DsCache.

protected DataTable GetCacheTable();

Return Value

Remarks

The Cache can contain only exactly one DataTable.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.GetDataDrivenStatus Method

Returns the currently set internal status. See SetEntityStatus.

protected virtual EntityStatus GetDataDrivenStatus();

Return Value

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.GetParametersFromCache Method

Derived classes creates for each item in the Cache a Parameter.

protected virtual ParameterCollection GetParametersFromCache();

Return Value

The collection of parameters created from the DsCache.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.GetRowStateDrivenStatus Method

Derived classes override this method to return the row state driven Status.

protected virtual EntityStatus GetRowStateDrivenStatus();

Return Value

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.PerformOperation Method

Executes the specified Operation in the specified Transaction on the specified DataAccess.

protected void PerformOperation(
DataAccess da,
Transaction transaction,
Operation op
);

Parameters

da
The DataAccess that performs the operation.
transaction
The Transaction in that the operation takes part.
op
The Operation to be performed.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.PerformRead Method

Fills the DsCache by executing the Read operation on all reading enabled DataAccess objects. Not to be called directly. Use Read or Read.

protected void PerformRead(
Transaction transaction
);

Parameters

transaction
The transaction of the current operation (null is allowed).

Remarks

Procedure: The constraints on the DsCache are disabled accordingly to ConstraintAction. The DataAccess objects are sorted accordingly to DataAccessSorting. The DataAccess objects are refreshed accordingly to DataAccessRefreshing. Read is executed on each data access. The constraints on the DsCache are re-enabled accordingly to ConstraintAction.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.PerformReadCount Method

Returns the maximal number of rows a DataAccess of this entity would return in a read operation. Not to be called directly. Use ReadCount.

protected int PerformReadCount(
Transaction transaction
);

Parameters

transaction
The transaction of the current operation (null is allowed).

Remarks

Procedure: The DataAccess objects are refreshed accordingly to DataAccessRefreshing. ReadCount is executed on each data access object. The maximal number of all results is computed and returned

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.ProcessReturnedParameters Method

Called after a read, insert, update or delete operation. Derived classes use this methode to access parameters that contain result values.

protected virtual void ProcessReturnedParameters(
Operation opType
);

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ReadAlternativeData Method

VDX Framework

EntityBase.ReadAlternativeData Method

Reads the alternative data if they are enabled for the specified operation.

Overload List

Reads the alternative data if they are enabled for the specified operation.

protected void ReadAlternativeData(Operation,Transaction);

Reads the alternative data.

protected virtual void ReadAlternativeData(Transaction);

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.ReadAlternativeData Method (Operation, Transaction)

Reads the alternative data if they are enabled for the specified operation.

protected void ReadAlternativeData(
Operation op,
Transaction trans
);

Parameters

op
The currently executed operation.
trans
The transaction in that the operation should take part.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace | EntityBase.ReadAlternativeData Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.ReadAlternativeData Method (Transaction)

Reads the alternative data.

protected virtual void ReadAlternativeData(
Transaction trans
);

Remarks

Because the alternative data is read into a clone of the table that is specified as the table to read the alternative data (SetAlternativeData) use SerializeAlternativeData.

There exist no refresh method for the DataAccess that reads the alternative data. Instead all parameters that werde passed to all "normal" data access objects are also passed to this data access object. In addition if you set UseParametersFromCache to true then for each value in the DsCache a parameter is created and passed to the data access object.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace | EntityBase.ReadAlternativeData Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.RecordException Method

Records an Exception onto a Transaction. If the specified transaction is null then the exception is thrown instead. If the exception was recorded then cancel will be set to true.

protected void RecordException(
Transaction transaction,
vdxException exception,
ref bool cancel
);

Parameters

transaction
The transaction the exception is recorded on.
exception
The exception to be recorded or thrown.
cancel
If the excpetion was recorded on the transaction, then cancel will be set to true.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.RefreshDataAccessObject Method

Refreshs a single DataAccess object.

protected virtual void RefreshDataAccessObject(
DataAccess accessObject,
Operation opType
);

Parameters

accessObject
The data access object to be refreshed.
opType
The operation that is currently performed.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace | RefreshDataAccessObjects

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.RefreshDataAccessObjects Method

Refreshs all DataAccess objects. This method can be overriden if you want refresh all data access in one place.

protected virtual void RefreshDataAccessObjects(
DataAccessCollection accessObjects,
Operation op
);

Parameters

accessObjects
Collection of all data access objects.
op
The operation that is currently performed.

Remarks

You can either override RefreshDataAccessObject or RefreshDataAccessObjects. The default implementation of RefreshDataAccessObjects is to call RefreshDataAccessObject for each DataAccess.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace | RefreshDataAccessObject

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.RemoveAccessObject Method

Removes a DataAccess object form the collection of data access objects.

protected void RemoveAccessObject(
DataAccess accessObject
);

Parameters

accessObject
The DataAccess to be removed.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.Serialize Method

Returns a copy of the DsCache.

public virtual DataSet Serialize();

Return Value

Copy of the DsCache.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.SerializeAlternativeData Method

Serializes the alternative data into a DataTable.

public virtual DataTable SerializeAlternativeData();

Return Value

Alternative Data

Remarks

Because the alternative data is read into a clone of the table that is specified in AlternativeData this is the only way to access the alternative data!

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SetAlternativeData Method

VDX Framework

EntityBase.SetAlternativeData Method

Sets the table in that the alternative data is read after a read, insert, update or delete operation that returns data.

Overload List

Sets the table in that the alternative data is read after a read, insert, update or delete operation that returns data.

public void SetAlternativeData(DataTable);

Sets the information which alternative data should be read and by which operations.

public void SetAlternativeData(DataTable,DataAccess,bool,bool,bool,bool,bool);

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.SetAlternativeData Method (DataTable)

Sets the table in that the alternative data is read after a read, insert, update or delete operation that returns data.

public void SetAlternativeData(
DataTable table
);

Parameters

table

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace | EntityBase.SetAlternativeData Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.SetAlternativeData Method (DataTable, DataAccess, Boolean, Boolean, Boolean, Boolean, Boolean)

Sets the information which alternative data should be read and by which operations.

public void SetAlternativeData(
DataTable table,
DataAccess da,
bool afterRead,
bool afterInsert,
bool afterUpdate,
bool afterDelete,
bool useParametersfromCache
);

Parameters

table
The table to read the data in.
da
DataAccess that reads the data.
afterRead
Read alternative data after a read operation.
afterInsert
Read alternative data after an insert operation.
afterUpdate
Read alternative data after an update operation.
afterDelete
Read alternative data after a dalete operation.
useParametersfromCache
Whether parameters should be created from the data in the DsCache and passed to the DataAccess for alternative data.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace | EntityBase.SetAlternativeData Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.SetConstraintsAfterOperation Method

Re-enables the constraints of the specified dataset if the specified action demands it.

protected void SetConstraintsAfterOperation();

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.SetConstraintsBeforeOperation Method

Disables the constraints of the DsCache if the specified action demands it.

protected void SetConstraintsBeforeOperation();

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.SetEntityStatus Method

Sets the Status to the specified 'status'.

protected void SetEntityStatus(
EntityStatus status
);

Parameters

status

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.SetEntityStatusDriver Method

Sets the EntityStatusDriver.

protected void SetEntityStatusDriver(
EntityStatusDriver driver
);

Parameters

driver
In which mode the Status will be computed.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.SortAccessObjects Method

Sorts the DataAccess objects by relations and constriants. Loop are not supported. This method is called internally when a read operation is executed.

protected virtual void SortAccessObjects();

Remarks

You can override this method to implement your own sorting algorithm.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.Validate Method

Validates the Entity.

public virtual void Validate(
Transaction transaction,
Operation op,
ref bool cancel
);

Parameters

transaction
op
The currently executed operation
cancel
If the validation method sets this value to true, the framework does not execute the following operation.

Remarks

You have to through vdxValidateExceptions to allow the framework to tell validation exceptions from programmatic exceptions.

See Also

EntityBase Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.ConstraintActionType Enumeration

Defines how the constraints on the DsCache are handled.

public enum EntityBase.ConstraintActionType

Members

Member Name | Description
Keep | Constraints are kept ==> exception if there are constraint violations.
Deactivate | Constraints are disabled before the read operation is performed. They keep deactivated.
Reactivate | Constraints are disabled before the read operation is performed. Afterwards they are re-enabled. ==> exception if there are constraint violations.
TryReactivate | Constraints are disabled before the read operation is performed. Afterwards they are re-enabled if possible, i.e if there are no constraint violations then the constraints are enabled otherwise not. ==> no exception.

Requirements

Namespace: Deag.Vdx.Server.Entity

Assembly: vdxServer (in vdxServer.dll)

See Also

Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.DataAccessRefreshType Enumeration

Defines how the collection of DataAccess object is refreshed.

public enum EntityBase.DataAccessRefreshType

Members

Member Name | Description
Single | Each DataAccess object is refrehed alone and afterwards the Read method of this DataAccess is called immediatelly.
All | All DataAccess and then the read operations are performed on each data access.

Requirements

Namespace: Deag.Vdx.Server.Entity

Assembly: vdxServer (in vdxServer.dll)

See Also

Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityBase.DataAccessSortType Enumeration

Defines the way the DataAccess objects are sorted.

public enum EntityBase.DataAccessSortType

Members

Member Name | Description
Keep | The order of registration is kept. The framework does not change it.
Auto | The framework tries to sort the DataAccess objects according to Das Framework sortiert die DataAccess Objekte wenn nötig.

Requirements

Namespace: Deag.Vdx.Server.Entity

Assembly: vdxServer (in vdxServer.dll)

See Also

Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList Class

Manages a collection of EntityObjects.

For a list of all members of this type, see EntityList Members.

System.Object
EntityBase
EntityList

public abstract class EntityList : EntityBase, ICollection, IEnumerable

Remarks

An EntityList can be used to read, insert, update, delete a whole collection of EntityObjects. If you want to work with EntityObjects then set ItemType to the type of your item and set UseCollection to true. Set UseCollection to false if your EntityList contains a huge amount of items. Then the framework will not generate the list of EntityObjects. Do not set the ItemType if you want to work only with the DsCache of the EntityList. If you use items then be sure that the entity objects can be created from the information hold in the cache of the entity list. Normally the types of the cache data sets of both the item and the list will be the same any way. The items are initialized by calling the Deserialize method with the corresponding row of the cache of the entity list.

EntityList implements ICollection, i.e. you can iterate over all items (only if ItemType and UseCollection are set).

Example

The following example shows an EntityList that uses items and a collection. The Filter Name is used to restrict to result set. In this case you can iterate over the collection and access the individual entity objects. When the list is written into the storage then the write is delegated to the single items.

            public class ELPerson : EntityList
            {
                public Filter Name = null;

                public ELPerson()
                {
                    UseCollection = true;
                    DataSetType   = typeof(DSPerson);
                    ItemType      = typeof(EOPerson);

                    // initialize the data access object for reading the list
                    DAPerson da   = new DAPerson();
                    da.Table      = ((DSPerson)DsCache).Person;
                    AddAccessObject(da);
                }

                protected override RefreshDataAccessObject(DataAccess da, Operation op)
                {
                    base.RefreshDataAccessObject(da, op);

                    da.AddParameter("Name", Name);
                }
            }
You can now iterate over the items:
            public void Iterate(ELPerson el)
            {
                foreach (EOPerson eo in el)
                {
                    System.Diagnostics.Trace.WriteLine(eo.Name);
                }
            }
In the following example neither items nor a collection is used:
            public class ELPerson : EntityList
            {
                [...]

                public ELPerson()
                {
                    UseCollection = false;
                    DataSetType   = typeof(DSPerson);

                    // initialize the data access object for reading the list
                    DAPerson da   = new DAPerson();
                    da.Table      = ((DSPerson)DsCache).Person;
                    AddAccessObject(da);
                }

                [...]
            }
In this case the entity list itself will update the data it is holding to the storage.

Requirements

Namespace: Deag.Vdx.Server.Entity

Assembly: vdxServer (in vdxServer.dll)

See Also

EntityList Members | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList Members

EntityList overview

Public Instance Constructors

EntityList Constructor Initializes a new instance of the EntityList class.

Public Instance Properties

Count | Gets the number of elements in the EntityList. Only valid if UseCollection is set to true.
IsSynchronized | Gets a value indicating whether access to the EntityList is synchronized.
Item | Returns the item at the specified index.
Parent (inherited from EntityBase) | Gets/sets the EntityBase that is the parent of this entity. Default value = null.
Status (inherited from EntityBase) | Returns a value that indicats the EntityStatus of the entity. Default value (after creation) = Unspecified.
StatusDriver (inherited from EntityBase) | Gets the EntityStatusDriver. Default value = DataDriven
SyncRoot | Gets an object to synchronize access to the EntityList.
UseCollection | Gets/sets a value that indicates whether to use the list of items. Default value = true;

Public Instance Methods

Add | Adds an EntityObject to the list.
Clear | Clears the DsCache and the List.
ClearAlternativeTable (inherited from EntityBase) | Deletes the information about alternative data --> no alternative data is read any more.
CopyTo | Not supported.
DataDrivenUpdate | Overloaded. Persists the data items in the collection into the storage.
Delete | Overloaded. Deletes all items from the DB.
Deserialize (inherited from EntityBase) | Overloaded. Fills the DsCache with the data in the passed DataRow. It is merged with Ignore.
Deserialize | Overloaded. Refreshes the List.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator for the EntityList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Read | Overloaded. Reads Data via a DataAccess's Read method, fills the DsCache and creates the List (only if UseCollection is set to true).
ReadCount | Overloaded. Returns the number of items a Read would return.
Serialize (inherited from EntityBase) | Returns a copy of the DsCache.
SerializeAlternativeData (inherited from EntityBase) | Serializes the alternative data into a DataTable.
SetAlternativeData (inherited from EntityBase) | Overloaded. Sets the information which alternative data should be read and by which operations.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Validates all items in the item collection.

Protected Instance Fields

entityStatus (inherited from EntityBase) The internal EntityStatus.

Protected Instance Properties

ConstraintAction (inherited from EntityBase) | Gets/sets a value indicating the way constraints are handled. Default value = Keep.
DataAccessRefreshing (inherited from EntityBase) | Gets/sets the way the DataAccess objects are refreshed. Default value = All
DataAccessSorting (inherited from EntityBase) | Gets/sets a value indicating whether the DataAccess objects are sorted. Default value = true
DataSetType | Gets/sets the type of the DsCache. Default value = null.
DsCache (inherited from EntityBase) | Gets/sets the cache of the entity.
EnforceCacheConstraints (inherited from EntityBase) | Gets or sets EnforceConstraints on DsCache. Default value = true.
ItemType | Gets/sets the type of the items. The type has to be a subtype of EntityObject. Default value = null.
List | Gets/sets the list of items. Only valid if UseCollection is equal to true.

Protected Instance Methods

AddAccessObject (inherited from EntityBase) | Adds a DataAccess object to the collection of data access objects.
AddAccessObjects (inherited from EntityBase) | Adds the specified DataAccess objects to the collection of data access objects.
CheckCacheIntegrity (inherited from EntityBase) | Checks the integrity of the DsCache.
ClearCache (inherited from EntityBase) | Clears the DsCache.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAccessObject (inherited from EntityBase) | Returns the DataAccess object with the specified key from the collection of data access objects.
GetCacheTable (inherited from EntityBase) | Returns the DataTable from the DsCache.
GetDataDrivenStatus (inherited from EntityBase) | Returns the currently set internal status. See SetEntityStatus.
GetParametersFromCache (inherited from EntityBase) | Derived classes creates for each item in the Cache a Parameter.
GetRowStateDrivenStatus (inherited from EntityBase) | Derived classes override this method to return the row state driven Status.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PerformOperation (inherited from EntityBase) | Executes the specified Operation in the specified Transaction on the specified DataAccess.
PerformRead (inherited from EntityBase) | Fills the DsCache by executing the Read operation on all reading enabled DataAccess objects. Not to be called directly. Use Read or Read.
PerformReadCount (inherited from EntityBase) | Returns the maximal number of rows a DataAccess of this entity would return in a read operation. Not to be called directly. Use ReadCount.
ProcessReturnedParameters (inherited from EntityBase) | Called after a read, insert, update or delete operation. Derived classes use this methode to access parameters that contain result values.
ReadAlternativeData (inherited from EntityBase) | Overloaded. Reads the alternative data.
RecordException (inherited from EntityBase) | Records an Exception onto a Transaction. If the specified transaction is null then the exception is thrown instead. If the exception was recorded then cancel will be set to true.
RefreshCollection | Creates the List from the data in the DsCache.
RefreshDataAccessObject (inherited from EntityBase) | Refreshs a single DataAccess object.
RefreshDataAccessObjects (inherited from EntityBase) | Refreshs all DataAccess objects. This method can be overriden if you want refresh all data access in one place.
RemoveAccessObject (inherited from EntityBase) | Removes a DataAccess object form the collection of data access objects.
SetConstraintsAfterOperation (inherited from EntityBase) | Re-enables the constraints of the specified dataset if the specified action demands it.
SetConstraintsBeforeOperation (inherited from EntityBase) | Disables the constraints of the DsCache if the specified action demands it.
SetEntityStatus (inherited from EntityBase) | Sets the Status to the specified 'status'.
SetEntityStatusDriver (inherited from EntityBase) | Sets the EntityStatusDriver.
SetValue | Sets the specified 'value' for the whole collection.
SortAccessObjects (inherited from EntityBase) | Sorts the DataAccess objects by relations and constriants. Loop are not supported. This method is called internally when a read operation is executed.

Protected Internal Instance Properties

AccessObjects (inherited from EntityBase) | Gets the collection of DataAccess objects of this object. Do not modify this collection use AddAccessObject and RemoveAccessObject instead.
AlternativeData (inherited from EntityBase) | Gets the AlternativeData information of this EntityBase.

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList Constructor

Initializes a new instance of the EntityList class.

public EntityList();

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList Properties

The properties of the EntityList class are listed below. For a complete list of EntityList class members, see the EntityList Members topic.

Public Instance Properties

Count | Gets the number of elements in the EntityList. Only valid if UseCollection is set to true.
IsSynchronized | Gets a value indicating whether access to the EntityList is synchronized.
Item | Returns the item at the specified index.
Parent (inherited from EntityBase) | Gets/sets the EntityBase that is the parent of this entity. Default value = null.
Status (inherited from EntityBase) | Returns a value that indicats the EntityStatus of the entity. Default value (after creation) = Unspecified.
StatusDriver (inherited from EntityBase) | Gets the EntityStatusDriver. Default value = DataDriven
SyncRoot | Gets an object to synchronize access to the EntityList.
UseCollection | Gets/sets a value that indicates whether to use the list of items. Default value = true;

Protected Instance Properties

ConstraintAction (inherited from EntityBase) | Gets/sets a value indicating the way constraints are handled. Default value = Keep.
DataAccessRefreshing (inherited from EntityBase) | Gets/sets the way the DataAccess objects are refreshed. Default value = All
DataAccessSorting (inherited from EntityBase) | Gets/sets a value indicating whether the DataAccess objects are sorted. Default value = true
DataSetType | Gets/sets the type of the DsCache. Default value = null.
DsCache (inherited from EntityBase) | Gets/sets the cache of the entity.
EnforceCacheConstraints (inherited from EntityBase) | Gets or sets EnforceConstraints on DsCache. Default value = true.
ItemType | Gets/sets the type of the items. The type has to be a subtype of EntityObject. Default value = null.
List | Gets/sets the list of items. Only valid if UseCollection is equal to true.

Protected Internal Instance Properties

AccessObjects (inherited from EntityBase) | Gets the collection of DataAccess objects of this object. Do not modify this collection use AddAccessObject and RemoveAccessObject instead.
AlternativeData (inherited from EntityBase) | Gets the AlternativeData information of this EntityBase.

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.Count Property

Gets the number of elements in the EntityList. Only valid if UseCollection is set to true.

public int Count {get;}

Implements

ICollection.Count

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.DataSetType Property

Gets/sets the type of the DsCache. Default value = null.

protected System.Type DataSetType {get; set;}

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.IsSynchronized Property

Gets a value indicating whether access to the EntityList is synchronized.

public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.Item Property

Returns the item at the specified index.

public EntityObject this[
int index
] {get;}

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.ItemType Property

Gets/sets the type of the items. The type has to be a subtype of EntityObject. Default value = null.

protected System.Type ItemType {get; set;}

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.List Property

Gets/sets the list of items. Only valid if UseCollection is equal to true.

protected System.Collections.ArrayList List {get; set;}

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.SyncRoot Property

Gets an object to synchronize access to the EntityList.

public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.UseCollection Property

Gets/sets a value that indicates whether to use the list of items. Default value = true;

public bool UseCollection {get; set;}

Remarks

If set to true you can iterate and access items over List. If set to false you can work with the cache. Attention: do not mix changes in the cache and in the items, because they are not synchronized for better performance.

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList Methods

The methods of the EntityList class are listed below. For a complete list of EntityList class members, see the EntityList Members topic.

Public Instance Methods

Add | Adds an EntityObject to the list.
Clear | Clears the DsCache and the List.
ClearAlternativeTable (inherited from EntityBase) | Deletes the information about alternative data --> no alternative data is read any more.
CopyTo | Not supported.
DataDrivenUpdate | Overloaded. Persists the data items in the collection into the storage.
Delete | Overloaded. Deletes all items from the DB.
Deserialize (inherited from EntityBase) | Overloaded. Fills the DsCache with the data in the passed DataRow. It is merged with Ignore.
Deserialize | Overloaded. Refreshes the List.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator for the EntityList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Read | Overloaded. Reads Data via a DataAccess's Read method, fills the DsCache and creates the List (only if UseCollection is set to true).
ReadCount | Overloaded. Returns the number of items a Read would return.
Serialize (inherited from EntityBase) | Returns a copy of the DsCache.
SerializeAlternativeData (inherited from EntityBase) | Serializes the alternative data into a DataTable.
SetAlternativeData (inherited from EntityBase) | Overloaded. Sets the information which alternative data should be read and by which operations.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Validates all items in the item collection.

Protected Instance Methods

AddAccessObject (inherited from EntityBase) | Adds a DataAccess object to the collection of data access objects.
AddAccessObjects (inherited from EntityBase) | Adds the specified DataAccess objects to the collection of data access objects.
CheckCacheIntegrity (inherited from EntityBase) | Checks the integrity of the DsCache.
ClearCache (inherited from EntityBase) | Clears the DsCache.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAccessObject (inherited from EntityBase) | Returns the DataAccess object with the specified key from the collection of data access objects.
GetCacheTable (inherited from EntityBase) | Returns the DataTable from the DsCache.
GetDataDrivenStatus (inherited from EntityBase) | Returns the currently set internal status. See SetEntityStatus.
GetParametersFromCache (inherited from EntityBase) | Derived classes creates for each item in the Cache a Parameter.
GetRowStateDrivenStatus (inherited from EntityBase) | Derived classes override this method to return the row state driven Status.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PerformOperation (inherited from EntityBase) | Executes the specified Operation in the specified Transaction on the specified DataAccess.
PerformRead (inherited from EntityBase) | Fills the DsCache by executing the Read operation on all reading enabled DataAccess objects. Not to be called directly. Use Read or Read.
PerformReadCount (inherited from EntityBase) | Returns the maximal number of rows a DataAccess of this entity would return in a read operation. Not to be called directly. Use ReadCount.
ProcessReturnedParameters (inherited from EntityBase) | Called after a read, insert, update or delete operation. Derived classes use this methode to access parameters that contain result values.
ReadAlternativeData (inherited from EntityBase) | Overloaded. Reads the alternative data.
RecordException (inherited from EntityBase) | Records an Exception onto a Transaction. If the specified transaction is null then the exception is thrown instead. If the exception was recorded then cancel will be set to true.
RefreshCollection | Creates the List from the data in the DsCache.
RefreshDataAccessObject (inherited from EntityBase) | Refreshs a single DataAccess object.
RefreshDataAccessObjects (inherited from EntityBase) | Refreshs all DataAccess objects. This method can be overriden if you want refresh all data access in one place.
RemoveAccessObject (inherited from EntityBase) | Removes a DataAccess object form the collection of data access objects.
SetConstraintsAfterOperation (inherited from EntityBase) | Re-enables the constraints of the specified dataset if the specified action demands it.
SetConstraintsBeforeOperation (inherited from EntityBase) | Disables the constraints of the DsCache if the specified action demands it.
SetEntityStatus (inherited from EntityBase) | Sets the Status to the specified 'status'.
SetEntityStatusDriver (inherited from EntityBase) | Sets the EntityStatusDriver.
SetValue | Sets the specified 'value' for the whole collection.
SortAccessObjects (inherited from EntityBase) | Sorts the DataAccess objects by relations and constriants. Loop are not supported. This method is called internally when a read operation is executed.

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.Add Method

Adds an EntityObject to the list.

public virtual void Add(
EntityObject eo
);

Parameters

eo
The EntityObject to be added.

Remarks

The EntityObject is added both to the list and the DsCache.

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.Clear Method

Clears the DsCache and the List.

public void Clear();

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.CopyTo Method

Not supported.

public void CopyTo(
Array array,
int index
);

Parameters

array
index

Implements

ICollection.CopyTo

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataDrivenUpdate Method

VDX Framework

EntityList.DataDrivenUpdate Method

Persists the data items in the collection into the storage.

Overload List

Persists the data items in the collection into the storage.

public void DataDrivenUpdate();

Persists the data items in the collection into the storage.

public virtual void DataDrivenUpdate(Transaction);

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.DataDrivenUpdate Method ()

Persists the data items in the collection into the storage.

public void DataDrivenUpdate();

Remarks

Depending of the Status of the items an insert, update or delete operation is performed on that item.

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace | EntityList.DataDrivenUpdate Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.DataDrivenUpdate Method (Transaction)

Persists the data items in the collection into the storage.

public virtual void DataDrivenUpdate(
Transaction transaction
);

Parameters

transaction
The trasaction the operation takes part of.

Remarks

Depending of the Status of the items an insert, update or delete operation is performed on that item.

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace | EntityList.DataDrivenUpdate Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Delete Method

VDX Framework

EntityList.Delete Method

Deletes all items from the DB.

Overload List

Deletes all items from the DB.

public virtual void Delete();

Deletes all items from the DB.

public virtual void Delete(Transaction);

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.Delete Method ()

Deletes all items from the DB.

public virtual void Delete();

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace | EntityList.Delete Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.Delete Method (Transaction)

Deletes all items from the DB.

public virtual void Delete(
Transaction transaction
);

Parameters

transaction
The trasaction the operation takes part of.

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace | EntityList.Delete Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deserialize Method

VDX Framework

EntityList.Deserialize Method

Refreshes the List.

Overload List

Inherited from EntityBase.

public virtual void Deserialize(DataRow);

Refreshes the List.

public override void Deserialize(DataSet);

Refreshes the List.

public override void Deserialize(DataTable);

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.Deserialize Method (DataSet)

Refreshes the List.

public override void Deserialize(
DataSet ds
);

Parameters

ds

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace | EntityList.Deserialize Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.Deserialize Method (DataTable)

Refreshes the List.

public override void Deserialize(
DataTable table
);

Parameters

table

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace | EntityList.Deserialize Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.GetEnumerator Method

Returns an enumerator for the EntityList.

public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Read Method

VDX Framework

EntityList.Read Method

Reads Data via a DataAccess's Read method, fills the DsCache and creates the List (only if UseCollection is set to true).

Overload List

Reads Data via a DataAccess's Read method, fills the DsCache and creates the List (only if UseCollection is set to true).

public virtual void Read();

Reads Data via a DataAccess's Read method, fills the DsCache and creates the List (only if UseCollection is set to true).

public virtual void Read(Transaction);

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.Read Method ()

Reads Data via a DataAccess's Read method, fills the DsCache and creates the List (only if UseCollection is set to true).

public virtual void Read();

Remarks

Additionally, the alternatîve data is read.

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace | EntityList.Read Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.Read Method (Transaction)

Reads Data via a DataAccess's Read method, fills the DsCache and creates the List (only if UseCollection is set to true).

public virtual void Read(
Transaction transaction
);

Parameters

transaction
The trasaction the operation takes part of.

Remarks

Additionally, the alternatîve data is read.

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace | EntityList.Read Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ReadCount Method

VDX Framework

EntityList.ReadCount Method

Returns the number of items a Read would return.

Overload List

Returns the number of items a Read would return.

public virtual int ReadCount();

Returns the number of items a Read would return.

new public virtual int ReadCount(Transaction);

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.ReadCount Method ()

Returns the number of items a Read would return.

public virtual int ReadCount();

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace | EntityList.ReadCount Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.ReadCount Method (Transaction)

Returns the number of items a Read would return.

new public virtual int ReadCount(
Transaction transaction
);

Parameters

transaction
The trasaction the operation takes part of.

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace | EntityList.ReadCount Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.RefreshCollection Method

Creates the List from the data in the DsCache.

protected virtual void RefreshCollection();

Remarks

The list is only created if UseCollection is equal to true (default).

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.SetValue Method

Sets the specified 'value' for the whole collection.

protected void SetValue(
string cacheColumn,
string itemProperty,
object value
);

Parameters

cacheColumn
itemProperty
value

Remarks

The 'value' is set to each row of the table in the DsCache. If there is a ItemType defined and UseCollection is set to true then the 'value' is set to the property 'itemProperty' of each item. The 'value' is not set for deleted rows.

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityList.Validate Method

Validates all items in the item collection.

public override void Validate(
Transaction transaction,
Operation op,
ref bool cancel
);

Parameters

transaction
The transaction this operation takes part of.
op
The currently performed operation.
cancel
Whether the current operation should be cancelled.

See Also

EntityList Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject Class

An EntityObject represents one single logical entity.

For a list of all members of this type, see EntityObject Members.

System.Object
EntityBase
EntityObject

public abstract class EntityObject : EntityBase

Remarks

The EntityObject provides functionallity for reading, inserting, updating and deleting data in the persistent storage.

Axiom: the DsCache of the EntityObject contains always exactly one DataTable and zero or one DataRow. Zero rows if it is not already initialized.

Example

The following example shows an EntityObject that represents a person.

            public class EOPerson : EntityObject
            {
                // creates a new instance representing a person.
                public EOPerson()
                {
                    // add the DataAccess that will read, write and delete
                    // a person from/to the storage.
                    AddAccessObject(new DAPerson());

                    // define the type of the data set used for the DsCache.
                    DataSetType = typeof(DSPerson);
                }

                // Gets/sets the name of this person
                public string Name
                {
                    get { return (string)GetFromCacheDefault(dsPerson.Person.NameColumn, null); }
                    set { SetToCache(dsPerson.Person.NameColumn, value); }
                }

                // Gets/sets the prename of this person
                public string Prename
                {
                    get { return (string)GetFromCacheDefault(dsPerson.Person.PrenameColumn, null); }
                    set { SetToCache(dsPerson.Person.PrenameColumn, value); }
                }

                // Refresh the DataAccess by passing the needed
                Parameters to it.
                protected override void RefreshDataAccessObject(Deag.Vdx.Server.DAL.DataAccess accessObject, Operation op)
                {
                    base.RefreshDataAccessObject(accessObject, op);
                    accessObject.AddParameters(GetParametersFromCache());
                }

                // Validate the entity object
                protected override Validate(Transaction transaction, Operation op, ref bool cancel)
                {
                    base.Validate(transaction, op, cancel);

                    // if no name is given then the validation fails
                    if (Name == null)
                    {
                        // record the exception on the transaction if one is present otherwise the exception will be thrown.
                        RecordException(transaction, new Deag.Vdx.Common.Exception.vdxException("Name missing"), ref cancel);
                    }
                }
            }

Requirements

Namespace: Deag.Vdx.Server.Entity

Assembly: vdxServer (in vdxServer.dll)

See Also

EntityObject Members | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject Members

EntityObject overview

Public Instance Constructors

EntityObject Constructor Initializes a new instance of the EntityObject class.

Public Instance Properties

Parent (inherited from EntityBase) | Gets/sets the EntityBase that is the parent of this entity. Default value = null.
ReadStatus | Returns a value indicating the ReadStatus.
Status (inherited from EntityBase) | Returns a value that indicats the EntityStatus of the entity. Default value (after creation) = Unspecified.
StatusDriver (inherited from EntityBase) | Gets the EntityStatusDriver. Default value = DataDriven

Public Instance Methods

ClearAlternativeTable (inherited from EntityBase) | Deletes the information about alternative data --> no alternative data is read any more.
DataDrivenUpdate | Overloaded. Depending on the Status of the entity object an Insert, Update or Delete operation is executed.
Delete | Overloaded. Deletes the entity from the DB by calling the delete operation of the DataAccess object(s).
Deserialize (inherited from EntityBase) | Overloaded. Fills the DsCache with the data in the passed DataRow. It is merged with Ignore.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Overloaded. Inserts the entity into the DB by calling the insert operation of the DataAccess object(s).
Read | Overloaded. Reads data from the DB and fills the DsCache.
Serialize (inherited from EntityBase) | Returns a copy of the DsCache.
SerializeAlternativeData (inherited from EntityBase) | Serializes the alternative data into a DataTable.
SetAlternativeData (inherited from EntityBase) | Overloaded. Sets the information which alternative data should be read and by which operations.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update | Overloaded. Updates and historicises the entity in the DB by calling the update operation of the DataAccess object(s) and the insert operation of the HistoryAccessObject.
Validate | Validates the EntityObject.

Protected Instance Fields

entityStatus (inherited from EntityBase) The internal EntityStatus.

Protected Instance Properties

AutoAddRow | Gets/sets a value indicating whether an empty DataRow is added to the DsCache when the DataSetType is set. Default value = true.
ConstraintAction (inherited from EntityBase) | Gets/sets a value indicating the way constraints are handled. Default value = Keep.
DataAccessRefreshing (inherited from EntityBase) | Gets/sets the way the DataAccess objects are refreshed. Default value = All
DataAccessSorting (inherited from EntityBase) | Gets/sets a value indicating whether the DataAccess objects are sorted. Default value = true
DataSetType | Gets/sets the Type of the DsCache. Default value = null.
DsCache (inherited from EntityBase) | Gets/sets the cache of the entity.
EnforceCacheConstraints (inherited from EntityBase) | Gets or sets EnforceConstraints on DsCache. Default value = true.
HistoryAccessObject | Gets/sets the DataAccess object that is used to create the history records. If this property is 'null' (default) then no history is created.
ValidateAfterRead | Gets/sets a value indicating whether after the EntityObject was read it should be validated. Default value = false;

Protected Instance Methods

AddAccessObject (inherited from EntityBase) | Adds a DataAccess object to the collection of data access objects.
AddAccessObjects (inherited from EntityBase) | Adds the specified DataAccess objects to the collection of data access objects.
CheckCacheIntegrity | Checks whether the DsCache is okay.
ClearCache (inherited from EntityBase) | Clears the DsCache.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAccessObject (inherited from EntityBase) | Returns the DataAccess object with the specified key from the collection of data access objects.
GetCacheTable (inherited from EntityBase) | Returns the DataTable from the DsCache.
GetDataDrivenStatus (inherited from EntityBase) | Returns the currently set internal status. See SetEntityStatus.
GetFilterEQUALFromCache | Overloaded. Returns an equal filter containing the value contained in the specified column in the DsCache.
GetFilterFromCache | Overloaded. Returnes a Filter of type 'filter' with the value from the specified column from the DsCache.
GetFromCache | Overloaded. Returns the value from the specified column. If there is no row in the cache then null is returned.
GetFromCacheDefault | Overloaded. Returns a value from the DsCache. If there is no value the specified default value is returned.
GetParametersFromCache | Creates for each item in the Cache a Parameter.
GetRowFromCache | Overloaded. Returns the row from the DsCache. Null if there is none.
GetRowStateDrivenStatus | Returns the EntityStatus depending of the DataRowState of the DataRow in the DsCache.
HasCacheChanged | Overloaded. Returns a value indicating whether the DsCache has changed. The cache has changed if the row in the cache has a Original version.
IsEntityStatusNew | Checks whether the data in the DsCache represent New data.
IsInCache | Overloaded. Returns true whether there is a value different from Value at the specifeid column in the DsCache.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PerformOperation (inherited from EntityBase) | Executes the specified Operation in the specified Transaction on the specified DataAccess.
PerformRead (inherited from EntityBase) | Fills the DsCache by executing the Read operation on all reading enabled DataAccess objects. Not to be called directly. Use Read or Read.
PerformReadCount (inherited from EntityBase) | Returns the maximal number of rows a DataAccess of this entity would return in a read operation. Not to be called directly. Use ReadCount.
ProcessReturnedParameters (inherited from EntityBase) | Called after a read, insert, update or delete operation. Derived classes use this methode to access parameters that contain result values.
ReadAlternativeData (inherited from EntityBase) | Overloaded. Reads the alternative data.
RecordException (inherited from EntityBase) | Records an Exception onto a Transaction. If the specified transaction is null then the exception is thrown instead. If the exception was recorded then cancel will be set to true.
RefreshDataAccessObject (inherited from EntityBase) | Refreshs a single DataAccess object.
RefreshDataAccessObjects (inherited from EntityBase) | Refreshs all DataAccess objects. This method can be overriden if you want refresh all data access in one place.
RefreshHistoryDataAccessObject | Refreshes the DataAccess used for the history.
RemoveAccessObject (inherited from EntityBase) | Removes a DataAccess object form the collection of data access objects.
SetConstraintsAfterOperation (inherited from EntityBase) | Re-enables the constraints of the specified dataset if the specified action demands it.
SetConstraintsBeforeOperation (inherited from EntityBase) | Disables the constraints of the DsCache if the specified action demands it.
SetEntityStatus (inherited from EntityBase) | Sets the Status to the specified 'status'.
SetEntityStatusDriver (inherited from EntityBase) | Sets the EntityStatusDriver.
SetToCache | Overloaded. Writes a value into the DsCache and updates the Status.
SortAccessObjects (inherited from EntityBase) | Sorts the DataAccess objects by relations and constriants. Loop are not supported. This method is called internally when a read operation is executed.

Protected Internal Instance Properties

AccessObjects (inherited from EntityBase) | Gets the collection of DataAccess objects of this object. Do not modify this collection use AddAccessObject and RemoveAccessObject instead.
AlternativeData (inherited from EntityBase) | Gets the AlternativeData information of this EntityBase.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject Constructor

Initializes a new instance of the EntityObject class.

public EntityObject();

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject Properties

The properties of the EntityObject class are listed below. For a complete list of EntityObject class members, see the EntityObject Members topic.

Public Instance Properties

Parent (inherited from EntityBase) | Gets/sets the EntityBase that is the parent of this entity. Default value = null.
ReadStatus | Returns a value indicating the ReadStatus.
Status (inherited from EntityBase) | Returns a value that indicats the EntityStatus of the entity. Default value (after creation) = Unspecified.
StatusDriver (inherited from EntityBase) | Gets the EntityStatusDriver. Default value = DataDriven

Protected Instance Properties

AutoAddRow | Gets/sets a value indicating whether an empty DataRow is added to the DsCache when the DataSetType is set. Default value = true.
ConstraintAction (inherited from EntityBase) | Gets/sets a value indicating the way constraints are handled. Default value = Keep.
DataAccessRefreshing (inherited from EntityBase) | Gets/sets the way the DataAccess objects are refreshed. Default value = All
DataAccessSorting (inherited from EntityBase) | Gets/sets a value indicating whether the DataAccess objects are sorted. Default value = true
DataSetType | Gets/sets the Type of the DsCache. Default value = null.
DsCache (inherited from EntityBase) | Gets/sets the cache of the entity.
EnforceCacheConstraints (inherited from EntityBase) | Gets or sets EnforceConstraints on DsCache. Default value = true.
HistoryAccessObject | Gets/sets the DataAccess object that is used to create the history records. If this property is 'null' (default) then no history is created.
ValidateAfterRead | Gets/sets a value indicating whether after the EntityObject was read it should be validated. Default value = false;

Protected Internal Instance Properties

AccessObjects (inherited from EntityBase) | Gets the collection of DataAccess objects of this object. Do not modify this collection use AddAccessObject and RemoveAccessObject instead.
AlternativeData (inherited from EntityBase) | Gets the AlternativeData information of this EntityBase.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.AutoAddRow Property

Gets/sets a value indicating whether an empty DataRow is added to the DsCache when the DataSetType is set. Default value = true.

protected bool AutoAddRow {get; set;}

Remarks

If you have a data set that contains constraint the prevents the addition of an empty row then you have two options that can help:

  1. Set AutoAddRow to false. Note that in this case you have to assure that you do not access the DsCache if there is no row present.
  2. Define default values for fields that are not allowed to be null.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | DataSetType

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.DataSetType Property

Gets/sets the Type of the DsCache. Default value = null.

protected System.Type DataSetType {get; set;}

Remarks

The Type of the DsCache has to be set in order to allow the framework to handle the cache.

If AutoAddRow is set to true (default) then an empty DataRow is added to the DsCache. This simplifies accesses to the cache because it is guaranteed that there exists always one row.

Exceptions

Exception Type | Condition
Exception | No DataRow could be added to the DsCache.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | AutoAddRow

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.HistoryAccessObject Property

Gets/sets the DataAccess object that is used to create the history records. If this property is 'null' (default) then no history is created.

protected Deag.Vdx.Server.DAL.DataAccess HistoryAccessObject {get; set;}

Remarks

The history data access should be atleast able to insert data (CanInsert and InsertingEnabled). If it can also read data (CanRead and ReadingEnabled) then first the read operation is called and afterwards the insert operation (see Update for more information).

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | Update

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.ReadStatus Property

Returns a value indicating the ReadStatus.

public ReadStatus ReadStatus {get;}

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.ValidateAfterRead Property

Gets/sets a value indicating whether after the EntityObject was read it should be validated. Default value = false;

protected bool ValidateAfterRead {get; set;}

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | Validate

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject Methods

The methods of the EntityObject class are listed below. For a complete list of EntityObject class members, see the EntityObject Members topic.

Public Instance Methods

ClearAlternativeTable (inherited from EntityBase) | Deletes the information about alternative data --> no alternative data is read any more.
DataDrivenUpdate | Overloaded. Depending on the Status of the entity object an Insert, Update or Delete operation is executed.
Delete | Overloaded. Deletes the entity from the DB by calling the delete operation of the DataAccess object(s).
Deserialize (inherited from EntityBase) | Overloaded. Fills the DsCache with the data in the passed DataRow. It is merged with Ignore.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Overloaded. Inserts the entity into the DB by calling the insert operation of the DataAccess object(s).
Read | Overloaded. Reads data from the DB and fills the DsCache.
Serialize (inherited from EntityBase) | Returns a copy of the DsCache.
SerializeAlternativeData (inherited from EntityBase) | Serializes the alternative data into a DataTable.
SetAlternativeData (inherited from EntityBase) | Overloaded. Sets the information which alternative data should be read and by which operations.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update | Overloaded. Updates and historicises the entity in the DB by calling the update operation of the DataAccess object(s) and the insert operation of the HistoryAccessObject.
Validate | Validates the EntityObject.

Protected Instance Methods

AddAccessObject (inherited from EntityBase) | Adds a DataAccess object to the collection of data access objects.
AddAccessObjects (inherited from EntityBase) | Adds the specified DataAccess objects to the collection of data access objects.
CheckCacheIntegrity | Checks whether the DsCache is okay.
ClearCache (inherited from EntityBase) | Clears the DsCache.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAccessObject (inherited from EntityBase) | Returns the DataAccess object with the specified key from the collection of data access objects.
GetCacheTable (inherited from EntityBase) | Returns the DataTable from the DsCache.
GetDataDrivenStatus (inherited from EntityBase) | Returns the currently set internal status. See SetEntityStatus.
GetFilterEQUALFromCache | Overloaded. Returns an equal filter containing the value contained in the specified column in the DsCache.
GetFilterFromCache | Overloaded. Returnes a Filter of type 'filter' with the value from the specified column from the DsCache.
GetFromCache | Overloaded. Returns the value from the specified column. If there is no row in the cache then null is returned.
GetFromCacheDefault | Overloaded. Returns a value from the DsCache. If there is no value the specified default value is returned.
GetParametersFromCache | Creates for each item in the Cache a Parameter.
GetRowFromCache | Overloaded. Returns the row from the DsCache. Null if there is none.
GetRowStateDrivenStatus | Returns the EntityStatus depending of the DataRowState of the DataRow in the DsCache.
HasCacheChanged | Overloaded. Returns a value indicating whether the DsCache has changed. The cache has changed if the row in the cache has a Original version.
IsEntityStatusNew | Checks whether the data in the DsCache represent New data.
IsInCache | Overloaded. Returns true whether there is a value different from Value at the specifeid column in the DsCache.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PerformOperation (inherited from EntityBase) | Executes the specified Operation in the specified Transaction on the specified DataAccess.
PerformRead (inherited from EntityBase) | Fills the DsCache by executing the Read operation on all reading enabled DataAccess objects. Not to be called directly. Use Read or Read.
PerformReadCount (inherited from EntityBase) | Returns the maximal number of rows a DataAccess of this entity would return in a read operation. Not to be called directly. Use ReadCount.
ProcessReturnedParameters (inherited from EntityBase) | Called after a read, insert, update or delete operation. Derived classes use this methode to access parameters that contain result values.
ReadAlternativeData (inherited from EntityBase) | Overloaded. Reads the alternative data.
RecordException (inherited from EntityBase) | Records an Exception onto a Transaction. If the specified transaction is null then the exception is thrown instead. If the exception was recorded then cancel will be set to true.
RefreshDataAccessObject (inherited from EntityBase) | Refreshs a single DataAccess object.
RefreshDataAccessObjects (inherited from EntityBase) | Refreshs all DataAccess objects. This method can be overriden if you want refresh all data access in one place.
RefreshHistoryDataAccessObject | Refreshes the DataAccess used for the history.
RemoveAccessObject (inherited from EntityBase) | Removes a DataAccess object form the collection of data access objects.
SetConstraintsAfterOperation (inherited from EntityBase) | Re-enables the constraints of the specified dataset if the specified action demands it.
SetConstraintsBeforeOperation (inherited from EntityBase) | Disables the constraints of the DsCache if the specified action demands it.
SetEntityStatus (inherited from EntityBase) | Sets the Status to the specified 'status'.
SetEntityStatusDriver (inherited from EntityBase) | Sets the EntityStatusDriver.
SetToCache | Overloaded. Writes a value into the DsCache and updates the Status.
SortAccessObjects (inherited from EntityBase) | Sorts the DataAccess objects by relations and constriants. Loop are not supported. This method is called internally when a read operation is executed.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.CheckCacheIntegrity Method

Checks whether the DsCache is okay.

protected override void CheckCacheIntegrity();

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


DataDrivenUpdate Method

VDX Framework

EntityObject.DataDrivenUpdate Method

Depending on the Status of the entity object an Insert, Update or Delete operation is executed.

Overload List

Depending on the Status of the entity object an Insert, Update or Delete operation is executed.

public void DataDrivenUpdate();

Depending on the Status of the entity object an Insert, Update or Delete operation is executed.

public virtual void DataDrivenUpdate(Transaction);

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | Status | StatusDriver

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.DataDrivenUpdate Method ()

Depending on the Status of the entity object an Insert, Update or Delete operation is executed.

public void DataDrivenUpdate();

Remarks

If the Status is New then the Insert method is called. If the Status is Modified then the Update method is called. If the Status is Deleted or ToBeDeleted then the Delete method is called.

If the Status is Unspecified or Unchanged then nothing happens. This is important if you build entire object models and you have to update a child of this entity object. That means you have not only to override the Read, Insert, Update and Delete methods, but also the DataDrivenUpdate method for this case!

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.DataDrivenUpdate Overload List | Status | StatusDriver

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.DataDrivenUpdate Method (Transaction)

Depending on the Status of the entity object an Insert, Update or Delete operation is executed.

public virtual void DataDrivenUpdate(
Transaction transaction
);

Parameters

transaction
The operation takes part in this transaction.

Remarks

If the Status is New then the Insert method is called. If the Status is Modified then the Update method is called. If the Status is Deleted or ToBeDeleted then the Delete method is called.

If the Status is Unspecified or Unchanged then nothing happens. This is important if you build entire object models and you have to update a child of this entity object. That means you have not only to override the Read, Insert, Update and Delete methods, but also the DataDrivenUpdate method for this case!

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.DataDrivenUpdate Overload List | Status | StatusDriver

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Delete Method

VDX Framework

EntityObject.Delete Method

Deletes the entity from the DB by calling the delete operation of the DataAccess object(s).

Overload List

Deletes the entity from the DB by calling the delete operation of the DataAccess object(s).

public void Delete();

Deletes the entity from the DB by calling the delete operation of the DataAccess object(s).

public virtual void Delete(Transaction);

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.Delete Method ()

Deletes the entity from the DB by calling the delete operation of the DataAccess object(s).

public void Delete();

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.Delete Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.Delete Method (Transaction)

Deletes the entity from the DB by calling the delete operation of the DataAccess object(s).

public virtual void Delete(
Transaction transaction
);

Parameters

transaction
The transaction this operation takes part of.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.Delete Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


GetFilterEQUALFromCache Method

VDX Framework

EntityObject.GetFilterEQUALFromCache Method

Returns an equal filter containing the value contained in the specified column in the DsCache.

Overload List

Returns an equal filter containing the value contained in the specified column in the DsCache.

protected Filter GetFilterEQUALFromCache(DataColumn);

Returns an equal filter containing the value contained in the specified column in the DsCache.

protected Filter GetFilterEQUALFromCache(string);

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFilterEQUALFromCache Method (DataColumn)

Returns an equal filter containing the value contained in the specified column in the DsCache.

protected Filter GetFilterEQUALFromCache(
DataColumn column
);

Parameters

column
the column holding the value.

Return Value

An equal filter.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFilterEQUALFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFilterEQUALFromCache Method (String)

Returns an equal filter containing the value contained in the specified column in the DsCache.

protected Filter GetFilterEQUALFromCache(
string column
);

Parameters

column
name of the column holding the value.

Return Value

An equal filter.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFilterEQUALFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


GetFilterFromCache Method

VDX Framework

EntityObject.GetFilterFromCache Method

Returnes a Filter of type 'filter' with the value from the specified column from the DsCache.

Overload List

Returnes a Filter of type 'filter' with the value from the specified column from the DsCache.

protected Filter GetFilterFromCache(Type,DataColumn);

Returnes a Filter of type 'filter' with the value from the specified column from the DsCache.

protected Filter GetFilterFromCache(Type,DataColumn,bool);

Returnes a Filter of type 'filter' with the value from the specified column from the DsCache.

protected Filter GetFilterFromCache(Type,DataColumn,DataRowVersion);

Returnes a Filter of type 'filter' with the value from the specified column from the DsCache.

protected Filter GetFilterFromCache(Type,DataColumn,DataRowVersion,bool);

Returnes a Filter of type 'filter' with the value from the specified column from the DsCache.

protected Filter GetFilterFromCache(Type,string);

Returnes a Filter of type 'filter' with the value from the specified column from the DsCache.

protected Filter GetFilterFromCache(Type,string,bool);

Returnes a Filter of type 'filter' with the value from the specified column from the DsCache.

protected Filter GetFilterFromCache(Type,string,DataRowVersion);

Returnes a Filter of type 'filter' with the value from the specified column from the DsCache.

protected Filter GetFilterFromCache(Type,string,DataRowVersion,bool);

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFilterFromCache Method (Type, DataColumn)

Returnes a Filter of type 'filter' with the value from the specified column from the DsCache.

protected Filter GetFilterFromCache(
Type filter,
DataColumn column
);

Parameters

filter
The type of the returned filter.
column
Column the value is taken from.

Return Value

A typed filter.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFilterFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFilterFromCache Method (Type, DataColumn, Boolean)

Returnes a Filter of type 'filter' with the value from the specified column from the DsCache.

protected Filter GetFilterFromCache(
Type filter,
DataColumn column,
bool throwOnError
);

Parameters

filter
The type of the returned filter.
column
Column the value is taken from.
throwOnError
Whether an exception should be thrown if the value cannot be read.

Return Value

A typed filter.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFilterFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFilterFromCache Method (Type, DataColumn, DataRowVersion)

Returnes a Filter of type 'filter' with the value from the specified column from the DsCache.

protected Filter GetFilterFromCache(
Type filter,
DataColumn column,
DataRowVersion version
);

Parameters

filter
The type of the returned filter.
column
Column the value is taken from.
version
The version of the row that will be read.

Return Value

A typed filter.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFilterFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFilterFromCache Method (Type, DataColumn, DataRowVersion, Boolean)

Returnes a Filter of type 'filter' with the value from the specified column from the DsCache.

protected Filter GetFilterFromCache(
Type filter,
DataColumn column,
DataRowVersion version,
bool throwOnError
);

Parameters

filter
The type of the returned filter.
column
Column the value is taken from.
version
The version of the row that will be read.
throwOnError
Whether an exception should be thrown if the value cannot be read.

Return Value

A typed filter.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFilterFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFilterFromCache Method (Type, String)

Returnes a Filter of type 'filter' with the value from the specified column from the DsCache.

protected Filter GetFilterFromCache(
Type filter,
string column
);

Parameters

filter
The type of the returned filter.
column
Name of the column the value is taken from.

Return Value

A typed filter.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFilterFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFilterFromCache Method (Type, String, Boolean)

Returnes a Filter of type 'filter' with the value from the specified column from the DsCache.

protected Filter GetFilterFromCache(
Type filter,
string column,
bool throwOnError
);

Parameters

filter
The type of the returned filter.
column
Name of the column the value is taken from.
throwOnError
Whether an exception should be thrown if the value cannot be read.

Return Value

A typed filter.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFilterFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFilterFromCache Method (Type, String, DataRowVersion)

Returnes a Filter of type 'filter' with the value from the specified column from the DsCache.

protected Filter GetFilterFromCache(
Type filter,
string column,
DataRowVersion version
);

Parameters

filter
The type of the returned filter.
column
Name of the column the value is taken from.
version
The version of the row that will be read.

Return Value

A typed filter.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFilterFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFilterFromCache Method (Type, String, DataRowVersion, Boolean)

Returnes a Filter of type 'filter' with the value from the specified column from the DsCache.

protected Filter GetFilterFromCache(
Type filter,
string column,
DataRowVersion version,
bool throwOnError
);

Parameters

filter
The type of the returned filter.
column
Name of the column the value is taken from.
version
The version of the row that will be read.
throwOnError
Whether an exception should be thrown if the value cannot be read.

Return Value

A typed filter.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFilterFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


GetFromCache Method

VDX Framework

EntityObject.GetFromCache Method

Returns the value from the specified column. If there is no row in the cache then null is returned.

Overload List

Returns the value from the specified column. If there is no row in the cache then null is returned.

protected object GetFromCache(DataColumn);

Returns the value from the specified column. If there is no row in the cache then null is returned.

protected object GetFromCache(DataColumn,bool);

Returns the value from the specified column. If there is no row in the cache then null is returned.

protected object GetFromCache(DataColumn,DataRowVersion);

Returns the value from the specified column. If there is no row in the cache then null is returned.

protected object GetFromCache(DataColumn,DataRowVersion,bool);

Returns the value from the specified column. If there is no row in the cache then null is returned.

protected object GetFromCache(string);

Returns the value from the specified column. If there is no row in the cache then null is returned.

protected object GetFromCache(string,bool);

Returns the value from the specified column. If there is no row in the cache then null is returned.

protected object GetFromCache(string,DataRowVersion);

Returns the value from the specified column. If there is no row in the cache then null is returned.

protected object GetFromCache(string,DataRowVersion,bool);

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFromCache Method (DataColumn)

Returns the value from the specified column. If there is no row in the cache then null is returned.

protected object GetFromCache(
DataColumn column
);

Parameters

column
Column

Return Value

A value from the cache.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFromCache Method (DataColumn, Boolean)

Returns the value from the specified column. If there is no row in the cache then null is returned.

protected object GetFromCache(
DataColumn column,
bool throwOnError
);

Parameters

column
Column
throwOnError

Return Value

A value from the cache.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFromCache Method (DataColumn, DataRowVersion)

Returns the value from the specified column. If there is no row in the cache then null is returned.

protected object GetFromCache(
DataColumn column,
DataRowVersion version
);

Parameters

column
Column
version
The version of the row that will be read.

Return Value

A value from the cache.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFromCache Method (DataColumn, DataRowVersion, Boolean)

Returns the value from the specified column. If there is no row in the cache then null is returned.

protected object GetFromCache(
DataColumn column,
DataRowVersion version,
bool throwOnError
);

Parameters

column
Column
version
The version of the row that will be read.
throwOnError

Return Value

A value from the cache.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFromCache Method (String)

Returns the value from the specified column. If there is no row in the cache then null is returned.

protected object GetFromCache(
string column
);

Parameters

column
Name of the column

Return Value

A value from the cache.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFromCache Method (String, Boolean)

Returns the value from the specified column. If there is no row in the cache then null is returned.

protected object GetFromCache(
string column,
bool throwOnError
);

Parameters

column
Name of the column
throwOnError
Whether an exception should be thrown if the value cannot be read

Return Value

A value from the cache.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFromCache Method (String, DataRowVersion)

Returns the value from the specified column. If there is no row in the cache then null is returned.

protected object GetFromCache(
string column,
DataRowVersion version
);

Parameters

column
Column
version
The version of the row that will be read.

Return Value

A value from the cache.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFromCache Method (String, DataRowVersion, Boolean)

Returns the value from the specified column. If there is no row in the cache then null is returned.

protected object GetFromCache(
string column,
DataRowVersion version,
bool throwOnError
);

Parameters

column
Column
version
The version of the row that will be read.
throwOnError

Return Value

A value from the cache.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


GetFromCacheDefault Method

VDX Framework

EntityObject.GetFromCacheDefault Method

Returns a value from the DsCache. If there is no value the specified default value is returned.

Overload List

Returns a value from the DsCache. If there is no value the specified default value is returned.

protected object GetFromCacheDefault(DataColumn,DataRowVersion,object);

Returns a value from the DsCache. If there is no value the specified default value is returned.

protected object GetFromCacheDefault(DataColumn,DataRowVersion,object,bool);

Returns a value from the DsCache. If there is no value the specified default value is returned.

protected object GetFromCacheDefault(DataColumn,object);

Returns a value from the DsCache. If there is no value the specified default value is returned.

protected object GetFromCacheDefault(DataColumn,object,bool);

Returns a value from the DsCache. If there is no value the specified default value is returned.

protected object GetFromCacheDefault(string,DataRowVersion,object);

Returns a value from the DsCache. If there is no value the specified default value is returned.

protected object GetFromCacheDefault(string,DataRowVersion,object,bool);

Returns a value from the DsCache. If there is no value the specified default value is returned.

protected object GetFromCacheDefault(string,object);

Returns a value from the DsCache. If there is no value the specified default value is returned.

protected object GetFromCacheDefault(string,object,bool);

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFromCacheDefault Method (DataColumn, DataRowVersion, Object)

Returns a value from the DsCache. If there is no value the specified default value is returned.

protected object GetFromCacheDefault(
DataColumn column,
DataRowVersion version,
object def
);

Parameters

column
The column.
version
The version to request.
def
Default value.

Return Value

The value from the cache or the default.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFromCacheDefault Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFromCacheDefault Method (DataColumn, DataRowVersion, Object, Boolean)

Returns a value from the DsCache. If there is no value the specified default value is returned.

protected object GetFromCacheDefault(
DataColumn column,
DataRowVersion version,
object def,
bool throwOnError
);

Parameters

column
The column.
version
def
Default value.
throwOnError
Whether to throw an exception if there is no row in the cache.

Return Value

The value from the cache or the default.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFromCacheDefault Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFromCacheDefault Method (DataColumn, Object)

Returns a value from the DsCache. If there is no value the specified default value is returned.

protected object GetFromCacheDefault(
DataColumn column,
object def
);

Parameters

column
The column.
def
Default value.

Return Value

The value from the cache or the default.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFromCacheDefault Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFromCacheDefault Method (DataColumn, Object, Boolean)

Returns a value from the DsCache. If there is no value the specified default value is returned.

protected object GetFromCacheDefault(
DataColumn column,
object def,
bool throwOnError
);

Parameters

column
The column.
def
Default value.
throwOnError
Whether to throw an exception if there is no row in the cache.

Return Value

The value from the cache or the default.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFromCacheDefault Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFromCacheDefault Method (String, DataRowVersion, Object)

Returns a value from the DsCache. If there is no value the specified default value is returned.

protected object GetFromCacheDefault(
string column,
DataRowVersion version,
object def
);

Parameters

column
The column.
version
The version to request.
def
Default value.

Return Value

The value from the cache or the default.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFromCacheDefault Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFromCacheDefault Method (String, DataRowVersion, Object, Boolean)

Returns a value from the DsCache. If there is no value the specified default value is returned.

protected object GetFromCacheDefault(
string column,
DataRowVersion version,
object def,
bool throwOnError
);

Parameters

column
The column.
version
The version to request.
def
Default value.
throwOnError
Whether to throw an exception if there is no row in the cache.

Return Value

The value from the cache or the default.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFromCacheDefault Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFromCacheDefault Method (String, Object)

Returns a value from the DsCache. If there is no value the specified default value is returned.

protected object GetFromCacheDefault(
string column,
object def
);

Parameters

column
The column.
def
Default value.

Return Value

The value from the cache or the default.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFromCacheDefault Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetFromCacheDefault Method (String, Object, Boolean)

Returns a value from the DsCache. If there is no value the specified default value is returned.

protected object GetFromCacheDefault(
string column,
object def,
bool throwOnError
);

Parameters

column
The column.
def
Default value.
throwOnError
Whether to throw an exception if there is no row in the cache.

Return Value

The value from the cache or the default.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetFromCacheDefault Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetParametersFromCache Method

Creates for each item in the Cache a Parameter.

protected override ParameterCollection GetParametersFromCache();

Return Value

The collection of parameters created from the DsCache.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


GetRowFromCache Method

VDX Framework

EntityObject.GetRowFromCache Method

Returns the row from the DsCache. Null if there is none.

Overload List

Returns the row from the DsCache. Null if there is none.

protected DataRow GetRowFromCache();

Returns the row from the DsCache. Null if there is none.

protected DataRow GetRowFromCache(bool);

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetRowFromCache Method ()

Returns the row from the DsCache. Null if there is none.

protected DataRow GetRowFromCache();

Return Value

The row from the cache.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetRowFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetRowFromCache Method (Boolean)

Returns the row from the DsCache. Null if there is none.

protected DataRow GetRowFromCache(
bool throwOnError
);

Parameters

throwOnError
Whether to throw an vdxEntityException if there is no row in the cache.

Return Value

The row from the Cache.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.GetRowFromCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.GetRowStateDrivenStatus Method

Returns the EntityStatus depending of the DataRowState of the DataRow in the DsCache.

protected override EntityStatus GetRowStateDrivenStatus();

Return Value

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


HasCacheChanged Method

VDX Framework

EntityObject.HasCacheChanged Method

Returns a value indicating whether the DsCache has changed. The cache has changed if the row in the cache has a Original version.

Overload List

Returns a value indicating whether the DsCache has changed. The cache has changed if the row in the cache has a Original version.

protected bool HasCacheChanged();

Returns a value indicating whether the specified column from the DsCache has changed. The value has changed if the row in the cache has a Original version and the value is different (original vs. current).

protected bool HasCacheChanged(string);

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.HasCacheChanged Method ()

Returns a value indicating whether the DsCache has changed. The cache has changed if the row in the cache has a Original version.

protected bool HasCacheChanged();

Return Value

Whether the cache has changed.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.HasCacheChanged Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.HasCacheChanged Method (String)

Returns a value indicating whether the specified column from the DsCache has changed. The value has changed if the row in the cache has a Original version and the value is different (original vs. current).

protected bool HasCacheChanged(
string column
);

Return Value

Whether the cache has changed.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.HasCacheChanged Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Insert Method

VDX Framework

EntityObject.Insert Method

Inserts the entity into the DB by calling the insert operation of the DataAccess object(s).

Overload List

Inserts the entity into the DB by calling the insert operation of the DataAccess object(s).

public void Insert();

Inserts the entity into the DB by calling the insert operation of the DataAccess object(s).

public virtual void Insert(Transaction);

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.Insert Method ()

Inserts the entity into the DB by calling the insert operation of the DataAccess object(s).

public void Insert();

Remarks

The entity is validated (Validate) and if the operation is not cancelled then the entity is inserted.

Afterwards alternative data is read (if AlternativeData ist set).

Finally the Status is set to Unchanged.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.Insert Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.Insert Method (Transaction)

Inserts the entity into the DB by calling the insert operation of the DataAccess object(s).

public virtual void Insert(
Transaction transaction
);

Parameters

transaction
The transaction this operation takes part of.

Remarks

The entity is validated (Validate) and if the operation is not cancelled then the entity is inserted.

Afterwards alternative data is read (if AlternativeData ist set).

Finally the Status is set to Unchanged.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.Insert Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.IsEntityStatusNew Method

Checks whether the data in the DsCache represent New data.

protected virtual bool IsEntityStatusNew();

Return Value

A value indicating whether the data in the DsCache is new.

Remarks

An entity object is new if all primary key fields have their associated default value set. If there exists no primary key column then the entity object is always new.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


IsInCache Method

VDX Framework

EntityObject.IsInCache Method

Returns true whether there is a value different from Value at the specifeid column in the DsCache.

Overload List

Returns true whether there is a value different from Value at the specifeid column in the DsCache.

protected bool IsInCache(DataColumn);

Returns true whether there is a value different from Value at the specifeid column in the DsCache.

protected bool IsInCache(DataColumn,DataRowVersion);

Returns true whether there is a value different from Value at the specifeid column in the DsCache.

protected bool IsInCache(string);

Returns true whether there is a value different from Value at the specifeid column in the DsCache.

protected bool IsInCache(string,DataRowVersion);

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.IsInCache Method (DataColumn)

Returns true whether there is a value different from Value at the specifeid column in the DsCache.

protected bool IsInCache(
DataColumn column
);

Parameters

column
The column.

Return Value

Whether there is a value.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.IsInCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.IsInCache Method (DataColumn, DataRowVersion)

Returns true whether there is a value different from Value at the specifeid column in the DsCache.

protected bool IsInCache(
DataColumn column,
DataRowVersion version
);

Parameters

column
The column.
version
The version to be checked.

Return Value

Whether there is a value.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.IsInCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.IsInCache Method (String)

Returns true whether there is a value different from Value at the specifeid column in the DsCache.

protected bool IsInCache(
string column
);

Parameters

column
Name of the column

Return Value

Whether there is a value.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.IsInCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.IsInCache Method (String, DataRowVersion)

Returns true whether there is a value different from Value at the specifeid column in the DsCache.

protected bool IsInCache(
string column,
DataRowVersion version
);

Parameters

column
Name of the column
version
The version to be checked.

Return Value

Whether there is a value.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.IsInCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Read Method

VDX Framework

EntityObject.Read Method

Reads data from the DB and fills the DsCache.

Overload List

Reads data from the DB and fills the DsCache.

public bool Read();

Reads data from the DB and fills the DsCache.

public virtual bool Read(Transaction);

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.Read Method ()

Reads data from the DB and fills the DsCache.

public bool Read();

Remarks

If ValidateAfterRead is set to true then the entity object is validated (Validate). Note that this operation can not be cancelled.

If the operation was successfull, i.e. there is now exactly one row in the DsCache, the Status is set to Unchanged and the ReadStatus is set to Successful. If the operation failed then the Status is set to Unspecified and the ReadStatus to Empty.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.Read Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.Read Method (Transaction)

Reads data from the DB and fills the DsCache.

public virtual bool Read(
Transaction transaction
);

Parameters

transaction
The transaction this operation takes part of.

Remarks

If ValidateAfterRead is set to true then the entity object is validated (Validate). Note that this operation can not be cancelled.

If the operation was successfull, i.e. there is now exactly one row in the DsCache, the Status is set to Unchanged and the ReadStatus is set to Successful. If the operation failed then the Status is set to Unspecified and the ReadStatus to Empty.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.Read Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.RefreshHistoryDataAccessObject Method

Refreshes the DataAccess used for the history.

protected virtual void RefreshHistoryDataAccessObject(
DataAccess accessObject,
Operation op
);

Parameters

accessObject
History data access.
op
Current operation.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


SetToCache Method

VDX Framework

EntityObject.SetToCache Method

Writes a value into the DsCache and updates the Status.

Overload List

Writes a value into the DsCache and updates the Status.

protected void SetToCache(DataColumn,object);

Writes a value into the DsCache and updates the Status.

protected void SetToCache(DataColumn,object,bool);

Writes a value into the DsCache and updates the Status.

protected void SetToCache(string,object);

Writes a value into the DsCache and updates the Status.

protected void SetToCache(string,object,bool);

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.SetToCache Method (DataColumn, Object)

Writes a value into the DsCache and updates the Status.

protected void SetToCache(
DataColumn column,
object value
);

Parameters

column
The column to write the value to.
value
The value to be written.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.SetToCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.SetToCache Method (DataColumn, Object, Boolean)

Writes a value into the DsCache and updates the Status.

protected void SetToCache(
DataColumn column,
object value,
bool throwOnError
);

Parameters

column
The column to write the value to.
value
The value to be written.
throwOnError
Whether to throw an exception if there does not exist a row in the DsCache.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.SetToCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.SetToCache Method (String, Object)

Writes a value into the DsCache and updates the Status.

protected void SetToCache(
string column,
object value
);

Parameters

column
The column to write the value to.
value
The value to be written.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.SetToCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.SetToCache Method (String, Object, Boolean)

Writes a value into the DsCache and updates the Status.

protected void SetToCache(
string column,
object value,
bool throwOnError
);

Parameters

column
The column to write the value to.
value
The value to be written.
throwOnError
Whether to throw an exception if there does not exist a row in the DsCache.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.SetToCache Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Update Method

VDX Framework

EntityObject.Update Method

Updates and historicises the entity in the DB by calling the update operation of the DataAccess object(s).

Overload List

Updates and historicises the entity in the DB by calling the update operation of the DataAccess object(s).

public void Update();

Updates and historicises the entity in the DB by calling the update operation of the DataAccess object(s) and the insert operation of the HistoryAccessObject.

public virtual void Update(Transaction);

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.Update Method ()

Updates and historicises the entity in the DB by calling the update operation of the DataAccess object(s).

public void Update();

Remarks

The entity is validated (Validate) and if the operation is not cancelled then the entity is historicised (if there is a HistoryAccessObject defined) and updated.

Afterwards alternative data is read (if AlternativeData ist set).

Finally the Status is set to Unchanged.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.Update Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.Update Method (Transaction)

Updates and historicises the entity in the DB by calling the update operation of the DataAccess object(s) and the insert operation of the HistoryAccessObject.

public virtual void Update(
Transaction transaction
);

Parameters

transaction
The transaction this operation takes part of.

Remarks

The entity is validated (Validate) and if the operation is not cancelled then the entity is historicised (if there is a HistoryAccessObject defined) and updated.

Afterwards alternative data is read (if AlternativeData ist set).

Finally the Status is set to Unchanged.

The history process can be executed in two slightly different ways:

If the HistoryAccessObject can only execute a Insert operation (CanInsert = true) then after the validation took place (and was not cancelled) the insert operation on the history data access is performed. In this scenario the history data access copies the data record within the single insert query.

If the HistoryAccessObject is able to read too then the read operation on the history data access in performed after the validation succeeded. Then, for all columns of the returned table (note that the table has to contains exactly one row) a Parameter is created with the name of the column and with a FilterEQUAL containing the read value. These parameters are then passed back to the history data access, the refresh method is called and finally the insert is performed.

When the historisation is finished then the normal update of the entity object is executed.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace | EntityObject.Update Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityObject.Validate Method

Validates the EntityObject.

public override void Validate(
Transaction transaction,
Operation op,
ref bool cancel
);

Remarks

This method is called before each insert and updateoperation. This method is only called after a read operation if ValidateAfterRead is set to true. Before a delete operation this method is never called.

There exist two szenarios to use the Validate methode: First, you can throw (and catch outside) a vdxValidateException if your entity is not valid. This is the best choice if there is no transaction present. Second, you can record an exception on the Transaction by calling RecordException. This gives you the opportunity to preceed with further validations, i.e. the program flow does not have to stop on the first error. If you have recorded exceptions then set 'cancel' to true to cancel the current operation. This prevents changes to be written to the DB. Afterwards let your program continue normally (validate further entities etc.). From the outside you can check if there were excpetion recorded by checking HasRecordedExceptions or by calling Commit. If there are recorded exceptions and you call Commit an exception will by thrown (Exception) then you can catch to rollback the transaction (Rollback).

Please see RecordException. This method implements the above described procedure.

See Also

EntityObject Class | Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityStatus Enumeration

Defines the state of an entity.

public enum EntityStatus

Members

Member Name | Description
New | The entity consists of new data that is not yet stored in the storage.
Modified | The entity consists of modified data. The data in the storage is propably different from the data in the entity.
Unchanged | The entity consists of data that does not differ from the data in the storage.
ToBeDeleted | The entity consists of data that is marked to be deleted but is not yet deleted.
Deleted | The entity consists of data that is deleted.
Unspecified | The state of the entity is not known.

Requirements

Namespace: Deag.Vdx.Server.Entity

Assembly: vdxServer (in vdxServer.dll)

See Also

Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


EntityStatusDriver Enumeration

Defines the way the Status is determined.

public enum EntityStatusDriver

Members

Member Name | Description
DataDriven | The data and the last executed operation defines the state of the entity.
RowStateDriven | The state of the row defines the state of the entity.

Requirements

Namespace: Deag.Vdx.Server.Entity

Assembly: vdxServer (in vdxServer.dll)

See Also

Deag.Vdx.Server.Entity Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ReadStatus Enumeration

Defines the result of a read operation.

public enum ReadStatus

Remarks

The ReadStatus defines the result of the last read operation of a EntityObject.

Members

Member Name | Description
NotRead | Not yet performed a read operation.
Successful | The Entity Cache was filled after the last read operation.
Empty | The last read operation returned nothing (Cache is empty)

Requirements

Namespace: Deag.Vdx.Server.Entity

Assembly: vdxServer (in vdxServer.dll)

See Also

Deag.Vdx.Server.Entity Namespace | Read

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


Deag.Vdx.Server.SoapExtensions

VDX Framework

Deag.Vdx.Server.SoapExtensions Namespace

Classes

Class | Description
ExceptionExtension | The ExceptionExtension class is used for serializing vdxExceptions over web services.
TraceExtension | Soap Extension for logging all Soap messages.

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ExceptionExtension Class

The ExceptionExtension class is used for serializing vdxExceptions over web services.

For a list of all members of this type, see ExceptionExtension Members.

System.Object
SoapExtension
ExceptionExtension

public class ExceptionExtension : SoapExtension

Remarks

If a vdxException is thrown and not cached on the web service then this class serializes the exception that it can be serialized by SOAP to the client.

Requirements

Namespace: Deag.Vdx.Server.SoapExtensions

Assembly: vdxServer (in vdxServer.dll)

See Also

ExceptionExtension Members | Deag.Vdx.Server.SoapExtensions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ExceptionExtension Members

ExceptionExtension overview

Public Instance Constructors

ExceptionExtension Constructor Initializes a new instance of the ExceptionExtension class.

Public Instance Methods

ChainStream | Save the Stream representing the SOAP request or SOAP response into a local memory buffer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInitializer | Overloaded. No initializer is used.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Nothing has to be initialized.
ProcessMessage | If an vdxException is included in the SoapMessage then serialize it.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ConvertText | Converts to text of the message.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExceptionExtension Class | Deag.Vdx.Server.SoapExtensions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ExceptionExtension Constructor

Initializes a new instance of the ExceptionExtension class.

public ExceptionExtension();

See Also

ExceptionExtension Class | Deag.Vdx.Server.SoapExtensions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ExceptionExtension Methods

The methods of the ExceptionExtension class are listed below. For a complete list of ExceptionExtension class members, see the ExceptionExtension Members topic.

Public Instance Methods

ChainStream | Save the Stream representing the SOAP request or SOAP response into a local memory buffer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInitializer | Overloaded. No initializer is used.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Nothing has to be initialized.
ProcessMessage | If an vdxException is included in the SoapMessage then serialize it.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ConvertText | Converts to text of the message.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExceptionExtension Class | Deag.Vdx.Server.SoapExtensions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ExceptionExtension.ChainStream Method

Save the Stream representing the SOAP request or SOAP response into a local memory buffer.

public override Stream ChainStream(
Stream stream
);

Parameters

stream
Stream to be chained.

Return Value

Chained stream.

See Also

ExceptionExtension Class | Deag.Vdx.Server.SoapExtensions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ExceptionExtension.ConvertText Method

Converts to text of the message.

protected virtual string ConvertText(
string text
);

Parameters

text

Return Value

Remarks

Override this method if you want to modify the message body.

See Also

ExceptionExtension Class | Deag.Vdx.Server.SoapExtensions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


GetInitializer Method

VDX Framework

ExceptionExtension.GetInitializer Method

No initializer is used.

Overload List

No initializer is used.

public override object GetInitializer(Type);

No initializer is used.

public override object GetInitializer(LogicalMethodInfo,SoapExtensionAttribute);

See Also

ExceptionExtension Class | Deag.Vdx.Server.SoapExtensions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ExceptionExtension.GetInitializer Method (Type)

No initializer is used.

public override object GetInitializer(
Type WebServiceType
);

Parameters

WebServiceType
Web service type.

Return Value

Null is returned.

See Also

ExceptionExtension Class | Deag.Vdx.Server.SoapExtensions Namespace | ExceptionExtension.GetInitializer Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ExceptionExtension.GetInitializer Method (LogicalMethodInfo, SoapExtensionAttribute)

No initializer is used.

public override object GetInitializer(
LogicalMethodInfo methodInfo,
SoapExtensionAttribute attribute
);

Parameters

methodInfo
Called method.
attribute
Attribute.

Return Value

Null is returned.

See Also

ExceptionExtension Class | Deag.Vdx.Server.SoapExtensions Namespace | ExceptionExtension.GetInitializer Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ExceptionExtension.Initialize Method

Nothing has to be initialized.

public override void Initialize(
object initializer
);

Parameters

initializer

See Also

ExceptionExtension Class | Deag.Vdx.Server.SoapExtensions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


ExceptionExtension.ProcessMessage Method

If an vdxException is included in the SoapMessage then serialize it.

public override void ProcessMessage(
SoapMessage message
);

Parameters

message

See Also

ExceptionExtension Class | Deag.Vdx.Server.SoapExtensions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


TraceExtension Class

Soap Extension for logging all Soap messages.

For a list of all members of this type, see TraceExtension Members.

System.Object
SoapExtension
TraceExtension

public class TraceExtension : SoapExtension

Requirements

Namespace: Deag.Vdx.Server.SoapExtensions

Assembly: vdxServer (in vdxServer.dll)

See Also

TraceExtension Members | Deag.Vdx.Server.SoapExtensions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


TraceExtension Members

TraceExtension overview

Public Instance Constructors

TraceExtension Constructor Initializes a new instance of the TraceExtension class.

Public Instance Methods

ChainStream | Save the Stream representing the SOAP request or SOAP response into a local memory buffer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInitializer | Overloaded. The SOAP extension was configured to run using a configuration file instead of an attribute applied to a specific XML Web service method.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Receive the file name stored by GetInitializer and store it in a member variable for this specific instance.
ProcessMessage | If the SoapMessageStage is such that the SoapRequest or SoapResponse is still in the SOAP format to be sent or received, save it out to a file.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TraceExtension Class | Deag.Vdx.Server.SoapExtensions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


TraceExtension Constructor

Initializes a new instance of the TraceExtension class.

public TraceExtension();

See Also

TraceExtension Class | Deag.Vdx.Server.SoapExtensions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


TraceExtension Methods

The methods of the TraceExtension class are listed below. For a complete list of TraceExtension class members, see the TraceExtension Members topic.

Public Instance Methods

ChainStream | Save the Stream representing the SOAP request or SOAP response into a local memory buffer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInitializer | Overloaded. The SOAP extension was configured to run using a configuration file instead of an attribute applied to a specific XML Web service method.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Receive the file name stored by GetInitializer and store it in a member variable for this specific instance.
ProcessMessage | If the SoapMessageStage is such that the SoapRequest or SoapResponse is still in the SOAP format to be sent or received, save it out to a file.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TraceExtension Class | Deag.Vdx.Server.SoapExtensions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


TraceExtension.ChainStream Method

Save the Stream representing the SOAP request or SOAP response into a local memory buffer.

public override Stream ChainStream(
Stream stream
);

Parameters

stream

Return Value

See Also

TraceExtension Class | Deag.Vdx.Server.SoapExtensions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


GetInitializer Method

VDX Framework

TraceExtension.GetInitializer Method

The SOAP extension was configured to run using a configuration file instead of an attribute applied to a specific XML Web service method.

Overload List

The SOAP extension was configured to run using a configuration file instead of an attribute applied to a specific XML Web service method.

public override object GetInitializer(Type);

When the SOAP extension is accessed for the first time, the XML Web service method it is applied to is accessed to store the file name passed in, using the corresponding SoapExtensionAttribute.

public override object GetInitializer(LogicalMethodInfo,SoapExtensionAttribute);

See Also

TraceExtension Class | Deag.Vdx.Server.SoapExtensions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


TraceExtension.GetInitializer Method (Type)

The SOAP extension was configured to run using a configuration file instead of an attribute applied to a specific XML Web service method.

public override object GetInitializer(
Type WebServiceType
);

Parameters

WebServiceType

Return Value

See Also

TraceExtension Class | Deag.Vdx.Server.SoapExtensions Namespace | TraceExtension.GetInitializer Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


TraceExtension.GetInitializer Method (LogicalMethodInfo, SoapExtensionAttribute)

When the SOAP extension is accessed for the first time, the XML Web service method it is applied to is accessed to store the file name passed in, using the corresponding SoapExtensionAttribute.

public override object GetInitializer(
LogicalMethodInfo methodInfo,
SoapExtensionAttribute attribute
);

Parameters

methodInfo
attribute

Return Value

See Also

TraceExtension Class | Deag.Vdx.Server.SoapExtensions Namespace | TraceExtension.GetInitializer Overload List

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


TraceExtension.Initialize Method

Receive the file name stored by GetInitializer and store it in a member variable for this specific instance.

public override void Initialize(
object initializer
);

Parameters

initializer

See Also

TraceExtension Class | Deag.Vdx.Server.SoapExtensions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.


TraceExtension.ProcessMessage Method

If the SoapMessageStage is such that the SoapRequest or SoapResponse is still in the SOAP format to be sent or received, save it out to a file.

public override void ProcessMessage(
SoapMessage message
);

Parameters

message

See Also

TraceExtension Class | Deag.Vdx.Server.SoapExtensions Namespace

Copyright (c) 2003 Devigus Engineering AG. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation is hereby granted provided that this copyright notice appears in all copies. THE AUTHOR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. THE AUTHOR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY ICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.